IRC channel logs

2024-03-06.log

back to list of logs

<graywolf>Hello, when I am trying to use ,build in REPL, how can I disable offloading?
<weary-traveler>lilyp: could you (or someone else on the "emacs" team) please have a look at this ~1.5 month old patch submission onto master when you have a moment to spare https://issues.guix.gnu.org/68462
<peanuts>"[PATCH] gnu: Add emacs-plan9-theme." https://issues.guix.gnu.org/68462
<PotentialUser-54>I got a gexp encoding issue, and googled a lot but found nothing related.
<PotentialUser-54>Can I get some help from here?
<PotentialUser-54>Here is my config with non-ascii chars:
<PotentialUser-54>```
<PotentialUser-54>(extra-special-file "/usr/bin/certbot-tc-authenticator"
<PotentialUser-54>                                        (program-file "certbot-tc-authenticator"
<PotentialUser-54>                                                                    #~(system (string-append #$(file-append docker-cli "/bin/docker")
<lilyp>weary-traveler: if you'd be so nice as to use git-version and all that jazz, it'd be great
<weary-traveler>lilyp: thanks; yes i should've done that
<weary-traveler>will send a revised patch in a bit
<weary-traveler>lilyp: v2 should be visible in debbugs. mumi is lagging. forgot to add x-debbugs-cc
<ebrasca>How to install libstdc++ ?
<adanska_>Hi Guix!
<ebrasca>Hi human!
<efraim>using clang-properties in rust.scm is driving me crazy. it keeps saying I need to add use-modules for (gnu packages llvm) but it's already there
<efraim>ok, looks like I finally got it :/ I'll test it after the build to see if it took
<ebrasca>How to install libstdc++ ?
<nckx>ebrasca: gcc:lib seems to have it.
<nckx>That's an observation, not necessarily a recommendation.
<futurile>morning all - happy Wednesday ;-)
<nckx>PSA: the ML moderation interface's pretty downy lately; first-time callers might take a bit longer to hit the lists.
<nckx>futurile: Ribbit.
<ebrasca>nckx: guix install: package 'gcc' has been superseded by 'gcc-toolchain'
<ebrasca>guix install: error: package `gcc-toolchain@11.3.0' lacks output `lib'
<nckx>...which doesn't have a :lib output. Rite. Uhm.
<efraim>looking at the gcc and llvm sources and at the debian-ppc mailing lists it looks like we could support the apple G5 with the powerpc port and add 'g5' as a tunable target.
<efraim>I don't think I'll mention that in the manual or add it until someone else notices and installs guix
<nckx>Something doesn't sound right about 'installing libstdc++' in the first place, though. If you already have a C++ toolchain, why is it not found?
<nckx>Probable answer to self: https://issues.guix.gnu.org/63393
<efraim>do we have a package that is built with clang that isn't a compiler? I'd like to test something
<peanuts>"[PATCH 0/2] Fix libstdc++.so and gcc-toolchain" https://issues.guix.gnu.org/63393
<nckx>ebrasca: I'm going AFK, but could you describe the actual problem/error (if any) at hand to which 'install libstdc++' appeared to be the answer? Maybe't's not. One can hope.
<ebrasca>nckx: ImportError: libstdc++.so.6: cannot open shared object file: No such file or directory
<nckx>Well, a bit more deets than that. What you're building, how, in which environment...
<nckx>ACTION away.
<nckx>ACTION returns with a better bug report that even has some suitably horrible work-arounds, but note the confirmation that g++ should find its libstdc++ just fine in the common case of building you a soft ware: https://issues.guix.gnu.org/63267#3
<peanuts>"gcc-toolchain is missing libstdc++.so" https://issues.guix.gnu.org/63267#3
<nckx>So the bug title's a bit extreme.
<graywolf>Hello, when I am trying to use ,build in REPL, how can I disable offloading?
<ebrasca>nckx: PySide6/__init__.py: Unable to import Shiboken from /home/ebrasca/.private/Games/RimSort, /home/ebrasca/.private/Games/RimSort
<ebrasca>Traceback (most recent call last):
<ebrasca>File "/home/ebrasca/.private/Games/RimSort/RimSort.py", line 18, in <module>
<ebrasca>File "/home/ebrasca/.private/Games/RimSort/PySide6/__init__.py", line 124, in <module PySide6>
<ebrasca>File "/home/ebrasca/.private/Games/RimSort/PySide6/__init__.py", line 64, in _setupQtDirectories
<ebrasca>File "/home/ebrasca/.private/Games/RimSort/shiboken6/__init__.py", line 27, in <module shiboken6>
<ebrasca>ImportError: libstdc++.so.6: cannot open shared object file: No such file or directory
<nckx>There we go. Run-time shenanigans, fully afoot. Try the guix shell -e $'(list (@@ (gnu packages gcc) gcc) "lib")' from the above bug, assuming you just want to run an unpackaged Python script.
<ebrasca>nckx: I can't make glx work inside of shell
<nckx>Why not? Which shell invocation?
<nckx>The above?
<ebrasca>nckx: guix shell -CF -e $'(list (@@ (gnu packages gcc) gcc) "lib")' nss mesa-utils libdrm --expose=/tmp/.X11-unix --preserve="^DISPLAY$" --expose=/var/run/dbus --preserve="^DBUS_" --expose=$XAUTHORITY --preserve="^XAUTHORITY$" --expose=$XDG_RUNTIME_DIR --preserve="^XDG_RUNTIME_DIR$" --expose=/dev/dri --share=$HOME/Games/RimSort/ -- ./Games/RimSort/RimSort.bin
<nckx>Whoa.
<nckx>Why the container?
<nckx>I have no idea what needs to be shared to enable GLX but I'm not at all surprised it doesn't work out of the box with -C.
<ebrasca>I am new to this , no idea why C.
<futurile>ebrasca: have you loaded Guix as your operating system, or are you using Guix on top of another Linux?
<ebrasca>futurile: I am on GuixSD
<futurile>ebrasca: is Rimsort available as a flatpak or something else like that?
<ebrasca>futurile: That does not fix my problem.
<futurile>ebrasca: then your problem is not the guix shell - it's something to do with your 3D set-up right - since if it doesn't work as a flatpak OR in a shell the problem isn't the method - it's the 3D part, no?
<ebrasca>futurile: Guix is the problem, it works in normal distros
<futurile>ebrasca: shell is particularly hard to work with as 3D/hardware - flatpak should work better - because more users use flatpak pakages - that's why I'm suggesting it
<futurile>ebrasca: correct - Guix is the problem - it's a completely different type of distro - it doesn't work like you're used to
<futurile>ebrasca: so I'm trying to figure out the easiest path you can take to get what you want - as you learn about the unique aspects of Guix
<nckx>Guix isn't made to run binary blobs although it can often be convinced to do so.
<futurile>ebrasca: in this case - if you don't have basic 3D up and running then messing around with a complex shell command won't help you unfortunately!
<ebrasca>I have 3D working
<futurile>do you? so you can run glx ?
<futurile>ebrasca: OK, so what about trying the browser set-up and the game I put into the blog post I linked you to last night
<futurile>ebrasca: if you can get glx-gears and then a browser & game running then you know that your set-up is good.
<ebrasca>glxgears does work
<futurile>ebrasca: then I suggest the trying to get the proprietary game in the blog post running - since if that runs you know you have all the underlying parts correct
<futurile>ebrasca: then you can see if you can get it going with your RimSort game
<futurile>ebrasca: if it doesn't work I think you're going to have to look at using a VM - and running a standard distro in that - loading the game through flatpak etc
<futurile>ebrasca: otherwise you're going to have a very frustrating time early in your Guix journey :-)
<ebrasca>RimSort is not a game or even propietary.
<futurile>oh then you could compile it?
<ebrasca>No idea how, they don't have a file explaining how to build it.
<futurile>ebrasca: I reckon try a VM, load whatever distro you are used to, and install it there - that unblocks you from messing around with something that's going to be quite hard right now - unless you're having fun of course ;-)
<nckx>Ah, so it's open source. /s If it weren't for the Python component (wrapping a .bin file? cool cool) I'd suggest dropping -CF altogether and using e.g. LD_LIBRARY_PATH instead. But I don't know if [this] Python [code] honours that
<ebrasca>It is not open source , it is GPL-3
<ebrasca>It clearly states Free Software, Free Source
<nutcase>Hi guix, what can I do, to help to get a patch merged into Guix's master? What does the usual process look like? I'm asking because of this: https://issues.guix.gnu.org/6571 The original patch is from September. My current patch suggestion needs some qa review.
<peanuts>"paste long file in terminal" https://issues.guix.gnu.org/6571
<nutcase>(The link was cutted, this is the correct link: https://issues.guix.gnu.org/65711 )
<peanuts>"[PATCH 0/2] Add wl-mirror." https://issues.guix.gnu.org/65711
<AwesomeAdam54321>nutcase: Could you split the wlr-protocols and wl-mirror into separate patches?
<nutcase>AwesomeAdam54321: yes, I can do so. I forgot to add license: prefix anyways. Therefore I have to create new patch(es) anyways. Should I send both patches to the same issue or create new issue(s)?
<AwesomeAdam54321>You should send both patches to the same issue
<nutcase>AwesomeAdam54321: both become revision 3?
<AwesomeAdam54321>yes
<AwesomeAdam54321>I also recommend that the prefix be set in #:make-flags and not be hardcoded in the makefile during a phase
<nutcase>AwesomeAdam54321: thank you for the advice. The two patches are submitted: https://issues.guix.gnu.org/65711
<peanuts>"[PATCH 0/2] Add wl-mirror." https://issues.guix.gnu.org/65711
<hapst3r>futurile: Mind sending me the blog article you were talking about trying to debug ebrasca's problem?
<futurile>hapst3r: this one: https://www.futurile.net/2023/04/29/guix-shell-virtual-environments-containers/ - hope it's useful!
<nutcase>futurile: this is useful. Maybe you can add some more info, e.g. on wayland, which I collected here: https://github.com/nuthub/guix-shell-examples?tab=readme-ov-file#x11--xwayland--wayland
<peanuts>"GitHub - nuthub/guix-shell-examples" https://github.com/nuthub/guix-shell-examples?tab=readme-ov-file#x11--xwayland--wayland
<graywolf>Is there something like .guile, but for guix repl?
<Kabouik>i3status-rust has been updated after years stuck in 0.20ish, that's great. Howerver, configurations are no longer compatible, and mine makes the whole system freeze and need a hard reboot, which is significantly making it harder to troubleshoot (there's no dry-run option to check the config). By any chance, is anyone using it, and could show me their configuration so that I can compare it with mine?
<Kabouik>I'm asking here because odds are high that others Guix users would have had 0.20.x configurations as well a few days ago. I also asked on the repository of i3status-rs, but fewer people have jumped from 0.20.x to 0.32.3 in one update.
<futurile>nutcase: oh yeah that's cool - I don't have any wayland examples
<efraim>I restarted cuirass on berlin, its now building packages again
<efraim>it looks like something got garbage collected before it could be built and hung the build processes
<civodul>ACTION sent doc about the source tree structure: https://issues.guix.gnu.org/69587
<peanuts>"Guix issue tracker" https://issues.guix.gnu.org/69587
<old>how can I delete a `guix pack' tarball after unpacking it?
<old>I get permission error on all files .. even tho I'm the owner
<hapst3r>civodul: hooray :)!
<lispmacs[work]>Can one use guix system image to create a disk image that is encrypted? I am using guix on a luks encrypted system, which I created with the installer, but looking at the the OS definition it seems like the mapped devices section doesn't have enough enough enfo about the cryptroot to actually create one itself
<lispmacs[work]>just wondering if I have to prepare a luks device first and install onto that, or if guix system image can do the whole thing
<civodul>hapst3r: glad you like it :-)
<civodul>old: you have to “chmod -R +w” first
<civodul>kinda annoying
<yarl>Did the meeting started?
<yarl>Hello?
<graywolf>yarl: What meeting you mean?
<yarl>Well the online
<yarl>guix meetup
<graywolf>The patch review thing?
<yarl>yes
<graywolf>I have it in calendar for tomowwor
<graywolf>tomorrow
<yarl>Oh.
<graywolf> https://libreplanet.org/wiki/Group:Guix/PatchReviewSessions2024
<yarl>Thank you :D
<peanuts>"Group:Guix/PatchReviewSessions2024 - LibrePlanet" https://libreplanet.org/wiki/Group:Guix/PatchReviewSessions2024
<yarl>Wrong day
<yarl>hum. Good night!
<jakiki6>plasma-desktop doesn't build
<nckx>Weird(-looking) test failure.
<festerdam>I was told on here that if I want to run guix on a foreign distro that no longer uses nscd, I need to make my own build of glibc with nscd support. How exactly does that work? Do I give the glibc configure script a flag to compile with nscd (only found very few flags that mentioned it), «make» it, run nscd and then run guix?