IRC channel logs

2024-03-02.log

back to list of logs

<theruran>hi I am building Guix v1.4.0 from source on Fedora 38 and I am having an error running the ./bootstrap script:
<theruran>configure.ac:99: error: possibly undefined macro: GUILE_PKG
<theruran>there are other macros too that are undefined. and ./configure also fails expecting GUILE_PKG macro
<ekaitz>hi! can i enter a build container as it is running?
<ekaitz>theruran: do you miss any dependency?
<theruran>ekaitz: well I dnf installed guile30, autoconf, automake and gettext and gettext-devel
<theruran>I am probably missing a step, but automake && make fails on ./configure
<ekaitz>you need many guile deps probably
<ekaitz>are you building or installing?
<ekaitz>the way I do it is `guix shell -D guix`
<theruran>ohh I was missing guile30-devel package
<ekaitz>but you need guix for that
<ekaitz>oh that can be too
<theruran>building, since guix is not available on the standard Fedora repos, it seems
<ekaitz>there's some install script out there if you want
<ekaitz>i don't know if it will work in fedora though
<theruran>uh there is guile-gnutls but no guile30-gnutls package and ./configure fails on missing bindings to GnuTLS
<ekaitz> https://git.savannah.gnu.org/cgit/guix.git/plain/etc/guix-install.sh theruran
<ekaitz>these are the requirements if you want to build yourself: https://guix.gnu.org/manual/en/html_node/Requirements.html
<peanuts>"Requirements (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Requirements.html
<ekaitz>ACTION has to go now, good luck theruran
<theruran>ekaitz: thanks! I will try it.
<theruran>it seems to have installed but I get this error when trying to (sudo) `guix install glibc-locales`, for example: guix install: error: remounting /gnu/store writable: Permission denied
<adanska>its happening again.. `guix weather mutter` shows no substitutes, and it fails on that same test
<adanska>and yet it builds on my machine!
<adanska>i smell a flaky test
<lilyp>A segfault in librsvg? B-but Rust is memory safe!
<PotentialUser-70>Hello! Does anyone know where to keep the icons in guix for mate?
<hapst3r>Good morning Guix o/ I am trying to look for a specific service within `%base-services`. How do I do that in a smart fashion?
<hapst3r>On Guix System, is it necessary to run `guix package -i guix` as root periodically to ensure that guix itself stays up to date?
<Altadil>guix pull takes care of that
<lilyp>It is actively discouraged to `guix install guix' as *any* user, including root.
<lilyp>On Guix System, you'll also find the root profile not really helpful all that much, to the point that you can live completely without it
<lilyp>(the system profile OTOH is quite important, but that's managed by guix system)
<hapst3r>Altadil: thanks
<hapst3r>lilyp: thanks
<hapst3r>I am trying to look for a specific service within `%base-services`. How do I do that in a smart fashion?
<yelninei>hapst3r: They are defined here https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services/base.scm#n3493.
<peanuts>"base.scm\services\gnu - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services/base.scm#n3493
<hapst3r>yelninei: Thanks! But is there no function to perform a lookup? Something like `(find-service $SERVICE $SOURCE)`?
<jpoiret>hapst3r: you can find out in which module a symbol is defined but that's it
<jpoiret>in a REPL, the meta-command ,a (for ,apropos) will tell you that
<hapst3r>jpoiret: that's a bummer, but thanks a bunch anyway!