IRC channel logs

2024-02-27.log

back to list of logs

<dodoyada>it's there!
<dodoyada>could we suggest where to install things in the package listing? I don't know where I was supposed to find that it should go there (though it did seem weird to me to just put it in packages)
<whomst>quick question: i have a local pacakge definition that i want to pack via `guix pack`, but AFAICT guix pack only accepts manifests and manifests require all packages included to be pulled from a channel. is there a way around this?
<mange>Can you use -L to add your local definitions to the load path?
<civodul>Hello Guix!
<civodul>not sure what happened, but the manual is all Fira Sans now: https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html
<peanuts>"Synopses and Descriptions (GNU Guix Reference Manual)" https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html
<civodul>we should probably use our own CSS entirely to avoid surprises like that
<sham1>Fira sans is a nice font
<efraim> https://qa.guix.gnu.org/branch/rust-team looks like I might be able to merge the rust-team branch today
<peanuts>"Branch rust-team Guix Quality Assurance" https://qa.guix.gnu.org/branch/rust-team
<fnat>I'm looking at https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system/install.scm#n524 where it says `%base-file-systems' is not being used because it contains elogind. That's no longer the case though, so maybe there's a few lines that can be cleaned away there? I.e. one can really just make use of `%base-file-systems'?
<peanuts>"install.scm\system\gnu - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system/install.scm#n524
<fnat>Not sure how to interpret line 520 where it says that the disk image build code will override the file system anyway... does that mean that the entire block (from line 519) is redundant?
<ayatsfer>hello! trying stuff with scheme-file:
<ayatsfer>(use-modules (guix gexp))
<ayatsfer>(scheme-file
<ayatsfer>"test"
<ayatsfer>(with-imported-modules '((guix build utils))
<ayatsfer>#~((use-modules (guix build utils))
<ayatsfer>"working")))
<ayatsfer>this seems to build fine, but when I change "guix build utils" to "ice-9 readline" it crashes, and the error log doesn't tell me much....
<ayatsfer>$ guix build -f ./test.scm
<ayatsfer>...
<ayatsfer>system/foreign-library.scm:183:4: In procedure load-foreign-library:
<ayatsfer>In procedure load-foreign-library: file: "/gnu/store/jr2319fvp1si8mnwqvm7bmfvpjbw7kg9-guile-readline-3.0.9/lib/guile/3.0/extensions/guile-readline", message: "file not found"
<ayatsfer>nevermind, I needed with-extensions instead of with-imported-modules...
<civodul>ayatsfer: you’re diving pretty deep into the internals :-)
<ayatsfer>just wanted to properly configure my ~/.guile with guix home 🙂
<civodul>oh nice
<civodul>i guess we should have a service for that actually
<civodul>it’s kinda ironic that one doesn’t get a proper ~/.guile by default with Guix Home :-)
<ayatsfer>there are instructions, but imperatively in https://guix.gnu.org/manual/devel/en/html_node/Using-Guix-Interactively.html
<peanuts>"Using Guix Interactively (GNU Guix Reference Manual)" https://guix.gnu.org/manual/devel/en/html_node/Using-Guix-Interactively.html
<ayatsfer>(I don't know if readline and colorized are configured by default in guix system, but it's not the case at least for guix+nixos)
<Kabouik>Does anyone know how to understand this build issue on a package imported from pypi? https://0x0.st/HRBJ.txt I'm lost with the errors.
<Kabouik>s/understand/interpret
<civodul>ayatsfer: Guix System installs a default ~/.guile that loads readline + colorized *if* they’re available in the search path
<civodul>*on the search path
<gerogaga>Hello, when I try to reconfigure with any configuration (even the base) one, I get an error saying "guix system: warning: exception caught while executing 'eval' on service 'root': error: service: unbound variable". I tried including (gnu services) in the configuration file but it didn't fix anything. Is this normal or should I be worried?
<Sally0>I am facing issues configuring xfce4-screensaver properly, once the screenlocker is enabled it won't allow login again, as far as I know this is due to no PAM permissions regarding the screenlocker. I added an entry on config.scm for the screen locker service and the login issue is fixed, but the program refuses to start on user login because GTK doesn't like programs starting with setuid/setgid.
<Sally0>The solution seems to add only a PAM entry and let xfce4 start the screenlocker rather than trying to do this through sheperd. How do I add a PAM entry for xfce4-screenlocker? Maybe this has to be patched so that the screen locker service entry does not add a setuid with GTK screenlocker programs?
<dkxr>HEllo!
<dkxr>Guys, does anyone know of a programming language written in assembly?
<dkxr>i want to study assembly language design, and would like to read a program available from guix that is just that
<ieure>dkxr, I'm not aware of a modern language that's implemented in assembly. Maybe an esolang? You'd probably need to look at historical source code, like very early versions of cc, before the language became self-hosting.
<ieure>I'm not sure historical source code would satisfy your needs. Implementing a programming language in assembler is an extremely poor choice, which is why there's pretty much nothing that chooses it.
<ieure>Esolang implementation almost definitely wouldn't be a good place to look to figure out how to do anything reasonably also.
<dkxr>but like why not, why are we fixated with using c?
<ieure>dkxr, "we" aren't. And I never said programming languages were, or should be, implemented in C.
<janneke>dkxr: the earliest c compiler in stage0-posix, cc_x86.M1 is written in assembly...but it's using a pretty unusual flavor of assembly
<janneke>it implements a compiler for a simplified, c-like language
<ieure>As for why it's a terrible idea to implement a programming language in assembler: a compiler is a complex program and assembler has few facilities to manage complex tasks; and it means your language will only work on one hardware platform. Most language implementers choose a higher level language than assembler for their first implementation, then aim for self-hosting, where the compiler is written in the language it implements.
<ieure>Implementing a compiler in assembly is most useful for bootstrapping new systems, and is never the long-term solution to those problems.
<dkxr>okay its like kinda pointless you really want to learn how to write programs for every architecture
<dkxr>unless*
<dkxr>i get it, i think im just kinda interested in programming torture
<dkxr>btw thank you ieure and thank you janneke ill check out the cc_x86.m1
<ieure>dkxr, If you're interested in programming torture, definitely look into IOCCC and esoteric programming languages (esolangs).
<dkxr>okay cool thank you xD\
<Sally0>Nevermind, I just re-read the docs, all I had to do is add the boolean values for pam and setuid, now it works as intended.
<freakingpenguin>dkxr: this isn't guix packaged, but there is a scheme implementation in arm assembly. Armpit Scheme.
<dkxr>freakinpenguin, lmao armpit scheme
<vagrantc>hrm. looks like p7zip is not realyl maintained upstream ... wondering if guix might want to switch to and/or add 7zip as a maintained implementation
<vagrantc>debian seems to be switching over ... i'm not terribly opinionated on the matter :)
<vagrantc>maybe more appropriate to a guix-devel post
<PotentialUser78>is anyone familiar with writing python packages? I have a package that fails in the check phase because pytest ends up not running any tests (exits with status 5). However, when I clone the source code and run "pytest -vv" I see all of the tests run and pass. I'm unsure of how to proceed with my package.
<ekaitz>PotentialUser78: can you `guix build` with -K and then jump to the folder and see if it does have the tests?
<PotentialUser78>Actually, I think maybe it's because guix by default is trying to use hypothesis to generate tests? I've never used hypothesis before so I'm not super sure
<PotentialUser78>ekaitz I'll try thatnow
<ekaitz>once you are in the folder you can `source environment-variables` then `cd source` and then try to run pytest there and see what happens
<PotentialUser78>ekaitz: So it apparently does not have tests. In the upstream source repo the tests are stored in "src/tests/", but that directory is absent in the folder I see when running with -K
<ekaitz>PotentialUser78: link me to the project source please
<PotentialUser78> https://github.com/fabianp/mord
<peanuts>"GitHub - fabianp/mord: Ordinal regression algorithms" https://github.com/fabianp/mord
<PotentialUser78>Sorry, I had the path for tests wrong, it's "mord/tests/"
<ekaitz>yeah
<ekaitz>and can I see your package
<ekaitz>?
<ekaitz>ACTION realizes that sentence is weird
<PotentialUser78>ekaitz: https://paste.debian.net/plainh/8e05c563
<ekaitz>PotentialUser78: look, you are getting the contents from the pypi repository of packages
<PotentialUser78>Is that not typical for python packages?
<ekaitz>yes it is
<ekaitz>but it might have different contents than the repository
<PotentialUser78>Oh you're right
<PotentialUser78>I just downloaded it and see it excludes the tests dir
<PotentialUser78>So I guess I should update my package to pull from github instead
<ekaitz>:)
<PotentialUser78>I'll try that now, thank you for your help
<ekaitz>thank you for your package :)
<PotentialUser78>If all goes well I'll be submitting it this evening :)
<ekaitz>add me in CC if you like when you do that
<PotentialUser78>Will do!
<ekaitz>my email is listed in guix's codebase in several places
<ekaitz>search my name (nickname and name are the same in my case)
<PotentialUser78>ekaitz: So I see that the latest version (0.7) is available from pypi but not commit was tagged with 0.7 in the github repo. The most recent tag on github is 0.6, however the test cases don't build because they rely on a deprecated scikit-learn testing function from ~3 years ago. Is it acceptable to package 0.7 and delete the check phase since no
<PotentialUser78>tests were provided for 0.7?
<ekaitz>I'd say so, yeah
<PotentialUser78>Ok, I'll do that then, thank you
<ekaitz>you can put #:tests? #f
<PotentialUser78>Gotcha
<ekaitz>but add a comment that explains the situation
<ekaitz>(short comment is ok)
<PotentialUser78>Absolutely, I'll do that
<PotentialUser78>Looks like that all worked as expected, just sent in the patch.
<PotentialUser78>Thank you again for your hlep
<PotentialUser78>*help
<ekaitz>PotentialUser78: got the mail
<ekaitz>i'll review it tomorrow if I have the time
<PotentialUser78>No rush, thanks again
<ekaitz>PotentialUser78: thank you for the contribution