IRC channel logs

2024-01-27.log

back to list of logs

<weary-traveler>what to do when changes introduced by guix style make some lines go past 80 col width?
<weary-traveler>is there a way to tell guix-style not to violate that?
<civodul>weary-traveler: unfortunately no, it’s a bug
<civodul>you may want to fix it by hand…
<weary-traveler>civodul: i see, thanks
<spiderbit>hello, anyone there that can help me get the gnome-team changes to eudev into my installation because I need to load a hwdb file?
<lilyp>if it's super duper necessary, you can reconfigure from gnome-team – alternatively, just cherry-pick the commits to your local checkout
<weary-traveler>lilyp: not sure if you saw my last response, but it seems #67260 is the gift that keeps on giving
<peanuts>"[PATCH emacs-team 0/2] Think ahead when compiling" https://issues.guix.gnu.org/67260
<spiderbit>lilyp how do I cherry pick I use guix not git to checkout my stuff :D is there a guix "checkout" command or "cherry-pick"?
<spiderbit>ok I see with branch at least, but not so sure about the cherry picking
<apteryx>do others also get test failures when running the cuirass test suite?
<apteryx>ugh, clicking on links no longer works to open icecat; I get some popup saying 'icecat is already running' or something
<Guest78>Helo : I am currently testing guix on vm :
<Guest78>Yet, one I go for "guix pull"
<Guest78>I end up - always - with :
<Guest78>builder for `/gnu/store/51142a66rk2zsq5xiy99xjx2pz7al9sd-guix-packages-base.drv' failed due to signal 9 (Killed)
<Guest78>build of /gnu/store/51142a66rk2zsq5xiy99xjx2pz7al9sd-guix-packages-base.drv failed
<Guest78>View build log at '/var/log/guix/drvs/51/142a66rk2zsq5xiy99xjx2pz7al9sd-guix-packages-base.drv.gz'.
<Guest78>cannot build derivation `/gnu/store/cbp0r9sg1ys310xan31nizb5a1b52w5k-guix-cli-core.drv': 1 dependencies couldn't be built
<Guest78>cannot build derivation `/gnu/store/fbsrrb341f32nv83ws5yi8f433033ra2-guix-cli.drv': 1 dependencies couldn't be built
<Guest78>cannot build derivation `/gnu/store/wwamyknbckm8ap42v7r8bpxmw1yv3bs9-guix-home.drv': 1 dependencies couldn't be built
<Guest78>cannot build derivation `/gnu/store/f6mqbrcq2cggkhxnhrw6m15bxmwp2sfy-guix-packages-base-modules.drv': 1 dependencies couldn't be built
<Guest78>thanks for your advice :
<janneke>Guest78: anything useful in the build log?
<Guest78>You mean by investigating this : https://guix.gnu.org/manual/en/html_node/Debugging-Build-Failures.html ?
<peanuts>"Debugging Build Failures (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Debugging-Build-Failures.html
<civodul>Guest78: hi! The “Killed” bit suggests it ran out of memory
<sneek>civodul, you have 2 messages!
<sneek>civodul, rlb says: it's actually hanging in the scm_spawn_thread for the signal_delivery_thread. Vaguely wondering if there might be some race when under load.
<sneek>civodul, rlb says: right wrt investigate -- note that this hang only occurs right now with the parallel test change, so it might or might not be a "real" bug.
<janneke>Guest78: no, i mean, have you looked at the build log (you pasted it just above): /var/log/guix/drvs/51/142a66rk2zsq5xiy99xjx2pz7al9sd-guix-packages-base.drv.gz
<janneke>and like civodul says, how much memory did you give the VM, https://guix.gnu.org/manual/en/html_node/Installing-Guix-in-a-VM.html suggests using -m 1024 (M)
<peanuts>"Installing Guix in a VM (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Installing-Guix-in-a-VM.html
<Guest78>yes, it is heavy load for the processor : 2GB ram as assigned by default
<Guest78>zcat /var/log/guix/drvs/51/142a66rk2zsq5xiy99xjx2pz7al9sd-guix-packages-base.drv.gz
<Guest78>[ 19/ 20] compiling...     90.0% of 10 filesguest@gnu ~
<janneke>hmm, 2GB should be plenty of memory, i think
<Guest78>peanuts can't  I use https://ftpmirror.gnu.org/gnu/guix/guix-system-vm-image-1.4.0.x86_64-linux.qcow2 directly ?
<peanuts>Guest78: Hi, for comments please contact my maintainers at https://codeberg.org/lechner/irc-helper-bot
<Guest78>assigned 8GBnow, and trying again :
<dariqq>is it possible that a service-type adds another service-type? Im trying to write a service for something that requires postgres running (and all of the setup ,etc the service type does) and it would be nice to add just add my-service-type that then figures out potentially other dependant services
<Guest78>succeeded !
<janneke>Guest78: nice
<janneke>Guest78: yes, you can use that image with qemu, but it doesn't start an ssh server, it seems you'll have to start it in full graphical mode in order to do anything with it
<janneke>it also doesn't have setxkbmap installed _gasp_
<nmeum>is it normal that `./pre-inst-env guix describe` does not pick-up channels defined in /etc/guix/channels.scm? can I somehow get to use those?
<lilyp>pre-inst-env side-steps channels altogether. You could hack up something that uses your local guix checkout + whatever else you have and use that with guix time-machine
<rekado>in a package build I have a problem with the toolchain. I’m using Bazel in the build phase and it does weird things to the environment. It calls GCC but fails to find bits/c++config.h, which is located in GCC’s include/c++/x86_64-unknown-linux-gnu/.
<rekado>How does GCC find these architecture-specific headers?
<rekado>(they are usually not on CPLUS_INCLUDE_PATH, so I’m guessing it’s something to do with -isystem or the like)
<janneke>civodul: it seems to me that the `-m 1024' suggestion is no longer sufficient for a guix pull when using the pre-built VM image that (now also) spawns a GUI
<janneke>`guix pull' was Killed
<janneke>rekado: yeah, or -B ...
<natmeo>defining records is too much boilerplate, is there a reason why I shouldn't wrap them in define-syntax?
<natmeo>i.e (define-record* foo bar) the end?
<sneek>Yey! efraim is back!!
<lilyp>natmeo: we already have a bunch of syntax around records, so your idea might not be that far off, you'll just need to justify your implementation
<lilyp>note that field names are far from the only thing important in a record
<tachymelia>any way to run a guile script from a repl to debug it?
<apteryx>has anyone played lugaru? I don't have any sound
<apteryx>I've asked on the lugaru project: https://gitlab.com/osslugaru/lugaru/-/issues/124
<Guest96>Hi Guix!
<podiki>+
<podiki>(sorry, cat)
<civodul>:-)
<viaken>Is there a trick to using substitute* across multiple lines? Or should I use something else?
<SquircleSpace>Hey Guix experts! I’m trying to understand why “guix git authenticate” requires a keyring branch. Shouldn’t the info in .guix_authorizations be enough?
<ulfvonbelow>that info says which public keys are authorized, but doesn't include the keys themselves IIRC
<SquircleSpace>Ooooh, GPG requires more info than just the fingerprint to recognize a valid signature. That makes sense!
<SquircleSpace>Thank you
<SquircleSpace>Has anyone tried convincing the git team to implement a similar approach to how guix does signing validation?
<civodul>SquircleSpace: i don’t think so, but approaching them would be great
<SquircleSpace>I’m just kinda shocked at the amount of guides I see online for setting up commit signing that then basically delegate responsibility for verification (or at the very least, identity management) to github. The guix approach feels very natural for git, I don’t understand why it isn’t the de-facto standard. Maybe I’m preaching to the choir,
<SquircleSpace>though
<civodul>SquircleSpace: you are :-)
<civodul>but yeah, we need to advocate for it, explain why it matters
<civodul>good advocacy would require an implementation suitable for inclusion in Git
<gnucode>heyo!
<civodul>that’s not something i’m willing to do personally, but if someone were to do that, that would probably greatly help
<civodul>SquircleSpace: ↑
<civodul>hey gnucode!
<gnucode>civodul: how are things?