IRC channel logs

2024-01-22.log

back to list of logs

<ajarara>I must be doing something wrong. I'm trying to write a custom build system (for haunt, the ssg). Here's how far I got: https://paste.debian.net/1304863/
<peanuts>"debian Pastezone" https://paste.debian.net/1304863
<ajarara>basically looking for a build system that allows me to run a command. In this case I create a binary but in haunt's case I come up with a directory that I can then feed into a deploy of nginx
<ajarara>the reason there's such a long tail of included modules is that adding them gives me a newmissing module. But there's so many that I'm sure I'm doing the wrong thing.
<ajarara>actually fastest thing to do is to give up and use gnu-build-system + make
<ajarara>oh lol inlining the builder fixed things. Nevermind!
<noobly>i have three different computers that i want an identical system on, and so planning on syncing my /etc/config between them. it then makes sense to also add all my user-level packages to config.scm, right?
<podiki>there's guix deploy (rather than syncing config, just build and send it to the machine)
<noobly>not sure if there's a seperate file like /home/me/.guix-profiles/something where i should instead keep user-specific stuff, and then sync the system config and the user config seperately
<podiki>downside to user packages in config is that adding/removing them means reconfiguring the system, not a huge deal if you want them to all be the same i guess
<noobly>podiki: that's good to know
<podiki>you can have a manifest that they all use for packages, but yeah then managed separately for install/update
<podiki>you could make a simple service (actually examples probably exist) which periodically upgrades from that manifest
<noobly>podiki: to me it seems cleaner to keep /etc/config.scm tidy and seperate from user-level packages. so /home/me/.guix-profile/manifest is the package I'd want to sync between users to keep the same system on the user level then? I saw that file but wasn't sure
<podiki>that file is auto generated, instead you want your own manifest
<podiki>e.g. https://guix.gnu.org/en/manual/devel/en/html_node/Writing-Manifests.html may be helpful if you haven't read it yet
<peanuts>"Writing Manifests (GNU Guix Reference Manual)" https://guix.gnu.org/en/manual/devel/en/html_node/Writing-Manifests.html
<podiki>or you could have your manifest in version control, or synced (like syncthing), or i'm sure any number of other ways
<noobly>podiki: i had just opened that up in info, thanks. i'll check it out
<noobly>podiki: yeah i just installed syncthing actually and it got me thinking about how i want to do this
<podiki>i think you have some options! :)
<noobly>haha yeah too many if anything!
<podiki>maybe something that watches for file change (the manifest) and then runs guix package -m manifest.scm to update; though you'd also want to guix pull and update sometimes too
<podiki>i'd say for a while you'll be making lots of changes to your manifest, but once you have what you need it'll change rarely (and i love "guix shell" to just use something that i don't need all the time installed)
<podiki>so eventually mostly it'll just be updating when you do a guix pull and want new versions installed
<noobly>podiki: that's a good idea, i was thinking just some daily chron job or something but yeah waiting for edits is probably more efficient
<podiki>i know people are interested in something like "guix deploy" for home services/profiles, but i don't know if anyone has hacked that yet
<podiki>it would be the missing part
<noobly>do you run syncthing automatically at startup? that'd be something shepherd could do for me right
<noobly>i need to read the whole manual still. i know i like the ideas of guix but have a long way to go before i'm using guix shell and deploy
<podiki>syncthing is a service in my system config, yes
<podiki>though might make more sense as a user service (home services) i just haven't tried out guix home yet
<apteryx>lilyp: not sure if you saw this one: bug#59489
<peanuts>"gdm: Accessibility icon missing in log in screen" https://issues.guix.gnu.org/59489
<lilyp>so there's some action, but not yet a patch to apply? okay
<podiki>apteryx: eventually got that service working, feels hacky using "spawn" and parsing the output and then conditionally running a command, but it works
<podiki>and didn't seem like i could make a list of activation services, though maybe just something i was doing wrong, so put the whole thing in the shepherd service part
<podiki>my unholy modification of oci-container-shepherd-service: https://paste.debian.net/1304872/
<peanuts>"debian Pastezone" https://paste.debian.net/1304872
<janneke>yay, got gnumach i686-linux build properly fixed
<efraim>yay!
<alethkit>Greetings! When trying to reconfigure my system, the ACL fails to build, claiming that it cannot find a file, but it appears to be treating the string containing the public key as a file name.
<mange>When you say ACL, what do you mean? The file in /etc/guix/acl?
<alethkit>yes
<alethkit>as in my previous configuration just had the public key in config.scm, but that option seems to have been removed now
<mange>Do you mean the authorized-keys option for the guix daemon? Looking at "(guix) Base Services" in the manual it seems to still be an option?
<alethkit>yes, but it seems to have switched to only accepting file names
<mange>I think it takes gexps. If you want it to be a file with specific content you could use (plain-file "acl" "... content here ...").
<mange>Sorry, that's a bit unclear: the option takes a list of gexp values. So it would be (list (plain-file "acl" "...")), which you might also want to combine with %default-authorized-guix-keys.
<apteryx>lilyp: there's a patch that adds things to the gdm-assets field or something
<apteryx>which is enough to get the accessibility menu working at the login screen
<apteryx>it's not ideal but better than status quo, I tInk
<muradm>hello guix
<muradm>please fix #68651
<peanuts>"[PATCH] gnu: cgit: Fix patch-absolute-file-names phase." https://issues.guix.gnu.org/68651
<doriru>hello. i'm trying to install guix system and i keep running into the same error during building phase. can anyone help me out?
<doriru> https://files.catbox.moe/tdlt2k.jpg
<doriru>here's what it looks like
<muradm>please ping #67657
<peanuts>"[PATCH] services: connman: Add 'connman-general-configuration'." https://issues.guix.gnu.org/67657
<doriru>should i try manual installation or will it be just a waste of time resulting in the same error?
<jpoiret>doriru: are you using the 1.4 image or the latest?
<apteryx>podiki: at least it works! 1. make it working 2. make it right 3. make it fast
<doriru>yep, it's 1.4.0. i downloaded and burned it yesterday
<doriru>should i try latest instead?
<apteryx>muradm: these are good ready for master?
<apteryx>ACTION finished merging most of the [core-update] tagged patches
<jpoiret>doriru: yes, I believe that specific issue was fixed after 1.4
<apteryx>muradm: please write proper changelog commit messages if you want to ease merge
<doriru>just tried to download latest and it seems like the server is down or something https://files.catbox.moe/5nyw7x.png
<muradm>apteryx: #68651 is definetely a fix. without it cgit package is broken with malfunctioning features
<peanuts>"[PATCH] gnu: cgit: Fix patch-absolute-file-names phase." https://issues.guix.gnu.org/68651
<apteryx>muradm: OK!
<doriru>1.4.0 download link seems to work
<muradm>apteryx: connman-general-configuration works for me on master, non invasive, shiny config thingy
<muradm>apteryx: i beleive connman-general-configuration patch is very well documented, both commit and inside.
<muradm>apteryx: for cgit fix, it is very tiny typo-like regression, idk what to write more.
<apteryx>muradm: I agree! my changelog comment was about the other cgit fix
<apteryx>I'll look into it
<attila_lendvai>ACTION wanted to write up his arguments about the unseen deleterious effects of the insistance on the changelog format... but haven't done so yet.
<apteryx>I think you already did
<apteryx>muradm: I've added this: * gnu/packages/version-control.scm (cgit) [arguments]: Fix regexp in patch-absolute-file-names phase.
<muradm>apteryx: for cgit, in short, substitute* pattern didn't escape $ properly, since it never matched the actual source file, missing `outputs` reference never was evaluated.
<muradm>effectively breaking about-formatting.sh script
<muradm>apteryx: thanks!
<apteryx>muradm: I think the convention for an escape hatch is to name it something like 'extra-config'
<apteryx>in services
<apteryx>would it make sense to rename 'general-configuration' field to 'extra-config' ?
<apteryx>oh, wait, it's *not* an escaped hatch, but a well defined strcuctured config
<muradm>apteryx: i don't think so. there could be `extra-config` field within `connman-general-configuration`, but not `general-configuration` it selft.
<apteryx>OK
<apteryx>will proof read the new doc and push if it's fine
<apteryx>looks very nice so far :-)
<muradm>apteryx: no issue. I used man page contents as source, with some additional notes commented on issue.
<muradm>apteryx: i still wonder why https://lists.gnu.org/archive/html/guix-patches/2023-12/msg00854.html here in the end connman called `nonfree`..
<peanuts>"[bug#67657] [PATCH] services: connman: Add 'connman-general-configuratio" https://lists.gnu.org/archive/html/guix-patches/2023-12/msg00854.html
<muradm>facepalm, "Furthermore, I consider that nonfree software must be eradicated." if it is part signature
<civodul>yeah, i was about to say that :-)
<apteryx>haha
<apteryx>I should put this in my signature to ensure I never end up working at microsoft
<rekado>didn’t you hear? Microsoft 💛 Open Source
<janneke>they were even present at RB-2019-Marrakesh
<civodul>yup!
<civodul>they even have a “product” called GUIX
<janneke>and seemed (pretended?) to be pretty interested in our full-source bootstrap
<civodul>right!
<apteryx>janneke: did they?
<janneke>"we don't trust binaries we download from the interwebs if we ever want to offer a populated WSL service"
<janneke>something like that
<apteryx>fun
<janneke>it was our luck that they were quite nasty and ill-behaved, i could easily have imagined a mutual benifitial arrangement wrt reproducible/bootstrappable builds
<rekado>nasty and ill-behaved?
<rekado>ACTION perks up ears
<civodul>sounds a bit strong to me
<rekado>ACTION didn’t attend
<apteryx>microsoft also have their own package manager vcpkg which is written in CMake
<apteryx>ACTION supposes they have their eyes on a potential canonical acquisition
<muradm>that is nobrainer
<civodul>wait wait wait
<civodul>wdym “written in CMake”, apteryx?
<apteryx>CMake is a programming language; see the language stats at: https://github.com/microsoft/vcpkg
<peanuts>"GitHub - microsoft/vcpkg: C++ Library Manager for Windows, Linux, and MacOS" https://github.com/microsoft/vcpkg
<apteryx>71% CMake
<civodul>😱
<apteryx>funny, they even have a shell.nix file
<civodul>they’re everywhere
<apteryx>perhaps we should have a team of people submittitng guix.scm files to high profile projects, as a branding initiative
<apteryx>;-)
<pinoaffe>hey folks, is there a way to `guix deploy' a home configuration?
<civodul>apteryx: heh, let’s hope it “just happens”, that’d be a sign that our stuff is useful :-)
<civodul>pinoaffe: unfortunately no!
<pinoaffe>ah, that's a shame
<pinoaffe>thanks!
<janneke>wouldn't the idea be to have home-configurations be part of operating-system?
<civodul>yup, we should do that
<janneke>(with some luck, deploy would then be automagical)
<civodul>but we could also do ‘guix home deploy’
<rekado>apteryx: are these shell.nix files enough to turn a repository into some sort of channel equivalent?
<janneke>ah, yeah
<rekado>our guix.scm files don’t benefit Guix users but only developers of that project
<rekado>perhaps that would change if we made it possible to install straight from a git repository as long as that repository contains a guix.scm file.
<pinoaffe>I would love it if home-configurations were part of the operating system, and I'm somewhat tempted to write a simple service that just does that
<civodul>rekado: guix install https://…/example.git ?
<civodul>i suppose ‘shell.nix’ is for developers only though
<mekeor>hello. i think i screwed up my guix system (probably store?) when my computer died abruptly (due to battery) during a "guix package -i ..." command. i now get "file.9.2.5.so: cannot open shared object file" error when i try starting xorg. how can i fix this? e.g. how to force reinstallation of all user-installed packages?..
<ieure>mekeor, Guix is transactional, interrupting a package operation *shouldn't* break anything, I think.
<ieure>mekeor, But it's also idempotent, so if you run the same command as was interrupted, and the system's not so broken that it can't do that, it should put things how they should be.
<pinoaffe>interrupting a package operation can break the store, but it should not be able to break the current profile
<mekeor>first, it's not just an interruption like C-c (SIGINT)
<pinoaffe>in this case the store doesn't seem to be broken, so indeed either rerun the install command, or go back to an earlier (known good) generation of your profile
<mekeor>i went back a generation and it did not help
<pinoaffe>then it sounds like something else went wrong
<apteryx>rekado: I don't know; I think it serves the same purpose as ours (setup a dev environment)
<doriru>does the latest system download link work for everyone? dunno whether my ip range is blocked or it's server-side problem
<apteryx>sneek: later tell muradm your connman improvements have landed
<sneek>Got it.
<mekeor>could anyone do me a favor and share "guix locate file.9.2.5.so" with me?
<apteryx>has someone something to say about "[PATCH v5] guix: download: Add support for git repositories." in #68405?
<peanuts>"[PATCH v2] guix: download: Add support for git repositories." https://issues.guix.gnu.org/68405
<apteryx>otherwise it looks ready to me
<civodul>apteryx: LGTM! :-)
<Altadil>doriru: seems down for me to
<civodul>thanks for reviewing, BTW
<muradm>apteryx: thanks for 67657 and 68651, i have to go
<sneek>Welcome back muradm, you have 1 message!
<sneek>muradm, apteryx says: your connman improvements have landed
<apteryx>my pleasure, it's something less on my todo list ;-)
<janneke>mekeor: guix locate: error: file 'file.9.2.5.so' not found in database '/home/janneke/.cache/guix/locate/db.sqlite'
<apteryx>one less thing*
<janneke>that's prolly not helpful...
<mekeor>janneke: thanks nevertheless :)
<efraim>I'd like guix home deploy
<janneke>i'd like rumpnet :)
<efraim>re home-configuration for operating-system: IMO it should be instead of a skeleton for a new user (like preset password), unless its a system account, in which case it can be always
<apteryx>is there a way to configure b4 shazam to add Signed-off-by tags?
<apteryx>or use the equivalent of git am -3 when resolving conflicts?
<civodul>mekeor: ‘guix locate -g 'file*.so'‘ doesn’t return anything useful either (‘filefuncs.so’ in gawk, that’s it)
<apteryx>ah, '-s'
<apteryx>for -3 we can use "b4.shazam-am-flags"
<apteryx>in our config
<mekeor>civodul: thanks :)
<apteryx>janneke: have you ever timed how long the full bootstrap takes about?
<janneke>apteryx: no
<apteryx>ok
<apteryx>seems more than 24 h
<apteryx>do we have a stance on adding gst-plugins-* to inputs?
<apteryx>since they are plugins, my traditional stance was it's better to leave it to the user
<janneke>i've rebuilt world on i686-linux this weekend, and i think it2s about 72h
<efraim>agreed, unless functionality is missing without them
<janneke>(but more cores may help)
<efraim>ACTION thinks jami might be like that
<apteryx>jami uses ffmpeg
<efraim>*functionality*, like "does the music play play music?"
<apteryx>which is a monolith
<efraim>ok, not jami
<janneke>also, gcc-mesboot[0/1] failed a couple of times
<apteryx>functionality as in 'don't crash the process if you are webkit and a video plugin is missing'
<apteryx>:-)
<apteryx>my other stance on that was that it's a bug in the webkit user experience
<apteryx>but it's not a very useful stance for people using GNOME and expecting youtube videos to work in 'Web Browser'
<apteryx>sawwy people may know that webkit relies on gst-plugins* but that's probably a minority of users
<janneke>by the time they know such things, they're ready to switch to exwm ;-)
<apteryx>ACTION has these questions looking at https://issues.guix.gnu.org/68657]
<peanuts>"[PATCH]: Update Nyxt to 3.11.1" https://issues.guix.gnu.org/68657
<apteryx>rekado: random idea for b4 users; it'd be useful to have an easy way to retrieve (e.g. copy to clipboard) a Message-ID
<apteryx>random idea for MUMI
<apteryx>currently I have to look at the HTML source and it's not pretty: view-source:https://issues.guix.gnu.org/68657#0
<peanuts>"[PATCH]: Update Nyxt to 3.11.1" https://issues.guix.gnu.org/68657#0
<rekado>apteryx: it’s a good idea and I’ve put the message id in the HTML for that reason, but I decided not to contribute to Mumi lest I give the impression that continuing the development of Mumi has been decided somewhere from above.
<rekado>if Mumi is to live it must survive on contributions from the whole group
<apteryx>got it
<podiki>apteryx: yes, always making it work first then pretty :)
<civodul>rekado: a laudable decision
<civodul>i guess the project is at a turning point: it’s gotten big enough that the organization has to change to accomodate that
<pinoaffe>I've got a question about the mpd service: could someone tell me where the actual code is that ensures that mpd is ran as the proper user? I can't seem to find any switching / anything like that
<pinoaffe>oh and is it just me or is it weird that the gexpression that evaluates to the shepherd forkexec constructor for mpd creates various directories?
<snape>pinoaffe: long time I haven't looked into that code, but it looks like the daemon is passed a config file, which is the mpd-shepherd-service parameter
<snape>which is the default value of mpd-service-type
<snape>that is: mpd-configuration, which contains "The user to run mpd as"
<apteryx>rekado: any clue where I could plug a Message-ID copy button in the MUMI UI (code area)
<apteryx>(mumi web view html) ?
<doriru14>for some reason i can't download the latest system build. tried through tor too, so it doesn't seem to be my ip range being blocked. what could be the problem?
<doriru14>error    "Could not find the requested build product."
<apteryx>ACTION is impressed by how clean the mumi code base looks
<rekado>apteryx: in that module there is issue-page, which renders the whole issue page.
<rekado>the inner definition of show-message is probably where you could add a button
<rekado>the mumi code is a little too nested for my tastes, but it greatly benefits from being small (thanks to Arun’s guile-email)
<apteryx>rekado: thanks, I'm looking into that show-message nested proc
<nmeum>how do I best test changes to the Guix repo that require me to run `guix system reconfigure` (e.g. changes to system services)? Do I just run the ./pre-inst-env script as root?
<apteryx>rekado: can I attach a javascript snippet to an HTML element?
<apteryx>looks like I need to execute "navigator.clipboard.writeText($message-id);"
<snape>nmeum: sudo -E ./pre-inst-env
<nmeum>ah, I forgot the -E. thanks!
<pinoaffe>snape: yeah, mpd-service-type extends shepherd-root-service-type with an mpd-shepherd-service, but I cannot find where in this stuff the scheme equivalent of `su pinoaffe` is located
<snape>nmeum: it's so that your user’s GUILE_LOAD_PATH and GUILE_LOAD_COMPILED_PATH are preserved.
<pinoaffe>because the shepherd service initialization just let-binds a variable `user', creates some directories, and then returns a normal forkexec constructor
<snape>pinoaffe, indeed
<rekado>apteryx: better to give the HTML element a class and separately provide a JS file that attaches an event handler to all elements with the given class, operating either on its “data-” attributes or its contents
<snape>does it work though?
<snape>does it actually run as a user?
<apteryx>rekado: I see
<rekado>snape: works for me. mpd here runs as the user I specified in mpd-configuration -> user.
<snape>ok thx
<apteryx>rekado: actually I see there's a Message-ID already supposed to be shown in the "details" element
<apteryx>but it's not; perhaps we just need to redeploy?
<rekado>it’s in the HTML but the element is hidden by default
<rekado>mumi.css has a rule for “.message .details” with “display: none”
<apteryx>should we just change that?
<rekado>I hid it back then because it clutters the UI
<pinoaffe>snape: yes it does, and I cannot seem to figure out why :)
<apteryx>OK
<rekado>apteryx: we could use a details tag
<rekado> https://developer.mozilla.org/en-US/docs/Web/HTML/Element/details
<peanuts>"<details>: The Details disclosure element - HTML: HyperText Markup Language | MDN" https://developer.mozilla.org/en-US/docs/Web/HTML/Element/details
<rekado>with the summary being the “from” line and the details containing … well, the details
<pinoaffe>`ps -aux | grep` mpd shows that mpd is indeed running as the proper user
<rekado>this way the details can be shown on demand
<apteryx>my naive design idea was to put a tiny "Copy Message-ID to clipboard" button next to (to the left) the "Download" button
<apteryx>with a cute icon
<rekado>sounds good to me too
<apteryx>or put it in the top "Details" section
<apteryx>that's enough for my use case (b4 shazam)
<apteryx>the one under the status/QA badge
<apteryx>but it's a table, and I'd want a row, so it'd look awkward
<apteryx>I mean its currently columns-oriented
<apteryx>back to the copy button idea
<snape>pinoaffe: https://github.com/MusicPlayerDaemon/MPD/blob/master/src/unix/Daemon.cxx#L104
<peanuts>"MPD/src/unix/Daemon.cxx at master ? MusicPlayerDaemon/MPD ? GitHub" https://github.com/MusicPlayerDaemon/MPD/blob/master/src/unix/Daemon.cxx#L104
<doriru> https://guix.gnu.org/en/download/latest/ can't download the latest build for some reason. are there any mirrors?
<snape>pinoaffe: mpd reads the config file, specifically the "user" part, and calls "setuid"
<pinoaffe>snape: aight, thanks, that solves the mystery!
<snape>:)
<apteryx>rekado: I see we have mumi.js; is this where I should add my button event listener? or should I create a new file?
<apteryx>(sorry for all the questions :-))
<rekado>apteryx: yes, you can add it there. mumi.js should be included on all pages via the layout procedure.
<jpoiret>doriru: I think we've had issues recently with this image being broken for some reason
<jpoiret>:(
<doriru>jpoiret .so the problem is not on my end. i'll try later then. thank you!
<apteryx>rekado: I think I'm code complete... now to test it
<apteryx>if you have tips to run mumi locally just to see the HTML in the browser, that'd be useful
<apteryx>looks like this (untested): https://paste.debian.net/1304946/
<peanuts>"debian Pastezone" https://paste.debian.net/1304946
<apteryx>ACTION runs ./pre-inst-env mumi web
<rekado>apteryx: I think you’ll need a small number of debbugs emails or else it won’t have anything to process
<rekado>I should add a few to make it easier to test things
<rekado>mumi includes tests/data; you could have it index that
<bienjensu>Hi, I'm getting an error about the directory "/homeless-shelter/" being missing while trying to build a custom emacs package. Not sure entirely why. Here's the scheme http://okturing.com/src/18269/body
<bienjensu>Ah, seems to be a common problem for packages propagating auctex.
<rekado>bienjensu: by default the build environment has no home directory
<rekado>it’s set to /homeless-shelter
<rekado>if you really need HOME you can set it in a build phase
<rekado>(there are some examples in gnu/packages/cran.scm or bioconductor.scm)
<bienjensu>It's building now. Thanks.
<apteryx>rekado: how do I cause mumi index tests/data?
<apteryx>to index*
<apteryx>I haven't indexed anything yet, but accessing the mumi web page, I get this crash: https://paste.debian.net/1304959/ expected?
<peanuts>"debian Pastezone" https://paste.debian.net/1304959
<apteryx>perhaps I should copy tests/data to /var/mumi/data
<apteryx>ah, MUMI_UNINSTALLED eh
<rekado>apteryx: you index with “mumi fetch”
<rekado>MUMI_UNINSTALLED is set by pre-inst-env
<apteryx>worker error: (system-error open-file ~A: ~S (Aucun fichier ou dossier de ce type /var/mumi/data/spool/index.db.realtime) (2))
<apteryx>ah, this was without pre-inst-env; with it, it's: worker error: (system-error open-file ~A: ~S (Aucun fichier ou dossier de ce type /usr/local/var/mumi/data/spool/index.db.realtime) (2))
<apteryx>maybe I should work in a pure env
<rekado>with pre-inst-env it looks for the “data” directory and the current working directory
<rekado>if that doesn’t exist it will use localstatedir
<rekado>so you have to cp -ar tests/data to data
<apteryx>hm, so I should symlink data to -> tests/data
<rekado>and then “./pre-inst-env scripts/mumi fetch” should do its thing and create a db
<apteryx>ln -s tests/data data && ./pre-inst-env mumi fetch did it
<rekado>great!
<apteryx>but now I'm modifying test data, so a copy would be nicer I guess
<apteryx>now it doesn't crash anymore
<Guest56>my wifi doesnt work i am assuming this is because free drivers are not available, can anyone reccomend a solution i am open to buying another wifi adapter thing if i must
<shcv>how do I debug / find the files generated in a system config file? I'm trying to get opensmtpd to work, but may be having issues generating the config. I tried searching my store for files with "smtpd.conf" in the name, but there were only the default files included with opensmtpd, not the one I thought I generated
<rekado>shcv: is opensmtpd running? If so, you can use “pgrep -fa opensmtpd” to see the actual invocation
<shcv>nvm; I found the files I was looking for. And sadly no, opensmtpd is dying without leaving obvious logs
<shcv>my mistake was not using a regex that included "xxxx-smtpd.conf" instead of only "xxxx/smtpd.conf"
<woshilapin>Hey there, I'm a happy new user of Guix, but I'm having problems setting up even basic things at the moment. Looking around, it seems that not having /run/user/1000 correctly set up is a important part of my problems. I understood (maybe I'm wrong?) that I should add `elogind-service-type` to my `%base-services` but it doesn't seems to work. `guix
<woshilapin>system reconfigure operating-system.scm` seems to fail early on the `file-system-/sys/fc/cgroup` with `Device or resource busy`. Relevant information, I'm on WSL.
<apteryx>ugh, I suck at css
<apteryx>i'm trying to have the button share its size with its inner icon, but padding gets added anyway
<trnry>How can I make `guix shell` work with python dependencies? They never get found by python when I try that, but if I put the same package in my home config all of a sudden everything works fine
<trnry>I think it has something to do with my environment btw because running --pure works
<rekado>trnry: when you use “guix shell” do you also include python itself in the environment?
<rekado>the search path for GUIX_PYTHONPATH is attached to the Python package, so it’s only set when the python package is part of the environment.
<trnry>Oh. Well that makes perfect sense then. I am including python when doing --pure becuase I'm forced to have it so of course it works
<trnry>Thanks
<jpoiret>woshilapin: is this while restarting the shepherd services?
<jpoiret>if so you should be able to shut down the wsl2 session and start a new one, it should boot with the proper services starting
<woshilapin>I suppose yes, it's when I'm doing `guix system reconfigure my-config.scm`
<jpoiret>although I don't know much about how wsl2 and shepherd can properly interact, last time I looked at it only systemd was supported
<woshilapin>How can I check which services are started? Because even after the `system reconfigure`, I tried shutting down the system, and rebooting, but can't see `/run/user/1000`after that either
<jpoiret>you can look at `sudo herd status`
<jpoiret>but elogind won't work with your setup i'm afraid
<jpoiret>I don't think starting a shell through the wsl2 command goes through PAM, hence elogind is never made aware of a new session starting, thus it won't create the session run directory
<jpoiret>these are just suppositions though
<woshilapin>With `herd status`, all services seems to be started correctly, except `loopback`
<jpoiret>yeah, I think there's going to be some mismatch with sessions because of how it is setup
<jpoiret>it seems systemd works though, but I don't know if it's upstream's systemd or not
<woshilapin>Oh, just read the part about PAM, and WSL2 not going through it, that might be it. Any workaround that you might know? At some point, I ended up finding https://lists.gnu.org/archive/html/help-guix/2024-01/msg00027.html which seems to set up the /run/user manually, but I'm not sure how much of it is correct
<peanuts>"Re: Some methods of getting a "login shell" do not create /run/user/<uid" https://lists.gnu.org/archive/html/help-guix/2024-01/msg00027.html
<woshilapin>Hey, yes, exactly, ok, I might try that again. I had some problems setting that up... but maybe I can give another try
<jpoiret>woshilapin: maybe you can try `loginctl enable-linger <user>` and reboot the wsl2 vm?
<jpoiret>that'll create a session for your user when the wsl2 vm boots up
<jpoiret>woshilapin: peanuts is a bot that echoes titles for links and other things like issue numbers
<peanuts>jpoiret: Hi, for comments please contact my maintainers at https://codeberg.org/lechner/irc-helper-bot
<jpoiret>peanuts botsnack
<peanuts>jpoiret: Hi, for comments please contact my maintainers at https://codeberg.org/lechner/irc-helper-bot
<jpoiret>huh, now that's unfortunate
<jpoiret>sneek botsnack
<sneek>:)
<woshilapin>`loginctl enable-linger <user>` seems to do the trick, thanks very much. I'll try to look at some doc tomorrow to understand what it is.
<woshilapin>And if it's possible to encode this in my `operating-system`
<woshilapin>Anyway, the help is very much appreciated and in any case, I have some more keywords to dig and some more information to look for.
<woshilapin>Time for a sleep, bye