IRC channel logs

2024-01-09.log

back to list of logs

<xisop>what are the steps to creating separate profiles each with different packages/configurations?
<xisop>for example, i need a work profile that has screen, vim, coreutils, node, python. but i don't want that part of my personal setup
<apteryx>xisop: you write a manifest.scm file
<apteryx>with the packages you want listed in (specifications->manifest (list "python-wrapper" "node" ...))
<apteryx>then if it's at the root of your project you can simply invoke 'guix shell' to have a working environment
<ieure>If I want to make a shepherd service for guix home that only runs conditionally, based on the presence/absence of a file on disk, how would I do that?
<ieure>Context is I packaged jellyfin-mpv-shim, and want to start it when I log into a graphical session, but only if it's been configured already.
<ieure>"Configure" in this case means starting it and putting in user credentials and getting back an auth token that's stored in ~/.config/jellyfin-mpv-shim.
<ieure>I could put a guard around the start function, but then it'll either report that it started when it didn't, or it'll fail to start every time until configured.
<wdkrnls>Dear Guix, I'm trying to render an rmarkdown document as a PDF.
<ieure>I'd prefer, if it's possible, to have the service start/not start depending on the config. But I don't see a way to express that.
<wdkrnls>What package provides mktexfmt?
<apoorv569>On this different system I installed guix on, I am using the same home config, I scp'ed the the config this new machine, but for some reason I get error `ice-9/eval.scm:159:9: In procedure string-append: Wrong type (expecting string): #f`
<apoorv569>but on the machine I already had guix on, this exact home config works..
<podiki>apoorv569: did you pull to a relatively similar version?
<apoorv569>podiki: I fixed the issue, I had some `(getenv` statements for non existing env vars, and `getenv` was probably returning `#f` I commented those out for now and it works.
<podiki>ah
<podiki>that'll do it
<jfred>Hmm, if I try to `guix pull` to a recent revision on my Reform (aarch64) it seems to want to build... libgit2, I think? Which eats up all my memory and OOMs my machine ^^;
<jfred>I guess there's no substitutes available...
<jfred>That's a bit odd though, it looks like there should be: http://ci.guix.gnu.org/search?query=libgit2+spec%3Amaster
<peanuts>"Search results" http://ci.guix.gnu.org/search?query=libgit2+spec%3Amaster
<apoorv569>jfred: You can do `guix weather` to see if substitute is available for a package.
<apoorv569>guix weather PACKAGE
<jfred>hmm, seems bordeaux should have all substitutes needed for libgit2 at least... http://paste.debian.net/1303498/
<peanuts>"debian Pastezone" http://paste.debian.net/1303498
<jfred>there's no argument to install only from substitutes and abort if a substitute isn't available, is there?
<jfred>oh - neat, I didn't realize that channels with substitutes are a thing that's available (and that enabling that is separate from enabling substitutes for packages)
<ulfvonbelow>did we ever find out what the deal with Jam (build tool)'s license is?
<apteryx>sneek: later tell wdkrnls perhaps you could use pandoc
<sneek>Okay.
<ulfvonbelow>jackhill: did you ever get a response from the FSF re: Jam's license? I see the OSI approved it, for whatever that's worth
<jackhill>ulfvonbelow: I don't recall getting a reponse, but it's been a while, so I should probably double check.
<jackhill>FSF did give me a ticket number though, so I could follow up. I'm fairly convinced that it would meet our requirements at this point though.
<jackhill>I never did finish getting argyllcms (which is what needed Jam packages though). I do seem to have a Jam package, so that's something at least https://git.hcoop.net/jackhill/guix/guix.git/commitdiff/5b150604c31a91bf77ea5e49382e6bd01f9d0324
<peanuts>"HCoop Git - jackhill/guix/guix.git/commitdiff" https://git.hcoop.net/jackhill/guix/guix.git/commitdiff/5b150604c31a91bf77ea5e49382e6bd01f9d0324
<ulfvonbelow>I've got an ajam (jam variant pre-patched for use with argyllcms) and argyllcms package locally
<ulfvonbelow>gonna load up an installer image plus argyllcms onto a flash drive so that I can pull an ancient laptop with a serial port out of storage so I can use the ancient spectrophotometer I got
<jackhill>oooh, that's exciting. If you need help cleaning up the packages for submission, let me know.
<jackhill>I actually realized I don't know how to use argyll. I last used it via GNOME's wizard, but that's gone away, and I made a right hash of things invoking it by hand…
<ulfvonbelow>there's online documentation, but every time I try accessing it over tor it seldom loads
<jackhill>using guix instead of the Debian VM would definitly make my learning more fun :) I was trying to calibrate a scanner.
<jackhill>would one of these usb serial adapters work for you?
<ulfvonbelow>probably, but if I can get it over with without having to wait for another part to arrive that'd be great, and if I do that, I won't have an immediate use for it
<jackhill>:)
<jackhill>doesn't look like I ever heard back on an official ruling, but I did get, "It is highly likely we would approve this license as a permissive license compatible with the GPL, but we would still have to go through our process."
<apoorv569>Would it work if use `(getenv "LIGHTDM_WALLPAPER")` for the `(background (local-file (` ? https://0x0.st/HIqX.txt
<apoorv569>so I can change the background image without reconfiguring system?
<jackhill>ulfvonbelow: I've asked the FSF for an update, but in my opinion, I don't think getting jam an argyll added to Guix should block on that.
<apteryx>I think I've finally managed to update jami;
<apteryx>we'll have 20231222.2 soon (a nightly)
<ulfvonbelow>jackhill: patches away, hope they're useful
<jackhill>wooo, thanks!
<ulfvonbelow>is it just me or are a whole bunch of rust crates switching from hyphens to underscores?
<ulfvonbelow>the importer gives stuff like (crate-uri "project-name" ...), but it gets 404s until you change it to (crate-uri "project_name" ...)
<ulfvonbelow>seems like a really dangerous thing to do given all the typosquatting supply chain attacks
<apoorv569>guix shell --pure -m manifest.scm --check, shows me lots of warning about some env variable being clobbered.
<apoorv569>I configure my shell via guix home and all env vars are either set via home-environment-variables-service or the shell's service-type
<apoorv569>what am I missing?
<vixus>so I've been working on upgrading a package which required upgrading some upstream dependencies, including vulkan which has a lot of dependents. if I want to submit a patch should I break it up best I can or submit as a series?
<hapster>Hej guix o/
<hapster>When I have guix as a package manager on a foreign distro, where is guix-related guile code located on the filesystem? I am asking because I want `geiser` to find it without me having to `use-module` in every org-mode source block (I use for learning guix)
<hapster>I mean I found out that it is (also) under `module-import-compiled`, but if I am not mistaken, this changes every time that I do a `guix pull` so it is not desirable to put into an emacs variable
<adanska>Hi Guix!
<adanska>Gonna try and package lem today... Probably won't get far, but wanna give it a shot :)
<ulfvonbelow>guix import crate -r imara-diff ... <spews out 64 package definitions still not in guix>
<ulfvonbelow>and the punchline: (synopsis "Minimal terminfo libary.")
<efraim>ulfvonbelow: If you're working on rust packaging I'd suggest working against the rust-team branch
<ulfvonbelow>that would probably be wise, but I'm on a local checkout that's already got a ton of changes, and I like to keep it rebased against master since it's my daily driver
<efraim>I've found git worktrees to be invaluable for guix. A shared .git folder and I get a separate path for each branch I have checked out. And I don't have to rerun make each time I change branches
<ulfvonbelow>it looks like the package in question has most of its transitive dependencies through some package called rust-git-repository, in #:cargo-development-inputs. Remind me, are the development inputs considered "actual" inputs or are they just a sort of suggestion, like a lot of the python native inputs?
<efraim>they're necessary for building the package
<efraim>ooooh got past the build failure for rust-bootstrap on powerpc64le-linux
<natmeo>ACTION sniffs
<natmeo>I used to have an Alpha 21064
<natmeo>wish I still had it
<civodul>Hello Guix!
<efraim>o/
<civodul>funny icedtea build error: “java.lang.RuntimeException: time is more than 10 years from present: 1388527200000”
<civodul> https://guix.bordeaux.inria.fr/build/432486/log
<peanuts>"Build log of build #432486" https://guix.bordeaux.inria.fr/build/432486/log
<efraim>restart ntpd
<civodul>hmm
<efraim>well, first find out what it thinks the date is so we can laugh about it
<civodul>the build machines all have a correct date
<civodul>looks like a time bomb :-/
<efraim>current date is 1704792878
<efraim>date --date="@1388527200"
<efraim>Wed 01 Jan 2014 00:00:00 IST
<efraim>guix lint says disarchive.guix.gnu.org's certificate is expired
<civodul> https://issues.guix.gnu.org/68333
<peanuts>"Time bomb in icedtea/openjdk" https://issues.guix.gnu.org/68333
<civodul>roptat stumbled upon the same thing
<civodul>i grepped around but couldn’t find where this message comes from
<natmeo>i'm getting 404 on git pull, something broken?
<natmeo>ahh nvm, bad config on my end
<apoorv569>icedtea failing to compile for me as well.
<apoorv569>package that had this dep for me is `javacc`
<graywolf>civodul: freebsd encountered similar issue in 2014: https://lists.freebsd.org/pipermail/freebsd-java/2014-December/011035.html https://lists.freebsd.org/pipermail/freebsd-java/2014-December/011041.html
<peanuts>"Error: time is more than 10 years from present: 1104530400000 when building java/openjdk*" https://lists.freebsd.org/pipermail/freebsd-java/2014-December/011035.html
<peanuts>"Java OpenJDK - build fail - error message dated 10 years in the future?" https://lists.freebsd.org/pipermail/freebsd-java/2014-December/011041.html
<graywolf>Maybe could be useful.
<futurile>Anybody know what the plans are for the paramterized packages GSoC code that were worked on?
<futurile>I see a blog post, patch - but can't see an issue - maybe my search foo is failing
<natmeo>can emacs guix mode operate on a remote machine?
<natmeo>i feel unironically that more and more of my stuff is becoming guixy
<civodul>graywolf: oh fun, it keeps haunting us all
<civodul>futurile: there are no concrete plans AFAIK, unfortunately
<wehlutyk>Hello Guix!
<civodul>the work is both impressive and a bit intimidating IMO
<efraim>yep
<civodul>hi wehlutyk!
<efraim>it might be best to try discussing it in person with pjotr during guixdays
<civodul>like i’d have hoped for something simpler
<civodul>but yeah, would be great to discuss it live in Brussels
<efraim>ok, have semver refresh looking good for crates packages, time to see what else I can reuse that code for
<efraim>also, way too early to celebrate but I've been making good progress with rust on ppc64le
<wehlutyk>I'm trying to get flatpak available in Gnome with Fish being the main shell
<wehlutyk>and XDG_DATA_DIRS is not updated for fish
<wehlutyk> https://github.com/flatpak/flatpak/issues/3109
<peanuts>"XDG_DATA_DIRS is not set on fish shell ? Issue #3109 ? flatpak/flatpak ? GitHub" https://github.com/flatpak/flatpak/issues/3109
<wehlutyk>now, trying to add something like https://github.com/flatpak/flatpak/issues/3109#issuecomment-1074271891 to fish home-config
<peanuts>"XDG_DATA_DIRS is not set on fish shell ? Issue #3109 ? flatpak/flatpak ? GitHub" https://github.com/flatpak/flatpak/issues/3109#issuecomment-1074271891
<wehlutyk>oups, that was the previous step
<wehlutyk>now trying to have fish run the existing flatpak env setup: https://github.com/flatpak/flatpak/blob/1.13.2/profile/flatpak.fish
<peanuts>"flatpak/profile/flatpak.fish at 1.13.2 ? flatpak/flatpak ? GitHub" https://github.com/flatpak/flatpak/blob/1.13.2/profile/flatpak.fish
<wehlutyk>would there be a standard way to add that to home-fish-configuration?
<wehlutyk>for zsh and bash it seems possible to have (home-bash-config (config '((...)))), but I'm not managing to copy that
<graywolf>Could someone recommend a guide/tutorial on using debbugs inside emacs? I've tried to read manual, but it seems to be off (debbugs-search-est does not even exist).
<graywolf>I would like to find all bug reports & patches made by some email address.
<graywolf>ACTION facepalms hard...
<graywolf>There is also debbugs-ug info manual. I should probably read that one.
<graywolf>Somehow I parsed "Debbugs User Interface for Emacs." as "ah, this will be some debugger for user interfaces in emacs..."
<wehlutyk>so this seems to be probably working: http://0x0.st/HIcw.scm
<jakef>i'm using guix home to manage my shell on a guix system and .bash_profile isn't getting sourced. so .profile isn't getting sourced. I'm using GDM and xfce.
<jakef>i went off to make a minimal example of a home config and the bug went away. darnit
<efraim>heh, thats one of those "I guess that's good?"
<jakef>yes a "learning opportunity"!
<jakef>alright i had the wrong idea. my problem was the SSH_AUTH_SOCK variable not being set for gpg-agent. i saw the setting there in setup-environment, yet the value was for the old ssh-agent.
<jakef>turns out that installing the package "openssh" changes the SSH_AUTH_SOCK back to the ssh-agent, even though you've got the gpg-agent configured to manage ssh
<apteryx>that's explained in 'info gpg' I think
<apteryx>I have this in my .bashrc: https://paste.debian.net/1303533/
<peanuts>"debian Pastezone" https://paste.debian.net/1303533
<mirai>does guix have something like 'community bounties' in the same vein of bountysource et al.?
<apteryx>uh, icedtea-2.6.13 is failing
<apteryx>Error: time is more than 10 years from present: 1388527200000
<mrvdb->would someone perhaps be so able to apply the patch in https://issues.guix.gnu.org/68212 (openssh build on powerpc64le fails)
<peanuts>"[PATCH] gnu: openssh: fix build on ppc64le." https://issues.guix.gnu.org/68212
<jakef>apteryx: why not just use export SSH_AUTH_SOCK="$(gpgconf --list-dirs agent-ssh-socket)"?
<jonsger>mrvdb-: what does `guix refresh --list-dependent` say about openssh?
<mrvdb->jonsger: running that now, takes a while apparently
<mrvdb->jonsger: https://dpaste.org/um0ow
<peanuts>"dpaste/um0ow (Bash)" https://dpaste.org/um0ow
<Altadil>Hi, I have just sent an updated version of https://debbugs.gnu.org/cgi/bugreport.cgi?bug=66821
<Altadil>If anyone is willing to take a look at it, I would appreciate any feedback for a packaging newbie.
<Altadil>But I have to be honest, it’s certainly not an important or critical patch series. ^.^
<peanuts>"#66821 - [PATCH] gnu: Add pantheon-stylesheet. - GNU bug report logs" https://debbugs.gnu.org/cgi/bugreport.cgi?bug=66821
<rekado>is anyone working on the icedtea time bomb?
<theesm>rekado: did you solve the nfsd availability issue on your system yesterday?
<rekado>theesm: I built a new kernel with nfsd explicitly enabled, but I haven’t been able to test it yet.
<rekado>(still working on the wip-python-science branch)
<lfam>It looks like CI has stopped evaluations
<lfam>I pushed to 'kernel-updates' an hour or so ago and still it hasn't shown up here: https://ci.guix.gnu.org/jobset/kernel-updates
<peanuts>"kernel-updates" https://ci.guix.gnu.org/jobset/kernel-updates
<lfam>Thanks for repeating my link bot
<lfam>"kernel-updates" https://ci.guix.gnu.org/jobset/kernel-updates
<peanuts>"kernel-updates" https://ci.guix.gnu.org/jobset/kernel-updates
<civodul>:-)
<civodul>howdy lfam!
<lfam>Hi!
<lfam>I saw the email about icedtea. Expiring code is always exciting
<civodul>indeed
<panosalevro>anyone using bluetooth on guix?
<civodul>lfam: kernel-updates on ci.guix was indeed triggered an hour ago for 8920cf302c5a2fd457a2629afe24cf4768f1fed7 (if i read the log correctly)
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=8920cf302c5a2fd457a2629afe24cf4768f1fed7
<civodul>we should really display that on the evaluation page
<lfam>Oh, I didn't realize that it was triggered but not reflected on the web page
<civodul>it’s reflected only if commits changed
<civodul>now, you can also trigger it with: wget --post-data="" -O- https://ci.guix.gnu.org/jobset/kernel-updates/hook/evaluate
<civodul>but again, you’ll get a new evaluation if and only if HEAD on that branch changed
<lfam>Hm, as I understand it, HEAD did change: https://git.savannah.gnu.org/cgit/guix.git/log/?h=kernel-updates
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/log/?h=kernel-updates
<lfam>It changed from commit f8001794f to commit 3439f9a7e4a4
<civodul>lfam: found the problem: there are already 8 evaluations in progress, and that’s the max allowed
<civodul>in particular, core-updates evals, and they take time
<lfam>Ah, a good problem to have
<civodul>i terminated the oldest ones (and inadvertently the latest one, oops)
<civodul>that frees a few slots
<jackhill>panosalevro: I am, but may or may not know the answer to your question :)
<panosalevro>jackhill: just looking for a guix config that makes it work haha
<jackhill>panosalevro: oh, ok. I just have a default bluetooth-service-type in my system services, and it just works! `bluetoothctl` can connect to in and manage the contoller, pairings, etc.
<jackhill>what do you have now
<jackhill>win 52
<mrvdb->jonsger: was my info sufficient? need anything else?
<podiki>howdy guix
<podiki>anyone here familiar with postgres on guix? is the postgresql-role to set up default users/tables (and then use psql to set a password, etc.)?
<apteryx>sneek: later tell jakef that's the example given in: info '(gnupg) Agent Examples'; it seems to be so that you set SSH_AUTH_SOCK only if it wasn't already for the current session (multiple login)
<sneek>Okay.
<apteryx>mirai: I don't know of any, but that'd be cool
<lechner>Hi, where is the variable 'name' defined, please? https://git.savannah.gnu.org/cgit/guix.git/tree/guix/import/cpan.scm#n254
<peanuts>"cpan.scm\import\guix - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/guix/import/cpan.scm#n254
<snape>hi, is it possible for a package to forbid collisions?
<snape>say I know to packages will collide and I want to make sure they will error out before colliding
<graywolf>lechner: I think it is magic from define-record-type*
<graywolf> https://paste.debian.net/plain/1303547
<graywolf>So the answer would be "on line 253" (I think...)
<lechner>graywolf / okay, thanks! wow
<graywolf>I realized it works like this ~yesterday
<lechner>i'm trying to find the bug in guix import cpan SOAP::Lite
<lechner>according to the debugger in Geiser module above is also #f
<lechner>'module' above 'name'
<graywolf>hm, I should really learn to use debugger in Geiser
<graywolf>until now I got by with (pk) but I do feel the limitations...
<lechner>can i use (pk) too?
<apteryx>graywolf: if you figure out how to use the debugger in practical situations with guix, let me know
<apteryx>I can never break where I want to with it
<apteryx>perhaps guix needs to be built in debug mode?
<lechner>apteryx / guile could also help more
<lechner>Hi, the regular online manual, i.e. not the "devel" one, says to run ./configure --localstatedir=/var even though some folks said that can break a Guix installation. The current manual instead says ./configure --localstatedir=/var --sysconfdir=/etc What happens if I run the command in the older manual, please?
<graywolf>Some things will not work (for example guix deploy failed to find the keys)
<graywolf>But it did not destroy anything, in my experience
<graywolf>I never deployed from it though
<graywolf>(to machine I care about)
<lechner>okay, that's somewhat comforting. i still wonder why the old manual is still around. i think it's negligent, misleading and confusing
<lechner>#51000
<peanuts>"The Web manual situation is still needlessly confusing" https://issues.guix.gnu.org/51000
<rekado>lechner: it’s still around because it is the manual for the latest release
<rekado>I think a bigger problem is that we don’t have regular releases any more.
<ieure>It's a rolling distro, why have regular releases?
<graywolf>For install medium where you are reasonably sure it works...
<lechner>rekado / my first Debbugs instances on GNU Guix are live, but still defective debbugs.juix.org for what's currently deployed (more or less) and better.juix.org for Don Armstrong's current upstream
<apteryx>lechner: failing to use --sysconfdir will "only" cause Guix to not find the usual keys under /etc/guix/
<apteryx>so it could break offloading and the likes
<apteryx>were some builds cancelled on the CI for aach64-linux?
<apteryx>e.g: https://ci.guix.gnu.org/build/1872989/details
<peanuts>"Build 1872989" https://ci.guix.gnu.org/build/1872989/details
<apteryx>cancelling should be a really last resort things, as they need to be restarted by hand *or* the derivation changed, which is unlikely for things like qtbase
<jackhill> /win 52
<jackhill>sorry!
<apteryx>that's a lot of windows
<jackhill>I may have a problem :), but their arrangment may be fragmented too
<lechner>apteryx / thanks!
<podiki>apteryx: that was an august evaluation? I know efraim was trying to keep builds going on aarch64 from the mesa-updates branch, but that didn't look like one
<apteryx>podiki: indeed, from August! I hadn't noticed these were old
<podiki>they take a while but hopefully not that long! :)
<apteryx>where is the cuirass database kept on berlin?
<rekado>apteryx: postgres
<podiki>does our certbot service generate a chain.pem as well? (haven't used certbot yet or i would look, hoping to deploy to a new server coming soon)
<lechner>graywolf / thanks for that hint about define-record-type*! the forced shawdowing is terrible
<lechner>i can't even use a local variable!
<graywolf>I was... suprised when I realized it. Not sure I am a fan either.
<mange>podiki: My Guix certbot configuration is generating chain.pem.
<podiki>mange: great, thanks!
<podiki>mange: and did you run into any difficulties on first setup? I saw some bug reports of first time with both nginx and certbot not being able to work (nginx wants the certs, certbot hasn't made them yet)
<podiki>(actually i have certificates from old server, so might use those first anyway)
<mange>Yeah, I did. I think I first configured nginx without the SSL configuration, ran certbot, then reconfigured nginx with the SSL configuration. It's a bit of an awkward dance, but it's only one time per server.
<Kolev>Still having issues with audio. https://lists.gnu.org/archive/html/help-guix/2023-11/msg00052.html
<peanuts>"chromebook-ucm-conf" https://lists.gnu.org/archive/html/help-guix/2023-11/msg00052.html
<graywolf>Is there a way to tell mumi to try more than 15 times? I tried it twice so far and neither time it worked...