IRC channel logs

2024-01-04.log

back to list of logs

<yaslam>Hi everyone, I am getting an error at the last stage of `guix system reconfigure` that says that modinfo.sh doesn't exist and it fails, here is the error: https://ibb.co/RC41jRP full config: https://git.sr.ht/~yusz/dotfiles-v2/blob/master/guix/.config/guix/config.scm and I do not use an i386 system so I don't know why it is looking in that director
<yaslam>y.
<peanuts>"2024-01-03-23-17-45-419 hosted at ImgBB ? ImgBB" https://ibb.co/RC41jRP
<davidh38>did someone have problems to install the python library *evdev* and even after installing linux-libre-kernel headers
<davidh38>?
<davidh38>I would like to stay on my beloved linux libre kernel
<loopback___>how to determine which derivations are source derivations and which are built binary packages via script or scheme api?
<yaslam>Replying to my question above, I booted the system in BIOS mode so grub is not looking at the right directory, my system is UEFI, so that answers the question.
<loopback___>also wow does guix gc -R on a system .drv
<loopback___>spit out a ton of stuff
<loopback___>all of that is needed to bootstrap a base system?
<Kolev>I was wondering if anybody could help me get audio working on a Chromebook, by installing an ALSA config.
<Gooberpatrol66>is it possible to pass a list of manifest files to the packages list in home-configuration?
<weary-traveler>what utilities do guix developers/maintainers use to keep the packages in ./gnu/packages/ update? specifically, often for a git-fetch origin what's needed is to update the version and the origin's sha256. are there scripts that somewhat automate this?
<freakingpenguin>Gooberpatrol66: It is, but you'll need to write code to take those files and turn them into a list of packages
<freakingpenguin>This is how I handle it. https://paste.debian.net/1302991/
<peanuts>"debian Pastezone" https://paste.debian.net/1302991
<Gooberpatrol66>freakingpenguin: sweet, big thanks
<ssouth>weary-traveler: Yes, there are Guix commands that help with this, including "guix refresh", "guix import" and "guix download."
<ssouth>These are all documented in the Guix manual: https://guix.gnu.org/en/manual/devel/en/html_node/Utilities.html
<peanuts>"Utilities (GNU Guix Reference Manual)" https://guix.gnu.org/en/manual/devel/en/html_node/Utilities.html
<weary-traveler>ssouth: thanks; guix refresh does what i was wondering about.
<weary-traveler>i suppose i would benefit from familiarizing myself with the utilities section of the manual
<apteryx>weary-traveler: I use this alias: alias ru='./pre-inst-env guix refresh -u'
<weary-traveler>apteryx: thanks. yeah, i'm trying to make some snippets for myself as well (including refresh, make, build, lint, style etc). i suppose the reason this isn't just part of a cron job that runs on something like cuirass is to increase the likelihood that the versions in guix remain mutually compatible
<oriansj>now that someone is resurrecting dillo: https://dillo-browser.github.io/ will guix be adding it back in?
<peanuts>"Dillo Website" https://dillo-browser.github.io
<Isaz>Hi, does anyone happen to know which package contains the 'pactl' (pulseaudio control) utility?
<apteryx>weary-traveler: we could have bots like nix, we're not there yet
<apteryx>oriansj: why not, if someone is keen to
<jackhill>Isaz: it seems to be in the pulseaudio package
<recj>Does anyone know how I can start a local postgres instance?
<recj>I am using a manifest and guix shell, and I followed the manual steps for adding a postgres service and reconfigured the system
<Isaz>jackhill: thanks, it was there!
<bumble>hello I wish to request attention to this patch https://issues.guix.gnu.org/67289
<peanuts>"[PATCH] gnu: qutebrowser: Update to 3.0.2." https://issues.guix.gnu.org/67289
<bumble>also for the past maybe two months, after logging at wl-greet there is a brief moment with a black screen and white text error message https://paste.debian.net/1303009
<peanuts>"debian Pastezone" https://paste.debian.net/1303009
<bumble>wl-greet and sway seem to work fine anyway but if anyone knows what the solution might be please share :)
<hapster>hej guix o/
<efraim>o/
<hapster>I have a question regarding the "Dissecting Guix" series (here, episode 1 on "Derivations"). The author uses PK liberally to show what is going on. Now, I noticed that, strictly speaking, PK doesn't seem necessary to output the stuff the author wants to output. Thus, I wonder: why is PK used so much in the examples?
<hapster>for example: `(define irssi-drv (pk (with-store %store (run-with-store %store (lower-object irssi)))))` outputs the derivation directly after the definition. However, using `irssi-drv` after it has been defined outputs the same. And in later examples, like `(pk (assoc-ref irssi-outputs "out"))`, the same output would've been available without PK.
<efraim>podiki: guix weather for aarch64 for mesa-updates says 14.8% on berlin, 18.3% on bordeaux
<efraim>wow, got alacritty updated to 0.13.0. Now to turn that all into commits
<futurile>Morning guix people
<efraim>o/
<csantosb>Hi guixers, I have a question related to a code I'm trying to package, and which relies on gnat (yes, that gnat)
<csantosb>Based on this, https://guix.gnu.org/en/blog/2023/the-filesystem-hierarchy-standard-comes-to-guix-containers/, I manage to create a package including the gnat binaries
<csantosb>I may use it witch a shell container using the --emulate-fhs flag. But.
<csantosb>Is there any means to build another package on top of it ?
<csantosb>Problem is guix-daemon doesn't accept the --emulate-fhs flag, of course. Any hint on how to hack this ?
<futurile>csantosb: if you're running your software in a container with --emulate-fhs, you're essentially running it as if it was on any 'standard' Linux distribution. There's no way to create a 'guix package recipe' that will run the software in that way.
<futurile>csantosb: I've created 'manifests' in the past that run 'proprietary' software inside an --emulate-fhs container. Would that sort of method work for you?
<csantosb>Problem is that, when I create another package with depends on gnat, and try to build it, it simply cannot find the gnat/gnatmake binaries.
<futurile>csantosb: OK - that's slightly beyond my knowledge - I know that one option is 'propagated inputs' and another is wrapping the binaries so they are aware of the other library capability. I'd try looking in the manual first, and then looking in the guix packages and seeing if you can find something similar being done - if not ask on the mailing list / here etc
<futurile>csantosb: it's on my list to investigate / understand this part of packaging a bit more heh
<csantosb>The gnat package is here, by the way: https://paste.sr.ht/~csantosb/9a5c2b37a25a03f10e175d15a6ae4ccc87eb98c8
<peanuts>"guix-gnat ? paste.sr.ht" https://paste.sr.ht/~csantosb/9a5c2b37a25a03f10e175d15a6ae4ccc87eb98c8
<deepankar_sharma>have a basic question - if i want to use guix to do the following, how do i do it - i want to get the source of postgres, make changes to a few of the c files in postgres, then use the guix build scripts to compile postgres and then test my changes.
<deepankar_sharma>i know about "guix shell -D" which gets the dependencies, but that shell doesnt appear to get the sources for the package in question and then i have to rely on the upstream build system if i download the source manually.
<futurile>deepankar_sharma: is there an existing postgres package in the Guix archive?
<futurile>deepankar_sharma: or someone's channel - it would be easiest to start with an existing package
<deepankar_sharma>yes postgresql exists as a package
<futurile>csantosb: so I guess you have another package, that 'depends' on this to run - but when you 'guix install' that it can't find the gnat compiler?
<futurile>deepankar_sharma: OK, I would look at the sections of the manual about package variants: https://guix.gnu.org/manual/devel/en/html_node/Defining-Package-Variants.html
<peanuts>"Defining Package Variants (GNU Guix Reference Manual)" https://guix.gnu.org/manual/devel/en/html_node/Defining-Package-Variants.html
<deepankar_sharma>thank you!
<csantosb>futurile: exactly, ghdl depends on gnat: https://paste.sr.ht/~csantosb/4fb4317a88f2a49ee2b8a47966bb902fda2c3b00
<peanuts>"guix-ghdl ? paste.sr.ht" https://paste.sr.ht/~csantosb/4fb4317a88f2a49ee2b8a47966bb902fda2c3b00
<futurile>deepankar_sharma: that's the clean way to do it - inherit the existing package, mess around with the source and so forth. I find messing with the source quite difficult to do - but there's lots of examples in the packaging archive to crib from
<futurile>csantosb: that paste isn't working for me - but anyway assuming the first package (gnat) actually works then I think you you should read up on 'propagated inputs' and that ghd1 would then have gnats as a propagated input. I would start there and/or look at other packages in the archive that have a similar dependency on a compiler/run-time
<csantosb>deepankar_sharma: and consider section "9.1.4 Debugging Build Failures", it helps a lot to debug packages
<futurile>csantosb: it's a bit beyond me at the sec, as I've asked about 'propagated inputs' before and it was unclear to me when you used them, and then when you did this thing about wrapping the program.
<deepankar_sharma>i was curious if the following semantics were possible somehow "drop me in a shell with the source code of the package and all its dependencies already present and some simple command that can canonically build the package". but looks like thats not possible. will study the links both of you posted
<futurile>deepankar_sharma: yeah that's not possible: you might be looking for something like this which is about connecting a development project and a guix shell environment https://www.futurile.net/2023/04/30/guix-reproducible-dev-environments/
<deepankar_sharma>thank you!
<futurile>deepankar_sharma: essentially `guix shell --development <package>` gives you the inputs (package build dependencies), it doesn't give you the canonical source of the package from the guix archive - though you could download that from the store etc
<csantosb>futurile: the problem is that "guix shell -C --emulate-fhs -L /tmp/guix-channels gnat -- gnatmake" works; but "guix shell -C -L /tmp/guix-channels gnat" doesn't. And guix-daemon uses the later.
<csantosb>It's funny to do a 'ls -la /' in both cases.
<futurile>csantosb: so if you create a normal `guix shell` with your gnat package installed, do you see the gnat binaries in the GUIX_ENVIRONMENT/bin - so can you actually use them when you source that in etc?
<csantosb>futurile: when using the --emulate-fhs flag, yes.
<futurile>csantosb: but not without - huh - that is so weird.
<csantosb>typing gnat or gnatmake works as expected: both binaries know where to find their linked libraries
<csantosb>These are compiled binaries: libs location are hard coded, to be found at fhs compliant folders
<avalenn>I'd like too to be able to be dropped in the build container or an equivalent. This could be really useful when debugging packaging.
<csantosb>avalenn: section 9.1.4 Debugging Build Failures, does it help ?
<futurile>csantosb: my understanding is that the way Guix finds libraries is completely different from other Linux distributions. I may not be helping - but I ran into this the other day: https://lists.gnu.org/archive/html/help-guix/2020-10/msg00038.html
<peanuts>"Re: Specifying dependencies among package outputs?" https://lists.gnu.org/archive/html/help-guix/2020-10/msg00038.html
<loopback___>any way to filter source derivations from built binary derivations via script or guile api?
<nikolar>What are the odds of having guix supported on steamdecks
<metsomedog>Hi. I'm trying to make a package, and the configure files, prerequisite scripts, make files etc. are spread in deeply nested directories. Is there some way to get the "top-level directory" or store it as a string from e.g. "pwd" in a guix package definition? This is to avoid having to do something like (chdir "../../../../../some-dir")
<tsmish>metsomedog: There is with-directory-excursion macro (https://guix.gnu.org/en/manual/devel/en/html_node/Build-Utilities.html#index-with_002ddirectory_002dexcursion).
<peanuts>"Build Utilities (GNU Guix Reference Manual)" https://guix.gnu.org/en/manual/devel/en/html_node/Build-Utilities.html#index-with_002ddirectory_002dexcursion
<metsomedog>It's weird, it thinks some directory doesn't exist, but I can see it does. I added a before 'configure phase "(lambda _ (invoke "ls") (invoke "ls scripts"))". The first ls includes scripts in the output, but then ls scripts says "No such file or directory"
<efraim>the second should be (invoke "ls" "scripts")
<csantosb>metsomedog: you mean (getcwd) ? Have a look at the llvm.scm source file in guix repo.
<metsomedog>csantosb: Thanks, yes that was what I was looking for, although the other macro mentioned will also be useful
<metsomedog>Ah the mistake was excepting some script from the master branch of the git repo which was not present at the time of the previous release
<metsomedog>If the configure script must be called from another directory than where it is stored, do I need to replace the entire configure phase in the gnu-build-system?
<metsomedog>For reference I'm trying to build the latest version of the Squeak smalltalk vm by replicating their "mvm" build script https://github.com/OpenSmalltalk/opensmalltalk-vm/blob/Cog/building/linux64x64/squeak.cog.spur/build/mvm -- it copies some files to the mvm directory, calls configure from there, then calls make with "non-default" options...
<peanuts>"opensmalltalk-vm/building/linux64x64/squeak.cog.spur/build/mvm at Cog ? OpenSmalltalk/opensmalltalk-vm ? GitHub" https://github.com/OpenSmalltalk/opensmalltalk-vm/blob/Cog/building/linux64x64/squeak.cog.spur/build/mvm
<metsomedog>instead of ../../../../scripts/copylinuxpluginspecfiles I directly copy the plugins.ext and plugins.int files from the parent directory (the aforementioned script doens't exist in the latest tagged tarball release)
<PotentialUser-4>Hello. I am trying out the cuirass service for the first time. It is running on my machine and web service on port 80  and port 8091 is up. I added a channel and afterwards changed a package definition in the channel. How is cuirass aware of any changes in my channel. Is it triggered automatically? And can I start a build manually?
<PotentialUser-4>The channel is on my self hosted gitlab. Cuirass runs on another server. Channel is publicly available, so no authentisation is needed
<mothacehe>Hello PotentialUser-4, Cuirass is polling periodically for new Git commits in your channels
<mothacehe>it triggers a new evaluation on new detected commit(s)
<PotentialUser-4>mothacehe: So far the worker status and running builds is empty. How long do I need to wait for polling in worst case (to make sure I did not another mistake)
<metsomedog>(need to afk for a while in case anyone replies to my above questions)
<mothacehe>600 seconds unless you set the `interval` field in the service configuration
<Kabouik>When using a screensharing software like Jitsi, I can only share a tab of my web browser running the softwware, or the full browser, but not other windows. Is that a Guix issue or is it related to Wayland/Sway?
<Kabouik>I'm guessing it's a Sway thing in the first place but that fixing it in Guix may have its peculiarities?
<PotentialUser-4>mothacehe: Are there any log files of cuirass in case it is not triggered. And also Thank you for your work on Cuirass
<Franciman>what's the politics for dependencies versions? Whatever makes it compile? OR stick to the precise version?
<Franciman>for example since most of the time rust crates respect the semver convetion, you can use serde 0.1.108 instead of 0.1.109 (invented version numbers)
<mothacehe>PotentialUser-4: can you see you specification on the Cuirass home page?
<mothacehe>*your
<PotentialUser-4>mothacehe: Yes I added it via web interface.
<PotentialUser-4>mothacehe: I replaced the default guix channel with my channel
<mothacehe>ok and http://your-instance/jobset/your-specification is empty right?
<mothacehe>you can have a look to /var/log/cuirass-remote-server.log
<mothacehe>and /var/log/cuirass-remote-worker.log as well
<PotentialUser-4>mothacehe: jobset not elements here. I will look into the logs.
<PotentialUser-4>mothacehe: Could not find appropriate mechanism for credentials
<Kabouik>jpoiret: is this still valid? https://issues.guix.gnu.org/52492 I can't seem to screenshare using that.
<peanuts>"[PATCH 0/7] Improve screen sharing support under Wayland" https://issues.guix.gnu.org/52492
<PotentialUser-4>mothacehe: but guix pull is working with this channel added
<mothacehe>yes but guix pull might have access to your .ssh/config while Cuirass cannot
<mothacehe>or something like that
<mothacehe>Kabouik: screensharing works fine here using Gnome + Wayland + Pipewire
<PotentialUser-4>mothacehe: Sounds reasonable
<Kabouik>Thanks mothacehe. I suppose the issue is partly with Sway then, as jpoiret in the patch mentioned it too. I am running pipewire and wireplumber manually before starting the browser, but it still doesn't work for me. The command jpoiret gave for running Icecat also shows an error whivh might be the (or one of the) issue(s): unable to lock lockfile '/run/user/1000/pipewire-0.lock': Resource temporarily unavailable
<mothacehe>Kabouik: note that you need xdg-desktop-portal and xdg-desktop-portal-gtk installed as well
<Kabouik>Yes, they are installed in my profile
<Kabouik>However I just get this in Icecat https://0x0.st/H6WB.png and it upon allowing it, it doesn't share anything
<Kabouik>(I no longer have the locked socket issue by the way, but screen sharing still fails)
<mothacehe>Kabouik: Icecat + jitsi doesn't seem to work. I am using another browser personally
<mothacehe>I get the screensharing window but nothing is actually shared
<Kabouik>I do get error while loading shared libraries: libguile-3.0.so.1: cannot open shared object file: No such file or directory though.
<Kabouik>Does sharing with Zoom work for you? (Unfortunately) everyone uses that among my colleagues. But I'd personally prefer jitsi-based services, which indeed doesn't work either.
<Kabouik>Which browser are you using and do you need to do something peculiar in addition to running pipewire and wireplumber manually mothacehe?
<Kabouik>In ungoogled-chromium, I can share a tab, but not a screen or window, which will be an issue when my slides are not reveal.js-based
<PotentialUser-4>mothacehe: I had a typo in the channel url. Working via webvnc on a remote machine with different keyboard layout is no fun :)
<mothacehe>Kabouik: no just starting pipewire and wireplumber using guix home
<Kabouik>I just started them directly in terminal, but I don't use guix home so I suppose that's the same
<mothacehe>Just tried zoom on Icecat doesn't work either
<mothacehe>I am using a variant of ungoogled-chromium, cannot say more
<Kabouik>And it does in chromium?
<PotentialUser-4>mothacehe: I also had to re-add the guix channel itself to the web interface. Does this mean, that every time a commit is pushed to guix it will be built on my cuirass instance as well?
<Franciman>i have the following package definition https://bpa.st/L7DA when i try to build it, i get this error: https://bpa.st/SNQQ
<peanuts>"View paste L7DA" https://bpa.st/L7DA
<peanuts>"View paste SNQQ" https://bpa.st/SNQQ
<Franciman>what am i doin g wrong?
<Franciman>rust-dirs is an already packaged crate, why can't it find it?
<rekado>pending builds on ci.guix.gnu.org just dropped below 100,000. This last happened on Dec 20. Hope this trend keeps going.
<Kabouik>Just to be clear mothacehe, you are able to share entire screen from Zoom webapp in ungoogled chromium after running pipewire and wireplumber using guix home, with xdg-desktop-portal and xdg-desktop-portal-wlr installed (not running them manually?) and without any extra settings? Any environment variables maybe? But you are using Gnome, not Sway, correct?
<Kabouik>I'm starting to spend too much time on this instead of making the slides, I'll probably have to use another computer to share my screen unfortunately if I am reasonable
<Franciman>switch to xorg Kabouik ?
<Franciman>i mean just for the screen sharing
<Kabouik>I'ḿ not entirely sure how to do that without a system reconfigure Franciman, my wayland session is started using (wayland? #t) in desktop-services, and I have no option to choose another DE/WM at the GDM logon screen
<Franciman>oh yes i see
<Kabouik>I believe many Guix users are academic people often presenting slides, hopefully someone uses Sway and have found a way to do it in Guix already. I found many resources online showing that screensharing in Sway is not trivial, but should work with environment variables and runtime flags to chromium, but not of that works for me so I'm assuming this is due to some added complexity with Guix.
<Kabouik>s/not/none
<metsomedog>I'm getting "configure: error: cannot run /bin/sh .../config.sub", which I assume is becaues the shebang is not changed. I added "(add-after 'patch-source-shebangs 'patch-more-shebangs (lambda _ (for-each patch-shebang (list "path/to/config.sub")) #t))" in the modify-phases, but still get the same error. Anyone know why?
<metsomedog>^ during guix build
<mwette>I'm cross-building a linux-libre kernel. I get a 'stop-sig' (?) during the "make modules_install" phase. Any ideas what that might be from?
<apteryx>on core-updates: guix build: error: gnu/packages/guile.scm:706:2: package `guile-gdbm-ffi@20120209.fa1d5b6' has an invalid input: #f
<apteryx>trying to build guile-gdbm-ffi
<Franciman>Ah, i think i get it, it's probably because i'm building a workspace project
<Franciman>it looks for dirs, but the dependency is rust-dirs
<apteryx>I think because it tries to access "locales" from %final-inputs, which doesn't exist
<apteryx>janneke: was it a mistake in commit f851fd6b2b4 to list "locales" in the implicit inputs of the guile build system?
<apteryx>ah, locales got removed in "gnu: commencement: Remove ‘glibc-utf8-locales’ from ‘%final-inputs’." from civodul, recently
<apteryx>in commit de9d6d12
<janneke>apteryx: ah, okay; i was gonna say f851fd6b2b4 didn't introduce that, it just moved it
<apteryx>ACTION wonders if "locales" can simply be removed with the guile-build-system dropped, or if I should re-add the new glibc-utf8-locales-final package
<apteryx>the gnu-build-system has its own phase installing locales, so it seems perhaps redundant?
<apteryx>agda-build-system will have the same issue
<apteryx>janneke: ah! the change is that glibc now *embeds* a C.UTF8 locale
<apteryx>so a separate locale package is not strictly needed unless you need extra locales
<apteryx>I guess build systems can stop depending on locales, and if needed extra locales can be added as native-inputs
<PotentialUser-4>Hi. Where does cuirass stores the channel specifications?
<csepp>hey yall, i'm investigating why celluloid fails to build, it seems pkg-config can't find libass, which is a transitive dependency coming from mpv. am i right to assume that i shouldn't have to add libass to celluloid's inputs and this should be handled by pkg-config?
<ekaitz>csepp: did you try? I don't see why it shouldn't work
<janneke>apteryx: right[, but we can blame that fix on civodul, mostly]
<csepp>ekaitz: i mean, shouldn't it be automatically propagated? the important word here is *should*. i can of course add libass to celluloid, but if pkg-config is misbehaving, then i'd rather fix the root cause.
<ekaitz>csepp: it's an input, not a propagated input... isn't that the proper behavior?
<csepp>ekaitz: yeah, but it could refer to it or something, and then pkg-config can find it through that reference.
<ekaitz>csepp: did it build before or it didn't depend on it?
<metsomedog>for reference I managed to fix config.sub error I asked about above. It was necessary to replace references to SHELL=... in the configure script with e.g. (which "sh") (from guile)
<csepp>ekaitz: good question, lemme check.
<futurile>Q: how do I get a patch that is on a package? I can see that the mutt package has a patch, I want to see/edit it
<apteryx>zst-compressed man pages tested working
<ekaitz>futurile: i don't know if there's an easy way to do it but patches are part of the guix codebase, like the packages are. In the same folder of the package, there should be a `patches` directory and there you could find all of them
<ekaitz>futurile: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/patches/mutt-store-references.patch
<peanuts>"mutt-store-references.patch\patches\packages\gnu - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/patches/mutt-store-references.patch
<futurile>ekaitz: ah OK cool - I was wandering around trying to find it via the derivation for the build or something heh heh <fail> - thanks that's great
<ekaitz>futurile: anytime!
<apteryx>hm, is debbugs on vacation?
<apteryx>haven't gotten a ticket # confirmation in 10 minutes
<metsomedog>(In the package I'm trying to make) Following the configure step there is a generated (?) Makefile. Most env-vars are correctly using /gnu/store/..., but I see at least 2 "prefix=/usr/local exec_prefix=${prefix}" which are used throughout the file, so it ultimately fails trying to mkdir /usr/local/lib... Can someone give advice on how to correct this? Is there some standard function to patch Makefiles?
<freakingpenguin>I have a static blog I want to build as a Guix package and deploy on a remote Guix system. What would be the best way for me to symlink the output to /var/www/html for Nginx service?
<podiki>efraim: thanks; you have guix weather with some script/manifest of all packages?
<podiki>efraim: also, alacritty update, nice! (not so nice i'm assuming the number of commits needed)
<Kabouik>Is there an issue with go-github-com-gorilla-websocket? It's not installed on my system, but guix pull fails because of it. It's in the main Guix channel.
<Kabouik>Specifically, the guix pull logs: https://0x0.st/H642.txt
<Kabouik>Or maybe it's my private channel messing with it? Weird, there is zero reference to that package in my private channel.
<Kabouik>I suppose it might be a conflict with a propagated-input in the nchat-deps.scm file in my private channel, which contains other go packages (although it does not contain gorilla-websocket). I'll try removing that scm file from my channel as I don't use it yet.
<Kabouik>Yeah, that was it. propagated-inputs are always a headache for me.
<metsomedog>in reply to my issue above with unset $prefix in Makefile: to fix had to invoke configure command using --prefix set to (assoc-ref outputs "out"), where outputs is an input to the 'configure phase lambda replacement function
<rekado>metsomedog: FWIW we prefer using #$output in a g-expression instead of ‘assoc-ref’ on ‘outputs’.
<mwette>Anyone willing to peek at my attempt to build linux kernel for (riscv) VF2 board? I think I'm missing python dep's somehow. http://pastie.org/p/1cxr1LeqCcLYc2pV8uFnHw
<peanuts>"Pastie" http://pastie.org/p/1cxr1LeqCcLYc2pV8uFnHw
<metsomedog>rekado: I'm very new to guix packaging and also confused by g-exprs when I read about them before -- can you suggest how to achieve this with g-exprs? Currently doing this "(lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "out"))) ...use out...))"
<rekado>metsomedog: (arguments (list #:phases #~(modify-phases … #$outputs …)))
<rekado>sorry, ‘#$output’
<rekado>(not #$outputs)
<rekado>in this case you might even be able to get away with just setting #:make-flags; depends on the makefile.
<rekado>e.g. (arguments (list #:make-flags #~(list (string-append "prefix=" #$output))))
<rekado>or similar
<metsomedog>I assumed (assoc-ref outputs "out") refers to the value corresponding to key "out" in an alist outputs -- does #$output refer to the same value then?
<csepp>ekaitz: it looks like it's actually mpv that can't find its dependencies: Package 'libavcodec', required by 'mpv', not found
<ekaitz>csepp: UH...
<csepp>or rather, pkg-config can't find mpv's deps. mpv itself of course builds fine.
<csepp>i think i was right to suspect that mpv's inputs should not need to be added to celluloid
<ekaitz>csepp: i don't know how to help you further
<csepp>ekaitz: no prob. uwu
<rekado>python-tbb is broken. The .egg contains misnamed files. They only consist of the last letter (”B.py“ instead of ‘TBB.py’)
<mwette>`guix install python' gives me path to python3. If I need python -> python3 is there a guix command to set that up (or I can monkey-patch using ln -s)?
<Kabouik>As I still haven't solved my screensharing issues in Sway, and after seeking help in #sway, I'm wondering if I am starting my sway session correctly in Guix. I see no updated information in the manual to start Sway. It is even written here https://guix.gnu.org/manual/en/html_node/Desktop-Services.html that only GNOME has supports for Wayland. Yet I think it is possible to start a sway session if it is installed systemwide (listed in system.cfg) and if
<Kabouik> the GDM service has the wayland? #t option. This is what I have in my config. Is something missing? My concern is maybe dbus is not started properly, and environment variables may be missing, to allow proper screensharing.
<peanuts>"Desktop Services (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Desktop-Services.html
<podiki>did you try something like "dbus-run-session sway" to launch?
<podiki>when just using a WM you often have to start/setup more things
<podiki>(i don't use wayland or sway though, sorry, just general advice that i use for dbus)
<Kabouik>I did try that from inside my session and it does run a new instance of Sway inside the original one podiki. I wouldn't know how to do that automatically from the GDM login screen.
<Kabouik>This didn't solve the screensharing issue though, but maybe it was floawed by being lauched from inside the original Sway session.
<Kabouik>flawed*
<podiki>Yeah I meant to launch your wm (I use xinitrc xsession but also not from gdm, not sure how sway gets launched)
<podiki>Maybe dbus-launch your program?
<Franciman>does guix run on wasm too?
<Franciman>i.e. build on wasm
<Franciman>packages
<Kabouik>Ohh, dbus-launch chromium does work podiki (well, except that my screen is a portrait screen, natively, and the Jitsi shows it rotated 90° unfortunately). Do you know what change this suggests in my config.scm to make that work automatically?
<ieure>Franciman, I don't think so, but Guile Hoot might be helpful for going in that direction. https://gitlab.com/spritely/guile-hoot
<peanuts>"spritely / Guile Hoot ? GitLab" https://gitlab.com/spritely/guile-hoot
<Franciman>ty
<ieure>Guix depends on stuff not written in Guile, though, like libc. Not remotely an expert on this stuff, but that also seems like a problem. Maybe gcc can target wasm now? No idea.
<ieure>I have decidedly mixed feelings on WASM. On the one hand, it's objectively much better than what we're doing now. On the other hand, it's 100% going to get used for per-website DRM stuff, which will make ad blocking illegal, because it'd require circumventing a protection device, which the DMCA prohibits.
<ieure>And that'll destroy the web. At least, I'll sure as heck use it way, way less.
<ieure>Can't wait to torrent a cracked copy of StackOverflow or whatever
<podiki>Kabouik: I think that means you don't have dbus running in sway; that might be a more general gdm/sway launching questions
<podiki>personally I use the package xinitrc-xsession to use my .xinitrc as my xsession file, but again, I don't use gdm or wayland
<Kabouik>I was told in #sway that it's not dbus-launch <chromium> that I should use, but dbus-launch sway, in which case I think it might be gdm not starting sway the proper way in my config.scm?
<apteryx>pukkamustard: I was reading https://issues.guix.gnu.org/52555#61, and the eris blocks are now stored in an SQL database?
<peanuts>"[RFC PATCH 0/3] Decentralized substitute distribution with ERIS" https://issues.guix.gnu.org/52555#61
<apteryx>is the content blocks (chunks) actually stored in the DB? if so, it seems that'd make an unwieldly large SQLite database
<podiki>Kabouik: sorry, I don't know in your case the details, but seems you need to get dbus running for sway however that is normally done (i doubt guix specific at this point)
<Kabouik>No problem, actually dbus-launch chromium made me realize this is a dbus issue in the first place. I do have a "exec dbus-update-activatoin-environment --systemd WAYLAND_DISPLAY XDG_CURRENT_DESKTOP=sway" in my Sway config, but seeing it's systemd, it's probably some line inherited from my old configuration before I moved to Sway, and I forgot to remove it. Since GDM now supports wayland and is configured from my config.scm, and if sway should be run
<Kabouik>with dbus-launch, I suspect there is something missing in my config.scm. But the documentation on launching sway with GDM in Guix is lacking, as the manual even says that only GNOME supports Wayland.
<Kabouik> https://wiki.gentoo.org/wiki/Sway says that XDG_RUNTIME_DIR must be set. It's set to /run/user/1000 in my case.
<peanuts>"Sway - Gentoo wiki" https://wiki.gentoo.org/wiki/Sway
<Kabouik>s/before I moved to Sway/before I moved to Guix
<vagrantc>is it just me, or does peanuts mostly reiterate things that are immediately obvious from the URLs given?
<peanuts>vagrantc: Hi, for comments please contact my maintainers at https://codeberg.org/lechner/irc-helper-bot
<vagrantc>lechner: ? :)
<Kabouik>(I find that a little annoying too.)
<vagrantc>wonder what it will do with this commit hash from u-boot :) 97a897444235921ce19b4f8a3b27de6f5a9ab367
<vagrantc>ah, looks like that might be fixed :)
<vagrantc>i vaguely recall it used to assume commit hashes were from guix.git :)
<Franciman>anybody have experience with cargo workspace projects?
<mekeor>vagrantc, lechner: i agree that peanuts mostly feels obtrusive. (1) it repeats URLs, which floods my screen with them. (2) i don't find the html-title of a website so important that it needs to be automatically mentioned by a bot, leading to noise. (/) i prefer bots that only talk when instructed to do so explicitely. i vote for muting peanut-s.
<peanuts>mekeor: Hi, for comments please contact my maintainers at https://codeberg.org/lechner/irc-helper-bot
<podiki>Kabouik: seems like you are on the trail; there are other sway users here I know, maybe they will chime in at some point
<mekeor>is it possible to specify --no-graft via options->transformation from (guix transformations)?
<mekeor>if so, enlighten me via sneek :) gotta go :)
<meorly>i think i accidentally broke the system shepherd
<meorly>herd status hangs indefinitely and guix system reconfigure hangs while configuring shepherd services
<meorly>what to do now? reboot?
<pukkamustard>apteryx: Yeah, currently blocks can be stored in a SQLite database with `guix publish --eris=sqlite://my-blocks.db`. Blocks are really stored in the database and I agree the SQLite database could become unwieldly large!
<pukkamustard>storing blocks directly into a sqlite database was/is useful for debugging but maybe does not have any real value beyond that (maybe if you want to store the blocks to a USB stick). Usually I think it would make more sense to send blocks to some server over CoAP (using the implemented `coap+unix` and `coap+tcp` methods). The server can be more clever with how to store blocks.
<pukkamustard>more clever could be appending blocks to a file that only grow to a certain size and use SQLite as an index...there are some ideas towards this, implementations hopefully soon
<wehlutyk>Hello guix
<wehlutyk>!
<ieure>ACTION waves
<wehlutyk>I'm running into a weird failure of home-syncthing-service-type
<wehlutyk>running syncthing manually from the ternminal works fine
<wehlutyk>here's an example: https://pastebin.com/1dLMKkyK
<peanuts>"[start] 2024/01/04 23:06:51 INFO: syncthing v1.27.1 "Gold Grasshopper" (go1.20.2 - Pastebin.com" https://pastebin.com/1dLMKkyK
<wehlutyk>then uncommenting my "(service home-syncthing-service-type)" line in home services gives a failing syncthing, as it insists to be for /root
<wehlutyk> https://pastebin.com/14LwbvRn
<peanuts>"2024-01-04 22:57:47 Starting service root...2024-01-04 22:57:47 Service root s - Pastebin.com" https://pastebin.com/14LwbvRn
<wehlutyk>(my config is https://gitlab.com/wehlutyk/guix-config/-/blob/master/config.scm and my home config is https://gitlab.com/wehlutyk/guix-config/-/blob/master/home-configuration.scm )
<peanuts>"config.scm ? master ? S?bastien Lerique / guix-config ? GitLab" https://gitlab.com/wehlutyk/guix-config/-/blob/master/config.scm
<peanuts>"home-configuration.scm ? master ? S?bastien Lerique / guix-config ? GitLab" https://gitlab.com/wehlutyk/guix-config/-/blob/master/home-configuration.scm
<wehlutyk>could this be a bug? or is there an obvious problem?
<Kabouik>podiki: yes, I hope. Please, if anyone is using Sway on Guix and see this, do ping me, I'd just like to know how you start Sway and if it's done in your config.scm only in other files and environment variables as well.
<wehlutyk>(to be more precise in case this is important: I uncomment home-syncthing-service-type, rebuild home, reboot, then "herd stop syncthing" and run syncthing manually which works fine. Then stop the manual syncthing, "herd start syncthing", and it then fails.)
<Kabouik>In my case, it just starts by having wayland and sway as packages listed in my config.scm, and this GDM setting https://0x0.st/H6yF.txt
<Kabouik>But I think it is not enough to start sway with dbus.