IRC channel logs

2023-11-13.log

back to list of logs

<nathan-web>lechner: I'll re-paste it. It seems to have something to do with another file I have in the directory. I'll put both in the paste.
<nathan-web>lechner: https://pastebin.com/MWHJgpgQ
<peanuts>";; ~/.system/nls/systems/base-system.scm(define-module (nls systems base-syste - Pastebin.com" https://pastebin.com/MWHJgpgQ
<lechner>nathan-web / Hi, I don't know enough Guile to tell what the issue is but I suspect it has to with the interaction of Scheme proper, Guile's records, and any syntax features. Personally, I don't use inheritance and include the components I need instead. https://codeberg.org/lechner/system-config/src/branch/history/host
<peanuts>"system-config/host at history - system-config - Codeberg.org" https://codeberg.org/lechner/system-config/src/branch/history/host
<Kabouik>lilyp: good news, after a `pv -tpreb /dev/nvme0n1 | dd of=/dev/destination bs=32M conv=notrunc,noerror iflag=fullblock`, which took 9 hours for a 1TB source SSD, the UUID are actually cloned too, so I could boot Guix without having to chroot to change them and reconfigure.
<Kabouik>Now I still have to figure out how to extend the btrfs partition on the destination disk so that it actually uses the extra space (the new disk being larger).
<Kabouik>Without breaking it.
<nathan-web>So, I figured it out. It seems that a use-module statement included a `(use-package-modules ...)` that was redundant.
<alxsim>hi, in the pyproject-build-system, isn't the argument #:tests? #f supposed to not run the tests?
<alxsim>the module that I'm trying to build is https://github.com/dask/dask-xgboost, it's using pytest I think
<peanuts>"GitHub - dask/dask-xgboost" https://github.com/dask/dask-xgboost
<alxsim>I don't get it, I even added #:phases (modify-phases %standard-phases (delete 'check)) and the check phase still happens
<podiki>yes correct; what is the error you see
<podiki>(also that package says it is deprecated, fyi)
<alxsim>(I know, I don't have much of a choice it's a dependency of another thing)
<podiki>what is the error? (paste site if it is more than a line)
<alxsim>the errors are in the tests, I don't think they are important, but I can't figure out how to remove the tests
<alxsim>sending the errors soon
<podiki>paste the whole log then; could be this package is running tests as part of how it builds?
<alxsim> https://pastebin.com/6g3p2kJx
<peanuts>"ERROR tests/python/test_with_pandas.pyERROR tests/python/test_with_sklearn.py - Pastebin.com" https://pastebin.com/6g3p2kJx
<alxsim>podiki: ah yes probably
<podiki>no, does seem the check phase is being run
<podiki>can you share your package definition?
<podiki>oh, it is python-xgboost that is failing, not python-dask-xgboost
<alxsim> https://codeberg.org/alxsim/local-channel/src/commit/8a097ec4d7a113b40c9b77fbd5d61d6711ea7373/popgen.scm#L205
<peanuts>"local-channel/popgen.scm at 8a097ec4d7a113b40c9b77fbd5d61d6711ea7373 - local-channel - Codeberg.org" https://codeberg.org/alxsim/local-channel/src/commit/8a097ec4d7a113b40c9b77fbd5d61d6711ea7373/popgen.scm#L205
<podiki>you might try building a newer version to see if that helps; guix build python-xgboost --with-latest=python-xgboost
<alxsim>ooooh good catch
<alxsim>wasn't looking at the right thing then
<alxsim>didn't even consider that because python-xgboost is from upstream
<Kolev>Why can't I install packages once the install has started? Does it have to do with `cow store`?
<podiki>it happens to me often too, forget to check the lines above the final messages
<alxsim>podiki: thanks for the help
<podiki>welcome!
<podiki>Kolev: not sure, could be how the daemon is set up or the last install steps (I don't remember details)
<Kolev>I can test kernels without worry by just rolling back, right?
<podiki>can always build your own install image including more packages :) (or just a full live system and then install that configured system)
<podiki>yup
<Kolev>podiki, I made a live system with GNOME. It says "system running out of disk space" and it remembers changes I make to the system between reboots.
<podiki>you roll back the whole system configuration
<Kolev>podiki, no, I mean it remembers that I set `user`'s password, and it remembers that I changed a setting in GNOME.
<Kolev>podiki, most live systems forget these things.
<podiki>Kolev: sorry, my messages are delayed, the roll back message was a follow-up to my "yup" about testing kernels
<podiki>been a while since I played with a live image, but could be the volatile setting when creating the image?
<alxsim>is the python build system trying to install by default all the extras_require? If so I find it kind of counterintuitive
<alxsim>I don't understand guix source code enough to know if it's the case
<nckx>sneek: later tell Andronikos: yes, as we all know trust is transitive, so we don't verify upstream source signatures in Guix itself.
<sneek>Will do.
<adanska>what would be involved in added exfat support to guix system?
<sneek>Welcome back adanska, you have 1 message!
<sneek>adanska, nckx says: Here's an untested attempt at exFAT support (*of course* it wasn't as easy as I promised, where would be the fun otherwise?) <https://tobias.gr/temp/exFAT.patch>. If you could test it with wild exFATs (created by SD vendors and/or Windows) I'd be grateful. I don't have either.
<adanska>oh!!
<adanska>thank you nckx! i'll give it a go :)
<KE0VVT>adanska: Wait, Guix can't ExFAT? Glad my ext. HD is XFS.
<adanska>KE0VVT: its not supported as a file system in your guix config, linux obviously supports it though, so you can still mount exfat
<KE0VVT>adanska: Ah.
<KE0VVT>Do free operating systems have trouble running on ThinkCentres?
<KE0VVT>Fedora will install but Trisquel and Guix will not. I'm trying to get all my systems on Guix.
<futurile>KE0VVT: Thinkcentres seem pretty standard to me - Fedora might have more drivers though
<KE0VVT>I keep getting `guix system: error: `/gnu/store/z4cigqx1vqbwcbyisa1m41l6dabmp1a1-guix-command substitute' died unexpectedly
<stellarskylark>Hi there! I'm trying to get Logseq working on my Guix system. I'm trying to run the appimage in an --emulate-fhs container, but it expects libgcc_c and I think also libstdc++. And since gcc:lib is masked in the CLI now, I can't actually provide those libraries. How do I go about this?
<stellarskylark>Also I already tried the flatpak and have the same problem there, it expects those .so files and I can't get them
<civodul>Hello Guix!
<nckx>stellarskylark: The hacky answer is to (ab)use the 'libgccjit' package as a sneaky gcc:lib.
<futurile>Morning civodul
<nckx>o/
<futurile>If anyone is up for some light reading this morning, put out a new blog post on Guix time-travel: https://www.futurile.net/2023/11/07/guix-time-travel-tricks/
<stellarskylark>I actually managed to get the flatpak working! It needed dbus-run-session prefixed before the run command.
<gabber`>(how) can i use the $(guix build --system) facilities on a non-guix system?
<janneke>gabber`: if your /etc/machines.scm specifies/supports the architecture i believe it should work
<janneke>* /etc/guix/machines.scm
<gabber`>so i specify some locally-running qemu virtual machine in there where i can ssh into?
<janneke>gabber`: yes
<gabber`>thanks!
<efraim>or you can use binfmt emulation
<janneke>how does that work on a non-guix system?
<gabber`>ACTION just learned there is a binfmt-support package in apt
<efraim>is that what it's called? I've pinned qemu-static or something on my debian powerpc machine
<gabber`>according to https://wiki.debian.org/QemuUserEmulation
<peanuts>"QemuUserEmulation - Debian Wiki" https://wiki.debian.org/QemuUserEmulation
<zororg>May I know if Arun Issac, from genenetwork, is here in this channel?
<jonsger> https://toot.aquilenet.fr/@civodul/111402901345951358 -> AMD, ARM or IBM. Who knows :)
<peanuts>"Ludovic Court?s?: ? Been discussing with a three-letter processor com? ? - Aquilepouet" https://toot.aquilenet.fr/@civodul/111402901345951358
<mekeor>damn, i need go-1.21. the patch for it is still pending :/
<efraim>is pip supposed to vendor its dependencies?
<elevenkb>Hmm, last time I tried inferiors I couldn't get them to use substitution. Has anyone had a different exeprience with them?
<crole>What do you need that for, mekeor?
<crole>Anything fun?
<mekeor>elevenkb: what are inferiors?
<elevenkb>`(info)Guix#Inferiors'
<mekeor>crole: no, nothing fun
<elevenkb>mekeor: Sorry that didn't work as I expected.
<elevenkb>But yah inferiors are a way to obtain a package from any list of channels not just the "current" one, so you can mix and match packages from different Guix branches in the same profile (for example).
<mekeor>it's fine, i found it. in emacs, in info-mode, press C-0 w for copying (info "(guix) Inferiors")
<elevenkb>Can you represent that as a link though in IRC?
<elevenkb>`(info "(guix) Inferiors")'
<elevenkb>`info "(guix) Inferiors"'
<elevenkb>nope so it seems.
<elevenkb>`current-buffer' though should work.
<elevenkb>yep.
<mekeor>ERC makes such info-sexps buttons (with a certain erc-module), also you can press C-x C-e... anyways, just emcas stuff.
<elevenkb>ahhh.
<mekeor>thanks for letting me know about inferiors. very handy feature. i could use it to use the master and the emacs-team branch at the same time
<elevenkb>yah.
<janneke>sneek: seen samplet?
<sneek>I think I remember samplet in #guile 3 months ago, saying: That’s an ancient (but still neat) treatment of the idea..
<janneke>dude
<janneke>sneek: botsnack
<sneek>:)
<elevenkb>sneek: help
<elevenkb>How can I get man pages for the UNIX api functions like dlopen?
<mekeor>elevenkb: on guix system or on a foreign distro?
<elevenkb>mekeor: on guix system :)
<elevenkb>never switching to anything else tbqh.
<elevenkb>too addicted to it.
<jpoiret>elevenkb: that's the package `man-pages`
<mekeor>cool, works for me :)
<mekeor>interesting that the man pages are retrieved from kernel.org and not part of the glibc package, even though e.g. dlopen is part of glibc, iiuc
<elevenkb>Works for me too! thanks jpoiret.
<jpoiret>the man pages for Linux are not developed by the glibc project
<jpoiret>iirc
<gabber`>weird thing. i have a $(guix shell python) ready and a $(guix shell python-ipython) -- but when i want a $(guix shell python python-ipython) guix starts downloading a (big) bunch of stuff.... shouldn't this be a quick-and-easy™ thing to do, merge two profiles?
<civodul>gabber`: it’s a bit more work than just merging due to “profile hooks” (similar to “post-install hooks” with apt, if you see what i mean)
<gabber`>civodul: i see.. though i don't understand (yet) why additional dependencies have to be satisfied (if that was actually what was happening)
<gabber`>how do i explicitly use libusb 0.1.12 as an input to a package in a package definition?
<gabber`>nvm
<pastor>Is it okay to submit packages for the `gnome-team` branch?
<Andronikos>I need to clone a HDD. Does someone one a good tool for that? I sure can use "dd" but it doesn't check integrity.
<sneek>Welcome back Andronikos, you have 1 message!
<sneek>Andronikos, nckx says: yes, as we all know trust is transitive, so we don't verify upstream source signatures in Guix itself.
<voroskoi>mcron: Couldn't find a usable `crontab-access'.
<Andronikos>s/one/know
<voroskoi>have You seeen this before? ^^
<Andronikos>nckx: Thanks for confirming.
<lilyp>pastor: same routine as for other branches, just label it [PATCH gnome-team] and also do the debbugs CC dance
<pastor>lilyp: thanks
<roptat>hi guix!
<civodul>howdy roptat!
<nckx>Andronikos: I'm failing to find a scenario where 'checking integrity' in user space is anything but snake oil, or 100% equivalent to dd if=a of=b && cmp a b.
<roptat>I'm trying to update my android importer to work with android 14
<Franciman>i think i will switch to guix on my main machine!
<Franciman>the test was very positive
<roptat>I was ignoring "visibility" of soong modules, but now I need to take it into account or it'll import something completely different from what I wanted
<roptat>I factorized my code and ended up with something much smaller and easier to understand
<roptat>but somehow, at some point I end up with a list of single-element alists, instead of an alist
<nckx>(If you're about to answer ddrescue, no, it doesn't provide much of that at all, it's the hardware+kernel.)
<roptat>fixed it, what as I thinking "(map (lambda (a . b) ...) alist)", of course it can't work
<Kolev>Substitute died. Restarting `system init`.
<dthompson>has anyone had any luck building a guix image that works with linode so they don't have to start with something like debian and convert it over to guix? would like a more "declarative" solution than that
<civodul>dthompson: i vaguely recall people “doing things” with Linode, not sure what that was
<dthompson>civodul: I'm attempting to see if I can get 'guix system image' to produce something that works
<dthompson>will report back if I succeed :)
<dthompson>setting up a new guix machine over at spritely
<futurile>Andronikos: clonezilla is good for cloning HDD (and the same group has a similar set of tools)
<vivien>So, orca does not work on guix, right? Or is it just me?
<lilyp>vivien: maybe one of those "are you using gnome" things?
<vivien>lilyp, if you run it, does it immediately throw a Python exception?
<pinpon>vivien: Regarding Orca, it seems it is a known bug: https://issues.guix.gnu.org/64357
<peanuts>"Orca screenreader crashes on start" https://issues.guix.gnu.org/64357
<dthompson>is there a way to use 'guix system image' produce a raw image with an ext4 root file system?
<vivien>Thank you pinpon
<civodul>dthompson: yes, i believe ‘guix system image -t mbr-raw’ does that
<dthompson>civodul: ah! will try. I haven't gotten around to that particular type yet.
<civodul>‘efi-raw’ should work as well
<dthompson>wasn't obvious from the names what they would do different from the default hybrid raw type
<civodul>would be nice if ‘guix system image --list-image-types’ could show short descriptions
<dthompson>yeah
<dthompson>I've just been trial and erroring
<dthompson>emphasis on the erroring
<civodul>heh
<dthompson>;)
<civodul>there’s room for improvement in the UI!
<jpoiret>i just uhhhh ... read the definition of the system image objects
<jpoiret>the "raw" qualifier is a bit useless too imo
<dthompson>if I get this to work I'll at least make a quick blog post about it
<civodul>would be nice!
<civodul>jpoiret: i guess it’s “raw” as opposed to “qcow2”
<civodul>problem is, the image type name embeds too much information
<dthompson>hmm, mbr-raw didn't help me. will try efi-raw.
<civodul>didn’t help in what sense?
<civodul>looking at (gnu system image), it seems to be what we’re looking for
<dthompson>civodul: linode still can't find the root file system and reports the disk as being "raw" rather than "ext4"
<dthompson>I haven't done much with linode in a long time so I'm still trying to understand what their images require to work
<dthompson>I'll have to pick this back up tomorrow. thanks for the help though civodul
<dthompson>I do feel like I'm fairly close... I think...
<dthompson>linode correctly sees the swap space as swap, but not the root disk. bleh. okay... stepping away from the computer for real.