IRC channel logs

2023-11-12.log

back to list of logs

<Andronikos>podiki: Caught signal 11 [Segmentation fault] (2229MB RAM, peak 2229MB), was running interesting
<podiki>oh, so one (or more) did fail? SkRuntimeBlender_GPU seems to be the usual test, https://ci.guix.gnu.org/build/2573633/details
<peanuts>"Build 2573633" https://ci.guix.gnu.org/build/2573633/details
<Andronikos>podiki: No, I just saw at the logs from the CI. I wonder if it may failed because the machine had RAM issues or something? Sometimes I read that they run out of it because something breaks and so on.
<podiki>failed locally here now too; perhaps a finiky test
<Andronikos>maybe it has it's positives running old hardware
<Andronikos>it is a GPU test. Maybe hardware problem?
<Andronikos>Just a theory because modern CPUs and 3D acceleration isn't really a thing.
<podiki>in this case, this branch has a newer mesa, which maybe is the problem? i can try updating skia also, though I didn't get very far before
<Andronikos>podiki: How can I find out which mesa was used for my Skia build?
<podiki>if you ran it on mesa-updates branch it is the newer one
<podiki>you could be right, a flaky test on some hardware, where bordeaux has something else and different test is run or it works better
<Andronikos>podiki: Need some other package compiled as well? I have time for one more before I go
<podiki>not off the top of my head but thanks, this was helpful
<podiki>I think i'll disable this test with a note it seems to be on some hardware only
<ieure>Does anyone have a working autofs setup? I see there's a package for it, but there doesn't seem to be any service to configure mounts.
<ieure>Also, I ran `make check' on Guix to make sure my changes weren't breaking anything; looks like there's a failure in tests/gexp.scm in rev af6105afc6 -- Anyone else seeing that?
<ieure>Looks like that's the most recent commit.
<Andronikos>You want me run "make check" from master?
<ieure>Andronikos, would you, please?
<ieure>I see quite a few failures.
<ieure># XFAIL: 3
<ieure># FAIL: 5
<ieure>Is there a way to run `make check' against a single test?
<Andronikos>ieure: Yeah, it sais in the manual somewhere. Let me find it.
<Andronikos>says
<ieure>Ah, I see it
<ieure>make check TESTS="tests/store.scm tests/cpio.scm"
<Andronikos>make check TESTS="tests/store.scm tests/cpio.scm"
<Andronikos>Not yet finished but gexp.scm fails for me as well.
<ieure>Andronikos, Alright, thank you for confirming.
<Andronikos>I have added --persistent to the guix system image vm command but the store is still locked and I can't build anything. Is it simply not possible or what do I need to do?
<vagrantc>hrm. qa not picking up patches from over 24 hours ago ...
<Andronikos>ieure: How long did "make check" take for you and which CPU do you have?
<ieure>Andronikos, On an AMD Ryzen 7 PRO 5850U here. `make check` takes like 30 minutes or something silly. `make -j12 check' maybe 5-10.
<Andronikos>Oh, make doesn't use all cores as a default? No wonder it takes ages (have only 4 but still more than 1)
<ieure>It doesn't.
<Andronikos>Ah right. That was a specific config in Gentoo. Well, I totally forgot that.
<ieure>This is an 8-core laptop, I usually tell make to use 1.5x the number of physical cores, since a good amount of most compiles is i/o bound.
<Andronikos>Finished with the same result as you have.
<Andronikos>(make check)
<ieure>Alright, I'm not making things worse. :)
<ieure>nckx, https://issues.guix.gnu.org/67118
<peanuts>"[PATCH] Change "tabulation" to "tabulation character" in linter & manual" https://issues.guix.gnu.org/67118
<Andronikos>I did a make check on master today and it had no fails. So it must be really recent.
<ieure>How can I get the store path for an installed package?
<dcunit3d>so i'm trying to build a perl-text-markdown package, but i'm getting a failure with perl-b-keywords which is a test dependency. the latter package is in Guix proper. does anyone else have problems building it?
<dcunit3d>here's my build log: https://0x0.st/HvzQ.txt
<dcunit3d>also, i was thinking of submitting an regpg patch to Guix for review. it otherwise req. zero deps and is generally useful IMO. but i think i need to build the docs, which is what perl-text-markdown and it's other native inputs do
<dcunit3d>--substitute-urls gets me past the errors though
<ieure>I made a package for jellyfin-mpv-shim which I want to contribute. It's implemented in Python. Should that go into (gnu packages python) or (gnu packages video)?
<ieure>It relies on some unpackages deps, those obviously go into (gnu packages python) -- but wondering about the actual application.
<ieure>Leaning towards (gnu packages video)
<ieure>Oh, I guess (gun packages python) is for Python-the-language, not libraries made in/for Python. hmm
<ieure>Ah, python-xyz, yes.
<dcunit3d>my packages look like this at the moment. https://0x0.st/Hvzf .txt, though the perl dep is in perl.scm and regpg is in gnupg.scm.
<dcunit3d>The `make install` step is failing to create /homeless-shelter/bin, so i'm googling around to figure that out
<dcunit3d>pre-building the perl-text-markdown, trying to skip the check step and forcing substitutes for everything gets me to the install step on regpg. i just need it to work for now, then i can clean it up to submit as a patch later.
<ieure>dcunit3d, Error seems (in my limited experience) to mean that the install step needs to set DESTDIR, PREFIX, or whatever other environment variable controls the installation location.
<dcunit3d>also, since perl is pretty much ubiquitous and there are zero runtime deps other than perl, i'm unsure of whether it should be included as propagated-input or input... i think input.
<dcunit3d>thanks ieure
<dcunit3d>i think this regpg script is extremely valuable (almost zero deps, etc), especially when you want to avoid centralized services (either for offensive security or for when you want to avoid cloud altogether). it's generally useful as an gpg interface for ansible-vault and to dump secrets from ansible where you don't leave a filesystem trace.
<dcunit3d>for me, just its documentation was fairly enlightening, as it gives you an indication of how to handle secrets using GPG for various scenarios. it illuminated quite a few missing pieces, like whether you care to use shred for files (i didn't realize you could), how to generate/protect TLS with keychain, how to use stdin/stdout with GPG generally, etc.
<dcunit3d>i
<dcunit3d>i'll check what the Makefile is setting for those ieure
<ieure>Hmph. Can someone help me understand this guix lint message? "label 'python' does not match package name 'python:tk'"
<ieure>My package definition has: (propagated-inputs (list `(,python "tk") ...))
<ieure>But this is the style the manual says I should be using: https://guix.gnu.org/en/manual/devel/en/html_node/package-Reference.html
<peanuts>"package Reference (GNU Guix Reference Manual)" https://guix.gnu.org/en/manual/devel/en/html_node/package-Reference.html
<dcunit3d>are you using python-build-system ieure?
<ieure>dcunit3d, No, pyproject-build-system.
<dcunit3d>i'm not sure ieure. how is the selection of build system separate from the package inputs?
<dcunit3d>i know the specifications of outputs has changed over the past few years. i've encountered similar issues, but i've been in ansible-land far too long (i reallly wish guix had more support bc guix deploy circumvents the need for ansible in many cases)
<ieure>dcunit3d, I don't know if that's a rhetorical question or not, but I'm just getting my bearings here and don't really have any idea about any of this.
<ieure>In the absence of experience, I'm leaning on the docs/manual. Part about guix lint _seems_ to indicate that this linter error is to report "old-style" input labels. But I'm not using those. So I don't know what's wrong.
<ieure> https://guix.gnu.org/en/manual/devel/en/html_node/Invoking-guix-lint.html
<peanuts>"Invoking guix lint (GNU Guix Reference Manual)" https://guix.gnu.org/en/manual/devel/en/html_node/Invoking-guix-lint.html
<ieure>`guix lint` should maybe print the name of the linter to help identify what's wrong -- I've seen other linters that do this.
<dcunit3d>is there any way to prevent guix lint from needing to check CVE issues?
<dcunit3d>checking `guix lint -h` ...
<dcunit3d>ok yes
<dcunit3d>:)
<ieure>dcunit3d, -X cve, I think.
<ieure>Just from reading --help
<dcunit3d>i imagined myself having accomplished more with guix, but my energy is diffused into too many other projects/techs, so experience is slow in coming :(
<podiki>ieure: you can ignore that message, it is because you selected a certain output of that package so the name isn't just the package name
<podiki>with new style inputs (just package variable list) I think that is always a false warning? it would come from doing in old style ("some random name" ,package-with-different-name) if I recall
<ieure>:|
<podiki>probably that can be modified
<podiki>(the lint check in this case I mean)
<ieure>Yeah.
<dcunit3d>is there anythink like a breakpoint for gexps? they're being executed by the guix daemon. i can check what's happened by using --keep-failed
<dcunit3d>i have some silly regexps that aren't replacing anything. i can't tell if it's because the file matcher is wrong or if it's the regexp.
<dcunit3d>i've got a ton of source code I'm looking at
<podiki>that is a common annoyance many of us have; some discussion that substitute should give a warning when nothing matches (it just silently does nothing)
<podiki>one thing to note is that you need to escape parens and backslashes
<podiki>I would search the code for examples as I usually guess wrong the first time, but basically backslash your backslashes (that escape characters) in the regex
<dcunit3d>k, i have a patch i can use, but i think i need to change like 2 lines in the Makefile and there's no ./configure script
<dcunit3d>ahh yes, i remember now that I was able to get it to replace ALL, but nothing with a regexp
<dcunit3d>thanks
<podiki>welcome
<podiki>i've had to write regexs here that had like 6 backslashes....took me more than 6 tries I bet
<dcunit3d>phew i got it ... at least for me. it was replacing the newline at the end of the file. half the calls to (substitute* ...) were to avoid the need for the perl package.
<dcunit3d>but then i remembered `guix import` which was like 99% of the work
<podiki>ah yes the newline; I think that at least has a hint in the manual
<dcunit3d>god i wish people would think for themselves. the capital for tech investment is too restricted and under the control of idiots that refuse to experiement with anything.
<dcunit3d>well i've read the manual at various levels of detail. it's actually what convinced me that i should try guix. there's so much info about services/packages in it, stuff i don't know. it blows the archwiki out of the water.
<dcunit3d>however, some details are less sticky for me until i go to actually work with the concept or its details. so i guess i need to re-read and re-re-read.
<podiki>the source is also a great resource; pretty much anything you want to do in a package has been done, in my experience
<dcunit3d>for some reason, "^prefix = .*$" wasn't matching until i replaced the spaces. idk. i should've pulled back and ran the code directly on the makefile. i need better habits.
<podiki>and if you have the hang of the changelog format for commit messages, it is very quick to search
<dcunit3d>yeh, it really is. i tried building a cura 5.x once though and they moved from python/c++ hybrid to python/conan hybrid and that's outta my league. mixing build systems is one thing, but making new conan build system and also mixing it with python? yeh that's a project for much, much later.
<podiki>yeah that sounds a bit much to jump into right away
<dcunit3d>i build XML for projects to git pull using google git-repo. when i learn a new language or something and i'm going to commit a lot of time to it, then i'll build the XML for it. i can usually do it with graphql (i have copies of almost all of KDE's repos on my machine)
<dcunit3d>so i also have a bunch of copies of guix channels and people's dotfiles. i otherwise don't get much feedback. i hate to cargo cult, but i'm bouncing around too many languages/frameworks too quickly enough for things to set in.
<podiki>i'm still constantly copying/adapting, often from my own old commits :-)
<dcunit3d>builds in general are something i lack experience in. i wish i had explicitly been taught: "write a package to solve those linux problems; when you reinstall, use your packages", which then implicitely acts as well-structured documentation.
<dcunit3d>it's so easy to get by in linux with packages and i had many noob problems because i was separated from that
<dcunit3d>nix/guix solve this and their home functionality is great
<podiki>glad you are enjoying it! I've been pretty hooked myself
<dcunit3d>and there are many open source projects where it's just not easy to become a contributer. Cura is one example. the build tooling is what it is, but then some upstream changes to code aren't readily acessible to a contributor .... this means "good luck getting your patches accepted"
<podiki>we have quite a backlog but I think are friendly and try to help out new contributors; the patch/mailing list might be foreign to some people but has some nice features I've found (I prefer it after using it)
<KE0VVT>podiki: I like the simple process of "Pull my work from example.net/alice/guix."
<podiki>maybe one day we'll have both together
<dcunit3d>podiki: i'm trying to get used to it. i'm in the middle of working on improving visibility in email. i just need to manage labels and filter rules better. i have what i need set up for Guix and it shows in Gnus/Thunderbird, but i've gotta figure out how to check it more frequently.
<dcunit3d>i like the patch-based workflow for some things. the younger generations need to be taught how to use email. it's something that can really empower you later on. other notification-based apps just don't give you the power/ability to intelligently define what you want to see.
<podiki>I think the very basic level of "just send a diff/patch via email" for simple contributions is pretty low barrier, but admittedly not what many might be used to
<dcunit3d>for me, the barrier to entry was primarily around being confident that my secrets for email-based workflow would be secure (so understanding how to setup access to IMAP/etc and ensure that GPG-encrypted secrets would make access available to apps as needed)
<dcunit3d>otherwise, it was fairly straightforward. another stumbling-block was how to use git to generate patches, but magit makes that easy.
<podiki>sure, to do it well, but I think simply using one's regular email and attaching a file is pretty simple. though i'm one of those that has my email in emacs so i guess my perspective is skewed
<podiki>even the output of regular diff would be okay for someone starting out with a simple change
<podiki>mumi has some send patches features now to take out some of the steps
<podiki>(which still needs git send-email, but automates some talking to debbugs)
<dcunit3d>more structured mentorship would help accelerate the learning process. identifying coachable noobs who really want to learn and find someone who can be their "sponsor" or something. the linux user groups and universities seem to do this well.
<dcunit3d>learning about how email actually works was challenging, but well worth it. otherwiese, i don't think i ever would have learned about the five types of MXA agents or their purpose
<podiki>we do have a mentors team of some sort; I think they should get emails of first time submissions? i'm not sure the details
<podiki>it is a good idea though, a little personal help pays off for everyone
<dcunit3d>jgart helped me out alot in the beginning. i was in school so i didn't really have enough time to do it though.
<Jaeme>May a committer merge my patch for ani-cli into master? <https://issues.guix.gnu.org/66694> It has already been reviewed but just not merged.
<peanuts>"[PATCH] gnu: Add ani-cli" https://issues.guix.gnu.org/66694
<podiki>Jaeme: I would send a polite ping on that thread (making sure it goes to Tobias) or chat up nckx next time you see them active here
<Jaeme>Oh OK, I'll do that.
<podiki>Jaeme: given that the review is from a committer, I will let them make the final call, though your response to the important last question seems reasonable to me as well
<podiki>so, I would expect to see it merged soon and thanks for your contribution
<lechner>Jaeme / there is no need to beg for package additions like yours. you can just set up your own channel. i have one too
<lechner>podiki / thanks for your help two days ago!
<podiki>welcome!
<podiki>I must away for now, have a good night guixers
<Jaeme>lechner / noted. I already have a guix channel with ani-cli already but I guess emailing or pinging the reviewers directly is better.
<Andronikos>ieure: https://issues.guix.gnu.org/67120 I think something went wrong here. Seems there are patches from a different patch series.
<peanuts>"[PATCH 0/4] Add jellyfin-mpv-player and deps" https://issues.guix.gnu.org/67120
<lechner>Hi, packages.ggo says Guix Data Service not available (?)
<lechner>Hi, does gnome-keyring 42.1 build for anyone? https://paste.mozilla.org/AzTE0Uv2
<peanuts>"Mozilla Community Pastebin/AzTE0Uv2 (JavaScript)" https://paste.mozilla.org/AzTE0Uv2
<Kolev>(issue "\s") ;; /etc/issue gives "Linux" for OS name
<Andronikos>lechner: /gnu/store/fari5k4naf6x16608x8m0albd6q9hryf-gnome-keyring-42.1 using guix time-machine -- build gnome-keyring@42.1
<Kolev>Where is the source code to the "graphical" installer?
<janneke>find . -name installer
<janneke>./gnu/installer
<AwesomeAdam54321>Kolev: It's in gnu/installer/installer.scm
<AwesomeAdam54321>If your interested in the graphical interface of the installer, that's in ./gnu/installer/newt.scm
<Kolev>AwesomeAdam54321, I'm more looking to script my install of Guix. The installer is not quick enough.
<AwesomeAdam54321>Kolev: Do you want the script to automatically install a specific configuration?
<Kolev>AwesomeAdam54321, yes
<Kolev>AwesomeAdam54321, I'm hung up on UUIDs.
<Kolev> https://codeberg.org/csh/dotfiles/src/branch/main/install.sh
<peanuts>"dotfiles/install.sh at main - dotfiles - Codeberg.org" https://codeberg.org/csh/dotfiles/src/branch/main/install.sh
<AwesomeAdam54321>I was going to suggest guix system init, but it's already in your install script
<futurile>Morning Guixers
<lars`>Hello, is there any way to configure a wireless network in my system configuration?
<lars`>The manual doesn't have a way to add connections to the networkmanager config
<futurile>hmm is the Guix Data Service down?
<lilyp>Is it expected that the builder for guix-packages-base spins several times from 50→100%?
<lilyp>It looks weird imho.
<lilyp>Same with guix-packages
<fnat>If I'm on Emacs 29.1, do I have to install emacs-modus-themes separately? I can definitely load the themes with the sole Emacs package, but then I feel I'm missing something re why emacs-modus-themes is packaged separately.
<futurile>fnat: I'm not an emacs user. But, it looks like there's a few different emacs themes. Why do you think you're missing something?
<fnat>futurile: Hi, thanks. Because the theme is already in Emacs and I don't see why having a separate package. But also, I seem to miss some of Emacs' modus-themes-* symbols that are mentioned in the theme documentation, so now I'm no longer sure I don't need the theme package :)
<fnat>Or maybe it's because the theme version packaged in Emacs 29.1 is slightly out-of-sync with respect to the upstream documentation, which is of course fine and understandable - it's just that I'd like to be sure I'm not missing anything else
<fnat>It might be more of a #emacs question as opposed to a #guix question, but I thought of asking here first
<fnat>Well, as a matter of fact, the documentation is pretty clear: https://protesilaos.com/emacs/modus-themes#h:a4ca52cd-869f-46a5-9e16-4d9665f5b88e it explicitly says "guix package -i emacs-modus-themes" :)
<peanuts>"Modus Themes | Protesilaos Stavrou" https://protesilaos.com/emacs/modus-themes#h:a4ca52cd-869f-46a5-9e16-4d9665f5b88e
<fnat>Possibly what's been brought in into main Emacs is just a subset of the theme? I'm sure this is mentioned somewhere in the docs, sorry for the noise
<futurile>fnat: if you're of a mind to investigate more you could grep the commits: https://git.savannah.gnu.org/cgit/guix.git/log/
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/log
<nutcase_> https://bordeaux.guix.gnu.org/api/queue?nr=1000' returned 502 ("Bad Gateway") . What does that mean?
<zamfofex>Usually 5XX HTTP status codes mean “something’s wrong and it’s not your fault”.
<zamfofex>As opposed to 4XX, which usually mean “something’s wrong, and *it is* your fault”.
<nutcase_>ok, correct answer :-). What does this mean to me, when I get a 502 by invoking 'guix weather'?
<nckx>That something went wrong on bordeaux and it's not your fault.
<nckx>So it means very little to you.
<nckx>After poking around a bit, it means very little to *me*.
<f1refly>is there a way to adjust delayed hibernation on guix?
<f1refly>my laptop is consuming lots of power even in deep sleep, if i leave it somewhere for two days it will run out of battery..
<nckx>What's that?
<nckx>Ah.
<nckx>Suspend-then-hibernate?
<f1refly>probably
<f1refly>i can't find that in the devel documentation
<nckx>I don't think so.
<f1refly>no can do?
<nckx>I don't know of a way. On other distros that's usually handled by systemd, which calls it hybrid sleep, because that's the Microsoft term.
<f1refly>i read that on the arch wiki
<nckx>It's not handled by the kernel and I'm not aware of any Guix code that does.
<nckx>If you get lucky, maybe elogind does.
<f1refly>why does my thinkpad from 2012 with eroded battery manage a week in suspend and my laptop from 2023 can barely handle a day :(
<f1refly>i'll see if there are options for elogind
<nckx>It's a wild guess but maybe some hardware's not being powered off properly, or refuses to be.
<f1refly>i think there should be at least an option to suspend to ram and also write resume data to swap so when the battery does run out the kernel will just resume from disk
<nckx>f1refly: Explicitly susending to disk is an easy option to set, it's the delayed part that I think we lack.
<f1refly>that will have to do if there's no automatic hibernation
<f1refly>explicitly suspending to disk is unfortunately very annoying with an encrypted disk with a long password
<nckx>f1refly: Yes, that's what systemd does. Maybe not in that order though.
<f1refly>according to the manufacturer a drain of 1W-2W is "normal"
<nckx>I patched my kernel to do it in your order once, but that is hardly a reasonable suggestion.
<f1refly>hmm
<f1refly>apparantely there's a userspace utility for hybrid sleep
<f1refly>called uswsusp
<nckx>It's really for 'user space' hibernation (still babysat by the kernel), and I think it's unmaintained?
<nckx>All I remember is that I packaged it for Guix, tried actually using it, then thought 'I'm not maintaining this'.
<f1refly>at some point it has to rely on the kernel to hibernate ram to disk i reckon
<nckx>Yes.
<f1refly>heh
<nckx>It sends pages to the kernel via ioctl or other syscall, IDR which.
<f1refly>fair point of view for something not maintained since 2010
<nckx>Frustrating answer, but: this isn't hard, conceptually, the pieces are all there and mostly in the kernel. (1) You echo 'suspend' into /sys/power/disk (the action the kernel will take after writing the image; defaults to 'platform' shutdown-with-maybe-pretty-LED). (2) Then you echo 'disk' into /sys/power/state to hibernate. You can optionally (0) use rtcwake to set an alarm and trigger some script to hibernate again, but this time shut down. Due to Linu
<nckx>kernel ideology you must hibernate twice if you choose this. So must systemd. Hence my attempt to add it directly to the kernel. But you don't strictly need to.
<nckx>Just make sure your script can tell the difference between rtcwake alarm and the user opening the lid :)
<f1refly>yes it would be very annoying otherwise
<f1refly>i'll test around a bit
<nckx>If you implement only steps 1-2, you at least don't lose data when the battery runs out, but it will still drain & wear the battery down.
<f1refly>I can't even get it to resume from hibernate x)
<f1refly>is there a problem when my swap partition is on an lvm in a luks device?
<f1refly>the system seems to write the correct swsuspend signature to my swap partition and i set the resume=/dev/myvg/myswaplv on my cmdline which is correctly reported in /proc/cmdline
<lars`>I need help debugging a strange network problem I'm having on my Pinephone Pro. I have a very minimal Guix image installed on it, and have wpa_supplicant and dhclient. I can successfully connect to my wifi, and dhclient gets an ip that looks correct, and I can ping the router. But the weird thing is that I can't ping anything else on the same network, and the phone itself is not pingable or visible from other devices on the same network
<lars`>And I can't ping anython on the internet
<lars`>anything*
<ekaitz>anyone wants to help me package more modern versions of llvm?
<ekaitz>anyone is delaying it and wants to have more energy and some help?
<efraim>ekaitz: llvm-16 and 17 landed today
<ekaitz>efraim: really?
<ekaitz>DAMN!
<ekaitz>thank you!
<f1refly>as expected, when booting with "debug" in my cmdline the kernel waits for the swap partition before asking me for my password which would enable it to find it :(
<efraim>Hilton did the work about 3 weeks ago, finally pushed it today
<ekaitz>now i'll package modern Zig
<ekaitz>:)))))
<ekaitz>also... should i try to become a committer for the zig ecosystem...?
<efraim>good luck with that, I think Hilton also worked on that, not sure if it can be built with zig-0.10
<efraim>of course :)
<ekaitz>i'll take a look
<ekaitz>i'll need some mentoring to become a commiter and be actually useful but... i want to do it
<nckx>f1refly: I know that the last commit to the hibernation code was supposed to allow more swap-on-foo scenarios, but I think the aim was LUKS. I don't know enough about LVM to say.
<f1refly>i'm on lvm on luks, so it should ask for a password regardless, no?
<nckx>Well damn, I was about suggest passing a raw offset to resume=, but with LUKS in the mix that won't work either.
<f1refly>yeah and because i don't have much space left I can't really repartition...
<nckx>Did you set it as a 'dependency' as you would for a file-system? (Probably, but that's my only idea.)
<f1refly>my root is unencrypted because /gnu/store resides there and i think it was not possible to have FDE with root encrypted when I set it up, but its only 100GiB and I need that space for the store and can't cut out a 32GiB-shaped hole to accomodate my ram :(
<f1refly>did you set it as a 'dependency' <- I'm not sure what you mean? i have (swap space (target ...)(dependencies (mapped-devices)(discard? #t))) in my swap definition list
<nckx>Linux hibernation fails if your RAM is >50% full, so your maximum size is 16GiB, and it's LZO-compressed.
<nckx>f1refly: (dependencies (mapped-devices)) was what I meant.
<f1refly>the swap gets picked up properly as well on boot, given I did not hibernate in which case it fails to activate swap because there's a hibernation signature in there
<f1refly>so everything is well, its just that the kernel tries to resume before the disk is available
<nckx>Except commit ec16f88522041dc285a35705ff9ee95672b78143 should have addressed that.
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=ec16f88522041dc285a35705ff9ee95672b78143
<f1refly>indeed, that seems applicable. is there a way i can debug this?
<ekaitz>efraim: saw your email, yeah! it's very correct
<f1refly>my kernel-arguments are in the form (cons* ... "resume=/dev/mapper/rootvg-swap" ... %default-kernel-arguments)
<f1refly>so that should get picked up, right?
<nckx>Yes.
<nckx>Although my thought earlier about (dependencies ...) was silly. Those don't get resolved until much later.
<ekaitz>efraim: the --tune mechanism, how does it work?
<nckx>But what's odd is that it should still work accidentally, because these dependencies should be smuggled in through your root file system. Does it also have (dependencies (mapped-devices))?
<nckx>We don't do any more set-up between trying to resume from hibernation and mounting root.
<ekaitz>in cross-compilation, should the strip step be removed automatically?
<efraim>ekaitz: half of the magic is in guix/cpu to parse /proc/cpuinfo for the --tune option (without an architecture listed). The rest is in guix/transformations which often wraps the compiler so you'd have 'gcc --march=foo'
<efraim>in place of a regular gcc call
<ekaitz>yeah... and if i need to wrap the zig compiler?
<ekaitz>i think i just need to -Dcpu=foo
<efraim>then the last bit is the compiler-cpu-architectures property on the compiler to say what options there are
<ekaitz>hmmm
<efraim>in the tuning-compiler function in guix/transformations.scm you can wrap zig itself, but I thought if we didn't have -Dcpu=baseline then it'd be -Dcpu=native by default
<ekaitz>yes
<ekaitz>what about the cross-compilations? i had one stripped and it broke the binary
<ekaitz>should I remove the strip step entirely from it?
<efraim>I suppose so, unless there are some strip flags that would reduce the size or separate debug symbols without breaking the binary
<ekaitz>i'm reading other build systems and they don't strip anything
<ekaitz>no, wait
<ekaitz>they don't remove the strip phase
<f1refly>nckx: my root does not have that dependency because.. well, because it doesn not need luks or lvm
<efraim>they probably inherit strip from the gnu-build-system
<f1refly>its a proper physical partition
<ekaitz>(i got mixed when writing the previous message)
<ekaitz>yeah, but that's broken
<ekaitz>at least i just cross-compiled a package and the strip step moved things in the binary and corrupted it
<ekaitz>hmm
<nckx>f1refly: Well, then abuse it to specify your swap dependencies.
<f1refly>will try!
<nckx>'It's crazy but it might just work!'
<efraim>ekaitz: how about the strip flags "--strip-unneeded" "--enable-deterministic-archives"
<ekaitz>hmm
<ekaitz>efraim: those are set by default
<efraim>oh
<efraim>then nevermind
<ekaitz>as the build command is for release, i think the best i can do is just remove the strip phase
<ekaitz>oh it even knows how to cross-strip... and why does it break my binary then?
<efraim>zig knows how to cross-strip or guix knows?
<ekaitz>guix knows
<ekaitz>the gnu-build-system's strip phase reads the target
<ekaitz>and adds it to the objcopy command so it uses the proper objcopy
<lechner>lars` / are the devices you are trying to ping on wired ethernet? your router may be isolating access from wireless devices
<ekaitz>in this case it's using riscv64-linux-gnu-objcopy
<ekaitz>and still, it's screwing the binary
<ekaitz>efraim: http://paste.debian.net/1297958/
<peanuts>"debian Pastezone" http://paste.debian.net/1297958
<ekaitz>oh efraim it only screws up in riscv!!!
<efraim>...because of course it does
<ekaitz>probably because zig doesn't support it very well idk
<ekaitz>i tried with aarch64 and it doesn't break the binary
<lechner>ekaitz / also, the objcopy manual page states Note that objcopy should be able to copy a fully linked file between any two formats. However, copying a relocatable object file between any two formats may not work as expected.
<f1refly>now hibernate works - yay
<f1refly>but now i have to provide my luks password twice and then also my login password - nay :/
<ekaitz>lechner hmmmmmmmmm
<ekaitz>but i mean... we do it in every package in the world
<fury999io>hey everyone how do i know if guix can run on my hardware
<lechner>ekaitz / i might ask in #zig about the risc-v target
<ekaitz>it's not really a priority atm
<ekaitz>it was that i was testing the zig-build-system in a cross-compilation setup
<ekaitz>if the output doesn't work it's not a big problem, it's the build system that I'm testing
<ekaitz>i can test aarch64
<mwette>or ask in #riscv : those peeps are mostly working linux on risc-v
<lechner>ekaitz / we are so lucky that the build system was accepted here!
<ekaitz>lechner: i insisted to civodul and he did
<ekaitz>hehe
<efraim>ekaitz: zig doesn't need a cross-compile toolchain, right? it uses the same zig in all cases?
<ekaitz>efraim: yes, it's just adding the -Dtarget flag
<ekaitz>i'm sending a patch with that rn
<nckx>f1refly: You can probably disable the log-in prompt (don't ask me how, not a Guix option) but the double-passphrase issue is a current restriction.
<lechner>ekaitz / maybe you can use your super powers on this issue also... i have been building all my Guix systems from scratch because our udev subsystem is broken https://issues.guix.gnu.org/63508#24
<peanuts>"[PATCH v2 0/4] Have udevadm look in /etc/udev/rules.d" https://issues.guix.gnu.org/63508#24
<lechner>since May
<nckx>There's a patch on the tracker to include kefiles in the initrd. I have no idea whether that is wise.
<nckx>*key
<efraim>I suppose like that it's most similar to go, which has goarch and goos flags in guix, so I suppose you could add the zig-cpu option like you suggested, have it set to baseline by default, and let the tuning-compiler override it
<ekaitz>lechner: that's probably out of my reach
<ekaitz>efraim: yes, i'll try to do that also
<ekaitz>i have a full branch with all these changes
<ekaitz>i'll send it to you soonish
<ekaitz>:)
<efraim>so based on your patch, it'd be (zig-cpu #f) -> (zig-cpu "baseline") and ,(string-append "-Dcpu=" zig-cpu)
<efraim>does -Dcpu=native work?
<efraim>ACTION has to go
<ekaitz>efraim: that's what I need to check :)
<ekaitz>i'll research a little, leave it well defined and even write the docs
<ekaitz>leave it in my hands
<lars`>lechner: I've tried both wired and wireless devices. All of which are pingable from my laptop. There is a lot more wrong here than just a separation between networks.
<lars`>But I finally managed to ssh into it now, so there is some networking working. It was only possible to do from the router itself (luckily my router is just a Linux computer), any other device is not able to communicate with the phone at all.
<lars`>I've also tried to connect the phone with a ethernet adapter, but it still behaves the same way
<lars`>The route is being set up correctly by dhclient, so I should be able to access the internet, but for some reason I am not. When trying to ping 8.8.8.8 I get a redirect from an ip address belonging to my subnet, but this is an ip that does not exist. It does not belong to any of the other devices on the network and the ip is not present in the dhcp leases on the router.
<pkill9>i wanna contribute more to guix D:
<renato>Hi! I am having some trouble setting up a nice emacs env in Guix for developing Guix packages.
<renato>I followed the guide but emacs is not loading the packages.
<renato>I am talking about "The perfect setup" article in the docs.
<renato>The `guix install eamcs guile emacs-geiser emacs-geiser-guile` command worked.
<renato>After that, running emacs starts without any of those packages installed.
<renato>Some other docs say that installing emacs causes Guix to set EMACSLOADPATH but that has not been set.
<renato>I tried adding `~/.guix-profile/share/emacs/site-lisp` to the `load-path` list in my init.el but that also does not work.
<renato>So I am stuck.
<elevenkb>Hello there, I broke my laptop's screen so I'd like to use it over SSH. The main thing I would like is the capacity to refer to my laptop over SSH using its hostname as opposed to e.g. its IP address.
<elevenkb>How might I accomplish this?
<renato>you mean when connected to the same local network? Did you configure that to use a static IP ?
<elevenkb>renato: Same local network.
<mwette>elevenkb: in /etc/config.scm, (services ... add (simple-service 'add-extra-hosts hosts-service-type (list (host "123.456.789.001" "mylaptop" '())))
<mwette>^ if it's static ip
<elevenkb>I'm not sure if my router maps the same e.g. hostname or MAC address to the laptop after rebooting.
<elevenkb>but yah, thanks for the suggestion. I'm considering using avahi tbqh.
<renato>modern routers let you assign a static IP to any connected device... but I've been able to make my raspberry pi get one even on an older router that didn't have that.
<elevenkb>sorry if my comment was confusing; to clarify I meant to say "I'm not sure if my router maps the same NIC to the same local IP address (e.g. using the hostname or MAC adddress)."
<elevenkb>ah ok, let me have a look at my router's settings for that.
<renato>if you need to know, in the Pi it was in the /etc/dhcpcd.conf file
<renato> https://www.tomshardware.com/how-to/static-ip-raspberry-pi guix probably lets you do something like that but I don't know Guix yet :D here to ask about my emacs issue !
<peanuts>"How to Set a Static IP Address on Raspberry Pi | Tom's Hardware" https://www.tomshardware.com/how-to/static-ip-raspberry-pi
<mwette>I'm trying to debug why some packages in a module in my channel are not showowing up. I'm `guix repl' I have been able to get my channel object. Any idea how to extract available packages as guix would?
<civodul>mwette: there’s a longstanding bug/annoyance: you need to ,use(gnu packages) at the REPL to make channels show up
<renato>Ah! I had not done `guix pull` on my system yet. After doing it, I get the packages alright.
<mwette>As root, what's the difference between the current Generation listed by `guix describe' and `guix package -l' ? The `guix describe' one has a much larger number.
<nckx>They are unrelated, so the numbers don't really matter. 'guix describe' describes the currently pulled guix; every time you 'guix pull' that number will increment. 'guix package -l' describes your default user package profile (here: root's); every time you install/remove/update packages its generation number will increment.
<nckx>'As root' doesn't matter.
<mwette>nckx: thanks!
<nckx>(Or at least, root is no different from other users in this regard.)
<ieure>I got some feedback on one patch I submitted as part of a series. Should I resend the whole series, or just the patch which needs adjustments?
<nckx>Just resend the whole series with 'git send-email -v2 ...'.
<nckx>Oh! And --to=NNN@debbugs.gnu.org
<ieure>Right. Cool, thank you.
<nckx>You know; the stuff.
<ieure>Yep.
<ieure>Just wasn't sure whether I could get away with the patch for the one in the series that needed the change or not.
<nckx>IMO that would complicate things for reviewers/committers for no reasonable benefit on your end.
<lechner>lars`` / this is a bit out of scope for this channel but the folks here usually don't mind. by "ip from your subnet" do you mean a private address or an address within your (or rather, your isp's) public ipv4 address block? https://en.wikipedia.org/wiki/Private_network
<peanuts>"Private network - Wikipedia" https://en.wikipedia.org/wiki/Private_network
<lechner>lars`` / also, do your ISP or your router spoof DNS responses? what are your router software and the name of your ISP, please?
<lechner>lars`` / finally, does your router advise DHCP clients on which gateway to use (option 3)? https://www.incognito.com/tutorials/dhcp-options-in-plain-english/
<lechner>the DNS thing probably does not matter, actually
<jbnote>hi guix, is there a simple way to execute a patched guix from a modified source tree without pushing a commit to git and doing a 'guix pull' from it? i'm trying to patch WSL image creation and the whole git commit; git push; guix pull; iteration is very slow. I've tried guix system -L ~/src/guix image build ... but it fails somehow.
<ieure>jbnote, Does the manual's "Running Guix Before It Is Installed" section cover what you want? https://guix.gnu.org/en/manual/devel/en/html_node/Running-Guix-Before-It-Is-Installed.html
<peanuts>"Running Guix Before It Is Installed (GNU Guix Reference Manual)" https://guix.gnu.org/en/manual/devel/en/html_node/Running-Guix-Before-It-Is-Installed.html
<ieure>(See also the previous, "Building from Git," which has steps essential for this to work.)
<lechner>jbnote / the ./pre-inst-env may be what you are looking for
<Andronikos>Maybe this https://git-send-email.io/ would be something for the docs about how to configure git send-email for beginners. Though we would require to send a patch for GNU Guix.
<peanuts>"Learn to use email with git!" https://git-send-email.io
<Andronikos>or we just make a small section for setting it up.
<jbnote>ieure: thanks, that's perfect
<jbnote>lechner: thanks also
<ieure>jbnote, Glad to help. :)
<nathan-web>How can I find the cause of this error when I run `guix system -L ~/system/ reconfigure ~/system/nls/sytems/base-system.scm`:
<nathan-web>"error: base-operating-system: unbound variable
<nathan-web>hint: did you forget a `use-modules' form?"
<nathan-web>`base-operating-system` isn't used at all in this file, it is defined there via `(define-public base-operating-system ...)`
<lechner>nathan-web / please post ~/system/nls/sytems/base-system.scm via a pastbin site
<Andronikos>Is it possible to setup Git global with a different username/email for specific repositories?
<lechner>Andronikos / this does not work? ~/system/nls/sytems/base-system.scm
<lechner>sorry, https://stackoverflow.com/questions/42167345/git-set-local-user-name-and-user-email-different-for-each-repo
<nckx>Huzzah, I have fixled bayfront (seems like the new bffe service is to blame?) so it's now useless with a *different* error. https://bordeaux.guix.gnu.org/api/queue?nr=1000
<nathan-web>lechner: pastebin.com/LB53EyRc
<nckx>You're *welcome*.
<Andronikos>This looks promising https://www.freecodecamp.org/news/how-to-handle-multiple-git-configurations-in-one-machine/
<peanuts>"How to Use Multiple Git Configs on One Computer" https://www.freecodecamp.org/news/how-to-handle-multiple-git-configurations-in-one-machine
<nckx>Andronikos: Global? No, I don't think so.
<nckx>Oh.
<nckx>Well.
<nckx>Yes, I think this is possible.
<nckx>There.
<Andronikos>Not exactly how I imagined this is handled but I test it out and see if it works.
<nckx>(Why must it be global though?)
<Andronikos>nckx: In case I reinstall my system, I just clone guix again and don't need to think about setting my correct credentials. More error prone for me at least.
<nckx>HmIsee.
<Andronikos>ieure: Did you setup git-credentials with pass? Does it actually require that password=<your-password> notation or can I only have the password itself?
<ieure>Andronikos, I haven't set it up yet. My understanding is that it has to have the password= stuff in its output, but I sure would love to learn otherwise.
<ieure>I forget the name, but I used to run a local MTA that only forwarded messages to my mailhost's SMTP box. Thinking of setting that up again, since I have multiple programs that need to send mail and configuring each of them is irksome.
<zamfofex>Is there any way to define a suffixe for search paths? E.g. for Lua search paths.
<zamfofex>suffixes*
<Kolev>How do I package a shell script?
<zamfofex>Kolev: An example is fff: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/disk.scm#n928
<peanuts>"disk.scm\packages\gnu - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/disk.scm#n928
<Kolev>I want Simgal. https://hack.org/mc/projects/simgal/
<ieure>Kolev, You probably want trivial-build-system with all the phases other than install removed, and to use install-file to copy the script to the output dir.
<Kolev>Sounds complicated. I'll just shove it into ~/.local/bin.
<Andronikos>Kolev: If it is just a simple shell script, there is copy-build-system which basically just copies the shell script in the output. Therefore you have it in your path and can run it like a executable.
<Kolev>Hm. Looks like it depends on `jhead` which Guix does not have.
<Kolev>Is there another photo album generator I could use that's in Guix?
<Kolev>Thumbsup is not packaged either. Hm.
<Kolev>Oh hell, Thumbsup is NPM.
<Kolev>Franciman, still can't install. https://issues.guix.gnu.org/66786
<peanuts>"Failed to install" https://issues.guix.gnu.org/66786
<lechner>nathan-web / This page is no longer available. It has either expired, been removed by its creator, or removed by one of the Pastebin staff.
<Andronikos>If a package has a tarball which can be verified, this needs to be done once manually by the person that packages it, since through the hash it is guaranteed to be the intended files?
<Andronikos>as of, it is not required to check in the package definition itself (to verify I understood this correctly)