IRC channel logs

2023-11-06.log

back to list of logs

<mrh57>is there a way to to pin a build system, and use that to build a package?
<Kolev>Does anybody have issues joining MUCs in Poezio?
<stikonas>hmm, has openjdk hash changed upstream? https://paste.debian.net/1297271/
<peanuts>"debian Pastezone" https://paste.debian.net/1297271
<stikonas>somehow guix reports mismatch...
<lechner>Hi, what's the best way to get pinyin input going via Guix Home in the standard gnome-desktop, please? Any method is fine. My son needs it for his homework. Thanks!
<mrh57>is there a way to set environment variables with guix shell?
<singpolyma>guix shell -- env ?
<apteryx>podiki: you can fold it to core-updates if you want, but it's up to you
<podiki>apteryx: I ungrafted nghttp2 and curl along the way; libx11 hits python and thus rust (who knew)
<podiki>i've built through mesa locally, was trying to do sdl2 (with a patch and then see about an update) but i'm churning away in rust land now....
<podiki>so it is not every package in the world but is a whole lot. still, i think pretty "safe"
<sundbry>mrh57: I just use .envrc with `use guix` for this
<mrh57>sundbry: okay that seems like a decent way, just a bit surprised that there's no direnv-esque functionality built into guix shell
<mrh57>would also be nice if it could be done with manifests
<podiki>i think it would be a nice addition, some comments have come up about that, or other ways of specifying options to guix shell through a file
<Kolev>Where do I define env vars?
<apteryx>with something like this: https://paste.debian.net/1297278/
<peanuts>"debian Pastezone" https://paste.debian.net/1297278
<apteryx>if you meant globally for all users
<apteryx>otherwise in your ~/.bash_profile or similar
<Kolev>apteryx: i put vars in .profile but sway did not see them
<efraim>I believe our gcc-objc{,++} packages are broken, I'm pretty sure they're supposed to use gcc as the front end, but we strip it out
<adanska>im trying to add a file system to guix. I've created an exfat partition labelled 'my-share' and added an entry to my file-systems field in my config that looks like this: https://paste.debian.net/1297289/ however, reconfiguring throws an error that guix cant find a file system with that label `ls /dev/disk/by-label` shows its there, though. what could be going wrong?
<peanuts>"debian Pastezone" https://paste.debian.net/1297289
<elevenkb>Hello there, does anyone know how to package a Rust crate which has some of its directories live as separate crates.
<elevenkb>i.e. one that uses path= declaractions in its Cargo.toml?
<efraim>elevenkb: does 'guix import crate ' do the right thing?
<efraim>you can use substitute* to change it to be like the others which don't use path=, but I normally leave it and just provide the packaged crate as an input and see if it can figure it out
<elevenkb>efraim: no not really, the subcrate (is that a word?) is published both on crates.io and as a part of the main crate's source code.
<efraim>is the main crate on crates.io?
<elevenkb>yes.
<efraim>then I'd just package the main crate and not package the subcrate
<efraim>I assume this means you need to go through crate by crate to find the dependencies; newsboat is packaged like that
<elevenkb>:-o
<efraim>newsboat only has 4 sub-crates so it's not so bad
<efraim>I guess if the subcrates are packaged on crates.io then you could import them each and then manually merge the inputs
<elevenkb>What I tried for now is definining packages for the subcrates which use local-file for their package-source.
<elevenkb>Trouble is that when I build the subcrates aren't found... when I substitute the path= declarations for normal declarations the packages don't end up in the guix-vendor folder.
<elevenkb>I'm now trying to build with path= declarations to remind myself of the problem that happened there.
<civodul>Hello Guix!
<elevenkb>Yah the package compiles but cargo package --no-metadata --no-verify doesn't work.
<efraim>elevenkb: add #:install-source? #f for the package, it's supposed to be useful for along the way to a final package
<elevenkb>efraim: Thanks, tryin' that right now.
<elevenkb>daydream: guix but for a lisp machine.... so that you don't have to rebuild from scratch every time you change your package or package definition. :D
<elevenkb>efraim: A successfull build! Thank you so much.
<efraim>yay!
<efraim>well that's unfortunate, gcc-boot0 changes its hash when the enabled-languages flag gets changed, even though it gets removed
<cbaines>morning o/
<sneek>cbaines, you have 1 message!
<sneek>cbaines, jackhill says: congrats on the blog post (and the grant)!! A typo: "switching between the C++ implementation and Guile implementation which any issues" → "without any issues"
<efraim>it seems everyone found that typo :)
<cbaines>indeed :)
<Guest42>Hi, I'm trying to switch a C++ compilation process  from Debian/Ubuntu context "into" Guix. I'm a beginner with guix and I can't find (the?) documentation for simple questions like the following : "How can I check if a specific file (not package!) is available in my guix profile ?
<Guest42>the "dpkg -S" guix command, and after that, the "apt-file search" ;-)   Would be hppyy with juste a link to documentation. Seems [to me] that the reference manual doesn't tackle with such considerations ...
<efraim>we have the 'guix locate' command, which will let you know if you have a file in your profile, but currently nothing like apt-file which can tell you where a file comes from if you don't already have it
<cbaines>Guest42, the profile is just a directory, so you just use your prefered way of checking if a file exists
<cbaines>here's some bash to check for bin/nc for example: test -f ~/.guix-profile/bin/nc && echo "Yes"
<Guest42>Ok, this is what I tried, and it fails. So, the file is not there. The question is now :  The boost package doesn't come  with the "boost-dev" part  (headers) ?
<efraim>It looks to me like boost comes with its headers in the main package, are you checking in include/boost?
<Guest42>Yes, I find (now) with guix locate  ;-)
<Guest42>What's the best way to rewrite an existing CMakeFiles in order to look at these directories ? Sorry, I'm googling with "cmake guix converting" keywords without great success
<Guest42>(CMakeLists.txt)
<Guest42>Ok, I'll try to switch all my compilation chain into guix before asking (maybe stupid) questions ;-)
<gabber`>which ones are python packages that are used as modules (for `import foo from bar`) and provide (command-line) binaries as well?
<efraim>I don't think we have a list
<gabber`>i was more hoping for somebody online here knowing a nice example
<efraim>radicale
<gabber`>thanks!
<gabber`>also - on other news - i've checked, reviewed, rebased and re-sent a fix for #48018 if anyone with committing rights wants to merge that...?
<peanuts>"ImageMagick?s ?convert? fails to delegate to ?dwebp?" https://issues.guix.gnu.org/48018
<crole>I've been unable to lock my screen in guix system for some time; wondered about that lately
<gabber`>crole: how have you set it up? what desktop are you using?
<gabber`>it's probably a setuid related thing
<mrh57>is there any documentation for getting pipewire working on guix?
<gabber`>mrh57: i think you'll have to start it manually
<crole>gabber`: let me remember how i can find this real quick--something about guix system edit desktop, right
<gabber`>which part? it should all be in your system config file
<mrh57>isn't pipewire a user level service?
<gabber`>mrh57: no(t yet)
<mrh57>right lol I guess it's not a guix "service" on any level, I just mean isn't it meant to be started/managed at the user elevenkb
<gabber`>mrh57: in my setup i start it (from the sway config file) at login, e.g. `exec --no-startup-id pipewire` and `exec --no-startup-id pipewire-pulse`
<mrh57>*user level
<gabber`>mrh57: yes, that's why i wrote "start it manually" ;)
<crole>oh, mine's pretty simple--thought it wouldn't be. i simply have (service xfce-desktop-service-type) and then a modification for gdm to not auto-suspend
<mrh57>mm okay so that should be working, good to know. I was starting it exactly like that in my river config but getting errors about "also: resource busy" when trying to play multiple audio sources at the same time
<gabber`>crole: which screen lock are you trying to use (sorry, i have almost no knowledge about xfce)
<mrh57>*alsa
<gabber`>mrh57: you might also need to add your user to some groups (e.g. audio, realtime, etc)
<mrh57>gabber: realtime o.O
<mrh57>gabber: I'll try that (already in audio group)
<mrh57>gabber: since you use sway I'll take advantage: if you use a laptop, how do you get swaylock to trigger on lid close/suspend?
<crole>same here. i believe i followed some advice for getting xfce on here just so i could get anything on here at all, and i forgot where that was recommended. that makes sense, though
<gabber`>mrh57: i have not done that (so far)
<crole>maybe i'll add slock or something and go from there--it worked previously, but i dunno what changed.
<gabber`>crole: have a look at screen-locker-service-type in the reference manual, this might clarify/simplify further advances
<gabber`>issues.gnu.guix.org seems to be down
<crole>aha, neato.
<crole>thanks, gamers
<charlotte112351>hi, how can i do the bootstrap from hex0? i love you guys but i wanna see it for myself that there's no thompson trickery hidden anywhere
<gabber`>charlotte112351: i think this is explained in full detail in chapter 20 of the Reference Manual
<charlotte112351>so cool
<charlotte112351>another question: where do you put packages? as in, publicly publish
<charlotte112351>i love scheme and i come from nixos, i will package so much shit for you its gonna be unreal
<gabber`>charlotte112351: if they are compatible with Guix (and/or GNU) philosophy, i'd try to get them merged in Guix' upstream. otherwise you can use other (or create your own) channels
<charlotte112351>nixos tried to make me create github account lmao, this is why i couldnt contribute there
<charlotte112351>is channels sort of like flakes, where with the url anyone can get my packages hosted wherever?
<gabber`>all you need to contribute here is knowledge on creating git patches and an SMTP configuration (aka the ability to send email)
<gabber`>i have no clue about NixOS - a channel is a guix module that provides Guix with package definitions.
<charlotte112351>is public domain/CC0 compatible with GNU philisophy? also: do disgusting nongnu packages, or any other channels packages really, still live inside the /gnu/store
<charlotte112351>email is great thank you for providing a path to contribute i am willing to take
<gabber`>and to really answer your initial question (though the execution might take some time): i think $(guix build bootstrap-tarballs --no-substitutes) builds the whole bootstrapped toolchain
<charlotte112351>is there like a todo list of pkgs that need packaging? something like a whishlist?
<charlotte112351>wow i will try this and examine what it does
<gabber`>all things that guix makes available to the system or a user goes into the /gnu/store - no matter which channel it comes from
<charlotte112351>i am considering going through the pain of replacing proxmox with guix - is this viable? i think i saw ceph and ganeti packaged. what about zfs and stuff? am i going to suffer or is it going to be managable?
<gabber`>there is a wishlist at https://libreplanet.org/wiki/Group:Guix/Wishlist
<peanuts>"Group:Guix/Wishlist - LibrePlanet" https://libreplanet.org/wiki/Group:Guix/Wishlist
<charlotte112351>thank you
<gabber`>it's relatively hard for me to estimate your suffrage, but zfs and zfs-auto-snapshot are packages for guix
<gabber`>*packaged for or *packages in
<charlotte112351>how much does guix rely on guile specific features? i have a complete r4rs scheme implementation, i was thinking it would be super cool if i could make guix use my own scheme
<dthompson>charlotte112351: it uses a lot of guile specific things. standard scheme doesn't offer much in terms on real-world usability.
<dthompson>and I would expect you'd need at least good r5rs compliance to begin to have a chance.
<dthompson>in terms of*
<charlotte112351>guess it doesnt make too much sense. what about using a different init system? or is shepherd very deeply integrated
<gabber`>charlotte112351: i have a feeling that you might get to love shepherd relatively soon
<gabber`>i'm sure you can get (your) Guix to do pretty much whatever you like, though the system (as it currently is) fits many use-cases
<charlotte112351>could you sell me on shepherd? i wanted to use hacked suckless init thing with my scheme buildt in, but if there is something well thought out and developed i am all ears
<gabber`>charlotte112351: i'm not a sales person. but since you're about to try it yourself i think you'll figure it out soon. shepherd is built into guix - it's the least pain to get a (bootstrapped) system up and running and start hacking
<civodul>with my latest upgrade, emojis in Emacs M-x emoji-insert have gone all flat and black & white
<civodul>what’s the deal?
<gabber`>civodul: might be a font issue?
<charlotte112351>how much control do i get over the file system? i like plan9 and i have some stuff planned on layout of all my stuff as files.
<charlotte112351>civodul: D: it sounds like font issue, yeah
<gabber`>issues.guix.gnu.org is still down (should i ping someone specifically or write an email about that?)
<jpoiret>gabber`: as long as guix.gnu.org is up, any of the sysadmins could look at it
<gabber`>ACTION has no clue who exactlyissues.guix.gnu.org is still down (should i ping someone specifically or write an email about that?)
<gabber`>whoopsie
<gabber`>i have no clue who the sysadmins are
<jpoiret>if guix.gnu.org is also down, it might be an issue at the hosting site (the MDC). If gnu.org is down, then it's most likely a GNU problem
<civodul>gabber`, charlotte112351: yes but i have the same font packages as before, so i suspect one of them was upgraded and got a “face lift”?
<jpoiret>I don't remember exactly either. rekado is one, civodul as well iirc
<gabber`>jpoiret: i think it's only issues.g.o (502 Bad Gateway)
<civodul>ACTION looks
<civodul>it got things like: GET /issue/15284/attachment/0/_head.php?_zb_path=../../../../../../../../../../etc/passwd%00 404
<gabber`>ewww
<gabber`>it's back up now (:
<jpoiret>civodul: ouch
<civodul>i guess it’s business as usual
<jpoiret>why would anyone want to host a website
<civodul>anyway, “sudo herd restart mumi” on berlin
<civodul>the admins are lurking here or, as a last resort, you can email guix-sysadmin@gnu.org (private mailing list)
<civodul>jpoiret: yeah, better leaves that to the companies that know!
<janneke>podiki: ah yes, test/data/disabled probably works
<sneek>Welcome back janneke, you have 2 messages!
<sneek>janneke, podiki says: for skipping a test in curl/fixed for hurd, is there a reason the test number wasn't added to test/data/disabled like the others? (working on ungraft)
<sneek>janneke, podiki says: oh, I guess the ~ (run but don't use output) doesn't work in tests/data/DISABLED? (sorry if sneek did this twice)
<janneke>hmm?
<bonmlp>I set up a Guix VM and now I am accessing its file system from an Emacs which is running on my laptop using TRAMP. Some problems are arising such as TRAMP not finding the ls command and magit not finding the git command. I am trying to solve these one by one but I wonder if someone else has solved this already?
<gabber`>can i (ab-) use the git-download facility to use a git repository on disk? or make (source (local-file "some/path")) recognize changes on disk?
<gabber`>i was using the latter but realized local changes didn't always(?) make it to the store
<luke-jr>master fails to build rust it seems; is there a way to system reconfigure using an older commit or something?
<rekado>oh, issues.guix.gnu.org was down? Any idea why?
<rekado>civodul: I also see font weirdness in Emacs. My doom modeline icons no longer show up.
<Lumine>rekado: I had that same problem, nerd-fonts replacing all-the-icons was the culprit, so I got emacs-nerd-icons
<Lumine>ie. doom modeline icons fixed now
<Lumine>Assuming you were using them that is
<lucypoo>Hey there, does anyone know how to replace the python package used in the python-build-system in an ad hoc manner? the replacement function used in the build system definition is not exported
<gabber`>to get to not-exported function in guile you can use (@@ (gnu module foo) hidden-function)
<lucypoo>oh sweet
<lucypoo>thanks
<lucypoo>hacks
<lucypoo>with the "@@"-s?
<gabber`>?
<rekado>Lumine: oh, nice. Thanks for the hint!
<Lumine>rekado: :)
<luke-jr>I don't get how people actually use guix when it's so broken out of the box
<pkill9>broken in what ways?
<luke-jr>first it tries to update guix from some non-existent /home/ludo path; then rust tries to access files inside a tar.xz without extracting it
<gabber`>how did you install your guix?
<luke-jr>downloaded the VM image from the site
<gabber`>luke-jr: to your initial question: i think most people here don't use the vm image.
<gabber`>and i'm not sure about the spread of rust packages here. but the '/home/ludo/' path sounds like a bug
<gabber`>if you provide us with more info (what are you trying to do, what are you executing, and output messages/logs of the commands) we might be able to help you get things done
<jpoiret>`guix describe` could probably help!
<luke-jr>just trying to get an updated system install going I can SSH into
<luke-jr>guix system reconfigure --no-grafts --no-substitutes --no-offload -c 1 -M 1 config.scm
<gabber`>i'd guess the from-the-shelf VM image should let you ssh in
<civodul>luke-jr: /home/ludo? how can i reproduce that?
<jpoiret>the vm image probably has openssh available ootb no?
<gabber`>luke-jr: did you $(guix pull) first?
<luke-jr>gabber`: yes, though guix system reconfigure seems to do that itself too
<gabber`>civodul: i guess you already have that on your machine :P
<gabber`>luke-jr: no, it does not
<jpoiret>gabber`: it can
<jpoiret>depending on the configuration of the image
<gabber`>huhb
<jpoiret>(current-guix) can do something very similar to `guix pull`
<gabber`>my bad
<jpoiret>I've had that happen to me too, but I couldn't ever figure out why, since i don't use (current-guix) in my config
<luke-jr>IIRC I copied the VM image's current config to make the config.scm file
<jpoiret>luke-jr: what's `guix describe`?
<jpoiret>does it mention /home/ludo/?
<jpoiret>the default vm config does use (current-guix)
<lucypoo>gabber: apologies if you replied but ( @@ ( guix build-system python) python-with-explicit-python) does not work for me
<gabber`>luke-jr: you may also share your config (through a pasteboard)
<lucypoo>maybe to do with ( define*) being used
<lucypoo>it workd with an exported module
<lucypoo>is this to be expected?
<jpoiret>lucypoo: non-exported functions can sometimes get inlined by the compiler, so they're not present in the resulting code and you can't @@ them
<lucypoo>ah thanks
<bonmlp>luke-jr: I tried all that with the VM and gave up on it. The documentation could be clearer. I got a working version by downloading the ISO, making an image with qemu and booting the ISO into it. That led to a clean build.
<luke-jr>Generation 2 Nov 06 2023 14:45:12 (current) guix 8e2f32c ...
<luke-jr>but I already hacked the file in /gnu/store that referenced /home/ludo, so idk what it would ahve said before
<jpoiret>luke-jr: `guix describe`, not `guix system describe`!
<luke-jr>yes, that was `guix describe` O.o
<jpoiret>oh sorry
<jpoiret>mb
<jpoiret>you shouldn't ever modify files in /gnu/store yourself
<gabber`>8e2f32c is v 1.4.0
<jpoiret>it's mounted read-only for that reason, guix expects files in there to never ever change
<luke-jr>jpoiret: I didn't get any response the other day when I encountered this initially :/
<luke-jr>it's not mounted read-only O.o
<jpoiret>that's weird then
<luke-jr>anyway, that was the only change I made in this system
<gabber`>/gnu/store is usually not mounted separately, i think -- therefore not mounted read-only
<luke-jr>kinda figured it'd go away when I finally got system reconfigure to work
<gabber`>but it should be not-that-easy™ to modify store content
<gabber`>luke-jr: on a fresh installation i would always $(guix pull) then $(guix system reconfigure old-config.scm) and then modify the config and reconfigure again
<luke-jr>so is this hopeless and I should just try again from teh IOS?
<luke-jr>ISO*
<gabber`>this might be easiest/fastest
<jpoiret>gabber`: it is, %immutable-store is in %base-file-systems
<gabber`>jpoiret: but $(df -h) does not list that path in my system..?
<gabber`>and the daemon needs to write there anyways - which i guess would not be possible on a read-only mount?
<gabber`>please enlighten me (:
<jpoiret>gabber`: have a look at `mount` instead
<jpoiret>the daemon can create a new mount namespace in which it will remount it rw
<gabber`>ACTION feels enlightened
<gabber`>thanks!
<jpoiret>this way, even root can't write to /gnu/store without going through some hoops
<gabber`>aaaahhha! $(df -a) lists *all* entries (including /gnu/store)
<luke-jr>more than mount -o remount,rw ?
<luke-jr>how do I tell the ISO installer never to use substitutes? -.-
<gabber`>you can pass --no-substitutes to build commands
<gabber`>
<luke-jr>ie, get out of the graphical installer XD
<luke-jr>bleh, it wants to do rust again; hopefully it works this time
<luke-jr>bah, it failed already
<civodul>luke-jr: the graphical installer offers an option right at the beginning to jump to a shell
<civodul>(in the first or second menu)
<civodul>alternatively, you can hit ctrl-alt-f3 or similar to get a console
<civodul> https://guix.gnu.org/manual/en/html_node/Manual-Installation.html
<luke-jr>...because of the freaking apache changing paths
<futurile>As a point of style in in package descriptions do you think it is: "this package's crate does blah...." or "this crate does blah" - it's a Rust crate ofc
<civodul>futurile: “This package does blah” maybe?
<futurile>OK - so in our minds it's a 'package' now and no longer a crate - fair enough
<civodul>yeah, dunno
<futurile>at least I'm not alone - I really hate 'this packages crate' it's literally 'this boxes smaller box contains ....'
<futurile>(it may be on my mind because Amazon literally just delivered a big box, with a teeny tiny box inside it)
<civodul>heh :-)
<lucypoo>internet on the blink grrr
<lucypoo>anyone familiar with the python build system know why the build phase invokes python as "python" and not "python3", just replaced the python version but python is present as "python3" and not "python"
<gabber`>python3 is the name of the binary of the python package. for plain python you need the package python-wrapper
<gabber`>IIRC
<lucypoo>ah, just replaced python 3.10 with 3.12, i would have thought python-wrapper would remain if it is an input to the build system
<lucypoo>just checking if that is currently an input to the build system
<gabber`>WDYM with "remain"?
<lucypoo>i used package-mapping to replace the python version used in the build system so if python-wrapper was an input to the python build system perhaps it would remain as such, just built with python 3.12
<lucypoo>python-wrapper is present in guix/build-system/python thanks, just investifating
<lucypoo>yep absolutely, python build system uses defualt-python... by default and that is a lazy load of python-wrapper
<lucypoo>thanks
<lucypoo>so need to rebuild python-wrapper with 3.12, then replace python with that
<gabber`>you could also invoke (wrap-python3) with a reference to that specific python version, no?
<gabber`>well, i guess those 2 statements are equivalent
<lucypoo>ah ok thanks, didnt know of that func
<lucypoo>gabber: gotta dash, thanks! have a nice day
<luke-jr>guix system: error: linking '/gnu/store/mnyi5...-module-import.drv.chroot/gnu/store/...-syscalls.scm' to '/gnu/store/...-syscalls.scm': Operation not permitted
<gabber`>luke-jr: what command did you invoke?
<lizog>tux1c, GNUtoo: i use bisect and found out the glibc cve fix somehow breaks the cross compilation: http://git.savannah.gnu.org/cgit/guix.git/commit/?id=1328c4cca531318e3ed90c6aecb522a5b22a4bcc
<peanuts>"guix.git - GNU Guix and GNU Guix System" http://git.savannah.gnu.org/cgit/guix.git/commit/?id=1328c4cca531318e3ed90c6aecb522a5b22a4bcc
<voroskoi>I would like to add ~/.guix-profile/share/guile/site/3.0 to GUILE_LOAD_PATH permanently
<voroskoi>.guix-home and /run/current-system is already there, but this one is missing
<voroskoi>where are thos env vars set up?
<jpoiret>voroskoi: you need to install `guile` in that profile then
<jpoiret>the package guile declares a search path for GUILE_LOAD_PATH, meaning that whenever it's installed in a profile, it will add that env variable when the profile is loaded
<voroskoi>jpoiret: i see, thanks
<Elouin>Hi, i just changed the sshd port on one of my server via `deploy`, after the change was made, i changed the port in the machine definition and now i get `not known` error when running `guix deploy`.
<Elouin>Any hints?
<jpoiret>can you ssh in manually?
<Elouin>yes, that works.
<Elouin>with the new port
<luke-jr>gabber: guix system init config.scm
<Elouin>Full error message: https://paste.debian.net/plainh/261bdfac
<lispmacs[work]>hi, I was wondering what is going on with Stellarium. weather says that it is not available as a substitute, but yet there seems to be a build of that version made last month on one of the subst servers?
<lispmacs[work]>I was a bit nervous about trying to build that package on my system
<lispmacs[work]>gnome always crashes when I try to build large packages
<efraim>lispmacs[work]: what commit are you on? I can queue it up on berlin
<nckx>Elouin: I don't use guix deploy, but you need to SSH as the same user and arrept the host key so the client's 'known_hosts' file is updated. Entries are per host:port, not per host, so changing the port invalidates the trust.
<nckx>*accept
<efraim>or perhaps they have ControlMaster and co set, so it's caching the connection
<lispmacs[work]>efraim: 3f83dc5587573f173b1f61864c9b510f05de84b1
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=3f83dc5587573f173b1f61864c9b510f05de84b1
<nckx>efraim: Possible, if Guix and ssh(1) don't follow the same control master rules.
<nckx>I though Guix respected the user'sxssh config.
<efraim>I'm pretty sure Guix doesn't use the control master rules, in my uninformed opinion™ it's why using GUIX_DAEMON_SOCKET is so slow
<nckx>Aha.
<efraim>lispmacs[work]: stellarium is built, it might take a few minutes for the substitute to be prepared
<lispmacs[work]>efraim: okay, thanks
<lispmacs[work]>efraim: should I see the substitute with guix weather?
<efraim>lispmacs[work]: hopefully soon
<nckx>Yes, although substitute availability is cached. In /var/cache/guix/substitute or so.
<lispmacs[work]>nckx: there doesn't appear to be a /var/cache/guix on my system
<nckx>I'm not sure of the exact location.
<efraim>there's another one in ~/.cache/guix/substitute
<nckx>Just to make it more fun.
<lispmacs[work]>I see a bunch of stuff there, yes
<nckx>Unalive it.
<lispmacs[work]>?
<lispmacs[work]>I'm seeing Stellarium now on ci
<zamfofex>‘rm -rf ~/.cache/guix’
<efraim>time to work on my pseudo-tmpfs home service, to allow mounting certain directories in XDG_RUNTIME_DIR so they get wiped on reboot
<Elouin>nckx: thx for the hint. simply sshing into the machine wasnt enough. had to remove the entry from the known host...
<Elouin>Thats definetly not intuitive and changing ssh ports ist something that propably some people do. Maybe a hint for this something would be nice.
<nckx>Feel free to open a bug. (Note that Guix merely uses SSH, we're not the ones choosing what's intuitive.)
<nckx>But I agree!
<panosalevro>hi all. probably an easy answer to this but I can't find it. after doing a `guix home reconfigure`, how do I enable that home environment? I didn't use a container
<nckx>Whoever can help you will benefit from knowing what you mean by 'enable' in this case. Home environments, like Guix Systems, replace the old one, but I suspect that old services & environments aren't, respectively can't, be replaced.
<Kolev>How do I run my personal scripts? I can't add ~/.local/bin/ to $PATH.
<panosalevro>right, let me be more clear. I expected to be able to use the packages that I installed with `guix home reconfigure`, but they are not available
<nckx>Kolev: Well, I add ~/.local/bin to $PATH in my ~/.bash_profile so...
<Kolev>I know none of this is the Guix Way but I can't get my current setup running under Guix Home. https://codeberg.org/csh/dotfiles
<peanuts>"csh/dotfiles: My public configuration files. - dotfiles - Codeberg.org" https://codeberg.org/csh/dotfiles
<nckx>ACTION stumbled in on Guix Home Hour, again. Hisses. Scurries.
<Kolev>nckx, I'm just using a plain GNU Stow directory with a plain config.scm.
<Kolev>nckx, so `PATH="$HOME/.local/bin:$PATH"` will work?
<nckx>~ λ grep PATH .bash_profile
<nckx>PATH="$HOME/.local/bin:$PATH"
<nckx>It's no CoolSH, but I make do.
<Kolev>nckx, I put it in .profile but it doesn't work.
<nckx>I'm not familiar with csh or your system.
<nckx>This does require csh to be your log-in shell.
<nckx>Guix's default .bashrc has this snippet: http://paste.debian.net/plain/1297366
<fjl>Hi, Looks like I did something wrong while sending patch series. By running `git send-email --cover-letter --cover-from-description="subject" --to="guix-patches@gnu.org" HEAD^^` I expected everything to go together, but I opened 3 separate tickets 66974, 66975 and 66976. No idea why.
<nckx>The manual describes, ~somewhere~, the correct way to send patch series to our Very Special bug tracker.
<nckx>Essentially you send the cover letter, wait for a reply with a bug number, say N, then send the series to N@debbugs.gnu.org.
<fjl>Thanks!
<nckx>I'll merge the bugs, no need to resend IMO (although users of QA might disagree).
<fjl>That would be great. I was about re-send the headless series to cover letter bug number email, but if you could fix it is even better.
<fjl>I found the section that I missed in the friendly manual.
<fjl>There is subsection "22.6.2 Sending a Patch Series"
<fjl>@nckx It looks like after the merge only last patch is visible now
<fjl>nckx:
<fjl>I seem, it's in folded "Details"
<nckx>That's just our bug tracker [front-end].
<nckx>It's erm
<nckx>well it's a thing.
<Kolev>Still having issues with PATH.
<Kolev>nckx, BTW csh is just my personal user account, my initials.
<Kolev>Nothing to do with the shell csh.
<nckx>ACTION lols quietly.
<rdrg109>[Q] People that read MOBI files under Guix, what packages from that Guix repositories you have installed for reading such files? I know calibre can open MOBI files, but I don't want to install a multi-purpose application just for reading a MOBI file.
<civodul>cbaines: hi! looks like qa.guix automatically rebases issues (nice!), but when it does so, the previous build results become unavailable (“Yet to process revision”)
<civodul>is there a way one could get at the previous results?
<civodul>also, i think we should reduce cross-compilation targets to say: aarch64-linux-gnu, x86_64-w64-mingw32, and i586-pc-gnu (other targets are mostly redundant)
<civodul>uh, ‘cuirass remote-server’ had gone awry on berlin, had to restart it
<Kolev>Swaylock doesn't work. 2023-11-06 16:40:01 - [source/pam.c:16] swaylock is setuid, but was compiled with the PAM backend. Run 'chmod a-s swaylock' to fix. Aborting. https://codeberg.org/csh/dotfiles/src/branch/main/config.scm#L76
<nathan-web>I just made a bunch of changes to my config and did an update. Logging in to gdm resulted in a fatal error with no error details and my only option was to log out. I tried using sddm with wayland instead, and logging in just kicks me back to the login manager. Any ideas on what might be wrong?
<nathan-web>But I'm not sure what to do about that - it shouldn't be using systemd at all