IRC channel logs

2023-10-15.log

back to list of logs

<mirai>grrr, this nss irreproducible issue is infuriating
<mirai>I think I narrowed down what/where the thing is diverging
<mirai>but I don't think mining/defeating the built-in RNGs is a good idea just to get consistent HMAC signatures on those .chk files
<mirai>It's more tempting to just replace shlibsign with something that does the same but with RNG=/dev/zero
<jaeme>Is there anything I should do after sending a patch?
<jaeme>Or do I just wait for it to be reviewed?
<TehBoss>is there a way to get guix to run os-prober?
<TehBoss>so the grub can autodetect the other distro i have installed
<lilyp>jaeme wait for review
<lilyp>if it's your first submission wait for it to appear before review (we have spam filters)
<lilyp>TehBoss: even if it did (we'd have to do so on the installation CD) you still need the right magic for the config.scm
<lilyp>but perhaps os-prober supplies enough information to figure that out?
<avalos>rrobin: regarding my issues with texinfo and stuff, I think what happened was that my laptop ran out of battery and went off while I was doing a `guix pull`, so maybe the build got corrupt?
<avalos>I could reconfigure after deleting texinfo using `guix gc`.
<avalos>Now I can't run `herd` because it's an empty file no matter how many times I reconfigure my home.
<avalos> https://convos.avalos.me/file/1/ScAt23fxTaT9wW5J
<TehBoss>lilyp: well is there a way to set the grubenv, cos you can set the grubenv to tell it to run os-prober
<TehBoss>i have no problem installing os-prober, its available as one of the packages
<avalos>rrobin: actually, a lot more things broke. Adding libelogind to the list.
<avalos>I thought Guix was relatively fault-tolerant.
<avalos>But a simple power off broke a lot of packages.
<efraim>avalos: In that case I recommend 'sudo guix gc --verify=repair,contents'. It will check all the items in your store and attempt to rebuild/redownload any which are corrupted
<lilyp>if what efraim suggested somehow doesn't work, roll back the generation, gc it, and build it again
<avalos>Unfortunately, I lost track of the generation where packages weren't corrupted. :(
<avalos>It must be way behind, as I've ran guix pull and reconfigure so many times.
<avalos>So, I hope what efraim suggested works! :P
<avalos>efraim: how do I link my home to the fixed packages?
<avalos>Is is enough with `guix home reconfigure`?
<efraim>it'll fix the ones in the store, replacing any that are broken with their correct versions
<efraim>so it'll fix it in-place
<avalos>Nice
<ulfvonbelow>could someone on mainline-ish guix run 'guix build --with-latest=qtbase -n --derivations qgit' and paste the resulting derivation? I'd like to verify something
<ulfvonbelow>(paste to a pastebin, that is)
<efraim>/gnu/store/paixxkdaakv55bffggxx4l9hiknl8i5r-qgit-2.10.drv
<TehBoss>wheres the code for guix bootloader?
<ulfvonbelow>efraim: could I get the contents, please?
<TehBoss>found it
<efraim>ulfvonbelow: https://bpa.st/2NKQ
<avalos>efraim: thanks, your solution worked!
<ulfvonbelow>efraim: thank you very much!
<TehBoss>would it be possible to overload this function to set the env GRUB_DISABLE_OS_PROBER to false https://github.com/guix-mirror/guix/blob/master/gnu/bootloader/grub.scm#L555C1-L555C1
<jpoiret>TehBoss: iirc os-prober is *not* enabled on guix
<jpoiret>otherwise your config wouldn't be reproducible
<Sleep_Walker>I'm using emacs-next from Guix installed on openSUSE and I'm struggling with font configuration. Emacs can't see all openSUSE fonts but can't see even the ones installed via Guix. If I install another GTK based app (I tried lxterminal), it use the fonts correctly. Any ideas?
<jpoiret>Sleep_Walker: can you compare the search paths of your profile depending whether you have that other gtk-based app installed? you can look at ./etc/profile inside of ~/.guix-profile
<jpoiret>that's the first thing that comes to mind if installing another unrelated app resolves anything
<TehBoss>jpoiret: but my config won't work on multiple systems without os prober, i need to probe for other distros installed
<TehBoss>even just on one system its much easier to let os prober handle finding things
<TehBoss>it should be doable i just need to figure out how to chnage the install-grub-efi function
<TehBoss>config isn't really more reproducible if instead of adapting it just doesn't work
<jpoiret>TehBoss: it just won't work, the grub config file is generated through a gexp, and that will thus run inside of the isolated build environment
<jpoiret>os-prober won't be able to detect your other systems this way
<jpoiret>(and it also needs superuser rights i presume)
<jpoiret>instead, I'd suggest detecting which host you're running on at the level of the config (if you're doing one config for all hosts you're probably already doing this) and adding the needed entries depending on that
<TehBoss>jpoiret: i only have one system running guix rn, so i suppose i can just hardcode it, but what if the kernel updates and then the menuentry is wrong?
<jpoiret>you'd have to either make sure the kernel path is stable across kernel updates, or use a regexp or something
<jpoiret>you could also chain load into the other distro's bootloader, which should not change across updates
<TehBoss>would that then require 2 grub menus?
<jpoiret>yes, that would then
<koollman>it seems easier to put a symlink to the kernel you currently want to boot
<jpoiret>on efi systems thou i don't even usually add each distro to the other's GRUB, since i can just choose which grub to boot on startup
<jpoiret>koollman: it might be annoying to integrate with some distributions though
<koollman>sure. But trivial compared to managing menuentry. might be easier to have a second grub automanaged. but, well, depends on specific things :)
<TehBoss>is there any reason why os-prober on arch can't detect guix?
<TehBoss>i tried to just update my arch grub, but it seems to be unable to detect guix for some reason
<jpoiret>TehBoss: os-prober is completely ad-hoc in its detection, it's just a bunch of hacked-together shellscripts
<jpoiret>just the fact that the kernel and initrd aren't in /boot might be too much for it
<TehBoss>well my boot partition is /boot/efi
<Sleep_Walker>jpoiret: they use the same environment. Furthermore, if I run openSUSE's Emacs `/usr/bin/emacs` which is comparable version and works fine. It seems like something Guix specific.
<Sleep_Walker>I compared function of `env -i DISPLAY="$DISPLAY" XAUTHLOCALHOSTNAME="$XAUTHLOCALHOSTNAME" XAUTHORITY="$XAUTHORITY" $HOME/.guix-profile/bin/emacs -Q` with `env -i DISPLAY="$DISPLAY" XAUTHLOCALHOSTNAME="$XAUTHLOCALHOSTNAME" XAUTHORITY="$XAUTHORITY" /usr/bin/emacs -Q`
<Sleep_Walker>for both evaluated `(find-font (font-spec :name "Noto Color Emoji"))` and got different results
<jpoiret>and if you install lxterminal both work?
<jpoiret>ie. you get the same results
<Sleep_Walker>I'm saying, lxterminal works itself, its installation doesn't affect this test
<jpoiret>ah, that's not how I understood what you said previously, I thought installing lxterminal made emacs work
<Sleep_Walker>nah, it was just a test, if GTK apps in general are affected
<jpoiret>emacs is by default not a "pure" GTK application
<jpoiret>but I'm not even sure if the pgtk branch uses GTK for font resolution
<jpoiret>so you can't find fonts installed by either guix or your host distribution?
<Sleep_Walker>yeah, I know that my problem is niche of niche :)
<jpoiret>now i'm even wondering how guix-installed fonts are found by fontconfig
<Sleep_Walker>at this moment I installed `font-tamzen` in Guix as a test and is not visible via fontconfig even after cache rebuilt
<jpoiret>are you still testing this with emacs or `fc-match` and friends?
<Sleep_Walker>I tried to add Guix fonts via `xset +fp` but it failed on some weird error...
<Sleep_Walker>when I verified lxterminal, I focused on Emacs only
<jpoiret>i don't get how guix's fontconfig is configured to look into the default profile
<jpoiret>have you looked at the X11 Fonts part of the manual?
<jpoiret>it's in 2.6.3
<jbnote>Hello, i'm trying to have a mixed networking setup where one interface is static and the other on DHCP. Alas, when instantiating both static-networking-service-type and dhcp-client-service-type (both adequately configured), guix system build tells me that service 'networking' is instanciated more than once. I've tried redefining the "provision" field in static-networking to no avail. Is there a simple hack around this?
<Sleep_Walker>jpoiret: yes, I had, I reread it again and it seems not to cover Guix installed on different distribution much. Anyway, I managed to adjust openSUSE's fontconfig to add my Guix fonts but the problem with Emacs is not affected.
<TehBoss>can i use nm-applet with guix without any additional config?
<jbnote>sorry, it works now. dhcp-service-type has a (shepherd-provision) entry that needs redefinition.
<Sleep_Walker>OK, my problem is fixed but I'm not sure by what because my synthetic test was missing HOME env variable...
<vivien>lilyp, apteryx, there does not seem to be a fix for gnome-online-accounts to use the newer webkitgtk, and there does not seem to be a merge request to fix it.
<cbaines>vivien, you were looking at making some changes to QA right? Have you got any further with those?
<vivien>cbaines, I didn’t investigate much, sorry. If you have ideas, don’t hesitate to implement them.
<mirai>jbnote: my suggestion is to use networkmanager instead
<lilyp>vivien we don't have to fix upstream; for now it suffices to package it
<mirai>hako: have you seen this <https://www.toaruos.org/>
<oriansj>mirai: network manager is usually over kill; iwd, iproute and isc-dhcp will cover 100% of all needed cases
<mirai>isc-dhcp is EOL
<mirai>sure, they can cover
<mirai>but networkmanager also suffices if you don't require the kind of flexibility from using N different tools
<oriansj>mirai: correct and it is easier for people to learn. and kea does not appear packaged in guix yet. And by the looks of its feature set, not really a good option for a dhcp client either.
<oriansj>oddly, the kea documentation https://kea.readthedocs.io/en/kea-2.4.0/arm/quickstart.html recommends the use of the isc-dhcp client which might indicate they are talking about the dhcp server not client bit with the creation of kea
<mirai>Is there a way to express dependency for system tests? (gnu/test/…)
<mirai>test-C depends on test-A and test-B
<civodul>mirai: “depends” in what sense?
<mirai>Say you want to test the XVNC service. Before we get to that we want to ensure that GDM works
<mirai>and for GDM (gdm.scm) we might have various variant tests, such as GDM-standalone, GDM-suspend-enabled, GDM-suspend-disabled. For XVNC we want to ensure that the GDM-suspend-disabled test passes
<PotentialUser-87>hi all, im having some troubles with NetworkManager - i own a thinkpad t530 with an intel 6300 card, i've set up everything and am even able to scan for wifi networks and see them, however i simply cannot connect to anything (nmcli says wifi device not found), and within `nmcli` i see that the device is listed as recognized, but it says `plugin
<PotentialUser-87>missing`, i tried looking around for people with that issue and all have fixed it by installing a `networkmanager-wifi` package, which should be built in the normal `network-manager` package in guix, as far as i can tell
<PotentialUser-87>`dmesg`, lspci, and such tools all list the card succesfully, with the appropriate drivers (iwlwifi) and no errors, the physical antenna is on, `rfkill list all` shows nothing
<snape>PotentialUser-87: I imagine it's because your wifi card isn't supported by the wifi drivers in Linux-libre
<snape>some were removed from Linux because they were non-free
<PotentialUser-87>snape I am not using that kernel
<snape>well then I don't know
<aldum>>`rfkill list all` shows nothing
<aldum>that doesn't sound healthy
<RavenJoad>Is the new module texlive-scheme/collection setup supposed to slow down document compilation?
<PotentialUser-87>does guix offer any package like "NetworkManager-wifi"?
<RavenJoad>PotentialUser-87: What makes the "-wifi" part special? Guix has both the NetworkManager package and a service-type for it.
<RavenJoad>I finally got around to making another blog post about Guix! This time it is about package specifications. https://karl.hallsby.com/introduction-to-guix-specifications.html
<PotentialUser-87>RavenJoad supposedly it lets NetworkManager control wifi devices, I am having troubles with my wifi card and nmcli reports it is "missing plugins", I searched around and people seem to fix it by pulling in those wifi plugins by that package
<RavenJoad>PotentialUser-87: I use network-manager-service-type from %desktop-services on my laptops, and it works fine for me.
<jackhill>hmmm, NetworkManager seesm to be wifi for me with just the desktop-services. (not sure about the hotspot, I haven't tried it). Are you sure your wifi hardward works without nonfree firmware? If the device show up in `ip addr show` it does, and you should be all set.
<PotentialUser-87>jackhill it does show up there, also I am able to successfully scan for, and find wifi networks, by executing `sudo iw wlp3s0 scan`
<PotentialUser-87>however, this is the output of running `nmcli` : `wlp3s0: unmanaged...  "Intel Centrino Ultimate-N 6300" ... wifi (iwlwifi), 24:77:03:E1:00:9C, plugin missing, hw, mtu 1500"
<jmml>m
<PotentialUser-87>I have set up everything firmware and kernel related, shouldn't be a libre-kernel or lack of blobs issue
<pastor>Hi. Could anyone recomend me a package to use as a reference on how to package an application which uses rust and python?
<PotentialUser-87>dmesg shows that the hardware is recognized and firmware loaded
<jackhill>hmmm, I'm not sure then. I don't remember having to do anything special
<jackhill>PotentialUser-87: sorry, I'm probably not likely to be able to help, but could you post the output of `nmcli device show` somewhere?
<jackhill>(paste.debian.net is a common recommendation here it seems)
<jackhill>I guess I'm curious which key the "plugin missing" is associated with
<PotentialUser-87>jackhill sure, thanks for trying to! here is the full output, I censored the MAC addresses but otherwise its unchanged: https://paste.debian.net/1295152/ the interface in question is `wlp3s0`
<jackhill>thanks. yeah, no clues there
<PotentialUser-87>here is `nmcli` https://paste.debian.net/1295153/
<attila_lendvai>is there a way to specify a `guix pull --commit` for a channel; i.e. not for the main guix channel?
<jackhill>attila_lendvai: the only why I know is to write a channels.scm file (you can use `guix describe --format=channels` as a starting point) either put it in the default location (~/.config/guix/channels.scm) or pass it to `guix pull -C`
<jackhill>would be cool to have a way to specify it on the command line
<attila_lendvai>jackhill, yep! i'll just rebase this channel for now. it's its staging branch anyway, so i'm free to fool around.
<jackhill>:)
<PotentialUser-87>how can i examine the reason of a herd service failing? for some reason bluetooth won't start...
<PotentialUser-87>i suspect it may have something to do with the wifi, also, as its the same card
<attila_lendvai>PotentialUser-87, i think there should be something in /var/log/messages... have you looked?
<RavenJoad>PotentialUser-87: Usually the service's logs or /var/log/messages are what I go to first.
<efraim>sneek: later tell pastor python-orjson https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/python-xyz.scm?h=rust-team#n3008 uses rust and python to build
<sneek>Got it.
<efraim>sneek: botsnack
<sneek>:)
<podiki>efraim: saw your recent cross compile commits, so I take it we can close https://issues.guix.gnu.org/66424
<podiki>efraim: and note in discussion there what was changed on core-updates, maybe you'd want to push the same changes there to avoid a merge conflict or it getting lost?
<TehBoss>is there an xorg log anywhere?
<TehBoss>my xorg isn't starting and i wanted to have a look at the log to see if i can figure out why
<TehBoss>so that i can see that i am at least starting xorg in my config, since i have a feeling i may have accidentally disabled xorg
<podiki>/var/log should have it
<RavenJoad>TehBoss: /var/log/X.0.log is what I have.
<TehBoss>it doesn't... i think i must have removed GDM and not included a substitute
<distopico>there is a way to run sudo inside of "guix shell --container"? I get "sudo must be owned by uid 0 and have the setuid bit set"
<civodul>distopico: the only way would be by passing --share=/run/setuid-programs and by doing “export PATH=/run/setuid-programs:$PATH” within the shell
<distopico>civodul: didn't work, i get the same "sudo: /run/setuid-programs/sudo must be owned by uid 0 and have the setuid bit set", calling directly "/run/setuid-programs/sudo --help" inside the container, the container command is "guix shell --container -F -N -P --share=/run/setuid-programs --share=/opt -m manifest.scm"
<civodul>distopico: indeed, weird
<civodul>not sure why that happens
<civodul>something with not having UID 0 mapped inside the user namespace i guess
<RavenJoad>Oh, civodul. I don't know if you saw, but I finally got around to making another Guix post. https://karl.hallsby.com/introduction-to-guix-specifications.html
<RavenJoad>This time it's about package specifications.
<the_tubular>Great write-up RavenJoad, I like to read those!
<civodul>neat!
<civodul>RavenJoad: one nitpick: (list libgccjit "10.4.0") in ‘native-inputs’ won’t work as intended
<civodul>this syntax is for outputs (for multiple-output packages), so “10.4.0” would be interpreted as an output name
<ohyllad>Guix/Guile question that has me stumped for a bit, When running guix shell -L ./the-module --file=test.scm containing a module import, and a function call into the library passed with -L. The error hints at using the correct module, which shows that its actually finding the (public) symbol somehow, but its still not in scope. Any hints what could be going on here?
<sneek>ohyllad, you have 2 messages!
<sneek>ohyllad, antipode says: for interpreting (#:key value) stuff, you can use lambda* / define*.
<sneek>ohyllad, antipode says: (from RhodiumToad): there's also let-keywords if you have a key-value list other than in function args
<RavenJoad>civodul: Oh! I did not know that. From a quick test it seems like (list libgccjit "version" "output") does not work, but (list libgccjit "output") does. Can package version be put into the list like that at all?
<civodul>RavenJoad: no, it’s not possible
<RavenJoad>Oh. Ok. I will amend the post soon then. URLs won't break, so linking to the post will continue to work.
<civodul>that’s really a minor issue though, the post looks nice!
<podiki>sneek: later tell efraim saw your recent cross compile commits, so I take it we can close https://issues.guix.gnu.org/66424
<sneek>Will do.
<podiki>sneek: later tell efraim and note in discussion there what was changed on core-updates, maybe you'd want to push the same changes there to avoid a merge conflict or it getting lost?
<sneek>Okay.
<podiki>sneek: bot snack
<podiki>sneek: botsnack
<sneek>:)
<podiki>civodul distopico I didn't think you could use setuid in a container anyway, maybe need something like https://github.com/NixOS/nixpkgs/pull/231673 ?