IRC channel logs

2023-08-26.log

back to list of logs

<Guest96>to generate a patches file, I make the changes in the cloned repository, and send the output of "git diff" to a file (the pathches file).  However, these patches fail:
<Guest96>Hunk #1 FAILED at 162.
<Guest96>Hunk #2 FAILED at 205.
<Guest96>Hunk #3 succeeded at 323 (offset -14 lines).
<mirai>I'd say the doc needs: splitting, restructuring, rewriting, more writing, more examples ; and an intelligent search “engine” for it
<Guest96>Wait, I am grabbing from pypi for my build, but github for git diff...
<Groumf>Guest96 git diff respect the patch format?
<Groumf>I did not know
<mirai>until a concrete plan is hatched, its all we got
<Guest96>mirai: interesting idea I had (and have the expertise to get a proof of concept working) is a light-weight natural language machine learning model that is fine-tuned on all the documentation on a system, and can point the user to a region of docs given a question
<Groumf>Guest96 I would use diff -u if that is an option.
<vagrantc>Guest96: chances are the cloned repository does not match the source in the package definition?
<nikolar>Guest96: isn't that basically grep :)
<vagrantc>Guest96: e.g. if you're using a specific version from git, rather than the current master branch, etc.
<mirai>Guest96: that'd be magnificent! Is it entirely self-reliant or does it rely on inscrutable components?
<mirai>nikolar: I'd like that `grep' then. If it can answer the query "How do I mix phases?" without any extra input from the operator…
<nikolar>it was a joke
<Groumf>I really love the code actually
<Groumf>"A gremlin is sort-of like an elf, you know"
<mirai>grep with "-R -C 5" is my search engine within guix when I'm looking for other snippets to steal
<nikolar>kek
<vagrantc>git grep -C 5 ... is even easier :)
<Groumf>damn I did not know git grep
<Groumf>life is changed
<mirai>cargo-culting can be quite infectious… and a bog if you have to later excise it if it turns out that a better approach exists
<the_tubular31>vagrantc you need a .git folder for that right ?
<mirai>its nice that people generally preserve the comments even when copy-pasting
<mirai>helps understanding and disentangling things later on
<mirai>jpoiret: IMO #57493 would have been worthy of appearing in NEWS
<mwette>efram: thanks; got this ref on #riscv: linux for VisionFive2 jh7110 processor: https://github.com/esmil/linux/tree/jh7110
<Guest96>Any idea what could cause a "malformed patch"?  I tried auto-generating with git, and and also hand-crafting, but no dice
<Guest96>vagrantc, yes, source in package def is different, but I tried generating one using the file in the failed build, but get the same error
<Guest96>nikolar: it could be similar to grep to start out with, but evertually the goal would be to get an assistant that (at least) knows the documentation.  This would be enabled as LLMs continue getting shrunken, and ML-ready compute becomes more free.
<lilyp>re diffs, for me it's typically a whitespace mishap, but that's rather specific to your workflow I must say
<Guest96>mirai: not sure what you mean by self-reliant vs inscrutable.  Ideally, the model would be reproducable in a guix-y way, so you could inspect it
<vagrantc>Guest96: without the patch in your package definition: guix build --source ... then adapt the source and ... i think diff -u ?
<Guest96>vagrantc: thanks, I was able to get it working, not sure how though ~.~
<vagrantc>i usually generate the patches from a git checkout these days ... but i am pretty familiar with patches having been fiddlign with this sort of things for decades now :)
<Guest96>For some reason, in the actual build, __file__ resolves to /gnu/store/..., but if I guix shell -C --pure -D ..., then __file__ will resolve to /tmp/guix-build-...
<Guest96>That's a pretty big deal if I can't reproduce bugs in the build.  For now, I think I will just disable that check though
<wone>Mm. With gnu's tigervnc build, is there a way to tell if it has DRI3 support?
<janas>I am trying to build an installer image from my local git checkout using `./pre-inst-env guix system image --image-size=3.5GiB ./gnu/system/install.scm`, however this results in a crash https://paste.debian.net/1290059/ Weirdly other commands do not fail, e.g. `pre-inst-env guix pull` works fine. Seems to have something to do with guix trying to
<sneek>janas, you have 1 message!
<sneek>janas, leinad says: Benutzt Du noch den Web-Client?
<janas>authenticate my local repo? Would appreciate any help debugging
<Wurt>Hi, is there any way to execute a hook when a guix subcommand runs? I read that apt can do it using --pre-invoke and --post-invoke options. I could create a wrapper, but I think that maybe It is better idea to send a patch that adds a call to 'run-hook' before and after the subcomand execution on 'run-guix-command' (guix/ui.scm:2286). Is it a bad idea? My silly goal is to play a random keygen song
<Wurt>each time I update.
<davidl>Is it allowed to use Guix as part of a name of a derivative Guix distribution? Say EasyGuix, XGuix, or whatever you come up with?
<the_tubular92>I have no idea. but it would still be guix no ?
<apteryx>wone: you could check the build log with something like 'guix build --no-grafts --log-file tigervnc'
<mirai>Wurt: I remember that Guile itself has something about hooks
<davidl>the_tubular92: it would be "just" a channel to begin with, but I may eventually rebrand it completely with /etc/os-release, grub screen, and everything being different with it's own installer. There are many Debian-based distributions for example, LMDE, that uses both Linux and Debian in it's name, and I wonder what conditions apply in order to use those names.
<the_tubular92>Yes, I understand what you meant davidl, I just find guix so different that you'd basically just ship a config.scm right ?
<the_tubular92>err, you said custom installer
<the_tubular92>I don't know, love your videos btw!
<davidl>videos?
<the_tubular92>Ohh I though you were System Crafters, my bad!
<the_tubular92>ACTION hides in shame
<davidl>I would "ship" a bunch of collected services and packages from different Guix channels around the web (incl my own) that hasn't reached Guix master yet. It would expose variables like %my-guix-distro-default-packages that you can use for your current config-file, and a %my-guix-distro-os that you can inherit from. I would also like to add a website with documentation.
<apteryx>bah, gitlab's cloudfare prevents signing in via icecat *again*
<the_tubular92>Seems like a cool project!
<the_tubular92>apteryx, have you heard about gitlab going to the fediverse ?
<damo22>clownfare*
<davidl>the_tubular_92: thx. There is already similar projects out there - like guixrus. My goal is slightly different in that I want to provide a handcrafted default desktop environment, and default most things, batteries included.
<mirai>so a bleeding edge of (bleeding edge) Guix?
<AwesomeAdam54321>davidl: I think it's allowed, if it follows the FSDG as well
<mirai>my 2¢: make it clear that it's a derivative of Guix
<mirai>within the nname
<davidl>hmm, and if it doesn't follow FSDG? I am thinking about the channel called non-guix, which distributes build recipes suggesting you to install non-free linux - would that violate Guix as a trademark or something?
<davidl>mirai: definitely I will!
<mirai>davidl: those are different things (related reading: <https://www.gnu.org/philosophy/komongistan.html>)
<mirai>just avoid clearly misleading names like “Guix Blue” or “Guix 2.0”
<davidl>mirai: thx, I will be reading that!
<davidl>mirai: how about EasyGuix, or GuixEdge, or GuixAlpha
<mirai>to me they look alright (doesn't strike me as misleading except for GuixAlpha)
<Groumf>If we are in that vein, I would name it ChadGuix.
<mirai>GuixAlpha sounds like an effort to run Guix on Alpha (a rather specific goal)
<mirai>Groumf: Chad ThunderGuix
<davidl>mirar: good point re Alpha, I wont use that.
<Groumf>More seriously, just my 2c, I really prefer EasyGuix in your list. It explains what it is.
<davidl>Groumf: lol
<Wurt>mirai: Could you refer the section about hooks? I could not find it on the Guix documentation.
<mirai>Wurt: Guile Manuall :-)
<davidl>Groumf: good point. The Edge thing is actually misleading too, because it's not necessarily ahead of Guix on package versions.
<Wurt>mirai: I search the word hook and I could not find it, maybe I am wrong. There are services that use hooks, but the guix command does not.
<mirai>Wurt: <https://www.gnu.org/software/guile/manual/guile.html#Hooks>
<mirai>note that I'm pointing you to Guile, not Guix :-)
<Wurt>Ah, I am not explaining it well. I know that there are Guile hooks, but I want to know if there is an option on Guix to execute hooks while some subcomands (for example guix install or guix pull) are executing.
<mirai>hmmm… I don't know. You'll have to wait a while (usually this isn't the most active time for the channel members)
<mirai>or post your question to ML
<Wurt>mirai: Thank you. ML means mail list?
<mirai>yup
<janas>davidl: I was also thinking of working on a custom installer for guix that would automatically add various channels
<Groumf>The sole reason why I hate Machine Learning is the fact that it kicked away the mailing list and the meta language :)
<nikolar>Guest96: the problem for the reproducibility of llms is that the training is inherently randomized
<roptat>hi guix!
<janneke>o/
<nikolar>Hello
<jpoiret>sneek, later tell mirai: that can always be added later :)
<sneek>Okay.
<the_tubular> https://hpc.guix.info/browse is dead
<the_tubular>Every package links to a 404
<rekado>got some problems with my rockpro64; can’t seem to boot any newer system later than linux 6.1.10.
<rekado>I don’t have HDMI output when Linux takes over (even on the kernel+system combination that works), and it’s a bit cumbersome to open it up to connect a serial adapter
<rekado>so I don’t have any details yet
<rekado>anyone else here with a rockpro64 on a new kernel?
<nikolar>Was that riscv?
<next4th>rekado: maybe this shepherd ntp bug? https://issues.guix.gnu.org/64966
<pkill9>can the guix-daemon be connected to over the network? I'm wondering if there's any security risks via network
<nikolar>This ntp bug is really annoying
<nckx>pkill9: Yes, see <https://guix.gnu.org/en/manual/devel/en/html_node/Invoking-guix_002ddaemon.html>.
<nckx>nikolar: Which NTP bug?
<nckx>Hullo, also, Guix.
<rekado>next4th: thanks for the hint. I’ll see if I can boot it with a workaround.
<nckx>nikolar: Never mind, I read the log. Thought you meant a bug in NTP.
<next4th>yeah i don't experienced it (luckly..), it seems shepherd would hang due to fibers unable to handle big time jump. https://github.com/wingo/fibers/issues/89
<nikolar>nckx no no, the shepherd bug
<nikolar>Can't it be made to use CLOCK_MONOTONIC
<nckx>‘The bigger problem with using CLOCK_MONOTONIC might be that it doesn’t count time the system is suspended, which would probably break stuff.’ (just quoting the Fibers issue; no opinion.)
<nikolar>So there's no winning
<oriansj>pkill9: well assuming the system connecting has a valid user account and the communication is properly secured. The risks are limited to the damage the built binary can cause. Which in the case of a compromised account can be rather extensive.
<oriansj>as due to the defects in hardware itself can be used to bypass kernel protections and be used to install new firmware to one's storage media which would ensure a persisting compromise. Which could have been avoidable if storage media didn't have upgradable firmware or required a physical switch to be flipped to enable writing. (or if we normalized external flashing of firmware)
<rekado>next4th: the patch in that issue let me boot; at least I think so, because the system can be pinged. I can’t SSH into the machine, though, so I’ll have to figure this out first before giving my thumbs up on that issue.
<oriansj>but as those risks are the exact same on all operating systems; there is no additional risk of having the guix-daemon running on a different system beyond that of a single point of failure.
<jetomit>rekado: ping-but-not-ssh is the behavior I get with the broken guile-fibers
<roptat>same here :)
<jetomit>I think it's because ssh is socket-activated by shepherd, which is busy counting the seconds until it reaches the current time
<jetomit>on a rockpro64 it takes a week or two, after that everything works OK
<roptat>good to know... it's been a few days for me
<roptat>(not exactly a rockpro64, but the same chipset)
<jetomit>if you're lucky you can ssh in just after boot, before ntpd updates the time
<jetomit>just don't disconnect :)
<roptat>that's what happened to me, my network is not completely stable
<rekado>previously I couldn’t even boot at all
<rekado>is there another way to get a remote shell?
<rekado>I don’t really *need* ssh, but I need something that lets me access the machine from the local network to reconfigure etc
<piptown>is this how I would define this: (service bspwm-desktop-service-type)
<oriansj>rekado: well depending on hardware (if it has a BMC), there is out of band management services that can be used to give you a serial console
<rekado>it has a uart, but it’s not possible to reach it when the case is assembled
<nckx>piptown: If such a service exists, then yes.
<next4th>maybe a usb2usb can be made from 2 usb2ttl by connect their RX/TX/GND?
<next4th>then you got a serial link with 2 usb ports..
<jetomit>rekado: maybe you could try one of the other ssh services, like dropbear, which is not socket-activated
<piptown>after changing my config.scm do I have to guix reconfigure for it to take effect?
<next4th>piptown: yes, and sometimes need a reboot
<piptown>next4th: thanks sorry if I'm asking such elementary questions
<next4th>no problem /w\
<rekado>apparently Guix doesn’t like me to use both openssh and dropbear: “service 'ssh-daemon' provided more than once”
<piptown> https://paste.debian.net/1290092
<piptown> https://paste.debian.net/1290092
<piptown>Sorry about the double links,  I keep getting and error about unbound variable with use-service-modules and a hint about did I forget a use-modules form?
<oriansj>piptown: well yes, they would be both trying to connect to the same port unless you configure them differently
<piptown>oriansj: what would?
<piptown>oriansj: I'm very new to GUIX, so I'm confused about what your saying is trying to connect to the same port?
<nckx>piptown: → (use-modules (gnu) (gnu packages wm)) ; to get use-service-modules
<nckx>Actually, (use-modules (gnu)) should suffice, since (gnu packages wm) is synonymous with (use-package-modules wm).
<nckx>piptown: ori​ansj was responding to rek​ado.
<piptown>nckx: oh thank you very much
<nckx>My zero-width space anti-ping trick no longer works with HexChat ☹
<nckx>…which considering the last HexChat release, is probably not the issue.
<piptown>when reconfiguring why is guix say I need to --allow-downgrades and when I do it gives an error about wpa-suppliant-dbus-group-policy.patch is not found?
<roptat>piptown, needig --allow-downgrades probably means there's something wrong with your setup
<roptat>have you ever run "guix pull" before?
<piptown>roptat: yes two weeks ago
<roptat>did you run it as root (directly or with sudo?) or user? How do you run reconfigure, as root or user?
<roptat>*as root directly or with sudo
<roptat>(for reconfigure)
<roptat>(since you can't reconfigure as user)
<roptat>oh, I need to go, I'll be back in ~30 mins, hopefully others can help
<piptown>say I ran it as root using sudo su, then reconfigure
<piptown>currently doing guix pull as now as root
<nckx>Oof.
<nckx>Say you did that, I'd ask why.
<piptown>nckx: I ran guix pull two weeks as user
<nckx>(There are valid reasons to run guix pull as root, but they all involve knowing why.)
<piptown>honestly I don't know why, I assume because I'm getting an error about missing patches
<nckx>I'm not seeing the link, but I would (1) guix pull now (2) if the reconfiguration error persists, paste the full output to the pastebin and share it here.
<nckx>Obviously, (1) not as root.
<piptown>nckx: yikes, already did (1) as root
<nckx>I should explain why it's ‘obvious’: guix pull is per-user, and pulling as root on Guix System without a known use case is at best pointless and at worst can confuse permissions if you hold it wrong.
<nckx>piptown: That needn't be a yikes, let's assume ‘at best’ for now :)
<piptown>nckx: please explain
<nckx>I think I added a warning for the ‘hold it wrong’ case but I can't guarantee it works 😉
<nckx>piptown: Because ‘sudo’ on Guix System should be configured to invoke the command with root privileges but (mostly) with your regular user's environment (sudo -E). ‘sudo guix’ invokes *your* guix, not root's. Having pulled as root will not give *you* an updated guix.
<nckx>The majority of people should never need to pull as root, ever.
<nckx>* people running Guix System, that is.
<nckx>ACTION has to go AFK too, good luck.
<indigo-oce>Is there a guide to creating a local guix channel (in a local git repo)?
<roptat>indigo-oce, there's at least the manual: https://guix.gnu.org/en/manual/devel/en/html_node/Creating-a-Channel.html
<piptown>where are the share/xsessions files located on the guix system, I can't seem to find it under /usr?
<apteryx>I think they're directly referenced by the xorg server configuration in the store
<indigo-oce>roptat is there a template?  how do you specify the channel url if it's a local filepath? I've never used scheme before so idk what to expect...
<apteryx>piptown: ah, seems they are available from: /run/current-system/profile/share/xsessions
<apteryx>I found that in the manual
<roptat>I don't know, the manual would help create the channel, even if it's locally, then the channel would be specified with its absolute path (maybe using file://)
<roptat>it needs to be a git repository though
<mwette>indigo-oce: here is my ~/.config/guix/channels.scm file: https://paste.debian.net/1290102/
<mwette>$HOME/channel/ is a git repo with my one package file.
<indigo-oce>mwette thanks
<piptown>apteryx: thanks I've searching the manual but didn't find it: is this the correct manual: https://guix.gnu.org/manual/en/guix.html
<roptat>piptown, https://guix.gnu.org/en/manual/devel/en would be the most recent version
<twelve>I'm thinking of trying out guix the pkg manager, but can it do system configuration using just config.scm like in guix system?
<roptat>twelve, yes, but then it would convert your system to a complete guix system, better not unless you know what you're doing
<twelve>So I'm better off with stow ?
<roptat>for system configuration?
<roptat>you can use guix home, just not guix reconfigure
<twelve>No just want a way setup my systems automatically using preconfigured scripts or somesuch, preferably generated by a program
<roptat>ah, ok, then if you don't want a guix system, you can't use guix for that
<twelve>I just peek at guix home on the manual, it seems to be what does it
<roptat>guix home configures your home directory, not you whole system, but maybe that's what you want?
<radio>I know it's kind of an emacs question, but it's related to guix and no one on #emacs seems (as me) to not understand what is happening
<radio>Whenever I start emacs outside guix shell I get a "Symbol’s value as variable is void: /bin/sh:"
<radio>Even with --debug-init or --no-init-file
<radio>With --quick it loads, but whenever I try to run a command, it display's me that error on the minibuffer
<radio>On guix shell it works normally
<roptat>radio, I don't use emacs,so hard to be specific, but to me it sounds like, either the emacs in and out of guix shell are not the same version, or something is wrong/missing in your user environment that guix shell removes/replaces/sets
<roptat>(and I mean environment variables)
<radio>Hm
<radio>Actually emacs-next doesn't work on guix shell too
<lilyp>That sounds like a rather weird issue
<lilyp>It seems that the shell is read as a symbol rather than a string?
<lilyp>can you toggle-debug-on-error?
<lilyp>(For the record, on emacs-team, M-x shell raises no such error)
<twelve>roptat: I'll make do with guix home and/or stow
<piptown>why am I getting an error: bspwm-desktop-service: unbound variable? here the link the /etc/config.com: https://paste.debian.net/1290104
<roptat>piptown, I don't see any bspwm service in Guix
<roptat>from the name of it, it's only a window manager, so there's no need for a desktop service
<piptown>roptat: what should I put bspwm?
<roptat>you should be able to select it from the login screen as long as you have it in the packages (which you have)
<piptown>roptat: okay when I didn't have this. GDM didn't let me select anything I login and get XFCE
<piptown>is there a key or something I have to press to be able to select it from the login screen?
<roptat>no, it should be drop down menu under your usename I think
<roptat>although, I don't have it either
<roptat>(I only have openbox, which works similarly, and it starts, but no menu to select it on its variants)
<roptat>did you reboot after adding bspwm?
<piptown>yes
<roptat>then I don't know :/
<piptown>let me try it again, just remove the bspwm-service stuff and reconfigured, so let me try rebooting again
<piptown>@roptat: It worked, there is a gear icon in the lower right that allows me to select desktop environment after I start typing in my password
<piptown>I would like to thank everyone that help me with getting started with  GNU GUIX
<hwpplayer1>Do you run GNU Emacs piptown ?
<piptown>hwpplayer1: yes
<hwpplayer1>how is your experience with GNU Emacs on GNU Guix ?
<hwpplayer1>piptown: ^
<piptown>my experience is fine, for my uses
<piptown>however I'm still trying to master GNU Emacs
<hwpplayer1>I am on Ubuntu I wait for getting more experience until switching to GNU Guix
<piptown>hwpplayer1: have you tried this book: https://www.masteringemacs.org/
<hwpplayer1>I know that book I read info inside Emacs
<piptown>hwpplayer: why wait to get more experience with emacs before switching
<piptown>emacs is the same regardless of the os
<hwpplayer1>I have time for GNU Guix
<aarcov>I'm looking to add SiriKali (https://github.com/mhogomchungu/sirikali) to the repos, and have this package file: https://paste.debian.net/1290019; what I don't know, is if I should add it as a new package file (sirikali.scm) or if it should be added to another multipackage file?
<aarcov>And, if it goes in as a new package file, do I need to define a sirikali.go file as well (and what is the purpose of these <package>.go files?)?
<zamfofex>aarcov: That ‘.go’ files are generated automatically from your ‘.scm’ files.
<zamfofex>You don’t need to add one, they are generated when you run ‘make’.
<aarcov>Thank you zamfofex
<distopico>Does guix shell have something like shellHook in nix flakes? I'm using direnv so I want do 'use guix --container -N --F rust' and run something inside of the container after it init, is that possible?
<distopico>Something like 'guix shell --container -N --F rust --search-paths --hook my-hook.scm' ? Or using manifest.s or guix.scm is possible?
<nikolar>Is emacs native compilation enabled on guix
<lilyp>Yes
<radio>Anyone using fish-foreign-env to source multiple profiles?
<radio>Btw, I was wondering why we have to source the etc/profile within a profile to activate it, instead of having a guix profile command to manage it
<radio>Found it a little strange
<lilyp>we typically prefer guix shell
<radio>Ah, yeah, I was considering to use guix shell
<radio>But it's strange to create multiple profiles just to guarantee that the packages won't be deleted by gc and then still using the manifest
<radio>Actually guix shell has a -p flag, hasn't it?
<radio>Hmm
<radio>But then when you have multiple custom profiles which you want to be used by default you just guix shell -p them in your .bashrc or something?
<panosalevro>hi all, it seems that all guix commands are broken on my machine. here's what I get with almost every guix command: https://paste.debian.net/1290114
<panosalevro>is this recoverable?
<lilyp>radio the multiple profile use case is sadly a little undersupported; basically you have to write your own shell functions as done in that one blog post™ way back when™
<Groumf>panosalevro doesn't look too bad. Just a license missing apparently
<Groumf>I would just use a dummy one or change the package.
<Groumf>Though it's probably not "the right way"
<lilyp>that sounds like a serious problem though; is that on master?
<lilyp>in any case, you can run older guix from /var/guix/profiles/per-user/$USER/current-guix-N, where N is any number lower than your current generation
<panosalevro>lilyp: is that the same as `guix package --switch-generation=[number]`? because I can't do that
<lilyp>not quite; you're invoking guix "directly" from the store, so you'd be getting previous modules
<lilyp>I used that once to get a specific version of chromium that I only wanted to compile once
<panosalevro>im not sure how I can run an older guix like that
<radio>lilyp: ah, I thought so, but it's good to have confirmation
<radio>I think I would like to help to improve such feature
<radio>Maybe in the end of year
<lilyp>first, do an $(ls /var/guix/profiles/per-user/$USER)
<lilyp>[without the $() of course, so that it doesn't get reinterpreted as a command)
<lilyp>look at the numbers, one of them is the highest
<lilyp>let's say it's 43
<panosalevro>right
<panosalevro>i can see the same list with `guix package --list-generations` btw. for some reason this command works
<lilyp>then just do /var/guix/profiles/per-user/$USER/current-guix-42-link/bin/guix
<lilyp>hmm if --list-generations works, you might also be able to do --rollback
<panosalevro>tried it, it doesnt work lol
<lilyp>okay, then my nerding did make sense
<panosalevro>there doesn't seem to be a guix file in bin
<panosalevro>oh nvm, i was looking at the guix-profile links
<panosalevro>but my current generation is 280 and the last current guix link is 46? why is that?
<lilyp>current-guix gets incremented on guix pull, the other generation on guix package
<lilyp>it only shows your pull:package ratio
<panosalevro>oh, that makes sense. okay
<panosalevro>`/var/guix/profiles/per-user/$USER/current-guix-45-link/bin/guix` doesnt work on its own
<panosalevro>I get "guix: missing command name"
<lilyp>maybe follow it up with "package me a sandwich"?
<panosalevro>ha, ok I get it now
<panosalevro>thanks, it works
<lilyp>:)
<Groumf>Do you guys know of a package that patches elfs to modify runpaths? I have been battling with that for quite a bit of time now.
<Groumf>(also I still can't get around the insane amount of wordplays available with elf)
<podiki>Groumf: patchelf
<podiki>unless you mean an example of it being used in a package, in which case I don't think you'll find it here (all must be built from source)
<Groumf>oh ok gotcha
<Groumf>well maybe I'll have more luck in nonguix then
<Groumf>thanks
<formbi>hi!
<formbi>I'm trying to package python-rapidfuzz, I currently have this: https://paste.rs/acrYc
<formbi>but it throws this error: «ModuleNotFoundError: No module named 'backend'»
<formbi>but a name «backend» doesn't really sound right, also I didn't really find one that seems like it would fit here
<podiki>maybe look at the full backtrace, see what the actual import statement is?
<formbi>hmm, pyproject.toml has «build-backend = "backend"»
<formbi>maybe someone used a wrong name for PDM…
<Guest69>There is dovecot but no postfix.  Which do you use as a replacement on Guix Systems?
<attila_lendvai>i can't even close my own damn debbugs issue. is this a authorization issue, or am i doing something wrong here: https://issues.guix.gnu.org/58437#9 ?
<lilyp>attila_lendvai: did you message control@debbugs.gnu.org?
<attila_lendvai>lilyp, that's my mistake, thanks!
<mwette>ACTION got a working vnc server session on wayland/guix-system, with client gnome-connections on ubuntu; next is tuning and cleanup