IRC channel logs

2023-08-12.log

back to list of logs

<psyclimb>Question: how do i add correctly, without breaking things...add, remove, or modify files in the store? Here's an example. I've installed a game called tome4 and there is a subdirectory there called "addons" where the game can use additional content: expansions and stuff. What is the proper path forward to addings some files to that directory?
<vagrantc>RavenJoad: yeah, i haven't poked at channels yet ...
<TakeV>I keep running into an issue when packaging things where the package cannot find cc, even when I install gcc-toolchain. Is there another package I should be using, or is there a way to set CC=gcc for the build?
<RavenJoad>psyclimb: If the game is in the store, then the only good way (I know of) to add addons is to edit the package recipe to put the addons in the final output.
<RavenJoad>TakeV: You can explicitly set CC=/gnu/store/gcc-.../bin/gcc with a configure-flags or make-flags in the arguments for the package. Are you sure Guix is not setting CC?
<TakeV>It does not appear to be set, no.
<TakeV>This is also for a ruby package, so the make-flags/configure-flags are not available.
<vagrantc>you can set CC with setenv
<RavenJoad>You can add a phase after the set-paths phase that sets CC using setenv, like vagrantc said.
<vagrantc>git grep -C3 setenv'.*CC.*for-target'
<TakeV>Excellent! Thank you very much.
<vagrantc>though not entirely sure if cc-for-target is available in all build systems
<vagrantc>hope so :)
<psyclimb>Thanks, RavenJoad. I speculated that was the solution but wasn't sure. I'll work on figuring that out now! :d
<vagrantc>weird ... guix shell xyz ... builds a profile with xyz in it ... guix shell (with a guix.scm defining xyz) ... build a development environment with the inputs relevent to building xyz ...
<vagrantc>i would expect it to only build a development environment if passed --development
<vagrantc>seems oddly inconsistent
<RavenJoad>vagrantc: I think it is because your xyz package is an input of some kind. When you guix shell on a package, you get an environment for building your package.
<vagrantc>RavenJoad: no, "guix shell --development PACKAGE" gives you a development environment for PACKAGE ... "guix shell PACKAGE" gives you a profile with PACKAGE installed
<vagrantc>"guix environment PACKAGE" ~= "guix shell --development PACKAGE" and "guix environment --ad-hoc PACKAGE" ~= "guix shell PACKAGE"
<vagrantc>with guix environment being deprecated, as i understand it
<RavenJoad>You're right. I am not sure why you get xyz sources too. If something is inconsistent with Guix's CLI, something is probably wrong somewhere.
<vagrantc>but "guix shell" with a guix.scm in the directory acts like what i would expect "guix shell --development" to do.
<RavenJoad>I am not quite sure then.
<vagrantc>i will ask about it eventually...
<apteryx>vagrantc: I think it installs the packages within it, same as a manifest.scm file?
<apteryx>it's like 'guix shell -m manifest.scm', I think
<apteryx>wow, someone packaged vagrant
<vagrantc>ACTION remains unpackageable and non-deterministic
<vagrantc>apteryx: that would be my expectation, but that is not what i experienced ...
<vagrantc>ACTION is probably even not freely licensed
<akd>I'm currently ssh'ing into my guix machine that has a desktop environment installed, shutting down elogind to prevent sleep when I'm away, and using tmux with weechat in it.
<akd>I'll detach from tmux and then disconnect. Hours later, I can't ssh in, because it immediately closes the connection after I type my password.
<akd>Any ideas?
<mwette>did you try: ssh -v -v -v
<akd>I believe I did, but I'll try again.
<mwette>the error messages usually tell something
<aarcov>also, are you able to access the logs from the desktop side to see if it reported anything?
<akd>I rebooted, so I'm on it right now.
<akd>What logs should I scroll through for something like that?
<aarcov>Maybe /var/log/messages?
<aarcov>still fairly new to guix, I was about to say journalctl, but that wouldn't work with guix
<akd>heh
<akd>Thanks, gamer.
<aarcov>I'm seeing entries like "localhost shepherd[1]: Starting service sshd-12... " and "localhost sshd[5909]: Accepted publickey for <blah>" etc in it
<aarcov>It might have details for why a connection failed?
<kedin>i have a question (out of curiosity)
<kedin>how minimal guix linux can be ?
<kedin>and what i mean by that i mean compute power consumption (ram,disk and cpu)
<kedin>i saw a minimal sway guix config that looks promising but the video (https://piped.video/watch?v=0IhP_YrGRvA) didn,t give me it,s usage...
<kedin>and also...
<kedin>does guix support installation with encrypted partitions ?
<damo22>kedin: sounds like a hardware question, i mean, you could use something like a raspberry pi right?
<kedin>damo22: will you believe me if i said i want to test it in a device worse than a rassberry pi 4
<apteryx>kedin: it's called Guix System :-) Guix requires at least 2 GiB of RAM for operation, which means while doing some upgrade or updating itself. If you use substitutes it won't use more resource than another system. It depends what you software you use.
<kedin>apteryx: yes i know... i talk about ideal ram usage and base system size....
<kedin>damo22: it,s a really old laptop
<damo22>>= 2GiB ram
<apteryx>kedin: you'll be fine if you have >= 2 GiB of RAM. many people use it on a x200, which is about 15 years old.
<apteryx>I use it on an x200 too with GNOME and it's zippy (I have an SSD installed and it has 8 GiB of RAM)
<kedin>damo22: So guix uses 2gb of ram for almost nothing???
<kedin>i have more than that but it,s RAM USAGE i want to know to be prepared for...
<kedin>apteryx: i have 4gb ddr3 ram that works fine... if the system use 2gb ram by default WITHOUT the DE then i have less than 1.5gb ram...
<kedin>that,s the point
<damo22>kedin: try it and see
<kedin>ok then...
<kedin>thanks
<kedin>btw does guix have external repos ?
<kedin>i didn,t find my favorite browser in there
<damo22>its pretty normal for a kernel to use the first 1GiB of ram isnt it?
<damo22>and the combined resident memory of programs to take another 1GiB?
<kedin>damo22: wat.
<kedin>the hell why.
<kedin>the kernel should <90mb.
<kedin><30 if you compiled it from source...
<damo22>i doubt linux can function with <100MB ram on a modern x86
<damo22>the filesystem cache lives in the kernel doesnt it? im not sure
<kedin> https://piped.projectsegfau.lt/watch?v=BHQGboT2--Y
<kedin>(he compiled gentoo and even trimmed xorg a bit down)
<kedin>60mb ram usage usable linux setup
<kedin>for plp who care that much
<apteryx>kedin: you should just give it a try :-) I can't reboot now but you can use slim as login manager with x11 and ratpoison, that should give you something pretty minimal (I remember booting this setup on Guix System with a memory usage of < 200 MiB a couple years back)
<apteryx>there's nothing inherently memory intensive in the operation of a Guix System, but having a fast disk such as SSD or at least 2 GiB of RAM will make for a better experience when using guix the package manager itself (which is a punctual thing to do)
<kedin>apteryx: i won,t use a DM
<kedin>i,ll simply install sway, pcmanfm, some terminal programs and my webrowser...
<kedin>my problem is that i did this with opensuse and ended up with 450mb-ish ram usage for whatever reason..
<kedin>yet i don,t want to use a minimal distro like void linux 'cause converting .deb packages to .xbps daily isn,t "enjoyable".
<kedin>+ sleep mode on void didn,t work...
<kedin>so all i ask for is to know guix ideal ram usage to i don,t end up wasting time... that,s all
<kedin>what,s going on with the irc server rn
<kedin>(to) *so
<apteryx>I don't foresee any serious problem if you got 2 GiB of RAM for peak usage (e.g. 'guix pull'), but you could tweak your OS definition and try it out in a VM and to be sure
<kedin>apteryx: i will install it in a spear computer to see how it performs (in my spear time)
<kedin>if it satisfies me i,ll install it on my laptop...
<kedin>that should do it
<aarcov>Guix itself is fairly light; the one gotchya is if you need to compile some software from source without sustitutes
<kedin>*spare
<aarcov>if you stay on mainline guix, without trying to add say chrome, or some other heavy compile it should run you shouldn't have too many issues
<aarcov>you can also spin it up in a VM
<kedin>aarcov: i,m looking for something like that...
<kedin>but usable at the same time...
<damo22>kedin: it seems like your requirements are very demanding, you want an operating system that uses no memory, and runs your favourite browser with unlimited tabs :D
<kedin>damo22: not unlimited...
<kedin>say like 7 at the same time..
<damo22>may i suggest if you dont want to compile your own custom OS, upgrade your ram
<kedin>damo22: how much ram do i need to use a web browser ?
<kedin>12gb???
<xd1le>web browsers are bloatware
<damo22>yeah god damn javascript
<kedin>xd1le: i know and very aware of it
<kedin>i wish there,s a web browser as lite as luakit yet private with fingerprinting protection (or even lighter)
<kedin>i even thought if i learnt programming enough to make use of webkit2gtk i could make that...
<damo22>kedin: the problem is most websites wont display anything unless you run the client side javascript that is provided by the server
<damo22>otherwise i would just use lynx or something
<kedin>damo22: that can be dealt with using adblockers... but that,s not enough
<kedin>they will use javascript to track your a** everywhere on the web...
<kedin>fingerprinting protection is hard bc every detail on your setup is used (os, timezone,reslotion and even all your fonts)
<kedin> https://www.deviceinfo.me/
<kedin> https://amiunique.org/
<kedin>which is cringe! javascript was made just to display some crappy animations on the web...
<kedin>(jet) *yet
<kedin>and before you say...
<kedin>librewolf.net has poor fingerprinting protection that only changes the fingerprint once per session...
<kedin>well brave.com doesn,t do that but it,s fingerprinting protection breaks compatibility with ddos protection like cloudflare (whitch is very widely used)
<kedin>*which
<kedin>both of which can,t hide to the website that they,re hiding alot of info... and that,s a problem
<kedin>damo22: my point is: we could live with html and css just fine but industry greed didn't allow us to
<aarcov>huh, never heard of librewolf, how does it compare to the bundled icecat with uBlock added?
<viaken>kedin: I have a fairly bare install running on a server and it's using just under 1g at rest.
<kedin>aarcov: it,s more like a user.js config (arkenfox for example) but with user convenience in mind (not breaking websites and not looking broken like mullvad and tor browser)
<kedin>it also remove firefox BS and binary blobs (which is good)
<kedin>if you want to compare them then someone did that already
<kedin> https://privacytests.org/ (you can run the test for yourself
<kedin>*icecat not included in the site
<kedin>viaken: wdym under 1gb at rest
<kedin>i,m sorry but can you show me it running $free -m
<kedin>viaken: https://github.com/privacytests/privacytests.org/tree/master/scripts
<kedin>viaken: i,m sorry for sending this by accident...
<kedin>aarcov: https://github.com/privacytests/privacytests.org/tree/master/scripts
<aarcov>sweet, I hadn't heard of that project before
<kedin>aarcov: i,m sorry... but for someone who uses icecat for privacy:
<kedin>weren't you supposed to search for something like that all the time ?
<samplet>My server is “only” using 374MiB. A lot of it is The Shepherd and Mcron.
<kedin>samplet: damn... that,s alot for a ideal server
<kedin>samplet: it should be atleat 120mb
<kedin>aarcov: anyway, i,m happy you found "some" better privacy!!!
<kedin>samplet: sorry for being annoying but  i meant
<kedin>*atmost
<samplet>Understood. There’s work to improve the Guile GC, which might help. Though I doubt it’s anyone’s priority when 8G was the norm ten years ago.
<kedin>samplet: i totally understand:
<kedin>i might be a bit of a freak to milk every drop of performance out of my old harware...
<kedin>but bloatware are bloatware and it makes programs worse
<kedin>plp should consider it as well but they never give a *duck
<samplet>The thing about RAM is that using more of it makes programs go faster. The other thing is that programs are not generally written to probe the amount of the RAM the current system has when making decisions about how much to use. That means they usually target a reasonable guess as to how much total RAM is available.
<samplet>As time goes on, the “reasonable guess” gets bigger and bigger.
<samplet>Some software (I’m thinking of Postgres) is pretty good about tuning RAM usage. It’s not too common, though (in my experience).
<samplet>Which is not to undermine the impulse to keep old hardware going. It’s a good one! I’m just thinking out loud about the issues.
<kedin>samplet: isn,t that madness!!
<kedin>just image every 3 year "apps" just use more bloated libraries
<kedin>then for the OS to cope with it adds native support for it
<kedin>then the OS require more specs to run
<kedin>then you are force to buy better computer even thou yours are still working
<kedin>i saw that happen many time and i refuse to do so
<kedin>samplet: i don't say that,s the case with linux or guix
<kedin>it,s just the issue expanded further...
<kedin>*forced
<kedin>*times
<samplet>I’m a little shocked that Linux can’t easily be compiled on a Raspberry Pi. Or that it requires 32G of RAM to compile Lineage OS.
<kedin>samplet: wat
<kedin>32gb of wat
<kedin>srsly ?
<samplet>On the other hand, a while ago I was working on an implementation of DEFLATE, and I used a 16M lookup table. I would not have chose that even 15 years ago.
<kedin>i "read" it required at least >=8
<kedin>*linage OS
<samplet>“A reasonable amount of RAM (16 GB to build up to lineage-17.1, 32 GB or more for lineage-18.1 and up).”
<samplet>That’s from the wiki.
<kedin> https://source.android.com/docs/setup/start/requirements#hardware-requirements
<kedin>* Google recommends at least 64 GB of RAM and doesn't test with less. Lower amounts lead to builds being OOM killed *
<kedin>shit
<kedin>samplet: that got out of hand
<kedin>HOW
<kedin>samplet: this is industry-level hardware they are talking about
<samplet>There’s a balance to strike. I don’t like that, but I don’t want to go back to Debian Sarge, either. :)
<kedin>samplet: you don't have to
<kedin>if you want debian you can install a base installation from netinstall, disable recommended packages and install a lightweight windowmanager
<kedin>yeah it,s some work but it,s better that what gnome and kde delivers
<kedin>samplet: wait...
<kedin>* realizes this is pretty much Debian sarge like installl *
<kedin>...........
<kedin> https://hyprland.org/
<kedin>can it help ?
<kedin>ok... thanks for the information... bye
<kedin>i,ll update my system
<apteryx>yay, qtbase 6.5.2 built
<hwpplayer1>hi people !
<sneek>hwpplayer1, you have 1 message!
<sneek>hwpplayer1, nckx says: Sorry, didn't mean to ghost you.
<unwox>hi guix :)
<hwpplayer1>hi people !
<jpoiret>nckx: wdyt of parametrizing by system only when building the hooks in profile-derivation instead?
<jpoiret>because profile-derivation takes a SYSTEM argument, just doesn't use it properly for the hooks
<jpoiret>sneek, later tell civodul: can't we assume that tests are running using bash? it ends up as an input of Guix so it should be fine. The fd leaking test doesn't work with my zsh, and I see you're adding a test conditionally if we're running on bash
<sneek>Got it.
<nckx>jpoiret: I tried that, but maybe I wasn't doing it right? I basically worked my way up through the call stack and this was the spot where it stopped double-building.
<nckx>I also expected profile-derivation to suffice.
<jpoiret>oh, so you tried parametrizing in the (extras ...) binding?
<jpoiret>haven't tried myself
<jpoiret>because this suggests that profile-derivation is wrong and that may also cause problems at other call sites
<nckx>I also think there's more to it. I'm not confident that I fully understand the problem yet, that patch is just where I stopped yesterday. I hope to find the root cause tomorrow. I won't be at a computer today.
<jpoiret>I can have a look at it as well. Do you have any nice testing tips?
<nckx>Friend, I used pk.
<jpoiret>😳
<nckx>😳
<jpoiret>i mean to check that it doesn't build for the host arch anymore?
<nckx>If it produces 2 profile derivations (the current behaviour) instead of one, it's wrong.
<nckx>That's why 'merely' tweaking the hooks does not feel like the full story. Although I agree that the SYSTEM argument should be used more than it currently is.
<jpoiret>thanks!
<nckx>jpoiret: Sorry, ignore those two messages, I think I'm confusing this bug with something else.
<nckx>ACTION at social gathering, people are trying to make me be social, it's tiring.
<nckx>jpoiret: You can use a package that refuses to build on your native arch. But make it fail in a phase, not through supported-systems, because the latter wasn't reliably checked. *That's* what was sus.
<jpoiret>okay, i'll have a try
<jpoiret>nckx: i think your fix is morally right, just that %current-system vs. SYSTEM argument led to SYSTEM not being properly passed to %current-system but rather snuck in half-heartedly
<jpoiret>we can maybe remove the SYSTEM argument here
<minima>hi, i have my `.bashrc' and `.bash_profile' created via guix home; `.bash_profile' sources `.bashrc'; however x11 terminals don't seem to be aware of anything that i set in my `.bash_profile'
<minima>(yes, i logged out and in again after changing `.bash_profile')
<minima>my understanding is that whatever is in `.bash_profile', that should be "inherited" by interactive non-login shells, such as the x11 terminals - is my understanding correct?
<next4th>.bash_profile is for login shell, the login manager (gdm, etc) may not source it? (need look..)
<minima>hm... that might be the case since i don't think i have a login manager at all
<minima>interesting
<minima>i'll need to see where `.bash_profile' is supposed to be parsed when using the good ol' startx
<next4th>without login manager? login from tty will sure source it.
<next4th>unless your shell is not bash
<minima>sorry, w/o login manager -> i mean w/o GDM and co. - just startx plus `.xinitrc' etc
<minima>ah yes, which is what you were saying
<minima>re tty
<minima>well, hm, it doesn't seem it parses it
<next4th>yes, startx doesn't care bash files, login into the tty does
<minima>let me see what happens in a tty
<jpoiret>nckx: i wish i hadn't looked deeper into this. monadic store + %current-target-system is a mess
<jpoiret>i'm writing a big reply highlighting what goes wrong
<minima>next4th: ok, thanks, `.bash_profile' and `.bashrc' are actually sourced correctly, i'm having an issue with a particular env variable that seems to be misteriously overwritten, but at least the general mechanism seems to be working fine - thanks for your help
<nckx>jpoiret: I'm... starting to feel grateful I fell asleep yesterday? What horrors did I miss, oh boy.
<nckx>If -target- comes into it, I missed that.
<jpoiret>ah no, i meant %current-system
<jpoiret>although we need the same fix for target imo
<jpoiret>i ended up finding a bug in gexp->derivation, so that's how deep i ended up
<jpoiret>aaaaaand, right after sending the mail, I figured that my reading of gexp->derivation is wrong yet again 🙄
<jpoiret>I mean, the code itself is misleading
<viaken>Ah, I gave kedin bad info. Stuff I had running took more RAM than I thought. Fresh boot is 147M, and ~50M of that is technically unneccesary.
<wehlutyk>hello guix!
<wehlutyk>I've been sending a request/question to help-guix@gnu.org and I don't see it appearing in the archives, nor being rejected (I'm not subscribed to it)
<wehlutyk>is that to be expected? (it looks like the email never reached the list)
<Guest58>Hello
<Guest58>i have a question: how can i build packages from source using the guix package manager? i am on guix system
<jpoiret>Guest58: Guix packages are all built from source, but Guix by default lets you download substitutes for them from the build farms so you don't have to rebuild them. You can disable substitutes for individual commands with --no-substitutes, or you could just remove all substitute servers from your guix system configuration
<jpoiret>depends on what you want to achieve
<jpoiret>you can also challenge CI builds by asking Guix to build a specific package and check that CI has the same output
<Guest58>i want to download the source code from github and then compile it
<jpoiret>of something that's packaged on guix?
<Guest58>no
<Guest58>e. g. tor browser
<jpoiret>right. Then you could just follow that program's building instructions then, no?
<Guest58>some  do not have any
<jpoiret>you don't need to install the build dependencies though, you can just use `guix shell` to have them available temporarily
<Guest58>mhh..
<Guest58>ok
<jpoiret>tor browser is quite special though, upstream insists that you should you their own built executables
<jpoiret>since browsers are fingerprintable, they really want to make sure every tor browser user has the same one
<Guest58>but what about something like sudo make install
<jpoiret>yeah, you often don't need to install the program to be able to use it
<jpoiret>you can launch it from the directory you built it in
<Guest58>how?
<jpoiret>depends on the program once again
<jpoiret>sometimes it's very tricky
<jpoiret>what's your goal?
<jpoiret>do you just want to use software that's not packaged in Guix?
<Guest58>yes.
<jpoiret>if so, and if you're not too used to building software yourself I suggest trying to find them via other sources, like flatpak for example
<Guest58>anything else than flatpak and snaè?
<Guest58>the have many flaws
<wehlutyk>quick question: are the message sent to help-guix@gnu.org filtered or some of them taken as spam? I'd like to ask a question there, sent it twice since yesterday, and I don't see it in the archive yet
<jpoiret>wehlutyk: if it's your first interaction with them you'll have to be manually moderated first
<jpoiret>Guest58: you could try other containerization engines
<Guest58>i have used them many times
<jpoiret>or running tor browser through an FHS shell
<Guest58>ok..
<Guest58>but what about building a package from source?
<jpoiret>see https://guix.gnu.org/en/blog/2023/the-filesystem-hierarchy-standard-comes-to-guix-containers/ for an example
<Guest58>like doing git clone URL cd PACKAGE and makepkg -si ?
<wehlutyk>jpoiret: it's not my first message there (although my last one was in April 2022)
<mwette>profile question: I understand you can have one or more profiles active. When you install a package, what determines which profile that gets added to?
<jpoiret>makepkg -si is an arch-specific command, to build arch packages
<jpoiret>all guix commands build packages according to the source, but take shortcuts by downloading from the build farm if available
<Guest58>it was an example
<wehlutyk>jpoiret: though I get it might be the moderation then. Just to get an idea, does it take more than a few days usually?
<jpoiret>mwette: the -p option of `guix package`, by default ~/.guix-profile
<jpoiret>wehlutyk: depends on the availability of moderators
<jpoiret>i've got no idea
<wehlutyk>ok, thanks
<jpoiret>Guest58: building something from source really depends on what you're building, there's no general answer
<Guest58>ok thanks
<Guest58>what about tor-browser?
<mwette>jpoiret: thanks
<jpoiret>if you're trying to build tor browser from source you'll run into some trouble i think.
<Guest58>why?
<jpoiret>it's a pretty big piece of software with lots of moving parts
<Guest58>ok.
<Guest58>thanks for the advice but i did not ask for that
<jpoiret>lots of dependencies, some are in Rust, and I'm not sure they really maintain build instructions
<jpoiret>well I don't know, never tried myself
<Guest58>o .k .
<Guest58>thanks for the help
<Guest58>also what guix package -p does?
<jpoiret>-p selects the profile you want to apply the operations to
<Guest58>ok bye
<jpoiret>the README at https://gitlab.torproject.org/tpo/applications/tor-browser has some pointers
<geri>hey, does anyone know why not adding network-manager-applet from %desktop-services break dunst?
<geri>i copied code for %desktop-services and removed a bunch of stuff i don't want and consequences are pretty bizzare
<minima-web>hi, i'm experiencing something similar to this: https://issues.guix.gnu.org/54919 tl;dr: guix home operations will hang after `Finished updating symlinks.'
<minima-web>`herd status' will also hang
<minima-web>whereas `herd status <service>' actually works (at least for a couple of services i tried - other than root)
<minima-web>any idea if this could be some kind of regression? or just a problem on my side?
<jpoiret>geri: did you remove dbus?
<geri>nope, dbus-root-service-type is still in
<geri>when i remove network-manager-applet stuff then dbus doesn't work anymore
<geri>if i re-add it dunst works again
<geri>i wonder if replacing network-manager-applet with profile-service-type w/ an empty list as extension will make it still work
<geri>nope
<mwette>I'm trying --install-from-file. The source has a #!/bin/python. I've added python to inputs, but when I run "guix package ..." I get this: patch-shebang: ./util/latency_report.py: warning: no binary for interpreter `python' found in $PATH
<mwette>
<mwette>Does python need to be in my profile I use to run "guix package ..."?
<geri>I won't say for sure but I think that means something is messed up in the package definition
<geri>also i recommend using #!/usr/bin/env python3 for shebang overall, then you kinda dont even need to patch it
<geri>jpoiret: got it fixed by adding dbus-glib as a package
<jpoiret>geri: in your system configuration?
<geri>actually in my home config, but system should be fine too
<mwette>I use that myself, but I didn't write the source package. pkgdef: https://paste.debian.net/1288726/
<jpoiret>geri: dbus-glib is apparently obsolete,
<jpoiret>replaced by glib's built-in equivalent
<geri>huh
<geri>just `glib'?
<jpoiret>yeah
<jpoiret>does that work with just glib?
<geri>lemme try
<geri>i already have glib:bin installed...
<geri>mwette: maybe you'll have to create a diff file for it
<geri>cause using `python' isn't portable either iirc, for example debian only has python3
<hako>mwette: "python" is available in python-wrapper
<jpoiret>geri: you want the default output of glib
<mwette>hako, geri: thanks
<geri>i need :bin too because it's got gsettings in it
<geri>and guix home complains about conflicting entries if i do both
<jpoiret>huh
<jpoiret>but it doesn't complain for dbus-glib? it propagates glib:out
<geri>yeah, dbus-glib is fine
<geri>idk what propogating means here but last messages from the error are `... propogated from libnotify@0.7.9' and `try upgrading both libnotify and glib or remove one of them'
<jpoiret>oh no
<jpoiret>can you try using glib@2.72.3:bin and glib@2.72?
<jpoiret>in your home config you can use the glib symbol from (gnu packages glib) instead of specification->package
<jpoiret>(and to specify a specific output of a package you should be able to give (list glib "bin"))
<jpoiret>when you give a version-less specification to guix anywhere, it always prefers the newer package, even though it might not be the default one used elsewhere (for example as a dependency). In guix we have glib and glib-next, but all packages use glib
<jpoiret>or at least, *most*
<geri>i have a fancy macro for adding packages to home profile
<geri>using 2.72 and 2.72.3 didn't seem to do anything, error's the same
<jpoiret>in any case, either glib should be propagated from dunst, or we should wrap the dunst executable with the GI_TYPELIB_PATH
<geri>hmm
<jpoiret>did you also replace your :bin output with the new version?
<geri>"glib@2.72.3:bin" "glib@2.72"
<jpoiret>if you still have the conflict error could you paste it to paste.debian.net?
<geri> https://0x0.st/H_Ue.txt
<geri>don't mind duplicate PATH, i do some black magic to "install" scripts
<geri>i guess "normal" glib is installed from libnotify and :bin is a different package so there's no conflicts
<jpoiret>omg
<jpoiret>ok I know what's happening
<jpoiret>you'll need to use the guile symbols though
<jpoiret>the base glib package is hidden, and another one is defined with the additional documentation output
<jpoiret>but because they're not exactly the same packages, they don't have the same derivations and so there's a conflict
<geri>hmmmmmmm
<jpoiret>so, if you can manage to give the guile symbol glib and (list glib "bin") that should be ok
<geri>where's glib at
<geri>(gnu packages gnome)?
<jpoiret>(gnu packages glib)
<jpoiret>it has its own little home
<geri>comfy
<geri>do i still need to specify versions
<geri>
<geri>okay that didn't do anything
<jpoiret>no, these symbols refer to specific package versions
<geri>glib is installed by libnotify i guess
<jpoiret>we could also fix dunst to have the GI_TYPELIB_PATH variable set by itself
<jpoiret>yeah, propagated is the word
<geri>does it mean it might work w/o the package if i set GI_TYPELIB_PATH var?
<geri>btw if it's obsolete, why is it used in network-manager-applet
<geri>which is default in %desktop-services
<geri>also what do i set GI_TYPELIB_PATH to
<jpoiret>it should be set automatically by either having glib in your profile, or if the programs are wrapped
<jpoiret>i'm writing a patch for the latter right now
<jpoiret>that way yes, you wouldn't need to add glib yourself
<geri>)
<jpoiret>wrt. network-manager-applet, I don't know, it probably hasn't been updated
<geri>alrighty
<geri>it seems it's depricated except it gets some minimal maintenance for network-manager and some other project
<geri>so i guess it makes sense why it's used in the applet, but using it elsewhere is not the best idea
<minima>oh, it must have been a fluke - things seem to be alright after a reboot (re my above issue with guix home reconfigure hanging after `Finished updating symlinks.')
<geri>it's weird, because if it still has #!/bin/python it should still break...
<jpoiret>uhm, geri, what's the actual error message of dunst when you start it?
<geri>CRITICAL: [dbus_cb_name_lost:1050] Cannot connect to DBus.
<jpoiret>it does work for me in a pure environment so it doesn't seem to be something with env variables
<jpoiret>how do you start your WM?
<geri>exec sway
<hako>minima: I think it might be related to Shepherd, since after "Finished updating symlinks", it's reloading services.
<jpoiret>in a shell?
<geri>do i need dbus-launch thing?
<geri>yes
<jpoiret>yes you do, you don't have a dbus session otherwise
<geri>what's the full command?
<jpoiret>exec dbus-launch -- sway?
<geri>lemme try
<minima>hako: yeah as a matter of fact "herd status" also hung and the system was all in a wobbly state - not sure what happened, now things seem to be ok
<minima>but i've been doing some cleaning, i might have nudged the system too much :)
<geri``>how to install dbus-launch lol
<jpoiret>it's in dbus i think
<geri``>okay yeah, seems to work
<geri``>funny thing is i never needed this before
<geri``>guess other distros do their own black magic for it
<jpoiret>did you only do shell login + exec sway on other distros?
<geri``>yeah
<geri``>and on bspwm too
<jpoiret>maybe dbus-using apps try to start the dbus daemon if it hasn't started yet, but since dbus-daemon wasn't available in the env it didn't start? just a wild guess
<geri``>they do try to start dbus or smth for sure
<jpoiret>starting other dbus apps on demand wasn't enough, they wanted more power
<jpoiret>pulseaudio does that too
<geri``>i can kill dunst, run notify-send and dunst is gonna be running again
<jpoiret>if a pulseaudio-using app sees no pulseaudio server, it'll start it itself
<geri``>oh yeah, true
<geri``>saw that recently
<jpoiret>it's possible to disable it with a system-wide config file
<jpoiret>guix sometimes forces you to peel back the layers of paint and then you realize what a mess everything is
<geri``>yeah xd
<geri``>for some reason my guix uses 2x the ram my gentoo used on boot
<geri``>guess its cause of guile in initramfs or smth
<hako>There's a home-dbus-service-type to start a session bus, and I personally extend home-shell-profile-service-type to put WM starting stuff (condition to "exec <wm>", no dbus-*) in .profile.
<geri``>i use file service instead of bash service to manage my bashrc cause otherwise it creates like 10 more files than i want
<jpoiret>the guile in initramfs doesn't stay, it execs the boot script that itself execs shepherd
<geri``>(more like .bash_profile)
<geri``>hm
<jpoiret>.bash_profile is quite important though for guix
<jpoiret>that's where profiles are loaded
<geri``>nah, .profile is
<geri``>.bash_profile is mostly useless in my case
<hako>I use Xonsh, as there's currently no service for it, I use a file service as well.
<jpoiret>ah right, i never remember the naming conventions across shells (i use zsh)
<geri``>(btw)
<geri``>hako: why do you use xonsh?
<geri``>jpoiret: it seems i just needed to add dbus package and now i dont even need dbus-launch command
<jpoiret>that's suspicious
<jpoiret>i'd still use dbus-launch to start your session
<geri``>i still dont understand what its for lole
<hako>geri``: Like, it doesn't need much configuration?
<jpoiret>it starts your dbus user session (different from the system session that's started by shepherd)
<geri``>oh, it's pretty fish-y, cool hako
<jpoiret>the user session is used by most dbus apps that don't need to interact with root things
<jpoiret>dunst is one of them
<geri``>alright then
<mwette>woohoo. I generated a package that builds. It took < 2 hours. Next is to execute. https://paste.debian.net/1288734/
<geri>congrats :D
<janneke>mwette: \o/
<geri>praise the sun! \[+]/ janneke
<porcupirate>Hi guix
<porcupirate>Why is sync service disabled in renpy?
<mwette>thanks all. For wayvnc, pam is optional, would including pam be nominal for guix (system)?
<porcupirate>I noticed the save screen doesn't work in renpy because has_sync is not defined.
<porcupirate>has_sync is not defined because guix deletes it.
<porcupirate>This can be fixed by defining the has_sync setting as None somewhere while config.locked = false
<Guest49>hi, i need help installing tor browser on guix, or at least set up tor in a browser
<Guest49>( i am a newbie )
<Guest49>because tor is not avaiable in the main repos..
<Altadil>Guest49: a possibility is to install flatpak, and get Tor Browser from there.
<Guest49>a non-container option (neither snap or similar)
<Guest49>like a portable exe?
<Altadil>If you want to run the executable directly, you will need to use guix shell. It works but I could not get audio/video fully sorted out.
<Guest49>thanks, how can i do that?
<Altadil>Guest49: https://lists.gnu.org/archive/html/guix-devel/2023-05/msg00005.html
<Guest49>ok, thanks
<Altadil>That’s the best I could do
<Guest49>that is very helpful, have a nice day
<Guest28>Does someone know how I can change my DNS settings? I don't have any network settings defined (using the default).  I looked at https://guix.gnu.org/manual/en/html_node/Networking-Setup.html but I don't understand how I would only change the DNS servers without anything else.
<piptown>does any here run bspwm on guix?
<piptown>I installed bspwm as user and as root. However bspwm isn't reading my bspwmrc file currently I created an alias to force it to read once. I Log in and open a terminal then run my alias. I'm trying to see why guix isn't reading my bspwmrc file upon startup?
<thanosapollo>can you replace emacs package archives with just guix? How would I have something like (dolist (package emacs-package) guix-install package) on a foreign distro(debian)
<thanosapollo>emacs-packages*
<Guest28>Not sure, but if you use Emacs from Guix and the package is available on Guix like emacs-ef-themes, you just need to do guix install emacs-ef-themes and Emacs should detect it automatically through the ENV variables
<thanosapollo>Guest28: yeah, that works, but I want to have a .scm or .el file with a list of packages to reproduce my emacs setup
<thanosapollo>manually installing 80 packages each time would be a pain xD
<Guest28>Ah.  There are manifests files
<Guest28> https://guix.gnu.org/manual/devel/en/html_node/Writing-Manifests.html
<thanosapollo>Guest28: looks exactly like what I was looking for, thanks!
<gnucode>hey guix people!
<Guest28>hey
<piptown>how does guix with the default login manager reads .xsession and .xinitrc or wm config files?
<piptown>how can I get bspwm to be register with my system like xfce is in this link? https://paste.debian.net/1288777/
<civodul>ACTION reviewed + applied a bunch of patches, woo!
<civodul>seems like qa.guix is processing the recent patches (one or two days old) but has kinda forgotten about the older ones
<sneek>civodul, you have 2 messages!
<sneek>civodul, ArneBab says: yikes! guix challenge guile:
<sneek>civodul, jpoiret says: can't we assume that tests are running using bash? it ends up as an input of Guix so it should be fine. The fd leaking test doesn't work with my zsh, and I see you're adding a test conditionally if we're running on bash
<civodul>jpoiret: tests aren't officially requiring Bash
<civodul>which one is the fd leaking test?
<civodul>well maybe we'll discuss that tomorrow :-)
<piptown>does anyone know why i have to source ~/.config/bspwm/bspwmrc manually to get bspwm to read my config file?