IRC channel logs

2023-08-10.log

back to list of logs

<dgr>I finally figured out how use https://issues.guix.gnu.org/65002#3 to only need to enter the pass phrase once.
<dgr>Maybe a example would have helped a guile noob like me to know how to replace a variable with a procedure. Anyway here is the working config.scm: https://paste.debian.net/1288436 and thanks to nckx and apteryx for the pointers!
<gnucode>dgr: hmmm. I am currently running libreboot. And I have to enter in the password twice. I wonder if what you just said could help my situation out...
<dgr>gnucode: chances are high, that this principle will also work in your situation. In essence, there is a second key slot added to the LUKS2 volume and this key isn't a pass phrase but a file that is the sole content of a additional initrd.
<viaken>I think I tracked down how I managed to get Shepherd stuck. I'll see if I can get together a minimal test case.
<iyzsong>viaken: good luck! i had to force poweroff my guix system several times last month..
<RavenJoad>viaken: That would be amazing! I have had similar issues too.
<civodul>Hello Guix!
<iyzsong>Hello ๐Ÿ™‹
<Luk6655>I've used guix pack command to create emacs 29 tarball to run on a foreign distro. When I run it it complains about two things. The locale and the users home. locale is set to en_US.UTF-8, regarding the user home I'm not sure why it may not like it. the machine uses a PAM module to auth (from windows AD) so maybe that's it?
<Luk6655>I just used --relocatable switch and emacs-next package. Does anyone know if I need to add anything else?
<minima>hi, i was thinking of writing a new guix home service; is there any kind of consensus on what it makes sense to make into a service (e.g. `home-msmtp-service-type') versus those configuration files that are simply too complicated and for which it might make sense to simply wrap around a static text file?
<bdju>I'm getting an error when I try to guix pull: guix pull: error: Git error: object not found - no match for id (22dd8039327c351fcd4b154733a3d6de3a7bb967)
<bdju>is this a known issue? I was hoping to run updates and reboot today
<minima>or any plan for this to be addressed with some abstraction - e.g. a consistent way for all yaml-based config files vs ini-style files vs etc... (sorry if there's already such layer of abstraction and i missed it)
<bdju>rebooted without updating and guix pull still gives the same error, fyi
<minima>bdju: not of great help, but i guix-pulled just fine a minute ago
<bdju>good to know it's not broken for everyone at least
<minima>bdju: do you have any extra channel that might be currently misconfigured?
<bdju>not that I'm aware of
<bdju>well I have one thing in my channels.scm, "public_guix_channel" gitlab.kokyou.de
<bdju>unsure what that is actually
<bdju>Oh, I vaguely recall someone trying to package something for me and I probably added this to test.
<bdju>I'll comment it out
<minima>yeah, that's what i'd try too
<bdju>ugh then I get an error that channels.sc did not return a list of channels
<bdju>how am I supposed to do this? delete the whole file?
<bdju>s/sc/scm/
<minima>hm, how are you commenting that bit out?
<bdju>I commented out every line in the file
<minima>maybe it's a simple syntax issue?
<bdju>I really hate guix channels, seems they're always fighting me and I delete the file, then someone asks me to add a channel and I don't remember how because I've deleted the channel
<minima>there might be some closing parentheses that you need to keep? or a leading `list' or quote symbol?
<bdju>I literally just added a ; to the start of every line in the file as I have no channels I need besides the default
<minima>let me see how that's setup on my machine
<bdju>I'm just gonna rename it with .bak and see if that works
<bdju>okay now I'm back to the original guix pull error so I guess it wasn't from the channel
<minima>when you pull, does it say where you're pulling from?
<bdju>Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
<bdju>guix pull: error: Git error: object not found - no match for id (22dd8039327c351fcd4b154733a3d6de3a7bb967)
<minima>oh... cache!
<minima>this might be relevant: https://issues.guix.gnu.org/40769
<bdju>ah, that would make sense. I did have an ssd failure recently and moved files back and forth
<minima>tl;dr: `rm -rf ~/.cache/guix/checkouts' (disclaimer: not tested on my machine)
<minima>hth
<bdju>I think it's working now, thank you very much
<minima>oh lovely
<apteryx>dgr: that series looks promising
<apteryx>a system test would by dandy to ensure it keeps working
<apteryx>yubikey-manager-qt added, for those interested
<dthompson>rekado: I've been trying out guix + jack + ardour for the first time, using your 2020 blog post as guidance, but for whatever reason I do not see ardour connections in the jack patchbay like you have here: https://guix.gnu.org/static/blog/img/2020-music-patchage.png
<dthompson>bringing it up here just in case it's something stupid simple that I am overlooking.
<apteryx>efraim: https://qa.guix.gnu.org/branch/rust-team looks rather good if we consider the combined availability of both bordeaux and berlin
<apteryx>mirai: so far I haven't seen any improvements after implying the docbook refactor series to core-updates, e.g. dropping a fix-docbook phase of some package
<apteryx>applying*
<apteryx>is it supposed to improve on things, or is just a cosmetical refactor?
<viaken>bdju: For future reference, you should be able to put %default-channels in your channels.scm to get it to behave with the commented lines.
<apteryx>mirai: looks mostly cosmetical, looking at the changes again
<apteryx>I'll apply it to core-updates
<bdju>viaken: got it, thanks
<dthompson>follow up: looks like patchage works with jack 2 and not jack 1. I couldn't figure out how to make jack 2 work so I've been using jack 1.
<lispmacs[work]>hi, I haven't wrote any python for quite a few years, but I was trying to run this example code here:
<lispmacs[work]> https://sffjunkie.github.io/astral/
<lispmacs[work]>I'm trying to run the code while inside of "guix shell python-astral" but python can't find the module
<lispmacs[work]>am I overlooking some step?
<lispmacs[work]>"ModuleNotFoundError: No module named 'astral'"
<apteryx>mirai_: do you know if we're still stuck with a blackscreen when using xvnc with GDM+
<apteryx>GDM? *
<jpoiret>lispmacs[work]: `guix shell python pyhton-astral`?
<lispmacs[work]>jpoiret: thanks, looks live I've got it working now. I inserted python-astral into my manifest and did a guix package update, and now it is working
<jpoiret>for search paths to work, you need both the "base" package and the thing that extends it
<jpoiret>same for guile, or any other interpreted language
<lispmacs[work]>is there some way to look up built-in python3 program reference on Guix system without looking on the Internet? Through emacs or info or something
<lispmacs[work]>I don't see an info page
<lispmacs[work]>like the Guile Reference Manual, but for python
<lispmacs[work]>I see python-mode has a "Help on symbol" function but it doesn't seem to work
<jpoiret>you can use help(something) in a python repl i think
<jpoiret>that or LSP modes
<jpoiret>i'm not sure python has a manual like Guile has
<jpoiret>(at least not for local consumption)
<lispmacs[work]>okay, if I import a module, I can run help(modulename)
<lispmacs[work]>which gives me an API and a link to Web docs
<lispmacs[work]>there seems to be only one function now
<lispmacs[work]>chatgpt3("spit out code that does what I want")
<GNUtoo>hi, is there a quick way in lisp or shell to get all packages?
<GNUtoo>for instance with "guix package -s <something>" that would show all packages
<GNUtoo>ACTION wants to know how many debug packages there are in Guix to see a rough coverage
<GNUtoo>I've looked at packages.guix.org but it seems to use some http API to get that number
<GNUtoo>*to get the number of total packages
<GNUtoo>Ah I found how: 'guix package -s "^." | grep "^name:" | wc -l' gives 24647 packages, so about the same than packages.guix.gnu.org
<GNUtoo>(for some reasons guix package -s "." had something much smaller)
<viaken>I would guess that packages.g.g.o counts each architecture separately, since it's showing the number of substitutes available.
<viaken>So, guile-x86, guile-86_64, guile-aarch64, etc would each be counted
<viaken>Actually, I'm not so sure. I have an extra channel or two, but my number isn't far off from the one on the site.
<viaken>Removed the other branches and now I'm getting 416k. ๐Ÿคจ
<viaken>Oh, I inverted my grep. With only the official channel, I'm getting 24,653.
<jpoiret>GNUtoo: the output of most guix commands uses the recutils format, and you can use the guix recutils package to manipulate it
<apteryx>GNUtoo: 'guix package -A'
<apteryx>so "guix package -A | wc -l"