IRC channel logs

2023-08-05.log

back to list of logs

<unmatched-paren>nckx: also, guix shell -Df guix.scm works
<nckx>Yeah, as does ‘guix build -f’, this is clearly just a bug.
<nckx>Not an uninteresting one, but I'm afraid I don't have time to dive into it at this time.
<fries>hmm, gdu has an official source tarball on its github releases page, but i do see that theres a "mirror://" protocol
<fries>does that guix protocol support github releases?
<unmatched-paren>fries: that's a shortcut for things like gnome
<nckx>fries: Nope. https://git.savannah.gnu.org/cgit/guix.git/tree/guix/download.scm#n53
<nckx>It's a simple hard-coded list and GitHub ain't on it.
<nckx>But… they don't have ‘mirrors’ anyway, no?
<unmatched-paren>or kde, or gnu, or... some other large project-thing
<nckx>Just a big cee dee en behind the github.com name.
<unmatched-paren>why is there a LET around %MIRRORS that unconditionally defines GNU-MIRRORS but there's no LET for any of the others
<unmatched-paren>fries: if you want to download a github release, generally you use (method git-fetch)
<fries>is that more reliable then using a packaged tarball?
<unmatched-paren>and (uri (git-reference (url "https://github.com/blah/blah") (commit version)))
<unmatched-paren>it's just cleaner, i think
<nckx>unmatched-paren: Because of the map cut right below it. If you mean ‘no, but *WHY*’, then I don't know.
<unmatched-paren>also generalises to other git hosting sites
<unmatched-paren>nckx: ah, right
<unmatched-paren>ACTION cannot see
<unmatched-paren>now, whether or not (commit version) will works depends on the format of their versioning tags
<unmatched-paren>you'll have to check that
<unmatched-paren>if they look like 1.0.0, it will work; if it looks like, say, v1.0.0, you'll have to do:
<unmatched-paren>(commit (string-append "v" version))
<nckx>(They do.)
<nckx> https://github.com/dundee/gdu/tags
<unmatched-paren>ah
<podiki>oh neat, guix build will show dependency cycles now instead of just exhausting itself
<nckx>podiki: IKR!!!!!
<nckx>guix import pypi -r heisenbridge | wc -l → 349
<nckx>Thanks, I hate it.
<podiki>nckx: happy to help with a bridge/hosting in needed, just let me know
<podiki>my quick try showed dependency cycle with pytest-enabler but I have to dinner now
<podiki>nckx: I've gotten thousands of lines before so anything with like ~10 packages seems reasonable....but that says more about the pain I've inflicted on myself more I guess
<unmatched-paren>podiki: does this extend to other guix commands?
<nckx>podiki: Thanks, but having thought about it for more than 2 seconds that would mean manually herding everyone over to #guix:podikispotatopie.biz for… presumably a short while until we set up something more official-looking, and that will irritate people even more than my constant harping about Matrix in this channel lately.
<podiki>unmatched-paren: I don't know! but I like it
<nckx>If there is a big manual migration, let's keep it to once.
<podiki>nckx: right. you do need a matrix server you can access to allow the appservice (bridge)
<nckx>Yeah.
<podiki>anyway, must run for now, let me know what I can do to help
<nckx>Run! While you still can! And thanks for your offer!
<unmatched-paren>ACTION away
<viaken>Is it just me, or does tlpui fail a build because lspci is in a different place in pciutils?
<viaken>nckx: I imported dendrite the other day and it was 7k lines. Nothing comoared to nushell's 13k, tho.
<fries>does go-build-system have a way to output a debug output
<fries>since it seems to strip symbols and theres a problem with the go program hanging
<zmhanham[m]>anyone have a clue what a "guix system: error: more than one target service of type 'shepherd-root' error could be caused by? From running guix system reconfigure. It's likely being caused by this code I wrote to insert nvidia stuff into a operating-system config.... (full message at <https://libera.ems.host/_matrix/media/v3/download/libera.chat/8e203f181ecff4ed215edc841371a7bebc2185ee>)
<zmhanham[m]>probably the "operating-system-services" part in my modify-services is incorrect? But I'm unsure
<zmhanham[m]>also apologies if this counts as discussing proprietary software, but I thought it should be ok since this is a generic problem not really nvidia specific
<viaken>zmhanham - I don't have it near me, but I had to use suchandsuch-user-services.
<nckx>zmhanham[m]: This is due to an ugly abstraction leak (or maybe not enough abstraction, depending on your viewpoint). There are implicit services, so that (operating-system-services OS) returns more than what you wrote under (services …). When your write anything resembling (operating-system (services (operating-system-services another-operating-system)), those implicit defaults are added twice. Replac
<nckx>e operating-system-services with operating-system-user-services to modify the latter.
<nckx>viaken: Fixed.
<nckx>viaken: I've entered the ‘let's disable all the test suites’ neighbourhood of rock bottom.
<nckx>It's not very effective.
<viaken>I understand the impulse
<nckx>What would cause a Python package to install itself as version 0.0.0?
<nckx>There is a ‘Version: 4.3.0’ in PKG-INFO.
<damo22>perhaps missing git tags?
<nckx>It's a PyPI tarball. I don't see any mention of git (but then where would I look?).
<nckx> https://pypi.org/project/jaraco.context/
<zmhanham[m]>thanks viaken nckx it fixed the error :D
<nckx>Something's off. *All* these packages are installing themselves as 0.0.0.
<nckx>o.o
<nckx>Calling it ‘suchandsuch-user-services’ would have been more honest.
<ulfvonbelow>is there a good way to associate extra information with a running shepherd service? For example, I have a process running in a container whose PID I need to remember, as well as a parent process of its that I need to remember, as well as a monitoring process. All of these processes should be shut down when the service stops.
<ulfvonbelow>I know the 'running' value can be other than just a pid, but I need shepherd to still understand the various PIDs involved
<nckx>ACTION points.
<nckx>sneek: botsnack.
<sneek>:)
<Kabouik_>I noticed that the vscodium package forcefully sets the architecture to x64 from the download url in the package definition, and installs it on non-x64 systems. I think there are other architectures available to download, but I don't know how to detect the architecture in a package definition. Is the packager here?
<jackhill>Kabouik_: I don't think vscodium is yet packaged for Guix. Probably best to ask whereever you got that definition. Besides, generally source code isn't achitecture-specific.
<Zambyte>Hi, does anyone know why a racket/gui program compiled with raco exe would be crashing with the following error: "system error: libfontconfig.so.1: cannot open shared object file: No such file or directory
<Zambyte> context..."
<sneek>Welcome back Zambyte, you have 1 message!
<sneek>Zambyte, RavenJoad says: Now wally-cli is pushed to Guix. Bug report 64778.
<Zambyte>RavenJoad: oo sweet!
<Zambyte>I checked the package definition of racket and it has fontconfig as an input, so I'm not sure why it would be missing that shared object file
<Zambyte>I also just checked: same error when passing the --gui flag to raco exe.
<Guest28>Will Guix transition from pulseuadio to pipewire as the default?
<nckx>Probably. Nobody can say for sure.