IRC channel logs

2023-07-22.log

back to list of logs

<nckx>I'm afraid there is no ‘just’ to running binary blobs on Guix System, although the FHS environment is a big step in that direction.
<Zambyte>ld-linux-x86-64 is found with ldd - I went through and added the dependencies to a guix shell before runinng it
<Zambyte>I will try running in a FHS environment
<bjc>strace will show you what it was looking for that returned enotfound
<bjc>it could be countless things
<Zambyte>bjc: I did that, it says the file itself is missing
<nckx>Nah, it'll just fail—yep.
<Zambyte>execve("./wally", ["./wally"], 0x7fff4574eab0 /* 83 vars */) = -1 ENOENT (No such file or directory)
<Zambyte>but: -rwxr-xr-x 1 robby users 9403752 Jul 21 17:18 wally
<bjc>that does seem like shared library infrastructure, then
<nckx>You say ld-linux is found, but ‘$(guix build glibc|grep [0-9]$)/lib/ld-linux-x86-64.so.2 /tmp/wally’ complains about a missing libusb, which sounds like it's further than you're getting. Are you sure the linker loader is found?
<Zambyte>I have libusb in my guix shell
<Zambyte>guix shell libusb webkitgtk-with-libsoup2 gtk gdk-pixbuf pango cairo atk libsoup glib pkg-config
<nckx>Yes, and I don't, but the salient point is the rest of my message.
<nckx>ld-linux.
<Zambyte>ldd output reports: /lib64/ld-linux-x86-64.so.2 => /gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35/lib/ld-linux-x86-64.so.2 (0x00007f4b7ab31000)
<nckx>But does that mean it's found at run time?
<Zambyte>AFAIK yes
<nckx>OK. I'll take you word for it.
<nckx>*r
<bjc>guix shell glibc libusb webkitgtk-with-libsoup2 gtk gdk-pixbuf pango cairo atk libsoup glib pkg-config -- ldd wally ⇒ libusb-1.0.so.0 => not found
<bjc>among many others
<Zambyte>Running in a fhs container will actually run the binary now - but I am getting an application error
<nckx>fatal error: unexpected signal during runtime execution
<nckx>Fun.
<bjc>i assume it's got /usr/lib or whatever in the rpaths
<nckx>Yes.
<RavenJoad>Zambyte: I have packages wally-cli in my personal channel. Perhaps I will submit it upstream.
<Zambyte>bjc: run like: LD_LIBRARY_PATH=$GUIX_ENVIRONMENT/lib ldd ./wally
<Zambyte>RavenJoad: that would be amazing \o/
<Zambyte>If I could rip it out of your channel and run it myself that would also be nice
<nckx>Zambyte: Which error do you get? Same as mine?
<Zambyte>Looks like it, yes
<RavenJoad>wally-cli is easier to run than wally, because of the lack of GUI. You pretty much can just rip it out. wally-cli is spread across 2 modules: go-xyz.scm and wally.scm. https://github.com/KarlJoad/synnax/tree/master/modules/synnax/packages
<Zambyte>this is a graphical application - I wonder if there is an issue with running in a container
<nckx>Probable.
<Zambyte>RavenJoad: Great, thanks! I will give that a shot :)
<nckx>I've tried --exposing and --preserving a few things but my motivation's gone now that there's a channel :)
<RavenJoad>Just make sure you have the udev rules set for your keyboard and that your user is part of the plugdev group. You have to make that group yourself.
<Zambyte>RavenJoad: thanks for the tip, I have added the udev rules and group (I think)
<Zambyte>I have added some other udev rules so I'm pretty sure I got this one right
<RavenJoad>I may get some patches put together and send them up later. It is a pretty easy package to package and build.
<bjc>huh. ‘ld.so ./wally’ works
<bjc>that's a head-scratcher
<bjc>it looks like a keyboard firmware thing
<RavenJoad>bjc: It is. wally is used to flash keyboard firmwares.
<bjc>where is ‘readelf’? binutils?
<RavenJoad>Yes
<bjc>hmm. is LD_LIBRARY_PATH used when searching for ld.so?
<bjc>i mean when using INTERP as part of the kernel execution process. i suspect it's used verbatim and the LD_* variables are only used once ld.so takes over
<bjc>the manual page implies that to me, at least, and its consistent with the observed behavior
<yewscion>Hey all, does guix home propagate guix now, or have I made a mistake somewhere in my manifest that caused it to be installed in the home profile?
<bjc>guix home shouldn't propagate the guix executable
<yewscion>bjc: Copy, I didn't think it would, but it did. I'll keep digging, thanks for the confirmation!
<bjc>that should always be under its own profile in ~/.config/guix/current/bin
<RavenJoad>I believe Guix should propagate itself.
<yewscion>Yeah, that's where I was expecting it to be. But after I ran guix home reconfigure (after editing my config and doing guix pull) my personal channel's packages were not showing up in guix install or guix show. So I ran hash guix to figure out which version it was using, and it's inside of my home profile. Weird.
<singpolyma>Maybe did guix install guix by accident
<yewscion>It's not listed in guix package --export-manifest as being installed in that profile, though I can confirm it is indeed the guix from the guix package after running file $(which guix).
<yewscion>singpolyma: This was in a guix home profile, which iiuc can't be modified using guix install. Has to be done through guix home reconfigure.
<Zambyte>RavenJoad: I was able to use the wally-cli package from your channel to do what I wanted :D
<RavenJoad>Perfect! I'm glad it helped.
<RavenJoad>When packaging something that is stable, but never had a release, tag, or release-branch made for it, what should its version be? Just a git hash?
<RavenJoad>Nevermind. I RTFM-d.
<RavenJoad>But what should the version argument to git-version be for (version (git-version "version" revision commit))? Can it just be "master"?
<nckx>"0.0.0"
<nckx>So you'd have 0.0.0-0.abcdef9 as end version.
<RavenJoad>Alrighty.
<damo22>when you guys are doing packaging, and have to work around something that isnt quite right in the build script, do you have a systematic process to upstream your workarounds? or do they just get absorbed in guix?
<nckx>ACTION feels seen.
<nckx>I upstream too few fixes, and when I do it's far from systematic.
<lilyp>I systematically avoid creating an account on github, if that counts
<damo22>i didnt intend that to be insulting, just wondering if there is a way to upstream that great work
<lilyp>well, that obviously depends on the upstream; sometimes contacting them and saying "hi, I'm packaging your stuff for guix, I found this or that bug, here's a patch" goes great lengths, sometimes you're stuck in an issue tracker
<bjc>i created a github account back when it was still in beta in like '08, and i was young and foolish
<nckx>ACTION wasn't insulted.
<nckx>ACTION has a GitHub account, too.
<RavenJoad>sneek: later tell Zambyte Now wally-cli is pushed to Guix. Bug report 64778.
<sneek>Will do.
<RavenJoad>Of course I forget to add myself to the author list at the top...
<bjc>heh: “id: cannot get effective UID: Gratuitous error”
<bjc>the hurd is fun
<damo22>bjc: how did you trigger that
<nckx>RavenJoad: You can add it & send a -v2 to 64778@debbugs.gnu.org.
<bjc>damo22: you can use the command line before you're logged in on the console. since you're not yet logged in, there's no uid available, and i guess this is how glibc handles that weirdness
<RavenJoad>nckx: That is what I will have to do.
<nckx>You have no choice.
<damo22>bjc: how did you get a shell without logging in?
<RavenJoad>Just add -v2 to git send-email? Or just re-send the entire patch?
<bjc>the “login>” prompt will run normal executables for you
<damo22>?
<bjc>so you can ‘cat README’ or ‘ls’ or, in this case, ‘id’ before login
<nckx>RavenJoad: Commit using --amend, then git send-email -v2 --to=64778@debbugs.gnu.org, yes.
<damo22>is this using guix to run a childhurd?
<bjc>i'm running it directly from qemu, but it might work from a childhurd as well. i haven't messed with that much
<damo22>i dont get login> on a debian hurd
<bjc>might be a guix thing, then. i don't remember seeing it when messing with the hurd on non-guix distros, but that was a long time ago
<damo22>ok
<RavenJoad>nckx: All done. Thanks for the pointers.
<squeaktoy>Anyone know how to debug unclosed parameters?
<squeaktoy>I find it hard to count them
<nckx>Use an editor that automatically indents entire code blocks. Or at least highlights the matching bracket when the cursor is at its twin. Or if that's too boring: something that highlights matching pairs with colours.
<nckx>I'd say nobody here counts them, but there's always that one…
<bjc>we do have someone who goes by “unmatched-paren”
<squeaktoy>how do I do the color thing
<squeaktoy>also vim doesn't help when the other pair is offscreen
<bjc>doesn't ‘%’ in vi bounce between parentheses?
<ChocolettePalett>> ... highlights matching pairs with colours
<ChocolettePalett>and looks like those "programming socks"!
<nckx>emacs-programming-socks sounds so much better than emacs-rainbow-delimiters.
<nckx>And I have no idea how to do so in vim, it's vim.
<squeaktoy>I'd like latex programming socks
<squeaktoy>squeak squeak
<nckx>They are squeakey.
<nckx>Damn you and your lack of lag.
<nckx>ACTION should really get a bouncer that doesn't round-trip the globe.
<squeaktoy>ACTION squeaks nckx
<nckx>ACTION is squek.
<superkamiguru>So I am running into a bit of an issue. I have a Guix install that I am using to generate a new Guix System Image. After updating with ```guix pull``` and ```sudo guix system reconfigure /etc/config.scm```, the image produced with ```guix system image ...``` doesn't contain the most up to date packages from the last update. Does anyone have an idea
<superkamiguru>why this might be the case?
<apteryx>what's the oldest Guix commit you've been able to time-machine travel to?
<superkamiguru>I am updating the system again really quick, but I can look. What would be the best way to find the oldest Guix commit available?
<nckx>I think the question might not have been aimed at you personally…?
<nckx>Anyway, good night Guix o/
<xd1le>goodnight o/
<yewscion>Hey Guix, I was adding some guile libraries to my home configuration, and found that guile-imanifest propagates a 'guix' binary into the profile it's installed in. Is this expected behavior, or should I report it as a bug?
<next4th>yewscion: does it cause something wrong / broken somethings?
<yewscion>next4th: I mean, it causes ~/.guix-home/profile/bin/guix to be used in place of ~/.config/guix/current/bin/guix, with all of the issues that causes (not respecting channels.scm, for one). But as guile-imanifest is a package specifically concerned with generating guix manifests programmatically, I was unsure if that's just the cost of using the package, which might only be meant for specific situations.
<yewscion>Basically, yes, installing guile-imanifest as a user will generally result in undefined behavior, but I'm wondering if it's only undefined because I don't know the package in question well.
<next4th>okay, i see. i think it worth report a bug :\
<yewscion>next4th: Alright, will do. Thank You!
<PotentialUser-49>Hello, how can i request for an application to be packaged?
<janneke>there's a whish list here https://libreplanet.org/wiki/Group:Guix/Wishlist
<janneke>but i'm not sure how well it works, if at all?
<lilyp>well, many of them aren't easily packaged, but people have a look at the list
<moelogis1>when a package is installet from the home profile, is guix package -I supposed to list it?
<jpoiret>nope
<jpoiret>you need to use `guix package -p ~/.guix-home/profile` i think
<meologismo>makes sense, thanks
<janneke>or guix home describe --list-installed
<meologismo>yeah i figured that's why, people shouldnt manipulate home-installed packages directly
<meologismo>web servers and such are meant to run on system level, not as user service instances correct?
<janneke>meologismo: yeah, that's usually the case
<pjals_fox>hey, whats the convention for usage of % in guix?
<pjals_fox>it seems to be either %foo low-level, fast, dangerous function, or Lisp system specific implementation of foo or %foo% local special variable, but none of those really fit
<janneke>pjals_fox: global variables and parameters are named %foo
<pjals_fox>parameter as in a value applied to a procedure?
<pjals_fox>or a parameter as in (make-parameter)
<pjals_fox>janneke: ^
<janneke>pjals_fox: the latter
<janneke>ACTION is unsure how one would apply a value to a procedure...
<pjals_fox>by that i mean (apply procedure value) :^)
<pjals_fox>also, what do you mean by global?
<bjc>some many hours into building hello, my hurd vm froze while building glibc-intermediate because of a use-after-free assertion failing in ext2fs
<janneke>pjals_fox: ah, well i would say that is applying a procedure to a value ;)
<janneke>bjc: ouch...
<bjc>annoying, for sure. but it exposes a much bigger issue: you can no longer boot the machine because the boot scripts won't fsck the disk for you
<bjc>i can do it from the host, of course, since it's a vm, but on bare hardware that's a showstopper
<squeaktoy>config.scm: https://bpa.st/YYFQ ; log: https://bpa.st/K37A ; anyone know what's wrong with my config?
<janneke>bjc: yeah, pretty annoying
<janneke>otoh, i wouldn't know how to install guix/hurd on hardware without having a guix/linux partition
<janneke>lots of room for improvments, though! ;)
<bjc>hehe
<Wurt>Hi, a month ago I sent my first Guix patch, https://issues.guix.gnu.org/63955 . I would like that someone could check this. What can I do to fix this situation?
<radio>Guys
<bjc>Wurt: i only have some general comments: the patch set looks like it should be a single patch, because it's only a single piece of functionality. the commit message should abide by the gnu coding standards. and i don't think you should mess with ‘(guix utils)’ because it will cause a lot of rebuilds
<radio>What's the fundamental difference from guix home and rde?
<bjc>i might be confuing (guix build utils) with (guix utils),though
<radio>Are they complementar? What should convince someone to use rde?
<Wurt>bjc: Thanks for your comments! I will redo that patch.
<davidl>anyone else having problems with downloading substitutes right now? Mine is restarting and has tried both ci and borduoux.
<meologismo>davidl: i've had occasional network hiccups over the last week or so
<davidl>meologismo: ok. good to know its not just me then
<meologismo>...i added xauth to the system manifest and now reconfigure is compiling the kernel
<meologismo>lol
<me7539420>why is it not "advertised" that guix is source-based? It just took me over 3 hours to install, guix pull and configure
<pjals_fox>thats because the current version a new commit, so all the binaries havent been built
<pjals_fox>by default, guix fallbacks to building from source when there are no binaries
<me7539420>okay, thank you. so it is usually binary just transitional at the moment?
<pjals_fox>yea, it usually downloads binaries (we call them substitutes, actually) unless you pass --no-substitutes, which forces guix not to download substitutes
<me7539420>Does it have to recompile the entire kernel every time you pull and configure? bc I think that's what it's doing
<pjals_fox>normally it should save the build output in the /gnu/store, so after configuring atleast once after pulling, you wont need to wait for linux to build until you pull again
<me7539420>okay, thanks for your help. it is the first pull and configure on a fresh install. Perhaps one last question. It doesn't say how often to pull and configure in the user manual, just that you should often for security. So how often should I be pulling and configuring?
<pjals_fox>i pull and reconfig every 10 days
<pjals_fox>like the command should say if you do anything that modifies the store without pulling for 10 days
<pjals_fox>*before in atleast
<pjals_fox>*atmost?
<me7539420>that's very helpful. I really appreciate it, thanks so much
<pjals_fox>you're welcome!
<squeaktoy>Anyone want to investigate my config.scm issues?
<squeaktoy>config.scm: https://bpa.st/YYFQ ; log: https://bpa.st/K37A ; anyone know what's wrong with my config?
<janneke>me7539420: there was a kernel patch yesterday and there are no substitutes yet
<janneke>=> https://git.savannah.gnu.org/cgit/guix.git/log/?id=acbb9d2dadc7011bce7e022689633944e595e75b
<janneke>if you were to pull to the previous commit, i.e., guix pull --commit=bdcf23cf69d47a1b576e70da63da08518329c0f5, you won't have to build the kernel
<me7539420>thank you janneke. how is it that you're able to track that, like if I wanted to? through the patches mailing list? bc I'm not finding anything on website itself
<janneke>me7539420: you could browse the git web interface that i linked above
<apteryx>efraim! hi! some git bisecting led me to b93057256fa982d985a80b3d3d52f783f2d3ef7b ("guix: cpu: Rewrite fallback for x86_64 cpu->gcc-architecture.") breaking the following program: https://paste.debian.net/1286608/ Is this possibly related?
<me7539420>yeah, I see. thanks. it's a patch tracking tool
<janneke>but i looked at my local guix git clone
<me7539420>I found the link to it on the website under the patches mailing list
<janneke>you just "picked" an unusually unfortunate moment to pull, linux-libre wise...
<me7539420>lol that's what I've come to realize
<me7539420>I'm going to stick with it though and really try to learn this system
<me7539420>I'm coming from hyperbola
<me7539420>nothing wrong with it, just wanted to try guix
<janneke>sure, welcome ;-)
<meologismo>why does gc remove some stuff from the store and then the next reconfigure immediately redownloads them, is this normal
<apteryx>hm, why does git bisect think 2ca299caf64489f4e1e665ec1158fb0309b0b565 is not an ancestor of master's HEAD ?
<janneke>meologismo: are you using guix gc with --free-space and/or --delete-generations?
<meologismo>janneke: no
<meologismo>maybe i just dont understand how it works
<janneke>meologismo: well, if you don't give guix gc any restrictions, it will remove anything that's not referenced in a profile
<janneke>so in that case, any build dependencies that are not referenced directly, e.g., sources, can (and will) be removed
<jpoiret>meologismo: if you're talking about grub, then grub is not referenced by anything and is only needed by reconfigures
<jpoiret>so `guix gc` will happily get rid of it even though you might still want it later no
<jpoiret>on *
<meologismo>jpoiret: no, i'm not sure if its misbehaving
<superkamiguru>Anyone know why `guix system image` wouldn't use the most up to date version of Guix? When I update my system and then create a new image, it's always based on the original version my system was created using.
<mwette>squeaktoy: I think maybe (services (cons* (list ... should be (services (append (list ...
<mwette>you can usually use (keyword (cons* item item item %base)) or (keyword (append (list item item item) %base))
<mwette>^ if I have the convention right
<nckx>superkamiguru: Are you sure you're invoking the right (up-to-date) Guix? What does ‘type guix’ say?
<nckx>Re: GC: Adding ‘--gc-keep-derivations=yes’ and ‘--gc-keep-outputs=yes’ to your guix-daemon invocation (guix-service-type) might help keep more build-time things around.
<superkamiguru>nckx: `guix is /home/admin/.config/guix/current/bin/guix` is the output.
<nckx>Damn it, that's correct.
<superkamiguru>I ran `guix pull` followed by `sudo guix system reconfigure /etc/config.scm` prior to generating the system image. I also tried removing previous generations after updating and before generating the new image. The produced image is still based on the original version of my current system
<superkamiguru>^ just to give some more context
<nckx>That's… not… no, guix should never ‘look’ at your running system. It's not like some other distro image helpers that copy things they find in /.
<nckx>And you're sure this is the exact commit you used to init your system, not the commit shown by ‘guix show guix’? (The ‘guix’ package in, er, Guix always lags behind the ‘outer’ Guix.)
<nckx>ACTION called away.
<superkamiguru>I can double check but it looked to be the same. Also, for example, before generating the new system image `guix pull` detects about ~2400 changes, and after updating and generating the new image, `guix pull` still detects the ~2400 changes.
<superkamiguru>Not sure if it is important to know but my current system was also created using `guix system image` since it's an aarch64 machine.
<jpoiret>yes, that's expected
<jpoiret>guix system image uses a fixed version of guix, not the one from guix pull
<jpoiret>(the one defined as a package, you can see it via `guix show guix`)
<jpoiret>well, let me clarify a bit: the guix that builds the image is the one you're using (so the recent `guix pull`'d one), but the guix that ends up in the image is older and fixed
<nckx>ACTION ret.
<squeaktoy>guix system: error: service 'networking' requires 'wpa-supplicant', which is not provided by any service
<superkamiguru>Oh ok. thanks! Is there any way to update which guix is defined as a package?
<Tecjor[m]>Hello, for some reason in my telegram-web update in my GNU system at 19% it leaves my machine immobile, that is, it leaves it without operating and does not allow me to do anything, any ideas. Greetings
<nckx>superkamiguru: Ah, that explains what would be otherwise be an extreme coincidence (if you'd used ‘guix system init’).
<squeaktoy>Anyone know how to get this wpa-supplicant thing?
<squeaktoy>adding wpa-supplicant to packages doesn't work so idk
<nckx>Tecjor[m]: I'm not seeing a telegram-web package. However, what you describe sounds like you're running out of RAM.
<nckx>You could invoke the OOM killa with SysRq-F. (Where SysRq is often Alt+PrintScreen.)
<me749902381>squeakytoy it's in the repos
<squeaktoy>wdym
<squeaktoy>I tried but it still complains
<me749902381>wpa-supplicant is in the repos
<nckx>squeaktoy: Tried what?
<squeaktoy>adding wpa-supplicant to packages
<nckx>Packages don't provide services.
<superkamiguru>squeaktoy: you will want to add wpa-supplicant-service-type to your servies
<me749902381>squeaktoy can you "guix install wpa-supplicant"?
<nckx>(service wpa-supplicant-service-type)
<nckx>squeaktoy: ☝
<superkamiguru> https://guix.gnu.org/manual/en/html_node/Networking-Setup.html
<nckx>me749902381: That won't affect the service graph.
<Tecjor[m]>nckx: I meant Telegram-Desktop
<me749902381>okay, didn't know that. I just installed guix today, so still learning
<ngraves>Hi Guix ! Does someone know if there's a way to pass a variable from one build step to another without having to setup a fancy way to have state variables across build steps ? There's the solution to write to a file, and then read from that file in later build steps, but isn't there a way to read it only once if the content of the file has to be
<me749902381>very lively irc
<ngraves>used in multpile build steps, instead of readnig it multiple times ?
<nckx>me749902381: You're here at a very active time, there is also peace and quiet to be found in #guix. But welcome!
<superkamiguru>me749902381 welcome to the community! There's a lot to be learned but the people here have been really helpful
<AwesomeAdam54321>ngraves: Does (setenv "VARIABLE" "value") work?
<me749902381>nckx thanks!
<me749902381>superkamiguru thanks too!
<me749902381>i'll get a username eventually
<me749902381>so i'm running icecat browser. the last release was like 2019 but the package itself was only built a month ago. is that safe or should I run something more updated? i love icecat and want to use it
<nckx>Tecjor[m]: I was expecting to find webkit or so in the ‘guix size telegram-desktop’ output, which is notorious for using up all your RAM, but it's not that. Still, what you describe sounds like low RAM. You could pass -{M,c}1 (-M1 -c2, to run 1 build at a time with ‘make -j2’ or equivalent, etc.) if you don't mind slower builds that will use fewer resources at once.
<nckx>Without more info there's no way to tell what's actually happening. OOMs do get logged in dmesg, though, if you can get your machine to respond again.
<nckx>me749902381: Guix's IceCat gets somewhat special treatment from IceCat's upstream. It is not the 2019 release but much newer.
<me749902381>nice! what a relief
<superkamiguru>jpoiret: Is there any way to update which version of guix is used with `guix show guix`? Or is this something that behaves differently on a system generated with `guix system image` vs using the installer?
<me749902381>guix is just checking all the boxes
<ngraves>Oh of course, I was trying to simplify the antioxidant build-system from Maxime Devos, so the whole thing about state variables was making this complex. I think the issue would be more complex because I would also have to take care of cleaning the variables afterward, but hopefully, this will do the job.
<nckx>superkamiguru: I've never tried it, but --with-commit=guix=$THE_LATEST_COMMIT might work.
<nckx>I can think of reasons why it wouldn't, though.
<AwesomeAdam54321>ngraves: I think at some point the efforts on the antioxidant-build-system have to be merged at some point
<Tecjor[m]><nckx> "Tecjor: I was expecting to..." <- guix install --option='make -j2 -{M,c}1' telegram
<nckx>guix install -{M,c}1 telegram-desktop
<Tecjor[m]>👍️
<AwesomeAdam54321>nvm, I read about this before and thought there were 3 separate antioxidant-build-system efforts: https://lists.gnu.org/archive/html/guix-devel/2023-06/msg00005.html
<nckx>-M means max number of packages to build at a time. -c limits the number of ‘cores’ each build may use. -M directly controls Guix, where -cN is just a hint to the package's build system.
<nckx>ACTION wonders in which year a single person last used guix-daemon's ‘--impersonate-linux-2.6’ option.
<squeaktoy>Hey the kernel stack corrupted while I was doing a guix system init
<nckx>wat
<squeaktoy>is linux-libre 6.0 buggy or something?
<nckx>Is this the 1.4.0 installation image? I've used it a few times, never had any kernel bugs.
<Tecjor[m]>the '--impersonate-linux-2.6' option was removed in version 0.3.0, which was released in 2014. So the last time a single person used this option was in 2013 or earlier.
<nckx>I'll just… remove it from the manual then.
<squeaktoy>businesses use Linux 2.6
<squeaktoy>I don't know how, but they do
<squeaktoy>Some kind of undisclosed version of RHEL that uses Linux 2.6
<squeaktoy>With all the security bugs mysteriously fixed
<nckx>Yeah, I think that's what rekado is/was using.
<squeaktoy>I can't find anything about it either
<squeaktoy>It's so mysterious and undisclosed
<nckx>Tecjor[m]: You sure? The code still seems to be there, too.
<squeaktoy>But at a business I worked before they had Linux 2.6 running
<squeaktoy>The build date said 2020 iirc
<squeaktoy>I can't find any build of RHEL or Linux 2.6 from 2020
<squeaktoy>As far as I can find on the surface web, Linux 2.6 is not maintained
<squeaktoy>But I guess businesses have some deep web distribution of RHEL or some shit
<nckx>I'm still sceptical of the usefulness of Guix's option though. I think it's just more trouble to remove than to maintain, since the daemon isn't strictly speaking maintained.
<squeaktoy>Linux 2.6 sounds like a golden era though, even though I never experienced it besides that business
<squeaktoy>Kind of as if Linux 2.6 is the Windows XP of Linux
<Tecjor[m]>I'm not sure
<squeaktoy>Because Linux 2.6 continues to be used by businesses despite EOL (same goes for Windows XP)
<squeaktoy>Linux 2.6 had a very long lifetime (just like Windows XP)
<nckx>Yeah, 2.6 was just a very long series.
<nckx>I think it was also the first series to be officially LTS'd.
<nckx>I don't remember it being golden at all.
<jpoiret>superkamiguru: you can also override the guix configuration of your installation and use (current-guix) from (gnu packages package-management)
<Vieta[m]>Do we have a list of Guix mirrors?
<squeaktoy>I cannot log in to my system
<squeaktoy>always says password incorrect
<squeaktoy>wtf
<squeaktoy>I used the (password (crypt thingy
<squeaktoy>Also I need to disable this stupid console-font service
<nckx>Your nemesis.
<squeaktoy>because I got the kernel params working
<Vieta[m]>Do you have a passed for your root?
<Vieta[m]>s/passed/password/
<squeaktoy>yeah hold on
<nckx>Vieta[m]: Git mirrors or substitute mirrors? (The answer to both is ‘no’, though. Still.)
<squeaktoy> https://bpa.st/7QSA
<nckx>Vieta[m]: You didn't answer, but for substitutes I know of 2 mirrors, https://bordeaux-us-east-mirror.cbaines.net (which mirrors bordeaux in the US) and https://mirrors.sjtug.sjtu.edu.cn/guix (which mirrors berlin in the PRC), and for Git there's https://github.com/guix-mirror/guix (which mirrors guix.git at Microsoft).
<nckx>Microsoft ♥ Guix.
<squeaktoy>I've never seen Microsoft sponsor a GNU project
<raghavgururajan>nckx: Also, https://git.disroot.org/guix :-)
<nckx>raghavgururajan: Thanks! That seems mildly out of date, though.
<raghavgururajan>8hours?
<nckx>9 here. Time zones are… magic.
<nckx>squeaktoy: They don't. At all.
<nckx>Worry not.
<squeaktoy>nckx: anyways, do you know why rubber's password isn't rubber?
<squeaktoy> https://bpa.st/7QSA
<lilyp>squeaktoy: (password ) is only set when creating a fresh user; for changing an existing user, use passwd as usual
<squeaktoy>I can't even log in
<squeaktoy>Is it possible that guix system init doesn't affect existing users?
<squeaktoy>How do I force it to work?
<squeaktoy>How can I reinstall a guix system?
<lilyp>did you install over a previous distro? if so, try your old password
<ulfvonbelow>IIRC if there's not a password for root, you can always just ctrl+alt+f2 and log in with a blank password. At least, that's how it's worked on fresh installs for me in the past.
<squeaktoy>my old password is nonexistant
<squeaktoy>I'd like to completely overwrite my old guix system if possible
<lilyp>well, my old password is hackme, so yours beats mine
<lilyp>i think you can do a very sneaky thing
<lilyp>using the install disk, edit /etc/shadow, so the line for your user has "$6$123$YOvjp91FNCfh8DcFTO8oD7l06pb/HojR3q0JW/D3flnyQ0DKzri9F94azD3ccta7ye64jDZL1bBy7ckqvow5J."
<lilyp>(in case you're wondering, that's (crypt "rubber" "$6$123"))
<squeaktoy>What is the salt for anyway?
<squeaktoy>passwd -R /mnt rubber
<squeaktoy>that works
<squeaktoy>also god damn GNU info is just some program where the only thing I can figure out is q to quit it
<Tecjor[m]>What tool or package are you using to disassemble?
<Tecjor[m]>DISASSEMBLER
<squeaktoy>I like rizin/radare2 and GDB
<squeaktoy>On Windows, x64dbg is amazing
<squeaktoy>I've been able to crack some proggies with x64dbg, but not with rizin/radare2 yet
<ulfvonbelow>info is great if you read the info manual for it first
<pjals_fox>squeaktoy: u to go up between sections, arrow keys to move the cursor, enter is to follow links
<pjals_fox>/ is to search
<pjals_fox>anything im missing?
<squeaktoy>but when I press enter I can never figure out how to go back anymore
<ulfvonbelow>or if you're in emacs, you can just C-s <query> C-s C-s C-s <mash to infinity> to find instances
<pjals_fox>squeaktoy: press u
<ulfvonbelow>it's l to go back
<ulfvonbelow>at least in emacs
<squeaktoy>I still have to figure out emacs
<squeaktoy>I'm a vim user
<squeaktoy>It's hard to break the habit of vim
<squeaktoy>Once vim, always vim
<pjals_fox>emacs-evil
<squeaktoy>but that's evil
<pjals_fox>vim is also evil
<nckx>ACTION was away. Anyway, ‘guix system init doesn't affect existing users’ was the answer.
<squeaktoy>whyyy
<squeaktoy>But how can I make it affect existing users?
<squeaktoy>Does guix system init affect other aspects of the system like which services will run?
<nckx>Remove /mnt/etc/{passwd,group,,shadow} perhaps.
<nckx>Perhaps because I might have forgot one.
<nckx>I wrote a poorly-writted wiki page on the wiki: https://libreplanet.org/wiki/Group:Guix/Mirrors
<nckx>Maybe it's manual material. Not sure.
<squeaktoy>Also I found that console-font-service thingy still runs and destroys the font I had set via kernel params
<squeaktoy>I still don't know how to disable it
<nckx>squeaktoy: Yes, and that's what's happening here: new users are created at system boot, not during ‘guix system init’. So ‘guix system init’ *is* adding a new ‘create user rubber with password rubber if user rubber doesn't exist’ service to the system, but when it runs, rubber already exists.
<janneke>nckx: having the text written down is the most important stap anyway
<janneke>nice!
<nckx>squeaktoy: I'd wager something like (modify-services %base-services (delete console-font-service-type)) in place of %base-services.
<squeaktoy>So I don't need to specify %base-services then?
<squeaktoy>modify-services just outputs the changes rather than modifying the %base-services variable?
<ulfvonbelow>yup, functional n stuff
<ulfvonbelow>modify-services just takes a list and returns a list
<squeaktoy>I keep forgetting where %base-services is defined
<nckx>(gnu services base)
<squeaktoy>Where are the gnu scm files stored?
<squeaktoy>so I can view the source code
<ulfvonbelow><PREFIX>/share/guile/site/3.0 + /gnu/services/base.scm
<ulfvonbelow>PREFIX can probably be something like /run/current-system/profile
<squeaktoy>does (delete) support (list)?
<squeaktoy>Or do I need to do (delete blah) (delete blah2)
<squeaktoy>it doesn't seem to error out while doing (delete (list console-font-service console-font-service-type))
<ulfvonbelow>I think that subform of modify-services expects a single service type, it might silently fail otherwise
<ulfvonbelow>since it just checks for pointer equality most likely, and that's a valid operation for every type
<ulfvonbelow>so the latter, (delete blah) (delete blah2)
<janneke>squeaktoy: (fold the-list (list blah blah2))
<janneke>eh
<squeaktoy>?
<janneke>squeaktoy: (fold delete the-list (list blah blah2))
<squeaktoy>the-list sounds weird
<janneke>your original list that you want to delete stuff from
<squeaktoy>/mnt/etc/config.scm:119:6: error: (%modify-service service (fold delete the-list (list console-font-service-type console-font-service))): source expression failed to match any pattern
<squeaktoy>I want to delete from %base-services
<janneke>squeaktoy: try: (fold delete '(0 1 2 3) '(0 2))
<squeaktoy>what are the numbers for?
<squeaktoy>Guess I'll just keep it simple and do separate deletes
<janneke>numbers are for counting
<janneke>squeaktoy: to remove from %base-services: (fold delete %base-services (list blah blah2))
<squeaktoy>Also why does every guix system init take so long even though all packages have probably been downloaded before
<lilyp>squeaktoy: because guix doesn't remember doing so
<squeaktoy>weird
<meologismo>will anything explode if i remove network-manager-service-type from %desktop-services and replace it with static-networking-service-type?
<squeaktoy>I've observed guix explode when you do not use network manager
<pjals_fox>wdym? im a networkmanager and connman hater and i havent seen guix explode
<squeaktoy>what do you use pjals_fox?
<squeaktoy>iwd?
<meologismo>well nothing exploded but gdm doesnt start
<meologismo>or rather it starts but nothing happens, local UI doesn't come up
<meologismo>gdm log is empty
<meologismo>is there an example of default gnome installation system configuration somewhere so that i can compare?
<meologismo>i'm sure i screwed up something in my machine config
<nckx>janneke: This delete isn't a procedure call.
<nckx>You can't fold in modify-services.
<nckx>Would be a cool world in which you could.
<squeaktoy>how do I properly delete a service then? console-font-service is still fucking up my font
<lilyp>modify-services + delete
<meologismo> https://lounge.mouses.xyz/uploads/26d37b5dc46517ca/20230722_121613.jpg
<squeaktoy>lilyp: well that didn't work
<meologismo>oops
<meologismo>sorry
<squeaktoy>meologismo: ooh please give me that piece of cake
<squeaktoy>I need to grow into a big squeaker
<meologismo>squeaktoy: it's a random thing from ##politics
<lilyp>meologismo: default gnome template should be the desktop one, but it uses networking service type as you'd expect
<meologismo>i dunno why it's in my buffer
<meologismo>lilyp: i got it to start by deleting network manager and wpa supplicant from %desktop-services
<nckx>squeaktoy: ‘Didn't work’ is dark and mysterious. What did you write, and what did Guix say?
<squeaktoy>it said nuffin
<lilyp>you're probably doing yourself a disservice here, those are core components of gnome
<squeaktoy> (modify-services %base-services (delete console-font-service-type)
<squeaktoy> (delete console-font-service)))))
<nckx>Guix is also dark & mysterious.
<meologismo>lilyp: I run i3-wm
<squeaktoy>When will Guix be light & transparent?
<nckx>Never.
<squeaktoy>bright & transparent
<nckx>(modify-services %base-services (delete console-font-service-type)) works here, in the sense that it returns a shorter list.
<squeaktoy>well my font still gets reset at the login screen
<lilyp>meologismo: that doesn't count too far if you still use gdm; you might want some other dm instead
<lilyp>chance is that's the kernel
<nckx>Mine doesn't, but I don't use %base-services at all.
<squeaktoy>Well idk how to debug this anyways
<squeaktoy>I can't find modify-services in the guile shell
<squeaktoy>and printing lists appears to be quite painful
<squeaktoy>painful to read
<nckx>,use (gnu services) → modify-services
<nckx>Yeah, I just wrapped it in (length …) to test.
<meologismo>lilyp: yeah ill switch to lightdm in a moment
<nckx>You can (map service-kind LIST-OF-SERVICES).
<nckx>Still ugly, but shorter.
<nckx>Note that the ‘kind’ is ‘console-fonts’, plural, but the ‘type’ is ‘console-font-service-type’, singular, just to confuse you.
<nckx>ACTION buggers off again.
<squeaktoy>So would just deleting console-font-service-type work?
<meologismo>huh i think i made guix hang
<rekado>re linux 2.6: it exists in name only
<nckx>Yeah, we were talking about the RH fake-out version.
<rekado>RHEL 6 is in extended support mode and still has a kernel that identifies itself as 2.6
<nckx>But even you don't use the --impersonate option, or do you?
<rekado>we’re not using RHEL 6 any longer
<nckx>uname --🥸
<nckx>Ah.
<nckx>Probably good.
<rekado>in June 2024 RHEL 6 will no longer receive extended support
<nckx>*Did* you use that option when you used RHEL6?
<rekado>I … don’t remember
<rekado>that would have been in 2018 or so
<rekado>when suddenly we weren’t able to build pigx right before publication
<rekado>I only remember digging through the srpm of the kernel to see if the features the glibc required are available in that 2.6 fake kernel
<rekado>and then we patched glibc
<rekado>but … I don’t recall ever using any impersonate option
<rekado>ACTION runs the update script again
<pjals_fox>linux64 --uname-2.6
<nckx>Mine was shorter.
<nckx>squeaktoy: I can't reproduce your failure in a VM.
<nckx>That's bare-bones.tmpl with this change: https://paste.debian.net/plainh/4ca1c032
<nckx>And when I create a VM without that change, it first downloads unifont, so it wasn't even included in the font-free image.
<nckx>…and it unifonts even before the log-in prompt. So yes, the diff I paste above is quite reliable and correct, a personal first.
<nckx>squeaktoy: I think you need to share your complete system.scm again, so we can hunt the typo together.
<nckx>rekado: R?
<meologismo>hmmm lightdm doesnt seem to be reading the session list
<ulfvonbelow>I'd like to request a package for python-cryptography@38.0.4. It's necessary for mitmproxy, and I'm going to go insane if I have to delve through both python and rust version hells.
<squeaktoy>I cannot make https connections
<squeaktoy>so I can't upload the paste
<squeaktoy>hmm
<nckx>…why isn't nss-certs in %base-packages anyway?
<ulfvonbelow>I imagine something about "the user should always explicitly choose their trust base" or something like that
<nckx>That's the answer I feared.
<nckx>C'mon…
<ulfvonbelow>IIRC the guided installer automatically adds it to the system packages
<meologismo>it offers to
<ulfvonbelow>ah, better
<squeaktoy>wtf
<meologismo>uhm i think changing display managers causes a hang in system reconfigure
<squeaktoy>why does curl work but wgetpaste not
<squeaktoy>thankfully I don't use display managers
<rekado>nckx: oops, that was for #guix-hpc
<rekado>(script for the guix-cran channel)
<nckx>It's easy to ‘forget’ (as squeaktoy did here: https://bpa.st/7QSA) and lock yourself out of most of the Web and I wonder if this is a reasonable trade-off.
<nckx>squeaktoy: Did you start from some template?
<squeaktoy>ye
<squeaktoy>barebones
<nckx>Cool, it doesn't even include nss-certs let alone a big fat warning.
<nckx>Please, save yourself some pain and add ‘nss-certs’ to your (packages …) list.
<meologismo>hmmm, what do I need to do to enable spice? the qxl driver package and the spice package do not seem to add themselves to xorg configuration's load module directives
<meologismo>of course its documented
<meologismo>nope, something is wrong
<meologismo>how is xserver.conf created? it's missing qxl drivers, but the packages for those are installed
<nckx>Installed how?
<meologismo>system configuration
<nckx>But where?
<meologismo>do I need to set-xorg-configuration to explicitly mention the qxl drivers
<meologismo>nckx: as packages
<nckx>meologismo: I think so.
<meologismo>aha
<nckx>Packages don't ‘do’ anything.
<nckx>So Guix's xorg-configuration doesn't sniff around your system packages field to see if there's anything interesting it can add, just like packages can't launch services on their own. It's a feature, but it's unusual compared to other distributions.
<nckx>I think the (modules …) field of xorg-configuration is for you.
<nckx>And remove them from (packages …).
<meologismo>makes sense
<squeaktoy> https://ttm.sh/BfE.jpg anyone know what this is?
<nckx>Jesus. Did you rob a tomb in a previous life?
<nckx>I asked this before but didn't see an answer: is this the Guix installer ISO?
<squeaktoy>This time it's actually not
<nckx>6.0.10 gnu is oldish.
<squeaktoy>It's the installed system
<squeaktoy>It's still 6.0.10
<squeaktoy>every time I do a guix pull it is very prone to panicking
<nckx>This is not normal.
<squeaktoy>and I did a guix system reconfigure and it panicked
<squeaktoy>the guix pull succeeded though
<nckx>I don't use linux-libre myself but I've not heard reports of this happening with 6.0 at all.
<nckx>ACTION doesn't use proprietary firmware or other nonsense, please don't PM me for support, people…
<squeaktoy>My thinkpad is free
<squeaktoy>I replaced the proprietary NIC
<nckx>Oh, I didn't mean you specifically.
<nckx>And this machine has proven itself stable in the past?
<meologismo>yeah it worked
<nckx>\o/
<nckx>squeaktoy: I could build you an installer image from current master, although it'll take a while.
<meologismo>nckx: im getting used to the declarative method, although my scheme is rusty
<meologismo>it does feel like there's some hacks floating around
<squeaktoy>I can't reconfigure my system
<squeaktoy>It keeps kernel panicking
<Guest28>I just installed network-manager and get "nm: 'a.out': No such file" if I run nm but nmtui works fine
<nckx>nm is a binutil, unrelated to network-manager.
<nckx>It dumps ELF symbols.
<nckx>squeaktoy: Did you see my offer above.
<meologismo>squeaktoy: this is a physical machine?
<Guest28>Ah, that explains a lot.  What was the cmd for the gui or is it a seperate package?
<squeaktoy>I first want to see if I can get the reconfigure to go through
<squeaktoy>This is on a ThinkPad X200
<nckx>Guest28: I don't know, sorry (I always use nmtui). Does NM ship its own GUI or does it rely on desktop environments and other third parties to provide one?
<meologismo>squeaktoy: highly suggest cleaning it and replacing the thermal compound
<nckx>Also, nckx> And this machine has proven itself stable in the past?
<nckx>If not, it's little use debugging Guix. Even if it has, machines fail. It's happened to me twice.
<nckx>Bad hardware always sounds like a cop-out until it happens to you.
<squeaktoy>according to someone in #libreboot, linux-libre is buggy
<meologismo>entirely possible
<nckx>6.0 specifically?
<nckx>(Also, leah isn't ‘someone’, or at least it's ‘the someone’ :)
<nckx>OK, so her rant doesn't target 6.0 specifically, just linux-libre.
<Guest28>GNU IceCat does not find CUPS printers.  Does someone which package am I missing?
<Guest28>know"
<nckx>If your machine's CUPS server is up and runnnig and configured, I have no idea.
<nckx>cups-service-type, that is.
<Guest28>Yep, need to print with the system dialog which is annoying
<nckx>I prefer the system dialog, so I was today years old when I discovered that my Firefox doesn't show any printers either.
<nckx>So it's a bug in upstream Firefox or (probably more likely) our IceCat packaging.
<squeaktoy>Hey linux-libre seems to be building from source. Are there substitutes available?
<squeaktoy>Binary subbies
<Guest28>Good, nice to know I am not the only one with the issue.
<squeaktoy>or whatever they're called
<Guest28>Do you configure the kernel?
<squeaktoy>I did nuffin
<Guest28>Hm, normally it uses substitutes unless you configure it.  At least that was always the case on my machines
<meologismo>there's no substitute for the latest kernel yet
<Guest28>guix weather linux-libre shows non available.  Guess it is still building
<squeaktoy> https://ttm.sh/Bf2.jpg :/
<nckx>Jeebes.
<hwpplayer1>hi people !
<nckx>o/
<squeaktoy>nckx: can you do the new image thingy?
<squeaktoy>I can't update my system like this
<nckx>Sure. https://tobias.gr/totally-legit-guix-eb12f3f.iso has linux-libre 6.3.
<nckx>I've sent you a PM.