IRC channel logs

2023-07-19.log

back to list of logs

<rekado>“bootloader-configuration” has no “installer” field
<latex>/mnt/etc/config.scm:70:35: error: (openssh-configuration (authorized_keys (quasiquote (("root" (unquote (local-file "pc_ed25519.pub"))) ("rubber" (unquote (local-file "pc_ed25519.pub")))))) (port-number 22)): extraneous field initializers (authorized_keys)
<latex>Now how do I solve this?
<nckx> https://paste.debian.net/plainh/ef139cc1
<latex> https://bpa.st/AOLQ
<nckx>‘_’.
<nckx>→ authorized-keys
<latex>What if I don't have efi?
<nckx>Then you inherit from the non-efi variant. I'm not 100% sure what it's called, maybe just ‘grub’.
<nckx>‘grub-bootloader’ in fact.
<latex>but wdym with ‘_’.
<latex>oh
<nckx>You wrote _ instead of -.
<nckx>:)
<latex>What is this wrong type to apply error?
<nckx>You're applying (calling) something that isn't a procedure.
<nckx>(define foo display) (display "hi") → "hi"
<nckx>I meant: (define foo display) (foo "hi") → "hi"
<nckx>(define foo 3) (foo "hi") → wrong type to apply
<latex> https://bpa.st/RKBA
<latex>idk what this is supposed to mean
<latex>or what's causing it
<nckx>That looks like %base-packages 🤨
<nckx>Could you share your current configuration?
<nckx>Yeah, it's %base-packages. Being called as a procedure.
<nckx>Which lists don't like.
<latex>So what does it need to be then?
<bjc>you have an error in the section of your config that is using ‘%base-packages’, but it's hard to say what without being able to see it
<nckx>latex: Can't help you if you don't help us.
<latex>I shared my config
<latex>You want another copy?
<nckx>Yes.
<bjc>i missed that, please do
<latex> https://bpa.st/O5AQ
<nckx>I want the actual configuration file throwing that error, not an older version.
<nckx>Thanks.
<nckx>See, you changed line 63 since you last shared it.
<bjc>(packages (%base-packages)) → (packages %base-packages)
<nckx>‘(packages (%base-packages))’ → superfluous ()
<nckx>‘(this)’ means call this as a procedure.
<bjc>by wrapping it in parentheses, you've told scheme it's a procedure call
<nckx>Replace it with (packages %base-packages) and you'll be fine.
<latex>Now there's something wacky with the bootloader, hmm
<latex>log: https://bpa.st/RVAQ , config.scm: https://bpa.st/QIQQ
<bjc>the argument to ‘bootloader’ is a ‘bootloader-configuration’
<latex>I remember it failing when I had it like that but let's try again
<nckx>Take my example.
<latex>/mnt/etc/config.scm:16:14: error: (bootloader-configuration (inherit grub-bootloader) (installer (gexp (const #t)))): extraneous field initializers (installer)
<latex>Yeah bootloader-configuration doesn't work while bootloader gets a little further
<latex>Not sure what the semantics are of that. This is all very new to me
<bjc> http://ix.io/4AV9 is what i use for my efi system
<nckx>That is not what I sent.
<latex>Oh so this (installer thingy is unneccessary?
<nckx>No.
<latex>I can just do targets /boot?
<latex>oh nvm
<latex>that's efi
<nckx>You said you didn't want to install a bootloader.
<latex>yeah
<latex>I just want the grub configs in /boot
<nckx>Then why would it be unnecessary.
<nckx>Anyway, (bootloader-configuration (bootloader (bootloader (inherit …) (installer …))).
<latex>log: https://bpa.st/SWMQ , config.scm: https://bpa.st/3MJA
<nckx>%base-services is inside the (list …)
<latex>It kind of sucks I can't make out anything from this log
<nckx>Your indentation (or your editor's) is misleading.
<latex>I use vim
<nckx>move one ‘)’ from (port-number 22)) to %base-services)))))
<nckx>If I'm counting correctly.
<nckx>I'm sure vim can count or even indent this for you, but don't ask me how.
<bjc> http://ix.io/4AVa
<latex>Alright it's doing things now
<latex>Why is the log so unfriendly though?
<nckx>bjc: See, I'm not good at counting.
<bjc>a bunch of factors, from guile being pretty unfriendly to guix being a thin layer on top of guile
<bjc>nckx: i just made emacs do it =)
<necrophcodr[m]>bjc: Guile and Emacs and Vim all have this in common. They're super friendly. But SUPER picky about who their friends are.
<bjc>i don't know anyone who doesn't struggle with guile's error output
<nckx>I wouldn't call Guile friendly…
<nckx>Gruff and likeable, maybe.
<nckx>As for the errors, it's like interpreting dance. Or tea leaves. Or the stars. Everyone likes the stars.
<unmatched-paren>evening, guix :)
<nckx>Apt.
<nckx>Hi!
<unmatched-paren>ACTION sees time displayed on screen, revises greeting
<nckx>ACTION slouches towards bed to get reborn.
<unmatched-paren>Good Essentially Midnight, guix. That's better.
<juliana[m]>TZAG?
<acrow>Has anyone successfully completed the 'check' phase when building chez-scheme-for-racket-9.9.9-pre-release.16.drv? It seems to be a required portion of an up to date install of racket-minimal as well as racket. No issues seem to be opened on this...
<latex> Okay the system won't boot
<latex>it tries finding a kernel in /gnu/store
<latex>It's not there obviously
<latex>How do I get linux kernel inside the boot partition?
<latex>I guess I need an initrd
<nckx>I thought you'd already installed Guix System earlier, when I asked, somewhat surprised, whether you had a working separate /boot.
<nckx>It's not supported out of the box.
<ChocolettePalett>nckx: Btw, have frama-c compiled for you? I couldn't find anything about it in logs, so I wonder if it only fails to compile on my system or there's something wrong with the package
<distopico>latex: I'm using a bash script, and I have a alias like this `alias guix-reconfigure="sudo guix system reconfigure /etc/config.scm; sudo ~/.local/bin/update-boot"`
<nckx>Heh. I wonder how many such scripts exist.
<nckx>ACTION has one too.
<distopico>the mine is based in https://issues.guix.gnu.org/48172#4
<nckx>Mine's very similar but older, and does weird things because at that time I was paranoid about writes to a tiny SSD partition.
<latex>Also I cannot chroot
<latex>if I do, I have no internet access and the environment is broken
<nckx>Why do you need a separate /boot, distopico? It's a niche use case, no?
<latex>So I guess I'll just run the init command again?
<latex>separate /boot is very common
<latex>at least nearly all my systems had them
<nckx>And why?
<nckx>ChocolettePalett: No, it's broken.
<nckx>Something is transitively linking zlib, but not propagating it (which I don't mind, at all, but it does mean we'd have to add it to frama-c).
<nckx>I have that ‘fix’ staged but was putting off pushing it because I want to know why it's being pulled in.
<nckx>I should probably just push it.
<nckx>Oh, somebody else did. Are you sure you're on master, ChocolettePalett.
<distopico>nckx: I have an Asus KGPE-D16, it doesn't have nvme, so I'm using an pcie, but is not detected before the boot, and I want to have the root in the nvme for performance reasons, so I have the boot in the ssd that is detected and all the root in nvme, not sure if this is a common case, maybe mostly for old motheboard
<ChocolettePalett>Oh, I haven't tried building it lately, just wanted to make sure it wasn't my system's fault. Thank you very much for fixing it! Will try to build it now.
<mirai>nckx: could you look into <https://issues.guix.gnu.org/64361>? It's a trivial fix that I think can be committed straight away
<nckx>mirai: Done.
<nckx>Could you close the bug (and maybe the parent too)? I'm exhausted.
<mirai>thanks!
<mirai>sure
<nckx>distopico: Thanks for the answer! I can't wait to get rid of mine, it feels anachronistic (I had one in the 90s, because my 1.1 gig hard drive confused the BIOS). Maybe they are still more common than I think & I'm just lucky.
<nckx>ACTION → 😴💤
<distopico>nckx: which is your user case? why do you need the script?
<latex>So do you guys manually run a script that copies kernel and initrd into /boot, or do you have a custom hook or something?
<distopico>I have a alias do each time that I run `guix-reconfigure`, reconfigure the system, and then run the script to update the boot images
<nckx>latex: I use a bash script, but that's pure laziness on my part. It works, it's private, so why make it pretty. Here's a proper example in Scheme, but I suspect it has bootstrap issues at first init: https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/berlin.scm#n149
<nckx>distopico: bcachefs. GRUB can't read it.
<nckx>o/
<distopico>:/
<ChocolettePalett>I have a separate /boot and / partitions, because I turned on full disk encryption, are you trying to achieve the same thing but without encryption (if I understood right)?
<ChocolettePalett>It worked out of box, I just configured everything in an instalaltion wizard, switched to manual mode and ran ``guix system init`` after editing the config
<ChocolettePalett>I guess that if /boot and / are different partitions, nothing stops you from placing them on different disks for example
<apteryx>ChocolettePalett: by default, /boot is part of the root file system (/), same partition, and full disk encryption is possible (grub promts for decryption)
<apteryx>I run a distinct /boot partition only because my file system is larger than 2 TiB, which causes issues when attempting to load a kernel at a storage address > 2TiB for my old BIOS machine
<bumble[m]> https://www.phoronix.com/forums/forum/phoronix/latest-phoronix-articles/1398623-gnu-shepherd-0-10-2-service-manager-fixes-some-long-standing-issues sharing this discussion about shepherd from phoronix here (hopefully wasn't linked already)
<raghavgururajan>apteryx: Thanks! May be down the road, as I am pretty swamped and running behind on gnome stuff.
<rekado>nckx FYI: my colleague confirmed that the firewall got a new pattern on Monday, and since then a lot of servers are affected by timeouts.
<mfg[m]>ngz: I noticed that lualatex is much slower now than before, did the old texlive use luajit and the new one doesn't or is it just that other backend thigns changed from TeXlive 2021 - 2023?
<mfg[m]>this happens with both the modular and the big monolithic package
<latex>fbcon:TER13x32 didn't work
<latex>Also how do I set up connman? It just says cannot connect to socket dbus or something
<latex>How do I shut down my computer?
<latex>poweroff command not found
<latex>wtf
<rekado>halt
<efraim>or shutdown
<rekado>I’m stumped by what looks like a bug in “guix deploy”
<rekado>I’m trying to deploy to my aarch64 machine from my x86_64 laptop
<rekado>the machine-ssh-configuration has (build-locally? #false) and (system "aarch64-linux")
<efraim>I created an image for my riscv64 machine from x86_64 and I got my profile hooks for x86_64 I think
<efraim>that was with --target though
<rekado>yet when I deploy it builds stuff locally anyway: while setting up the build environment: a `aarch64-linux' is required to build `/gnu/store/djdpd9d4gbhv8kwqimw9faadg6hkapyb-gitile-0.1.4.drv', but I am a `x86_64-linux'
<efraim>no aarch64-linux offload machines defined?
<rekado>when build-locally? is #false should it not build on the target machine?
<efraim>I would think so
<rekado>the aarch64 machine is not configured as an offload machine, because I generally don’t want to offload aarch64 builds to it
<rekado>but it should build its own packages when needed
<latex>And what's the command to suspend?
<efraim>I've never actually tried from the cli
<jpoiret>latex: if you use elogind then `loginctl suspend`
<efraim>maybe something with loginctl? if you have the elogind service or %desktop-services
<jpoiret>if you don't then either ask your local login manager or just do a raw suspend by writing something to the sysfs, I don't remember which file
<latex>shepherd is waiting for process termination
<latex>my laptop won't turn opff
<latex>off
<jpoiret>did you upgrade your system?
<jpoiret>shepherd does that sometimes when upgrading
<jpoiret>i think the new shepherd release should fix this although I'm not 100% confident
<latex>I don't have an internet conneciton
<latex>connman is misbehaving
<latex>I feel like Guix doesn't install the dependencies that my packages require
<latex>or doesn't set them up properly
<rekado>do you have an example?
<latex>dbus is not present despite connman needing it apparently
<latex>also shepherd is being buggy: halt waits on a process forever
<latex>I have to hold the power button for 5 seconds to shut down
<latex>forcefully
<latex>because shutting down in software is not working
<latex>I hope btrfs can handle forceful shutdowns because I heard horror stories of btrfs corrupting beyond repair from a single unsafe shutdown
<rekado>the connman-shepherd-service does declare dbus-system as a requirement, so the system dbus will run when the service is running
<rekado>do you use the connman-service-type in your config?
<ChocolettePalett>Try installing elogind, it could help maybe (or maybe not). Also it seems that many people are having the issue with being unable to shutdown after updating guix
<janneke>how do you run `make check' in a meson build system?
<janneke>found it: cd ../build && meson test "--no-suite=slow" "--no-suite=flaky"
<janneke>(for glib, that is)
<janneke>...
<janneke>187/252 glib:gio / stream-rw_all TIMEOUT 600.19s killed by signal 15 SIGTERM
<janneke>...
<rekado>the tex-team merge broke python-nbconvert
<rekado>nbconvert runs xelatex, but xelatex complains that “I can't find the format file `xelatex.fmt'”
<rekado>I just upgraded my own home profile, and yes: xelatex no longer works
<mfg[m]>i guess the inputs have to be changed, so do you have texlive-scheme-basic and texlive-collection-basic in that profile? those seem to be important (i only used luatex with the new packages, so not sure what you also need for xelatex)
<mfg[m]>guix shell texlive-collection-luatex texlive-collection-basic texlive-latexmk texlive-scheme-basic gives me a usable luatex
<rekado>I’ll add texlive-latex-base and see if that fixes it
<rekado>it provides the xelatex.fmt file
<mfg[m]>kk
<rekado>oh, that package no longer exists
<rekado>uhm
<rekado>guix build: package 'texlive-latex-base' has been superseded by 'texlive-latex-bin'
<mfg[m]>yeah maybe texlive-scheme-basic is the right one as it now contains texlive-collection-latex and texlive-collection-basic
<rekado>the texlive-latex-bin package now only comes with pdflatex.fmt, latex.fmt, lualatex.fmt, and dvilualatex.fmt
<rekado>okay, I’ll check out the others
<rekado>texlive-collection-basic doesn’t come with any fmt files either
<rekado>and texlive-collection-latex doesn’t have xelatex.fmt
<mfg[m]>sad, this seems like a bug then
<mfg[m]>ah, there is texlive-xetex
<mfg[m]>this also doesn't contian your missing fmt file
<irfus>hi all, I've run into another instance of store corruption and don't know how to fix it
<irfus> http://ix.io/4AXs
<irfus>somehow store items related to grub configuration have got messed up along with a bunch of other stuff. `guix gc --verify=..` fixed most of them but errored on the grub items. Now system reconfigures are failing because of this.
<irfus>'gc --delete' doesn't work on those paths because they are still alive. Anything else I can try?
<jpoiret>if they're alive they probably can't be repaired, right
<jpoiret>janneke: I don't think this is doable on such a large scale though
<jpoiret>(finding tests that are failing on the Hurd)
<jpoiret>commendable effort but this is going to be a lot of work if we also want those tests to actually work
<jpoiret>irfus: you could rollback if you can and repair
<jpoiret>or chroot from a live system
<irfus>jpoiret: I'll try the chroot option, thanks for the tip!
<janneke>jpoiret: yeah, well /me just takes their time now
<jpoiret>i'll try the native compilation patches on hurd-team
<rekado>mfg[m]: I submitted a bug report: 64729
<janneke>jpoiret: great!
<janneke>ACTION has updated the hurd native build patch wrt (or assoc-ref ...)
<jpoiret>when?
<jpoiret>i fetched this morning
<jpoiret>oh i see i have the updated version :)
<janneke>ok good :)
<Zambyte>Hi, can anyone confirm if they received an email on help-guix with the subject "Using NoiseTorch with Sway and Polkit" yesterday? It seems like it sent on my end but I'm not seeing it in the archives
<Zambyte>Want to double check before trying to send it again
<nckx>Zambyte: It has now been delivered.
<Zambyte>Like just now?
<nckx>Yes. I've unmoderated you.
<nckx>That's per-list, so if you're newly subscribed to -devel, your first mail might also be held for review.
<Zambyte>Oh, thanks!
<apteryx>mirai: for the xvnc test, we can simply change invoke to system*
<apteryx>that's silencing the failure (system* doesn't raise by itself on unclean exit status)
<mirai>hmmm
<apteryx>*can't
<mirai>so the fix should be to include the module that exports invoke
<apteryx>ah, yes, that rings a bell
<apteryx>these used to be leaked in the environment from the host
<mirai>the failure from patch 1/4 is because guile has no idea what “invoke” was
<mirai>s/was/is
<apteryx>fixed by ludo a couple months ago
<mirai>makes sense, which commit was this?
<apteryx>(but with some tests now failing as a result)
<mirai>probably worth to check if there are other tests suffering from the same
<apteryx>a bunch were fixed at the time
<apteryx>some later
<apteryx>such as the jami one
<apteryx>see 99fc7e5dd3c9c92f9b6c2e51db9dc5b0481a56b2
<apteryx>I think lightdm is broken because of the same thing
<apteryx>(the test)
<apteryx>I think the (use-modules (guix build utils)) needs to be moved inside the eval
<apteryx>ACTION tries
<apteryx>works
<mirai>neat
<mirai>though am pretty sure this is also a GDM regression
<mirai>(no idea if you got my last messages here)
<mirai> <https://logs.guix.gnu.org/guix/2023-07-04.log#013738>
<apteryx>hadn't seen it, thanks
<mirai>regarding the patch-series, do you want me to send a v4 for the missing module?
<apteryx>so I'm not alone facing the VNC blackscreen with GDM
<apteryx>no, I'm editing it locally, will push shortly
<mirai>right, thanks!
<mirai>I didn't open an issue with GDM upstream yet
<mirai>am hoping to give it one more try with the upcoming gnome-team updates first
<apteryx>last working lightdm: https://ci.guix.gnu.org/build/634675/details, first fail: https://ci.guix.gnu.org/build/640595/details
<apteryx>that's before a09c7da, I think
<apteryx>uh, it passed now
<apteryx>maybe just the delay needs to be made longer
<apteryx>we use 120 s for GDM
<mirai>that was a leptonica build failure
<apteryx>default is 30 s
<dportnrj[m]>Hello. How to invoke guix copy on non-standard port? There is no CLI arguments for it: https://guix.gnu.org/manual/en/html_node/Invoking-guix-copy.html
<mirai>There's also something that is worth noting
<mirai>the default OCR arguments scales the image by 10
<mirai>this is not a cheap CPU operation
<mirai>not too many tests make use of OCR but those that do might be taking much longer than necessary
<apteryx>that one uses Tesseract
<mirai>no longer with 3-4/4 :)
<apteryx>which is not fast either but at least doesn't require me to do combinatorial probabilities with the arguments to succeed...
<mirai>oh, the delay is within gnu/build/marionette.scm
<mirai>s/delay/scale**
<apteryx>it's part of the default args of ocrad
<mirai>scaling by 10 seems… unreasonably large
<apteryx>dunno
<mirai>the regular ratpoison text only needed scale=2 to work
<mirai>actually, larger than that it makes it worse
<mirai>s/it makes/makes
<nckx>dportnrj[m]: I add any non-standard ports to .ssh/config. It just works without having to manually specify ports for each random command that uses SSH.
<mirai>The OCR gadget does need to be adjusted occasionally, there's no automagic for it yet™
<nckx>However, --to=HOST:PORT silently ignoring :PORT is probably not a deliberate design decision. You can file a bug to bug-guix at gnu dot org if you like.
<apteryx>what do you mean with 3-4/4 ?
<apteryx>your patches don't touch tests/lightdm.scm :-)
<mirai>patch 3,4/4
<apteryx>so that one still uses tesseract
<mirai>oh, that's about the OCR in xvnc
<apteryx>yep
<jpoiret>janneke: were you able to pass checks for guix?
<apteryx>lightdm passes; I just bumped the timeout to 60 s to avoid flukes on slow/busy systems
<jpoiret>it's failing for me for a couple of them
<mirai>apteryx: can you measure how long it takes with `time` or similar?
<mirai>I'm curious whether the vnstat tests do pass in ci
<mirai>I recall that occasionally it might take something like 2mins for it to signal a `success`
<janneke>jpoiret: yes, on hurd-team
<janneke>but that was a month ago and meanwhile we rebased, so yeah
<janneke>jpoiret: i managed to run `guix pull'
<janneke>but that left a broken installation
<jpoiret>for some reason i had to build a native guix for x86_64
<jpoiret>and its tests are failing
<janneke>ACTION hopes that will be magically fixed by jpoiret's guile work ;)
<jpoiret>nah, i think these are guix problems that are biting us back
<jpoiret>ie. tests that got broken recently
<jpoiret>but that also means I can't really test :(
<janneke>oh, not good
<janneke>who can we blame? ;)
<rekado>the python-team spec on ci.guix.gnu.org has lots of failures, but many of them are due to network failures
<rekado>I tried restarting all builds, but this doesn’t seem to retry the source code download jobs
<rekado>and so now I’m restarting builds manually
<rekado>am I doing this wrong?
<nckx>rekado: Oh, thanks for the firewall update by the way.
<nckx>Was the message you got really that vague? Oh, we added some rule and now stuff randomly fails, oh well, it happens…?
<nckx>Or is bureaucracy such that simply rolling it back isn't an option…
<rekado>since I’m just a regular user nobody tells me anything more than that
<rekado>in fact, the official message I got from IT was just “try again”
<rekado>(the vague background info came from a better-connected colleague)
<rekado>I have no idea what they are trying to do and what their processes are. My mental model of how a firewall is operated does not match the apparent practice.
<nckx>:)
<nckx>Apparently, same.
<yelninei>hi, does anyone know if command substitution works in shepherd services, i.e a service with (start #~(make-forkexec-constructor (list "foo" "$(bar)" ))) is a service executing "foo $(bar)"?
<nckx>No, it doesn't support shell scripting. You'll have to manually invoke bash if you want to write in a different language.
<yelninei>thanks
<nckx>I don't know if you could use (system …) somehow, which invokes a shell. I've never written a nontrivial Shepherd service.
<ulfvonbe`>anyone know how I would be getting empty string dependencies in a binary? such that the 'validate-runpath' phase says stuff like 'error: depends on '', which cannot be found in RUNPATH ()'?
<apteryx>rekado: sounds like a bug. Are you sure it's network failures? I'd think it's the daemon not handling parallel download well, and reporting the archives are corrupted
<apteryx>I had this a lot on a multicore machine yesterday using multiple daemon jobs (--max-jobs=10 I think)
<apteryx>the CI must be setup similarly
<irfus>chroot and system reconfigure (following the section in the manual) also failed with the same error
<irfus>any other tricks I can try? :(
<nckx>Blow away /gnu and /var/guix and reinstall (after exporting a list of installed user packages if you still can, and don't use a manifest)?
<nckx>That's what I would do.
<RavenJoad>Does anyone here use msmtpq to queue email messages? I have been having problems, and want to double-check if someone else has solved it. If you do not use msmtpq, what do you use to queue mails for later sending instead?
<lambdanil>hi, is there a straightforward way to get firewall on Guix?
<lambdanil>I looked around if there's some Firewall service but didn't find anything
<mirai>nftables
<mirai>there's a service type for it
<lambdanil>okay thank you, I'll look into it
<geri>how do i properly get a path to the store where file created with local-file will be available?
<ngz>Hello Guix!
<geri>hi-hi
<apteryx>what does this error mean? Wrong type (expecting exact integer): #<&formatted-message format: "cannot travel past commit (~a) from July 10th, 2018\n" arguments: ("2ca299c")>
<HiltonChain[m]>geri: (with-store %store (run-with-store %store (lower-object (local-file "/tmp/1")))) ?
<HiltonChain[m]>use (guix store) first
<ncd>GUIIIIIIX
<apteryx>the above error is from this wip patch: https://paste.debian.net/1286368/
<apteryx>ah, the raise
<apteryx>should be raise-exception, else I need to import srfi-34 or something
<ncd>Anyone doing anything really cool with guix?
<apteryx>yeah, that was it
<lambdanil>is just using Guix considered cool?
<geri>^^^
<ncd>So far, yes.
<ncd>Just to accidentally start a flame war, does guix's init do whatever "socket activation" is?
<msavoritias>yep
<geri>HiltonChain[m]: it complains about %store not being defined, and it doesn't seem any modules define it, except (guix scripts package), which doesn't export it
<HiltonChain[m]>(guix store)
<mirai>apteryx: I think jpoiret did some raise-exception fixing lately
<HiltonChain[m]>ncd: <https://www.gnu.org/software/shepherd/manual/html_node/Service-De_002d-and-Constructors.html#index-make_002dinetd_002dconstructor> ?
<geri>that's where with-store is too, but it doesn't provide %store
<geri>i should try gexp as in example in docs
<mirai>ncd: depends on the threshold of coolness? :)
<geri>uwu
<geri>no matter how high it's gonna be cool
<HiltonChain[m]>geri: I can run this: <https://paste.debian.net/hidden/46e50b61/>. Ah, I didn't ask, where do you use it?
<geri>okay, how stupid is it to use plain-file to get an image to the store? :D
<geri>HiltonChain[m]: guix system, im trying to put my sway wallpaper into store and use it straight in the generated config
<lambdanil>I think Guix Home would be a better fit for that
<geri>i am using guix home, i meant like the distro
<geri>my bad
<lambdanil>ah okay I see
<HiltonChain[m]>I personally use mixed-text-file for that: <https://codeberg.org/hako/Testament/src/branch/trunk/dorphine-home.scm#L132> (ignore those stupid names, the procedure used for wallpaper is a local-file wrapper)
<ncd>HiltonChain[m]: so it's not just systemd that could do that. Very interesting.
<geri`>something messed up in my config and it decided to cat my wallpaper and crash my emacs lol
<geri`>,logs
<geri`>found it
<geri`>HiltonChain[m]: i really like how your hyperland config definition looks like
<apteryx>do we have something to check for network connectivity in the shell tests?
<apteryx>shell scripts tests*
<apteryx>looks like no
<rekado>apteryx: sorry, what sounds like a bug?
<rekado>the timeouts we get go beyond just guix-daemon
<apteryx>rekado: the fact that source derivation fail on transfering things
<apteryx>which doesn't seem to have anything to do with the stability of the network
<rekado>oh, that
<rekado>yeah, I don’t know what that’s about
<rekado>when I manually restart each build they succeed.
<rekado>but restarting all builds doesn’t cause them to succeed
<rekado>as if they aren’t actually retried
<rekado>it’s not *just* about transferring, though
<rekado>there are a number of builds that just timed out when they tried to get the source code
<rekado>there are *also* cases where the build succeeded but the result didn’t make it to the head node
<rekado>both cases exist
<msavoritias>is the guile-gnunet package maintained anymore?
<msavoritias>or should i just use gnunet-scheme?
<msavoritias>because the commend "different services" in the description is confusing
<ngz>rekado: Hi! I fixed `python-nbconvert'. However, its propagated packages are wrong. `texlive-updmap.cfg' should only be used as a native inputs, since propagated inputs benefit from the profile build process. I understand (cf. our discussion about python-sphinx) that some texlive packages are expected as propagated inputs, but those only needed for the tests should be moved as native-inputs, wrapped in a texlive-updmap.cfg call. Do you
<ngz>know which ones should go there?
<ngz>rekado: another option is to keep them all as propagated inputs, along with texlive-collection-basic to get a standalone texmf tree. I don't think updmap.cfg is needed with XeTeX/XeLaTeX anyway.
<ngz>rekado: Confirmed. It is possible to remove `texlive-updmap.cfg' altogether, and list all texlive packages (those outside texlive-updmap.cfg and those inside), along with `texlive-collection-basic', as propagated inputs. Shall I just push this?
<lispmacs[work]>in my system scm file, if I have a service like (service tor-service-type), how do I modify that to pass shepherd options, like to not start the service and to have it disabled?
<lispmacs[work]>I'm looking at the guix reference but am a bit confused
<rekado>ngz: good! Yes, please push.
<ngz>rekado: done.
<rekado>thanks!
<podiki[m]>nice work on the big texlive update, that's a lot of commits!
<podiki[m]>i guess mesa-updates is next...
<podiki[m]>there was a graft made on master, so could ungraft and add other updates (libdrm etc.) and do a rebuild....hm
<nckx>podiki[m]: ping_test_2_final-FINAL.docx.odt.pdf.gif
<podiki[m]>polo
<nckx[m]>Test.
<nckx>Hm.
<podiki[m]>your connection seems fine from either side
<RavenJoad>I need to wrap several binaries with a command line flag to point to their configuration file. Is there a service I can model this off of?
<civodul>RavenJoad: maybe you can look at dbus-daemon-wrapper, wrapped-dbus-service, or mysqld-wrapper
<civodul>(i grepped for "wrap" in gnu/services :-))
<civodul>ngz: thumbs up for tex-team!
<civodul>and i586-gnu native compilation, yay!
<RavenJoad>civodul: Yeah, I did that. I will try the dbus route for now. I copied the X version first. I am having issues getting a for-each or map to work with the X route.