IRC channel logs

2023-06-17.log

back to list of logs

<lilyp>endlich
<juliana[m]>sughosha: I was suggesting you use one of these procedures https://www.gnu.org/software/guile/manual/html_node/File-Tree-Walk.html to collect the files you want to delete (say, into a list called `unwanted-files`) then do `(map delete-file unwanted-files)`
<juliana[m]>I checked and delete-file is indeed a standard Guile procedure
<juliana[m]>I am working on some example code but there are several ways to go about doing this
<sughosha>juliana[m]: Thank you. I look into it.
<mirai>sughosha: is this for a package?
<sughosha>mirai: I was trying to unbundle ardour's libs. There are a lot in libs folder and only few are native.
<mirai>is it feasible to simply unbundle them all and delete the lib directory instead?
<sughosha>It has some folders including "ardour" and "ardouralsautil".
<sughosha>I don't know how many of them can be unbundled.
<juliana[m]>I haven't tested this code but here's an idea of what I mean: https://ttm.sh/BIj.scm
<juliana[m]>er, had a typo: https://ttm.sh/BIc.scm
<mirai>sughosha: the lib/ardour is part of ardour?
<sughosha>juliana[m]: Thanks a lot for this example. I will take some time to understand it.
<mirai>or is it a standalone package (maybe it should be packaged as ardour-libs)?
<sughosha>mirai: It seems "libs" does not mean third party libraries. The actual library for ardour ist "libs/ardour".
<juliana[m]>sughosha if you have any questions, you can reach out to me privately (i know this is theoretically possible but don't use irc enough to know how). don't wanna flood the channel or leave you high and dry ^.^
<sughosha>I don't know about gtk2_ordour by the way!
<Kolev>Ew, GTK2.
<mirai>unless the bundled lib spawns more than a directory, a simple (map delete-file-recursively '("dir1" "dir/dir2" …)) should suffice
<lispmacs[work]>hi, I wasn't sure if I should start here or in #emacs... but I was writing some little elisp scripts, and was wondering how I could use Guix package name completion in an interactive argument
<lispmacs[work]>Like, I can get a prompt with (interactive "Mpackage name: ") but that doesn't provide package completion, like when I call an Emacs-Guix package function
<mirai>lilyp: is shared-mime-info within the scope of gnome team?
<mirai>it's within gnome.scm though it's not exactly a GNOME-only thing
<lilyp>probably maybe
<mirai>(personally I think it should be at freedesktop.scm)
<lilyp>yeah, that'd make more sense
<mirai>shared-mime-info definition could use a update :)
<lispmacs[work]>also, is there a way to tell `guix package -s` not to use a pager
<mirai>the one in guix is from 3y ago, with the implication that AVIF files for instance not working properly with anything that uses gdk-pixbuf
<lilyp>you're welcome to aid us on updating the gnome stack itself
<mirai>I've tried looking into it in the past (<https://issues.guix.gnu.org/60826>) though it will need a rebase
<mirai>I think back then I replied via IRC that the patch depended on the docbook refactor series or some other issue was cropping up
<mirai>I could revisit it
<lambdanil>oh yeah my plans to help update the Gnome stack have been left in the dust as I've been more busy lately
<mirai>the thing that stands out is that it uses (recursive? #t) within the git-reference
<mirai>I couldn't figure out what the submodule was about
<bjc>what package contains ‘ldd’?
<bjc>nm. it's ‘glibc’
<PotentialUser-9>ChocolettePalett: "you might need elogind ..."  <-- Thanks for this hint on question about ACPI+PowerKey. Passing through an event chain from elogind, it led to gnome settings at the end, and there was written final action on pushing PowerKey (was Suspend by default, no idea why it is default). Changing it to poweroff there, I got what's needed.
<mirai>alright
<mirai>got the accursed shared-mime-info with the alopecia inducing tests working
<mirai>Reworked patch sent to <https://issues.guix.gnu.org/60826>
<mirai>an interesting (obvious?) observation: changing shebangs changes the mime-type
<mirai>if a particular unit test is expecting a particular mime-type, patching (source) shebangs can make it deviate from the expected
<mirai>could be a possible cause for obscure build/test failures
<lilyp>that shouldn't be the case though and ought to be filed as a bug
<lilyp>e.g. whether you have /usr/bin/env python, /gnu/store/.../bin/env python or just /bin/python, it ought to be a python file
<Kolev>Does Podman work on Guix?
<bvbfan>I still cannot understand what is different between Github action ubuntu-latest and VM Ubuntu 22.04 for Guix. sudo apt install guix in both, it works fine in VM and fails (everytime in Github action)
<bvbfan>building /gnu/store/vx8a40w032nv913janngc0r210vdlz18-compute-guix-derivation.drv...
<bvbfan>Backtrace:
<bvbfan>          13 (primitive-load "/gnu/store/xvdcfn6zr3fjxd2yjzizn24acliqxsrj-compute-guix-derivation")
<bvbfan>In ice-9/eval.scm:
<bvbfan>    155:9 12 (_ _)
<bvbfan>    159:9 11 (_ #(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#<directory (guile-u?> ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?))
<bvbfan>In ice-9/boot-9.scm:
<bvbfan>`guix pull` works in Ubuntu VM, Gihub action fails with above message
<zamfofex>bvbfan: Can you paste your error message somewhere then share the link here? Check the channel description.
<bvbfan>Sure, here is https://pastebin.com/GM0tGjX2
<Guest206>morning, guix :)
<zamfofex>bvbfan: I know it’s difficult to debug GitHub Actions, but maybe it didn’t install the daemon properly (would be my guess). Have you considered using sourcehut builds as an alternative? It has Guix System as an inbuilt option.
<zamfofex>bvbfan: See: <https://man.sr.ht/builds.sr.ht/> and: <https://man.sr.ht/builds.sr.ht/compatibility.md#guix-system>
<zamfofex>The neat thing about sourcehut builds is that you can use SSH to connect to the build VM if it fails (for easier debugging) and you can just submit one without needing a sourcehut repository.
<bvbfan>The idea is to use Github action, there is an action https://github.com/PromyLOPh/guix-install-action/blob/v1/action.yml is there something wrong here?
<zamfofex>Why do you have the channel declaration?
<zamfofex>Will having both the mirror and the official channel (through ‘%default-channels’) even work?
<zamfofex>Ah, I see what you’re doing now, sorry.
<zamfofex>bvbfan: Maybe try it with the Ubuntu/Debian package rather than from the tarball.
<bvbfan>The weirdest thing is everything deb package or wget *works* in real machine or normal VM
<bvbfan>It doesn't work (all the way) in github action
<zamfofex>bvbfan: Wait, is that repo you linked yours? Because if not, then maybe you would have more luck opening an issue in it to ask for help.
<bvbfan>It's a marketplace https://github.com/marketplace/actions/install-gnu-guix I just going through to see what is doing
<bvbfan>But test it in VM and it works but it fails on github action
<bvbfan>It has some limitation on github action that impact guix somehow
<bumble[m]>I want to run a guile ncurses hello world style script, which uses ` #:use-module (ncurses curses))`, but even though home reconfigure installed "guile-ncurses", this error happens when trying to run the script...... (full message at <https://libera.ems.host/_matrix/media/v3/download/libera.chat/d6db600f248a57ca5d53d5d9941a9d1d1d270cf4>)
<bumble[m]>would someone tell me what I am doing wrong?
<next4th>bumble[m]: 'guix shell guile guile-ncurses' works for me. guess your guile and guile-ncurses aren't in a same profile, leading GUILE_LOAD_PATH not right..
<bumble[m]>@next4th `guix shell guile guile-ncurses` works for me also. I don't know how to fix the load path
<bumble[m]>I tried adding "guile" to the home configuration and running guix home reconfigure but that did not help
<next4th>bumble[m]: does ~/.guix-home/profile/etc/profile contains GUILE_LOAD_PATH? you can source it in the current shell (or logout, then login again..)
<qeqpep>How to use local-file with variables? I'm trying to map over bunch of filenames. Says wrong type.argument
<qeqpep>Solved. use quasiquote.
<indigo-oce>I have a critical issue with git... it's not able to pull or clone anything, the error message is 'git: 'remote-https' is not a git command. See 'git --help'.'
<indigo-oce>there are other people with this error that seems to be building git without libcurl or something like that...  I'm not sure if it's only https yet
<indigo-oce>I've got like 5 other pretty serious issues with guix tbh thinking of switching to nix
<Kolev>indigo-oce, what are those issues?
<HiltonChain[m]>indigo-oce: I don't have any issue with git.
<indigo-oce>HiltonChain[m] Yeah I doubt anyone else does since it's so debilitating it would be fixed immediately...
<HiltonChain[m]>From the output of "guix describe", which guix commit are you on?
<indigo-oce>Kolev  1.  Cannot remove GDM, tried several times.
<indigo-oce>2. nerd-dictation package doesn't build (issue with kaldi dep)
<indigo-oce>3. don't have a way of controlling my pc fans (tried lm-sensors but that didn't detect them), not sure if theres a solution elsewhere, this is less important but frustraiting at night
<indigo-oce>4. haven't figured out how to get nvidia gpu stuff, I know it's not supported but it's been much harder to figure out than I thought... just figuring out what it is exactly that's being configured is awkward since I gotta learn a new language and env
<indigo-oce>That's what I remember off the top of my head...
<indigo-oce>Basically I've realised I need to be an active contributer to solve the problems I've got, I do have the time to spare it's probably worth it
<indigo-oce>HiltonChain[m] 6fe9a004dba2d4ddf69ff6f1714af15ffaa7e62a is my commit on master, quite recent...
<juliana[m]>could you link a pastebin of the full output of guix describe?
<juliana[m]>(See the channel description)
<indigo-oce>not sure how to use the cgit site for guix commits...
<indigo-oce>juliana[m] it just shows the commit...
<indigo-oce> https://paste.debian.net/1283253/
<HiltonChain[m]>Dose the git from "guix shell git" work for you?
<HiltonChain[m]>and how do you try to remove GDM?
<indigo-oce>"guix shell git" has the same issue
<indigo-oce>HiltonChain[m] I tried having this but it wouldn't build without gdm-file-system-service, and just removing gdm-service-type doesn't remove gdm:
<indigo-oce>(services
<indigo-oce>  (append (list
<indigo-oce>    (service nix-service-type)
<indigo-oce>           (service dicod-service-type)
<indigo-oce>           (set-xorg-configuration
<indigo-oce>            (xorg-configuration (keyboard-layout keyboard-layout))))
<jpoiret>please use paste.debian.net for pastes
<jpoiret>indigo-oce: can you paste that there?
<indigo-oce>sure, my bad
<ngz>Hello Guix!
<juliana[m]>indigo-oce: you may want to try updating your various profiles (eg `guix pull` followed by `guix package -u`, `sudo guix system reconfigure /path/to/config.scm`, and `guix home reconfigure /path/to/home/config.scm` if you use it) to see if things are working? I'm on the latest version of Guix and not running into your issues with nerd-dictation or git...
<indigo-oce>I've tried that, doing so again, otherwise I'll try reverting to an older commit... such a weird issue with git... I don't think it happened after an update...
<juliana[m]>I feel like I've run into this issue before but for the life of me can't remember when or how I resolved it...
<juliana[m]>I'm looking into the GDM thing now but the tl;dr is that you'll need to remove it from the %desktop-services service, which is probably relied upon by whichever desktop service you're using (see https://guix.gnu.org/en/manual/devel/en/html_node/Desktop-Services.html)
<juliana[m]>I've never done something like that so I'm trying to remember how. I know it can be done
<juliana[m]>okay so,
<juliana[m]> https://ttm.sh/BnD.scm
<juliana[m]>that should do it
<juliana[m]>and the available services are: https://guix.gnu.org/en/manual/devel/en/html_node/X-Window.html
<juliana[m]>display manager services*
<juliana[m]>you my need to do further configuration to get things to play nicely with each other but ye
<indigo-oce>juliana[m] https://paste.debian.net/1283255 this is what I tried, I tested in the shell to ensure the service was removed from %desktop-services, but it gdm was still there from just removing gdm-service-type, I tried also removing gdm-file-system-service but it wouldn't build without that...
<indigo-oce>(still there after system reconfigure + reboot)
<juliana[m]>and that's the entirety of your services field, right?
<indigo-oce>comments are removed, otherwise yes
<Guest28>Hey, I need to apply this patch https://issues.guix.gnu.org/64073#4-lineno8 to test if it fixes the issue.  How would I do that?
<bumble[m]>@next4th logout then login again worked! thank you
<juliana[m]>indigo-oce: maybe try adding a display manager service to the `set-xorg-configuration` form after the `xorg-configuration` form itself?
<juliana[m]>so like (set-xorg-configuration (xorg-configuration ...) (some-dm-service-type))
<indigo-oce>maybe... I just want to use xinit
<Kolev>Do i need to modify system declaration to use Syncthing?
<juliana[m]>Guest28: you should be able to copy the email into a file and then use `git apply the-file.patch` in the git repo
<juliana[m]>Kolev: I think you can just install it and run it manually, but if you want it to be persistent then using the system service is the easiest way to go about that
<Kolev>juliana[m]: OK, thanks.
<Kolev>I selected i3 in the installation. Why is it pulling in gnome-session?
<lilyp>probably because you have gdm?
<juliana[m]>lilyp: do you know how to go about getting rid of gdm? it seems someone else is having issues with that as well
<lilyp>well, there's two big ways of doing it: first, roll your own services on top of %base-services rather than desktop-services
<lilyp>second, use modify-services to delete gdm-service-type
<juliana[m]>the latter method seems to not work
<Kolev>Does anybody run a NAS on Guix?
<Kolev>I'd like to replace i3 with Sway.
<lilyp>the stupid way of setting your xorg-keyboard-layout also pulls in gdm
<lilyp>you want to use the declarative approach
<Kolev>lilyp: I'm using the installer's declaration. I need to make a Sway-only system.
<lilyp>the installer probably produces the stupid way
<lilyp>instead of using (set-xorg-configuration ...), use (xorg-configuration your-config) in sway/what-have-you
<Guest28>how is date set on guix? normally i would use timedatesysctl. my system thinks in 1 1970
<Kolev>lilyp: Another thing the installer generates is an ugly `something->something` syntax for paclages.
<juliana[m]>lilyp: so you're saying there's no way to configure, in the system declaration, the default keyboard layout for a graphical session unless you're using a display manager of some kind? (the xorg config being within the display manager config)
<juliana[m]>Guest28: the `timezone` field of the `operating-system` declaration should handle that, but you may also want to make sure you have ntpd (openntpd) setup if you're not using %desktop-services (you can see if it's currently running with `sudo herd status ntpd`)
<juliana[m]>the system service in question is the ntp-service-type: https://guix.gnu.org/en/manual/devel/en/html_node/Networking-Services.html#index-ntp_002dservice_002dtype
<Guest28>ah I see.  Thanks.  Yea it is a headless system which makes sense.
<juliana[m]>ah, yeah :3
<Kolev>OK
<Kolev>What is this (specification->package nonsense in my system declaration?
<apteryx>Kolev: run: info '(guix) Using the Configuration System'
<Guest28>Kolev: that is actually pretty neat since now you don't need to import the modules which has the package in it.
<Guest28>in other words: less code for the same output
<lilyp>juliana[m]: no, there is, but you typically have to edit three different locations because they carry their own layouts (i.e. there is no uniform knob)
<lilyp>set-xorg-configuration is a sadly quite confusing attempt of making that "easier to read"
<sughosha>Hi! Could someone review this patch? https://issues.guix.gnu.org/63199
<lilyp>the substitute*s look somewhat suspicious, especially the latter
<lilyp>put inputs before native-inputs imho
<lilyp>the synopsis and description could use some love, but it's not like upstream provides much information
<sughosha>lilyp: For substitute* I think to use find files instead of the long path.
<sughosha>And in the v2 patch I kept native-inputs before inputs :)
<lilyp>licensing also seems shaky, we should make sure it doesn't actually impose restrictions on top of the gpl
<lilyp>I didn't just mean the long file names, the substitutions themselves raise some eyebrows as well
<sughosha>Actually without this substitutions fonts do not show up in the applications built with this.
<lilyp>yeah, sure, it works for *some* fonts
<Grog>hello everyone
<Kolev>Ugh! GNOME Secrets crashed.
<sughosha>lilyp: I don't know if it is needed to patch /etc/fonts or only patching include dir of freetype.
<lilyp>normally, you'd try to use fontconfig instead of whatever's probably attempted here
<brettgilio>How would one get gtk applications installed from guix to honor gnome themes on a foreign distro
<sughosha>lilyp: In juce_linux_Fonts.cpp it has an array of /etc/fonts/fonts.conf, /usr/share/fonts/fonts.conf,... I don't know if there is a variable for search paths for fonts.conf, and also don't know how to enter the variable in the .cpp file.
<lilyp>the patches field exists, use it :)
<lilyp>brettgilio: use gsettings from guix to set the theme to the same value as the foreign distro
<sughosha>lilyp: I know but I don't know what to patch in the cpp file :)
<lilyp>okay, what difficulty are we talking here – do you not know how to C++ or is it just fontconfig that's confusing=
<lilyp>s/=/?/
<sughosha>lilyp: Is there a search path variable for fonts.conf?
<lilyp> https://www.freedesktop.org/software/fontconfig/fontconfig-user.html
<VesselWave>Hi guix, I am trying to package `rust-fast-image-resize` here is it's definition https://paste.debian.net/1283262/. It's repo has another crate in `testing/` directory https://github.com/Cykooz/fast_image_resize/tree/main/testing . But it when I build it doesnt import testing, I get `use testing::nonzero; use of undeclared crate or module testing`. What I should do succesfully build it?
<Kolev>OK, what should I do, to remove GDM? https://codeberg.org/csh/dotfiles/src/branch/main/guix/hosts/bender.scm
<tao[m]1>I just installed Guix System and installed Guix Home then ran `guix home import ~/src/guix-config`, added a few packages including Git, then ran `reconfigure` but `git` isn't available on my PATH. I can see it in `~/. guix-home/bin`. Am I supposed to log out and back in before it takes effect?
<VesselWave>Kolev: Here is what I do with GDM https://gitlab.com/VesselWave/dotfiles/-/blob/main/Systems.org?plain=1#L83
<sughosha>lilyp: I think that instead of replacing /etc/fonts.conf, I can append the store path to the array.
<PotentialUser-76>Is there any desktop environment maintained by gnu or closely linked to gnu?
<lilyp>sughosha: yeah, no, that entire file is useless and needs a rewrite
<juliana[m]>tao: yes; you'll need to source your new profile/rc files to get the new paths. alternatively you can simply source said files
<Kolev>PotentialUser-76, IIRC, GNOME is/was GNU.
<tao[m]1>juliana that did it, thank you!
<juliana[m]>yay!
<sughosha>lilyp: I cannot do much with that cpp file for now. I think appending the store path of fonts.conf would be fine.
<lilyp>why not?
<PotentialUser-76>Why guix use old gnome version?
<lilyp>see and contribute to the gnome-team branch for our efforts of shipping gnome 44
<juliana[m]>I was asking about this the other day, but you probably weren't here (it was the middle of the night in Europe). I'd really like to help out the gnome team more; do y'all have a mailing list or the like I can follow along to see what needs to be done?
<Kolev>I messed up /etc/config.scm. where can I find the last workimg config?
<lilyp>it's guix-patches for everything
<juliana[m]>coolio
<lilyp>use PATCH gnome-team so that both the reviewers and patchwork know what's up
<lilyp>also use ./etc/teams.scm cc-members gnome if you don't already
<juliana[m]>is the teams script working? I think I remember someone talking in here about how it didn't seem to be working properly a while back
<lilyp>it ought to be working, you might have to rerun ./configure to get it though
<juliana[m]>good stuff. i am currently wrestling with the Ruby ecosystem so i can hopefully do this job interview exercise without having to install a different distro, but when I'm not longer wrapped up with that again XD i'll look into what i can do to help out
<juliana[m]>(alternatively if someone wants to give me a job working with Guix that would be cool)
<VesselWave>Kolev: `guix system describe` there will be a path to `configuration file:`
<webe>Will cinnamon be added to guix?
<Kolev>VesselWave: Thanks.
<Guest28>I can't use my SD card reader. Does someone know what is missing from my system to make it work?
<jlicht>sneek: later tell civodul: going with an integer for the date-related stuff in sqlite seems like a good approach to me!
<sneek>Will do.
<Kolev>`guix system reconfigure` takes so long.
<civodul>jlicht: cool, thanks for confirming!
<sneek>Welcome back civodul, you have 1 message!
<sneek>civodul, jlicht says: going with an integer for the date-related stuff in sqlite seems like a good approach to me!
<Kolev>I can't launch Dino. `Couldn't open libGLESv2.so.2: libGLESv2.so.2: cannot open shared object file: No such file or directory`