IRC channel logs

2023-05-21.log

back to list of logs

<senko`>Hello, I am switching from Gentoo and have a small question about substitutes
<oriansj>senko`: they are optional
<senko`>since i want to compile everything from source, with the exception of large packages like qtwebengine, rust, llvm, and etc, is it possible to specify a list of packages to use substitutes for, while compiling everything else from source?
<senko`>i scanned through the documentation in areas that seemed relevant but couldnt find anything
<oriansj>senko`: well you can disable substitutes by default (I do that) but I think it might be possible to use --substitute-urls= when installing a package (Not something that I do)
<senko`>i read that you can derive variants of a package with different compilation options, so maybe there could be something useful there
<senko`>but i havent thoroughly read through those docs so i'm sure i'll figure something out
<senko`>ok so i think i can use package transformation options to do it, since 9.3 in the docs says "guix build guix --with-debug-info=zlib" can be expressed with "(define transform (options->transormation '((with-debug-info . "zlib"))))". so i can probably do the same with --substitute-urls if that's under build options i'm assuming
<senko`>i think i got it down, thank you for the advice! :3
<oriansj>looks like the package /gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv is broken and is preventing kiwi* packages from getting built
<DigitalKiwi>my poor packages :(
<ytc>what is the difference between installing packages to a profile with "guix package -i" and declaring them in the guix home configuration?
<ulfvonbelow>should a shepherd service for monitoring mdadm raid arrays go in (gnu services admin) or (gnu services monitoring)?
<evilsetg[m]>Why do the openjdk packages all depend on each other like a chain 19 -> 18 -> 17 -> 16 -> … ?
<efraim>that's how they get bootstrapped
<evilsetg[m]>Ah, okay.
<ngz>Hello Guix
<jpoiret>hi guix
<janneke>o/
<macrocreation>Whats the best way to display a message after a package is installed?
<macrocreation>I want to display an alert to the user not to use the default confs shipped by the package in production?
<macrocreation>as they are for demo, but not secure for deployment.
<jpoiret>macrocreation: don't think there's any good way to do that currently
<macrocreation>Thanks.
<jpoiret>you could also remove the confs and force the end-user to explicitely use unsafe configs if they wish to do so
<macrocreation>Do any of you guys monitor the help-guix mailing lists? Have written several emails, but no responses thus far.
<macrocreation>jpoiret - how do you do this?
<macrocreation>I know how to delete the confs.
<macrocreation>Will this require a seperate package?
<macrocreation>or an inheritance
<jpoiret>well if you delete the confs there's no way for the user to use them without noticing
<macrocreation>of the minimal package.
<jpoiret>just let the end-user manage the configuration themselves?
<jpoiret>I don't know what app that is but you could package a guix service for it or something similar
<macrocreation>Yeah. Fair point. Problem is the config is heavily tied to the modules that get loaded in compile.
<macrocreation>it's for freeswitch. Still working on it. BTW it's now compiling and long way in.
<macrocreation>I really like guix - but wish there was access to a handy set of experts instantly. Happy to pay. Very slow going.
<macrocreation>Hi, does anyone know what the function is to append to text file?
<tribals>Hi, folks!
<janneke>macrocreation: (let ((port (open-file <file-name> "a")) (display ... port ) (close port)))
<tribals>It is possible to use/build icedtea 8 (openjdk 8) which runs on top of JamVM? According to JamVM homepage, "In addition to HotSpot, IcedTea also packages and supports alternative virtual machines such as JamVM. To use JamVM, the -jamvm option is given on the java command line." (Seems like it is `-XXaltjvm=jamvm`). But this is not the case: it fails with "JNI error". I suppose it is no so simple, and build process of icedtea-8 need to be tuned in some way?
<tribals> https://jamvm.sourceforge.net/#:~:text=In%20addition%20to%20HotSpot%2C%20IcedTea%20also%20packages%20and%20supports%20alternative%20virtual%20machines%20such%20as%20JamVM.%20To%20use%20JamVM%2C%20the%20%2Djamvm%20option%20is%20given%20on%20the%20java%20command%20line.
<macrocreation>janneke thanks- that looks like scheme. Is there any way to to do in in a more guix way e.g. I have a modules.conf - and I want to create a new file with two lines appended to it. the substitute* function is a good example of this.
<macrocreation>I think with-output-to-file looks like the right function. Can't find any docs
<ennoausberlin>Hi guix. To introduce guix to the decision makers for our next project I need some success stories from the wild. I some time ago read about the users / supporters of guix e.g. Max Delbrueck center etc, but I can not find it anymore. Is there an up to date list of institutions and businesses which openly uses GUIX?
<rekado>ennoausberlin: you can find the HPC activity reports at https://hpc.guix.info/
<ennoausberlin>rekado: Yes. Somewhere there. Thank you.
<Kabouik>Guix package manager started to complain that there is no space left on my device, although df -h / reports that I have 11GB free (this is a 60GB partition so that is not negligible). I ran guix gc already. What are my options? I don't understand why Guix starts to complain at about 80% disk use.
<jpoiret>Kabouik: store is on /gnu/store, maybe it's in a specific partition?
<Kabouik>Hum, I need to check you're right, this is a phone and I didn't really decide on my partition scheme if root is separated from home indeed.
<ulfvonbelow>also worth noting the out-of-space condition may have occurred during a build that used a lot of disk space, and the subsequent deletion of the build directory may have freed it back up
<ulfvonbelow>some packages have tests that use several GB of disk space
<ulfvonbelow>and some monsters, like ungoogled-chromium, use upwards of 30GB of disk space during the build
<ulfvonbelow>though if you have substitutes enabled you shouldn't ever have to build that
<Kabouik>jpoiret so apparently there is a single partition, home and root are the same, so not sure why those free 11GB are not enough. I'll try to increase the partition size anyway, but I feel the issue will come back eventually.
<macrocreation>Hi, after much messing around I have now (define (append-to file filname listOfLines)...
<macrocreation>but trying to use it as part of the phases keeps saying I calling an unbound variable.
<macrocreation>any ideas?
<jpoiret>macrocreation: where did you define that/
<jpoiret>?
<jpoiret>code in a gexp doesn't see code outside of it
<jpoiret>you can't just define a function at the top level and then use it inside a gexp
<macrocreation>in the freeswitch-guix file
<macrocreation>I kinda figure that.
<macrocreation>Hence the post.
<macrocreation>Have tried using #~
<jpoiret>you'll need to add it to a module that you then include in the gexp, you'll need (with-imported-modules ...) around the gexp and (use-modules ...) inside of it
<jpoiret>or if it's only used in one phase you can just define it in that phase
<jpoiret>see the guix source for lots of examples of this
<macrocreation>Ok.
<macrocreation>jpoiret is there an inbuilt append to file I can use in build-phases?
<macrocreation>thats all I need for now
<minima>hi, i have the package adwaita-icon-theme installed via guix home; some applications don't get properly displayed for reasons that'd seem to be reconducible to missing adwaita pieces (e.g. "emblems"?)
<minima>am i supposed to refresh a icon cache of some sort to make sure the latest adwaita stuff gets picked up by my apps?
<macrocreation>Everytime I do a guix build it just gets stuck on substitutes. Any ideas?
<macrocreation>just started happening.
<macrocreation>Any ideas?
<janneke>macrocreation: are you using private/custom substitute servers?
<macrocreation>nope.
<macrocreation>Am using the defaults
<macrocreation>warning: ci.guix.gnu.org: connection failed: Connection timed out
<macrocreation>looks like one of the servers is down
<janneke>yeah, seems to be down
<oriansj>good thing we don't need substitutes
<janneke>those of us who have an unlimited resource of time certainly don't...
<PotentialUser-18>Is there an ETA on the outage?
<civodul>no idea
<civodul>good thing is that the bordeaux.guix.gnu.org build farm is up and running
<macrocreation>Its still not working with bordeaux for me
<macrocreation>Does guix use bordeaux automatically
<macrocreation>Strange. I have bordeaux in my config and unless i explicitly do --subtitute-urls=....bordeaux url - it doesn't work
<macrocreation>doing that fixed everything
<PotentialUser-18>Yea that works, lovely
<macrocreation>looks like bordeaux is slowing down now.
<civodul>macrocreation: by default, substitutes get fetched from bordeaux but only after ci.guix timeout (a few seconds)
<civodul>(though there was a bug in guix-daemon some time ago where that didn't work)
<civodul>if you want to avoid that timeout, it's best to pass --substitute-urls=https://bordeaux.guix.gnu.org
<macrocreation>Ok thanks.
<unmatched-paren>afternoon guix :)
<macrocreation>hello
<civodul>hey unmatched-paren!
<jlicht>o/ guix
<davidl>good afternoon unmatched-paren! I have an old resubmitted package you have helped review before - bash-bcu, and I wonder if you wanna have a look at it again? https://lists.gnu.org/archive/html/guix-patches/2023-05/msg00949.html
<Guest28>I alway need to restart libvirtd or  else I can't connect to the daemon.  Does anyone else have that issue as well?
<unmatched-paren>davidl: hello! looking at that, seems like a lot of that substitute* is overcomplicated
<Guest28>also, how can I see the logs of a daemon?
<unmatched-paren>(("export BCUSED=(sed)" _ library) ...) can just be (("=sed") (string-append "=" (search-input-file "bin/sed")))
<unmatched-paren>same for everything else of that form.
<unmatched-paren>ACTION wishes once again that scheme had a standardised abbreviation for STRING-APPEND
<unmatched-paren>also, (assoc-ref %build-inputs) should be replaced with $(this-package-input ...) (or better (search-input-file ...))
<unmatched-paren>davidl: also, i really think you should make this a COPY-BUILD-SYSTEM package with a BUILD phase manually added
<unmatched-paren>NATIVE-INPUTS should use new style
<unmatched-paren>same for PROPAGATED-INPUTS
<ascetic>Is it supposed that I can import package modules provider by Guix channel in `guix repl`? E.g, if I'm using `guix time-machine --channels=channels.scm -- repl` and `channels.scm` specifies additional channel, then packages from that channel will be available in REPL?
<unmatched-paren>for GUILE-BASH-FOR-BASH-CODING-UTILS, you should use MODIFY-INPUTS for INPUTS, and SUBSTITUTE-KEYWORD-ARGUMENTS/gexps with ARGUMENTS
<unmatched-paren>ascetic: if you import them, yes
<ascetic>That's what's strange: I can `guix show` (`build`, etc) but can't import them
<unmatched-paren>hm
<jpoiret>ascetic: that's a known shortcoming
<jpoiret>first do (use-modules (gnu packages))
<jpoiret>then you should be able to
<ascetic>jpoiret: going to try it
<ascetic>jpoiret: Thanks! Worked! ^_^
<davidl>unmatched-paren: okay, thanks I will have a look at fixing those things. Thanks
<davidl>I am not sure I am able to simplify much of the substitute things though, unfortunately.
<davidl>but I will see what I can do (comparing with the sed example you mentioned)
<zimoun_>hi!
<ascetic>jpoiret: does it apply to scripts as well?
<jpoiret>ascetic: i believe so
<ascetic>jpoiret: got it
<davidl>unmatched-paren: I dont know what you mean by the following, Ill try and look it up, but maybe you can give a pointer? > for GUILE-BASH-FOR-BASH-CODING-UTILS, you should use MODIFY-INPUTS for INPUTS, and SUBSTITUTE-KEYWORD-ARGUMENTS/gexps with ARGUMENTS
<zimoun_>I am running an old version of Guix (29efa27 pulled on 17 January). And I cannot download substitutes. Is it expected or known?
<unmatched-paren>davidl: you're using old-style inputs and arguments for your GUILE-BASH variant, yes?
<unmatched-paren>MODIFY-INPUTS and SUBSTITUTE-KEYWORD-ARGUMENTS are macros that let you modify existing input/argument lists in a much cleaner way
<unmatched-paren>(substitute-keyword-arguments ARGUMENTS ((#:phases #t) NEW-PHASES) ...)
<unmatched-paren>(modify-inputs INPUT-LIST (prepend PACKAGE))
<unmatched-paren>hmm, actually, if GUILE-BASH uses old-style inputs, MODIFY-INPUTS may not work...
<jpoiret>zimoun_: berlin is down
<zimoun_>jpoiret: Ah… Thanks
<minima>oh ouch... my guix explodes with an out of memory error and a laconic "Killed"; i'm just updating via "guix home reconfigure ..."; anywhere in particular i should start from to debug this?
<unmatched-paren>minima: likely an endless recursive reference somewhere
<minima>ah... no subs possibly?
<minima>unmatched-paren: oh i see
<minima>interesting
<zimoun_>jpoiret: well, it means that we still have issues with our code because “guix shell foo” takes ages with Guix 14c0380 from 19 May. And this should automatically fallback or stop. And not loop for (almost) ever.
<minima>unmatched-paren: what are my options? rolling back to a prev guix? debugging this to see where the possible circular ref is? (i'm using guix on a foreign distro, fwiw)
<minima>just waiting and guix-pulling again in a bit? :) the lazy option
<jakiki6>is ci.guix.gnu.org down?
<macrocreation>yes
<jakiki6>do you know why?
<macrocreation>No idea.
<macrocreation>you need to use bordeaux
<macrocreation>by doing ---substitute-urls=....
<jakiki6>thanks
<unmatched-paren>minima: not sure :/
<cbaines>minima, I think we've got a loop in the package graph
<cbaines>time to run around in circles :D
<cbaines>... although maybe not, as the loop detection code doesn't find one
<cbaines>anyway, something is up in the last set of changes
<anemofilia>How can I install haunt in guix?
<anemofilia>I tried to install normally, but I get no response from the repo
<anemofilia>And when I use --with-git-url=https://git.dthompson.us/haunt.git it won't work either
<cbaines>haha, found the loop https://git.savannah.gnu.org/cgit/guix.git/commit/?id=87d5754107e2393cc5d2ab44cd9586b3bf73b011
<cbaines>maybe the loop detection code doesn't work when the loop is so tight
<vagrantc>that's ... amazing
<ngz>cbaines: Oh oops! I guess I was distracted.
<cbaines>no worries, although this does suggest that emacs-keycast wasn't actually built in this state
<cbaines>the commit message seems to suggest a working change, so I'm not sure how that's OK but the actual changes aren't
<jpoiret>janneke: so i got stuck trying to get native compilation working again, but i'll try to send my patchset tomorrow, updating Hurd/gnumach/mig but also more importantly adding a glibc just for hurd
<jpoiret>I'm getting an endless loop in Guile while trying to cut coreutils-boot0 on the hurd for some reason
<sneek>wb tschilp
<tschilp>sneek: botsnack
<jpoiret>btw I was wrong about being able to rm the directory in Guile, as the comment right above that points out :) so I'm trying to use the bootstrap's coreutils instead. If that doesn't work, we might have to just update the bootstrap blobs, adding the kernel headers as well
<sneek>:)
<tschilp>Hi Guix!
<tschilp>Have there been any major changes regarding 'guix pull --news --details' since 7b00b155d8f474d493a22ff7cccbeec311b9bbc8? I'm starting the command with 4.8GB available RAM and it gets killed...
<tschilp>After the pull to e499cb2c12d7f1c6d2f004364c9cc7bdb7e38cd5
<efraim>tschilp: pull again, that commit is part of a broken set
<tschilp>efraim: thanks!
<mirai>jpoiret: have you thought on making that git format option to workaround DKIM errors a default in etc/git/gitconfig ?
<jpoiret>I was about to say no, but actually I have!
<jpoiret>mentioned it briefly before the patch got merged
<raghavgururajan>Hello Guix!
<raghavgururajan>lilyp: Sorry, was caught up with some personal stuff for past months.
<raghavgururajan>How can I help with the current gnome work?
<mirai>jpoiret: oh right, it's already there 😂
<raghavgururajan>Do you have priority list from from I could pick packages and work on?
<davidl>unmatched-parent: the modify-inputs procedure on guile-bash-for-bash-coding-utils worked fine. So thats fixed. Working on the other parts..
<tschilp>mhm, and for 26b71e1982afac9112f73c359a21ac76f641d19e I get https://paste.debian.net/1280809 on 'guix pull --news --details'...
<davidl>unmatched-paren: the substitute-keyword-arguments stuff seems quite difficult to understand to be honest. I found this commit for reference, but it takes a while to figure out whats going on I must say. https://github.com/guix-mirror/guix/commit/a6194d1f35ec8ac9b58f4d05affa5aabf1ca7014
<lilyp>raghavgururajan: core is mostly done, it's now upgrading all the other things to gnome 44 basically
<raghavgururajan>Okey doke!
<tschilp> https://ci.guix.gnu.org/ does not seem to load for me
<ngz>tschilp: It loads for no one.
<tschilp>ngz: oh -- just looked, as I think I just pulled from bordeaux for the first time...
<davidl>unmatched-paren: alright, I got the substitute-keywords thing working for guile-bash-for-bash-coding-utils to work now.
<dzwdz>how long `guix pull` on a fresh vm take?
<dzwdz>is there something i'm supposed to do beforehand to make it faster?
<davidl>unmatched-paren: maybe Ill be able to fix the new style for bash-coding-utils tomorrow. Im not sure how to write the native-inputs there correctly.
<tschilp>ACTION thinks restarting my computer might be a good idea.
<apteryx>is it just me having issues ssh'ing into berlin?
<civodul>apteryx: no, it's unreachable
<civodul>i've just emailed guix-sysadmin; no idea what's going on
<apteryx>we can reboot it, node 129 is up and reachabel
<civodul>oh is it?
<apteryx>I'm connected to it
<apteryx>ah; SYSTEM HAS CRITICAL ISSUES from idrac dashboard
<apteryx>it's short on details though
<civodul>uh
<cbaines>bayfront was struggling today, but I think earlyoom saveed it
<cbaines>maybe berlin was affected by the same issue?
<minima>unmatched-paren cbaines: hey thanks, i've pulled again and, fwiw, all seems back to normal here
<apteryx>I don't see what's wrong from idrac
<apteryx>and I have to run
<civodul>ACTION fails to connect to the iDRAC web interface :-/
<rekado>civodul: want me to reboot it?
<civodul>rekado: hi! yes if you don't mind; i suppose that's the only thing we can do
<rekado>ok
<rekado>“Server power operation initiated successfully”
<rekado>I see it booting on the serial console
<civodul>great, crossing fingers
<rekado>copying kernel files…
<rekado>(surely this can be simplified a bit…)
<rekado>civodul: have you tried connecting to iDRAC via SSH?
<rekado>hop onto 129 and then ssh guix@iDRAC-IP
<rekado>(I forgot the password for that user; I have a separate account.)
<rekado>it booted
<rekado>anonip things failed to start
<rekado>so nginx isn’t up
<rekado>it’s up now
<oriansj>rekado: keepassxc is available in guix
<rekado>I have a password manager
<rekado>it’s just an account I don’t use
<oriansj>sadly none of the mooltipass tools are not available
<oriansj>^are not^are^
<civodul>rekado: thanks! i tried to connect to the web interface via an SSH tunnel and got HTTP 500
<civodul>(based on infra-handbook.org)
<rekado>civodul: does the SSH method work for you?
<civodul>the proxy.pac thing, no (i'm already using a proxy so that's just too much for me :-))
<civodul>so i tried "ssh -L ...", but something's wrong
<rekado>I meant without the browser
<rekado>directly connect with ssh to the iDRAC console
<rekado>the web interface is useful for things *other* than the serial console
<rekado>(e.g. firmware, idrac logs, system stats, etc)
<rekado>for the serial console itself I use SSH to connect to iDRAC and then run “console com2” from there
<civodul>oh i see, i hadn't noticed this section in infra-handbook.org
<civodul>i'll try that next time
<civodul>ACTION looks at /var/log/messages
<rekado>ACTION sent a mail to guix-sysadmin
<rekado>two issues: OOM and btrfs sadness
<civodul>yeah
<civodul>it's running shepherd 0.10!
<civodul>rekado: looks like the anonip didn't "formally" fail to start, did they?
<civodul>oh they did actually, sorry
<civodul>"herd log" shows them in red, wonderful