IRC channel logs

2023-04-05.log

back to list of logs

<mekeor[m]>hello. what's the best way to customize a package (in scheme code) by changing configure-flags? in particular, i would like to install emacs-next-tree-sitter without the "--with-native-compilation" flag.
<coolguy>Hello, I've been experimenting with Guix and more specifically the pack option. I've been building a few packages and I was wondering whether or not the pack option generates static binaries.
<coolguy>From what I can tell, it does but only if the binaries are sitting under /bin.
<mekeor[m]>mekeor: you want this: (arguments (substitute-keyword-arguments (package-arguments foobar) ((#:configure-flags configure-flags)
<mekeor[m]>Guest52: there is this search engine for packages (and service etc) within many community-maintained channels: https://toys.whereis.xn--q9jyb4c . you can always search for a package there, if it's missing in guix proper.
<Guest52>mekeor[m]: Awesome! I found a zerotier package in nongnu with that tool. Thanks!
<guixcurious>would someone know offhand why i would be getting a message "duplicate 'sudoers' entry for /etc"  upon running   `guix system init` - I'm not seeing getting any results for this problem anywhere, not sure if its Guix specific or some order of operations issue on my end
<timothyw>exit
<lilyp>guixcurious: probably because you're trying to add another sudoers file to etc? what does your config file look like?
<lilyp>ACTION → work
<apoorv569[m]>Is there a build system for zig?
<ulfvonbelow>do we not support mixing explicitly-labeled and implicitly-labeled inputs?
<TristanCottam[m]>IIRC, no
<ulfvonbelow>e.g. our python build system assumes the python in question will have an input label of "python", but I need to use python2, which is named "python2".
<TristanCottam[m]>Actually not so sure anymore
<ulfvonbelow>so I guess that means I need to change the entire input list to the old style. How is this going to work once the old style is removed?
<ulfvonbelow>hmm, seems the friction I'm running into is because I'm just pulling certain phases out of python-build-system (package itself uses configure and make). Maybe it would be better to just include make as a dependency and use the python build system.
<mvnx>apoorv569[m]: There is an unreviewed patch for zig-build-system that was been submitted a few months ago. https://issues.guix.gnu.org/60889
<apoorv569[m]>I see. How much time does it usually take for a PR to be merged and available in the channels?
<user_oreloznog>o/
<jpoiret>ulfvonbelow: we technically could, but since it's been decided that the new input system is the way to go i don't think this would be accepted
<jpoiret>but yeah i've run into this issue myself
<ulfvonbelow>seems that if the python to use is passed as #:python in the arguments and python-build-system is used it'll automatically arrange to make the input label just "python"
<jpoiret>internally the new package inputs are converted to (list (package-name package) package), but this transformation is either applied to the whole input list or not applied, whereas it could be just applied to whatever elements are just packages
<mvnx>I need a go builder that supports modules. I need to learn Scheme first to help
<mvnx>Also need the zig builder :D
<mekeor[m]>hello. after installing a package with --with-branch or so, is there a way to find out which commit has been installed?
<ardon>Hi guix, just bumping this https://lists.gnu.org/archive/html/help-guix/2023-03/msg00273.html to see if anyone follows a similar workflow. I like to work on top of Guix but test things from my local dotfiles checkout, is this something common here?
<oriansj>well running scripts for local setup isn't uncommon; I myself do it and publish the procedure along with the configuration used for those interested.
<unmatched-paren>hello, guix :)
<ardon>oriansj: Thanks for chiming in :) Could you share your exact setup? I feel like apart from setting the guile load paths, I'm missing something crucial that is not letting me use the modules in my local Guix checkout
<Guest10>Hi. Does anyone know why the bittorrent app "Fragments" has no guix package yet? It's written in rust. Is there some underlying problem with the app (the way javascript apps can't be packaged for guix) or has just no one come around to package it yet?
<ardon>Guest10: I guess because most folks are already using Transmission. Feel free to submit a patch for it though
<Guest10>Alright, thank you
<TristanCottam[m]>Hi guys! When I run `sudo guix system reconfigure`, I get the following warnings:... (full message at <https://libera.ems.host/_matrix/media/v3/download/libera.chat/1d3de93afe76ced92f83d168efcc9e585cf480dc>)
<efraim>TristanCottam[m]: you can ignore those, it comes from Guix using slightly different versions of guile at different points to decrease world rebuilding changes
<TristanCottam[m]>efraim: I was wondering if it was the cause of this error:... (full message at <https://libera.ems.host/_matrix/media/v3/download/libera.chat/a61d7970f394d1e962f311d3ebe63927e10fcea0>)
<efraim>that one I dont recognize offhand, but it looks like some file imported by (gnu machine ssh) changed and I'd guess it's not happy with something going to be placed in /etc/<something>
<TristanCottam[m]>How can I troubleshoot?
<efraim>can you share your config? Then I can take a look at it.
<efraim>also, are you running from a git checkout or using guix from `guix pull`
<TristanCottam[m]>`guix pull`
<TristanCottam[m]> https://codeberg.org/tristan-cottam/server/src/branch/main/system.scm
<efraim>I'm getting 'doesn't exist or not authorized'
<TristanCottam[m]>Sorry about that, fixed
<efraim>I'd try inlining pg_hba.conf since it's only 3 lines
<efraim>I don't think it's the mcron job, I have mcron jobs using the mcron-service-type directly and I don't have an /etc/mcron directory
<TristanCottam[m]>I don't remember changing anything for this to happen, I'll go back in time
<TristanCottam[m]>Indeed, this problem is not, or at least not only, caused by my config
<efraim>when is the older guix version from? I can see if I can figure out what's changed since then
<TristanCottam[m]>Previous commits have the same problem
<efraim>oh
<TristanCottam[m]>Can I not make use of all of Guile's magic to troubleshoot this systematically?
<efraim>I haven't used guix deploy before, but I would change the file so you can build the system locally and see if it builds correctly with 'guix system vm`
<TristanCottam[m]>I'll give that a try
<efraim>and then add and remove bits to try and see if that changes anything
<TristanCottam[m]>It doesn't work, even with a minimal configuration
<mirai>what's the 'he' parameter in home environment
<mirai>has anyone managed to use modify-services with home-environment-essential-services?
<mirai>Zstd 1.5.5 was releated today and it fixes a corruption bug <https://github.com/facebook/zstd/releases/tag/v1.5.5>
<mirai>though running a dep count on it indicates: guix-count-deps zstd
<mirai>7214
<fiesh>I recently learned about lzip and how it basically is the good version of xz and should replace it entirely
<mirai>fiesh: while lzip is better, that's inconsequential here
<mirai>anything that uses zstd with the right combination of factors is is risking data loss
<oriansj>ardon: you can find a copy of my setup procedures and default configurations here: https://git.sr.ht/~oriansj/System_setup and https://git.sr.ht/~oriansj/config
<fiesh>mirai: didn't say it was relevant to what you wrote
<ardon>oriansj: Thanks for the pointers! Apologies if I missed it, but I can't seem to find where you add the local Guix checkout to your load path in your setup script?
<sysfu>I'm trying to stop the service that runs GDM (Gnome Display Manager) and have it shut down X and kick me back to a console. Would that be the elogind service?
<jackhill>sysfu: it's called xorg-server I think.
<jackhill>(the names a little confusing to me as well)
<jackhill>it's xorg-server even when GDM is running in wayland-mode
<sysfu>jackhill: Got it, will give that a shot thx.
<ngz>Hmm. I get a TLS error on <https://qa.guix.gnu.org/patches>. Am I alone?
<pusherofbrooms>No TLS errors for the root host but that patches page is  taking a long while to load.
<phyto[m]>how secure is a guix shell --container?
<pusherofbrooms>Ah, so the server seems to be maybe getting a TLS error from a dependent service. I see the tls error now.
<apteryx>phyto[m]: as secure as any Linux namespaced process (man 2 clone)
<phyto[m]>also, sorry if this is a stupid question (i'm new), but how can you let one program call another? pipe-viewer relies on mpv to play anything, but it can't call it because sh: line 1: /bin/mpv: No such file or directory
<apteryx>which is what Docker and other containerization technologies relies on, if I'm not mistaken
<phyto[m]>ty
<apteryx>phyto[m]: is this pipe-viewer package in Guix already? if so, it should be patched to refer to (search-input-file inputs "bin/mpv") instead, with mpv added as in input
<cel7t>jpoiret: I'm still expecting that I'll run into a lot of road bumps while finishing it- especially while implementing generic transforms for converse parameters. For example, even with package rewriting it might be hard to rewrite a package to _not_ use X11 in a way that's applicable to a lot of packages
<apteryx>otherwise, to run a prebuilt binary that expects a file hierarchy standard layout, you could try the --emulate-fhs of the 'guix shell' command
<phyto[m]>yes pipe-viewer is packaged in guix (and mpv is installed both via guix and system package manager)
<phyto[m]>oop wait i'm dumb, it does define the packages that it needs - but mpv was just always set as the default video player so i never noticed that mpv just uses xdg-open
<phyto[m]>i don't suppose i could just crudely guess the syntax for this and get something working https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/video.scm#n1163
<sysfu>jackhill: So I tried that (sudo herd stop xorg-server) and got stuck with a blank screen and flashing cursor top left, no ability to switch to another vconsole via CTRL-ALT-F#, nothing. Had to poweroff and reboot.
<jackhill>sysfu: huh, odd. But switching worked before you did that?
<sysfu>jackhill: yes, I switch to other vconsoles without issue while xorg-server service is running. Appears the that GDM login screen is on vcon7, desktop on vcon8, vcon9 has that flashing cursor in upper left, and vcon12 looks like xorg log.
<jackhill>sysfu: ok, well, unfortunatly you're past my knowledge, sorry. Hopefully someone else can jump in.
<phyto[m]>oh my god i'm a moron, pipe-viewer has a hardcoded /bin/mpv path in its default config
<phyto[m]>that's one mystery solved then
<sysfu>jackhill: I might opt for a reinstall, foregoing all of the WM environments. I have been using ratpoison but I'm going to check out stumpwm, the lisp successor.
<sysfu>any tips on how to disable the login manager for guix systems that were originally setup with a graphic installation? I want to get rid of GDM and have it book to a console.
<msavoritias>You can delete the gdm service.
<msavoritias>The manual says how to delete services in the system config
<sysfu>msavoritias: Will read up on that section, thank you.
<msavoritias>np. its under System config. Look for modify-services
<yuna>Hi, does anyone know if theres a good way to lookup where to find things in the package trees? Guix/Guile seem to have things very well sorted and so Im finding it hard to 'discover' the interface
<cel7t>What kinds of things? If you're looking for binaries (ex. what package provides the 'clear' command) use command-not-found.com
<efraim>sorry everyone for the broken commit, fixed now. I was testing on aarch64 and ppc64le
<yuna>@cel7t I mean like stuff in Guix's Guile interface. All the variou modules. I find I have to do some detective work every time to figure out what exactly I need to import
<yuna>So far Ive found I just end up going through the git repo. Im not sure its thats meant to be how we do it
<yuna>I guess what might be useful is if there is just documentation for the modules somewhere? Eg everything like (guix), (guix cpu), (guix x y x), etc etc etc
<lfam>Thanks for working on those tangled packages, efraim
<lilyp>rgrep works wonders, but guix itself can detect missing imports also some of the time (especially with packages9
<lilyp>s/9/)/
<yuna>whats rgrep? havent heard of that one
<sysfu>yuna: just shorthand command fro 'grep -r'
<panosalevro>hi all, how would I go about installing this package on my system? https://issues.guix.gnu.org/61423
<yuna>sysfu: lilyp: ah okay thank you.
<yuna>panosalevro: I dont know the specifics of that package, but It seems to appear in just guix search for me. ~guix package -i zrythm~ doesnt work?
<panosalevro>yuna: zrythm in guix is ~2 years outdated
<panosalevro>i would appreciate some help installing this package until it is merged
<yuna>panosalevro: ah yeah I see. the guix one actually failed to build for me when I tried to shell it just now even.
<panosalevro>yep
<lfam>The TLS certificate for guix-patches.cbaines.net has expired
<lfam>"#<x509-certificate 7fdefca6c5b0>patches.guix-patches.cbaines.net#<gnutls-certificate-status-enum expired>#<gnutls-certificate-status-enum invalid>"
<yuna>panosalevro: so this doesnt actually solve your problem directly, but zrythm is on flathub is you need it working asap. otherwise Im not sure how to bypass to that patch
<panosalevro>actually, can i just use zrythm binaries? that would be a good workaround
<panosalevro>yuna: thanks, i know that. unfortunately the flatpak version has the limitation that it can only accept flatpak addons as well
<apteryx>what's the problem with zrythm currently?
<panosalevro>apteryx: it's ~2 years outdated
<apteryx>have you tried updating it?
<panosalevro>the guix package is outdated
<apteryx>right; from a guix checkout: ./pre-inst-env guix refresh -u zrythm
<lfam>Usually, you could do this:
<lfam> guix time-machine --url=https://git.guix-patches.cbaines.net/git/guix-patches --branch=issue-61423 -- install zrythm
<lfam>But, that server's TLS certificate has expired
<panosalevro>that's pretty cool, i didnt know that lfam.
<panosalevro>apteryx: can you explain the command you sent?
<lfam>Yeah, it's new-ish service
<yuna>Oh thats a nifty trick, I didnt know time machine worked going forward
<lfam>It works generally. Think of it like `guix pull` but it doesn't create an entry in your profile generations history
<lfam>An ephemeral `guix pull`
<panosalevro>when can we expect the server to work again?
<lfam>I'd guess, shortly after cbaines notices my messages on the subject ;)
<bjc>does anyone have any hints on srfi-64 style testing of service composition?
<panosalevro>cbaines: ping! :)
<cbaines>lfam, I've just noticed :) now I just need to fix things...
<lfam>Otherwise, you can do as apteryx suggested. Apply the patch to a Git checkout of Guix and then carefully follow the instructions in the first two sections of this manual chapter: https://guix.gnu.org/manual/devel/en/html_node/Contributing.html
<panosalevro>lfam: thanks!
<lfam>Probably, time-machine is easier. But the latter will help you join the ranks of the Guix contributors :)
<panosalevro>would be happy too. still trying to wrap my head around guix
<panosalevro>s/too/to
<lfam>Cheers, welcome to your journey
<cbaines>apteryx, there's already one patch series for updating zrythm waiting for review
<panosalevro>since zrythm is updated quite frequently, what would be the best way for me to actually get the latest version of zrythm each time, independent of zrythm repos?
<apteryx>cbaines: oh, great! did it pass the QA checks?
<cbaines>as far as I remember it did
<apteryx>panosalevro: perhaps --with-latest would work
<apteryx>hm, guix build --with-latest=zrythm zrythm -> using zrythm 0.8.982, which is older than the packaged version (1.0.0-alpha.12.0.1)
<apteryx>are there no usable stable releases ?
<panosalevro>no, it's still in beta
<panosalevro>I get "guix time-machine: error: Git error: cannot locate remote-tracking branch 'origin/keyring'"
<cbaines>looks like some review did happen on the zrythm issue I was thinking of https://issues.guix.gnu.org/61423#8
<cbaines>anyway, qa.guix.gnu.org should be slowly coming back now
<lfam>Huh, I'm surprised that time-machine has that error
<lfam>Not sure how that is supposed to work
<lfam>Does anyone understand how to fix it?
<Guest19>does sound in guest for work for you in virt manager?
<apteryx>panosalevro: I'm looking at it
<panosalevro>thanks
<lfam>I can reproduce the error
<apteryx>lfam: I guess it cannot go further in time than before the keyring branch was created?
<lfam>It's this branch: https://git.guix-patches.cbaines.net/guix-patches/log/?h=issue-61423
<lfam>Idk, I'm lost
<Guest42>Hi. I'm trying to package Fragments, but I'm getting the error that pango needs to be version >= 1.50 but 1.48 is installed. Even though I specify pango-1.90 as an input. I don't understand this, can someone please help me? https://paste.debian.net/1276439/
<jonsger>lfam: put it up for discussion :) https://issues.guix.gnu.org/62685
<lfam>jonsger: If you push, please add a news.scm entry as well
<jonsger>eh, thats what I wanted to ask for :)
<jonsger>like, if we should do that
<lfam>It's nice to d
<lfam>To do
<Guest19>Guest42: gtk+ is gtk3, just use gtk and you do not neet pango since it is indirectly included for gtk
<Guest19>(except pango is required for the actual program)
<Guest42>Guest19: That was it, thank you!
<jonsger>cbaines: bordeaux building packages from patches at issues.guix.gnu.org is a beauty work-flow wise, thanks!
<lfam>Yes, very nice
<lfam>As a project we should invest our resources instead scaling it up
<lfam>I meant to write, "invest our resources into scaling it up"
<lfam>That's my sign that I've drank too much coffee and need to log off
<jonsger>My sign is no coffee and need to sleep :)