IRC channel logs

2023-03-25.log

back to list of logs

<NewUser-Basic-Qu>Hi...playing with sway. Wanted to try some modding. if i check wm.scm i see that sway version is 1.6.1 and has sha256 (base32 " 0j4sdbsrlvky1agacc0pcz9bwmaxjmrapjnzscbd2i0cria2fc5j").. My assumption was if i download the 1.6.1 version via guix download <source> i will see the base32 but i do not. Waht am i missing?
<pkill9>is guix system usable on raspberry pi yet?
<gnucode>pkill9: what's your use case?
<pkill9>use as a NAS
<NewUser-Basic-Qu>google DNS does not resolve git.savannah.gnu.org
<NewUser-Basic-Qu>tried "nslookup git.savannah.gnu.org 8.8.8.8" and get a servefail
<NewUser-Basic-Qu>ok....works again...
<jgart[m]>Would anybody like to suggest better examples than these for match-lambda? https://www.gnu.org/software/guile/manual/html_node/Pattern-Matching.html#index-match_002dlambda
<practical-friend>"Pattern Matching (Guile Reference Manual)" https://www.gnu.org/software/guile/manual/html_node/Pattern-Matching.html#index-match_002dlambda
<jgart[m]>I feel like we can do better than that for an example of match-lambda
<jgart[m]>pkill9 not sure but it's useable on a ppp: https://git.sr.ht/~abcdw/guix-pinephonepro
<practical-friend>"~abcdw/guix-pinephonepro -
<pkill9>coool
<jgart[m]>I think there will probably need some work to be done to create a config for sway similar to the sxmo one but using rde APIs for sway? abcdw_
<jgart[m]>singpolyma: would be cool to get this into guix: https://github.com/purescm/purescm/
<practical-friend>"GitHub - purescm/purescm: Scheme backend for PureScript (a small strongly, statically typed programming language with expressive types, inspired by Haskell)." https://github.com/purescm/purescm
<mirai>jgart[m]: IMO what makes the examples subpar is that it immediately starts off with one that is "hard on the eyes"
<jgart[m]>it compiles to chez
<mirai>matching a list within a list containing a symbol
<jgart[m]>mirai: I just think that is the worst example I have ever seen of trying to explain something
<mirai>perhaps a match that does strings, numbers, list of strings and numbers is a better way to kick things off
<jgart[m]>it's unnecessarily convoluted
<mirai>and a more elaborate one towards the end
<mirai>agree
<jgart[m]>that is not the way people normally use match-lambda
<jgart[m]>it's terrible
<mirai>I was also befuddled the first time I read it (even the simple match example is way too convoluted IMO)
<mirai>match-lambda also comes with a neat surprise
<jgart[m]>there so many elegant examples that could have been demonstrated for match-lambda
<mirai>docstrings don't work :)
<jgart[m]>it feels like an april fool's joke of an example
<mirai>you'll get mystery error messages
<jgart[m]>docstrings are broken for other guile code also
<mirai>😂
<jgart[m]>the convention in those situations is to think of scheme to be as dumb as C
<jgart[m]>you just write a comment above the thing like c
<mirai>prime bikeshed window
<jgart[m]>atleast that's what I've seen people doing when docstrings are broken on the object
<mirai>do you place it before or after the 'define' ?
<jgart[m]>before
<jgart[m]>I've seen it before
<jgart[m]>but not sure if that's a hard rule
<jgart[m]>just empirical
<mirai>but then the comment doesn't accompany the code and it's liable to be orphaned over time!
<mvnx>Using `guix home` - any idea why the environment  variable doesn't get passed through, for example, `alias v="$VISUAL"` equivalent for this config (doesn't set it properly) https://paste.debian.net/hidden/cdc0cd81/
<practical-friend>"Debian Pastezone" https://paste.debian.net/hidden/cdc0cd81
<jgart[m]>mirai ya not sure what we do about that
<mirai>mvnx: I think the manual covers about some helpers that care about $ interpretation
<jgart[m]>guix home describe could use json output like guix describe has
<mirai>failing that, scheme code always works
<jgart[m]>would be cool to add
<jgart[m]>on my TODO list
<mirai>(let ((...)) ... (assoc-ref ... ))
<jgart[m]>but feel free to take it off my list ;()
<jgart[m]>there's no way to uninstall guix home
<jgart[m]>I've been procrastinating fixing that
<mvnx>mirai: Thanks I'll try to dig for that. And the Scheme helps too - new to this
<jgart[m]>If you install guix home on an alien distro then it's a mess to uninstall it
<jgart[m]>s/alien/foreign
<jgart[m]>there's an ml thread open for this issue
<jgart[m]>somewhere in the Mailman jungle iirc
<jgart[m]>mvnx: actually i had a similar issue today with EDITOR
<jgart[m]>let me try something and reconfigure now that I just thought about
<mvnx>I think I want the `environment-variables` to apply before `aliases` in `home-bash-configuration`. I haven't dug into the source yet
<mirai>jgart[m]: I've been dumping some ideas about guix at https://makinata.eu/drafts/guix/
<mirai>pretty much all of them are still WIPs
<jgart[m]>it's terrible to press e in nnn and get terrible nano which i don't even know how to exit out of...
<mirai>s/ideas/ideas & pain points
<jgart[m]>mirai: cool
<jgart[m]>you have more discipline than I do since I usually dump them on #guix and then forget about them
<jgart[m]>i think busfactor is a real thing for guix and guile: https://makinata.eu/drafts/guix/busfactor.php
<jgart[m]>organizing to spread the knowledge about internals of both would be amazing but very ambitious
<jgart[m]>extremely ambitious for guile internals to say the least
<jgart[m]>but I am still interested in that
<jgart[m]>and pursue what I can at my pace
<jgart[m]>mirai: I just got a nice config going for sway on guix system: https://git.sr.ht/~whereiseveryone/confetti
<practical-friend>"~whereiseveryone/confetti -
<jgart[m]>thanks to unwox and unmatched-paren who I stole a ton of code from ;()
<jgart[m]>still don't have wlgreet working with greetd on tty1 though but that's ok.
<jgart[m]>I want to start porting some of this perl code to common lisp gexp based scripts for practice: https://github.com/pflanze/chj-scripts/search?l=perl
<practical-friend>"Search · · GitHub" https://github.com/pflanze/chj-scripts/search?l=perl
<jgart[m]>there are some gems there
<jgart[m]>not ruby
<mirai>interesting
<mirai>there's quite a lot here
<mvnx>I use-modules `(gnu packages vim)` which defines `neovim`. Is there a way I can get the binary name, or at least it's primary `out` path, from that? I'm sure it's documented but I don't know the keywords for what I'm trying to do.
<bjc>it doesn't have a path until it's built
<jgart[m]>mvnx: you can use a gexp to get the binary name
<jgart[m]>depends the context in which you need that binary name
<mvnx>I was still experimenting with this `$VISUAL` thing - probably not needed. I'm brand new to all of this just trying to get a working system primarily so maybe I'll focus on that and then dig deeper into Guile and more advanced things here.
<jgart[m]>one thing you can do is just focus on learning the package manager first
<jgart[m]>learn how to package and contribute packages, updates, etc.
<jgart[m]>on any foreign distro
<jgart[m]>of your choosing
<jgart[m]>that's what I did the first two years
<mvnx>I have been getting started yeah. I packed a few missing rust dependencies and upgraded a few that built locally. Contributing is a short-term goal.
<mvnx>I have some software I want :P
<jgart[m]>what's the long term goal?
<jgart[m]>if you don't mind sharing
<next4th>hello :)
<jgart[m]>hi
<next4th>so debbugs is working again, good..
<jgart[m]>that should be debbugs' project slogan
<next4th>um, i don't get the humor point, but there must be some in your words. lol
<mvnx>jgart[m]: I'd like to learn to understand my Guix system very well and actually learn Guile (I've wanted to learn a Lisp for a long time). It seems things are still a bit early so it's a good opportunity to contribute while I learn. It's difficult to paint a long term goal but if I'm contributing new packages or updates for things I need then I
<mvnx>would continue to maintain them. If I learn more Guile, maybe I could contribute in other ways. It's been surprisingly easy to create and update packages locally given I have zero Lisp background and just starting to explore with Guix.
<next4th>mvnx: that's good to hear!
<Guest19>does anyone else having dns problems with gnu?
<ichernyshovvv[m]>Yeah, I can not connect
<minima>yeah, same here
<minima>up again for me now?
<Guest19>on my side it is still not reachable
<cel7t>Yeah I can't connect to issues.guix.gnu.org either
<cel7t>By the way, the default installation has a broken notification icon on XFCE
<cel7t>Any idea how to fix this?
<next4th>use elementary-xfce-icon-theme may fix icons on Xfce
<cel7t>we should probably package this with the default XFCE package
<cel7t>Is there a mirror for issues.guix.gnu.org?
<next4th>i don't think there is a mirror, and looks it's unreadble due to DNS died...
<next4th>maybe it's time looking into gnunet-dns :)
<apollo>is guix.gnu.org down?
<next4th>gnu.org and its subdomains are unreachable for me (from China), with unresolved address, well add '185.233.100.56 guix.gnu.org' to /etc/hosts does the trick...
<lilyp>there is actually a china mirror IIRC
<apollo>I'm getting a 'Gnu.org is DOWN for everyone.' at isitdownrightnow.com, I'm in EU rn
<cel7t>Does anyone know the IP address of the issues subdomain?
<cel7t>It's definitely a DNS issue
<cel7t>We should also perhaps try and setup an onion link for the Guix site
<mragkousis>I am also getting a dns error, and came here to confirm I am not alone
<apollo>Yeah, can't even use guix to install packages rn, even if i'm using the github mirror
<cel7t>Hmm interesting I can access gnu.org over tor but not the Guix site
<mragkousis>gnu.org also works normally
<mragkousis>now
<cel7t>I wish Guix had an onionsite too
<cel7t>they are more resilient to DNS issues
<sarg>hi guix. Is there some status page for guix on a non-gnu domain? It seems that *.gnu.org is not responding and unfortunately there is no way to find out what's the deal. lists/issues/ci/irc logs/substitutes - everything is on gnu.org
<sarg>anyone has NS addresses for gnu.org?
<janneke>sarg: https://hostux.social/@fsfstatus
<practical-friend>"FSF Out of Band Updates (@fsfstatus@hostux.social) - Mastodon Hostux" https://hostux.social/@fsfstatus
<sarg>janneke thx
<sarg>is there a substitutes server hosted outside of gnu.org?
<mirai>o/
<sarg>found one from cbaines
<cbaines>sarg, that's probably old, I don't current run one personally
<sarg>that's fine, I've got what I needed
<mirai>yhetil.org has some ML mirrors
<mirai>and ML<->IMAP/NNTP/...
<civodul>hello! what's the status with DNS?
<civodul>tip of the day: --substitute-urls=https://141.80.181.40
<practical-friend>Exception: #<&compound-exception components: (#<&error> #<&origin origin: host-mismatch> #<&message message: #<x509-certificate 7fd453a0de60>> #<&irritants irritants: "141.80.181.40"> #<&exception-with-kind-and-args kind: tls-certificate-error args: (host-mismatch #<x509-certificate 7fd453a0de60> "141.80.181.40")>)> https://141.80.181.40
<janneke>yeah, that's helpful
<mirai>cel7t: an onionsite sounds interesting
<mirai>perhaps with an eepsite as well
<mirai>incidentally, that reminds me that I've yet to rework the tor service in guix
<cbaines>I'm not quite sure what's wrong where with the DNS, I don't seem to be able to resolve the domains for the GNU nameservers
<alanz>me too. Neither guix update nore gnu elpa
<janneke> https://mastodon.social/@amszmidt/110083210377407192
<practical-friend>"Alfred M. Szmidt: "@fsfstatus@hostux.social can you make a list of I…" - Mastodon" https://mastodon.social/@amszmidt/110083210377407192
<civodul>the last toot at @fsfstatus@hostux.social was almost 23h ago :-/
<civodul>s/almost//
<janneke>yeah, terrible
<mirai>I stole this msg from #gnu: https://tumbleweed.nu/tmp/gnu-hosts.text
<madand>hello, I jut tried to guix pull and got this:
<madand>guix pull: error: Git error: failed to resolve address for git.savannah.gnu.org: Temporary failure in name resolution
<madand>could this be a problem on my side?
<madand>ah, navermind. seems to work now.
<next4th>madand: not your side, there have some dns problem for gnu hosts. you can try add those hosts manauly in /etc/hosts with https://tumbleweed.nu/tmp/gnu-hosts.text
<NewUser-Basic-Qu>DNS resolution for gnu.guix.org unstable...at least until 5 minuets ago
<NewUser-Basic-Qu>anyway...hi all
<next4th>Hello :)
<madand>next4th: thanks for the hosts file, added to mine
<futurile>happy weekend guixers!
<NewUser-Basic-Qu>Question: I want toexperiment with packages a bit. Therefore i took sway-package from wm.scm and tried to mod it. First thing was  i thought i use "guix download" to check base32 of existing configuration. Seems i am not able to fetch a sway 1.6.1 Version that has base32 "0j4sdbsrlvky1agacc0pcz9bwmaxjmrapjnzscbd2i0cria2fc5j". What am i doing
<NewUser-Basic-Qu>wrong? As reference: https://controlc.com/e0c8bc91
<practical-friend>"guix sway config - e0c8bc91" https://controlc.com/e0c8bc91
<mirai>what's the problem?
<next4th>it's a 'git-fetch' which can't be fetched/checked via 'guix download' iirc, you can do 'git clone ...; git checkout 1.6.1; guix hash -xr ...' instead.
<NewUser-Basic-Qu>next4th , oki oki oki ....thanks so much...
<mirai>looks like things are working again?
<janneke>ACTION receives some email again
<NewUser-Basic-Qu>next4th https://controlc.com/83abcd82 thanks so much
<practical-friend>"okidoki... - 83abcd82" https://controlc.com/83abcd82
<next4th>glad to be helpful :)
<Hasnep[m]>Hi everyone, quick question, does anyone have any experience using a DE installed through Guix on a foreign distro? Does anything break, anything I need to be aware of, or should I just stick to installing a DE through my system's package manager? I'm thinking of Sway particularly, but if people have experience with other DEs that'd be good to know too. Thanks :)
<madand>I'm too contemplating setting up my new maching with Devuan as the kernel+zfs+drivers only. And having all the other user-level tools (Pipewire, Sway, Emacs ...) managed with Guix. Has anyone tried having Wayland, Sway and Pipewire installed via Guix on a foreign distro like that?
<mekeor[m]>y not use guix system? *ducks*
<next4th>madand: if guix's mesa support your video card (means a intel one) well, then i think there should be no problem.
<unmatched-paren>hello, guix :)
<cel7t>hello unmatched-paren
<unmatched-paren>feedback still needed for https://issues.guix.gnu.org/62356 :)
<practical-friend>Exception: #<&compound-exception components: (#<&external-error> #<&irritants irritants: (-11)> #<&exception-with-kind-and-args kind: getaddrinfo-error args: (-11)>)> https://issues.guix.gnu.org/62356
<unmatched-paren>huh?
<unmatched-paren> https://issues.guix.gnu.org/62356 <- no, this one is [PATCH guix-artwork] website: posts: Add Dissecting Guix, Part 3: G-Expressions.
<practical-friend>Exception: #<&compound-exception components: (#<&external-error> #<&irritants irritants: (-11)> #<&exception-with-kind-and-args kind: getaddrinfo-error args: (-11)>)> https://issues.guix.gnu.org/62356
<unmatched-paren>>:(
<unmatched-paren>aaaanyway yeah i'd like some feedback on that post, whatever issue number it uses...
<unmatched-paren>#62356 will this work?
<unmatched-paren>practical-friend: nooo come back!
<dcunit3d>i'm getting a issue similar to #56012, where guix pull fails when building the package-cache
<dcunit3d>it's having issues with a guixrus package python-interrogate
<dcunit3d>i've got the gnu DNS configured statically for now
<dcunit3d>but i can't seem to run guix pull with that package
<dcunit3d> https://0x0.st/HoSL.drv
<dcunit3d>i haven't tried using guix time-machine yet
<jpoiret>dcunit3d: this should be reported to that channel
<janneke>ACTION runs guix home reconfigure
<ds-ac>Hi. I am new to guix and am having trouble getting my smartcard to work (fresh GuixOS installation). I have added the pcscd service to my configuration and have reconfigured my system. When trying to decrypt something, gpg uses the correct key, but fails with "decryption failed: No secret key". I first thought that gpg could not find any pinentry program, so I added "pinentry-program $(which
<ds-ac>pinentry-qt)" to gpg-agent.conf, without success
<ds-ac>Does any of you have an idea of additionnal steps I should take ?
<old>I'm trying to use rofi-wayland
<old>I get this error
<old>Rofi on wayland requires support for the layer shell protocol
<old>then it crashes
<old>rofi-wayland is part of my home-configuration. I 've also added gtx-layer-shell
<old>any idea?
<jpoiret>ds-ac: is the gpg-agent started?
<jpoiret>it needs to be started with the proper DISPLAY (or WAYLAND_DISPLAY) env variable so that the pinentry program can launch properly
<ds-ac>jpoiret: It was indeed the issue. Thank you :)
<ds-ac>I should have thought of that ^^
<jpoiret>happy to have found that :p
<guixfren>hi, does anyone have an idea why I can't access any gnu urls?
<guixfren>guix pull fails
<guixfren>and I can't access gnu.org or any other gnu website in the browser either
<rhododendrox>afik there are some problems with dns
<rhododendrox>afaik*
<Guest19>complete gnu was down since they had DNS issues but it works now again.  Maybe you need to restart since you get cached results or something?
<guixfren>looks like it
<civodul>guixfren: for possible solutions, check out https://toot.aquilenet.fr/@civodul/110083670202946166
<Guest19>normally libGLX_mesa.so.0 is in the package mesa but not on Guix.  Which package does provide it?