IRC channel logs

2023-03-18.log

back to list of logs

<devcarbon>Is there a way to exclude a package from guix shell, without using an all out container?
<lilyp>depends on what you mean by excluding
<lilyp>a pure shell might suffice
<devcarbon>lilyp / right now I'm trying to run flutter (via nix) and it needs clang. ... oh hold on, just did some more digging, and clang is indeed under nix under the path. My next guess is that there is some env flag that is thowing off the compiler.
<devcarbon>CMake Error at /nix/store/l341npqn3j8pwqq1nqgj5cqhnfbzhphd-cmake-3.25.1/share/cmake-3.25/Modules/CMakeTestCXXCompiler.cmake:63 (message):
<devcarbon>  The C++ compiler
<devcarbon>    "/home/pacman/.guix-home/profile/bin/clang++"
<devcarbon>Seems I still get the same error with --pure.
<lechner>Swingball / i run guix on a nano Linode with 1 GB RAM and 2 GB swap, but there is of course no X or any other desktop environment
<oriansj>well one can run guix with i3/sway with 512MB of RAM and swap (Flash swap really cuts the latency down)
<oriansj>The biggest problem is all of the Web browsers packaged in guix are either massive memory hogs or have issues that make them less than ideal for some people
<the_tubular>Is the "version" value required in a package ? Or only the commit
<oriansj>the_tubular: well the version is more for the humans. The commit is about ensuring only the exact code you want to be built is built.
<the_tubular>But it's not require right ?
<oriansj>well some packages use tarballs and the version allows a shared build script as one would only need to replace the version number to build multiple different versions.
<mirai>is it really that big of a problem if it uses more than 1GB?
<mirai>I don't expect a desktop for daily use to have less than 4
<oriansj>mirai: well sub $20 computers don't have more than 1GB of RAM
<oriansj>which I am guessing is probably their reason.
<mirai>sub 20$ computers usually aren't considered desktops (for serious use)
<oriansj>mirai: but sometimes that is all that someone has
<oriansj>and GNU software is about empowering *EVERYONE* with the 4 freedoms; so being able to run on a $20 computer really expands the potential user base.
<mirai>sure, provided its within 'reason'
<mirai>and the request "reasonable"
<mirai>complaining about guix/<anything> bloat whilst using electron apps weakens the argument
<mirai>and the within 'reason': you wouldn't want to limit yourself to Z80-like machines :)
<oriansj>mirai: well Z80-like machines retail in the $200-$800 range these days due to the surge of interest in retro computing. So 32bit processors and 1GB would actually be cheaper
<oriansj>all cheaper retro systems actually just use an arm processor a couple gigs of RAM and emulation software (and an FPGA if doing Amiga Compatibility)
<lilyp>on the topic of embedded web browsing: is the experience better for folks not using guix?
<sarg>hey, should I `guix style` even if the output is uglier?
<lilyp>Not really. The gold standard remains Emacs, but you could raise an issue about the ugly output.
<sarg>any recommendations on how to work with debbugs efficiently? I can spare some time to go through the backlog in guix-patches.
<lilyp>if it's about reading bugs comfortably, I can only recommend visitig issues.guix.gnu.org
<lilyp>if you prefer emacs over glorified web interfaces, emacs-debbugs it is
<sarg>reading and responding (including sending debbugs commands)
<lilyp>for sending commands I just use plain email
<sarg>lilyp: http://ix.io/4r7R, low-hanging fruits. Patches for packages which are either already added or have newer versions in guix.
<sarg>in exchange I'd like this to be reviewed and merged: https://issues.guix.gnu.org/62251 :)
<helpful-friend>"[PATCH] gnu: Add physlock." https://issues.guix.gnu.org/62251
<TristanCottam[m]>Hi guys, I'm having problems with `guix deploy`. When I run the command, the target machine adds the origin's signing key to `/etc/guix/acl` as expected, but then removes it, renaming the generated `/etc/guix/acl` to `/etc/guix/acl.bak`, [as if the original edit was done manually](https://guix.gnu.org/manual/en/html_node/Base-Services.html#index-guix_002dconfiguration)
<helpful-friend>"Base Services (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Base-Services.html#index-guix_002dconfiguration
<TristanCottam[m]>* done manually](https://guix.gnu.org/manual/en/html_node/Base-Services.html#index-guix_002dconfiguration).
<helpful-friend>"Base Services (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Base-Services.html#index-guix_002dconfiguration
<lilyp>sarg: use @itemize or @enumerate for the mechanisms and prefer new-style arguments
<sarg>lilyp: the new style is about using gexps?
<sarg>can we add this check to `guix lint` ?
<lilyp>yup, that is (list #:tests? #f #:phases #~(...))
<sarg>what's the advantage? it's to enable cross-compilation?
<lilyp>it's more future-proof: if you want to make a change that requires the power of G-Expressions, you don't need to wiggle your way around
<sarg>why are @itemize or @enumerate needed? I suppose it's to export descriptions to html or other format, but is it already used anywhere?
<sarg>okay, it's texinfo's syntax. Need to read its manual
<lilyp>we use texinfo markup in our package descriptions
<hwpplayer1>lilyp do you like to share one example for me I mean a code sample
<lilyp>code sample for what
<sarg>lilyp: I've sent v1 patch for physlock
<lilyp>LGTM, only some minor things remain
<lilyp>1. is the license really just gpl2?
<sarg> https://github.com/xyb3rt/physlock/blob/master/LICENSE
<helpful-friend>"physlock/LICENSE at master · xyb3rt/physlock · GitHub" https://github.com/xyb3rt/physlock/blob/master/LICENSE
<sarg>says gpl-2.0
<lilyp>2. the synopsis could be shortened to "Lock virtual terminals" or similar
<lilyp>3. how should i parse the first sentence in the description?
<lilyp> https://github.com/xyb3rt/physlock/blob/master/main.c "or (at your option) any later version"
<helpful-friend>"physlock/main.c at master · xyb3rt/physlock · GitHub" https://github.com/xyb3rt/physlock/blob/master/main.c
<sarg>hmm, don't remember where I copied the descriptions. Usually I take them from either debian or nixos
<sarg>but then, answering 3. - physlock locks all VTs and the graphical session as well. You can't Ctrl-Alt-Fn to other tty and log in there
<sarg>when locked you have just a blank black screen with `Password: ` at the top
<lilyp>yeah sure, but "and uses PAM" for authentication doesn't fit into that sentence
<sarg>ah, I've copied it from the author's README literally
<hwpplayer1>For package descriptions lilyp
<hwpplayer1>You said that : we use texinfo markup in our package descriptions
<lilyp>you can do an rgrep on @itemize for example
<lilyp>we also use @acronym and @code where appropriate
<lilyp>use grep :)
<sarg>lilyp: what license do you want me to set? I'm not an expert here
<hwpplayer1>sarg what is your project ?
<lilyp>hwpplayer1: physlock, as posted above, it's gpl2+
<hwpplayer1>It is fair as far as I can see lilyp
<lilyp>wdym fair?
<lilyp>the issue was that the license in the issue was reported as merely gpl2, not gpl2+
<lilyp>the + is important :)
<hwpplayer1>Hmm
<hwpplayer1>I didnt realize +
<hwpplayer1>It should be GPLv2+
<mirai>o/
<evilsetg[m]>I have a question about licenses: I want to package something that has a COPYING file that contains GPLv2 and a debian/copyright file that specifies LGPLv2.1+ in the source tarball. How should I decide which license to pick?
<mirai>ask for clarification
<mirai>ask upstream*
<mirai>bonus points if you ask them to support SPDX identifiers instead
<mirai>à la REUSE spec
<evilsetg[m]>Ah yes, that is a good idea. I did not know about SPDX or REUSE. They seem very useful.
<mirai>I like REUSE
<mirai>it efficiently discharges questions and ambiguities like these
<lilyp>looking at the source code itself is often also helpful
<lilyp>plus there are packages that have lgpl and gpl parts thrown together (e.g. an lgpl library with a gpl ui)
<evilsetg[m]>I looked into the source files and as it seems everything is LGPLv2.1+ except the test suite which is GPLv2. What would one do in such a case?
<lilyp>it's effectively lgpl2.1+ then
<lilyp>the test suite is typically not installed
<evilsetg[m]>True, that makes sense.
<mirai>hmmm.... is "./pre-inst-env guix repl <FILE.SCM> -i" supposed to skip evaluating ~/.guile ?
<mirai>readline doesn't work
<mekeor[m]>i would not guess that it is intended
<minima>Hi, there's something I'd like to test in my guix home configuration; I know of `guix home container` but what I'd like to test has to do with the window manager, therefore I think I'd rather need to build an image instead of running a container
<unmatched-paren>afternoon guix :)
<minima>Is there any straightforward way to build an image out of a guix home folder?
<mirai> https://www.imgbly.com/ib/HJVtr5ctJj
<helpful-friend>"Imgbly — Image - HJVtr5ctJj" https://www.imgbly.com/ib/HJVtr5ctJj
<mirai>gnuvola ?
<unmatched-paren>ACTION is back with yet another mysterious error in what will be a dissecting guix example... <https://paste.sr.ht/~unmatched-paren/0e34270c7f6a4f3a9379a586768ec9eb91a16b41>
<helpful-friend>"script-directory.scm — paste.sr.ht" https://paste.sr.ht/~unmatched-paren/0e34270c7f6a4f3a9379a586768ec9eb91a16b41
<unmatched-paren>The error is "While reading expression: In procedure length: Wrong type argument in position 1: lambda
<unmatched-paren>"
<jgart[m]>unmatched-paren: Is the goal with that script directory to auto deploy scripts with their guix deps?
<unmatched-paren>jgart[m]: it's just a silly example for the blog
<unmatched-paren>it's not meant to actually have much use
<jgart[m]>cool
<jgart[m]>I started trying to hack together some gexp scripts after reading Arun's blog post
<jgart[m]>Have you read it yet?
<unmatched-paren>link please? i'm not sure
<jgart[m]> https://systemreboot.net/post/deploy-scripts-using-g-expressions
<helpful-friend>"Deploy scripts using G-expressions" https://systemreboot.net/post/deploy-scripts-using-g-expressions
<jgart[m]>I'm trying that approach with some CL scripts
<kraai>Hi. When I run `guix pull`, it displays `error: java-eclipse-aether-Api: unbound variable`. Am I doing something wrong? Full output at http://paste.debian.net/1274504.
<helpful-friend>"debian Pastezone" http://paste.debian.net/1274504
<unmatched-paren>jgart[m]: ah, i haven't read that
<unmatched-paren>kraai: looks like someone committed a typo; could you grep the guix repo for ``java-eclipse-aether-Api''?
<reyman>hi !
<reyman>Is there a way to do more than substitute and overwrite one file of source by a manual copy ?
<reyman>during packaging
<unmatched-paren>reyman: what do you mean by that? :)
<unmatched-paren>what, specifically, do you want to do?
<reyman>i have a package.json on a github repository that miss some information ...
<unmatched-paren>so, you need to modify it?
<unmatched-paren>you could try making a patch
<reyman>npm display a package.json, and the corresponding package.json on github as multiple line in plus
<unmatched-paren>reyman: multiple extra lines that don't appear in the npm version?
<reyman>no, invert my phrase, npm display a package.json with correct information, and the version on github miss multiple line
<reyman>sorry
<unmatched-paren>ah, okay. :)
<sarg>when it's about multiple lines then the easies would be to make a patch
<unmatched-paren>you'd probably want to make a patch file
<unmatched-paren>ACTION shakes fist at sarg :)
<reyman>ok
<reyman>hum this is new for me :)
<unmatched-paren>reyman: the SOURCE record has an optional field PATCHES
<unmatched-paren>usually what you want to do is make a .patch file that makes the changes, then add that file somewhere in the GUIX_PACKAGE_PATH
<unmatched-paren>in the guix repo, patches are stored in gnu/packages/patches
<unmatched-paren>so, once you have a patch in there, add (patches (search-patches "PATCH-NAME.patch")) to the package SOURCE
<reyman>so if i guix build from /my-project/my-node.scm this is possible to set the patch into /my-project ?
<unmatched-paren>are you using ``guix build -f''
<unmatched-paren>?
<reyman>yep with -L .
<unmatched-paren>ah, so not -f?
<unmatched-paren>that's good
<unmatched-paren>with ``-L .'' you should put the patch file into the current directory
<reyman> guix build -f dart-saas.scm -L . -K
<reyman>ok !
<reyman>thanks unmatched-paren i will try !
<unmatched-paren>ahh, i see what you're doing
<unmatched-paren>you shouldn't even need -f; just restructure dart-saas.scm as a module
<unmatched-paren>but it'll work either way
<cel7t>Hi I'd like to commit a new package to Guix, do I need to push any changes to the website too or is adding the package definition in the relevant file in /gnu/packages/ enough for the commit?
<cel7t>^I've tested the build locally and it runs perfectly, this is purely a commit-related question
<jpoiret>mirai: define-record-type is missing a * for screen-locker-configuration
<ngz>cel7t: You need to add the definition to the relevant file, commit it, and send the patch to guix-patches@gnu.org. You'll find all the details in the Submitting Patches section of the Guix manual.
<cel7t>ngz: Thanks!
<jpoiret>mirai: or at least I don't think it's a good idea to not make it a guix record
<mirai>jpoiret: it's not really 'missing', it was always a plain record-type
<mirai>but I agree that it should be made into a record-type*
<Guest74>If I use Guix home to install packages, what would be the cmd equivalent to "guix package -I"?
<lain_>Hello
<lain_>When I run 'guix build -S texlive', I get the error "package 'texlive' has no source"
<lain_>Isn't guix a source-based distro? Why is there no source for texlive?
<Guest74>Do you mean building by source?  That would be --no-substitue.  -S is for derivation and I can't help with that since I am no expert in this field
<evilsetg[m]>I noticed that there are small descriptions for the multiple outputs of a package when I use guix search. How would add such a description to a package? Or are they hardcoded to specific outputs?
<Guest74>you can do also guix edit texlive to see how it is defined
<lain_>'guix build -S' is supposed to give the sources used to build the package
<lain_>it doesn't build anything, it just gives the source code
<Guest74>ah you mean the .drv files
<lain_>typically they're .tar.gz's
<Guest74>you mean the source code of texlive itself?
<lain_>yes
<lain_>specifically what guix uses to build it
<Guest74>type guix edit texlive and you will see what repo it uses which version and how it is build.  Beyond that I am not of help for you since I am new to Guix too
<lain_>it says "source #f"
<lain_>I assume this means no source is used and it isn't built from source?
<ngz>lain_: "texlive" is a meta package. It is an union from texlive-bin and texlive-texmf.
<lain_>ngz okay, so there is no additional source needed to create texlive aside from what is used for texlive-bin and texmf?
<ngz>Right.
<lain_>"guix build -S texlive-bin" works as expected
<lain_>I didn't know about meta packages, thanks for clarifying
<ngz>guix edit texilve will show explicit (source #f) in the package definition.
<lain_>the #f means false, correct?
<Guest74>yes and #t for true
<tissevert>lain_: more generally, you are absolutely write in your assumption that guix is source-based. Hence it would not be possible that a package has no source on account of it's being proprietary, because such a package wouldn't meet the criteria to be added to guix packages
<mroh>"guix show git-crypt" yields "error: pre-commit: unbound variable" in "(resolve-interface (gnu packages python-xyz) #:select _ …)" on master?!
<dansa>I've not understood how to add a package to the system as a whole. I'm trying to add the /make/ package. I see its location is ``location: gnu/packages/base.scm:489:2''. What must I write in my /etc/config.scm so that make is installed for all users?
<dansa>I always get ``/etc/config.scm:60:24: error: make: unbound variable''. It seems my trial-and-error attempts never land on having the make binding.
<mirai>mroh: double check
<mirai>it's working with 99114eb63895712d2d3e62c5a83e3a1540438f15
<helpful-friend>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=99114eb63895712d2d3e62c5a83e3a1540438f15
<dansa>But somehow I made it to install tex, emacs, docker, man pages and nginx. :-)
<mirai>paste the config
<mirai>you can include (gnu packages base) or use (packages (append (specifications->packages '("make" ...)) %base-packages))
<dansa>My config: https://paste.mozilla.org/2Xn8F1op/raw
<dansa>You'll see I did add (gnu packages base) before.
<dansa>I'm gonna try this longer specifications->packages to see what I get.
<dansa>And that worked.
<dansa>Thank you, mirai.
<mirai>the variable is gnu-make
<dansa>Aha!
<mirai>(define-public gnu-make
<mirai> (package
<mirai> (name "make")
<dansa>So I just missed the right name? Okay, so I should have looked into the package definition.
<mirai>in general I prefer the specification->package procedure
<mirai>handles everything automatically
<mirai>no need to import package modules by hand
<dansa>And where would I have found the existence of specification->package? (How did you learn about it?)
<mirai>I think it's in the manual
<dansa>Okay, thanks so much. Now I look where to find the binding for the package. Always good to know how to get to the source of things.
<dansa>Now I [know] where to find [...]
<jpoiret>are you sure you want to include gnu make for all users though?
<dansa>I'm sure. Why would I not?
<dansa>Everyone uses make to compile a C program, say.
<dansa>``Everyone''. :-) You know.
<jpoiret>you can use `guix shell` to have a specific dev environment suited to whatever you're building
<jpoiret>or maybe just as a user-installed package
<dansa>I often use it and often recommend people do use it, too. That'd be a second step. I love /make/.
<jpoiret>😳
<dansa>I always install system-wide programs I think everyone should use. Say --- noweb, tex, the GNU EMACS...
<mirai>if only that thing supported files-with-spaces in a sane way...
<dansa>Lol. I personally don't support files-with-spaces. I mean I use some of them sometimes, but if anything about them breaks I don't even provide myself with support. :-)
<jpoiret>i'll be sure to consult you on my future make issues
<dansa>Lol. You're welcome to, but I'm a really basic user of it.
<dansa>I find amazing how people use make so deeply. All I usually care about is to issue a shell command when a file is updated.
<dansa>Speaking of make, why don't we have a make-type of program for tex and latex documents?
<mirai>wdym
<jpoiret>I had to patch some failing Makefile the other day because we were running it with -j8 and the subdirectory it was building didn't have any declared dependencies on each other. I was questioning what the #include_next semantics were when the problem was that the .h file hadn't even been copied yet!
<jpoiret>there's latexmk, it works well enough for me™
<dansa>Omg, that's what I need.
<dansa>mirai: it's hard to know when to recompile a latex document: it involves multiple passes, so trusting last modified time-stamps is not enough.
<dansa>jpoiret: I never produce large enough software that would make me paralelize make.
<dansa>Lol --- I have latexmk installed. (Likely part of texlive.)
<dansa>I really searched for this various times and had never found it, but it does make sense that it would exist. Alright, now it's time to learn to use it.
<dansa>Wow, it's such a nice program --- so easy to use.
<ngz>dansa: there is also the tectonic project, which seems useful to build LaTeX documents.
<dansa>ngz: it looks like the miktex competitor for UNIX systems
<dansa>looks very good
<dansa>and I think it might make me leave texlive for good?
<dansa>I also enjoy the tectonic name
<dansa>``What's in a name?'' -- Juliet.
<dansa>It seems that latexmk just obseleted all my makefiles. Great news.
<dansa>I mean --- not all of them, just the latex ones for sure.
<jpoiret>tectonic will download texlive things on its own though
<jpoiret>i prefer guix's declarative approach but to each their own
<dansa>I kinda like to see tex and latex packages being downloaded automatically.
<dansa>MikTeX (on Windows) does it and I enjoy it.
<dansa>So, you guys have been amazing with me today. Thanks very much.
<gnucode>hey guix!
<jgart[m]>hey gnucode !!!
<jgart[m]>gnucode: Have you heard of the ghost cow?
<gnucode>jgart[m]: nope! What's a ghost cow ?
<jgart[m]>gnucode: The ghost cow is the most frustrated animal on a farm because it is invisible.
<jgart[m]>gnucode: It has just one job and that is to sneek up on the other cow's and scare them.
<jgart[m]>gnucode: So, it sneeks up on the other cows and goes "booooo!".
<gnucode>jgart[m]: sounds like the punchline of a joke....
<jgart[m]>gnucode: And the other cows don't hear that well and they say yeah "moooo!".
<jgart[m]>gnucode: And then the ghost cow says, "no, I said "boooooo!". It's frustrating being a ghost cow!"
<jgart[m]>That last msg was the punchline...
<jgart[m]>🦗
<gnucode>what emoji did you jjust put in the chat?
<gnucode>a grasshoper ?
<jgart[m]>ya
<jgart[m]>👻🐮
<jgart[m]>a cricket technically
<jgart[m]>emojis might be agnostic to that
<gnucode>🐄
<jgart[m]>anyways, jokes aren't my forte
<jgart[m]>any guix jokes?
<gnucode>that's ok. It is worth doing things poorly until you can do them well.
<gnucode>The GNU Hurd Guix System has great usb support. :)
<gnucode>🤣
<jgart[m]>hardy har har that one made me chuckle
<jgart[m]>hurd is my favorite meme out there
<lilyp>haven't hurd that one before :)
<jgart[m]>hardy har har that one made me chuckle as well
<ardon>Hey #guix, first time submitting a patch series with 50+ packages. This is for a package that has a bunch of go library dependencies, where some of these are split out in many sub-packages. Do I need to send out each package addition as a separate commit, even if it's a sub-package?
<lilyp>what's a "sub-package"?
<ichernyshovvv[m]>Guys, is there a way to dual-boot guix and windows?
<efraim>lechner: I'm still somewhat involved in the ppc64le port, I have access to one of the build machines. I'll take a look at the go@1.19 build failure. it sounds like 'patch-gcc:lib in go-1.17
<ardon>lilyp: I'm not that knowledgeable in go, but basically many packages can be defined inside a single top-level one. For example, see how this procedure https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/golang.scm#n7454 is used to create many sub-packages
<helpful-friend>"golang.scm\packages\gnu - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/golang.scm#n7454
<dansa>Ran a guix system reconfigure and it seems to take many, many minutes on /gnu/store/kphp5d85rrb3q1rdc2lfqc1mdklwh3qp-guile-3.0.9/bin/guile --no-auto-compile /gnu/store/4nw0zb4swga0cb8i35nvng3rg6z5qm8p-shepherd-0.9.3/bin/shepherd --config /gnu/store/cya0sj6dg5ia0n8vnv5n3if02ghby6wz-shepherd.conf. (It's taking an entire CPU, too.) Do I just wait?
<dansa>The last it printed: guix system: bootloader successfully installed on '(#f)'
<lilyp>ardon: these look like properly separate packages to me, so one patch per package it is
<lilyp>the only exception i know to this rule is common lisp, where the transformers produce literally the same package for three platforms
<lilyp>#f seems like a bad device for a bootloader to be on
<lilyp>but other than that no issue with reconfigure taking minutes
<lilyp>though you might want to take a closer look at all your shepherd services
<ardon>lilyp: Gotcha, thank you for clarifying this
<gnucode>ardon: what is the package that you are hoping to package?
<gnucode>dansa that last line probably means that you are done reconfiguring.
<vv0r>hi, new guix user here. i guix installed font-terminus, how can i use it on my system as my emacs cant find it etc
<gnucode>vv0r: guix install fontconfig; fc-cache -rv
<vv0r>thanks, wil try.
<sarg>ichernyshovvv[m] sure, guix just installs bootloader for you. I don't dualboot, but it should be no different from any other distro
<nutcase>Hi all, I am running "guix shell openjdk@17:jdk maven -- mvn" and get a maven error "Unable to load cache item". Can anyone try and confirm that and does anyone have an idea, what could be the reason for this error or what I could check or try?
<ichernyshovvv[m]><sarg> "ichernyshovvv sure, guix just..." <- The problem is that I don't know how to describe windows OS in my guix config. Maybe it's possible to run os-prober during reconfigure process to automatically recognise all the installed distros? I tried to search through the logs of this chat, and googled and nothing found on how to configure grub
<dansa>gnucode: I do believe you, but I can say that there's definitely a problem with the guix program: 1 root 20 0 241.7m 64.7m 142.0 1.6 171:40.00 R /gnu/store/kphp5d85rrb3q1rdc2lfqc[...] You see that ``171:40.00 R''? That's top saying that process has taken 171 minutes of CPU time. Guile is pretty busy due to something I don't know.
<dansa>
<dansa>due to something I don't know what. (Thanks for your input, by the way!)
<dansa>I'm gonna ^C and reboot.
<dansa>Funny: ``sudo reboot'' hangs, sleeping. :-)
<dansa>I'm gonna have to kill process 1.
<sarg>ichernyshovvv[m] do you know how to dualboot in other distros? maybe start from archwiki's dual boot article? Guix isn't that flexible in making custom grub entries, but I did that once to add a livecd entry to the boot menu
<dansa>It doesn't die even with ``kill -9''. I'm so surprised.
<sarg>ichernyshovvv[m] here is the code, but I don't know if it still works: https://github.com/sarg/dotfiles/blob/79d93fde0df470a7e2894a9f66c84d50846dbff4/guix/system.scm#L73-L85
<helpful-friend>"dotfiles/system.scm at 79d93fde0df470a7e2894a9f66c84d50846dbff4 · sarg/dotfiles · GitHub" https://github.com/sarg/dotfiles/blob/79d93fde0df470a7e2894a9f66c84d50846dbff4/guix/system.scm#L73-L85
<dansa>Hard rebooted. All is back in order. (Let's keep an eye on process 1.) See you guys later. Thanks!
<jpoiret>dansa: this is literally pid 1, you can't kill it
<jpoiret>too late 🙃
<gnucode>jpoiret I've had fun in the past raising the elephant. :)
<ardon>gnucode: mautrix-whatsapp
<minima>hi, i'm wondering if there's a way to create an image out of a guix home configuration - so as to launch it and test it with, say, qemu
<minima>i know of `guix home container` but i'm actually looking at building an image rather than running a container
<sarg>minima: yeah, I'm also wondering. It seems that it's currently not supported, but I'm currently exploring how to do that
<minima>hey sarg, thanks, cool, let me know if you come up with something - i'll do the same
<jonsger>ACTION still didn't migrated to `guix home`. Feeling I'm the last not yet on this party ^^
<jpoiret>jonsger: i think we're still a majority :p
<jonsger>guix needs some way of data collection/user survey. Which every hipster software project does nowadays :)
<jpoiret>like the widely successful https://toot.aquilenet.fr/@civodul/110040546376128646 ?
<helpful-friend>"Ludovic Courtès : « As a #Guix user, what's your relation with 'guix … » - Mastodon (Aquilepouet)" https://toot.aquilenet.fr/@civodul/110040546376128646
<Guest74>How can I include submodules if I define a package?  I need it to use bundled deps since I just want it to make it work and later I am going go make it correct
<Guest74>I am talking about Git Submodules
<Guest74>nvm, found it
<Guest74>Well apparently not, the directories are empty.  I did (recursive? #t)
<reyman>hi, this is perhaps a silly question, but i search how to alias a /gnu/store/xxx/bin/my-program to local bin (? .guix-home/profile/bin/my-program ?) accessible after install phase
<reyman>ok i understand i need to guix package install after a guix build ...
<reyman>\o/
<vagrantc>you could skip the build part; it will build it if needed
<vagrantc>although the output will default to being less verbose
<reyman>thx vagrantc :)
<vagrantc>(or download it, etc.)