IRC channel logs

2022-07-19.log

back to list of logs

<nckx>But good memory :) Cursed or not, there's a reason I use Postgres for anything that's not a toy.
*nckx is running .recover now. Anything that uses this much CPU must work.
<singpolyma>nckx: I have a forkbomb for you
<nckx>Those ‘work’ quite well.
<mbakke>apteryx: perhaps you can find out where the build system adds -lnss3 and insert a -L #$nss/lib/nss before it, or just use the bundled nss
<dcunit3d>i'm trying to update a profile and i'm running into "collision encountered" involving a bunch of packages which depend on gdk-pixbuf, i think. that seems to be the common thread. at that point, the build just stops
<dcunit3d>this is going to be i think the fourth upstream thing i've dealt with in 4 days, if i include not being able to build pwsafe on arch. not that it's a big deal, but it just keeps happening lol
<apteryx>mbakke: I was able to manually build it by adding '-L/gnu/store/4jwfs75934swmhdj0hvz06ychj1qda64-nss-3.72/lib/nss' to ./src/core/api/CMakeFiles/WebEngineCore.dir/link.txt
<apteryx>so now I'm checking the best option to provide this LDFLAG to the CMake build system
<dcunit3d>i'm trying to get a bunch of stuff built before i travel in a few days, so i can can connect to my network by VPN. it looks like it's not going to happen
<mbakke>dcunit3d: the 'collision encountered' messages are just warnings, no? probably there is something else going on
<apteryx>I'll try CMAKE_SHARED_LINKER_FLAGS
<mbakke>apteryx: probably the $LDFLAGS variable is supported too, unless it overrides the one set by CMake or something
<dcunit3d>yeh, but it stops immediately after that. i have -v3 for debug logs. it's happening on two laptops. i tried updating my channels, but it was happening before that, so i think that means it's upstream
<dcunit3d>i'm a bit lost at this point. i really don't know anything about gnome/gdk lol
<dcunit3d>i'll keep digging into it i guess
<mbakke>dcunit3d: sounds like the problem is with guix, and not GNOME/GDK :) you're in the right place!
<dcunit3d>here's what i'm trying to install https://pastebin.com/qSuwk5rF
<mbakke>dcunit3d: can you share the manifest?
<dcunit3d> https://pastebin.com/2yV6XNW9
<dcunit3d>i split out my fonts into another manifest bc it's getting too big, but i'm not sure how else to break it up.
*mbakke compiles
<dcunit3d>i've been updating my profiles in bulk and this one was failing silently, so i think there may have been some issues for a while....
<dcunit3d>i just fixed the formatting (see "playerctl""gstreamer") and removed some dups. it compiled very quickly SMH
<mbakke>sbcl takes forever, probably I should have grabbed a substitute :P
<dcunit3d>hmmmm it's still stuck on the other laptop
<oriansj>mbakke: laughs in building rust from source with only 8GB of RAM
<dcunit3d>nvm it failed fast
<mbakke>oriansj: there is some good news on the 'staging' branch, if it's any consolation
<oriansj>mbakke: I'm cool with week long builds, building from the bootstrap seeds just takes patience
<oriansj>makes for much more interesting guix challenge results
<mbakke>indeed, that's mainly why I don't use substitutes either :) I do have a dedicated server that's acting as a poor-mans build farm though, just added 'sbcl' to the scheduled job
<oriansj>I'll probably have to do that too when I finally upgrade my wife's laptop from Debian to Guix
<oriansj>as I doubt she'll be patient enough to do the builds
<NaturalNumber>when i edit my emacs config, i can put my cursor on a function and look up its definition. i wonder if i can enable the same behavior for editing guix configs?
<NaturalNumber>i'm a noob at both emacs and guix, so please forgive me :D
<dcunit3d>you can, sorta, but it's more complicated than editing scheme
<dcunit3d>for scheme, you have to use geiser and you'll want to read the docs
<dcunit3d>running the tests in the mcron project is a good task to ensure your environment is set up
<dcunit3d>have you used the repl with emacs buffers before?
<dcunit3d>here's the geiser docs: https://elpa.nongnu.org/nongnu/doc/geiser.html
<NaturalNumber>yes i believe so. i am able to look up things related to guile, but not guix
<dcunit3d>do you have emacs-guix installed? it helps a lot with navigating guix, but it also starts the guix repl
<NaturalNumber>i am installing it right now ha
<mbakke>dcunit3d: the manifest you pasted 'works for me', although it took a surprisingly long time to compute the profile ... could you be running out of memory or something?
<NaturalNumber>i thought i had it installed
<dcunit3d>well the manual explains everything better than i can lol https://emacs-guix.gitlab.io/website/manual/latest/emacs-guix.html
<dcunit3d>evaluating sexps, switching modules and etc with emacs/guix has been a bit hard for me to get used to. i've been able to get it to work a few times
<dcunit3d>if you're building packages or systems, you can use `guix build` with various options and things like that help break things into steps
<dcunit3d>i just find-grep the guix codebase whenever i'm trying to figure something out lol
<NaturalNumber>do you keep a local version of the docs?
<NaturalNumber>the guix manual is really good but i wish i could access it through emacs easily
<dcunit3d>it's in the codebase, but you can use `info guix` in the shell or through info-mode
<dcunit3d>C-h i
<NaturalNumber>oh nice
<NaturalNumber>thanks so much
<dcunit3d>and if you use the geiser repl with scheme, you'll definitely want to read this: https://elpa.nongnu.org/nongnu/doc/geiser.html#Autodoc-and-friends
<dcunit3d>basically if you accidentally reevaluate code with a repl running a scheme command, it can cause the repl to hang. it's really confusing
<NaturalNumber>oh good to know
<NaturalNumber>this emacs package seems really good
<NaturalNumber>i think the perfect guix emacs setup should include this
<dcunit3d>mbakke: i'm not sure. it just keeps running. it blew up because i'm running out of inodes on this laptop. it's old but i have no WM running. it is running suspiciously slow right now.
<mbakke>dcunit3d: perhaps 'dmesg' has some clues?
<apteryx>question: do we really want to go out of our way to enable patent encumbered codecs in our qtwebengine build?
<apteryx>that'd be "-DQT_FEATURE_webengine_proprietary_codecs=ON", and that's how things currently are (the upstream default is OFF)
<dcunit3d>no, that can be split out to nonguix or something
<dcunit3d>or provided by someone else. obv. what i think doesn't matter, but it's interesting how much i'm learning about all this since i'm forced to think about it
<mbakke>apteryx: does it not just offload to ffmpeg, like the regular chromium?
<mbakke>apteryx: ungoogled-chromium has "proprietary_codecs=true" to the same effect as I think it's silly for the browser to artificially restrict formats supported by the system ffmpeg library
<apteryx>ah, that was the reasoning
<apteryx>I switched back to GCC + LD but it used vast amount of RAM and failed
<apteryx>so now I'm trying GCC + lld-as-ld-wrapper
<apteryx>it seems to help a lot so far
<apteryx>it's keeping the RAM usage on my system to less than 30% even with the 24 cores used
<apteryx>ld would fill it all up at some point
<apteryx>(32 GiB of RAM)
<apteryx>hmm, when it gets near the end it's still using too much with GCC
<NaturalNumber>having a bit of trouble building xmonad on guix
<NaturalNumber>when i do stack build i get "I don't know how to install GHC on your system configuration, please install manually"
<NaturalNumber>after playing with some flags i eventually got to an error that says "ghc-cabal-bindist: line 3: /home/adam/.stack/programs/x86_64-linux/ghc-8.10.4.temp/ghc-8.10.4/utils/ghc-cabal/dist-install/build/tmp/ghc-cabal: No such file or directory"
<NaturalNumber>podiki[m], any help is appreciated :D
<podiki[m]>NaturalNumber: I currently use cabal to build xmonad on my guix machine (not using the xmonad package currently, just haven't gotten around to it)
<podiki[m]>from my dotfiles repo I sent earlier you can see the simple script I've used and the manifest; have not updated it in a while but that's how I built the version I use
<podiki[m]>though I'm a bit fuzzy on all of it since I haven't looked at in a while
<NaturalNumber>ah, understandable
<NaturalNumber>i noticed that ./build-cabal requires an argument for the output file. did you have that set to "xmonad-x86_64-linux"?
<podiki[m]>...I want to say yes, based on what i see
<podiki[m]>haven't built it since october :-P (I used to follow git xmonad more)
<podiki[m]>I did mean to switch to guix's xmonad, but do have some custom code from elsewhere and didn't sit down to see how to do it
<podiki[m]>(there were some work in progress patches to add stack, some time ago)
<NaturalNumber>nice :D
<NaturalNumber>seems like it might be working now
<NaturalNumber>this has been one of those things that i spent wayyy too long trying to figure out
<NaturalNumber>at least my understanding of haskell, guix, etc is better now
<podiki[m]>i stumbled a lot with compiling a custom xmonad at first too, and still probably have it a bit janky since I need extra libs I include (middlecolumn layout)
<podiki[m]>presumably you could make a custom "my-xmonad" package that packages it up for you, not sure what is ideal though
<NaturalNumber>yea it's not super straightforward
<NaturalNumber>guix reminds me of upper level math courses. you generaly have to figure things out on your own and can't easily find solutions on the web
<NaturalNumber>very fun and rewarding though
<podiki[m]>it gets addictive, watch out :)
<podiki[m]>this talk of xmonad makes me want to maybe go back to my lisp roots (i know almost nothing about haskell) to stumpwm...
<podiki[m]>I switched to try out haskell and because of hitting a crash with stumpwm when using (very very rarely) an additional display
<NaturalNumber>i like using a variety of languages to mix things up, although stumpwm would be cool because emacs, guix, and stump all use LISP
<podiki[m]>yup
<podiki[m]>though I think both my xmonad and stump configs are pretty stable, always fun to improve but has all the basics for me
<NaturalNumber>woo hoo i finally got xmonad up and running
<NaturalNumber>the only problem is that i can't get ghc to recognize the xmonad-contrib library
<PotentialUser-53>hi all, so I have a .drv fine with the binaries that I built - how can I make that into a installable package?
<PotentialUser-53>total 1368
<PotentialUser-53>dr-xr-xr-x    5 root root          4096 Jan  1  1970 .
<PotentialUser-53>drwxrwxr-t 1245 root _guixbuild 1380352 Jul 18 13:43 ..
<PotentialUser-53>dr-xr-xr-x    2 root root          4096 Jan  1  1970 bin
<PotentialUser-53>dr-xr-xr-x    3 root root          4096 Jan  1  1970 lib
<PotentialUser-53>dr-xr-xr-x    3 root root          4096 Jan  1  1970 share
<PotentialUser-53>how can I use this ?
<PotentialUser-53>ah, ok, so I see ... build packages or derivations without installing them. So that doesn't make a package?
***scisssssssors is now known as unwox
***unwox is now known as scisssssssors
***scisssssssors is now known as unwox
<PotentialUser-53>installing guix on a vm, pretty cool that it has exwm as an option in the installer, does anyone here use it ?
<nikola`>I've only installed it in a vm
<nikola`>And basically never used it because i forgot how to xD
***unwox is now known as scisssssssors
<Maya[m]1>hey guix! is there a way to start the cow-store service from withing guix? I want to install to a drive from an alive installation of guix
***furrymcg1e is now known as furrymcgee
<unmatched-paren>Hmm, ssh-agent uses env variables to tell processes where the socket is
<unmatched-paren>so i'm not sure how i'd turn that into a home-service...
<PotentialUser-84>hey, when I try to reconfigure my config.scm I get this error message:
<PotentialUser-84>guix system: error: symlink: Permission denied: "/var/guix/profiles/system-3-link.new"
<PotentialUser-84>any idea what could be the cause?
<PotentialUser-84>well, the cause is this permission being denied, but how could I solve this?
<unmatched-paren>PotentialUser-84: I guess you're doing it with sudo, so that's pretty weird.
<PotentialUser-84>oh, I didnt do it with sudo
<PotentialUser-84>so I have to do that all the time when I reconfigure? Im very new to guix
<unmatched-paren>you need to do it with sudo, it's modifying your whole system
<PotentialUser-84>ok I see. thanks for the help
<andrzejku2>hello
<andrzejku2>is it intentional that guix doesn't include golang package?
<unmatched-paren>andrzejku2: what? `guix show go`
<unmatched-paren>we call ours 'go', not 'golang'
<andrzejku2>ahh true
<unmatched-paren>anyone know if there's a way to set 'global' variables for home services that are set when the user logs in?
<unmatched-paren>env variables
<Maya[m]1>unmatched-paren: are you using guix home?
<unmatched-paren>Maya[m]1: I do, yes. I'm trying to write a service.
<unmatched-paren>an ssh-agent service, specifically
<unmatched-paren>So if FOO
<unmatched-paren>oops
<unmatched-paren>So if FOO=bar is set globally by the service, all processes launched under the user get FOO=bar set
<unmatched-paren>but i can't figure out a way to do that
<Maya[m]1>unmatched-paren: you can do home-environments-service-type
<unmatched-paren>ssh-agent prints this when run:
<Maya[m]1>bu iirc shell only preserves variables to child processes
<unmatched-paren>SSH_AUTH_SOCK=/tmp/ssh-XXXXXX8RJdA1/agent.5424; export SSH_AUTH_SOCK;
<unmatched-paren>SSH_AGENT_PID=5425; export SSH_AGENT_PID;
<unmatched-paren>Maya[m]1: i think you might be misunderstanding
<unmatched-paren>i'm not trying to set a global unv var in a service
<unmatched-paren>not in my home config
<Maya[m]1>oh
<unmatched-paren>sorry, i *am* trying to set it in a service
<unmatched-paren>typo
<unmatched-paren>so what i'd need to do is
<Maya[m]1>you could modify the service to execute some shell code before it’s execution
<unmatched-paren>Maya[m]1: problem is, the shell code needs to be evaluated in an environment such that every program can access it
<unmatched-paren>if you evaluated it inside the service only subprocesses could access it
<Maya[m]1>yes
<Maya[m]1>then I don’t think that you can use environment variables for that
<Maya[m]1>or is it a one time thing? or does it need to be reactive
<unmatched-paren>but you need to use environment variables for ssh-agent information, and therein lies the problem :)
<Maya[m]1>you can simply modify your bash_profile if it doesn’t need to be reactive(through a service of course)
<unmatched-paren>ssh reads SSH_AGENT_PID and SSH_AGENT_SOCK to connect to the agent
<unmatched-paren>Maya[m]1: Is that possible and a good idea?
<ardon>unmatched-paren: rde has an ssh-agent service bundled in https://git.sr.ht/~abcdw/rde/tree/master/item/gnu/home-services/gnupg.scm
<unmatched-paren>ardon: Oh, cool!
<nckx>Hullo Guix.
<unmatched-paren>ardon: Um, that looks like gpg-agent, not ssh-agent.
<unmatched-paren>nckx: Hello.
<nckx>Is session-environment-service-type too static for your needs?
<ardon>unmatched-paren: It provides both, ssh-agent being optional per one of the service's fields
<unmatched-paren>ardon: Oh, so gpg-agent can be used as *an* ssh-agent but not as *the* ssh-agent?
<unmatched-paren>I'm trying to get the actual ssh-agent(1) provided with openssh to work.
<ardon>unmatched-paren: Correct. I use it that way so I don't have to keep SSH keys lying around and backed up
<unmatched-paren>I could also try to get himitsu and hissh working, I just packaged that in guixrus
<unmatched-paren>nckx: I don't know much about services; is it possible, then, to use the functionality of one service from other services?
<nckx>Your service could extend it, yes.
<unmatched-paren>I'll have to look into features of shepherd services, I didn't realize you could do that :)
<unmatched-paren>Thanks!
<nckx>I've got to go (typical, says hullo, leaves) but look at service-extension examples in gnu/services.
<nckx>G'luck!
<unmatched-paren>Hmm, no, looks like session-envionment would be too static indeed.
<unmatched-paren>Programs that connect to ssh-agent need to know its PID, so the variable needs to be globally set *after it's launched*.
<unmatched-paren>Usually you'd use `eval $(ssh-agent)` in .profile.
<unmatched-paren>Yeah, I think I'll just use himitsu. ssh-agent is too badly behaved.
<unmatched-paren>Oh, wait, hissh-agent is the same :(
<nckx>This design sounds flawed.
<nckx>Why does it not use a well-known file name or so? A PID in an environment variable is stupid, what if the agent crashes or simply needs to restart.
<nckx>(I mean a socket file; a PID file would merely be slightly less stupid.)
<PotentialUser-84>I did my reconfigure of my config and it shows this in the terminal at the end
<PotentialUser-84> https://paste.debian.net/hidden/5168cbdf/
<PotentialUser-84>this seems to be an error even though it doesnt explicitly say so. can someone tell me what went wrong?
<nckx>Not a list: "/dev/sda" → (targets (list "/dev/sda"))
<nckx>You used to be able to specify only one device, not more, but that is now possible (hence the list) and a mere string is deprecated.
<furrymcgee>just a variable not environment
<furrymcgee>a file is more global than a shell variable
<furrymcgee>for some reason socket name often contain pids
<RudraveerMandal[>Is there any syntax in guix similar to services.xserver.windowManager.qtile.enable?
<RudraveerMandal[>How exactly will I get qtile working on guix?
<nckx><furrymcgee> just a variable not environment — ?
<furrymcgee>?
<nckx>What do you mean by that?
<PotentialUser-84>nckx ok so taking the strings away will do the job?
<nckx>No.
<nckx>Wrap it in a list.
<nckx>See example above.
<drakonis>RudraveerMandal[: have you tried adding qtile to your system environment?
<RudraveerMandal[>Using the (packages (Append (list thingy?
<drakonis>or a bit of the docs?
<drakonis>yes
<RudraveerMandal[>yeah but it requires startx
<RudraveerMandal[>I added xorg package but
<RudraveerMandal[>that says X missing
<drakonis>look at the cookbook
<furrymcgee>not all variables are exported to environ
<RudraveerMandal[>drakonis: K
<drakonis>dont you need a window manager too?
<drakonis>oops
<drakonis>a login manager?
<nckx>furrymcgee: Correct, but I don't see how this connects to ssh-agent.
<nckx>How are shell variables relevant?
<nckx>(By ‘well-known’ I meant predictable, that is, *not* containing PIDs — the unneccessary PID is the stupidity I was referring to, no matter how it gets smuggled in.)
<furrymcgee>ssh-add connects to ssh-agent via variables
<PotentialUser-84>nckx thanks, that problem got fixed, but now I see something else https://paste.debian.net/hidden/e6fb2a57/
<apteryx>mbakke nckx some of the errors seen yesterday (failing to link to nss for example) disappear when using the CMake ninja generator instead of the make one... only ninja is officially supported by Qt; related: https://bugreports.qt.io/browse/QTBUG-96897
<PotentialUser-84>can someone help me? its weird, I had nothing like that before
<nckx>apteryx: Ooh, that is good to know, I wouldn't have thought of that, ever.
<nckx>PotentialUser-84: I don't think Guix can fetch from SSH URLs.
<nckx>If it can, it would need extra configuration. I've never tried.
<nckx>(This is not a hint that it does support it at all.)
<nckx>Use an HTTPS URL if possible.
<nckx>furrymcgee: This was already established, yes.
<apteryx>nckx: right? it's interesting that one can target a specific CMake backend in a non-portable way
<PotentialUser-84>nckx Oh, I think I added one in my channels.scm, so this could be the problem?
<apteryx>"interesting"
<nckx>furrymcgee: But shell variables seem irrelevant here.
<PotentialUser-84>I was able to install packages from there though
<nckx>furrymcgee: If you're unfamiliar with the difference: shell variables are purely a shell construct, they (can) have no bearing on external commands at all.
<nckx>Saying that ssh-add honours a shell variable doesn't make sense.
<nckx>PotentialUser-84: It's not a use case I'm familiar with (I think SSH agents are more trouble than they're worth, which seems to be borne out by the current discussion 😛). Maybe SSH is supported only for a subset of uses.
<nckx>PotentialUser-84: My guess is: could this be because you're running this as root?
<furrymcgee>sure you use password agents only when you have a reason to do so
<PotentialUser-84>nckx could be because when I dont, it doesnt show this. but when I dont do it gives me another problem with symlink acces denied
<PotentialUser-84>If I dont do sudo it tells me: guix system: error: symlink: Permission denied: "/var/guix/profiles/system-4-link.new"
<nckx>No, you're right to use sudo, but your *root* user has no access to *your* agent.
<nckx>By design.
<nckx>Previous discussion implies there's an environment variable to pass through (sudo -E, or --preserve-env=WHATEVER_IT_IS). I have no idea if that's enough or secure.
<PotentialUser-84>ok, so I should use the keys of ssh-agent somewhere?
<PotentialUser-84>hmm
<nckx>I'm not an ssh-agent user, sorry.
<nckx>I use HTTPS even for my private channels.
<nckx>I don't want each machine to have an SSH key to worry about.
<singpolyma>nckx: ...you know ssh supports passwords right?
<nckx>No, really?
<PotentialUser-84>yeah I see. no problem, your help was very useful. I think I'll delete it then from my channels.scm temporarily
<PotentialUser-84>well, I'll see
<apteryx>neat, jami can now be built without that pesky qtwebengine dependency.
<apteryx>will be interesting to see tho transitive dependency closure size reduction
<mbkamble>I haven't dwelt into understanding the concept of provenance, so am gettimg stumped by the following failure: If I run "guix package --export-channels", I get the error : "guix package: error: no provenance information for this profile"
<mbkamble>I get the same error if I provide an explicit profile name:  "guix package --export-channels -p A-PROFILE-PATH" where A_PROFILE_PATH could be one of {"~/.guix-home/profile", "/run/current-system/profile", "~/.guix-profile"}
<mbkamble>Is it because these profiles are created without using manifests? There are a few profiles I created in ~/.guix-extra-profiles using manifests and the export-channels command executes successfully
<podiki[m]>how does/can setuid programs work in guix shell --container? do they need to just be shared with the container?
<two[m]>they don't
<podiki[m]>with no way to bypass? (i understand for security why it would be this way, wondering if there is a way to allow it though)
<jpoiret>sneek, later tell mbkamble: using manifests is orthogonal to provenance
<sneek>Will do.
<two[m]>how to translate "graft"?
<jpoiret>in what language?
<lechner>Hi, does anyone else see this error from zbarimg? I wonder if we should build without dbus, too. https://github.com/mchehab/zbar/issues/104
<antipode>If you want a low-resources desktop environment but not so minimal it hasn't a battery monitor that predicts the remaining time, what would you recommend?
<antipode>Also, irsii seems to use 100% CPU.
<antipode>* irssi
<apteryx>qtwebengine 6 finally built
<antipode>The e-mail configuration (in Evolution) dissappeared when switching from GNOME to awesome to MATE
<antipode>At least, it's asking for e-mail setup again ...
<antipode>Also, 225952 is still an issue (slim + MATE)
<antipode>* SLiM
<antipode>Not really surprising given that it doesn't interat with elogind ...
<antipode>Maybe a comment should be added next to slim-service-type of mate-service-type to note that they are incompatible with each other?
<antipode>Anyway, I'll try out SDDM
<antipode>two[m]: Maybe you can translate is as "graft" in "skin graft"
<antipode>Or as "transplant", as done in the Dutch translation
*antipode reboot
<PotentialUser-29>does anyone know of a good guix program in the default channel for capturing images on screen?
<efraim>Line screenshots?
<antipode>Any recommended graphical e-mail client that is not Evolution?
<drakonis>thunderbird
<drakonis>they finally revived it
<drakonis>i'm not sure if the gnu fork was updated
<antipode>icedove is at 91.11.0
<antipode>Upstream is at 102
<drakonis>oic
<drakonis>well, perhaps it is time to get it bumped up
<drakonis>its a big leap
<antipode>I'll give it a try, though I'm going to neglect the ";; Update this together with icecat!" comment
<drakonis>icecat should also get bumped to 102 too
<drakonis>but then, it follows firefox-esr
<drakonis>the next esr release is supposed to be in a couple months
<unmatched-paren>nckx: Yes, I know, it's stupid
<civodul>jonsger[m] is the icedove expert here :-)
<unmatched-paren>and I see that most services use a PID file
<civodul>we have a mozilla team actually!
<antipode>it appears to be a complicated package to update, is there a set of instructions for updating?
<antipode>I thought that our Firefox variant was out of date but apparently 91.11.0 is ESR
<antipode>Likewise for Thunderbird / Icedove I asuume
<antipode>So is sufficiently up-to-date for me after all.
<vivien>Dear guix, I’ve proposed patches for #56504 and #56505, and I’d like to remind you they exist and they are very simple and do not require a world rebuild :)
<vivien>I don’t really understand why 56505 has lots of noise at the end of the patch, but I guess you can ignore it.
<unmatched-paren>vivien: I'll have a look :)
<kaelyn>On a mildly-related mingw note, I've submitted a pair of patches to update mingw-w64 from 8.0.0 to 10.0.0 as https://issues.guix.gnu.org/56620 :)
<antipode>vivien: FWIW we have a 'target-mingw' procedure
<antipode>* target-mingw?
<vivien>antipode, should I use it for openssl? All other test cases use string-prefix
<antipode>I guess that those (string-prefix? "..." target) predate the introduction of those procedures.
<vivien>Ok
<antipode>I'd go for target-...?
<antipode>(note: unverified that that actually was what happened)
<antipode>FWIW the (string-prefix? "..." target) seem a bit simplisitic to me, they should check bot the architecture and the kernel (in principle the Hurd could be ported to x86_64 and Windows supports aarch64 ...
<vivien>I’ll rewrite every tests using the predicates from (guix utils)
<antipode>So I'd go for something like (string-append (cond (ishurd "hurd") ("islinux" "linux") (#true (error "unrecognised ...")) [likewise for architecture])
<antipode>(TBC, antipode = maximed, I've changed nicks)
<vivien>There’s no predicate for mips64el in (guix utils), I guess I should add one?
<antipode>I suppose.
<antipode>FWIW make-machine-alist in (guix build-system meson) does a (string-prefix? "mips64el" ...)
<unmatched-paren>vivien: Oh, sorry, I thought you meant reviewing, but lily's already given it the LGTM :)
<unmatched-paren>And it's out of my field of knowledge anyway.
<antipode>icedove: Downloading message header 159 of 15838 in [archive of Guix things]
<apteryx>our icedove package lacks an icon, last time I checked in a GNOME desktop
<apteryx>on a*
<antipode>Is Icedove's OpenPGP key manager independent from GnuPG?
<antipode>looks like it is
<davidl>anyone using GuixSD as their primary OS on their Pinephone Pro?
***forthmacs is now known as lispmacs
<jackhill>davidl: I'm not. I do have a pinephone (non-pro) that I'd love to use with Guix System though
***lispmacs is now known as forthmacs
<davidl>jackhill: there's the image here thats for pinebook pro: https://guix.gnu.org/en/download/latest/
<davidl>idk if it would work on the pinephone as well or not
<jackhill>a good place to start at least
<vivien>I’d like to try and cross-compile openssl for the hurd, what is its triplet for x86?
<vivien>I tried i586-gnu but guix build tells me guix build: error: 'i586-gnu' is not a supported target
<vivien>OK --list-targets gives me the answer
***forthmacs is now known as lispmacs
<vivien>antipode, I sent the update to 56505
<vivien>Does it correspond to what you meant?
<vivien>I don’t think mingw works like the other targets, so I have the separate case for that.
<nckx>unmatched-paren: I don't remember what ‘Yes, I know, it's stupid’ was responding to but whatever it is, I'm sure I agree. Most things are.
<unmatched-paren>nckx: It was a response to your response to my remark on how ssh-agent uses environment variables to allow other processes to connect to it :)
<nckx>Rightio.
<unmatched-paren>So, I guess there's no way whatsoever to get that to work?
<PotentialUser-73>im a little confused with my networking. my interface was named eth0 and the config has static up with that interface name. but for some reason it was renamed to eno1. so the static ip fails and so does dockerd. the 3 other interfaces are eth1 through eth3. any ideas why it now is eno1?
<PotentialUser-73>maybe i should just change my config to eno1 to see if that works?
<nckx>The confusing thing is why it was called ‘eth0’. That's not normal. Did you boot without eudev?
<nckx>unmatched-paren: How does it work on other distroes?
<PotentialUser-73>it has been eth0 for as long as i remember on this maachine. udev service is running
<nckx>Odd.
<nckx>Maybe there's a race condition. When you say ‘it was renamed’, is the ‘new’ eno1 name consistent across boots?
<nckx>The renaming is normal and intentional.
<PotentialUser-73>i think it's consistent.
<PotentialUser-73>but i should probably change it to eno1 in my config?
<nckx>I guess, and I'd normally say ‘yes, because that name is reliable’, but clearly in your case it {i,wa}sn't, which is slightly worrying.
<nckx>So yes, you should, but I hope it won't randomly flip back some day.
<PotentialUser-73>thanks. i reconfigured so time to see how it goes
<unmatched-paren>nckx: Other distros don't have home services, so you're just supposed to add `eval "$(ssh-agent)"` in .profile
<nckx>OK, so they don't manage it for you?
<unmatched-paren>`ssh-agent` prints shell code to set the environment variables, and launches the daemon
<unmatched-paren>nckx: no
<unmatched-paren>(they don't manage it)
<nckx>19 Jul 12:34:14<unmatched-paren> i'm not trying to set a global unv var in a service
<nckx>19 Jul 12:34:19<unmatched-paren> not in my home config
<nckx>I must have misunderstood this in turn (!) to mean system service.
<unmatched-paren>nckx: first 'not' was a typo, too :)
<nckx>Confusion upon befuddlement.
<nckx>There's no profile.d equivalent for users, right?
<nckx>(Which N.B. would still be ugly! Just a possible approach.)
<unmatched-paren>nckx: Not sure.
<nckx>At least we're not regressing by asking users to add it themselves, if it would come to that.
<nckx>I admire your tenacity however.
<apteryx>tests are disabled by default in Qt modules now... I can enable them with a CMake flag, but then they get installed so we need a phase to delete them. Should we go out of our way to run the tests still?
<efraim>it'd be better to do so
<efraim>I haven't looked at qt-6, is there something like QT_PARTS that we can override in the 'install phase to remove the tests?
<nckx>apteryx: +1 for yes.
<PotentialUser-20>i was just here with the eno and eth itnerface name issues and static ip conf. i changed it to enoN and rebooted, it failed. changed it back to ethN, rebooted and now it works again.
<nckx>If there's really no way to disable the installation, it's still a small price to pay for a tested package.
<nckx>PotentialUser-20: Ergh.
<PotentialUser-20>not motivated enough to see if it consistently works. dockerd runs again. i have to do some work. maybe i can look at it later
<nckx>(You can set whatever nickname you prefer, PotentialUser-XX is just a default.)
<PotentialUser-20>will do. thanks!
<nckx>PotentialUser-20: I hope you find the time to report a bug. Simply send a mail to bug-guix@gnu.org with some details. The more the better, because this is certainly not normal — I've never heard of it before.
<nckx>PotentialUser-20: Just type ‘/nick mynewname’ or set it in the Web UI when you connect (I guess; it's been a while since I looked at that).
<PotentialUser-20>yeah i will do that. i have to get back to work. it was just so i could get dockerd service to start.
<apteryx>efraim, nckx thanks for confirming
<apteryx>efraim: about QT_PARTS, I'm not sure; I haven't used that so far
<efraim>I just remember its a thing with qt@5
<nckx>PotentialUser-20: Sure! Good, uh, luck, literally for once.
<efraim>hmm, I don't have the 'guix' command inside my guix home container. anyone know if that's intentional?
<nckx>I don't know, but I'd be a bit surprised if guix gave me cool bonus container contents without asking.
<nckx>davidl: Yo. I've got a bit more work but then I'll finish the bcu tonight.
<efraim>I'm definately thinking it might be possible to hack guix home container into a locked down environment on login
<jab>hello guix!
<davidl>nckx: that sounds great!
*davidl I cant wait! :D
<nckx>Maybe there where it's not six trillion degrees and your hands don't turn the hot laptop keyboard into a swamp. Here, I just want the computing day to end.
<nckx>Hi jab.
<civodul>efraim: why would you have it? :-)
<civodul>you can get it if you add the 'guix' package there
<civodul>but that's not a good idea
<efraim>civodul: to be honest I think I was hoping for an overlay of guix home on top of my current home directory, not a "container" at all, despite 'guix home container' having 'container' in the name :)
<civodul>efraim: perhaps we should rename it "guix home container-yes-really" for clarity? :-)
<antipode>nckx: The antioxidant jobset can be enabled again
<antipode>I think I've found how to run tests, to be tested ... (no pun intended)
<nckx>antipode: Ack.
<nckx>civodul: >:(
<mbakke>civodul: I hate to interrupt, but could use your expertise on https://issues.guix.gnu.org/56633 :-)
<mbakke>no hurries, though
<civodul>alright!
<PotentialUser-29>efraim Idk what you mean by line, but yeah I'm looking for a guix program for making screenshots
<mbakke>any suggestions for a timeline for 'core-updates'? I'm thinking we could "freeze" shortly after the biannual glibc and binutils releases early august, and aim for a merge ASAP after that
<mbakke>maybe go for a Guix 2.0, with the full source bootstrap and everything else that has happened since 1.3 :-)
<civodul>hmm
<civodul>i'd like to do 1.4 before we merge core-updates!
<civodul>but yeah, FSB is 2.0-worthy maybe?
<civodul>what's up with the fancy #:disallowed-references in nspr?
<mbakke>FSB, gexp build systems, removed input labels ... what else? :)
*jonsger[m] never understood why `guix archive --import`reads from stdin and not a filepath given...
<nckx>jonsger[m]: I for one would welcome a patch that adds (optional!) file name support.
<jonsger[m]>I would welcome a patch with --import FILE and --import --stdin for the behaviour before...
<nckx>Why?
<nckx>The stdin behaviour is handy, and that's harder to type and to remember.
<nckx>Use ‘-’ if you want to be explicit, but it should still be optional.
<jonsger[m]>I found it a bit more consistent with other commands, its `guix system reconfigure config.scm` and not `guix system reconfigure < config.scm`...
<nckx>Wait, we're bikeshedding in the wrong place, this is IRC, not the patch tracker.
<jonsger[m]>yeah `--import --stdin` and `--import -` can go both...
<mbakke>or just consume stdin when file-name is not given
<nckx>Of course.
*mbakke tries the glibc 2.35 patch on the tracker
<civodul>mbakke: fixed!
<civodul>mbakke: the glibc patch on issues.guix lacks a few things
<mbakke>civodul: woo, thanks!
<civodul>like, we need to adapt glibc-dl-cache.patch rather than remove it :-)
<mbakke>civodul: I think that was fixed in the latest revision, also Greg Hogan had some helpful comments today
<mbakke>any thoughts on handling non-ASCII file names in bootstrap-origin, ref https://lists.gnu.org/archive/html/guix-devel/2022-07/msg00212.html ? I'm not proud of the GCC 11 patch further downthread, but could not think of a better way.
<civodul>ah!
<civodul>you'd need a UTF-8 locale and all
<civodul>but look, if you switch to glibc 2.35, i *think* C.UTF-8 is included by default
<civodul>which means we could (setlocale LC_ALL "C.UTF-8") without having to pull in glibc-utf8-locales and all
<mbakke>wowza, interesting
<mbakke>will try!
<civodul>lemme know how it goes!
<mbakke>but wait! bootstrap-origin won't use glibc 2.35, will it? :)
<mbakke>short of uploading new binaries
<jab>nckx`: what up pal?
<mbakke>another approach could be to delete those files by 'rm -rf' on the offending directory from 'coreutils-boot0' in the snippet, instead of using delete-file{,-recursively}
<jab>I have chose to do other things instead of the opensmtpd server stuff....the last few days. It's been fun. I hope to carve out some more time for the opensmtpd server stuff soonish...
<nckx>jab: Hot, swamped in work, and just got a call that I need to drive to Frankfurt (400km from here) by noon tomorrow for a ‘meeting’ that will net me 0 extra $.
<nckx>And I'm *still* doing better than last week. Can't complain :)
<civodul>mbakke: oh right, bootstrap-origin will run on the bootstrap guile, hmm
<nckx>jab: <opensmtpd> No presh.
<civodul>perhaps you can sidestep the issue by doing (%default-port-encoding "ISO-8859-1")
<civodul>mbakke:
<jab>nckx`: Sprechst du Deutsch?
<jonsger[m]>nckx: Frankfurt isn't famous for $, but maybe for € :)
<jab>nckx`: make sure you eat extra food for me, I would come if I could, but I'm on the other side of the pond.
<nckx>I believe $ and € are currently equivalent.
<nckx>Previously, €1 was about $0, which presented great arbitrage opportunities.
<nckx>jab: Schlecht.
<nckx>(You'd go to Germany *for* the food? Odd. But enough -offtopic from me.)