IRC channel logs

2022-04-26.log

back to list of logs

<WesterWest[m]>apteryx: so I just skim through the patch try it inside an virtual environment and what should I do next? Should I reply to that thread with my successful test or? I’m sorry I’ve never done this before
<lechner>apteryx: yes
<lechner>Hi, is anyone using Guix System with encrypted home folders?
<the_tubular>I do, but /home is in the same partition as my root
<lechner>the_tubular: LUKS or an overlay encrption?
<lechner>Hi, with user's shell paths pointing to hashed paths in the store, can one keep per-user information in LDAP? Will the shell preference be ignored?
<GNUtoo>Hi, with guix system, when I add a python library (like python-sh) in my system.scm, is it supposed to be available in 'python3' (with import sh) ?
<singpolyma>GNUtoo: only if you also add python package to the same place
<GNUtoo>ok, thanks. I probably have some issue then
<GNUtoo>Maybe I need to reboot or something like that
<lechner>Hi, the profile links in /var/guix/profiles/per-user encode the relationship between uid and username. Should it be /var/guix/profiles/per-uid instead?
<Ox151>what is the package for the dig command?
<Ox151>the bind package description says the `utils` output has it but that is not helpful i am finding
<jackhill>Ox151: the description is correct. It sounds like you're asking how to use different package outputs at the command line, correct? Many of the guix commands accespt package:output (out is the default output which is used if one is not specified). So in this case if you wanted a guix shell with bind, you'd do someting like `guix shell bind:utils`
<jackhill>Does that help?
<Ox151>jackhill: yes that did, thank you.
<jackhill>great!
***zacts is now known as z4kz
<apteryx>WesterWest[m]: yes, it'd be useful to skim through patch, pick one you are interested in, check its code, ensure it passes 'guix lint', build it, run it (you can often run it directly from the store). Then you can reply that it LGTM on the thread
<apteryx>even mark it as reviewed using a Debbugs user tag
<abrenon>hello guix
<user_oreloznog>o/
<abrenon>user_oreloznog: \o
<jpoiret>hello guix
<littlebobeep>jpoiret: moinsie!
<user_oreloznog>o/
<mothacehe>hello jpoiret!
<jpoiret>phodina[m]: did you manage to resolve your rust-nix issue?
<bovid-19>hi guix!
<PurpleSym>mothacehe: Following up wrt wip-python-pep517: Would it make sense to kill and restart the job? It’s still stuck.
<mothacehe>yes let me kill it
<mothacehe>and done
<PurpleSym>Thanks!
<abrenon>is there a way to "try" a service without having to reconfigure one's system, just like guix shell but for services ?
<WesterWest[m]>abrenon: cant you just start it with herd?
<mothacehe>abrenon: you can use "guix system vm my-config.scm" to try out a specific system configuration
<abrenon>hmmm even if it's not installed ?
<enno>Hi. I do not get my channel definition right. Can someone go with me through my existing code to see where I fail. I'd like to contribute and spread the word, but I feel stupid right now.
<abrenon>ok, in a VM, granted
<mothacehe>i don't know any easier way
<abrenon>that easy enough, I just wanted to be sure I was not missing yet another spectacularly useful feature of guix
<mothacehe>enno: sure can you share your channel URL here if it only contains free software
<bost>I have a syntax-object and I want to write it to a different file, formatted as described by the line and column information. Is it possible?
<bost>e.g. '(syntax-source (call-with-input-string " (+ 1 2)" read-syntax))'
<enno>You can find my channel here: https://gitlab.kokyou.de/enno/oaichannel
<enno>mothacehe: At the moment it contains a single python package which is not yet part of guix. The full module will contain around 10 to 20 packages (all python)
<rekado>apteryx: are we currently using any of the SAN shares on ci.guix.gnu.org?
<FlaminWalrus>enno: for one, the (package) may need to be wrapped in (define-public)
<FlaminWalrus>enno: what's breaking?
<mothacehe>enno: you also need to use license:bsd-3 instead of just bsd-3
<mothacehe>because of: #:use-module ((guix licenses) #:prefix license:)
***meena1 is now known as meena
<WesterWest[m]>what is your setup for writing guix guile? I have geiser, cape, paredit but geiser doesn’t seem to suggest anything from imported modules and I need to run-geiser every time. I’d also like some kind of on-the-fly error reporting if that’s available
<enno>mothacehe: Sorry for the late reply. I had a short meeting in between. I fixed the license part, but still get this fail log:
<enno>(repl-version 0 1 1)
<enno>(exception misc-error (value #f) (value "no code for module ~S") (value ((oai))) (value #f))
<enno>FlaminWalrus: I added the surrounding define-public but get still same error log
<FlaminWalrus>enno: all I can think of is the nested directory structure; that syntax has given me trouble before. Try moving oai.scm to the parent directory. If you want the directory structure, I seem to recall one needs an additional .guix-channel inside the directories, but I should go make sure
<FlaminWalrus>enno: ignore my last sentence. The main channel doesn't do that.
<enno>FlaminWalrus: I have no idea how to debug this. I am relatively new to guile, have only basic understanding of lisp / scheme in general, but eager to learn it.
<sneek>wb yewscion
<FlaminWalrus>enno: The official repository does define a module in the parent directory though, i.e. you may need a (define-module (oai)...) in file oai.scm the base directory.
<FlaminWalrus>enno: I'm also pretty new. The error messages are about as bad as when you'd confuse the Rust borrow checker back in the day. I've found the best way to learn is to look at others' code, and ask on IRC ofc :)
<enno>FlaminWalrus: I will have a look at some other public channels. Hope they are not too complicated
<yewscion>sneek: botsnack.
<sneek>:)
<mothacehe> enno: your channel builds with this patch: https://gitlab.com/mothacehe/test-channel/-/commit/6d7c33da29af1f4691d572c970ea34e50bb84f9b
<enno>mothacehe: Great! Thank you. BTW: Do you have interest to port GUIX to the Pinephone Pro?
<enno> https://www.pine64.org/pinephonepro/
<mothacehe>enno: would be great, but i have very little bandwidth for guix related developments sadly :(
<WesterWest[m]>is there a simple way to define pem certificate for wifi networks?
<abrenon>WesterWest[m]: what do you mean by "simple" ? like openssl ?
<WesterWest[m]>abrenon: i want to install eduroam certificate so I can connect to that wifi network, but you need to setup your institutions certificate to make it secure and gnome settings just crashes when I try to do it manually
<enno>mothacehe: If you know someone who is capable, I would donate one for development
<mothacehe>enno: i'll keep that in mind, thanks for the generous offer :)
<bjc>is there a version of gnome for phones?
<bjc>i only know of kde, which has its issues on guix
<apteryx>rekado: we aren't
<apteryx>the root file system of berlin is not on SAN, right?
<apteryx>rekado: oh, wait, checking now. I guess /gnu is still on SAN
<enno>mothacehe: I really appreciate the efforts of the GUIX team. Hope to be versatile enough one day to contribute by myself.
<abrenon>WesterWest[m]: oh that's funny I had to struggle a bit with that too but I found the ugly python script they provide to be the easiest way to do that in the end
<abrenon>the ones retrievable on https://cat.eduroam.org/
<abrenon>I had to tweak it a bit to deactivate complicated GUI script I didn't need and which wouldn't work in my environment
<abrenon>in the end I just opened a guix shell with python and the thing really needed (don't remember which, sorry, it was a while ago), and ran what was left of the script
<WesterWest[m]>bjc: well gnome is usable on phones but it’s far from ideal, as for other interfaces there’s phosh
<WesterWest[m]>abrenon: i really don’t want to do that :D but ig i have bo other reasonably not difficult options
<abrenon>I was really reluctant at first too
<abrenon>you mentioned "gnome settings", is there a dialog there to edit wifi preference in addition to NetworkManager's own GUI ?
<rekado>apteryx: it is?
<rekado>it’s on the external storage
<rekado>not the SAN
<peterpolidoro>what is the proper procedure for submitting two packages to guix when one depends on the other? submit one, wait until it is accepted, then submit the other with the dependency? or use a patch series? or just submit them independently and let the reviewers figure out that one needs to be accepted before the other?
<WesterWest[m]>abrenon: there is! but it crashes upon saving, yet the connections made from the top menu work, but require root privileges
<abrenon>then I'll be of no help, I'm sorry, I don't use gnome and don't know anything about the current stability of any of its components, I only use NetworkManager, and didn't use it directly in that case
<abrenon>peterpolidoro: a patch series sounds appropriate in that situation
<peterpolidoro>so in the patch series there will be a main patch and a subsequent patch, the first patch should be the dependency package and the second patch should be just the dependent package? or does the second patch include both packages?
<rekado>peterpolidoro: one patch per package
<rekado>you can send a cover letter to guix-patches@gnu.org, wait for the number in the confirmation mail, and then send both patches to the address 1234567@debbugs.gnu.org.
<peterpolidoro>ok thanks! what should the patch email subject be when there are going to be multiple packages added?
<rekado>just “Add [name of final package] and dependencies”
<peterpolidoro>sounds great, thank you!
<enno>Hi. How do I pretty format guile code in an emacs buffer?
<rekado>you can adjust indentation of the current S-expression wit C-M-q
<rekado>*with
<rekado>that’s bound to indent-sexp by defautl
<rekado>*default
<enno>rekado: Hmm. Somehow that does not look consistent
<apteryx>rekado: OK; then I think we are not using the SAN at all currently
<wonko-the-sane>enno: #emacs exists ;)
<enno>wonko-the-sane: You are right ;)
<rekado>enno: is Guix-devel mode enabled?
<enno>rekado: I use doom emacs. Still not experienced enough to do my own emacs config
<rekado>that’s fine, but is that minor mode enabled?
<rekado>C-h m shows you the enabled modes
<rekado>i guess you could also use “guix style” on the file to fix the indentation. Just seems a bit heavier.
<enno>I will try guix style if building package cache is finished. This takes a lot of cpu and memory. Wow.
<apteryx>is there something in Guix that'd help me manipulate the package source in sexp form (rather than as a string?)
<apteryx>I want to rewrite the (properties ...) field, which may spawn multiple lines.
<sneek>zimoun: Greetings!!
<zimoun>hi
<konstantinos>Hello. I try to send a patch to guix-patches@gnu.org with git send-mail. The output of the command says it was sent but I can't see it in the archives. I have subscribed to the list. Does anyone have an idea?
<konstantinos>sending it to an other address of mine works ok.
<apteryx>it'll take some time to show up
<apteryx>and if you are recently subscribed it'll go through moderation
<konstantinos>I just took a confirmation that the email was sent. Thanks. There may be up to 3 mails sent :). The last one is the correct.
<konstantinos>The patches are slightly different
<apteryx>OK; you can close the erroneous ones by sending to NNNNN-done@debbugs.gnu.org (adding '-done' to the GNU Debbugs email prefix corresponding to the issue)
<konstantinos>Thanks. I will do it when I see them in the list. I got response for only one of them.
<apteryx>good, thank you
<guixsd-n00b>Hi!
<guixsd-n00b>I'm trying to get network access on a guix shell --container, for running some code
<guixsd-n00b>debugging with something more simple:
<guixsd-n00b>guix shell -C --network iproute2 iputils -- ping 8.8.8.8
<guixsd-n00b>ping: socket: Operation not permitted
<bjc>don't use ping, it often requires extra permissions
<bjc>telnet or netcat or wget will be a better test
<guixsd-n00b>yes, but that's TCP
<guixsd-n00b>anyway I'm trying to debug something different. What I was really trying to do, is to install a prolog package in a container
<guixsd-n00b>I'm trying with:
<guixsd-n00b>guix shell \
<guixsd-n00b>     --container \
<guixsd-n00b>     --link-profile --network --preserve='^DISPLAY$' \
<guixsd-n00b>     -f guix.scm graphviz@2.38 \
<guixsd-n00b>     coreutils iputils iproute2 grep bash make git nss-certs readline less \
<guixsd-n00b>     --expose=$(which env)=/usr/bin/env \
<guixsd-n00b>     --expose=/etc/ssl/certs
<guixsd-n00b>and inside the container
<guixsd-n00b>swipl -g "pack_install('prolog_library_collection')" -t halt
<guixsd-n00b>% Contacting server at https://www.swi-prolog.org/pack/query ...
<guixsd-n00b>ERROR: -g pack_install('prolog_library_collection'): SSL(1416F086) tls_process_server_certificate: certificate verify failed
<guixsd-n00b>(you can ignore guix.scm, and graphviz@2.38 I guess
<guixsd-n00b>(you can ignore guix.scm, and graphviz@2.38 I guess)
<bjc>if you're getting that error then your network is fine
<bjc>that's a bad tls cert on the remote's end. you can try to verify it with: openssl s_client -connect host:port
<guixsd-n00b>it seems..
<guixsd-n00b>this seems to work also
<guixsd-n00b>guix shell -C --network iproute2 iputils netcat -- netcat 8.8.8.8 53
<guixsd-n00b>the thing is, that outside the container it works, but I'll try openssl
<bjc>and, fwiw, the request you're issuing that's failing is almost certainly over tcp, so the tests i gave you are useful
<bjc>you may want to read up on what tcp, udp, and icmp are
<guixsd-n00b>lmao, I know, thanks
<guixsd-n00b>I was just reviewing all the net stack, pinging first is second nature
<bjc>right, but it often doesn't work in containers, because it needs extra permissions in many environments
<guixsd-n00b>and how I can give those perimssions?
<bjc>i don't know how to do that with guix
<guixsd-n00b>ok
<bjc>linux has a generic capabilities framework that couples with the guix container system, but i don't know how to configure that with guix
<guixsd-n00b>yes, I tried 'sysctl ...' but need permissions, installed sudo in the container, but the same problema, chicken and egg problem
<bjc>root permissions in the container won't help. the capabilities were removed from the container itself
<bjc>you have to start the container with the right capabilities
<guixsd-n00b>that makes sense
<jpoiret>don't you need to set SSL_CERT_DIR?
<jpoiret>arf, they left
<dlowe>for how long is it polite to wait to ping a small package-adding patch?
<dlowe>median + stddev please :D
<lechner>a year?
<podiki[m]>politeness knows no bounds?
<podiki[m]>what package? maybe you can try pinging someone that has added similar ones in the past
<podiki[m]>(unfortunately it is a constant battle with the amount of submissions and limited people power to review everything)
<lechner>maybe dlowe can rewiew someone else's patch, and then get the one in question reviewed in turn?
<dlowe>sure, hook me up with merge access :p
<dlowe>(do not hook me up with merge access.)
<enno>Well, I could pack some of the packages which are needed for python-fastapi, but python-orjson (from guix import pypi orjson) can not be built.
<enno>Any ideas, how to solve this?
<enno>error: in phase 'build': uncaught exception:
<enno>misc-error #f "no setup.py found" () #f
<dlowe>I have the package in my own personal channel so I'm not fussed about it, but the documentation does strongly encourage contributing upstream
<podiki[m]>unfortunately it can just take some time for someone to get around to it
<podiki[m]>but asking here (when it seems active) can get some review
<podiki[m]>link to the patch? (I'm not a committer)
<podiki[m]>enno: is that because it is a package with the newer python style of packaging? I forget the status for guix, there might be a branch that is working on that for the python-build-system
<dlowe> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=54920
<podiki[m]>a few quick things: stylistically I think gexps will be preferred (though not mandatory?), there's an extra line, is the license correct? (looks a bit like expat but I'm not sure), is propagating openssl necessary/what is the purpose of the search path?
<phodina[m]>Hi,
<phodina[m]>is it possible to specify the other of the outputs using gexp?
<phodina[m]>I need to get `glib:bin` output. I've tried using this expression `#$(this-package-input "glib")` but this does not get me the `gsettings` binary for `wrap-program`.
<phodina[m]>I've tried `#$(this-package-input `(,glib "bin"))` but this just returns `#f`.
<podiki[m]>...I've asked the same thing and did get an answer.... let me see
<podiki[m]>do you not want to have `(,glib "bin") in your inputs?
<dlowe>podiki[m]: thanks for the feedback. I was copying some off other tcl projects. I'll see about using gexps.
<podiki[m]>then I think this-package-input "glib" should get the bin output?
<podiki[m]>if you are searching for a specific file, probably better to use search-input-file
<podiki[m]>dlowe: gexps will be tricky the first times (and even later!) so I wouldn't worry about that just yet
<podiki[m]>more the propagated input and search path; propagated tends to be avoided if possible, since it adds to the profile when installing a package; search-paths are used by other packages in conjunction to find files like plugins
<podiki[m]> https://issues.guix.gnu.org/53274 here is one I did recently; added a search path to rofi so it knows where to look for plugins, but only gets used if you have a package installed that puts something there in their own output
<dlowe>podiki[m]: it was my understanding that propagated input was necessary when the package was necessary to both building and running the package
<podiki[m]>dlowe: not quite, any input can be used at run time if the package keeps a reference to it
<podiki[m]>you can try without the propagated and see if it works
<podiki[m]>sometimes it is necessary though, that a package needs something to be installed in the same profile to work, then you propagate
<podiki[m]>as an example, had to do that for xdg-desktop-portal-gtk as it relied on dbus files (I think) from xdg-desktop-portal and wouldn't work without it also installed
<dlowe>I see. I'll try it without.
<podiki[m]>it is confusing at first, and I still guess sometimes, but propagation should hopefully be only rarely needed
<podiki[m]>makes things a bit messier so we try to avoid it without good reason
<enno`>podiki[m]: I am not sure if the python-orjson package uses some newer packaging style. In my personal opinion python packaging is broken beyond repair. But unfortunately I have to use it at work. Thank God, its not npm
<phodina[m]><podiki[m]> "do you not want to have `(,glib..." <- I do have it in the inputs `(inputs (list `(,glib "bin") ...))` but the `glib` does not even contain `bin` dir. The `gsettings` are in `bin/gsettings` in `glib:bin`
<phodina[m]>FIY: I've solved the problem by not wrapping the program but putting ``(,glib "bin")` into `propagated-inputs`
***Guest28 is now known as davidl
<lispmacs[work]>hi, I believe there is a missing ./configure flag in one of the packages using autotools, which is causing a problem. Before filing the bug report, I was wondering what is the easiest way to test a rebuild with just adding that one flag
<lispmacs[work]>some snazzy one-liner command I can run...?
<vagrantc>depends on the nature of what's missing
<vagrantc>though that does give me an idea ... guix edit usually returns a read-only package description if you are not building from a local copy ... but what if you have 'guix edit --modify PACKAGE -- build PACKAGE' or something similar that copies the files out of whereever and then builds the tree and executes the action ...
<vagrantc>handles the steps of making the files writeable, editing with the changes you want to make, ./bootstrap && ./configure --localstatedir=/var && make ... followed by the passed action
<vagrantc>we kind of talked about something that touches on that at the meetup last night
<vagrantc>jgart: ^^
<vagrantc>i've always found "guix edit PACKAGE" frequently giving you a non-editable copy kind of strange behavior, name-wise.
<vagrantc>(i get why it's that way, but still)
<vagrantc>lispmacs[work]: there are a few different ways to approach it, but all of them have their downsides. i prefer using a git checkout of guix and then doing the steps documented in the manual for building from git
<vagrantc>mostly because that's the easiest to submit the changes back to guix
<vagrantc>you just end up with a submitable patch
<vagrantc>lispmacs[work]: https://guix.gnu.org/en/manual/devel/en/guix.html#Building-from-Git
<morganw>If you have a separate checkout for development is it safe to build and run environments on top of an existing Guix system that was setup normally?
<podiki[m]>yup
<podiki[m]>I have a checkout I use for patches, updates, testing; sometimes even installing from there to use on the main system
<vagrantc>at least for hacking on packages, if you're messing with guix internals it might get more interesting :)
<podiki[m]>phodina: weird, maybe it is something about glib? or the newer input style or something? I figured if you had it as an input you should be able to do the search-input-files (or whatever the proper name is) to find anything in the inputs
<EMax`0Mancer[m]>has anyone had weird font issues with mu4e (in emacs) on Guix? I don't have any problems on non-Guix systems with the same config; nor problems in Emacs on Guix outside of mu4e.
<morganw>At a guess, it might depend on the shr setting for variable-pitched fonts, as if the message is HTML and mu4e uses the Gnus messages viewer (which I think it does now) it will potentially switch font.
<morganw>And maybe you don't have the same fonts.
<vrnk>hello! I am trying to install guix on a foreign distro and I'm having an issue with the daemon systemd service failing. Running the `ExecStart` in a terminal as root works just fine, so I am confused as to why it's failing with systemd.
<morganw>And maybe nothing else in your emacs setup uses variable-pitched fonts.
<EMax`0Mancer[m]>have the same fonts. and it works outside of mu4e buffers (and even works in the mu4e gnus-view buffer). it's only in the mu-search buffer and the mu-compose buffer. and only on guix.
<EMax`0Mancer[m]>it's essentially not wanting to display non-roman characters (including emoji), but again, only in those particular buffers (and only on when on Guix).
<vrnk>According to a few sources I found online, the quotation of the service definition should be fine. (see https://gist.github.com/vrinek/22a251ecd3cbee606dec4384dc896484)
<morganw>EMax`0Mancer[m]: Maybe you are missing additional fonts: "you may want to install the unifont and/or symbola fonts on your system" https://www.djcbsoftware.nl/code/mu/mu4e/General.html
<EMax`0Mancer[m]>no, it's only an issue in (certain) mu4e buffers. other buffers show non-roman and emoji fonts with no issue.
<morganw>It is relative to an mu4e specific option: `mu4e-use-fancy-chars`
<morganw>which would seem to indicate those buffers might be looking to use a different font in order to display those fancy characters
<morganw>I guess checking the face of the text will tell you for sure.
<EMax`0Mancer[m]>this isn't related to the mu4e fancy chars setting (which I have on), but just display of chars in e.g. subject lines
<EMax`0Mancer[m]>one in buffer, for the same character, I'll get "file code: not encodable by coding system utf-8-unix", and in the other buffer "file code: #xE0 #xA4 #xB2 (encoded by coding system no-conversion)"
<stfnbms>LibreOffice in Guix keeps complaining about missing hyphenation data: ‘Please install the hyphenation package for locale “en”.’
<stfnbms>But, as far as I can tell, there are no such hyphenation packages in Guix.
<stfnbms>What do I do?
<rekado>apteryx: etc/committer.scm has something
<rekado>it reads the source as an s-expression and then compares the old with the new version to generate a commit message
<sneek>yewscion: wb!!
<yewscion>sneek: botsnack.
<sneek>:)
<apteryx>rekado: interesting, thanks
<apteryx>I was expecting you'd have some trick to share about this kind of hackery, eh :-)
<apteryx>rekado: the surrounding-sexp reads from a port... would it not return a string rather than a sexp?
<apteryx>it seems edit-expression is close to what I want, but it exposes the expression as a raw string. I want to be able to use match and the likes to destructure it so I need a sexp, not a string
<apteryx>oh, surrounding-sexp uses both read-line (returns a string) and read (returns a sexp)
<apteryx>I guess read-line is used for its side effect only (move the seek position it seems)
<apteryx>oh, and `read' reads one sexp at a time. handy
<apteryx>stfnbms: you could look into packaging it, but it may not be trivial
<apteryx>we're also lacking non-english dictionaries, if I recall correctly.
<apteryx>or language packs
<apteryx>rekado: so my latest idea is to use `read' to use from a string port setup from edit-expression's exposed string expression
<phodina[m]><podiki[m]> "phodina: weird, maybe it is..." <- Not sure, but at least `bottles` start ... Now I focus more on `No vkd3d found.` and `No dxvk found.` messages. For some reason the `dxvk` fails to build due to `wine-staging` failing.
<phodina[m]>There is already opened ticket https://issues.guix.gnu.org/54257 but no activity around it.
<stfnbms>apteryx: One more reason to switch back to TeX! (But sometimes I have to use LibreOffice.)
<apteryx>TeX is a beast in its own, but the packaging of it in Guix has been improving as of late
<apteryx>`tlmgr info --list something` is your friend
<stfnbms>I do want to teach myself packaging, but things like onboard, bub and scantailor (classic) are top priorities for me. (Happy if somebody else beats me to packaging them!) I currently use them through Nix on Guix.
<apteryx>:-)
<apteryx>what's the most direct way to access the `source-properties` of a package in Guix?
<stfnbms>Thanks for the tip about tlmgr! I was using the monolithic 3GB texlive package, but just switched to the recommended modular approach.
<apteryx>answering my question, looks like that'd be (location->source-properties (package-location some-package))
<apteryx>where location->source-properties is from (guix ui)
<apteryx>or rather package-definition-location