IRC channel logs

2022-04-14.log

back to list of logs

<jts>blake2b: this is the best documentation on the actual usage of `guix home`: https://guix.gnu.org/blog/2022/keeping-ones-home-tidy/
<jts>if you need to add more than a couple strings to your dotfiles, you can specify paths to files to be concatenated onto the end of your shell dotfiles. I'm not sure how to do that for eg .profile, though
<blake2b>jts: thanks! I've been so busy I didn't even realize there was a recent blog post
<jts>hope it helps!
<jgart[m]>cool, I haven't read that yet
<jgart[m]>blake2b: re complex emacs config: https://git.sr.ht/~abcdw/rde/tree/master/item/rde/features/emacs.scm#L901
<jgart[m]>elisp and guile happily together forever
<jgart[m]>wrapping there parens around each other
<jgart[m]>s/thei4
<jgart[m]>s/their
<boogiewoogie[m]><efraim> "boogiewoogie: Julia's in a..." <- that's great to hear! is there like a rule of thumb you can suggest as to which to install with which? just do the ones already packaged with guix and the rest with Pkg.jl? also, if I added the bioinformatics channel to my guix, I would have plots available? do I get that right?
<jgart[m]>it's not too bad actually now that I've read it a few times although I might prefer to just have one lang in my config file. I'll have to dogfood it for a while to see how it feels
<jgart[m]>boogiewoogie: yes that's correct
<boogiewoogie[m]>nice!
<jgart[m]>if you add guix-bioinformatics you'll have all their packages
<jgart[m]>but you won't have their substitutes, yet...
<jgart[m]>maybe someone will provide substitutes for guix-bioinformatics in the future
<boogiewoogie[m]>ah, their prebuilt binaries?
<jgart[m]>so you'll have to build/compile all the packages on your own machine.
<boogiewoogie[m]>is it because they don't offer them, or because additional steps would be required on my side?
<jgart[m]>main GNU Guix channel does not provide substitutes for guix-bioinformatics
<jgart[m]>it's because they don't offer substitutes
<boogiewoogie[m]>I see
<jgart[m]>and if they did maybe they won't offer them to the public but internally
<jgart[m]>it depends what's being offered
<jgart[m]>but you could run your own substitute server and offer substitute servers for guix-bioinformatics if you like
<jgart[m]>s/substitute servers/substitutes
<boogiewoogie[m]>I see
<boogiewoogie[m]>okay
<jgart[m]>We offer substitutes for Guix 'R Us at https://bags.whereis.みんな/
<jgart[m]>for example
<jgart[m]>we run the substitute server on our own server
<jgart[m]> https://whereis.みんな/
<jgart[m]>currently there are 820 packages in Guix 'R Us as of now
<boogiewoogie[m]>what would be the steps required for the julia packages on guix-bioinformatics to land in the main channel? just out of curiosity, I'm trying to understand this specific fragmentation
<jgart[m]>That page updates the packages in the channel as we push new commits
<jgart[m]>boogiewoogie: someone would have to send patches
<boogiewoogie[m]>oh, that's very interesting
<jgart[m]>review the patches and then merge them
<jgart[m]>into master
<jgart[m]>or core-updates
<jgart[m]>or some other branch in GNU Guix
<jgart[m]>but you can have them today. No need to wait for them to get merged in master
<blake2b>jgart: whoa! yes, this is what I was hoping to find originally when diving in, thanks :)
<boogiewoogie[m]>gotcha. thanks a bunch for all the info =)
<jgart[m]>ain't no body got time for dat
<jgart[m]>just start a channel
<jgart[m]>or join one ;)
<blake2b>I'm pretty confused, i had thought that rde is a "just works" distribution of guix, "unbuntu guix style"
<jgart[m]> https://git.sr.ht/~whereiseveryone/guixrus#contributing
<jgart[m]>rde is a guix home config iirc
<jgart[m]> https://git.sr.ht/~abcdw/rde
<jgart[m]> https://inv.riverside.rocks/channel/UCuj_loxODrOPxSsXDfJmpng
<jonsger>sneek: mothacehe
<blake2b>nice, its been a while since I checked it out
<jgart[m]>the best docs are probably those videos
<jonsger>sneek: last seen mothacehe
<jgart[m]>and discussing on https://lists.sr.ht/~abcdw
<jgart[m]>or https://todo.sr.ht/~abcdw
<boogiewoogie[m]>so merging of new packages/patches into main guix tends to be on the slower side I take it? not that that's bad, but it would give some context to availability in the main repo, especially some package versions =)
<blake2b>jonsger you can do /whois mothacehe
<blake2b>jgart: thanks for the tips, I need to break into sr.ht properly
<jgart[m]>boogiewoogie: yes that's correct
<jgart[m]>that's why channels exist
<jgart[m]>or one of the reasons
<xelxebar>How can one add external module dependencies to a personal channel?
<jgart[m]>blake2b: send patches to Guix 'R Us. That's one way to break in to it
<jgart[m]>s/it/sr.ht
<blake2b>:)
<xelxebar>I am using modules from another external channel, and `guix build -L local/path/to/my/channel foobar` builds just fine.
<jgart[m]>xelxebar: you can mix and match module deps from any channel
<jgart[m]>including a local channel that is not online in a git repo
<jgart[m]>one simple way is to use the -L flag
<xelxebar>However, when pulling my channel I end up getting "no code for module" errors.
<jgart[m]>guix build my-hacky-python-library -L ~/my-hacky-channel
<jgart[m]>substitute guix shell and the command works the same way
<jgart[m]>xelxebar: did you use -L ?
<xelxebar>jgart[m]: With pull?
<jgart[m]>or `guix shell --load-path=~/my-hacky-channel` if you like to type out long flags
<jgart[m]>no pull needed
<jgart[m]>if you have the channel on your file system, that is
<xelxebar>In my channels.scm, let's say I have channel my-channel and some-other-channel, where my-channel uses modules from some-other-channel.
<jgart[m]>for example, one way to use guixrus channel is like this:
<jgart[m]>`git clone https://git.sr.ht/~whereiseveryone/guixrus`
<jgart[m]>cd guixrus
<jgart[m]>guix install -L . node-typescript
<xelxebar>jgart[m]: Yeah, that all works fine. My question is a different one.
<jgart[m]>the same goes for any other channel
<jgart[m]>out in the wild
<jgart[m]>what's your question?
<jgart[m]>> where my-channel uses modules from some-other-channel.
<jgart[m]>do you have that other channels modules in path?
<jgart[m]>if not, then you should add them also
<xelxebar>guix pull fails with "no code for module" on my channel, when I use some module from some other, external channel (which is also included in channels.scm)
<jgart[m]>if you're trying to use a channel that you're not subscribed to or not putting it in path then the deps won't be available of course
<jgart[m]>do you have your configs online?
<jgart[m]>if you can point to the files in question maybe it will be clearer
<jgart[m]>otherwise I may be overlooking something in the context of your situation
<jgart[m]>some gotcha
<xelxebar>jgart[m]: Not sure if it's completely kosher to share here, but there's my channels.scm: http://ix.io/3V4r.
<xelxebar>My channel is guix-bmw, and I'm trying to use modules from one of the other non-primary channels.
<xelxebar>guix build -L local/path/to/my/channel foobar works just fine, but guix pull errors with "no code for module" when trying to build my channel's modules.
<xelxebar>If I remove the dependency on the third-party channel's module, then guix pull succeeds.
<jgart[m]>what channel does guix-bmw depend on?
<jgart[m]>a local one that you mentioned above that is not online?
<jgart[m]>xelxebar: maybe send an email to guix-devel@gnu.org
<jgart[m]>and open a discussion about it so it doesn't get forgotten here in irc ocean
<jgart[m]>if your question doesn't get answered by someone else
<xelxebar>jgart[m]: No, guix-bmw depends on one of the channels listed in channels.scm.
<jgart[m]>ah ok
<jgart[m]>yup, that does sound weird
<wdkrnls>Dear Guix, I'm trying to get the hang of working with Guix profiles.
<wdkrnls>They make sense to me for very self contained software, but how can I manage software that goes everywhere like my window manager?
<wdkrnls>I have been contentedly running my window manager from emacs and a bunch of shell scripts for a while now, but it's all assumed that everything was happily installed in the default profile. Now that I'm trying to split it up, I'm facing pains with my window manager being able to run one command, while failing on another.
<wdkrnls>Strangely, I managed to figure out how to open a new emacs frame, but cannot get it to open a new emacs frame inside a new shell buffer.
<wdkrnls>The script I had been using works if I run it from bash, but my window manager can't seem to spawn it.
<singpolyma>wdkrnls: if you activate all the profiles you want before running your WM then all commands should be on path for it, same as with one profile
<wdkrnls>singpolyma: I think I understood that. I've been doing that via: . ~/my/system/$custom-profile/etc/profile
<wdkrnls>and I think I have just learned I can do that once by creating a bash script to be sourced which sources my profile and then exports whatever extra environment variables I want to set which I want to reuse across my dozens of scripts which help me control my window manager.
<wdkrnls>It's just that, it doesn't seem to work for creating a shell, but since all the errors are going off into the netherworld, I cannot see what is happening.
***taiju65 is now known as taiju
***taiju__ is now known as taiju
***taiju` is now known as taiju
***taiju__ is now known as taiju
***taiju is now known as Guest8616
***taiju` is now known as taiju
<Tril[m]>I did guix pull and then ran guix -V, reports version 0, is this normal or a bug?
<Tril[m]>previously version was some long hex string instead of 0.
<atka>Tril[m]: same result here
<atka>first time I've run guix -V though
<atka>usually run guix describe which says guix 5743d50
<Tril[m]>ok thanks. guix describe says f6bc281.
<abrenon>hello guix
<atka>hello
<attila_lendvai>someone with the commit bit: libfprint requires python into its native-inputs to restore buildability
*attila_lendvai has filed the fix at: https://issues.guix.gnu.org/54926
***Roy_Mustang is now known as A_Dragon
*attila_lendvai is dismayed to see that his idris PR has been sitting there for months with a fix, and now he has to rebase/merge it with someone else's fix already in master
***toulene8 is now known as toulene
***Lightsword_ is now known as Lightsword
<jonsger>good morning Guix
<rekado>attila_lendvai: can we use python-minimal here?
<rekado>I’ll apply this today.
<rekado>any other patches you’d like me to review?
<attila_lendvai>rekado, i don't know, but most probably. shall i retest and resend, or you'll do it?
<rekado>I can do it
<rekado>(I’m in the middle of a bioconductor mass upgrade; will take a little while before I have free CPU cycles)
<attila_lendvai>rekado, i think these are relatively non-controversial: https://issues.guix.gnu.org/54910 https://issues.guix.gnu.org/54906 the rest of my open issues is less obvious: https://issues.guix.gnu.org/search?query=submitter%3Alendvai+is%3Aopen
<attila_lendvai>rekado, thanks! i'll test with python-minimal and resend
<xelxebar>jgart[m]: Just FYI, it turns out I did need to explicitly declare channel dependencies: https://guix.gnu.org/en/manual/devel/en/html_node/Declaring-Channel-Dependencies.html#Declaring-Channel-Dependencies
<attila_lendvai>rekado, it seems to build green with python-minimal, too: https://issues.guix.gnu.org/54926
<rekado>excellent
<abrenon>ohhh, I get ABI mismatch running make from my local copy of guix : (
<rekado>abrenon: make clean-go
<abrenon>ah, thanks
<abrenon>I was looking for clean or mrproper or something
<abrenon>I only came here to complain, but it's even better if I get an accurate answer so fast !
<abrenon>thank you very much !!
*attila_lendvai is testing his idris2 packaging and hopes to submit it today
<jonsger>abrenon: sometimes you need to do a ./bootstrap && ./configure afterwards...
<abrenon>I thought it was only the first time ?
<abrenon>I haven't done that in ages
<abrenon>how do I know when it is required (apart from running "make" and trying from ./bootstrap again if it fails ?)
<rekado>abrenon: whenever the build system changes significantly you need to re-bootstrap
<rekado>it doesn’t happen often
<rekado>attila_lendvai: I applied 54926 and 54910; for the go-build-system patch I’d prefer to have someone look over it who is familiar with that build system. I’ll ping some people.
<rekado>for https://issues.guix.gnu.org/54910 we also need to change tests/go.scm, which now fails
<rekado>I’ll do that before pushing
<rekado>tests/crate.scm too
<rekado>actually, … I’m not sure the behavior is correct
<attila_lendvai>rekado, much appreciated, thank you! i'll be around for a while, ping me if you need any help/info!
<rekado>for go.scm the change is trivial, but crate.scm expects labels in the #:cargo-inputs field in arguments
<rekado>so I’m not sure we can actually apply this
<rekado>I’ll comment on the issue and ping contributors to this build system
<attila_lendvai>hrm. unfortunately i don't know much about the crate stuff.
<attila_lendvai>IIRC i've seen some chatter somewhere about converting crates to the new format. or maybe even getting rid of the #:cargo-inputs in favor of the normal #:inputs
<attila_lendvai>if the docs build requires some extra dependencies, then what's the practice? just add them to the native-inputs?
<attila_lendvai>somehow it feels wrong to increase the number of dependencies only for building the doc output...
*attila_lendvai finds the foo-minimal + foo (which includes the docs) pattern
*attila_lendvai decides to just add the dependencies to the native-inputs with a comment
<Haider>The Guix installation of Blender has no denoiser. Blender's compositor says that Blender is compiled without "OpenImageDenoise". Do you lot also see this problem?
***gyara[m] is now known as gyara
***gyara is now known as Guest5061
<attila_lendvai>idris2 in guix, bootstrappable all the way down from GHC: https://issues.guix.gnu.org/49607#4
<attila_lendvai>rekado, if you're rolling, then you may want to consider this^ too
<rekado>Haider: you reported this yesterday, didn’t you?
<Haider>perhaps
<rekado>things get easily lost on IRC. Please consider reporting a bug by sending email to bug-guix@gnu.org
<Haider>Was going to do that, but sent a email to help-guix@gnu.org instead.
***Guest5061 is now known as nanami
<GNUtoo>hi,
<Haider>Hello.
<GNUtoo>When you override a package, can you modify its phases if it already modified the standard phases?
<GNUtoo>For instance valgrind/interactive inherit from valgrind which uses modify-phases, and I want to add a phase in vagrind/interractive
<rekado>GNUtoo: yes, you would use substitute-keyword-arguments, capture the phases as “phases” and then `(modify-phases ,phases …)
<GNUtoo>Thanks a lot, I'll try to understand how that works
<ZhuAisi[m]>do grep `(substitute-keyword-arguments` in Guix repo and you can see more examples
<GNUtoo>indeed
<rekado>substitute-keyword-arguments takes the value of a package’s “arguments” field and allows you to latch on to any of the fields, bind values, and then supply replacements.
*GNUtoo found a good example with the "chez" packages and will try it
<GNUtoo>Thanks a lot for the help
<GNUtoo>The code is much cleaner now. I'll also try to update the guix.scm that I have to use that.
<EMax`0Mancer[m]>which package is xcompose part of?
<GNUtoo>Debian has no xcompose at least (there you can search for package that has a filename or a path ending in a filename)
<EMax`0Mancer[m]>? https://wiki.debian.org/XCompose
<EMax`0Mancer[m]>So perhaps just libx11
***the-porcupirate is now known as porcupirate
<SeerLite[m]>Hi. In my profile I have a package with a tarball source, but I've installed it with the --with-git-url= flag. The problem is when I try to guix upgrade I get a "the source of <package> is not a Git reference" error
<SeerLite[m]>I've tried running guix upgrade --with-git-url=<package>=... too, but it doesn't work either
<SeerLite[m]>Is there a way to upgrade without removing or working around this? Is this a bug
<jab>SeerLite[m]: if it is a tarball...then you should probably install it without the --with-git-url right?
<jab>should probably *NOT
<jab>scratch that I had it right the first time.
<SeerLite[m]>jab: The original source is a tarball but I want to install it from git
<SeerLite[m]>As far as I understood from the manual that's something that should work
<SeerLite[m]>(and it does, what doesn't work is running guix upgrade afterwards)
***Roy_Mustang is now known as A_Dragon
***the-porcupirate is now known as porcupirate
***darosior0 is now known as darosior
***duds-_ is now known as duds-
***erhandsome_ is now known as erhandsome
***erhandsome is now known as Guest5559
<rekado>vagrantc: I don’t understand how any of this works. I assumed I would need a boot script. I don’t know how to use extlinux to boot from sdcard and then use the SSD as the root file system.
<Haider>I am packaging something where to compile something you run a CMake process then you run Make after, can I make guix strip the flag of the Make proccess instead of CMake?
<Haider>In other words, after Guix build system has ran CMake, it runs "make install" but I want "make".
<blake2b>haider: in (modify-phases..) you want (delete 'install)
<Haider>blake2b: Wouldn't that just stop the entire build proccess
<blake2b>no because the thats the 'build phase
<jgibbons[m]>For the past month or so, my laptop's network card stopped working every few minutes. Guix was practically useless because most of what it does takes more than a few seconds of network activity. I thought it was a network card problem, but it looks like it was fixed after I removed TLP as a system service. I should still check, did the default TLP configuration change in the time I described?
<blake2b>so think of phases usually like "./configure" = 'configure, "make" = 'build, "make install" = 'install
<Haider>I think it worked...
<blake2b>if you need to do some things before or after these you can add custom phases with (add-before 'build 'whatever-you-want-to-name-this-phase (body ...))
<blake2b>Haider: :)
<Haider>Yeah It probably worked, Thanks man!
<blake2b>np! its (usually) pretty easy when you get the hang of it.
<mfg>Hi, has someone else had an error when trying to run `guix shell -C emacs'? The error i get is a mount error: invalid argument
<mfg>this doesn't happen when using the `--no-cwd' option
<Haider>mfg: Not for me, is your system up-to-date
<mfg>well i just guix pulled but i was only 98 commits behind
<Haider>Are you on the Guix operating system or a foreign distro?
<mfg>this is on a foreign distro
<mfg>ah yeah on guix system it also works (it's on my other machine) so this has to be something with the host distro iguess
<Haider>well just update your system and reboot. If the error continues, it probably is your host system
<vagrantc>rekado: eitehr a boot script or extlinux should be able to do the same thing functionally, the main functional difference is a boot script requires you to transform it with some binary headers and an extlinux.conf configuration is a plain text file
<vagrantc>rekado: and what language it's implemented in (e.g. u-boot's shell vs. syslinux-style configuration syntax)
<bjc>is there a built-in way of sharing an x or wayland session with ‘guix home container’?
<lilyp>I'm not aware of one, but you could try adapting that huge blob of --expose lines that I used for seahorse
<bjc>yeah, --expose=/tmp/.X11-unix works, i was just kind of hoping there was something built in
<bjc>so i wouldn't have to be smart about whether its an x or wayland session
<bjc>thanks, though
<apteryx>ipython 8.2.0 with the full docs (even as info); phew
<apteryx>which begs the question; where should the *.png files used by the ipython.info manual go? currently they sit right next to it and would be installed along it
<apteryx>oh nevermind, they are in infodir/ipython-figures/*.png
<jackhill>jgart: I wonder if a message to guix-devel@ about your authentication issue would be useful? I wonder if the folks who would know what happened haven't seen your message. I think a lot of the rest of us didn't run into it becasue we didn't pull at the right/wrong time.
<apteryx>rekado: currently texlive-polyglossia provides a full-featured xelatex.fmt; ugly but it seems to get the job done for now
<bdju>has anyone tried to package visurf?
<blake2b>bdju: i thought about it, but its currently a bit of an ad-hoc setup, requiring that you grab sertain sources from netsurf but not others -- which made it seem like a bit of headache for something I (probably) won't really use
<blake2b>i imagine it will become simplified after pre-release
<bdju>qutebrowser audio has been broken for over a year and it's also just very slow and hogs my CPU even when seemingly doing nothing. so the idea that visurf might be a less-broken browser that is otherwise similar is pretty appealing to me
<bdju>I see that there's an alpine package for visurf (likely made by Drew himself)
***bandali_ is now known as bandali