IRC channel logs

2022-03-19.log

back to list of logs

<unmatched-paren>how would i use a library that provides no pkg-config files on guix?
<unmatched-paren>i'm trying to link in uthash, but it doesn't have a .pc
<unmatched-paren>`gcc -luthash` can't find it, i'm guessing that i'd need to `-L` its store directory
<pushcx>Roughly how long does it take for an email update to appear in the debbugs web interface?
<barra>Is it just me or does Icecat have no video acceleration?
<barra>also, I've managed to figure out why eshell couldn't use programs from an activated guix profile
<barra>emacs searches exec-path, which emacs-guix sets fine, but eshell uses a seperate eshell-path-env
<barra>by setting eshell-path-env to exec-path after activating a profile
<barra>eshell picks up the new programs
<unmatched-paren>ok, i'll rephrase that question: is there a good C hash map library in guix?
<unmatched-paren>half of what i get when i search on ze internet is C++ stuff
<ryanprior[m]>unmatched-paren: I packaged wyhash, which is used in a number of languages standard libraries for implementing their hash maps.
<atka>working on a server config including docker, during reconfigure: error: service 'dockerd' requires 'dbus-system', which is not provided by any service, I have the dbus service module but there is no dbus-service-type, do I need to include %desktop-services in my server config or can I use dbus + dockerd on its own?
<jgart[m]>hi, should this be news.scm instead of news.txt?
<jgart[m]> https://git.sr.ht/~whereiseveryone/guixrus/tree/master/item/.guix-channel
<atka>nm I think I figured it out
<jgart[m]>Is there a global option for building a set of packages without building the documentation?
<jgart[m]>nix allows this, for example
<jgart[m]>I see many packages just include the docs pre-baked
<kittyblam>yoyoyo hows it all going? anyone know if there is any good example configs anyone has laying around? just kinda feel like seeing if there is any neat ideas im missing similiar to how dissecting emacs configurations can yield a lot of insight
<philofosser>Hello!
<philofosser>Welcome.
<luchadoritos>Hey Guix! I installed the package "sbcl-rtg-math" via Guix but when I use a system that has depends on "#:rtg-math.vari" SBCL throws a "Simple file error" that rtg-math/vari cannot be created.
<luchadoritos>When I go to the /gnu/store/.../sbcl-rtg-math/lib/com I find many directories (like quaternions) from https://github.com/cbaggers/rtg-math but I do not see "vari" directory.
<philofosser>Have you verified that your current profile has the package and if so your current environment is such that SBCL can see that path?
<luchadoritos>I thought the source of the error was that the input does not contain varjo in the package definition. However I added it myself and I do not see the folder show up. When I try to build using "guix build sbcl-rtg-math" I just get the store link, I actually wanted to see the compile log if there's a warning like "Did not find Varjo".
<luchadoritos>My SBCL can see the path I can use other functions from the package like the v! Function which creates vectors.
<luchadoritos>There's actually two .asd files (one for rtg-math, another for rtg-math.vari) in the Git repo. Does that cause an issue?
<luchadoritos>Adding "rtg-math.vari.asd" to the "#:asd-files" argument list didn't seem to help. But I think that puts me closer...
<philofosser>Pardon, right after I said something I lost power momentarily and missed out on the conversation.
<philofosser>So if you were talking to just me, I missed everything between my message and this last one you sent.
<philofosser>Sorry about that.
<luchadoritos>Ah! May I repeat myself?
<philofosser> Please do.
<luchadoritos>So I can see the rtg-math package from SBCL and can use some functions like v!. However I cannot use all functions from the package. I believed this was due to the repo having 2 asd files but adding the other one into the #asd-files argument does not solve it entirely
<philofosser>So, you have access to only some packages. Have you tried using the '::' accessor as well in case it's just an export issue with asdf?
<philofosser>
<philofosser>It's been a little bit since I've done a common lisp project, but I recall that using an absolute reference into the namespace from outside the package can sometimes find missing symbols.
<luchadoritos>Sadly I cannot find the specific function :(
<philofosser>Darn.
<luchadoritos>When I go to the gnu/store for this package I cannot find the directory for this function either
<luchadoritos>I believe it's not even "compiled" in (if that's the right terminology)
<philofosser>Oh, perhaps the guix package does not ship the library with all the bells and whistles you're used to. I'm not familiar with that one, unfortunately, so I can't do much more than speculate.
<philofosser>I supposed worst case scenario you can do a good old "find -type f | xargs grep 'function-name'
<luchadoritos>Sadly I cannot find it that way either. All I know is that I can find it on the GitHub page the ASDF build system sources this package from ( https://github.com/cbaggers/rtg-math , need /vari dir)
<philofosser>It's quit possible that the guix substitute is an older commit.
<philofosser>*quite possible
<philofosser>You can try modifying your package to use a newer commit.
<luchadoritos>Aye aye captain! Will try it!
<philofosser>Good luck.
<luchadoritos>Yooo! Adding '#asd-systems '("rtg-math" "rtg-math.vari")' to 'arguments' in the package worked! Thanks for your help philofosser !
<luchadoritos>I got to draw a red square in SDL2 lol
<Ribby>Hello guys, I was wondering if there's a gnu alternative to the propietary mkfs program?
<Ribby>Going to do a guix pull thing.
<Ribby>About that QubesOS discussion, I feel that virtualization is basically a frontend rather than a backend.
<luchadoritos>Mkfs is proprietary? I had no clue :O
<Ribby>I mean, you are using a cover to test something, right?
<philofosser>You're welcome.
<Ribby>Well, the default guix package repository doesn't seem to have it?
<Ribby>either by pull or just server hosting.
<Ribby>It's not a problem, though. I just learned about to add extra repositories in a sources.list text configuration file.
<philofosser>Ribby, the mkfs programs are in the file system util packages.
<philofosser>dosfstools, exfatprogs, etc.
<Ribby>It's not pre-installed, of course. I probably didn't get the right names.
<Ribby>Sorry about that.
<philofosser>What file system are you planning on using? You can run 'guix search <filesystem>' and see what pops up.
<Ribby>file system should be gpt
<Ribby>I'll go test the straight install commands for the default server.
<philofosser>GPT is a partition table scheme, not a file system.
<Ribby>Oh, sorry. Mistake.
<philofosser>MBR and GPT are written by programs like fdisk and gparted.
<Ribby>Partitioning tables
<Ribby>I think it was called exfat?
<Ribby>e something.
<philofosser>exfat however is a file system.
<philofosser>You're looking for the "exfatprogs" package.
<philofosser>In the future, run 'guix search <filesystem>' and you'll find your tools much faster.
<Ribby>Okay.
<philofosser>Good luck, Ribby.
<Ribby>Thanks.
<Ribby>I think guix may benefit from clamav/clamtk, chkrootkit, and rootkit hunter (rkhunter). It's a security thing, but it can be quite vague.
<Ribby>Oh, the firewall could be walld or firewall-config, which is said to be a gui of nftables.
<Ribby>Which filesystem reformater should I use? exfatprogs, exfat-utils, or fuse-exfat?
***alMalsamo is now known as lumberjack123
<Ribby>Yeah, I think I'll go with exfat-utils.
<philofosser>You'll need exfatprogs for mkfs.exfat iirc.
<philofosser>Fuse-exfat is only for FUSE, a userspace filesystem tool. I don't use FUSE much, so I can't comment further.
<Ribby>How do I know if I have it?
<Ribby>Oh, I do have it!
<Ribby>Didn't know it!
<philofosser>When in doubt, double tab will list all your commands in PATH.
<Ribby>I'll have to uninstall the outdated exfat-utils
<Ribby>after the pull, of course!
<Ribby>It doesn't appear to be registering despite successful installation... interesting.
<luchadoritos>Ribby: Do you mean that the updated version is not appearing in your path when you run a command (like "mkfs.exfat -V")?
<Ribby>Like, "sudo mkfs.exfat /dev/sdb"
<Ribby>Command doesn't register? I think I might do an update.
<luchadoritos>Ah, so it would say something like mkfs.exfat command not found?
<Ribby>Maybe restarting the computer will do because these reformat problems usually involve restarting the computer.
<Ribby>Yes.
<Ribby>Reformat problems as in misconfiguring with the devices.
<luchadoritos>Try updating your source GUIX_PROFILE. That is, running the two commands in this page where it says hint: https://guix.gnu.org/manual/en/html_node/Getting-Started.html
<Ribby>Anyone know how to remove terminal command history?
<atka>rm .bash_history?
<the_tubular>^
<atka>might need to logout after
<atka>or close all bash terminals, can't remember
<Ribby>Finally some help.
<Ribby>Got source reference?
<Ribby>Citation from a webpage?
<atka>search how to clear bash history, you will find dozens
<luchadoritos>"man bash" then /HISTFILE
<the_tubular>Hey atka
<atka>hello
<the_tubular>How are you ?
<atka>I'm well, yourself?
<the_tubular>Pretty good, learn anything new today ?
<atka>yeah learned a few things, played around and tested some things, set up docker for a couple services, minimal server config is almost complete and ready to be depoyed to two servers to start
<atka>you do any hacking?
<the_tubular>Like security wise ?
<the_tubular>Or just hacking in scheme in general ?
<atka>the latter
<atka>don't pen test me please
<the_tubular>Yeah, I do the first
<the_tubular>I wanna start learning scheme
<the_tubular>But it's kinda hard to learn
<atka>did you work on guix today?
<the_tubular>No :/
<atka>for shame
<the_tubular>I should at least put 1hour everyday
<the_tubular>I should get more hardware though, My cpu died not so long ago
<atka>what are you on now?
<atka>a potato?
<the_tubular>Yeah ...
<the_tubular>A potato that can't run VMs, and stuck on Windows for work related reasons ...
<the_tubular>Well I can run WSL
<atka>no bueno
<atka>I hear there's guix on pinebook pro
<the_tubular>Yeah, I'm wondering if I should buy a laptop and Egpu
<atka>not fast, but cheap and fun to hack on
<the_tubular>Or a desktop and a laptop
<atka>I prefer lappys myself
<the_tubular>Yeah, although I like to game sometimes.
<atka>and a server somewhere for heavy lifting
<the_tubular>This configuration doesn't really work if you game...
<atka>I enjoy the occasional game, mainly stuff like factorio so I'm all good :)
<the_tubular>Yeah, I like games that you need to install malware to play :(
<atka>any of the zachtronics stuff is good too
<the_tubular>Not familiar with this
<atka>programming puzzle games
<the_tubular>Damn, I should check it out
<atka>but realy good
<the_tubular>Big fan of CTFs, But I never really got into the programming challenges ....
<atka>like overthewire and such?
<the_tubular>I can't remember the name, the one in december ...
<the_tubular>Yeah, Hackthebox or tryhackme
<the_tubular>Or more official CTF that gets published on ctftime
<atka>I had a lot of fun with otw around ~2015
<the_tubular>Never really tried that one. I think it's pretty dead
<the_tubular>Not sure though
<the_tubular>I just don't hear about it a lot
<atka>because its too good
<atka>underground
<the_tubular>Really ?
<atka>:)
<atka>haha no
<the_tubular>I'll give it a try if you say so :P
<the_tubular>When I first came to guix I wanted to make "My own Kali"
<the_tubular>Cause I never really liked Kali
<the_tubular>I was checking out this package yesterday : https://github.com/tkf/emacs-request
<the_tubular>I was wondering if you could use it like a proxy
<atka>not sure, haven't dug into emacs yet...
<atka>its on the list though
<atka>be back in a bit
<Aurora_v_kosmose>...:/// broken packages.
<devmsv`>so I have defined my own package variant on config.scm, but I can't used see: http://ix.io/3SPz after doing sudo system reconfgigure. This is my config.scm: http://ix.io/3SPA
***devmsv_ is now known as devmsv
*atka zzz
<unmatched-paren>ryanprior[m]: well, that looks like a hash function, not a hash map, but i guess i could use it to implement my own hash map
<maximed>I recently sent a mail to help-guix (18 Mar, ‘Packaging go-github-com-hashicorp-vault-sdk -- ‘no Go files found’’), has this mail been received? I don't see it on <https://lists.gnu.org/archive/html/help-guix/2022-03/threads.html>
<gnoo>maximed: it's not on my inbox either, you should probably resend it tomorrow (in case it is still being held for moderation)
<alethkit>Hi again! I'm trying to add a new guix home service as follows: https://paste.debian.net/hidden/5089e18d/, but I end up with the following error: https://paste.debian.net/1234887/
<civodul>alethkit: hi! at first sight the config looks good to me
<civodul>could you show the context around it?
<oriansj>so have the missing functionality in this list: https://paste.debian.net/1234889/ been added yet?
<nckx`>Nothing's held for moderation. Resend what's been lost.
<xdg>has anyone been able to get ar9271 dongle working on pinebook? (assuming anyone has a pinebook)
<oriansj>xdg: got the ar9271 USB to work on an AMD64 system
<oriansj>using this snip: https://paste.debian.net/1234890/
<alethkit>Dang it
<alethkit>Turns out there was a hidden quote character
<oriansj>alethkit: how was it hidden?
<alethkit>Editor theme didn't make it easy to see
<alethkit>I only noticed it when copying the file over
<nouun>I just setup WiFi on my Guix setup and I'm unable to connect to SSH anymore. I can't see anything in the manual related to firewall like when I had the same issue on NixOS.
<xdg>I have it working on x86_64 and manjaro on the PBP but the guix kernel isnt even reconizing the device?
<xdg>I presume its a driver issue and it is on the PBP official image but im hitting some real road blocks. there is basically no documentation on PBP kernel
<xdg>I already specified the firmware on the system config. I found it just sitting in the store, but not loaded at all?
***alMalsamo is now known as lumberjack123
<acrow>Hello.
<phodina[m]><xdg> "has anyone been able to get ar92..." <- Hi, yes but it requires unfree driver which is not possible to use with libre kernel.
<avp>Hello Guixers! How do you configure a proxy for the 'guix-daemon' when Guix is running on a foreign distro?
<phodina[m]>I've would like to build the kernel for PineNote from Pine64. Unfortunately it's still under development and lot of patches are not yet in vanilla kernel.
<phodina[m]>There's https://gitlab.com/pgwipeout/linux-next repo with the patches. I've checked `gnu/packages/linux.scm` and there's variable `%upstream-linux-source` which defines the source uri.
<phodina[m]>What would be the best way to create a new linux libre kernel from the git repo? What deblob scripts should I use?
<Aurora_v_kosmose>avp: A proxy?
<Aurora_v_kosmose>avp: "export GUIX_BUILD_OPTIONS='--substitute-urls=https://ci.guix.gnu.org --substitute-urls=http://cache.wg'" is in my /etc/bash.bashrc
<Aurora_v_kosmose>The list of substitute urls takes the first in reverse order.
<jab>phodina[m]: I do not know how to build a linux libre kernel...
<jab>I remember there being an email thread between a guix developer and the linux-libre project...
<jab>In my estimation, it sounded like the linux libre dev just wanted us to use the already de-blobbed libre kernel...but I do not remember the summary.
<Aurora_v_kosmose>Do we have a way to see the last working versions of given packages?
<Aurora_v_kosmose>I don't particularly want to debug openblas & kaldi when all I want is just to use vosk...
<Haider>When using glad (installed as a package) in guix, my IDE cannot pick it up and spits out a bunch of errors
<sneek>Welcome back Haider, you have 1 message!
<sneek>Haider, SeerLite[m] says: How are you changing the username? Did you change it in operating-system in the config file and then reboot?
<Haider>Do you know of any way to fix this? I am using lsp-mode in emacs
<raghavgururajan>If anyone would like to join us at Guix Doc meetup, please do so at https://meet.nixnet.services/b/rag-8bi-sdx-kdf
<apteryx>civodul: I would avoid touching Berlin for now (no reconfigure or reboot)
<phodina[m]><jab> "I remember there being an..." <- Thanks, found the thread https://lists.gnu.org/archive/html/help-guix/2019-07/msg00056.html.
<phodina[m]>However, now it also needs pinenote_defconfig. Is there a way how to specify it in the phases?
<phodina[m]>I know there's a post on Guix blog about that https://guix.gnu.org/de/blog/2019/creating-and-using-a-custom-linux-kernel-on-guix-system/.
<phodina[m]>Seems like the best option though is to use `make-linux-libre` and just replace `make-linux-libre-source` with the git repo. This way I should be able to supply also the defconfig specific to the device
<alethkit>Does xmonad require any special GHC setup in order for live reload to work?
<devmsv>Hi so, I'm tryng to install Guix System on an Asus chromebook but graphical installer is looping after selecting mode of partitioning
<devmsv>there is a segfault of libparted.so on dmesg so if I can help debuggin just tell me what you need (take into account I'm just a "power user" and don't really know how to use gdb)
<civodul>apteryx: re berlin, noted!
<civodul>sorry that i haven't really followed (plus my email setup is in flux, which doesn't help)
<EndOfAnEra>hi is there a way to print the (package) declaration?
<EndOfAnEra>of a package
<EndOfAnEra>with updates, they sometimes add or remove build logic, and is there a way to see the complete package declaration
<civodul>EndOfAnEra: hi! try "guix edit PACKAGE"
<EndOfAnEra>civodul: yes that shows all of the logic, and the (package) is made from different parts of code
<EndOfAnEra>so I'm wondering if there's a way to display it only
<EndOfAnEra>nevermind, maybe I'll write a library that prints the record and all
<phodina[m]>So I've put together definition for the PineNote kernel, but cross compilation gives me errors. Does somebody now what's wrong?
<phodina[m]>I've managed to build the kernel outside of Guix and now I'd like to package it so it can be used in system configuration.
<phodina[m]> https://paste.debian.net/1234926/
<civodul>phodina[m]: no idea, it may be worth comparing with the linux-libre definition
<civodul>well it's supposed to the the same
<civodul>hmm, dunno
<phodina[m]>civodul: Thanks, I was thinking about that. Using `linux-libre-arm64-generic` as base package results in the same error.
<phodina[m]><civodul> "phodina: no idea, it may be..." <- Switching to tar ball instead of git fetch seems to fix the problem
<simendsjo>I've managed to break my Guix System server by adding configuring a non-existing drive. I get into a guile shell, but I don't know how I'm supposed to switch generation from here. Any tips?
<KarlJoad>Is there a way to force Cuirass to evaluate a specification? I have a personal spec that I want to have built now.
<jpoiret>hmmmm, seems a lot of people are reporting that installer segfault with libparted
<jpoiret>the thing is, I don't think it'll be easy to add the proper debug symbols for the libparted used by the installer
<civodul>simendsjo: hi! you can switch generations from the GRUB menu
<civodul>now, "guix system reconfigure" should detect non-existent drives and error out
<civodul>unless you pass --skip-checks
<simendsjo>civodul: How can I get to the grub menu on the server? The problem isn't a non-existing drive I guess, but something wrong with the drive/volume. I get "e2fsck: Bad magic number in super-block while trying to open /dev/sdc".
<jab>simendsjo: depends on the hosting service. My hosting provider provides me a graphical way to view the boot up process. It lets me select various boot options from grub on boot up.
<simendsjo>jab: I'm on Linode. Guess they support something like that, but I haven't found it. I'll do some digging.
<simendsjo>Ok, so I have a shell into the server as it boots, but it doesn't seems like it accepts keyboard input at that stage.
<jab>simendsjo: you may be stuck...
<civodul>"guix home container" is in the house!
<simendsjo>jab: Sounds quite alarming. I guess the drive wasn't formatted or something. A wrong mount cannot possibly brick the entire server...?
<simendsjo>Isn't it possible to do the rollback via the guile API? Or somehow hack away the fstab entry?
<fnstudio>hi, i don't seem to be able to find qmk (open source keyboard firmware) in guix - before looking into how it might be made into a guix package, i was wondering if folks here simply use some different firmware/tools when it comes to custom keyboards?
<ryanprior[m]>civodul: that sounds awesome but I can't find any info. Running "guix home container -h" just prints generic "guix home" help, and "container" isn't listed as one of the valid actions.
<ryanprior[m]>The Guix home manual online doesn't contain any mention of "container" under "Invoking guix home"
<ryanprior[m]>Running "guix home container" just prints "guix home: error: no configuration specified"
<unfroq>fnstudio: As far as I can see on https://docs.qmk.fm/#/newbs_getting_started, qmk seems to be a python package available on pypi. You can try to generate a package receipe with 'guix import pypi qmk' and try to build it.
<fnstudio>unfroq: oh i see, hm... i should have thought of checking if it was a python package... excellent, i can try to import it as you mention then, thank you very much!
<civodul>ryanprior[m]: oops, i'll need to add "container" to the output of "guix home --help", thanks for reporting it!
<civodul>the manual on-line will be updated within an hour
<civodul>you can also see the discussion at https://issues.guix.gnu.org/54377
<unfroq>fnstudio: The command to build the package would be: 'guix package --install-from-file=python-qmk.scm' where python-qmk.scm is a file with the contents from the import. You might adjust the package definition a little bit if you run into build errors. See https://guix.gnu.org/en/cookbook/en/guix-cookbook.html#Packaging-Tutorial for more information.
<fnstudio>splendid, that's very helpful unfroq tx! yeah i tried to import a python package a couple of weeks ago and it went very smoothly, so i'm hopeful
<the_tubular>That new command looks pretty useful civodul :)
<the_tubular>Containerize all the things!!!
<alethkit>Does xmonad require a custom package in order for xmonad.hs reloading to work as expected?
<alethkit>The mailing list on this wasn't too clear on what is going on.
<unfroq>Hey guix! I would like to list all actively used packages on my current guix installation. 'guix package --list-installed --profile=/run/current-system/profile' and the corresponding command for the user-profiles doesn't seem to yield all packages and their dependencies.
<barra>anyone know what packages I need to get icecat to have video acceleration on intel integrated graphics?
<unfroq>barra: I have xf86-video-intel installed on guix system. I also added xf86-video-intel to the modules in xorg-configuration (not sure though, if this is necessary). Icecat seems to play videos well and hw acceleration is ticked in the settings.
<barra>hmm, perhaps that's why it's not working, I need to add it to xorg
<jgart[m]>nckx: re: python packages in check: not sure. I moved it there because Raghav had suggested it over python-xyz
<jgart[m]>in the code review for this package: https://issues.guix.gnu.org/54284#3
<jgart[m]>that was offlist with RG
<nckx>jgart[m]: IC. And it is better than that, I just wonder if python-check was dismissed (and why) or forgotten.
<nckx>Aha.
<jgart[m]>Ludo has since reviewed also
<jgart[m]>not sure why
<jgart[m]>I'd like to know too
<jgart[m]>maybe we should start putting python test packages in python-check
<KarlJoad>Is there a way to force Cuirass to immediately evaluate a specification? I have a personal spec that I want to have built now.
<jgart[m]>seems more logical to have them there
<barra>unfroq: Could I possibly see that portion of your system config?
<nckx>TBC I don't have an opinion, check.scm is fine if there's some issue (import cycles?) making python-check.scm problematic, I'd just like to know if so.
<barra>I'm looking at the manual and I'm not exactly sure how I should go about it
*nckx hasta go o/
<jgart[m]>if there is no import cycles then I prefer python-check
<jgart[m]>but I understand it can be annoying to move packages
<barra>I just tried to use my pc's keyboard to type on my laptop
<barra>bruh
<Aurora_v_kosmose>Better ergonomics.
<Aurora_v_kosmose>You just might need to install barrier first.
<Aurora_v_kosmose>oh. We don't package it yet.
<Aurora_v_kosmose>Well, we have its predecessor synergy, so that can still work.
<unfroq>barra: https://paste.debian.net/1234933 there might be mismatching parenthesis.
<unfroq>Anyone there to give me a hint regarding my package listing problem?
<barra>unfroq: thank you: xf86-video-intel seems to be unbound, now I have an idea of what rabbit hole to go down
<unfroq>barra: good luck! :)
<barra>oh, it appears I forgot to add (use-package-modules xorg)
<barra>I'm not sure if that's the problem fixed, but I am getting a system reconfiguration now
<unmatched-paren>i'm trying to modprobe.blacklist all the nonfree kernel modules so the kernel doesn't complain at boot
<unmatched-paren>does anyone know if there's a list of all the modules that don't work on linux-libre?
<unmatched-paren>i've tried killing pcspkr, iwlwifi, and bluetooth
<unmatched-paren>hm, looks like i might still need to get rid of some other bluetooth modules...
<unmatched-paren>i've managed to get rid of one of the messages, but there's still three others...
<mike23123>how do I configure keyboard layout in config.scm? i have read the man page but i still cant seem to get it working
<atka>mike23123: what layout are you wanting?
<mike23123>slovene
<atka> https://termbin.com/wwcx
<atka>so here is an example of mine
<atka>"us" is the layout "colemak" is the variant
<atka>with added option to swap caps and ctrl keys
<atka>depending on your needs you should be able to replace "us" with your layout and omit the rest
<avp>Hello Guixers! http://isl.gforge.inria.fr/isl-0.23.tar.bz2 seems to be not available...
<avp>Or it's blocked here.
<mike23123>i get no module for (system keyboard)
<samplet>avp: I think Gforge was taken offline last year.
<samplet>avp: https://issues.guix.gnu.org/42162
<atka>mike23123: are you doing this within your (operating-system section?
<mike23123>yes but also want it in the bootloader
<samplet>avp: According to that thread, isl is mirrored at gcc.gnu.org.
<avp>Hmmm, 'torify curl https://tarballs.nixos.org/sha256/0k91zck10zxs9sk3yrbb92y1j3w981w3fbwkfwd7kl779b0j52f5' returns 404 as well
<samplet>avp: However, I don’t see isl 0.23 there, just 0.24.
<avp>I mean, Guix wants to get "isl-0.23.tar.bz2"
<atka>mike23123: https://termbin.com/i8t8
<avp>samplet: FWIW, I want to package this: https://paste.debian.net/1234934/
<efraim>I have an isl-0.23.tar.bz2 I can host if you need
<avp>civodul: Besides, thanks for sharing this! https://toot.aquilenet.fr/@civodul/107984361834006583
<avp>I managed to configure a proper proxy for 'guix-daemon' by systemd service modification on my Ubuntu GNU/Linux 20.04
<mike23123>so i put (keyboard-layout (keyboard-layout "us" "colemak"
<mike23123>                 #:options '("ctrl:nocaps"))) under the operating system?
<efraim>I have a copy of isl-0.23.tar.bz2 at flashner.co.il/~efraim/missing-tarballs. if you download it with `guix download` and it's unchanged from the original then guix will happily use it
<samplet>avp: Also, https://libisl.sourceforge.io/isl-0.23.tar.bz2
<atka>mike23123: yes, if you look at the examples in the guix manual you will see
***cybersyn` is now known as cybersyn
<avp>Okay. But in Guix, isl package points to http://isl.gforge.inria.fr/
<avp>efraim: Thanks!
<atka>mike23123: you are defining the (operating system which involves setting up keymap, bootloader, services, packages etc. everything will be declared within the operating system parens
<atka>start with an example config and edit to your needs until you understand how it works
<atka>also the guix manual is pretty darn good as far as linux docs go
<mike23123>i get this https://pastebin.com/JLsbE3AJ
<atka>you'll need to share your whole config.scm
<mike23123>ok
<unmatched-paren>atka: yeah, gnu gets a lot of criticism for texinfo, but if you look beyond the tooling most of their docs are actually really good
<civodul>avp: you're welcome!
<mike23123> https://pastebin.com/qY3XLRGy
<atka>unmatched-paren: yeah, between the manual and pretty easy to parse source it has been a good learn by doing experience for me
<civodul>avp: gforge.inria.fr went down a few months ago, but hopefully we have backups around
<barra>hmmm
<barra>intel video acceleration in icecat still isn't happening
*avp prepares a patch that updates ISL to 0.24
<avp>Okay, I've sent the patch to guix-patches.
<atka>mike23123: change line 14 to (keyboard-layout (keyboard-layout "si"))
<civodul>avp: the tarball is at http://4zwzi66wwdaalbhgnix55ea3ab4pvvw66ll2ow53kjub6se4q2bclcyd.onion/file/isl-0.23.tar.bz2/sha256/0k91zck10zxs9sk3yrbb92y1j3w981w3fbwkfwd7kl779b0j52f5
<mike23123>same errot
<mike23123>*error
<civodul>oh it's a .bz2, which is why we don't have it in Disarchive databases
<atka>mike23123: looks like you need to add the keyboard layout to your services
<atka>maybe
<mike23123>i tried with keyboard and keyboard-layout and u get the same error
<atka>mike23123: look at the desktop example here, should have all the info you need
<atka> https://guix.gnu.org/en/manual/devel/en/html_node/Using-the-Configuration-System.html
<atka>I need to go, good luck!
<barra>I'm going to try ungoogled chromium to see if this is an icecat issue
<barra>Is there any packages I should be aware of to get hardware accelerated video in icecat?
<avp>civodul: https://lists.gnu.org/archive/html/guix-patches/2022-03/msg01107.html
*atka is away
<mike23123>i think i fixed it with (use-modules (gnu system keyboard))
<barra>okay, video is working fine in ungoogled chromium, so what gives
<Ribby>Okay, anyone can tell me where is the sources.list located in the guix sys?
<Ribby>it's a repository list.
<nckx>barra: (e.g., intel-)vaapi-driver?
<nckx>Dunno why Chrome would work, though.
<barra>nckx: That's installed
<mike23123>i get this now /etc/config.scm:21:24 warning the 'target' field is deprecated, please use 'targets' instead guix system: warning cannot determine provenance for current system
<nckx>Ribby: A repository list for what?
<Ribby>To download/install packages from other servers.
<nckx>mike23123: (target "/dev/disco") → (targets (list "/dev/disco")) in the common case.
<unmatched-paren>barra: maybe try poking around in `about:config`?
<barra>OH
<Ribby>Just in case something is amiss.
<barra>I JUST FOUND A THREAD FROM MOZILLA
<barra>okay, by setting a bunch of force-enabled flags it seems to be working now
<barra>I had only one missing
<nckx>EVEN WITH CRUISE CONTROL YOU STILL HAVE TO STEER
<nckx>Cool.
<nckx>I have a few of those set, in retrothink.
<barra>I DON'T IT'S AS STRAIGHT AS I AM*crashes*
<mike23123> i still get get guix system: warning cannot determine provenance for current system
<nckx>Ribby: Why packages?
<nckx>*Which packages.
<Ribby>I think it's the exfat-utils, maybe more, but one at a time please.
<nckx>mike23123: That's not important.
<Ribby>Sure, I got it installed, but somehow, the system is not reading the commands? I thought maybe a program from a different server will help. Otherwise, guix is on a different level of registry reading.
<nckx>I have no idea what you're talking about. Which servers? What registry?
<mike23123>ok thanks for the help
<Ribby>I'm going to put a debian stable repository in guix's sources.list.
<Ribby>The registry, well, that's an assumption on program operation on the guix platform if I somehow can't get the same program from different os servers.
<unmatched-paren>guix doesn't have a sources.list... that's an apt thing?
<Ribby>Yes, apparently.
<unmatched-paren>guix has ~/.config/guix/channels.scm
<nckx`>There is no such thing as guix's sources.lost.
<Ribby>Ok, that'll do! :)\
<unmatched-paren>you can't add debian repos to guix
<unmatched-paren>they work completely differently
<nckx`>I doubt it, Ribby.
<Ribby>Oh... really?
<Ribby>Gotta have faith!
<unmatched-paren>no, you cannot
<nckx`>It's like asking where to add your autoexec.bat lines to Guix. 'Ah, channels.scm, got it!' :-)
<unmatched-paren>WHERE IS THE C: DRIVE AAA LINUX SUCKS
<unmatched-paren>:)
<nckx`>It's /dev/C: duh.
<civodul>AUTOEXEC.BAT!
<nckx`>I apologise :-)
<nckx`>Send therapy bills my way.
<unmatched-paren>i mean, it might be theoretically possible to package apt on guix i guess
<Aurora_v_kosmose>Do we have a way to see the last working versions of given packages & what version of guix was used for them?
<vagrantc>but to actually try to use apt on guix would be madness :)
<Ribby>I think I found the location, but it's a hard design?
<nouun>What's the proper way to add patches? I'm doing (patches '("path/relative/to/root")) but that keeps giving me a warning when building so I assume there's a better way.
<unmatched-paren>but i can't see any point in adding an inferior package manager to guix :)
<nckx`>We have dpkg but it's not meant for that :-P
<unmatched-paren>Ribby: repeat after me:
<unmatched-paren>you cannot add debian repos to guix
<Ribby>~/.config/guix/current/manifest
<unmatched-paren>you cannot add debian repos to guix
<nckx`>I don't remember what it's for. Things, probably.
<vagrantc>actually, i have tried to package apt for guix, but ... not to be able to install packages on guix :)
<unmatched-paren>you _cannot_ add debian repos to guix!
<vagrantc>i sometimes manually extract and/or inspect .deb packages from guix boxes
<Ribby>unmatched-paren: you_cannot_add debian repos to guix
<unmatched-paren>:)
<Ribby>I saw the manifest code. I was like, "Uh oh!"
<vagrantc>does guix still have several different meanings for "manifest" ?
<nckx`>Guix is not a Debian fork. I know, probably illegal.
<unmatched-paren>~/.config/guix/current/* is not to be manually edited
<maddo>what would even be the point?
<maddo>that would make guix just another debian/ubuntu derivate, and it's not
<unmatched-paren>it is auto-generated when you `guix pull`
<unmatched-paren>it stores your user's current guix-the-package-manager installation
<nckx`>nooun: Prolly missing context but why aren't you using search-patches?
<nckx`>If the answer is 'uh I don't know', search-patches is probably the answer.
<unmatched-paren>debs are just `ar`-chives, right?
<Ribby>I don't know, I just thought that maybe programs don't work for certain reasons. Maybe different builds? There are different unix-likes anyways.
<unmatched-paren>Ribby: you can probably guarantee that 99% of programs that work on $SOME_GNU_LINUX_DISTRO will work on $SOME_OTHER_GNU_LINUX_DISTRO
<Ribby>I think it might relate to a proprietary issue.
<Ribby>True.
<unmatched-paren>i specify GNU + linux here because there are some nonGNU linux systems like Alpine that you can't really make that guarantee for
<nckx`>If a programme doesn't work, downloading bit-identical source code from another mirror can't help.
<unmatched-paren>specifically because of musl
<Ribby>Oh, well, okay.
<unmatched-paren>writing guix packages is pretty easy once you get the hang of it.
<Ribby>I guess I was asking for a block since I was looking to usb rewrites, which deals with hardware, etc.
<unmatched-paren>whenever i come across some cool software i'd like i don't even bother with compiling it normally, i just write a guix package :)
<unmatched-paren>Ribby: ?
<singpolyma>Ribby: while you cannot add Debian repos on the OS called Guix System, you *can* install guix using apt on Debian and thus have it both ways if you want/need
<florhizome[m]>hi guix
<unmatched-paren>but it's worth noting that using guix on a foreign system deprives it of a *lot* of its power
<Ribby>Writing a package is definitely better.
<unmatched-paren>rollbacks from grub, declarative kernel/service configuration, every `guix system *` command
<florhizome[m]>how is shepherd supposed to be started for guix home on a foreign system?
<florhizome[m]>User shepherd
<singpolyma>unmatched-paren: but I get Debian, so it's trade-offs :) guix on Debian is still very useful
<unmatched-paren>i think you can transform a foreign system into a guix system somehow; i've heard that it's been done
<singpolyma>Sure, just run sudo guix system reconfigure then watch the fireworks
<nckx`>It's even 'trivial' but like shaving with a chainsaw is.
<nckx`>Well' more common. Much more common.
<Ribby>Rather, maybe guix can use a virtual emulator/packager to install programs catered for different os builds. Maybe like flatpak, maybe. Yes, you may need the emulator active in order to keep program running. At least it's a start!
<samplet>It looks like isl is hosted on SourceForge now: https://libisl.sourceforge.io/
<philip>In a shell with `guix shell --pure less` (and other stuff), I am seeing "<C2><B7>" instead of "·" (unicode). What am I missing?
<sneek>Welcome back philip, you have 1 message!
<sneek>philip, mroh says: I don't think there is a package for that (a 'doc' output for guix might be an idea, though), but you can `guix shell -D guix -- make html` in a guix git repo to generate html doc.
<civodul>philip: i think that's because 'less' lacks access to terminfo data
<fnstudio>i've typed "guix build --load-path=. <package>" in the wrong folder and aborted after a while, after eventually realising the mistake
<fnstudio>i suppose that can't have done any harm?
<unmatched-paren>no
<fnstudio>thanks unmatched-paren
<fnstudio>you happen to know what that does? does it look for scm files recursively in all folders? and try to see if they contain package definitions?
<unmatched-paren>i think it looks for scm files in the cwd... i'm not entirely sure
<unmatched-paren>(non-recursively)
<unmatched-paren>i'm probably wrong
<unmatched-paren>either way, it won't have done anything harmful
<fnstudio>thanks
<fnstudio>it doesn't connect to any remote server, of course, as part of the build process...
<fnstudio>... i suppose