IRC channel logs

2022-02-02.log

back to list of logs

***LispyLights is now known as Aurora_v_kosmose
<the_tubular>Mind sharing me how you configure emacs rekado_ ?
<the_tubular>I've read what you said above, but I'm still unsure
<the_tubular>You got a git repository ?
<pinoaffe>the_tubular: my emacs config is at https://git.pixie.town/pinoaffe/emacs-config/ , I just pushed a bunch of changes
<pinoaffe>most guix-related hackery is in https://git.pixie.town/pinoaffe/emacs-config/src/branch/master/lisp/guix-profiles.el
<pinoaffe>basically, what that file does, is it maintains a list of available guix profiles as well as a list of "active" guix profiles, whenever a profile is activated/deactivated, it sets the required emacs environment variables and normal emacs variables
<pinoaffe>it does so in a very hacky way by parsing `guix --search-paths` output
<pinoaffe>oh and https://git.pixie.town/pinoaffe/emacs-config/src/branch/master/lisp/init-profiles.el also includes some guix-related stuff
<the_tubular>I see, that looks very ahcky lol
<the_tubular>hacky *
<pinoaffe>the_tubular: it is very hacky (much like the rest of my emacs config), I've been planning to make the parse step non-hacky by letting emacs "talk" to guix using a repl rather than a shell, but I haven't gotten around to it yet
<KE0VVT>Does Guix have yt-dlp?
<the_tubular>I wonder if you could configure emacs directly from guix
<KE0VVT>YAY! It does!
<the_tubular>Yes KE0VVT, IIRC
<pinoaffe>KE0VVT: yup, yt-dlp 2021.10.22 out gnu/packages/video.scm:2440:2
<podiki[m]>apteryx: I do want to try emacs config from guix, but on my foreign distro I was thinking to use the precompiled variant I use from the distro (no subs on guix, though I could try guix publish from my desktop....?)
<the_tubular>podiki[m] keep me updated if you can manage this
<MysteriousSilve4>any easier way to test emacs-xyz packages? emacs launched from `guix shell emacs-foo` doesn't seem to load emacs-foo
<alMalsamo>Does anyone here use Edwin from MIT/GNU Scheme? It might seem nice because it is written in pure Scheme instead of mixture of C and Emacs Lisp, but for some reason it doesn't seem to be very popular?
<alMalsamo>Also do any of the web browsers in Guix ship with EME support?
***jonsger1 is now known as jonsger
<apteryx>podiki[m]: why not use emacs from guix as well? This way you ensure the byte compiled .elc were compiled with that very version.
<apteryx>MysteriousSilve4: just combine both emacs and the emacs packages in the same profile: 'guix shell emacs emacs-magit'
<MysteriousSilve4>thanks!
<ryanprior[m]>You can also have emacs packages in a separate profile if you want to separate them for some reason.
<ryanprior[m]>Then you'll want to:
<ryanprior[m]>(add-to-list 'load-path "/path/to/profile/share/emacs/site-lisp/")
<ryanprior[m]>(add-to-list 'exec-path "/path/to/profile/bin/")
<MysteriousSilve4>đź‘Ť
<podiki[m]>apteryx: I'm just trying to avoid (though I guess not a big deal) compiling the version of emacs I use (native-comp-pgtk); it is fast on my desktop to do that, slow on the laptop, and Arch has binaries available for that variant
<podiki[m]>not a huge deal I guess, but could be an interesting tool to have
<apteryx>why not contribute a variant of emacs for it in guix; you can have your cake and eat it, too!
<podiki[m]>maybe I'll just use my usual org-mode/babel/literate dotfiles to generate the manifest and config, using that to do per-machine details
<podiki[m]>oh it is in a guix channel, not sure why it is not in guix proper, I guess since it is a git version of emacs; should be in the main branch soon-ish
<podiki[m]>...actually we do have emacs-next-pgtk, is native-comp now in emacs 28 by default...?
<ryanprior[m]>You can use Guix to build it on your fast desktop and deploy the binary it to your slow laptop
<ryanprior[m]>I also have a native comp pgtk binary I could send you, if you want to trust mine
***Xenguy_ is now known as Xenguy
***califax- is now known as califax
<podiki[m]>I can build it, just trying to make things complicated for myself I guess :)
***califax- is now known as califax
<Aurora_v_kosmose>Does ~/.config/guix/channels.scm override all channel definition normally? Else what use-modules is it supposed to include?
<sneek>tissevert: wb!!
***janneke_ is now known as janneke
<efraim>I assume we're not affected by the samba bug since we don't have a samba service yet
<attila_lendvai>this is simple and old. i'm running it on my laptop for months (couple of extra config params for tlp): https://issues.guix.gnu.org/50565
<tschilptschilp23>Hi! Is it to be expected, that my python from guix-home does not see packages I install through 'guix package install -f PACKAGE.scm'? The one from 'guix install python' does... maybe I should try to submit my first patch to have stuff nicely integrated, but I'm still somehow struggling with hacking on guix itself...
<rekado>attila_lendvai: I’ll push it. Thanks for pinging.
<attila_lendvai>thanks rekado!
<roptat>tschilptschilp23, if you install python packages, you need python in the same profile so guix sets up PYTHONPATH properly
<roptat>alternatively, you can install the python packages with guix home
<attila_lendvai>when gnu.org goes down, then do i need to resend mails to debbugs, or does it catch up eventually?
<attila_lendvai>i have a mail missing from https://issues.guix.gnu.org/53663 https://debbugs.gnu.org/cgi/bugreport.cgi?bug=53663
<tschilptschilp23>roptat: thank you -- I didn't know yet that guix home features that! I'm trying to run 'everything' through it, so I guess I should read up a bit more...
<tschilptschilp23>(I'm somewhat of a messy, so I have to stay clear from 'guix install PACKAGE' ;))
<roptat>tschilptschilp23, I mean, just add python-* to the list of packages in your home configuration
<tschilptschilp23>roptat: that I do, but I'm with a definition, that is not in guix yet! and I don't know how to point guix home to a local file...
<tschilptschilp23>I do have a few python-* packages in my home-definition, but the one I need is not available. now I have my (working) definition including all testing and would like to integrate it
<tschilptschilp23>(it's the new python-nltk including the tests, and the required new version of python-regex)
<rekado>tschilptschilp23: if you have it in a Guile module just point Guix to it with “-L the/root/of/the/module”
<tschilptschilp23>rekado: thanks, I will try that! Here's the definition, in case someone with superpowers can place it in the proper place (I defined a module for my local setup, but I think python-xyz.scm certainly needs no additions on the module level): https://paste.debian.net/1229278/
<roptat>tschilptschilp23, make sure the file is named "python-nltk-3.6.7.scm" and then you can load it like rekado showed you
<roptat>guix home -L root/of/the/module reconfigure home-config.scm
<roptat>or similar
<roptat>and you can use python-nltk-3.6.7 after you load (python-nltk-3.6.7) in your config
<ekaitz>hi guix how do I obtain the uuid of a device to put it on file-system?
<ekaitz>ls -l /dev/disk/by-uuid
<ekaitz>maybe we should add that to the documentation instead of a weird reference to a tool that doesn't really work when you run it as it comes
<akonai>blkid works just fine
<ekaitz>> UUIDs are converted from their string representation (as shown by the tune2fs -l command) using the uuid form24, like this:
<ekaitz>that's what the documentation says
<ekaitz>but if you run it as that it doesn't show anything
<ekaitz>we could choose to put any other tool that just runs
<akonai>interestingly blkid is specified in the system configuration part of the manual
<ekaitz>where is that? lol
<ekaitz>aaaah i see
<ekaitz>i was just looking in the wrong place? fantastic
<ekaitz>well, not the wrong, but maybe not the entry point
<ekaitz>anyway, problem solved and thanks akonai for suggesting blkid
<gordon1>do i understand it correctly that if i want to install guix channel from custom repo w/o signatures, i have to use guix pull --disable-authentication which in turn disables authentication for every other channel specified in channel.scm?
<gordon1>*channels
<gordon1>otherwise i have to re-sign every single commit in guix repo with my own key
<gordon1>*local guix repo
<akonai>gordon1: if you don't specify authentication in the channels.scm you don't need to sign it
<akonai>i have a local repo without authentication and it works fine
<gordon1>no, if you don't specify authentication guix tells that guix channel have to have authentication
<gordon1> https://git.savannah.gnu.org/cgit/guix.git/tree/guix/channels.scm#n403
<gordon1>*has
<akonai>i mean, my local channel has no authentication and it definitely doesn't tell me that on a guix pull
<gordon1>is your local channel - guix channel?
<akonai>nevermind, i see what you mean now
<gordon1>i mean the one called 'guix
<whound>Guys any tips on making this package def "https://github.com/emscripten-core/emscripten" ?
<sneek>whound, you have 1 message!
<sneek>whound, podiki[m] says: sorry, don't know anything about ghcjs, I would start with guix import and/or looking at other haskell packages to get started
<whound>Show all procedures form 'nix-env -iA nixos.emscripten' needed to make a Guix package of it ?
<whound>*Should
<whound> https://github.com/NixOS/nixpkgs/blob/nixos-21.11/pkgs/development/compilers/emscripten/default.nix
<rekado>looks like in Nixpkgs they just run yarn and add the downloaded node_modules directory as is to the build environment
<vldn>Is it possible to Use a local directory AS a Channel inside channels.scm?
<rekado>vldn: yes, though when you’re in the position to have a local directory anyway you might as well use “-L the/directory” or set GUIX_PACKAGE_PATH instead of using channels.
<civodul>hey there! i've pushed a draft post announcing the upcoming FOSDEM talks, as in previous years: https://git.savannah.gnu.org/cgit/guix/guix-artwork.git/tree/website/drafts/meet-guix-at-fosdem-2022.md
<civodul>lemme know if there's anything wrong and i'll publish later today
<vldn>Thx already doing that rekado
<vldn>How to define it inside the channels.scm without add-to-loadpath?
<rekado>vldn: pretty sure you can use a file:// URL
<ekaitz>civodul: "heroic work"
<ekaitz>come on
<ekaitz>delete that for gods sake
<vldn>Ah that'll be nice to know for the Future xD
<tschilptschilp23>rekado, roptat: thanks for your hints, working on this right now (so far I keep bumping into 'no code for module'-errors, but I'm hopefully close to an internal (me) guile-upgrade :))
<rekado>ekaitz: sounds about right to me :)
<rekado>“determined effort especially in the face of difficulty”
<attila_lendvai>did anyone manage to add a custom xkb file through ~/.config/xkb on Guix? any hints?
<ekaitz>rekado: lol i'm a little bit more humble than that
<ekaitz>i just made it because I had nothing else to do
<ekaitz>but anyways, thank you all for the support, it means a lot to me
<muradm>hello guix
<GNUHacker>hi
<muradm>not really a guix question, but may be some one got around, guix package --search=fail2ban gives nothing
<muradm>any fail2ban alternative used on guix?
<civodul>ekaitz: i do find it heroic, but i can delete it if you prefer
<efraim>I've locally adjusted the cve checker to strip the leading 'python-' and some others from the package name, but now I'm sure I've got a bunch of false positives to filter out
<ekaitz>civodul: do as you please
<efraim>civodul: is ppc64le limited to power9+ or does it also run on power8?
<efraim>also, do we want to add riscv64? we don't have an install tarball yet
<civodul>efraim: re ppc64le, not sure, i think it's POWER9 per https://guix.gnu.org/en/blog/2021/new-supported-platform-powerpc64le-linux/
<civodul>re riscv64, are you talking about the Guix-HPC report or something else?
<efraim>I'm talking about the machine sitting on my desk building guix packages
<civodul>so re "do we want to add riscv64", you're asking if you should add this machine of yours to the build farm?
<civodul>i guess i'm missing some context, sorry!
<efraim>oh, I meant to the footer at the bottom "... or it can be used as a standalone operating system distribution for i686, x86_64, ARMv7, AArch64 and POWER9 machines."
<civodul>aaah, got it!
<civodul>well it might be too early no?
<civodul>when there's a release that includes riscv support, we can add it
<civodul>i don't even know what the exact status is
<efraim>probably, I don't think we have a release announcement or the bootstrap binaries mirrored yet or things like that
<civodul>too many things happening!
<civodul>ah indeed, so not completely ready
<civodul>and we'll need a blog post, too :-)
<attila_lendvai>guix pull hangs for me at: "guix system: bootloader successfully installed on '(/boot/efi)'" (it's probably something in my service code i'm working on)
<attila_lendvai>no idea how it could cause that, though
<attila_lendvai>oh, it's something with shepherd: herd status also just hangs
*attila_lendvai reboots
<attila_lendvai>how can i reboot relatively gracefully when shepherd doesn't respond?
<attila_lendvai>even kill -9 1 didn't do it
*attila_lendvai reaches for the power button
<civodul>attila_lendvai: the "bootloader successfully installed" is from 'guix system reconfigure', not 'guix pull', right?
<civodul>would be nice to see why shepherd wasn't responding
<attila_lendvai>civodul, of course, sorry for the mistake
<attila_lendvai>civodul, unfortunately i can reproduce it regularly. once again, probably my bug in the service code. i'll need to leave soon... :/
<attila_lendvai>and the kernel also panics at boot... daaamn.
<civodul>uh
<civodul>it could be the result of a service's 'start' method taking forever
<civodul>we'd need to find which one
*attila_lendvai tries linux 5.16.2
<attila_lendvai>that one doesn't even install. trying the 5.10 line. (it involves _that other channel_)
<attila_lendvai>5.10.91 boots fine. finally i can leave the physical proximity of my server. later!
<tschilptschilp23>roptat, rekado: thanks for your help again. my lesson for today, guile-modules love numbers and dots. in the alice in chains way :)
<attila_lendvai>civodul, i think i know what happens: my start gexp waits for the ipc file to show up, but "[openethereum] <defunct>", i.e. it's waiting there indefinitelye. i'll fix that on my side, but it's certainly a weakness of shepherd
<civodul>attila_lendvai: not sure what openethereum and indefinitelye are :-), but yes, busy waits like this are currently a problem for the shepherd
<civodul>(hoping to fix it this year...)
<attila_lendvai>it's also strange that the spawned service process is sitting there in <defunct> state
*attila_lendvai needs to leave o/
<abrenon>hi guix
<civodul>o/
<abrenon>civodul: thanks for your feedback, I'm working on v2 of my patch
<abrenon>hmm actually I have a question: you said G_ was from (guix i18n)
<abrenon>I rewrote my generated fallback description using it, and tested, but I forgot to add the import
<abrenon>yet it works, but I don't see any include of G_ in the header
<abrenon>could another module have by any chance re-exported it ? how could I efficiently find which one ?
<abrenon>(yeah, again, explicit imports for the win…)
<ss2>hello, I hope I’m not being too annoying now, but has someone looked into this yet? https://lists.gnu.org/archive/html/help-guix/2022-01/msg00166.html
<civodul>abrenon: G_ is from (guix i18n), but it's reexported by (guix ui)
<civodul>perhaps that's what you're seeing?
<ss2>efraim: that should change soon.
<civodul>ss2: np! the "syntax transformer" error is because the code refers to 'contact-information?' (actually a macro) before it is defined
<civodul>i think Guile shows a warning a build time by default
<abrenon>ahah absolutely ! thank you
<abrenon>is that considered good practice ? I mean, re-exporting from a module which isn't "above" in the folders tree ?
<ss2>civodul: should it be defined before hand then? I still can’t make much use of the error message.
<abrenon>I could have expected a submodule guix/ui/i18n to implement some particular G_, and guix/ui to be a shortcut to expose the most useful functions implemented, but as it is, I fail to see the link between guix/i18n and guix/ui
<abrenon>is that a more schemey approach I'm just not used to with good reasons to do so ? or are other people bothered by it as well ?
<civodul>ss2: yes, the message is unhelpful; what you need to do is make sure the use of 'contact-information?' comes after the 'define-configuration' form that defines it
<civodul>abrenon: in this case it's reexported for compatibility with a time where (guix i18n) didn't exist; it's probably nicer to use (guix i18n) explicitly in new code
<abrenon>great ! I'll do it !
<ss2>okay! The reordering helped. Maybe the code sample from the manual should be rearranged too? I got the code of the manual, and I tumbled over it.
<civodul>ss2: ah sure, i'll do that
<whound>Guys any tips on making this package def "https://github.com/emscripten-core/emscripten" ?
<whound>Should all procedures form 'nix-env -iA nixos.emscripten' needed to make a Guix package of it ?
<whound> https://github.com/NixOS/nixpkgs/blob/nixos-21.11/pkgs/development/compilers/emscripten/default.nix
<jpoiret>whound: it uses npm so it'll need some work
<whound>Will it be a easy task ?
<whound>Can Nix def be reflected to Guix ?
<whound>jpoiret: Can you give a overview on how it would be ?
<jpoiret>you'd need to define all the dependencies yourself (nix doesn't do that), and I don't know how hard it is to package npm things in guix
<jpoiret>i don't think it'll be easy either
<jpoiret>basically, you can't let npm/yarn/whatever fetch everything itself
<MysteriousSilve4>related: https://dustycloud.org/blog/javascript-packaging-dystopia/
<ss2>civodul: thanks a lot!
<whound>Guys I were to send a patch to upgrade a package to a newer version. How would you resolve dependency issue that someother package depends on the older one ?
<jpoiret>whound: either the other package actually works with the newer one, and you can patch the requirement if it's enforced somewhere, either you also keep the older package under a new variable
<Michal_Atlas[m]>Hello, what's the difference between a substitute being reported as "transferred" vs. normal progress bar?
<vivien>Hi, I’m trying to use nyacc to parse gnutls/gnutls.h, but I get: (unknown):1: not found: "sys/types.h"
<vivien>What am I missing? I’m in a guix shell with guile, nyacc, gcc-toolchain, pkg-config and gnutls
<vivien>Okay I just added the /gnu/store/…/include path of glibc and it works for sys/types.h, but not stddef.h
<Aurora_v_kosmose>Hm... For some reason I have issues with "GUIX_BUILD_OPTIONS="--substitute-urls='http://example.com https://ci.guix.gnu.org'"" but not with "GUIX_BUILD_OPTIONS='--substitute-urls=https://ci.guix.gnu.org --substitute-urls=http://example.com'"
<whound>jpoiret: I wanted make GHCjs def. Now that its dependencies are difficult to make. I'm thinking an alternative solution. Since Nix has GHSjs is it possible to make dummy package to mask Nix package of GHCjs. This is the current path '/nix/store/8fng3k2i99pqzp18w8za8cb1bd7lqki3-ghcjs-8.10.7/' what if I softlink to lib,bin,share folders from the dummy package ? Will this work ?
<Aurora_v_kosmose>The issue specifically is that I get complaints about package "https" not existing, which is because: [export GUIX_BUILD_OPTIONS="--substitute-urls='http://example.com https://ci.guix.gnu.org'"] ends up expanded in a way that treats the second url not as part of the argument expression.
<Aurora_v_kosmose>Ah right, I had to remove the single-quotes in that. Anyway, yeah, https parsed as a package name.
<vldn>Someone Runs guix on their rpi?
<jpoiret>whound: soft-linking won't work in a package definition
<jpoiret>You couldn't use nix to build it in guix either, since nix won't have network access during build and fail for the same reason as npm does
***daviid` is now known as daviid
***civodul is now known as civodul`
***civodul` is now known as civodul
<sneek>nckx: wb :)
***iridium.libera.chat sets mode: +o ChanServ
<asdf-uiop>Hi guix
<asdf-uiop>I deleted a partition and didn't think of removing it from my configuration. Now I cannot boot.
<asdf-uiop>Or rather it boots into a guile/bournish shell.
<asdf-uiop>I trued to edit my configuration, but either vim, emacs etc are not there or i just dont know how to access them
<asdf-uiop>And I wasn't able to find documentation
<asdf-uiop>Being on a phone doesn't make the search any easier
<asdf-uiop>Old generations don't work either
<jgart>hi guixers!
<jgart>in the case of a cl library that vendors another cl library what is the recommended/usual thing to do? https://github.com/byulparan/cl-collider/tree/master/osc
<jackhill>is what is produced by `guix build -S rust-fiat-source` really considered source? All the files have a header saying that they were autogenerated and to not edit them. I was expecting the source to be the Coq code
<jackhill>er, of course I meant `guix build -S rust-fiat-crypto`
<Haider>A small question. Do any of you know how to compile the emacsql database required by org-roam? Whatever I do I get the error: "emacsql-sqlite-ensure-binary: No EmacSQL SQLite binary available, aborting"
<Haider>I (in my perspective) have done everything properly. I have no idea what to do here.
<jackhill>looks like the issues.guix.gnu.org cert has expired
<nckx>jackhill: Thanks.
<jackhill>nckx: you're welcome
<asdf-uiop>Haider: I think you have to have to have gcc, make etc installed in your profile