IRC channel logs

2021-07-24.log

back to list of logs

<ArneBab>one reason why guix is awesome: guix environment --ad-hoc --pure guile guile-wisp mercurial wget bash coreutils grep findutils -- bash -c 'mkdir -p /tmp/eval-r7rs/; cd /tmp/eval-r7rs/; wget https://ecraven.github.io/r7rs-benchmarks/all.csv; hg clone --insecure http://hg.sr.ht/~arnebab/wisp; cd wisp/examples; for i in $(cat ../../all.csv | cut -d , -f 1 | grep \- | sort -u) s7; do ./evaluate-r7rs-benchmark.w ../../all.csv $i 2>/dev/null |
<ArneBab>tail -n 1 | xargs -i echo {} : $i; done | sort -h; echo'
<atka>platoxia`: could you explain what I did wrong? I am running the 1.3.0 qemu image, I copied the configuration.scm from /run/current-system/configuration.scm to /etc/config.scm, changed the keyboard layout and ran sudo guix system reconfigure /etc/config.scm and it broke image, it fails to boot now unless I roll back to previous configuration.
<vivien>Arnebab, I would not run a script that has been downloaded with a --insecure switch :P
<ArneBab>vivien: good catch — and I agree. I didn’t manage to get ssl-validation working. If you know which package is missing to make the clone work with pure, I’d be very grateful!
<ArneBab>(without --pure it works, but that’s not the point :-) )
<vivien>I would try nss-certs
<vivien>maybe with gnutls
<vivien>Basically, any package that is remotely connected to TLS
<ArneBab>that didn’t work (I tried)
<vivien>(I’m not sure it’s a good pun, but hey at least I tried)
<ArneBab>(nss-certs)
<ArneBab>:-)
<vivien>Seems like you need both openssl and nss-certs
<vivien>Don’t ask me why though ^^
<vivien>I mean: openssl litterally has "SSL" in its name
<vivien>So why not
<ArneBab>Got it working — thank you!
<ArneBab>guix environment --ad-hoc --pure guile guile-wisp mercurial wget bash coreutils grep findutils nss-certs openssl -- bash -c 'mkdir -p /tmp/eval-r7rs/; cd /tmp/eval-r7rs/; wget https://ecraven.github.io/r7rs-benchmarks/all.csv; hg clone http://hg.sr.ht/~arnebab/wisp; cd wisp/examples; for i in $(cat ../../all.csv | cut -d , -f 1 | grep \- | sort -u) s7; do ./evaluate-r7rs-benchmark.w ../../all.csv $i 2>/dev/null | tail -n 1 | xargs -i echo {
<ArneBab>} : $i; done | sort -h; echo'
<vivien>Among the different people that want to attack my email server, some are ashamed of themselves, some are not. Looking at you, einstein.census.shodan.io
<ArneBab>:-)
***califax- is now known as califax
<apteryx>ArneBab: GnuTLS only consults /etc/ssl/certs, it doesn't use environment variables; so --pure or not shouldn't matter so long as your certs are found in /etc/ssl/certs
<apteryx>(wget uses gnutls)
<apteryx>ah, but hg
<apteryx>yeah that one probably needs openssl installed along nss-certs (openssl *does* use an environment variable to find the certs)
<KittyOwO[m]>I am curious if anyone would be familiar if anyone has messed with reproducible machine learning? I am quite curious if it would be possible for someone to make a reproducible machine learning denoiser, given that is a niche that actually seems to work quite well for that type of garbage lol
***daveed is now known as uu
***ecraven- is now known as ecraven
<ArneBab>apteryx: yes — and it works now!
<ArneBab>apteryx: It is pretty cool that I can send someone a single command that does not modify the usual environment but provides all the tools needed to run my code with very little overhead
<bricewge>Hello Guix!
<tissevert>hi guix
<KittyOwO[m]>hello bricewge ! , hello tissevert ! uwu
<tissevert>: ) KittyOwO[m] I haven't but I'll possibly have to at some point (I'm doing NLP) so I'm curious if you manage to do anything with ML, and if I make any progress on my side I'll let you know
<the_tubular45>Anyone has a guix pentesting man file ?
<the_tubular45>I'll be starting one myself and looking for inspiration
<the_tubular45>I guess I should only start with a WM, and slowly work my way from there ...
<KittyOwO[m]>tissevert: I do not do anything with machine learning, I was just curious as something like that if/once it exists would be sensical for use with my renders. I sometimes do art lol
<the_tubular45>So, nobody here uses ZFS successfully at all ...?
<the_tubular45>How do you guys keep your important data ?
<dstolfa>backups, backups and more backups
<the_tubular45>Good point
<the_tubular45>I have those too
<gxr>Hi there. I'd like to mount cifs shares via fstab. Somehow cifs is not available for the mount command. Therefore I cannot use fstab. I configured mount.cifs to be in /run/setuid-programs/mount.cifs. So I can mount my network shares via mount.cifs command, but not with mount -t. Any ideas?
<civodul>gxr: hi! could be that you need to add the package that provides mount.cifs to 'setuid-programs', no?
<civodul>oh you already did, i misread
<civodul>hmm dunno
<gxr>civodul: You are actually right ;). For some reason I did not install cifs-utils. I might have missed it in my config. Now I have installed it, and it works almost as expected. I can do a 'sudo mount /mnt/myshare' and it does the job. Now I am trying to fix that I need sudo to mount. I like to do it as the user.
<gxr>civodul: I think I know how to solve my issue. In https://lists.gnu.org/archive/html/help-guix/2020-12/msg00079.html suggests a patch for util-linux to add an additional search path to fine setuid-programs.
<gxr>civodul: Do you have an idea how I could apply the suggested patch from nckx to the util-linux package? I know how to do it for non-system packages via custom channels.
<bricewge>gxr: I would built guix localy (doc 16.1 and 16.2) with the patch applied to it https://guix.gnu.org/manual/devel/en/guix.html#Building-from-Git
<bricewge>Maybe there is a less involved way to achieve this; but when you managed to build guix locally you will be able to modify any part of the system
<civodul>gxr: i second what bricewge wrote
<civodul>you could also try out the util-linux patch by running "guix build util-linux --with-patch=xyz.patch"
<civodul>but in the end, you'll want that part of Guix proper
<civodul>in other news, https://hpc.guix.info/browse (hpcguix-web) can now display channels and links to package definitions
<gxr>civodul: I would like to try your option. What format should the xyz.patch have?
<MysteriousSilver> diff -Naur original-file edited-file
<civodul>gxr: it should be a patch generated with 'git diff' or with 'diff' as MysteriousSilver writes
<civodul>actually the option is --with-patch=util-linux=/path/to/xyz.patch
<MysteriousSilver>why is specifying the name of package a second time needed? does it imply that it is possible to use the patch of another package?
<gxr>MysteriousSilver: From the manual: guix build coreutils --with-patch=glibc=./glibc-frob.patch
<MysteriousSilver>ah, so does it mean coreutils is build with custom glibc?
<gxr>MysteriousSilver: Never tried, but it seems like you can apply patches to certain packages before building a package which depends on that particular package.
<civodul>yes, the patch is applied to a package that's potentially deep down in the dependency graph: https://guix.gnu.org/manual/en/html_node/Package-Transformation-Options.html
<gxr>civodul: I am in a guix environment within the official guix repo. I am trying to 'guix build util-linux --with-patch=util-linux=./util-linux_setuid.patch'. It tells me that it can't find the files mentioned in the patch. I used 'git diff' to produce the patch.
<civodul>gxr: could you paste the patch?
<civodul>for instance on https://paste.debian.net
<calher>Saluton, Giksoj.
<gxr>civodul: https://paste.debian.net/1205476/
<civodul>calher: saluton!
<civodul>gxr: the patch LGTM, but it's a patch against Guix, not against util-linux (i misunderstood you wanted to patch)
<civodul>to i guess you could try: guix build guix --with-patch=guix=./the-patch.patch
<civodul>a bit of a sledgehammer, but should work
<gxr>civodul: haha. Yes indeed a sledgehammer. Is there no other way to build util-linux with my changes?
<maximed>gxr: Do ./pre-inst-env guix build util-linux from the git clone
<maximed>That's the conventional method of testing changes in guix itself afaik
<maximed>(it appears bricewge and civodul already suggested this)
<gxr>civodul: I successfully built util-linux with the command provided by maximed plus '---with-patch=guix=./the-patch.path'. I use the mount command directly from the store with its absolute path. It seems that it applied the path, since the change is working. How can I apply the freshly built util-linux to my system, so that the regular 'mount' will
<gxr>use the patched version instead of the default?
<gxr>civodul: *patch, not path
<maximed>if you're working from the git clone, why are you doing "--with-patch=guix=./the-patch.path"
<maximed>I assume you made the patch with "git format-patch HEAD^..HEAD"
<maximed>if the patch is applied locally, then you can just do "./pre-inst-env guix system reconfigure ..."
<maximed>"./pre-inst-env": Use the git clone, instead of the latest version from "guix pull"
<gxr>maximed: I just did 'git diff > the-patch.patch', nothing more. So in order to install I need to reconfigure the system, but use the guix git clone in which I changed linux.scm which provides util-linux? If I test my changes and like to see them in guix latest version, how would I continue from there?
<maximed>not sure what you mean with "install" ("guix system reconfigure" or "guix install", with "./pre-inst-env"?), but yes, that's how you can test out local changes to guix
<maximed>There's a section in the manual I believe (‘Contributing’ or something like that)
<maximed>you can read it with the command "info '(guix)"
<maximed>(or read the HTML documentation online)
<maximed>basically, you'll need to send the patch to guix-patches@gnu.org
<maximed>(A commit message is required though, so you'll need to do "git add -p", "git commit" and "git format-patch HEAD^..HEAD" or the like)
<maximed>* "info '(guix)'"
<gxr>maximed: Thanks for the help. I'll consider submitting a patch after my tests. Thank you also to civodul and bricewge!
<jorge[m]123>Hola, estoy presentado un errror initializing operatin system under /mnt
<jorge[m]123>error: /gnu/store/certs/NetLock_Class_Gold
<maximed>I have no idea how you would end up with the file name "/gnu/store/certs/NetLock_Class_Gold". Could you paste the system configuration? (paste.debian.net)
<maximed>(/gnu/store/certs/NetLock_Class_Gold is not a valid store path)
<maximed>(though /gnu/store/HASH-nss-certs-VERSION/etc/certs/NetLock_Class_Gold could be valid)
<jorge[m]123>/o error: /error/gnu/store/2f032p23rgg56kkn1q7hl0vzqyr7k5-nss-certs-3.59/etc/ssl/certs/Nnetlock Arany =Class Gold=F??tv??ny:2.6.73.65.44.228.0.16.pen:No such file or directory
<tschilptschilp23>Hi guix!
<Guest23>Hey everyone. I'm having quite some issues with locales on my guix system. Gnome-terminal immediately exits with status 8 when opened, and even flatpak applications like Element have locale errors that make them unusable `Could not fetch translation json for locale: 'en-us' Error: Cannot find module './i18n/strings/en-us.json'. Anyone have any
<Guest23>ideas how these issues can be avoided or troubleshooted?
<Guest23>In my system configuration I my locale set as follows: `Could not fetch translation json for locale: 'en-us' Error: Cannot find module './i18n/strings/en-us.json'`
<Guest23>*`(locale "en_US.utf8")`
<gxr>Guest23: What is the output of the `locale` command?
<Guest23>`LANG=
<Guest23>LC_CTYPE="POSIX"
<Guest23>LC_NUMERIC="POSIX"
<Guest23>LC_TIME="POSIX"
<Guest23>LC_COLLATE="POSIX"
<Guest23>LC_MONETARY="POSIX"
<Guest23>LC_MESSAGES="POSIX"
<Guest23>LC_PAPER="POSIX"
<Guest23>LC_NAME="POSIX"
<Guest23>LC_ADDRESS="POSIX"
<Guest23>LC_TELEPHONE="POSIX"
<Guest23>LC_MEASUREMENT="POSIX"
<Guest23>LC_IDENTIFICATION="POSIX"
<Guest23>LC_ALL=`
<gxr>Guest23: you can use https://paste.debian.net/ for longer outputs and just paste the link here.
<Guest23> https://paste.debian.net/hidden/4e25c293/
<civodul>jorge[m]123: ¿puedes enviar todo lo qué escribe "guix system"? https://paste.debian.net
<gxr>Guest23: I suggest setting your locales in a functional terminal first, e.g. xterm before starting other applications which have issues with the locales. You could set 'export LC_ALL="en_US.UTF-8"' in such a terminal and run the locale command again. All locales should have changed. If that fixes your problems, you can make them permanent by
<gxr>setting them in your .profile or .bashrc etc.
<gxr>Guest23: You must start the problematic applications from that terminal, in which you've changed the locale settings
<Guest23> https://paste.debian.net/hidden/1d174e2b/
<Guest23>Unfortunately, despite the environment variables being changed, the errors persist.
<gxr>Guest23: It could also be that the applications grab the locale settings from somewhere else.. in such a case you should set your locales persistently, in your .profile and .bashrc etc. You need to relogin to your graphical environment to apply the changes. I am not sure though your errors are directly related to the locales..
<Guest23>Interesting. Do you think this could be a conflict with Gnome settings? I had to manually set keyboard layout and formats since entering them into my configuration file did not seem to work with gnome.
<Guest23>Or is there any other information I could provide that might help narrow down the problem?
<Guest23>Even running `LANG=en_US.UTF-8 gnome-terminal` results in the same issue
<gxr>Guest23: I don't use gnome, but I would not exclude an issue related to what you are thinking. Try to set everything as consistently as possible, even if you are using a different keyboard layout than en_US. Try different combinations and look for certain packages to be installed. For example look if you have glibc-locales installed. There is
<gxr>another package which provides just a subset of the available locales.
<Guest23>`glibc-locales` wasn't installed at all
<gxr>Guest23: I set my locale exactly like you. I also set locale-definitions explicitly for different languages. For example: (locale-definition (name "en_GB.utf8") (source "en_GB") (charset "UTF-8")). I put those definitions in a list and hand them to (locale-definitions ...) in my operating system config.)
<tschilptschilp23>Does anyone know what changes regarding graphics comparing the 5.10.x-series and both of 5.12.x and 5.13.x? I'm asking, because if I adapt my 'pinned'-kernel-setup to use any of these, my laptop screen blanks out shortly after entering the decryption key for the second time. I am on gnome, but just tried it with mate (through reconfigure, removing gnome) and yield the same result. Actually, graphics are not totally down, because I can
<tschilptschilp23>attach an external monitor via hdmi and this one gets signal (but that's not making my laptop very usable). I post my config below, from which I write now with the monitor screen working. If I change the kernel to 5.12.17 or 5.13.2 the laptop screen blanks and only external monitors work (unplugging these makes it feel like a black screen).
<tschilptschilp23> https://paste.debian.net/1205480/
<Guest23>gxr installing `glibc-locales` and changing my configuration file to express locales in the same way you did. Will logout and report back. Thanks!
<gxr>Guest23: Good luck.
<bricewge>tschilptschilp23: I also have graphical issue with 5.13 compared to 5.12, hardware acceleration is sluggish (around 1fps) in any app using like alacritty or mpv
<bricewge>I have no idea what is the issue here, I'm hoping next relased will fix it
***LispyLights is now known as Aurora_v_kosmose
<jorge[m]123><civodul "jorge: ¿puedes enviar todo lo qu"> No deja pegar la imagen 413 Request Entity Too Large
<tschilptschilp23>bricewge: thanks for letting me know! I'm waiting for a while now already for a 5.12 or 5.13 for me to work. but I'm pretty happy with the 5.10 in all other ways!
***davii is now known as daviid
<jeko>Yooo Guixters
<jeko>Yooo Guixters
<the_tubular45>o7
<cky>I couldn't find a Guix FAQ or anything, but, how do you search packages in Guix? Similar to packages.debian.org or the like. :-)
<jeko>there is the command line "guix search hello"
<cky>Awesome, thanks! No web interface, eh? Okay.
<bricewge>cky: https://hpc.guix.info/browse
<jeko>cky: there is also this https://hpc.guix.info/browse
*cky looks. Thanks!
<jeko>haha
<calher>I'd love a GNOME Software interface to Guix. Who do I pay?
<dstolfa>calher: there are a few people here who understand gnome pretty well i would say, given that they've been making it work on guix. if you're willing to pay them as you say, it sounds like something that could indeed happen :D
<calher>dstolfa: Who is working on GNOME?
<dstolfa>calher: raghavgururajan has been working on getting GNOME 40 into guix with all the guix goodness, i assume there are a few others too
<calher>Mm... GNOME 40...
<cky>If you're referring to GNOME Software as in the package management GUI, I know Ubuntu has its own adaptation of it, and it could be a useful starting point for a Guix version.
<cky>(The diff between GNOME Software and Ubuntu Software, I mean.)
<calher>cky: Ubuntu forked the entire thing? That isn't efficient, form an engineering perspective.
<cky>calher: I haven't looked in depth but I think Ubuntu Software is just extra modules that work atop GNOME Software.
<the_tubular45>bricewge I swear to god, sometimes I click on this link and it redirects me to https://guix.gnu.org/en/packages/