IRC channel logs

2021-01-25.log

back to list of logs

<roptat>since we've switched to pootle, should we extend packages.pot to translate every package (and not a subset of the package modules)?
<roptat>civodul, not sure, but I think there's an issue here: https://git.savannah.gnu.org/cgit/guix/guix-artwork.git/tree/website/apps/base/templates/cuirass.scm#n54
<roptat>should there be a (G_ ) around the (li)?
<civodul>roptat: well, thanks for taking a day to do that!
<civodul>re packages.pot, i agree
<civodul>well, perhaps we'll still exclude things like Go packages, there's just too many tiny packages...
<civodul>\
<civodul>roptat: re missing G_, you may be right, but i'm still not super familiar with that
<roptat>yeah, I managed to generate a pot that looks correct that way, so I'll push that
<roptat>(and the website looks correct after generating it)
<civodul>great
*civodul -> zZz
<civodul>later!
<firstlove>is it necessary to "guix system reconfigure" everytime I update linux-arguments in /etc/config.scm?
<vagrantc>firstlove: it is necessary to reconfigure whenver you change anything in config.scm and you want it to take effect
<firstlove>vagrantc: thanks, but reconfigure takes quite a long time :(
<iyzsong-w>if you haven't update guix and its channels, it shouldn't be too long..
<firstlove>Yes, I have update the guix and channels
<iyzsong-w>yeah, then that will depends on luck :)
<sundbry>Hello Guix hackers, does anyone have a good development flow to recommend how to modify guix sources in place without doing a `git commit` and `guix pull` cycle?
<sundbry>Suppose I want to change some package and modify some modules it depends on and just test that it runs
<sundbry>I suppose I could try hot loading code REPL style, but I am a vim person
<lfam>sundbry: The Guix development workflow described in the manual section Contributing is quicker than `guix pull`
<lfam> https://guix.gnu.org/manual/en/html_node/Contributing.html
<lfam>Check the instructions in Building from Git and Running Guix Before It Is Installed
<sundbry>I see, reading 16.2 now thanks
<lfam>The point is to get the 'pre-inst-env' scripts, and then use it to run your guix commands
<apteryx>raghavgururajan: still having issues with btrfs? Had you changed the faulty disk that caused the problems you've had in the past?
<atkka>has anyone successfully installed guix system using the installer? I have tried multiple computers, version 1.2.0 and snapshots. I haven't been able to get a bootable system or even finish the install in one go...
<lfam>Yes, it has worked. What goes wrong?
<atkka>lfam: the installer has hung while downloading from ci.guix.gnu.org at somepoint during the installation on every attempt (I'm at attemp 7 or 8 today alone). I have tried both encrypted and unencrypted partition layouts, if the installer actually makes it to the end to reboot, I boot into grub recovery without a viable filesystem
<atkka>also the installer will only accept my keyboard layout on external keyboard, laptop keymap stays qwerty, this happens on multiple computers
<atkka>I normally chroot install my distros so I'm not too woried about using the terminal method, since I'm new to guix I wanted to try the automated installer to get a config to start from though
<atkka>another install just failed
<atkka>got to the end, hung on reboot, grub: unknown filesystem
<apteryx>:-/
<apteryx>you are using the installer as simply as possible (without tweaking many options?)
<atkka>apteryx: yes, just going through as basic as possible
<atkka>I have tried many different things now though
<apteryx>that's strange! Could it be that it selects the wrong kind of grub? e.g., grub-bios instead of grub-efi
<sundbry>what are yo talking about chrooting your distros?
<atkka>sundbry: I usually set my distros up by hand over a chroot from a live media instead of using installers
<atkka>I do this for alpine and void
<sundbry>I have a script that can do it from a livecd
<sundbry>I will share with you
<sundbry>it took me a few days to get it towkr
<sundbry>to work
<atkka>thanks, I'll take a look at it
<sundbry>i used a SystemRescueCd on some server I wanted it on
<atkka>apteryx: I'm not sure what the issue it
<atkka>on the two computers I've tried there's issues with the keymap on both, install fails on both, using just the defaults and the installers proposed partitioning
<atkka>also, every single install hangs at some point during the download portion, it will start downloading the files from the ci, then a random file with stop downloading in the middle and sit forever, I have to restart the installer and resume from the last step
<sundbry>@atkka https://gist.github.com/sundbry/5c435b0d35576b9863710b48b675d363 Try this
<sundbry>I had some hacks in there to run on old kernels < 3.10 without CONFIG_USER_NS but with User namespaces it should work better
<atkka>sundbry: thanks, I bookmarked it, I'll go through it sometime, need to take a break for an hour or so
<sundbry>Theory of operation for the script: Downloads the Guix binary distribution (not system dist) and installs it on a /mnt chroot to bootstrap itself. Once that is installed it will `guix system init /` on itself to install Guix System Distribution from your inline config.scm
***janneke_ is now known as janneke
<sundbry>@lfam so I have a repl running with the pre-inst-env, it recompiled all of the dependent modules when I did (load "gnu/packages/clojure.scm") [the file I am hacking], which although that was somewhat slow was not a problem. Now I want to test building it with `guix build clojure` naturally, so I loaded (use-modules (guix ui)) inteinding to call (guix-main ...)
<sundbry>which loaded some more modules and broke on gnu/packages/commencement.scm, which looks from the comments in that file like it should not be loaded at all
<sundbry>How do you do your repl flow with testing package builds?
<sundbry>hm it seems if I just ignore the pre-inst-env and use guile in the default environment it wont bother recompiling the world which works out fine
<firstlove>what's herd equivalent of systemctl start sshd? I cannot find any services like sshd/openssh and etc with "sudo herd status".
<sundbry>@firstlove `sudo herd status` for all services
<sundbry>ssh is `ssh-daemon`
<firstlove>I have check herd status, but I cannot find ssh-daemon, should I install some other packages?
<lfam>sundbry: For building packages I don't use the repl. I do `./pre-inst-env guix build --no-grafts $package`
<apteryx>rekado_: the most problematic uses of PYTHONPATH post GUIX_PYTHONPATH_X_Y have been amended in this branch: https://git.savannah.gnu.org/cgit/guix.git/log/?h=cu/farewell-to-pythonpath, if you are curious about what it entails.
<sundbry>@firstlove you need to add the ssh service to your /etc/config.scm
<apteryx>I've taken the opportunity to add augment the python build system a bit to get rid of more PYTHONPATH boilerplate in the check phases.
<sundbry> https://guix.gnu.org/manual/devel/en/html_node/Networking-Services.html
<sundbry>then `guix system reconfigure /etc/config.scm` after you add openssh-service-type
<firstlove>sundbry: thanks!
***apteryx_ is now known as apteryx
<firstlove>Is there a cli patch-source-shebangs for guix?
<firstlove>I am strungling with shebang issues when build kernel on guix
<raghavgururajan>apteryx: Yeah, fixed the issue. The old is long gone. I have been using new one.
<raghavgururajan>*old disk
<davidl>My store is totally corrup after a failed btrfs-convert, is it possible to "reinstall" the store by booting to the guix installer, mounting and removing /gnu/store and then doing the normal herd start cow-store /mnt, guix system init procedure? Or are there for example files outside of /gnu/store that keeps tracks of links and things that would cause issues when rebooting to disk?
<davidl>Im currently running guix gc --verify=repair,contents but Im not sure thats gonna fix it.
<davidl>an example error: root@librem13v3guixsd ~# guix gc
<davidl>finding garbage collector roots...
<davidl>guix gc: error: cannot unlink `/gnu/store/trash/bv6hr5kvaf7wsr98xzbppa2iv9d36vhb-profile/share/help/ja/gnome-help/figures/color-camera.png': No such file or directory
<jlicht>hey guix!
<rekado_>davidl: have you tried “guix gc --verify=repair,contents”?
<efraim>I know I can use #:system to build for a system, is there something like #:target to target a specific system? and still work as cross-compiling?
<jlicht>Is there an example configuration on how get started with Guix' openvpn-server-service?
<efraim>oh, it looks like it works, but (cc-for-target) doesn't give me what I was hoping for
<davidl>rekade_: hi, yes and it finally just finished without error. Now I have issues with dead links in the /gnu/store/.links dir - which I am currently removing (will run guix gc --optimize again after). Maybe things will work after this.
<davidl>s/rekade_/rekado_
<raghavgururajan>Hello Guix! o/
<iyzsong>Hello :))
<zimoun>hi!
<zimoun>On Guix System, is it possible to install Debian package? Does something like “guix environment --ad-hoc dpkg -- sudo dpkg -i ./foo.deb” work? Some scientific packages I need are in Debian and not yet in Guix.
<civodul>o/
<civodul>zimoun: i don't think that could possibly work
<civodul>i'd suggest using a container running Debian
<civodul>better yet: package the missing pieces in Guix! ;-)
<zimoun>container coming from where?
<zimoun>why that could not work? Because writing in /usr/ and co? Something else?
<iyzsong>install a dpkg package need install all its dependencies too, which mean bring the whole debian system, i guess
<iyzsong>and you better just install it in a debian, instead of turn guix to debian...
<zimoun>iyzsong: what does “it” refer in “just install it in a debian”?
<iyzsong>that scientific package?
<iyzsong>what are you going to install?
<zimoun>so your are suggesting to install in a container running Debian, right? So container coming from where?
<efraim>do we have a build system for d?
<iyzsong>you can try docker, but that scientific need to be able running in a docker container too.
<iyzsong>zimoun: for docker, container image (eg, debian:10) can be pull from dockerhub
<iyzsong>efraim: 'dub-build-system' for dlang?
<efraim>iyzsong: thanks. in the end it looks like a regular autoconf project using d
<iyzsong>cool :)
<zimoun>well, you said «install a dpkg package need install all its dependencies too, which mean bring the whole debian system» so same story with any container. ;-) My question is if there is a technical reason that prevents to install Debian package on Guix System?
<zimoun>And to answer to my question “container coming from where”? From https://github.com/debuerreotype/debuerreotype/blob/master/examples/debian.sh :-) Now, my question: does this script could work on Guix? :-) Other topic.
***leoprikler_ is now known as leoprikler
<efraim>zimoun: I suppose, if you want to, you could use dpkg and override admindir and use a different root and use --force to get it started. dpkg --help lists some options if you really want to go that route :)
<zimoun>efraim, thanks! I will give a try… first in a Guix VM. :-)
<nefix>Hello! How can I add `libGL.so.1` for both 32 and 64 bits? I've tried to add meson in inputs and propagated inputs with no luck. Thanks!
<raghavgururajan>nefix: Its 'mesa' not 'meson'.
<mjsb>Buongiorno :) ! I was wondering: is awesome "Guix Days" conference having place ? Haven't seen the related blog news yet
<nixo_>mjsb: Hi! there was a mail from Pjotr titled "Guix Days and FOSDEM 2021" on the mailing list, here's the link published: https://libreplanet.org/wiki/Group:Guix/FOSDEM2021
<nixo_>ops too late
<bdju>what to do about this error when trying to update? guix pull: error: open-file: Permission denied: "/home/brad/.cache/guix/checkouts/last-expiry-cleanup"
<roptat>bdju, you probably used sudo with guix at some point?
<bdju>not on this machine. I always use aliases and so my commands are not changing
<roptat>it's just a cache directory, so you can remove the whole ~/.cache/guix directory (though you'll need root for that, it's probably been touched by root)
<bdju>well, anything is possible I guess
<bdju>alright
<roptat>you could check, but none of these files should be owned by root
<bdju>looks like root owns that exact file but the dirs and such are all owned by my user
<roptat>wrong $HOME while running guix as root can create this kind of issues
<roptat>mh... last-expiry-cleanup sounds like a recent addition
<bdju>should I just delete that one file and pull again?
<bdju>or chown and chgrp it...
<roptat>yeah, I'd chown it
<bdju>so far so good after doing that and then trying to pull again. thanks for pointing me in the right direction
<roptat>did the file change ownership again?
<GNUtoo>hi, jami requires something named 'dring', is it packaged in Guix?
<roptat>guix search dring returns nothing
<roptat>although we have a jami.scm that says it's in libring
<GNUtoo>"Error : dring is not available, make sure it is running"
<GNUtoo>I'll install libdring
<roptat>mh... we already have a jami package
<GNUtoo>yes, that's what I used
<GNUtoo>I'll now install libring and launch ringd
<GNUtoo>thanks
<roptat>according to the comment I found, dring should be started automatically by dbus
<bdju>roptat: hasn't changed owners again so far
<roptat>bdju, good
<GNUtoo>I've a ring.cx but not dring
<GNUtoo>maybe it's not exported somehow
<GNUtoo>it's in lib/ring/dring in some dirs in /gnu
*GNUtoo found it in /gnu/store/j9j0aqpjmzivaq8824lvni6gjjf6949a-libring-20200710.1.6bd18d2/lib/ring/dring
<GNUtoo>Thanks a lot
<ekaitz[m]>i'll use GNUtoo's message as an excuse
<ekaitz[m]>is there any simple way to ask guix to show the store paths for a package?
<ekaitz[m]>package -l does it, but I don't find a way to search by one package
<ekaitz[m]>or for packages that are built but not in current profile or so, and I find myself grepping in the whole /gnu/store
<Anonymous_>grep the output ekaitz[m]
<Anonymous_>I did this way
<ekaitz[m]>yeah, looks like grep is the solution for everything :D
<ekaitz[m]>but it's not very accurate in some cases
<ekaitz[m]>i can live with that though
<Anonymous_>package --list-instaled | grep pkgname
<Anonymous_>ops
<Anonymous_>guix package --list-instaled | grep gcc
<Anonymous_>^ i just tested with gcc rn
<ekaitz[m]>yeah, but in environments? or for builds that are not installed but there are in the store?
<ekaitz[m]>`guix gc` should be able to do something about that too, right?
<Anonymous_>Oh we can just put the regex after list installed i read it from help now
<Anonymous_>guix package --list-installed=pkgname
<Anonymous_>well i confess
<Anonymous_>I grep the ls of /gnu/store
<Anonymous_>haha
<Anonymous_>I will wait for the answer of some more experienced user, I dont know it properly ekaitz[m] :|
<roptat>ekaitz[m], "guix build foo" will show you the store path (after it builds the package if it's not yet in store)
<ekaitz[m]><roptat "ekaitz, "guix build foo" will sh"> Oh! True! i forgot about that
<ekaitz[m]><Anonymous_ "I grep the ls of /gnu/store"> :D I do too
<Anonymous_>I did it most of times i got lazy when the linker is not finding some library
<Anonymous_>I use find sometimes too,, then i just pust the path in LD_LIBRARY_PATH
<raghavgururajan>Which package provides `setfacl` program?
<roptat>probably acl
<roptat>yes, acl
<nefix>raghavgururajan: yeah, I have mesa, not meson. I think the issue is that I'm using python-build-system
<raghavgururajan>netfix: So while building you see something like .../lib64/foo not found?
<cybersyn>is anyone here using the meson build system on guix? i just installed it, and while the guix install went fine, there is an error when i'm trying to run it. i'm not familiar with meson, as its the build system for Akira UX, free UX design software that I want to package, so any help is appreciated
<cybersyn>does anyone perhaps know a recent working commit?
<cybersyn>if anyone is interested in seeing the backtrace http://paste.debian.net/1182720
<jlicht>cybersyn: what ouput does `guix describe' give? And do you get the exact same error if you run `guix environment --ad-hoc meson -- meson' instead of simply `meson'?
<raghavgururajan>is %fuse-control-file-system part of %base-file-systems?
<jlicht>s/ouput/output
<mdevos>raghavgurajan: I don't think so, but it's easy to verify: run "git grep -F %base-file-systems" in a git clone of guix
<nixo_>Hi, is import of module (gnu packages electronics) somehow broken? I get "error: binutils: unbound variable", seems to happen when importing "(gnu packages embedded)"
<cybersyn>with guix describe, it shows what is expected, my current generation, the savannah repo and the commit hash
<cybersyn>on second let me try the env, good idea!
<nixo_>The error seems to be in propeller-binutils
<bdju>got a build failure on kdenlive because of kwayland failing it looks like
<cybersyn>jlicht: i think this will work, thanks for the tip
<apteryx>nixo_: ./pre-inst-env guix repl; ,use (gnu packages electronics) works on master
<apteryx>commit f9bd4621dd92a9415276706b476b9bd2973411fa
<apteryx>cybersyn: some packages wants an exact version of meson
<apteryx>try installing meson@0.55
<nixo_>apteryx: true, but can you try adding #:use-module (gnu packages electronics) to admin.scm
<nixo_>guix repl does not complain, yet then I cannot build anything from admin
<apteryx>you probably introduced a module cyclic dependency
<apteryx>there must but an import on admin in the electronics module
<apteryx>you can't have it both ways
<apteryx>I'm not sure if there was a way to visualize (graph) module dependencies
<apteryx>I haven't done much work at that level.
<apteryx>Perhaps rekado_ ?
<nixo_>apertyx: oh yes, embedded uses admin
<nixo_>what's the way to get around it?
<apteryx>factoring common stuff in a third module
<apteryx>then both embedded and admin can refer to that new module as a dependency
<apteryx>that's the way I know, at least
<nixo_>Ok thanks
<apteryx>this is horrible: phase `check' failed after 4076.4 seconds
<apteryx>nss package on core-updates
*apteryx bumps nss to 3.61; now waits for the tests another hour
<quelle>hello! i cannot modify the config file in order to add the nix services.i looked at the guix manual but i miss something. can someone help me??
<roptat>quelle, can you share your config file and what you tried to do (for instance via paste.debian.net)?
<quelle>i have a basic config file generated from the grafical installation and trying to modify it addind whot i found here...https://guix.gnu.org/manual/en/html_node/Miscellaneous-Services.html
<quelle>in the session about the nix services
<roptat>so, do you have an error message or something?
<quelle>yes. i got: duplicate field initializer
<roptat>does this duplicate field have a name?
<quelle>is the packages...
<roptat>ok, you need to have only one (packages ...) field in the operating-system declaration
<roptat>(same for the services field)
<quelle>ok. let me try
<roptat>so you need to merge what you currently have with the packages field that's proposed in the manual
<quelle>yes... what about the voice append? need to be only one??
<roptat>yes, you need something that looks like this: (packages (append (list nix other-package other-package) %base-packages)))
<civodul>lfam: hey! i wanted to jump to "staging" but: "commit 8b55544212a90b0276df49596a3d373e5c2e8f5c, which is not a descendant of c03875b0361f114634caeb54935fe37a9b7b05af"
<roptat>you simply add nix to the previous list of packages
<civodul>lfam: looks like we lack a merge of master in staging?
<lfam>civodul: Are you saying the rollback protection kicked in?
<roptat>quelle, it's very similar for services: you'll add (service nix-service-type) at the beginning of the list of services you currently have
<lfam>civodul: I can merge master into staging now and push
<quelle>and each entry i ll add it will need to be in parentesis??
<roptat>around all the (service ...) things yes
<quelle>but around nix??
<roptat>no
<quelle>ok..it will be in quotes??
<roptat>no
<roptat>like this: (list nix emacs nss-certs)
<roptat>for the three packages nix, emacs and nss-certs
<roptat>of course you choose the packages you want to install system-wide, you don't have to install these three specifically :)
<roptat>well, it'd be easier if you shared your current config, I could show you
<quelle>ok. super...i belive i did it correctrly now.. i can just run conficure now??
<roptat>yes
<quelle>lets see!
<roptat>if it works but does something unexpected, you can always roll-back the entire OS, so don't be scared, you can experiment and make mistakes :)
<quelle>wow! thats lovely :)
<quelle>its downloadind pretty much stuff.. its that normal??
<roptat>yes, if you ran guix pull, it downloads updates to packages and services
<roptat>it means it's working :)
<quelle>but a just run reconfigure...
<roptat>it uses the latest packages it knows of, so it's normal (might also be that nix has lots of dependencies, but I don't think so)
<quelle>ok
<roptat>if you never ran guix pull, I think you'll get slightly older stuff than what the installer installed for you, but I'm not sure
<mdevos>quelle: is this a new install? The installation images on guix.gnu.org use a guix that's a little old. So when you run guix pull, and then install new/updated packages (e.g. via guix system reconfigure), then the new versions will be downloaded (or built if there aren't any substitutes yet)
<roptat>civodul, when we build the installer from the release commit, the installer system uses a guix daemon that's older than that commit, right? Then, when it installs the system, it installs a guix-daemon that's even older; when you reconfigure that system without pulling, you end up building something that's again older
<roptat>actually, if you never pull, don't you get an older and older guix every time?
<quelle>was not suppose to be a new install.. but im not sure what i did. i just run guix system reconfigure /path/to/new configfile
<roptat>quelle, have you ever run "guix pull" before?
<quelle>yes i did it. pretty often
<roptat>"reconfigure" is a full install anyway
<quelle>ok..so whas good i did or not??
<roptat>you did well, now you need to be patient and wait for the reconfigure to finish
<quelle>was needed to add nix services???
<quelle>ok. :) thankyou
<roptat>again, you didn't share your config, so I can't check, but I think it'll work
<atkka>the 1.2.0 installer doesn't support XFS out of the box?
<lfam>atkka: We support ext4, btrfs, JFS, and F2FS
<atkka>lfam: thanks, I'll try ext4 for now.
<civodul>roptat: that's correct
<civodul>regarding AArch64 build machines, i was told about these nice looking Pyxis devices: https://www.grid5000.fr/w/Lyon:Hardware#pyxis
<roptat>I'd be more interested in armhf :p
<civodul>i suppose it can do both?
<roptat>don't we have issues building armhf packages on aarch64?
<lfam>I don't think that CPU can do 32-bit, civodul
<lfam> https://en.wikichip.org/wiki/cavium/thunderx2#CN99xx
<lfam>We should find an authoritative source, but that wiki says "Only the 64-bit AArch64 execution state is support. No 32-bit AArch32 support."
<lfam>Would still be nice to get some
<que>roptat, i got an error.. error: symlink: Permesso negato: "/var/guix/profiles/system-2-link.new"
***que is now known as quelle
<quelle> roptat, i got an error.. error: symlink: Permesso negato: "/var/guix/profiles/system-2-link.new"
<roptat>are you running multiple guix processes at the same time?
<quelle>an error in the buildind fase..
<roptat>or maybe you're running "guix system reconfigure" as non-root user?
<lfam>civodul: I merged master into staging and pushed
<quelle>o no!!! i did it as a non super user!!! im very bad
<quelle>so.. i will run it again!!!
<roptat>well, it means it worked up to the point it created the OS (which is good, you won't have to do that again), but failed when it wanted to install it for real :)
<civodul>lfam: thanks, lemme give it a spin!
<quelle>ok.. super!
<civodul>lfam: re AArch64, not great then, i guess we'd rather have something that can do both
<civodul>OTOH, just a single 256-core board would be nice
<lfam>Yeah...
<quelle>it's finish!!! how can i test it now??
<lfam>By the way, civodul, do you know if we are using the overdrives now? A couple weeks ago it seemed they were idle, right?
<roptat>quelle, now you should have nix available as a command, you can try running it
<civodul>ah, not sure; i know mothacehe changed the way things work, but i haven't been able to catch up yet
<lfam>I saw some chatter about getting them building again, so I guess it's fine
<civodul>at least mothacehe got access to the one that's at my place
<civodul>lemme check
<quelle>the shell tells me :To complete the upgrade, run 'herd .should i run it?
<civodul>lfam: hmm it's idle and there's no dynamic offload daemon running
<civodul>not sure what's up; we should ping em tomorrow and probably give them a hand
<lfam>civodul: I'd expect everything to get busy soon since I just pushed that merge
<lfam>Okay, I'll be around tomorrow too
<roptat>quelle, I think it's fine not to run it, because the nix service should automatically be started when you just added it
<civodul>i'd expect things to be constantly busy actually
<lfam>Yes, me too
<lfam>Well I am doing my part
<lfam>To keep them busy :)
<lfam>It would be nice to add them to <https://ci.guix.gnu.org/workers>
<quelle>roptat,ok.. so now should olready work? im not supposed to set a channel and other thing like i read in the manual??
<roptat>quelle, well, I don't use nix, so I don't know. Now you have the nix daemon running and the nix tool too. You probably have to set things up like the manual says
<roptat>but that's outside the scope of guix, you're using another package manager now
<quelle>wow!! thankyou very much!!!! now ill try to set the other stuff
<quelle>i know...i love guix but i need to follow some pakages that are not available yet
<roptat>sure, don't worry :)
<quelle>but this means i cannot use guix anymore? or i can use both at same time??
<roptat>you can use both at the same time, they don't conflict
<roptat>you have guix as your system and as the package manager, as well as nix as a package manager only
<quelle>wow. guix is really an amazing project
<roptat>happy I could help :)
<quelle>thank you very much for your help. it was super!!!
<atkka>hello, can some on explain the second part of this (password (crypt "alice" "$6$abc"))
<atkka>the "$6$abc"
<quelle>may the light shine on you!!!!!! :)
<lfam>atkka: It's an example of an encrypted password
<lfam>You can ignore it unless you need to pre-provision user passwords
<lfam>You can just set the password imperatively in the "normal way" with the passwd program
<roptat>quelle, if you have time, you might consider packaging some of the packages you're missing from guix :)
<roptat>it's not as hard as it sounds, most of the time
<atkka>lfam: ok, thanks
<lfam>atkka: Did you read the documentation of that password field?
<atkka>I'm working through the manual right now, I was just reading the templates
<lfam> https://guix.gnu.org/manual/en/html_node/User-Accounts.html
<atkka>is the $6$abc" always the same?
<roptat>atkka, it's generated from your password
<lfam>I'd guess that almost no Guix users have password fields in their config.scm
<roptat>actually, it's a salt: https://www.gnu.org/software/guile/manual/html_node/Encryption.html#index-crypt
<roptat>so it can be the same, but it should be randomly chosen
<atkka>thats what I was thinking since its declared and in multiple examples despite the password being different
<atkka>thanks for clarifying
<quelle>roptat,actually i would really love. but i belive i need a mentor or something similar because for me the manuals really looks complicate and i always get stocked.maybe you can suggest me some links to have an easy start
<roptat>(if you click on "crypt" in the example, it gets you to that page in the guile manual)
<atkka>roptat: oh wow, that's really nice
<roptat>quelle, we have a fairly easy packaging tutorial, let me find it again
<roptat>quelle, https://guix.gnu.org/cookbook/en/html_node/Packaging-Tutorial.html#Packaging-Tutorial
***amiloradovsky1 is now known as amiloradovsky
<roptat>I'm afraid it's only available in English and German for now
<roptat>you could also contribute translations, that would be awesome :)
<joshuaBPMan>quell:  I am learning guix too.
<joshuaBPMan>I've got a lot of hacking videos on hardlimit...let me send you a link just a moment...
<joshuaBPMan> https://video.hardlimit.com/accounts/joshua_branson/video-channels
<joshuaBPMan>I've got a Guix Playlist in there that should help you out.  The videos are half-hour to an hour long.  I've currently working through making a sway service.
<joshuaBPMan>quelle:  sorry the above message was meant for you
<joshuaBPMan> https://video.hardlimit.com/accounts/joshua_branson/video-channels
<quelle>roptat,Thankyou very much.the lenguage is not a problem...i will study it!!! even if seems difficoult to me on a first look :)
<atkka>so, I'm running into the same issue I was having yesterday with the installer. I ran guix system init, downloaded several packages, now it has hung getting cdparanoia-10.2. been stuck at 71.4% for 15 minutes
<lfam>atkka: Can you share the URL?
<lfam>We can try downloading it
<atkka>ok, on sec, its on another computer
<lfam>You might also try to attach to the guix-daemon process with `strace -f` from another TTY, to see what it's doing
<lfam>You'd have to acquire strace with `guix environment --ad-hoc strace`
<lfam>If you want assistance, the more information you provide, the more likely you'll get help
<atkka>ok, i'll try that and then copy the url
<lfam>So, exact error messages, commands, computer type, did you follow the instructions carefully, etc
<atkka>lfam: https://ci.guix.gnu.org/nar/lzip/yrb8dfcf1ay6wfaqcr3y9k4bb94cyxld-cdparanoia-10.2
<lfam>atkka: It downloads fine, almost instantly
<atkka>it downloads just fine on another computer
<atkka>but it is stuck at 71.4% on guix, it stalls every attempt on a random file
<atkka>what info do you want from strace
<quelle>someone can help me whit this?...error: attribute 'nixpkgs' in selection path 'nixpkgs.pkgx not found
<quelle>is the very last step to meke nix pakage work on guixos.all the rest seems to work
<lfam>atkka: Whatever it shows, leading up the point where it gets stuck
<lfam>I mean, could it be that your network goes offline? Or, is the disk full? I/O stuck somehow?
<atkka>so in another tty strace -f guix-daemon?
<atkka>my network is ok, we are on the same one right now
<lfam>Get the PID of the main guix-daemon process and then do `strace -f -p $PID`
<atkka>lfam: select(4, [3], NULL, NULL, NULL
<lfam>Maybe with some more context...
<lfam>What is doing before that?
<roptat>quelle, I would rather ask nix people about that (sorry I don't use nix, so I can't help)
<atkka>that is literally the only line from strace -f -p 277
<lfam>Right, but try the thing again
<lfam>CTRL+C and re-run the command
<atkka>oh ok
<quelle>roptat,ok thankyou very much!!!! :)
<joshuaBPMan>quelle  So you are trying to run source /run/current-system/profile/etc/profile.d/nix.sh   ?
<joshuaBPMan>I personally use flatpak for not-icecat.
<atkka>trying to re-run guix system init /mnt/etc/config.scm /mnt/ returns: guix system: error: failed to connect to '/var/guix/daemon-socket/socket': Connection refused
<joshuaBPMan>atkka  Are you running that command as root?
<quelle>joshuaBPMan,yes.i was giving a try to nix,and yes i run that comand.
<atkka>joshuaBPMan: yes, I'm running from a tty using the guix 1.2.0 image
<joshuaBPMan>gotcha.  Do you have it working now?  Or do you still need some help?   I used to use nix-service, but the I just started using flatpaks.
<joshuaBPMan>atkka gotcha.  Ok you are doing the manual install....
<mhj[m]>Heyo all, quick question. I saw this on a git page before but forgot where to find it. I need to blacklist a kernel module for my wireless driver. Is there any examples of that for guix?
<atkka>joshuaBPMan: yes, after the main installer failing many times I decided to try manually but the same issues are happening, guix hangs at some point while fetcing stuff from the ci
<joshuaBPMan>Hmmm... Let me check through the manual
<lfam>atkka: What kind of computer are you using?
<joshuaBPMan>atkka  I always reccommend installing a "bare bones" install.  I'
<joshuaBPMan>Then you can update to a desktop system.
<atkka>i've tried two both with the same issues, 2007 macbook and a 2015 dell xps, with a usb ethernet adapter supported on h-node
<joshuaBPMan>I find that works more reliably.
<lfam>Oh
<joshuaBPMan>atkka  I've gotten guix to install on a macbook 7,1 before (2010).
<lfam>I've had terrible luck with USB ethernet adapters, even models that should work, like from Apple
<atkka>i'm using one from cable-matters but the chip is supported
<atkka>and it works, I downloaded a bunch from the ci, just sometimes it stops
<lfam>Yes, that's the problem I've observed
<lfam>They work and then they don't
<atkka>hmm
<atkka>ok
<lfam>I mean, they should work. I don't know why they wouldn't
<joshuaBPMan>atkka  you should try a "bare bones" install.
<atkka>well I have 11 network adapters at my disposal and this is literally the only one thats supported
<lfam>And, I don't know why it would break things for you
<lfam>It should be fine to retry the command until it finishes
<atkka>I need a new computer just for guix I guess, but i'm poor
<lfam>Is that an option?
<atkka>it won't let me try again this time, see above message
<atkka>I was able to retry with the installer and it would finish
<lfam>I don't see why you couldn't try again
<atkka>but then it would leave me without a bootable system grub: unrecognized filesystem
<lfam>In that case, it sounds like you set the bootloader up incorrectly
<atkka>I didn't
<atkka>the installer did everything
<lfam>Sorry, I mean you or the tools you used
<atkka>many times, encryption or not
<lfam>"the bootloader was set up incorrectly"
<joshuaBPMan>atkka:  I personally use a Lenovo T400.  You could buy a T400 or T200 on online for probably $100-$200.
<joshuaBPMan>8BG of RAM.  Core 2 Duo at about 2.5 Gigahertz per second
<joshuaBPMan>I know the installer works on those machines.
<lfam>Let's clarify the problems you're experiencing. At some point while downloading things, the guix process stops and you can't kill it or recover gracefully?
<atkka>I'll think about it, I'm frustrated for now. This is like trying to install linux in the 90s
<atkka>I have no issues with alpine as my main distro
<atkka>can guix run on musl?
<rekado_>no
<rekado_>it is closely tied to the glibc, all the way down to the bootstrap
<joshuaBPMan>atkka:  I felt that way when I first installed guix.  I had to install ubuntu first to correctly install grub.  Then in the grub screen I had to say boot from this usb.  That was interestingly learning how to do that.
<lfam>It's a shame the installation process is still so difficult for newcomers
***rekado_ is now known as rekado
<joshuaBPMan>rekado_  I've been reading about Zig and sway and they both talk about how musl is pretty gravy.  I get that we want to be tied to GNU....idk...thoughts?
<rekado>joshuaBPMan: it’s a technical decision to use the glibc
<rekado>this has wide-ranging implications for all of Guix
<joshuaBPMan>rekado  may I ask what that decision is?  I'm certain I'd agree with it...
<rekado>we won’t switch to musl, nor will musl be a selectable option
<joshuaBPMan>oh The Hurd!  That's why!
<joshuaBPMan>musl doesn't support Hurd no?
<rekado>the hurd is implemented as a distributed feature across different projects; glibc is one of them
<rekado>“tied to GNU” sounds like a bad thing
<atkka>lfam: yes, I was downloading from the ci, downloaded many many packages, hung on cparanoia (only 90KiB), press ctrl-c, press up to go to the last command and it throws the aformentioned error
<atkka>using the installer method it would just restart and chug along fine
<rekado>joshuaBPMan: we aren’t “tied to GNU”; Guix System is an implementation of the GNU system using one of the most feature rich C libraries out there: the GNU C library.
<lfam>That socket permissions error is weird
<spk121>joshuaBPMan: FWIW, a version of Guile built w/ musl can't handle any non-utf8 encodings
<joshuaBPMan>rekado  Ahhh...glibc may be less lean, but it has a more complete feature set.
<apteryx>atkka: sorry to hear you've having such a hard time installing Guix. Have you tried the old school 'manual' installation defined in the manual yet?
<rekado>joshuaBPMan: heh, that’s almost like saying the same thing twice :)
<atkka>apteryx: yes, I am currently on my second attempt manually installing it
<apteryx>and the problem is always Guix getting stuck downloading things?
<shcv>why does set-xorg-configuration require various desktop services? I am working on a configuration for wsl2 that will use a remote X server (vcxsrv)
<apteryx>Do you have an option to plug an ethernet cable to eliminate any potential wifi issues?
<shcv>trying to set the keyboard layout...
<rekado>joshuaBPMan: this is a common pattern. I don’t mean to sound dismissive. I think it’s good that there are more C library implementations. But the initial impulse to start from scratch, implement things “cleanly”, without “bloat” … well, it often turns out that “bloat” is another term for “features” or
<rekado>“workarounds for real-world problems”.
<rekado>that’s how we ended up with autotools, and why any attempt to replace it has been frustrated by the same problems that made autotools look like gorilla spit.
<atkka>apteryx: yes, it has happened every single time on two different computers, then if I can resume and actually finish (gui method only so far), it reboots into grub but with a botched filesystem (this is using the installers recommended partition scheme, both with or without luks)
<atkka>I have successfully ran guix as a package manager on void without issues
<atkka>*tui* method
<atkka>apteryx: I'm not on wifi, I'm using ethernet
<rekado>(citation for “gorilla spit”: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/History.html)
<lfam>apteryx: atkka is using a USB ethernet adapter
<lfam>I don't know if that's salient
<lfam>I had terrible experiences using them for my job. We found that wifi is more reliable
<lfam>We tried 4 different implementations using USB Type A and C
<lfam>It's hard to believe but for critical livestreams ($$$$) we use wifi or LTE
<mroh>mhj: try something like `(kernel-arguments (list "modprobe.blacklist=yourmodule"))` in your configuration file (operating-system part).
<lfam>But, the deeper problem is that Guix somehow hangs and is not recoverable for atkka
<atkka>lfam: I'm going to borrow a computer and try it
<lfam>I suspect that USB ethernet adapters are a market for lemons
<atkka>lfam: well mine works fine on other distros
<lfam>Yeah, and they worked fine for us at work, until we had an application that couldn't tolerate very short duration network loss
<lfam>That shouldn't matter here, but I dunno
<lfam>Something isn't working
<lfam>I learned to avoid them
<atkka>well when you have an OS that doesn't support 99% of hardware made in the last 10+ years I don't know what the options are
<lfam>Yeah, it's tough
<atkka>I'm all for free computing, but its putting the cart before the horse
<lfam>I agree
<atkka>any status on the pinebook pro?
<atkka>I saw there was a WIP note somewhere
<lfam>I think that vagrantc has one. I don't know if they are around
<lfam>I would also clarify that Guix does support 99% of hardware, but the 1% that isn't supported is critical
<lfam>That is, most wifi
<atkka>but what about any accelerated graphics, or power saving features?
<lfam>I don't really know about those things
<atkka>every network chip I've seen that is even supported lists power saving as disabled
<lfam>How do you look that up?
<atkka>h-node and the fsf certified lists had it somewhere
<lfam>Oh
<atkka>or one of their wikis
<lfam>Those sites are rather out of date in my experience
<lfam>I'd guess that Intel NICs have good support
<atkka>I dunno, I want a free system more than anything, the truth is there isn't really anything available so I run minimal alpine systems with busybox and suckless for now
<atkka>I am bitten by guix and guile though, I will find a way to run it
<lfam>I recommend using Guix on another distro until you are comfortable with it
<joshuaBPMan>rekado  that doesn't sound dismissive at all.  Speaking of autotools.  I thought it would be kind of cool to use a guile DSL to generate the makefile.in or whatever file you have to write.
<atkka>lfam: I did run it on glibc void for awhile, which is why I wanted to try guix system
<atkka>guix plus debian stable would probably be a good mix
<lfam>We want installing and using Guix to be seamless. But as you can see, the current state requires some strong troubleshooting skills
<lfam>I use Guix on Debian primarily
<atkka>I will get it working, I don't give up that easily. I am going to take a break for a couple hours though. Thanks for the help everyone.
<lfam>Alright, we'll be here
<lfam>I guess I'll try re-installing one of my systems tonight, and see how it goes
<apteryx>atkka: Cheers for your perseverance! I had a tough install also 5 years ago. On the flip side, I never had to do it again ;-).
<apteryx>I suspect that is true for most Guix hackers, which may explain why the installer is not as tested as it should ;-)
<joshuaBPMan>apteryx:  You've had better luck than me!  I
<jonsger>apteryx: installers in general hard, thats not only for Guix. My last two installer bugs are at openSUSE...
<lfam>The previous release had some problems in the installer
<lfam>It's hard to get motivated to do "real installs" to test it
<lfam>We should try to find a way to have fun doing it as a group in the release testing period
<joshuaBPMan>I've probably had to 3-5 times.  Generally because I kept trying crazy things.
<apteryx>lfam: testing in group could be a way to make it a funnier experience indeed!
<joshuaBPMan>The big issue was trying full disk encryption and having weird layout issues.
<joshuaBPMan>lfam:  We could sell T-Shirts to raise awareness "Guix System: World's best Installer."
<lfam>It's tricky to test because, as you allude to, there's a billion possibilities in terms of partitioning and filesystems
<shcv>anyone use colemak with guix?
<shcv>(keyboard layout)
<joshuaBPMan>lfam  Yeah.  I remember reading in the mailing list one of the developers talking about how hard it is to get it working right.  It's gotta be hard.
<joshuaBPMan>shcv  I use dvorak
<joshuaBPMan>I'm also a pleasure to be around too.  :)
<joshuaBPMan>shcv  You can see my config at notabug.org/jbranso
<shcv>how do you get setxbkmap to load the variants properly? If I use "setxkbmap us" it works, but attempting to set the variant results in "Error loading new keyboard description"
<atkka>shcv: I use colemak as well
<atkka>shcv: I've noticed some issues regarding it and guix, I have yet to submit a bug report
<atkka>shcv: for one, when using loadkeys colemak can't be found, but if you use the absolute path it works, I think it is a naming issue as its name latin-9 or something inside the colemak folder
<shcv>yeah; I've used the latin-9 name in other systems before
<joshuaBPMan>shcv:  I actually manually specify my layout for sway, but keyboard layout works for me on the console.
<atkka>shcv: you can make a 00-keyboard.conf inside /etc/X11/xorg.conf.d with you variant and options like ctrl:nocaps
<shcv>ok