IRC channel logs

2021-01-24.log

back to list of logs

<mhj[m]>That did it! Thanks again, I’m liking this community already and it makes me want to learn more!
<Sharlatan>Supurbe! build passed
<Sharlatan>mhj[m]: nice to see it :)
<bavier[m]>Sharlatan: great!
<Sharlatan>thanks you for the help, see you.
<lfam>Glad to hear it mhj[m] :)
<rndd>wellll, i just copy-pasted guix kernel config and it works now ^_^
<lfam>rndd: As it should :)
<rndd>lfam: wellll, why defconfig don't applyable in guix?
<rndd>* is not
<rndd>btw i'm new in linux kernel related stuff
<ekaitz[m]><leoprikler "ekaitz: I think that detail shou"> do you think? in our bootstrap.scm currently we have this for riscv64:
<ekaitz[m]>what's `lp` and `d` in that case?
<lfam>rndd: Kernel components can be either built-in or modular. We build the ahci parts as modular, and then the Guix code that builds the initrd copies those modules into the initrd
<lfam>rndd: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system/linux-initrd.scm?id=51bcc29ca05067c74375edd6bec9ec5322164083
<lfam>Or rather: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system/linux-initrd.scm?id=51bcc29ca05067c74375edd6bec9ec5322164083#n321
<lfam>If you don't build these things as modules, then this code can't find them and it crashes
<leoprikler>ekaitz[m]: good point, in that case your choice for the riscv32 linker makes perfect sense
<ekaitz[m]><leoprikler "ekaitz: good point, in that case"> i'm not sure neither... i sent a pr for the elf targets and we can use that as a discussion for other targets
<ekaitz[m]>also I don't get why do we mix bootstrap with the compilers
<ekaitz[m]>the compilers are not only supposed to be made for our system... and that's breaking our cross-compilation
<leoprikler>46059 certainly lgtm, but I'll let someone else do the review
<ekaitz[m]>yeah, good decision
<ekaitz[m]>:D
<rndd>lfam: hmmm, thank you for this explanation
<ekaitz[m]>this stuff is tricky as F*
<leoprikler>ehm, compilers are somewhat important for bootstrapping?
<rekado_>katco: sorry for not providing more details earlier! My time in front of the computer is often interrupted so I’m barely keeping up with conversations here.
<rekado_>katco: I also agree that it’s worth trying sxml first
*rekado_ disappears again
<rndd>btw, where i can find reference of each .config parameter?
<ekaitz[m]><leoprikler "ehm, compilers are somewhat impo"> yes, but that shouldn't compromise their other uses
<katco>rekado_: no worries at all, friend! i can definitely empathize. thanks for the input!
<leoprikler>what other uses particularly? you mentioned cross-compiling, but I don't see cross-compilation in Guix as particularly broken
<lfam>rndd: You can use `make menuconfig` and choose "Help" to see the documentation of an option
<lfam>Or search on the web
<rndd>iflema: anyway, people from #linux recommend to read sources
<rndd>0_o
<lfam>Yes, the docs are scattered all over the source code in the Kconfig files
<lfam>It's not convenient
<lfam>I normally use this web page: https://cateee.net/lkddb/web-lkddb/PHY_ROCKCHIP_DPHY_RX0.html
<rndd>well
<rndd>i will think twice next time
<rndd>but thanks for your help
<lfam>Alright, let us know if you have more questions
<rndd>i will ^_^
<ekaitz[m]><leoprikler "what other uses particularly? y"> it's not broken, but the gcc packages depend the glibc-dynamic-linker, and I don't think that makes sense in every case
<ekaitz[m]>so that is making users unable to install or package cross compilers easily imo
<joshuaBPMan>I'm curious, which one implements virtual console login in guix system?  mingetty or agetty?
<joshuaBPMan>Ok, it looks like mingetty.  agetty looks like it is for serial console login
<apfel>hi there, the --use-substitutes feature of cuirass should work? For me cuirass still builds things from scratch which have a prebuilt package. This is my current test spec/manifest, any hints?
<apfel> https://paste.debian.net/hidden/4bff9d86/
<joshuaBPMan>hmmm.  I didn't realize that you could specify packages for guix to build.  That's pretty cool!
<joshuaBPMan>cuirass I mean
<mhj[m]>Hi all, thanks again for the help lfam and crew. Now I suppose I have a different question. If I wanted to use the latest kernel from the repos that’s been packaged, do I need to specify that in my config scm file or is there some other method?
<mhj[m]>I looked through the manual and didn’t see anything about any variables or types to do that. Maybe I overlooked it? Is it a package assignment?
<lfam>Can you clarify what you mean by latest kernel from the repos?
<lfam>My understanding is that the default kernel is the latest one that has been packaged
<lfam>In general, you can specify a package to use with the (kernel) field of the operating-system
<lfam> https://guix.gnu.org/manual/en/html_node/operating_002dsystem-Reference.html
<mhj[m]>Ohhh. My current kernel is 5.9, but I’m seeing 5.10 in a package search. From here: https://guix.gnu.org/en/packages/linux-libre-5.10.9/
<mhj[m]>I see! Thanks!
<lfam>mhj[m]: Oh, it sounds like you need to run `guix pull`
<lfam>Or, if you already see 5.10.9 in your search, then your guix is up to date and you can reconfigure to update the kernel
<lfam>You can do `guix show linux-libre` to check which versions are available to you
<lfam>I guess that we released 1.2.0 while 5.9 was the stable kernel
<mhj[m]>Ooh
<mhj[m]>Thanks for the info!
<ccao001[m]>Hi, what is the best way to use a modified version of a package? guix edit is read only. I want to be able to use guix edit to change the package but it doesn't allow me because it is read only. Is cloning a copy of the guix source tree and setting GUIX_PACKAGE_PATH the only way? any help is much appreciated
<vagrantc>ccao001[m]: it's a little confusing, but you need to follow the instructions for building from source and then ./pre-inst-env guix edit
<vagrantc>e.g. so that the version you're running is using the same files that you want to edit
<ccao001[m]>so I have to follow the test suite also? https://guix.gnu.org/manual/en/html_node/Running-the-Test-Suite.html#Running-the-Test-Suite
<ccao001[m]>vagrantc: what is your workflow for setting this up?
<vagrantc>you don't *have* to run the tests, although obviously if there is something broken it could cause issues, but everything leading up to that
<vagrantc>strangely, https://guix.gnu.org/manual/en/html_node/Building-from-Git.html does not include the instructions to actually build...
<OriansJ>vagrantc: well no; hasn't worked for quite a while actually
<vagrantc>or maybe make authenticate is enough
<vagrantc>oh?
<vagrantc>i've used it as recently as a month or two ago
<OriansJ>fresh git clones and build attempts resulted in missing build files the last time I checked.
<OriansJ>but hopefully they fixed it since I last reported.
<vagrantc>although i've started using "guix time-machine" to build one-off commits lately
<vagrantc>a little more expensive for trivial edits to rebuild guix each time ...
<OriansJ>depending on guix to build guix is a dangerous problem to bootstrapping.
<OriansJ>but perhaps I am just a little bit of a zealot
<vagrantc>well, i also build it on debian :)
<vagrantc> https://tracker.debian.org/guix
<vagrantc>but when working on one-off commits to update a package or two, having to bootstrap everything from scratch every time seems a bit overkill :)
<OriansJ>vagrantc: speaking of which you will need this procedure to do guix pull without substitutes on debian: https://issues.guix.info/44559
<lfam>Building guix is performed by `make check`
<vagrantc>ah right, check depends on the other stuff
<lfam>That's regarding the instructions in the manual
<lfam>I suppose we should make the manual more explicit. I think it's a source of confusion
<vagrantc>i did start to get a little wild west and just started running make now and then
<vagrantc>i also never find the "./configure --localstatedir=/var" part in any of the places i would think it should show in the manual
<lfam>It's in Building from Git
<vagrantc>lfam: i guess i always expect to see it in the cut-and-pasteable examples, rather in the prose :)
<vagrantc>i think i typically do something like: ./bootstrap && ./configure --localestatedir=/var && make authenticate && make
<vagrantc>or make check
<ccao001[m]>thanks vagrantc
<ccao001[m]>If I make a guix channel and I forget to gpg sign my commits what should I do in order to fix the commits already made without signing?
<ccao001[m]>what would be the best way?
<ccao001[m]>should I start an orphan branch and recommit everything while gpg signing?
<vagrantc>i *think* that's the only way possible to fix it
<joshuaBPMan>ccao001[m]  I've never been able to keep one gpg key.  Generally what happens, is my computer crashes (because I'm trying new and exciting potentially lose-your-data-stuff).  Then I have to make a new gpg key.
<ccao001[m]>what do you do with the old commits that are signed with a different gpg key?
<ccao001[m]>do those old commits become unusable by subscribers to the channel?
<ccao001[m]>i.e. will the channel fail to authenticate with guix
<vagrantc>there was a blog post explaining it not too long ago
<vagrantc>but basically which keys are valid is part of the commit history, so new commits have to be signed by one of the keys already present in the repository
<vagrantc>it doesn't bother with expired keys at all
<vagrantc>as in, it doesn't check current validity ...
<goldenshimmer>Hi, how can I pull my personal channel without also pulling the main Guix channel? I tried guix pull --url=... but it tries to use that URL to update the Guix channel.
<joshuaBPMan>goldenshimmer:  You probably need to customize your default channels....just a second.
<vagrantc>ccao001[m]: https://guix.gnu.org/en/blog/2020/securing-updates/
<joshuaBPMan> https://guix.gnu.org/manual/en/html_node/Specifying-Additional-Channels.html
<joshuaBPMan>goldenshimmer:  Just change %default channels to '()
<joshuaBPMan>Then you will pull only from your channel.
<ccao001[m]><vagrantc "ccao001: https://guix.gnu.org/en"> thanks! I'll take a look
<mroh>sneek later tell rndd I think, the error you're getting with you kernel config is because of the initrd module safety checks, so you might try `guix system --skip-checks` or make sure all the modules that are tested are in your kernel (see default-initrd-modules in ~/gnu/system/linux-initrd.scm for the list of modules)
<sneek>Okay.
<vagrantc>OriansJ: gnutls 3.6.14 seems to build fine with --no-substitutes on the debian package
<vagrantc>or do i have to purge my entire /gnu/store to trigger the issue?
<vagrantc>oh, maybe also need --no-grafts
<goldenshimmer>Thank you!
<OriansJ>vagrantc: you wouldn't hit it unless you did a fresh install and did not enable substitutes at all. Then you would hit it on first guix pull
<vagrantc>admittedly don't test a no-substitutes scenario very often
<vagrantc>and the current Debian packages default to enabling substitutes
<ryanprior>y'all ever wish there were a --no-builds option where it would just skip anything for which there isn't a substitute?
<ryanprior>when upgrading packages I routinely use --dry-run to find a list of things I don't want to build, and then pass a bunch of --do-not-upgrade flags
<vagrantc>ryanprior: definitely. it's been brought up often
<ryanprior>if I dare to really dream, I want to say --no-builds=time>2m as in, for anything you're about to build, check the CI stats for that package and if 95% of builds take more than two minutes to complete, skip it
<lafrenierejm>What's the proper way to manage service configuration files that one would normally put in /etc?
<lafrenierejm>In particular, I'm wanting to include some YAML files for use with intercept-tools (bug 46066) ala https://emacsredux.com/blog/2020/07/05/remap-enter-to-control-in-gnu-linux-2020-edition/.
<alextee[m]>libsndfile is broken
<alextee[m]> https://github.com/libsndfile/libsndfile/blob/e7f5137b47710cb83ac91a43327c7faed5067168/configure.ac#L370 needs opus too since 1.0.29 otherwise it has no vorbis/flac support
<alextee[m]>gonan send a patch in a bit
<vagrantc>lafrenierejm: i think most services will generate the configuration somehow and then pass it as an argument to the daemon or symlink it in /etc if that isn't possible
<alextee[m]>how do you check the number of dependent packages again?
<alextee[m]>just so i know if i should use master or not
<lfam>`guix refresh -l foo`
<lafrenierejm>vagrantc: Is my only option to define a full service, then?
<alextee[m]>lfam: thx
<alextee[m]>`Building the following 741 packages would ensure 1358 dependent packages are rebuilt`
<lfam>It qualifies for staging-next
<vagrantc>lafrenierejm: i'm not well versed in these things, just based on what i've observed from what services do and how guix works in general...
<alextee[m]><lfam "It qualifies for staging-next"> 👌
<lafrenierejm>vagrantc: Sure. That's how it looked to me too, I was just hoping to avoid having to write a service definition right now. :/
<alextee[m]>patch sent https://debbugs.gnu.org/cgi/bugreport.cgi?bug=46067
<alextee[m]>i think the current libsndfile breaks support for flac/vorbis to all packages that use it so it should probably be merged soon
<vagrantc>lafrenierejm: how else would you run a service?
<ryanprior>lafrenierejm: packages can only contain immutable data, so if this is configuration that the user should never have any reason to overwrite, or that they would want to do so by providing a different config path, you could just put that config file in the package.
<ryanprior>lafrenierejm: if the data is something that the user might want to modify, or other services might want to modify or extend, then that puts it beyond the definition of what a package is, now it's a service (even if a slim one)
<ryanprior>If writing service definitions is daunting or tiresome for you (it is both for me!) then I think that points to the need for tidier tools for defining services =D
<lafrenierejm>ryanprior: I haven't written any service definitions before, so we'll see how it goes. :)
<raghavgururajan>sudo: unable to open /var/run/sudo/ts/rg: Read-only file system
<raghavgururajan>guix package: error: fport_read: Connection reset by peer
<raghavgururajan->test
***raghavgururajan- is now known as raghav-panic-mod
***raghav-panic-mod is now known as raghav-panic
<raghav-panic>Folks!
<raghav-panic>guix system doesn't boot
<raghav-panic>btrfs related errors
<raghav-panic>just a sec
<raghav-panic>BTRFS error (device dm-1): parent transid verify failed on 73036480512 wanted 65151 found 65489
<raghav-panic>BTRFS error (device dm-1): failed to read block groups: -5
<raghav-panic>BTRFS error (device dm-1): open_ctree failed
<raghav-panic>apteryx: I remember you helping me with btrfs before. Do you have any clue regarding the above?
<Rovanion>Would it be appreciated if I added a text to the top of about how to set up Gnome Boxes? https://guix.gnu.org/manual/en/html_node/Virtualization-Services.html
<Rovanion>It was the only manual page I found about virtualization yesterday when I tried to get a VirtualBox-like VM situation going.
<stikonas[m]>raghav-panic: btrfs rescue might help but better make backup first
<pkill9>which package contains yacc?
<rekado>pkill9: bison?
<civodul>hi there!
<civodul>i'm looking into time traveling, and it seems we lost things like qtmultimedia-everywhere-src-5.11.2.tar.xz
<civodul> https://download.qt.io/archive/ has a few versions, but not this one
<civodul>you can reproduce with: guix time-machine --commit=0791437 -- build qt
<civodul>does anyone happen to have these tarballs?
<civodul>that's only two years ago :-/
<PurpleSym>Wayback has a directory listing, but not the file itself :/ http://web.archive.org/web/20190414164951/http://download.qt.io/archive/qt/5.11/5.11.2/submodules
<OriansJ>civodul: these things are going to keep happening forever
<civodul>OriansJ: yup, we're aware of this :-)
<OriansJ>Guix is going to have to pull a Debian and host copies of the source code too
<civodul>there's work with SWH and there's Disarchive, which means to address this
<OriansJ>civodul: ipfs could also help address it if there was an easy process for people to become source mirrors for Guix.
<OriansJ>say guix download --all-the-sources
<profmakx>urgh
<profmakx>partypeople, which of the tomb of gnome packages contains the "FileChooser"
<profmakx>does everyone just install the whole gnome to make gtk apps work?
<efraim>download.qt.io/archive used to host the qt4 sources too
<civodul>bummer
<civodul>i've checked on a few servers but didn't find it
<zimoun>Hi!
<civodul>o/
<pkill9>yea rekado, thakns
<pkill9>thanks*
<civodul>cbaines: you don't seem to have those Qt 5.11.2 tarballs at cbaines.net, right?
***zimoun` is now known as zimoun
<civodul>ah ha! http://sources.buildroot.net/qt5base/
<zimoun>sneek tell later vagrantc: --localstatedir=/var/ is written in the manual, at least 2 places, and one in the section Building from Git. What could be improved?
<sneek>later, zimoun says: vagrantc: --localstatedir=/var/ is written in the manual, at least 2 places, and one in the section Building from Git. What could be improved?
<zamfofex>profmakx: I might be wrong, but I think gtk+.
<zamfofex>I remember running into an issue regarding a missing “FileChooser” when trying to run NetSurf. My “guix package -I” shows “gtk+” immediately after “netsurf”, which is highly indicative! See if it works well for you. Feel free to let me know what happens!
<zamfofex>Or, well, when opening NetSurf settings, more specifically.
<rekado>civodul: I’m looking at the MDC store, so we can compare hashes
<raghavgururajan>Hello Guix!
*raghavgururajan just recovered from file-system corruption
<pkill9>would it be better for the command line output to change the current line instead of creating new lines for each item downloaded?
<pkill9>nice to see --with-latest
<PotentialUser-83>hi all, If I broke my channels.scm where I can copy the default one?
<civodul>rekado: source.buildroot.net has it all, with the correct hashes \o/
<mdevos>PotentialUser-83: idk your particular situation, but "guix pull" has a "--channels" argument, maybe that's useful?
<mdevos>Also, there should be old guix generations in /var/guix/profiles/
<profmakx>zamfofex: yes that did indeed work; should those packages that are missing FileChooser (or whatever else) not depend on gtk+ then?
<civodul>in /gnu/store/p2d7i5258vi0rd9ydbpr9c1vb3sxcz6h-mariadb-10.1.37.drv (from 2 years ago), there's *one* test failure
<civodul>ISTR we occasionally experienced it in the past, but somehow found a way to sidestep it
<civodul>was it --cores=1 or...?
<civodul>mbakke: perhaps you remember that? ↑
***amiloradovsky1 is now known as amiloradovsky
<mbakke>civodul: do you have the output from the failing test?
<mbakke>civodul: could it be https://issues.guix.gnu.org/39310 ?
<civodul>mbakke: looks like it!
<civodul>ah, so it's a time issue
<civodul>bah
<roptat>hi guix!
<roptat>finally translating the website to French :)
<civodul>salut roptat, nice! :-)
<civodul>to whom it may concern: i've temporarily taken hydra-guix-129 off the build farm and changed its date to 2018
<roptat>we still have a mention to "Guix System Distribution" in our contribute page
<roptat> https://guix.gnu.org/en/contribute/ (Project Management)
<joshuaBPMan>Hey guix people! I've been working on a sway service. For now I think I've got the data structures pretty well. Working on emiting the config file now.
<guix-vits>sneek: botsnack
<sneek>:)
<civodul>mbakke: it worked, thank you!
<civodul>sneek: later tell mothacehe could you restart the cuirass workers on hydra-guix-129?
<sneek>Got it.
<apfel>hi there, https://ci.guix.gnu.org/ shows a number of specifications, which repository contains those specifications? I want to check how they work, to improve my own cuirass specs.
<raghavgururajan>Folks! If any of you on the streak of updating packages, can you include #46075 on the list? Thanks!
<apfel>hm, https://git.savannah.gnu.org/git/guix/maintenance.git contains some specs, but not all, but maybe the other specs are old and just still in the database
<leoprikler>raghav eager as always
<raghavgururajan>leoprikler: 😅
<apfel>hm, sometimes a package installed with 'guix install' gets downloaded as a substitue on one system but gets build on another system. Why is that? because the installed packages/dependencies are not recent enough -> build with old/installed dependencies? This also sometimes happens with 'guix package -u', which is irritading because i would assume dependencies would be updated during this process. But maybe i am missing something, can
<apfel>somebody explain?
<civodul>hi apfel! it depends on a number of factors, most importantly the configured substitute URLs
<civodul>and authorized substitute keys
<civodul>then, if these are the same on the two machines, there can still be differences
<civodul>for instance, because the thing became available on the substitute server in the meantime
<civodul>or because one of the machines has a cached substitute lookup failure
<civodul>it's always possible, but it should be quite rare in general
<leoprikler>or because they are on different `guix pull` generations ;)
<civodul>ah sure, that too!
<roptat>74%, I'll finish this afternoon :)
<apfel>civodul: yea ok, but both of those machines are running 'guix (GNU Guix) c95f7dc6f113dc66ca463e3a44c309c0c5ccd7f4', i used guix gc and guix gc -d on both of them, but this one machine - my slow notebook - want to build 'krita', while my rather powerfull desktop pc just downloads the prebuilt package ... this is frustrating, because building something like this takes forever on my notebook ...
<civodul>apfel: i can imagine
<civodul>then again, you can share binaries among your machines
<civodul>there's a new discovery mechanism in current Guix
<civodul>so each machine can advertise its "guix publish" instance and others on the LAN can discover it and use it automatically
<civodul>in addition to that, you can also "guix copy --to=OTHER-MACHINE krita"
<apfel>well, i tried to fix this by setting up cuirass on my server, i download packages now via this server but still the same, now the notebook downloads the sources from my server and my desktop the package ...
<civodul>you mean the notebook isn't getting the package substitute?
<apfel>what is also funny, all the krita dependencies are downloaded as packages, only krita is built from source ...
<civodul>did you authorize your server's key?
<apfel>civodul: i did, i will check again
<apfel>well yes, because if i did not authorize my substitute server then guix would not even doenload the sources
<raghavgururajan>apfel: Try `sudo rm -r /var/guix/substitute/cache/*` on the machine that doesn't get the substitute.
<raghavgururajan>apfel: Also, does the output of `guix describe` match between the machines?
<apfel>raghavgururajan: thanks, that did the trick! is there a guix command which can do this, or is the assumption that this cache should never be corrupted?
<apfel>
<raghavgururajan>Glad!
<raghavgururajan>There is no command for it. I am longing for it though.
<raghavgururajan>civodul: Is there a way to add a guix command to clear substitute cache? I wanted to suggest this on mail list, but kept forgetting.
<leoprikler>reminds me of the multi-profile proposal I keep forgetting
<raghavgururajan>Like `guix package --clear-substitute-cache` or `guix substitute --clear-cache`?
<civodul>raghavgururajan: that should not be necessary, there are time-to-live (TTLs) on replies coming from the server
<civodul>you might need to fiddle with /var/guix/substitute/cache as a core developer, but otherwise probably not
<raghavgururajan>civodul: Ah I see.
<roptat>so cold outside, my hands are frozen it's hard to type ^^'
<kraai>I'm trying to package elm-format, which is built using the Shake build system. Shake depends on some unpackaged libraries. Should I package the latest version of these libraries or the version in a particular LTS Stackage release?
<apteryx>is MELPA now an acceptable upstream for the packages sources?
<apteryx>(emacs packages)
<lfam>I notice that the window decorations of QEMU from `guix system vm` have no glyphs for the clickable menus
<lfam>I don't think it used to be like this
<efraim>lfam: I'm test building icedtea on aarch64 on staging
<lfam>Thanks efraim
<lfam>I'm kinda lost
<lfam>Not sure how to proceed from here
*apteryx finished editing all PYTHONPATH occurences on core-updates... That's about 160 patches.
<efraim>I think for some of it we may need to force a rebuild by hand of some packages, and for others either specifically fix them or fix them on master after merge :/
<efraim>just under 7.5 hours on the build phase for icedtea@1
<lfam>efraim: I've built a lot of things by hand but it's not easy to tell what is really broken and what is a spurious failure
<joshuaBPMan>efraim:  dang!  That's a long build process!
<red44>hi!!! i would like to install nix pkg manager on the top of guix os.is that possible? can someone give me some help? thakyou very much!!
<lfam>Almost everything I've checked has been a spurious failure
<lfam>I think the only way to actually finish the work is to get more people involved, and breaking things on master might be the only way
<joshuaBPMan>red44  I believe that is possible.
<joshuaBPMan>sneek:  nix?
<joshuaBPMan>red44:  just a moment while I consult the manual.
<joshuaBPMan> https://guix.gnu.org/manual/en/html_node/Miscellaneous-Services.html
<lfam>efraim: And, perhaps very little is actually still broken, at least on x86_64. The only thing I know of is vtk / freecad
<joshuaBPMan>red44 There's a section there about how to set up the nix package manager.  :)
*lfam afk
<red44>thank you very much!!! i will study it!!! and by doing it i could be able to install pkgs from the nix repos,right???(sorry for the silly question)
<joshuaBPMan>red44  Yes.  That's how I used to install not-icecat.  Then I just used the flatpak directly.
<red44>for flatpak i also have to do something similar right?? (set the services in the config file)
<joshuaBPMan>actually no. :)
<joshuaBPMan>I just installed flatpak.
<joshuaBPMan>Then I think it's flatpak --user --install not-icecat or something like that.
<joshuaBPMan>works fairly well.
<red44>oh...i also installed flatpak but i didnt manage to make it works
<red44>but a cannot find a manual or something
<mhj[m]>Ooh, I installed flatpak but didn’t do the user flag. Oops. Time to reinstall all the packages lol
<leoprikler>how do I spawn a container with nothing but my packages, some envs, and an empty $HOME?
<leoprikler>-u "nobody"?
<leoprikler>okay, now how do I get $DISPLAY to work inside a container?
<roptat>all translated!
<roptat>and pushed, when it's regenerated, the website should be available in French too :D
<red44>can someone tell me if is possible to package luxcorerender into guix?the licence should be ok..
<leoprikler>it certainly looks possible, but it'll take moderate amounts of effort
<red44>do you belive it will be hard to find someone with the proper skill to do it??
<leoprikler>I think it might be a good package to learn Guix packaging even.
<leoprikler>There don't seem to be too many inputs, so you should get something that runs "fairly" quickly.
<civodul>roptat: \o/
<civodul>roptat: perhaps we should add a link at the bottom of pages to translation instructions or to weblate?
<leoprikler>However, as you make your way toward quality control, you will notice, that you may have to unbundle some dependencies.
<leoprikler>IOW, give it a go if you want to flex your scheme and don't hesitate to ask us if something's unclear :)
<leoprikler>with that said, I'll go afk for now, though
<nefix>hello! Is it possible to mix meson-build-system and python-build-system? Thanks!
<roptat>civodul, while translating, I found the instructions in the website, we should update that first
<red44>i would love to learn but i am what you call newbe..i really have no idea maybe you can suggest me something to read about??
<roptat>civodul, https://guix.gnu.org/en/contribute/ Translation
<civodul>oh right
<civodul>roptat: if you feel motivated, i guess you can go ahead and update them
<red44>i would love to learn guix pakaging. im complete beginner. could someone suggest me where to start?
<vagrantc>red44: do you have guix installed? if so, "guix edit PACKAGE" will show you how a particular package is built
<vagrantc>red44: the other thing is how familiar are you with guile or scheme?
<vagrantc>as all guix packaging is pretty much implemented in guile
***amiloradovsky1 is now known as amiloradovsky
<rekado>red44: have you looked at the Guix Cookbook?
<rekado>it contains a packaging tutorial: https://guix.gnu.org/cookbook/en/html_node/Packaging.html
<red44>here we are...i am not familiar at all. do i have to learn a programming language?
<red44>thankyou for the link
<rekado>red44: the cookbook also has you covered: https://guix.gnu.org/cookbook/en/html_node/Scheme-tutorials.html
<red44>i will study it!
<vagrantc>i've also been writing package definitions for a couple years now, and i wouldn't say i understand guile or scheme, fwiw :)
<roptat>civodul, done
<Rovanion>How come only OpenJDK 9 and above is packaged?
<Rovanion>The earlier versions are named icedtea?
<rekado>Rovanion: correct.
<rekado>the icedtea packages cover JDK 6 through 8
<Rovanion>I understand why when reading about it, but man that is confusing.
<leoprikler>history is complicated
<Rovanion>I would be fore ignoring history in this instance and just declaring openjdk-8 and -7 anyways.
<stikonas>Rovanion: icedtea and openjdk are not the same
<stikonas>so it would be wrong to just decleare icedtea-8 openjdk-8
<stikonas>icedtea has a different build harness
<roptat> https://guix.gnu.org/fr/ \o/
<jonsger>très, très bien roptat :)
<civodul>roptat: bien joué !
<civodul>that was fast!
<roptat>took me a day :)
<roptat>but I'm afraid some strings have changed since then, there were some changes to the website after the last generation of the pot file