IRC channel logs

2021-01-09.log

back to list of logs

*lfam keeps trying to make progress on the staging branch
<raghavgururajan>I get this C++ related error: https://paste.debian.net/1180280/
<raghavgururajan>Is that a standard issue?
***amfl_ is now known as amfl
<raingloom>ayyyyyy, got snapperd running just now :D
<raingloom>config support coming
***gavlee is now known as gavlee__
<marusich>efraim, regarding bootstrapping for another arch like powerpc64-linux-gnu: once I update the package definitions etc. to use the newly created bootstrap binaries hosted on the GNU FTP servers, what would the next steps be? My understanding is that the end goal is to get it so that I can build Guix using Guix on a "foreign" powerpc64-linux-gnu machine, e.g. Debian. (I could aim for building a Guix System in a VM, too, but that seems harder?)
<marusich>Once I've made the changes to add the bootstrap binaries in the package definitions etc., do I want to try to use that code to build Guix from source on Debian, for example? Or is it best to try cross-compiling Guix itself using Guix on an x86_64 machine? Would both ways be possible paths to arrive at the end goal of running Guix on the ppc system?
<dftxbs3e>marusich, hello! :-)
<dftxbs3e>marusich, you must compile GNU Guix from source on a powerpc64[le]-linux machine, then simply run `guix build hello` for example
<dftxbs3e>You must have an existing installation of GNU Guile etc. yes.
<GNUtoo>hi,
<GNUtoo>I install git-repo
<GNUtoo>And I've "CAfile: none CRLfile: none"
<GNUtoo>Which additional package do I need?
<vagrantc>GNUtoo: what exactly are you doing that says this?
<GNUtoo>I did that:
<GNUtoo>guix pack -RR -S /usr/local/bin/repo=bin/repo git-repo le-certs nss-certs
<GNUtoo>Then I unpacked that and used the following command:
<GNUtoo>repo init -u https://git.replicant.us/replicant/manifest.git -b replicant-6.0-dev
<GNUtoo>git.replicant.us uses a letsencrypt certificate
<GNUtoo>And the full error is this one:
<GNUtoo>fatal: unable to access 'https://git.replicant.us/replicant/manifest.git/': server certificate verification failed. CAfile: none CRLfile: none
<GNUtoo>Maybe I need to add git too to the list of programs to install
*GNUtoo tries adding python-certifi
<vagrantc>GNUtoo: https://guix.gnu.org/manual/en/guix.html#X_002e509-Certificates-1
<vagrantc>ooops, this is better:
<vagrantc> https://guix.gnu.org/manual/en/guix.html#X_002e509-Certificates
<vagrantc>GNUtoo: not sure how it works with guix pack, exactly, but i suspect the environments in which you want to use the pack need to have appropriate variables set
<GNUtoo>oh ok
<GNUtoo>Thanks a lot
<GNUtoo>That seem to bypass that error
<PotentialUser-47>Hello!
<PotentialUser-47>When will GuixSystem be upgraded to GNOME 40?
<vagrantc>when someone does the work, and since it's a large set of interrelated packages, it will probably go through staging or core-updates or something
<vagrantc>which gets merged into master periodically
<wleslie>squee!
<wleslie>wleslie@gauss:~$ ls /gnu/store/zxfv3i9wlnyhrbni51ycpjgvajs2w9xz-capros-build-0.1.0/host/bin
<wleslie>dbvol i486-mkimage lsimage lslog lsvol mkvol npgen segtest setboot setvol sysgen
<wleslie>host image tools for capros, built with guix. `guix system vm-image coyotos` is a little closer.
<KREYREN>does guix have options yet? e.g. compiling wine with cheerypicked components?
<abcdw>Packaged a plugin for OBS Stuio. The problem: OBS loads plugins only from its package directory or ~/.config/obs/plugins => that means I have manually simlink or copy resulting .so of the plugin to ~/.config/obs. Is there a way to solve this issue without manual simlinking?
***sorki is now known as srk
<leoprikler>you could patch the plugin loading code to also regard $GUIX_PROFILE/lib/obs in some way
***apteryx is now known as Guest98549
***apteryx_ is now known as apteryx
<raghavgururajan>Any idea about this error? https://paste.debian.net/1180280/
<abcdw>leoprikler: thank you for the idea!) if you remember any package examples, which do similar stuff - let me know, please.
<leoprikler>gtk does something similar for a different reason, grep for GUIX_GTK
<leoprikler>raghavgururajan: that code is a perfect example of 意味分かんない, it seems to be using C-style dot initializers in C++
<leoprikler>you may perhaps get around this by substituting ("\\.(.*) =" all var) with (string-append var " :")
***iyzsong- is now known as iyzsong
<Anonymous__>Hello
<Anonymous__>my system is sudenly giving a ton of message like
<Anonymous__>;;; In procedure load-thunk-from-memory: incompatible bytecode version
<Anonymous__>;;; WARNING: loading compiled file /gnu/store/hwa87ncnp1iv1nznhyaf88snrxx321ws-guix-module-union/lib/guile/3.0/site-ccache/gnu/packages/password-utils.go failed:
<Anonymous__>;;; In procedure load-thunk-from-memory: incompatible bytecode version
<Anonymous__>;;; WARNING: loading compiled file /gnu/store/hwa87ncnp1iv1nznhyaf88snrxx321ws-guix-module-union/lib/guile/3.0/site-ccache/gnu/packages/authentication.go failed:
<Anonymous__>when trying to use guix upgrade
<raghavgururajan>leoprikle: Perfect example of what? xD
<raghavgururajan>leoprikler: Is this correct? https://paste.debian.net/1180312/
<Anonymous__>:/ all operations on guix is giving those errors
<leoprikler>raghavgururajan: exactly. Now cross your fingers and hope it works
<raghavgururajan>hahah
<leoprikler>Anonymous__: might be a guile 2.2 vs 3.0 or 3.0.2 vs 3.0-latest issue
<Anonymous__>Maybe removing all from site-ccache helps?
<leoprikler>It's mostly harmless, since Guile will simply interpret the source code instead.
<raghavgururajan>leoprikler: Nope, same error. :(
<leoprikler>Is this on a foreign distro?
<leoprikler>raghavgururajan: in that case you might try newer versions of gcc and/or clang, or you could also write a patch reordering the fields
<leoprikler>in the initialization of course
<Anonymous__>nop, using Guix itself
<Anonymous__>Oh.. if the question was for me
<Anonymous__>Guix dont let allows to delete from this directory
<leoprikler>Yeah, it's harmless
<leoprikler>The Guix package itself is stuck on Guile 3.0.2 whereas your profile has 3.0.4 or even 3.0.5
<leoprikler>Those are sadly not bytecode-compatible to each other, hence the warning.
<Anonymous__>something strange happend im not able to just list /gnu/store
<raghavgururajan>leoprikler: Okay. So I need to add ("gcc" ,gcc-9) as input right?
<leoprikler>not sure which version telegram requires, but yeah
<raghavgururajan>Btw, does cmake uses gcc or clang?
<raghavgururajan>I thought I could just change the -std value, but didn't work.
<raghavgururajan>never mind. I see gcc during the build.
<Anonymous__>drwxrwxr-t 9696 root guixbuild 9797632 jan 9 06:10 store/
<Anonymous__>t is the bit which prevent write/removes?
<dftxbs3e>Anonymous__, I think it's a mount point, not sure
<leoprikler>Anonymous__: don't mess with the store, you want it to be read-only
<Anonymous__>the files which are failling to load is all /gnu/store/j1l58m8k5kxwmlp33yzqs4pq788xdnwy-guile-3.0.5/lib/guile/3.0/ccache/..
<Anonymous__>I wonder if there is a flag to ignore the cache
<raghavgururajan>leoprikler: Working with gcc9
<leoprikler>Anonymous__: what does (version) yield?
<Anonymous__>guile (GNU Guile) 3.0.4
<Anonymous__>guix (GNU Guix) 1.2.0-8.7624ebb
<leoprikler>then of course it won't load 3.0.5 libraries ;)
<leoprikler>try hash guile
<Anonymous__>I tried
<Anonymous__>I never manually installed the guile 3.0.5
<Anonymous__>I did a guix pull; guix upgrade
<Anonymous__>and it crashed aloned
<Anonymous__>alone*
***amfl_ is now known as amfl
*KREYREN got disconnected from the channel since his last reply x.x
<leoprikler>where did it crash? all you showed were warnings
<leoprikler>sneek: seen KREYREN
<sneek>KREYREN?, pretty sure was seen in #guix 2 hours and 2 minutes ago, saying: does guix have options yet? e.g. compiling wine with cheerypicked components?.
<leoprikler>I don't think so.
<leoprikler>You'll have to cherry-pick those components in your own recipe.
<Anonymous__>Well leoprikler i just rm'd guile
<Anonymous__>used guix remove guile, it remove the installed 3.0.4 and seems that the warning have gone
<Anonymous__>I will do anothet pull;upgrade and see whta happens
<Anonymous__>I have lost the crash message because of being dumb
<Anonymous__>I used the terminal and filled all the buffer ...
<KREYREN>leoprikler, i see x.x thanks for info
<abcdw>leoprikler: It seems I found a way to patch obs to accept PLUGIN_DIR via env variable. Now I have a question how to pass an environment variable to it?) native-searh-paths?
<leoprikler>if it's DIR, it's likely not a colon-separated path, right?
<abcdw>leoprikler: tried native-search-paths, works as expected, but didn't find any documentation about it.
***stikonas_ is now known as stikonas
<alextee[m]>Can someone help with bug#36900 and bug#42279 please?
<cbaines>alextee[m], where are you stuck?
<alextee[m]>cbaines: keymon doesnt start and fonts not showing in distrho ports
<cbaines>the not starting is probably the first thing to look at
<cbaines>do you have a theory as to why it doesn't start?
<alextee[m]>No idea, I don't have much experience with python on guix
<alextee[m]>Looks like it cant use python xlib properly
<alextee[m]>It thinks that python xlib is not installed if you run it with --pure --ad-hoc
<cbaines>looking at the code where it's failing, import xlib is the bit that's failing
<cbaines>I'd try running import xlib in guix environment --ad-hoc python@2 python2-xlib -- python
<cbaines>and see if you get the same error?
<alextee[m]>it says no module named xlib
<cbaines>interestingly, looking at python2-xlib, it seems to provide Xlib
<cbaines>and doing import Xlib seems to work
<alextee[m]>oh it's case sensitive
<alextee[m]>yeah Xlib works
<alextee[m]>do we have any other package that uses python gtk?
<cbaines>probably, why's that relevant?
<alextee[m]>maybe it does a hack to make it work
<cbaines>I'm thinking that it's probably key-mon that's probably in the wrong here
<alextee[m]>oh i could raise an issue in their repos but im not sure what exactly is the issue
<cbaines>the project looks dead to me, the source is being fetched from the Google Code Archive, is development still happening?
<cbaines>I'd perhaps try just changing the Guix package to change xlib to Xlib, and see if that works?
<alextee[m]>not sure how to do that o.o
<alextee[m]>it does look dead wow
<alextee[m]>maybe i'll try this instead https://www.thregr.org/~wavexx/software/screenkey/
<cbaines>If you want to try, I'd just look for a simple example of substitute* in another package definition, copy it, and then try and adapt it
<moesasji>pointed it out previously. The dependencies in the guix keymon package look strange compared to the ones used by Arch: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=key-mon
<sneek>moesasji, you have 1 message!
<sneek>moesasji, mdevos says: sorry, I don't understand what your trying to say. Doesn't the last sentence address the issue in the first sentence? I hope you can make it work, though! But I won't be working on that patch anymore.
<moesasji>sneek: tell later mdevos: difficult to explain as keyboard layouts are such a mess. My understanding of how initrd works is that you need to correct keyboard layout embedded and I don't think that is what your patch was doing. In any case probably more important things to work on than my corner-case.
<sneek>later, moesasji says: mdevos: difficult to explain as keyboard layouts are such a mess. My understanding of how initrd works is that you need to correct keyboard layout embedded and I don't think that is what your patch was doing. In any case probably more important things to work on than my corner-case.
<alextee[m]>cbaines: thx, i tried replacing import xlib with `import xlib as Xlib` but apparently that doesn't have the XEvents attribute
<alextee[m]>maybe this depends on an earlier version of python-xlib
<cbaines>Hmm, that's a shame
<cbaines>since this was released in 2014, that's possible
<cbaines>regardless, there's still something to be done about this, either fixing it or removing it
<dftxbs3e>alextee[m], the issue is that key-mon depends on itself, import xlib isnt wrongly cased, just it refers to xlib.py in the same directory. PYTHONPATH must not include key-mon itself somehow, maybe wrap it.
<dftxbs3e>"couger" is another package that does this.
<dftxbs3e>Maybe it is also because it refers to itself in nested subdirectories (src/keymon/xlib.py)
<cbaines>dftxbs3e, alextee[m] ah, good spot, so maybe "from keymon import xlib" instead of "import xlib" would work?
<alextee[m]>aahh there is XEvent, you're right dftxbs3e:
<cbaines>I don't think it's a wrapping issue
<alextee[m]>still can't find it with from keymon import xlib
<alextee[m]>i'll try wrapping like cougar does
<alextee[m]>er, how do you print again from a package definition?
<cbaines>(peek "FOO") should work, assuming you mean output during a build?
<cbaines>when testing "from keymon import xlib" in a REPL, I spotted an issue with six
<cbaines>looks like the python-xlib package doesn't propagate python-six, when it should
<cbaines>after fixing that, I'm back to the "Xlib.error.DisplayConnectionError: Can't connect to display ":1": No protocol specified" error
***sorki is now known as srk
<dftxbs3e>cbaines, propagating python-six fixes it for me, you got it - cc: alextee[m]
<alextee[m]>heh im still trying to figure out how to make it import from keymon
<alextee[m]>cbaines: can you pls upload your package definition somewhere?
<dftxbs3e>cbaines, alextee[m]: it also needs gdk-pixbuf+svg it seems
<dftxbs3e>it must be missing from propagation somewhere
<dftxbs3e>works for me with https://bpa.st/raw/I6EQ and by running: $ ./pre-inst-env guix environment --ad-hoc key-mon gdk-pixbuf+svg --pure -- $(which bash) -c 'DISPLAY=:0 key-mon'
<dftxbs3e>(on an X11 desktop)
<dftxbs3e>--pure ensures it really works standalone and doesnt depend on my existing env
<dftxbs3e>figuring out where to propagate gdk-pixbuf+svg remains to be found
<alextee[m]>meanwhile im trying to also package screenkey and i get this:
<alextee[m]>intltool-update -p -g screenkey
<alextee[m]>error: command 'intltool-update' failed with exit status 1
<alextee[m]>any ideas?
<alextee[m]>here is my package def https://paste.debian.net/1180332/
<alextee[m]>oh was just missing intltool
<alextee[m]>not sure if python packages are just dumb or guix doesnt handle them properly
<alextee[m]>this is trying to do libX11 = CDLL('libX11.so.6')
<alextee[m]>how can I fix this? i tried adding libx11 to propagated-inputs but it doesnt pick it up
<alextee[m]>ah i think i need to replace that with the absolute path
<alextee[m]>we dont have python-gtk for gtk3???
<alextee[m]>oh it seems it's included in main gtk 🤷‍♀️
<alextee[m]>it almost works now, same error as keymon: Unable to init server: Could not connect: Connection refused
<alextee[m]>No protocol specified
<alextee[m]>i'll send a patch anyway in case someone wants to get it working
<rlp10`>Hello, I'm new to Guix - and I'm messaging you from my brand new, freshly installed Guix box (although in a virtual machine, for now)! :)
<rlp10`>I was wondering, how do I manage Emacs packages so that they are "inside" Guix? Is that a thing?
<jonsger>rlp10`: nice! what do mean with inside?
<rlp10`>jonsger: Thanks for your reply :) What I mean is that there is an Emacs-way of configuringthings (it has a config file .emacs, or .emacs.d/init.el). But I assume that there might be a Guix-way of configuring things instead, so that it was transferrable to another machine? I had understood that to be part of the value proposition of a tool like Guix. Does that make more sense now? I guess I'm expecting there to be some config f
<rlp10`>somewhere I can edit or create which will allow me to select which Emacs packages are installed and how they are configured.
<rlp10`>Or maybe what I should be doing is creating a new Guix package (if "package" is the right name)?
<rlp10`>I picked Emacs because I imagine that it is a widely used and supported application under Guix. I thought it would be a good place to start learning/understanding how Guix works.
<jonsger>you can install packages either via `guix install emacs-foo` or add it to the packages section of /etc/config.scm (or whereever your config file is) and reconfigure afterwards...
<rlp10`>I see, when I install with "guix install", does that modify /etc/config.scm?
<jlicht>rlp10`: As you are new to Guix, I would ignore using it for now, but you might want to have a look at the guix-home-manager; I've been playing around on configuring Emacs using it, but it is still pre-alpha-quality stuff for now
<jlicht>and to answer your question: `guix install ...` installs packages to your profile ($HOME/.guix-profile) by default
<lfam>rlp10`: Regarding your last question: with Guix, package management is per-user, and the full distro Guix System also includes a concept of "system packages". What you do with `guix install` is just for the user that runs that command. Even the root user can have their own packages. The packages in config.scm are at the "system level" and available to all users, and cannot be managed with `guix install`
<sneek>Welcome back lfam, you have 1 message!
<sneek>lfam, efraim says: I just built pulseaudio on my aarch64 board for staging, no problems like seen on cuirass
<lfam>Thanks efraim
<lfam>Does that make sense rlp10` ?
<lfam>sneek: later ask efraim: Do you have any ideas about what is going wrong on Cuirass that is causing failures like that?
<lfam>sneek: botsnack
<sneek>:)
<lfam>sneek: later ask efraim: Do you have any ideas about what is going wrong on Cuirass that is causing failures like that?
<lfam>Sigh
<lfam>sneek: later tell efraim: Do you have any ideas about what is going wrong on Cuirass that is causing failures like that?
<omr>i'm trying out the guix distro through the qemu image, tried installing emacs-guix through guix package -i but emacs won't recognize anything but m-x guix-emacs-autoload-packages
<omr>ok now i tried 'guix package -i emacs guile emacs-geiser' and it worked...
<civodul>just read what omr wrote above: are we missing propagated inputs in the "emacs-guix" package?
<lfam>Hi civodul
<nojr>Does anyone have issues running QGIS or FreeCAD on a foreign distro? I always have issues related to python
<nojr>right now I have an error when launching FreeCAD: No module named 'WebGui'
<nojr>on QGIS it doesn't load several python modules correctly
<civodul>hey lfam :-)
*civodul never used freecad
<lfam>nojr: We changed the freecad package recently (within the last week): https://git.savannah.gnu.org/cgit/guix.git/commit/?id=ed2e0b1b50587a38ad26574585f73979874e56f0
<lfam>Do you know how to check if you are using the guix package with those changes?
<nojr>lfam: no I do not know
<lfam>And there was a bug fixed regarding qgis python plugins: https://bugs.gnu.org/42941
<lfam>nojr: What command did you use to install freecad?
<aecepoglu[m]>How should I license a package that states this: `All files in libs/ are distributed under GNU LESSER GENERAL PUBLIC
<aecepoglu[m]>LICENSE v2.1 with STATIC LINKING EXCEPTION as written below. All
<aecepoglu[m]>other files are under GNU GENERAL PUBLIC LICENSE v3.`
<civodul>hi aecepoglu[m]! as a rule, of thumb, take a look at the source file headers: they are the ultimate authority
<civodul>in particular, they say if it's "v3 only" or "v3 and later versions"
<civodul>if there are none, then the COPYING or LICENSE files will hopefully be clear enough
<nojr>lfam: guix package -i freecad
<lfam>nojr: Okay, have you run `guix pull` since then?
<nojr>yes before guix package -i freecad
<lfam>But not since then?
<aecepoglu[m]>civodul: this is the LICENSE file
<lfam>nojr: Not after?
<nojr>I ran guix pull then guix package -i freecad
<lfam>Okay
<nojr>no not after
<lfam>What is the "commit" from `guix describe`?
<nojr>I haven't ran it yet
<nojr>lfam: so should I run it again?
<lfam>What is the "commit" from `guix describe`?
<nojr>commit: 0fab032ae3849a8827b4ccf40d7a8f70090b4255
<lfam>Okay, then you should have the most recent packages of freecad and qgis
<jonsger>nojr: that QGIS problem is known to me...
<nojr>jonsger: freecad also fails to load several python modules
<nojr>it won't even finish launching the program
<efraim>lfam: sorry, no idea about cuirass
<lfam>The freecad / qtwebkit thing is incredible. It worked like 5 days ago
<efraim>marusich: I normally build guix from source and then use pre-inst-env to run the daemon until I can build all the way out to guix itself
<lfam>efraim: Thanks anyways
<lfam>It's good to hear that it works for you. It makes me feel less crazy
<efraim>Also I touched vtk, that might've broken something with freecad or qgis :/
<lfam>I think the freecad thing is a qtwebkit problem, so that seems unlikely
<lfam>I checked this about a week ago and it worked
<lfam>Freecad is supposed to use qtwebkit to launch a sort-of interactive splash screen when it launches
<efraim>I've never actually used it
<lfam>I only dealt with it during patch review
<efraim>Last I checked vtk still ftbfs on staging even with my recent commits
<lfam>Previously, freecad did not depend on qtwebkit, so this feature was broken already
<lfam>Huh, and now it works after launching the program a few times in a row
<lfam>nojr: The freecad webgui error seems to fix itself
<lfam>Maybe try logging out and logging back in
<nojr>lfam: i am going to do that
<nojr>I uninstalled and installed right now as well
<lfam>A lot of new visitors here lately!
<apteryx>lfam: wow, indeed!
<apteryx>That's neat. I wonder caught there interest :-)
<apteryx>what caught*
<apteryx>their*
*apteryx is not fit for writing today
<lfam>There was an article about bootstrappable builds on LWN a few days ago
<apteryx>Right I saw that one. Perhaps it's this!
<antidoto>I am trying to make mcron to run 3 commands once a day. I tried reading the mcron manual and experiment with different compinations but after altering and saving the .guile file, when I run mcron I get an error. If I remove the 2nd and 3d command mcron runs. If someone want's to help my file is at https://paste.debian.net/1180365/
<lfam>antidoto: Does it support multiple commands per-job?
<lfam>I don't have much mcron knowledge but based on your report, I would look into that
<terpri>antidoto, it only accepts a single command as the third argument (and some extra optional/keyword arguments after that), which can be either a shell-command string or a scheme function
<lfam>antidoto: Check the manual section 3.1.1 "Job specification": https://www.gnu.org/software/mcron/manual/mcron.html#Job-specification
<lfam>Specifically, "The second argument to the (job) function can be either a string, a list, or a function." and the rest of that paragraph
<terpri>antidoto, so you'd have to rewrite it as a single command linking them with "&&" (or ";" etc.), or as a scheme function
<lfam>What terpri said :O
<lfam>I mean, :)
<terpri>i was about to link to that info node too :p
<lfam>Does that make sense antidoto?
<lfam>A team effort, terpri
<antidoto>I appreciate your responses. As I understand, I either create 3 seperate files, or one that has job ((time settings) "command 1") & job ((time settings + 1 min) "command 2") & job ((time settings + 2min) "command 3"), is that correct?
<terpri>antidoto, you could i guess, but i'd recommend keeping it as one (compound) command if all the steps are supposed to run in order
<lfam>I would try something like this: https://paste.debian.net/1180367/
<lfam>A terpri said, you probably intended for these things to be run together
<antidoto>Thank you both, the code tepri send, solved it. I am really glad for your help. I wish that I could find more examples about mcron, so I would understand better how to do things. I am not a programmer so I just copy and paste things for trial and error.
<apteryx>Wouldn't it be preferable to set '--brief=no' as default for our SCM test driver? It's dead quiet for now, which is surprising (and the option not easily discoverable: SCM_LOG_DRIVER_FLAGS=' --brief=no').
<lfam>antidoto: Did you see the examples in the Guix manual? https://guix.gnu.org/manual/en/html_node/Scheduled-Job-Execution.html
<apteryx>with --brief=no, it prints a PASS/FAIL for each test case it runs.
<lfam>That's for the Guix test suite, apteryx?
<antidoto>lfam
<apteryx>lfam: yes
<antidoto>thank you, it is great resource.
<lfam>antidoto: Let us know if you have more questions
<lfam>apteryx: Seems like a good idea to me
<apteryx>OK. I'll propose a patch.
<apteryx>I'm looking at adding a way to select only test cases by their name
<apteryx>something like --select=regexp
<lfam>I do think a test suite is a case where silence is not preferred
<antidoto>Great, having a baby and a toddler only allowes me to study max 1 hour a day. This means 1 poject per day for me. If I fail and everyone goes to sleep, I will ask here. Have a great day/night. I will sleep well tonight knowing that mcron will do something for me to check in the morning. :)
<lfam>Okay :)
<apteryx>so, if we add both: SCM_LOG_DRIVER_FLAGS=' --brief=no' VERBOSE=1, make check is more suited for a test-driven development context
<apteryx>it prints what it runs, and it shows failures directly (you don't have to grep the log file).
<apteryx>ugh. The test-tmp/store in which tests are run makes it so that strip-store-file-name doesn't give the expected result
<doom_>hi. can anybody help. how use make on guix. trying to build st from source, but cannot c99 not found.
<doom_>/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-5.0.16/bin/sh: c99: command not found
<lfam>sneek: later tell doom_: With Guix, install the gcc-toolchain package in order to compile things by hand
<sneek>Okay.
<jgart[m]>what is the recommended way to install only uuidgen from util-linux? https://guix.gnu.org/en/packages/util-linux-2.35.1/
<jgart[m]>should I create a new package and inherit from it?
<lfam>Yes, although any significant Guix installation will already include util-linux, so you will probably not save any space or bandwidth by making another package
<lfam>But, there are reasons to do this sort of thing: https://github.com/lfam/pkgs/blob/master/leo/packages/moreutils-perpendicular.scm
<jgart[m]>lfam: I'm using guix on a debian server but I don't seem to have uuidgen in my path. I have not installed util-linux. Is util-linux supposed to be installed when installing guix?
<lfam>The only things that Guix puts on your PATH are from the packages you install with `guix install ...`
<jgart[m]>right
<lfam>But, you can check if util-linux is a run-time dependency of something on your system with `echo /gnu/store/*util-linux*` and poking around in the results
<lfam>That command works better on solid state storage
<lfam>If there is a copy of util-linux, you can see what refers to it with `guix gc --referrers /gnu/store/...-util-linux...`
<nij>Any simple example that showcases how a package is packaged with different compiling options in mind?
<lfam>What do you mean, nij?
<nij>"Package1 with option1=on, option2=off, option3=on".
<nij>"Package1 with option1=off, option2=on, option3=on".
<nij>Does the one who packages Package1 (like in this case), has to take care of 2^3=8 different scenarios?
<lfam>If the package is for GNU Guix, we typically make one fully-featured package
<lfam>Occasionally there will be different packages but it's quite exceptional
<nij>lfam: I see!
<lfam>And, there is not a standard way to achieve it. It depends on the build system used by the package
<GNUtoo>hi, I've tried guix pack yesterday and it seem to work fine
<GNUtoo>I'd like to use it for something official like distributing some binaries as part of a free software project
<GNUtoo>Is there a way to generate something that can be redistributed like that?
<GNUtoo>For instance I probably need a bit more than just generating a tarball of a binary, like shipping the source code as well, maybe the .scm used during the build or a way for users to reproduce that tarball
<GNUtoo>Is there some information on how to do that or is all that already included in the tarball somehow?
<atomsk298[m]>hello, I have a question regarding fprint. I have enable the service in my config and downloaded the needed files. What i'm trying to figure out right now is how to edit pam.d so that I can log in with my finger. I tried looking through the docs but can't find what I'm looking for. Any thoughts? i'm using the arch wiki for reference
<leoprikler>atomsk298[m]: you probably need a service for that, which extends pam
<atomsk298[m]>which service extends pam? The option I've found in the docmentation (pam-mount) doesn't seem to match what's needed
<cbaines>looks like Guix now has more than 15,000 packages now!
<cbaines>(this is counting by name, not name+version)
<cbaines>it was this change a few days ago that crossed the line http://data.guix.gnu.org/compare?base_commit=95e7542e6c6e2622b3ad7615a192d4c6af2579e7&target_commit=7144a2614c785c3aa0ec15d40c17cd3ea3f06169