IRC channel logs

2020-12-12.log

back to list of logs

<mdevos>all guix depends on gnutls. If guix version (n+1) build successfully (from guix version n), then that implies guix version n has a good gnutls
<sys2>ohh so this is just preventing the /next/ guix, but old ones should allow me to hop to the present?
<mdevos>sys2: I guess, I'm not time-travelling much myself
<sys2>seems odd I wouldn't be able to hop from the current point... maybe I'm misunderstanding
<sys2>yeah I only use things like this when something breaks. I remember once getting a good suggestion to boot into an older version when I got stuck on a kernel upgrade
<mdevos>the pulling process is a bit complicated
<mdevos>There is a package definition for guix, inside the guix source code
<mdevos>If you're pulling a newer Guix, ...
<sys2>same issue with old guix: https://paste.debian.net/1176543/
<mdevos>then guix pull creates a package definition from a template I think and replaces the source code iput
<sys2>so guix always builds from source? I know most use substitutes for /most/ packages
<mdevos>sys2: guix always builds from source, unless you're using substitutes. However ....
<kozo[m]>but those substitutes were built from source
<mdevos>If you're using guix pull to install a newer guix, then the newer guix is build as any ordinary package. But the (newer) guix package has depencies of its own, so the newer guix is build using packages defined in the older Guix. So a Guix(commit A) built from Guix(B) isn't necessarily the same as a Guix built from Guix(C), so the derivation is different, so they will be built separately
<sys2>so guix can't jump (if you've delayed updating for awhile) in the same way other packages can?
<mdevos>It's quite possible that ci.guix.gnu.org doesn't have a substitute for a Guix+(exact dependency versions) combination itself.
<sys2>either way I've disabled substitutes
<mdevos>sys2 (package jumping): yes! Time-travelling can be a big mess of timey-wimey
<mdevos>the package manager is special
<mdevos>(well, you could do guix package -i guix, but then you always get an older Guix, which isn't what you want)
<sys2>well it is if it'll get me to the present (even in a roundabout way)... but it seems like I need to go through all the versions? so I don't see a non-reinstall-y way forward
<mdevos>sys2: wait, I believe I see a problem!
<sys2>O.o
<mdevos>sys2: gnutls@3.6.12 used to build fine, but there are time issues (as you know)
<mdevos>sys2: so you would need to go back to a guix that uses a gnutls without time issues
<mdevos>sys2: alternative suggestion:
<mdevos>git clone the guix repo
<mdevos>add #:tests? #f for every definition of a gnutls package
<mdevos>(so that you don't miss any)
<mdevos>(perhaps use git grep -F)
<mdevos>(I'm presuming you have *a* gnutls in your environment)
<mdevos>build guix
<mdevos>./pre-inst-env guix pull guix
<mdevos>(with build guix meaning ./configure --localstatedir etcetera make in the git dir)
<mdevos>If the last step succeeds, you should have a reasonable guix system again!
<sys2>hmm, I don't understand the "build guix" part. I need to prep something before running the ./pre-inst-env command?
<mdevos>cd ~/where/you/have/downloaded/the/guix/repo
<mdevos>./confiure --localstatedir=/var
<mdevos>make
<mdevos>let it complete
<mdevos>now you have build a guix (in the more manual sense, not in the sense of guix build a-package)
<mdevos>and you can use it for testing without installing with ./pre-inst-env guix do-stuff
<sys2>./configure fails: No Guile development packages were found.
<sys2>:O
<mdevos>./pre-inst-env is a wrapper script changing the environment so you'll use the guix you have just build rather than the guix in the environment
<sys2>seemed like a good thought though. I'm guessing turning on substitutes back on might do it, but I don't think I'll do that
<mdevos>sys2: that failure was somewhat expected! Because ...
<mdevos>guix has some dependencies it requires for building
<mdevos>(One of which is guile-gnutls. Eeergh)
<sys2>heh, tricky bug
*mdevos will be logging off soon (getting late)
<sys2>no worries. appreciate the attempts!
<mdevos>sys2: could you do "guix edit guix"?
<sys2>+ I learned some stuff :)
<sys2>trying it now. no idea what it does
<mdevos>Copy that package definition somewhere
<mdevos>There is a problematic gnutls input
<sys2>add #:tests? #f and rebuild? ahh I see one in inputs and another in propigated-inputs
<sys2>havent learned about those yet
<mdevos>look at the source code of a recent guix and copy its gnutls
<mdevos>let's save the definitions gnutls-that-would-actually-build and guix-that-would-build-if-it-werent-for-gnutls in a single tricky.scm file
<mdevos>Also, beware: this guix package definition you now have definition refers to an ever older git commit! Replace it with a recent commit.
<mdevos>lik this: (version "1.2.0") (commit "799f066768bacb321ebad84c75b2bbfd269e7cd8"
<mdevos>and this: sha256
<mdevos> (base32
<mdevos> "04k8q5yjmxazskl13ap210jki2zh73zlzd0xdx06v08liskgz10q"))
<profmakx>guys, it seems that an installed encrypted guix asks for the passphrase twice on boot, once before grub starts and once after. is this intentional?
<mdevos>profmakx: yes, debian does it as well
<profmakx>but... why?
<mdevos>short answer: because GRUB and GNU/Linux kernel+userspace don' t communicate encryption keys
<vagrantc>profmakx: one for grub to decrypt the volume and load the kernel, initrd, etc. ... and one for the loaded operating system to decrypt the volue
<vagrantc>if guix supported an unencrypted /boot partition, that's one of the typical ways to work around that
<mdevos>sys2: also make sure your frankenguix refer to gnutls-from-the-present
<vagrantc>another would be to generate an initrd with an embedded decryption key ... but then that would have to not be in the store, since files in /gnu/store are world-readable
<mdevos>(well, gnutls-from-the-future from your broken guix perspective)
<sys2>mdevos: how do I do that? following so far (took the version + commit + hash from the most recent guix repo, as well as gnutls)
<mdevos>sys2: which step?
<vagrantc>what was sys2's problem to be on this crazy adventure of redefining packages? :)
<sys2>refering my current/franken-guix to gnutls
<sys2>vagrantc: :) https://issues.guix.info/44559
<mdevos>could you post your guix-gnutls-weirdness.scm?
<mdevos>paste.debian.etcetera
<sys2> https://paste.debian.net/1176547/
<sys2>it's picky (couldn't name it frankenguix because that's too long)
<vagrantc>oh, fun!
<mdevos>you see the guix inputs? It refers to gnutls somewhere
<sys2>haha, it's been awhile since I've been able to update. guix/gentoo are awesome systems... but I wish there was a way to prevent stuff like this. definitely want to get involved in a year or two
<mdevos>but gnutls itself is broken, and should be replaced with gnutls/fixed I think
<mdevos>I wasn't very clear I believe
<sys2>this: (gnutls (assoc-ref inputs "gnutls")) -> (gnutls (assoc-ref inputs "gnutls/fixed") ??
<mdevos>that doesn't need to be changed actually
<mdevos>It's this line: ("gnutls" ,gnutls)
<sys2>right under it there's (deps (list ... gnutls ...))
<sys2>ok changed
<mdevos>and this one: `(("gnutls" ,(if (%current-target-system) gnutls-3.6.14 gnutls))
<sys2>("gnutls" ,gnutls/fixed)
<sys2>ok got that one too
<mdevos>the idea is to replace gnutls-that-fails-to-build with gnutls-that-succeeds-to-build
<sys2>and just guix install -m frankenguix.scm?
<sys2>guessing I add "guix" to the end?
<mdevos>sys2: no!
<mdevos>don't install guix in the environment!
<sys2>xD so ready to do this lol. will be awesome to have fresh software
<mdevos>because guix install guix will always install another guix. Not the right approach
<mdevos>instead, do:
<mdevos>guix environment frankenguix.scm
<mdevos>then go to the git clone of the guix repose
<mdevos>s/:repose/repo
<mdevos>and now ./configure should succeed
<mdevos>(If you still get a message about not being able to build gnutls ...
<sys2>guix environment: error: /home/me/guix.scm: unknown package <- adding -m didn't do it either
<sys2>guessing guix environment takes an option?
<mdevos>guix environment -l franken.scm
<mdevos>guix environment PACKAGE ///// guix environment -l file.scm
*mdevos is logging of (it's late!)
<sys2>thanks again! will post here if I get it working (it doesn't seem to like that: https://paste.debian.net/1176548/)
***scs is now known as Guest87482
<mekeor>i'm planning to buy a single-board computer called APU2E4 and install guix on it and write such a guix-config that the computer creates a wifi-hotspot and routes all its traffic through tor. i thought of APU2E4 because it's an x86-architecture and has 4GB memory (which i think is useful for guix) and i really want something stable. what are your thoughts on the idea and on that hardware for that purpose? (
<mekeor> https://www.pcengines.ch/apu2e4.htm )
<mekeor>(actually it's an x86-64 architecture)
<mekeor>do you think 2GB should be enough?
<mekeor>maybe memory could be worth a paragraph in the user manual (→ 3. system installation → 3.2 hardware considerations)
<roptat>mekeor, I run guix on a system with 512MB of RAM, it's short when doing guix pull, but the situation improved a lot in the last couple releases :)
<roptat>the only problem would be the wifi chipset, there are only a few that are supported by linux-libre
<mekeor>roptat: the apu2 boards don't include a wifi chipset. but they have an pci-e port where i'm planning to plug in a libre-compatible wifi chipset
<mekeor>*miniPCI-e
<lfam>mekeor: I use an APU2 and it's definitely a stable system. I run Guix on Debian. It's slow but steady
<lfam>If you don't already have them, I recommend also buying some equipment to connect to the serial port
<lfam>I use a USB to serial interface with a null modem adapter
<lfam>Of course, Guix on Debian is not at all like Guix System. But the board seems used a lot for GNU / Linux
<lfam>mekeor: If you want, I can boot the Guix System installer on it and poke around
<mekeor>lfam: cool! which apu2 board do you have? :)
<lfam>apu2b4, which is an earlier revision. Should be the same but maybe a tiny bit worse
<mekeor>lfam: can i plug in a VGA-monitor on the DB9-port?
<mekeor>omg, i was thinking the DB9-port is like a VGA-port x)
<lfam>mekeor: It's a different number of pins from VGA. Is VGA over DB9 something you can usually do?
<lfam>Heh, it's the same form, just fewer pins
<lfam>It has USB 3, so you could do USB -> VGA / HDMI
<lfam>Or DisplayPort
<mekeor>cool. is there even an alternative to that? i guess, one could boot an operating system which launches SSH…
<lfam>That's what the serial port is for :) Console access when you need it
<lfam>You can connect to it using e.g. `screen` with the USB / serial adapter
<mekeor>whoa cool :O
<lfam>`sudo screen -t 'ttyUSB0 115200 8n1' /dev/ttyUSB0 115200,-ixoff,-ixon`
<lfam>So it's useful for installing the OS or upgrading the firmware
<mekeor>i guess some screens might have a serial port themselves huh?
<lfam>That would be nice!
<lfam>It's not really a video signal, more like a paperless teletype terminal interface
*jorge[m] uploaded an image: Captura de pantalla de 2020-12-11 00-40-12.png (71KiB) < https://matrix.org/_matrix/media/r0/download/matrix.org/RmUQCYMwSmjbgVfdpjsOIfYX/Captura de pantalla de 2020-12-11 00-40-12.png >
<mekeor>jorge[m]: maybe use lower-case?
<jorge[m]>Esto por que pasara?
<mekeor>jorge[m]: puedes tratar de escribir "guix install freeipmi", no "guix install FreeIPMI"
<mekeor>con minusculas
<jorge[m]><mekeor "con minusculas"> si,resulto gracias pero con la busqueda por que lo busco?
<mekeor>jorge[m]: porque guix no es tan intelligente como tu :D
<jorge[m]><mekeor "jorge: puedes tratar de escribir"> si,resulto gracias
<mekeor>de nada :)
<mekeor>lfam: so you have 4GB RAM though! :D do you have a wifi-card?
<mekeor>lfam: a wifi-card put into the mini-pci-e slot, i mean
<mekeor>lfam: i already looked up that the ethernet network controller uses the GPL-licensed igb (intel gigabit) driver :)
<lfam>4 GB RAM, no wifi
<lfam>The ethernet NICs are good quality
<charles`>raghavgururajan what should the /etc/config.scm look like for the wip-desktop branch? Specifically the services part.
<ryanprior>Anybody know how well Guix System works on Purism devices?
<ryanprior>sneek: later tell lemes: I saw your blog post, great idea & glad you're working on it! What do you think about having a `guix versions` command that shows past package versions & what commits they're reachable by?
<sneek>Okay.
<ryanprior>fanks sneek
<spudpnds>Heya! I'm trying to install emacs 27.1 on Guix. "guix package -i emacs" installs emacs 26.
<spudpnds>"guix package -i emacs@27.1" gives me an error.
<spudpnds>"guix package -i emacs-next" gives me 27.0.something.
<spudpnds>Any ideas?
<spudpnds>I can see that the package exists: https://guix.gnu.org/en/packages/emacs-27.1/
<spudpnds>But I'm pretty confused as to how to install it.
<mange>Hmm. What's the output of `guix describe`? I think it's likely that your guix is out of date. You can pull it up to date by running `guix pull`.
<spudpnds>So I've run guix pull a few times.
<charles`>ryanprior I haven't tried it, but it should work since purism devices are designed to run libre OSes
<mange>What does `guix describe` say? You may still be running an outdated guix if your environment isn't set up right.
<spudpnds>guix describe: error: failed to determine origin
<spudpnds>hint: Perhaps this `guix' command was not obtained with `guix pull'? Its version string is 1.1.0-17.36a1925.
<mange>Yeah, there we go. Can you try sourcing ~/.config/guix/current/etc/profile in your shell, then trying `guix describe` again?
<spudpnds>Yup.
<spudpnds>Ahhh, my path was getting guix from pointing ~/.guix-profile/bin/guix
<spudpnds>Rather than ~/.config/guix/current/bin/guix
<spudpnds>I have GUIX_PROFILE set to ~/.guix-profile, and in my .bashrc I source $GUIX_PROFILE/etc/profile. I take it that's ... wrong?
<spudpnds>I think I don't understand profiles. I'll go read more docs :)
<mange>The way Guix pull works these days is that it sets up a separate profile for Guix itself in ~/.config/guix/current, which then also needs to be sourced.
<mange>If you're on a Guix system then it should happen as part of /etc/profile, but if not then you have to make sure you do it yourself. I assume this is mentioned somewhere in the manual, but I don't know where off the top of my head.
<spudpnds>Ok cool!
<mange>It looks like it's mentioned in "(guix) Getting Started" and "(guix) Invoking guix pull", but it's not super prominent in either place.
<spudpnds>Thanks for the tip.
<spudpnds>I have to say, moving back and forth generations is amazing.
<spudpnds>I updated my emacs-guix package and it broke something, and I can debug it by flipping back to the previous version and seeing what's different.
<blendergeek>I run GuixSD and I am trying to compile program that uses the gmime library. This isn't a Guix package. I finally got gmime installed and included but now I get the following error message: In file included from gmime-test.c:2:
<blendergeek>/home/timothy/.guix-profile/include/gmime-3.0/gmime/gmime.h:25:10: fatal error: glib.h: No such file or directory
*apteryx is cooking a package.el based site-start.el loader for Guix
***amfl_ is now known as amfl
<guix-vits>blendergeek: did u installed 'gcc-toolchain'? instead of gcc.
<pkill9>for people who use guix as a package manager on a foreign distro, how good of an experience is it? does everything just work?
<sneek>pkill9, you have 1 message!
<sneek>pkill9, civodul says: that looks like a shadowsocks packaging bug, probably worth reporting to bug-guix@gnu.org
***scs is now known as Guest87665
***apteryx_ is now known as apteryx
***rekado_ is now known as rekado
<raghavgururajan>sneek, later tell charles`: It should be %generic-desktop-services
<sneek>Will do.
<raghavgururajan>sneek, later ask dannym: Would you be able to push the #44957 v4 patch-set without cosmetic changes patch?
<sneek>Got it.
<dftxbs3e>sneek, later tell civodul: Sorry about the electrum patches mess.. git-send-email is just a mess, it doesnt account for mistakes and being able to revert them (can't delete sent emails..) - it's unclear whether things succeed or not, combined with spam filters rejecting or delaying mail arbitrarily ..
<sneek>Will do.
<dftxbs3e>how would you include the code of some file inside config.scm? I am trying to get unattended-upgrades to use my /etc/guix/channels.scm file
<dftxbs3e>Would local-file do it or..?
<dftxbs3e> /run/current-system/channels.scm even
<dftxbs3e>I think I succeeded. I copied the facility from guix/scripts/pull.scm
<dftxbs3e>load-channels function in particular
<dftxbs3e>It wouldnt work
<dftxbs3e>succeeded with:
<dftxbs3e> https://paste.debian.net/1176580/ - if that's of interest to anyone
<dftxbs3e>sneek, later tell charles`: Been using Emacs ever since we talked, it's going on OK but autocompletion is really bad, geiser/company can't autocomplete GNU Guix's code itself, it misses lots if not everything.
<sneek>Got it.
<leoprikler>dftxbs3e: there are some snippets for packages at least :)
<dftxbs3e>leoprikler, yes, but also speaking of GNU Guix's internal code
<dftxbs3e>It seems macro-heavy (especially as complete as Scheme macros) languages can hardly be autocompleted
<guix-vits>pkill9: on Armbian, with rockpro64 (aarch64), no gui app installed via Guix have worked for me. when i installed Guix System, all were ok. idk why.
<vldn>someone runs nix on guix system?
<vldn>with herd start nix-daemon i get /run/user/uid/shepherd/socket not found
<guix-vits>vldn: try sudo
<vldn>service not found
<guix-vits>.. by default there is no user's Shepherd instance..
<guix-vits>vldn: try `guix system search nix`
<guix-vits>also `sudo herd status`
<guix-vits>also nix should be instaled in config.scm
<guix-vits>afaik
<vldn>how do i set the service for it in config.scm? just installed it via (packages)
<vldn>the Rest of your commands are running
<mdevos1>vidn: package != service. Packages are just binaries, documentation, etcetera, while services actually run daemons
<vldn>yes i know it from nixow
<vldn>nixos
<vldn>whats the right Definition to include it in the (services)
<mdevos1>(and the daemons' executables are in a package)
<procra02>civodul: thanks for the help about the network the other day, it worked
<vldn>or where can i found it?
<mdevos1>vidn: I don't use nix, but you could look in the guix manual
<mdevos1>search for nix-service-type
<vldn>in guix system search it shows the Shepard Name is nix-daemon and it's in GNU/services/nix
<vldn>alright thx
<procra02>now, someone know how to install a custom xkb keyboard? and how set a gtk theme?, I have a error with "lxappearance" setting one on a emacs-exwm session, I set one on gnome bot, it did not apply to other sessions.
<kisaja[m]>btw suckless playing a big game against every bit of gnu
<kisaja[m]>lxappearance didn't work for me too on i3, and it doesn't notice packages like *-gtk-theme from guix
<guix-vits>kisaja: modern gnu weights in mib. 'cause modern.
<guix-vits>u're badly mistaken. really, suckless playing a big game against every _mib_ of gnu.
<guix-vits>℅|
<profmakx>zanz
<profmakx>sorry
<guix-vits>sneek seen zanz
<sneek>Not as far as I can remember.
<guix-vits>sneek seen gans
<sneek>gonz_ was in (here?) 5 months ago, saying: Now, for a short blackout, as I say goodbye to my EC2 instance..
<guix-vits>gans > zanz (powered by sneek)
<guix-vits>sneek whst is guix
<sneek>So noted.
<guix-vits>sneek forget
<guix-vits>lol
<guix-vits>nckx: we're lost sneek
<guix-vits>^^^
<vldn>how to import a directory with package definitions inside the (packages) in config.scm?
<vldn>like bin/prog1.scm bin/prog2.scm
<guix-vits>vldn: either `guix system rrconfigure -L ./bin config.sm.cm`
<vldn>i meant per Definition to include some selfdefined packages that are not available in the channel
<guix-vits>vldn: or (add-to-load-path "path") inside config.scm
<vldn>thats it ty very much :))
<guix-vits>vldn: be sure that there is no (for example) a guix git tree under ./bin. or it may compile a lot.
<kisaja[m]>was on sddm wayland, deleted that stuff from config, to get back to gdm xorg, now org.freedesktop.accounts org.fre....policykit1 timed out on boot, new sessionof user gdm, and some kind of freeze, can't change tty. when on grub choose older configuration it boots sddm normally
<kisaja[m]>i entered working kernel config, did guix pull fixed internet and reconfigured, still freezes. did i have to do guix package -u?
<kisaja[m]>can i extract working config.scm from a working system that is offered as old on grub? maybe i forgot to change something
<guix-vits>kisaja: try /run/current-system/config.scm
<guix-vits>it was somewhere there
<vldn>that killed me on nixos a lot xD
<guix-vits>they also should be stored somewhere, as generations...
<vldn>find /gnu/store -iname "config.scm"
<guix-vits>vldn: var/guix
<guix-vits>it has profiles, store is mess
<kisaja[m]>ty
<guix-vits>+1
<mroh>`guix system list-generations | grep configuration` gives the config.scm for every generation.
<vldn>nice :)
<vldn>is lutris nonfree?
<vldn>is it worth contributing a package?
<vldn>(game library and wine management like playonlinux)
<kisaja[m]>parabola blocks it because it promotes only nonfree software for nonfree os i think
<kisaja[m]>see in parabolas git 'freedom' package
<vldn>mhh
<guix-vits>tbh, our maintainers may possess another opinion. if wine packaged in guix?
<vldn>i don't see the point why it is blocked just because it allows you to install proprietary packages
<vldn>so we block the guix channel feature also..
<vldn>*should
<guix-vits>they not block it. they just reject it to their repo.
<guix-vits>quite a diff :) (unlike linux-libre kernel, which actually blocks attempts to use nonFree).
<vldn>i heard that it is a bug that you cant Load nonfree Firmware? but read about both sides
<mdevos1>sneek: seen sneek
<vldn>will try to commit a lutris package in the feature and let's see if i'll get slain for my request xD
<vldn>*future
<guix-vits>gnu's black ops team, like in hl1.
<guix-vits>can be negotiated with fsf japan. ginja.
<kisaja[m]>linux-libre has that kimd of name, it would look stupid to have *-libre with nvidia and not call it a fork
<guix-vits>that a chance for Stallman to return to fsf. as chief gnuisance, that is.
<guix-vits>ginga chief.
<guix-vits>kisaja: 1:1 what i thought trying repair the boot of my box recently.
<kisaja[m]>perfect config, but reconfigure makes a frozen screen os
<guix-vits>kisaja: try maybe if u have time: --no-grafts during reconfigure? idk, just.. maybe a security update does it now? idk.
<guix-vits>i've no other stupid ideas, devs?
<mdevos1>kisaja: is it that thing with the gdm login screen saying ‘oops there is a problem (sad face)’ or something like that?
<mdevos1>I had that a while ago sometimes
<kisaja[m]>i get to 'new session gdm user' console message and it freezesthere on console
<mdevos1>though I could switch virtual terminals just fine
<kisaja[m]>tty is frozen too, but power button works, i force poweroff
<mdevos1>kisaja: could it just be GDM being slow to boot, and plenty of IO making everything slow? (The former is (or was) sometimes the case, and the latter is often the case on my machine when building things)
<kisaja[m]>oh, i went further back in grub menu, entered 100%working gdm system, same freeze happens
<vldn>sudo herd status kisaja[m]
<vldn>or something spooky in" top"?
<mdevos1>kisaja: idk what's going on, I can't offer any further assistance
*mdevos1 away-from-chat
<vldn>Ctrl alt F1-8 isn't working?
<kisaja[m]>guess when i entered kde-sddm didn't know theres no comming back
<kisaja[m]>tty change frozen
<kisaja[m]>ctrl alt f2... i mean
<vldn>freeze after gdm is loaded and you can't choose a user?
<vldn>or before displaying
<kisaja[m]>i just see same console.. welcome to gnu.. firware...service... sessiom gdm those are some messages in it
<kisaja[m]>no gui at all
<kisaja[m]>will no-grafts keep my users profile untouched?
<vldn>no-grafts is for installing without security patches i think
<vldn>but i'm in the guix world myself just 3 days xD
<vldn>so noob alert
<MSavoritias[m]2>Maybe if the default nonfree options are removed.
<MSavoritias[m]2>I don't see why not then
<vldn>okay :)
<kisaja[m]>im fine with x11-sddm, guess won't even try with fully upgraded system and user to reproduce gdm freeze
<guix-vits>kisaja: maybe try sway-wm? still wayland.
<guix-vits>also i not sure if gdm on guix has wayland.
<kisaja[m]>it doesn't
<vldn>bloated anyway :D
<vldn>mh add to Load path doesn't work
<vldn>is there an example to implement it?
<vldn>(to include a directory with package definitions in my config.scm)
<thorwil>hi! trying to update my 10 day old guix. `guix pull` fails with “\substitution of /gnu/store/q0s3bi0by383cqzl9zz1wf74p6pdl3fc-libx11-1.6.A-doc failed”. if i try with `--fallback` i basically get a list of substitution failures.
<thorwil>has there been a critical change recently?
<guix-vits>vldn: if ur dir contains modules, then add-to-load-path work. for plain scheme code, use (load "file")
<kisaja[m]>how can i replace dm by .xinitrc. i need only env variables right?, so how do i enter static comands that would work even after upgrade, for example SOMETHING=/gnu/store/*bash/bin/sh
<vldn>no its a pypi package generated with guix import guix-vits
<vldn>but after i used add to Load path the package is not found
<guix-vits>vldn: paste the pypi package definition?
<vldn> https://bpa.st/UCAA
<guix-vits>is it all file?
<vldn>yeah
<guix-vits>if so, use (load "file"). or u need something with scandir and for-each.
<guix-vits>but easier is to create a module, and then add-to-load-path will work.
<vldn>and how can i make this file to a module?
<vldn>already looked on the defining module page but didn't worked
<guix-vits>see: ./bin/file.scm
<guix-vits>is (define-module (bin file)) at the top.
<guix-vits>also u need, aside add to load path: (use-modules (bin file))
<guix-vits>in config.scm
<vldn>and then is it added to the packages automatically or do i have to add it there too?
<guix-vits>i think, it only working for system. for packages u need either: additional channel, or make a manifest (see guix manual)
<guix-vits>manifest may contwin any code, but last expression should return a manifest.
<vldn>reconfigure complains about no code for module (bin autotiling)
<guix-vits>vldn paste config.scm?
<guix-vits>it basically should work, i sure.
<vldn>is (add-to-load-path "/etc/guix/bin") right?
<vldn>add top of config.scm
<vldn>*at
<guix-vits>ye, if bin contains module.
<guix-vits>also module should only define things. so (define-public python-autotiling (package ...))
<guix-vits>not (define -module ...) (package ...)
<guix-vits>+ https://www.gnu.org/software/guile/manual/
<guix-vits>* define-public after define-module
<vldn> https://bpa.st/YKOA
<guix-vits>is right
<guix-vits>...
<vldn>and package
<vldn> https://bpa.st/JVUQ
<guix-vits>before use-modules, (add-to-load-path "/etc/.../bin")
<guix-vits>in config
<vldn>Tried before :(
<guix-vits>w/o it will know nothing about where to find this module
<vldn>still no code for module
<guix-vits>vldn: module name should contain a path
<vldn>ah
<guix-vits>if u added dir /etc/guix/bin
<guix-vits>then it is just autotooling
<guix-vits>if it was (add-to... /etc/guix)
<guix-vits>name of module was as it is
<guix-vits>(bin autotooling)
<vldn>now it looks good :)
<vldn>just have (autotiling) now :D
<guixy_>what is the best site-specific browser available on guix?
<guix-vits>? site-specific
<vldn>whats site specific?
<vldn>i use ungoogled chromium..
<guixy_> https://en.wikipedia.org/wiki/Site-specific_browser
<vldn>ah
<guixy_>I use a site-specific browser for productivity. No worrying about tabs.
<vldn>something like webview for android
<guix-vits>guixy_ for which site?
<vldn>i used a custom userchrome.css file for Firefox and chromium long time
<vldn>to hide my bars and everything
<vldn>maybe take a look at qutebrowser
<guixy_>Any site. I guess I just want some sort of manager.
<guix-vits>guixy nomad, but it is alpha.
<guix-vits>written in guile, uses webkit by default.
<vldn>or nyxt
<guixy_>I use ungoogled-chromium right now, but it's bloated. Same with icecat.
<vldn>i used qutebrowser but not having ublock origin is annoying
<vldn>but maybe i'm just on the wrong sites :P
<guixy_>Speaking of ublock origin, is it still included in icecat?
<guix-vits>guixy: if no, downloads from addona.mozilla usually do work, anyway.
<guix-vits>btw, guixy_: > GNOME Web ("Install Site as Web Application" feature)
<guix-vits>gnome know weird things, probably it is what u want.
<guix-vits>didn't used myself, but epiphany is a quite generic browser like chrome or firefox
<guix-vits>* didn't used site->app
<guixy_>I'll work something out. Anyone use guile-wm?
<vldn>last commit 17 month ago
<vldn>no is it good?
<guixy_>I think it usually fails because it isn't generic enough. You need to configure everything.
<vldn>i'm waiting for a guile wm for wayland :D
<guixy_>I'm going to try to make a guile-wm configuration for a pinephone. See if tiling makes it any better.
<guix-vits>guixy_: do u have a dock for pinephone with the ethernet thingy?
<vldn>mh it not complains about anything but the package is not installed guix-vits
<guix-vits>is it added to packages field?
<guix-vits>in operating-system
<guix-vits>in config.scm
<rekado>guixy_: “GNOME Web” is available in Guix as “epiphany”
<vldn>with "autotiling" added it says unknown package
<guix-vits>vldn: for '(define-public X (package ...))' u want X
<guix-vits>(packages (... X))
<guix-vits>name (field in (package ...)) used on command line, but currently u operate on a file.
<guix-vits>vldn: the autotiling is a module name. the (packages ...) needs a package name.
<guix-vits>if u have any troubles, paste more
*guix-vits afk
<vldn> (packages (append    (map (compose list specification->package+output) `( "autotiling" "redshift-wayland" [....]
<vldn>ah maybe because of the ℅base-packages at the End of the list? :D
<vldn>python-autotiling AS in the package Definition doesn't work
<guixy_>guix-vits, yes, but it doesn't work half the time, and QT apps can't be moved. It currently runs manjaro, but I want to eventually make it run guix with a keyboard-independent tiling wm.
<guixy_>manjaro-phosh
<guixy_>There's one package with the Julia build system. I didn't know that was a thing.
<procra>Did someone know how to set a custom x11 keyboard an how to change the gtk theme on EXWM?
***scs is now known as Guest44764
<Aurora_v_kosmose>Packages include their outputs' hash. What happens if a graft changes an output's hash?
<Aurora_v_kosmose>Or is it their input? Oh that'd be an embarrassing assumption...
<Aurora_v_kosmose>My apologies. That's input. Makes sense. Nevermind me.
<PotentialUser-28>Which gnu/packages/*.scm file should I edit to add a computer-aided knitting program (controls knitting machine to knit patterns/images)?
<Aurora_v_kosmose>Where are other CAD things?
<PotentialUser-28>In engineering.scm mostly, but it's not related to engineering.
<Aurora_v_kosmose>Ah, it's not some industrial machine?
<PotentialUser-28>It's a basic knitting machine with a modified controller (Arduino + Shield).
<Aurora_v_kosmose>Oh neat.
<Aurora_v_kosmose>Someone else might have a better idea.
<Aurora_v_kosmose>Hmm... wouldn't grafting have issues with languages that only produce static libs?
<OriansJ>Aurora_v_kosmose: the hash is of the inputs; those static libs wouldn't have different names or paths.
<Aurora_v_kosmose>The grafts article's paper did explain it legibly. How nice.
<civodul>Aurora_v_kosmose: grafts make sense if package reference to one another, for instance via shared libraries or commands
<civodul>IOW, it's for run-time references, not build-time references
<civodul>so it won't work for static libraries
<Aurora_v_kosmose>civodul: So one would have to manually mark them as such?
<civodul>Aurora_v_kosmose: no, it's just that grafting wouldn't happen
<civodul>it's the same for all build-time dependencies
<civodul>for example, if a package relies on Bison at build time
<civodul>and then you add a 'replacement' field to Bison
<civodul>then this will have no effect, because packages rely on Bison at build time only
<Aurora_v_kosmose>Wouldn't that mean that say... Golang before -linkshared became a thing would've had to wait for a full rebuild cycle rather than benefiting of grafts?
<civodul>yes, probably
<civodul>in practice it's less of a problem to rebuild Go packages though
<civodul>compared to what would happen if you change glibc, openssl, etc.
<Aurora_v_kosmose>That's true.
<pinoaffe>does guix support colourful output for things like `guix search`?
<pinoaffe>and if so, how do I enable it?
***altomcat is now known as Triton
<ryanprior>pinoaffe: no colorful output, but it's in recfile format so you might be able to write a nice colorizer for it using recutils. (And if you write it in Guile, we might be able to incorporate that upstream.)
<dissoc>anyone know why jconsole wont open with openjdk packages?
<PotentialUser-85>I'm packaging a python program and I get a "no setup.py found" error when I try to compile it.
<PotentialUser-85>I just copied the output of guix import pypi.
<ryanprior>PotentialUser-85: the importer isn't perfect, it's possible there is no setup.py (or it's in an unusual location or something) and we'll have to handle a special case.
<ryanprior>PotentialUser-85: can you share your package so we can take a look at the details?
<PotentialUser-85>ok thanks
<guix-vits>vldn: i not sure, but try for meantime: (packages (cons python-sutotiling (append ...))).
<guix-vits>maybe the specification->thingy isn't see autotiling. use variable's name
<guix-vits>(define-public VNAME (package ...))
<PotentialUser-85>ryanprior: The python program that I am trying to package is ayab (https://github.com/AllYarnsAreBeautiful/ayab-desktop).
***scs is now known as Guest6425