IRC channel logs

2020-11-21.log

back to list of logs

<roptat>what are prerequisites for being able to use a specific --target in guix?
<roptat>I'm trying to run "guix build hello --target=x86_64-linux-android", but it fails with dynamic linker name not known for this system "x86_64-android"
<roptat>does that mean there's a support missing somewhere in guix?
<mbakke>roptat: it means there is no bootstrapping path for x86_64-android, see (gnu packages bootstrap)
<roptat>even though I'm using --target and not --system?
<roptat>ah, I think I see what's happening, thanks for the pointer!
<Formbi> https://termbin.com/r2qu
<Formbi>hmm
<Formbi>what can it mean?
<dftxbs3e>nckx, sent a comment with updated patches: https://issues.guix.gnu.org/38459
<dftxbs3e>nckx, is it OK to skip reproducible builds for now for powerpc64le-linux-gnu? It's been the major blocker in marusich's work
<dftxbs3e>nckx, if you can merge that patch on this issue against master, please do..
<dftxbs3e>The wip-ppc64le branch will be more useful for later changes relating to individual softwares not compiling
<nckx>dftxbs3e: I'm just about to go to bed. Thanks for the answer. Non-repro: that's fine for now, for the wip-ppc64le branch.
<nckx>o/
<dftxbs3e>nckx, What about master? Good night!
<roptat>looks like I was bored tonight: https://framagit.org/tyreunom/guix-android/-/blob/master/android/import/repo.scm
<roptat>:)
<roptat>also I managed to write the missing low-level bits of the rtnetlink protocol, so I'm going to write the high-level bits now
<Formbi>looks nice
<Formbi>but I don't understand what it does :(
<roptat>for now, it only gets a manifest from android sources and uses it to learn which repositories to clone; then it clones them all in a directory. next step is to list all Android.bp files, parse them and return a list of packages that build each component.
<roptat>that means writing a blueprint-build-system, and I do have a plan for that :)
*roptat zZz
<db48x>does anyone know what needs to be installed for python3's urllib to be able to verify SSL certificates?
<db48x>I tried installing nss-certs
<db48x>(this is just guix, not a guix system)
***daviid is now known as Guest64948
***Guest64948 is now known as daviid
<wleslie>I have a cross compiler with libgcc and some custom crtfiles built, but the cross compiler is trying to link against crtfiles from the native glibc for some reason
<wleslie>can I remove these from the load path, somehow?
<wleslie>maybe - is there a macro for changing the %current-target-system for some dependencies? maybe that will remove native libraries from the load path...
<wleslie>ooh, current-target-system
*wleslie looks at (guix build-system gnu)
<wleslie>I hacked a thing with `package-with-explicit-inputs` of which I'm surely missing several
<abcdw>hey guix!
<wleslie>(hey! abcdw)
<abcdw>wleslie, (:
<wleslie> https://bpa.st/GCEA I've just added the (cross-package) function and now a request to build just hangs, nothing after a note about some source files newer than compiled files
<abcdw>roptat, Will we do some kind of test call before tomorrow?
<wleslie>replaced that function, now just using (arguments '(#:implicit-inputs? #f))
<wleslie>:/ so newlib depends on crtfiles but there's no package for it in my store
<wleslie>oh, it is in my store.
<wleslie>and the crtfile location is passed as a configure argument
<wleslie>ok, removed the single quotes from the configure-flags CFLAGS and now it configures and I get to figure out why it doesn't make
<roptat>abcdw, we tested it with zimoun, but if you want to test it too, we can do it
<abcdw>roptat, yep, I would like to check everything working.
<abcdw>If you have free time today, please let me know.
<roptat>we can do that now :)
<abcdw>roptat, cool, let's do)
<sss2>hi all, why guix installer does not have option to configure network manually ?, requirement of dhcp server is a problem ...
***sneek_ is now known as sneek
<mroh>db48x: something like `export SSL_CERT_DIR=/etc/ssl/certs` should help.
*nckx removes scam spam.
<roptat>how?
<nckx>sed.
<roptat>then... from where?
<nckx>The logs.
<roptat>oh
<roptat>I'm cloning the android source repositories... I'm amazed: one of them takes 2.1G even though I'm doing a shallow clone
*nckx can't reach into your client, as much as I'd like to.
<roptat>:)
<nckx>Does it include the Linux kernel? That alone's close to 2GiB nowadays.
<nckx>Mine is 2.9 but it's full of crap.
<roptat>oh, that's prebuilts/clang/linux-x86
<nckx>Ah.
<nckx>Versioned-controlled binaries means reproducibility.
<roptat>I doubt it's really sources, from the name ^^
<roptat>well yeah, if everyone downloads the same binary, it's reproducible, right?
<roptat>;)
<roptat>I should probably prevent it from downloading these prebuilts
<nckx>Can git do that?
<roptat>it's a separate repository, so not running git can do that
<roptat>30 GB already and I need to clone 649 more repos...
<roptat>and... no space left
<zzappie>roptat: so terrible...
<OriansJ>roptat: clearly need a bunch more 100TB SSD drives
<roptat>yeah, and I can't guix gc more than that...
<roptat>how do you change a parameter in guile?
<roptat>ah, parameterize
<civodul>ah yes, codename "srfi-39" :-)
<giaptx`>Hello everyone, I'm trying to setup Guix as main OS replace my Debian
<giaptx`>I would like to use Unbound service
<giaptx`>I see guix had unbound package, but doesn't provide unbound service
<roptat>ok, I set %repository-cache-directory to my 2TB HDD, that should help ^^'
<roptat>hi giaptx` :)
<giaptx`>So do I have to define a new unbound-service-type?
<giaptx`>Thanks
<roptat>indeed, we don't have an unbound service type yet, so if you want unbound, you'll need to create the service yourself
<roptat>there's the knot-resolver-service-type that seems to do something similar to unbound though, if you're willing to use something else
***giaptx` is now known as giaptx
<roptat>defining a service is not necessarily too complicated: the easiest way to do it is to follow what the opensmtpd-service-type does: you only provide an option for selecting the package and a configuration file, and you run unbound with that file
<roptat>it's much nicer if you provide an actual record type with all the configuration options, but that'll take more time to create :)
<giaptx>Thank you very much.
<giaptx>it is a good suggestion to begin
<roptat>so, without any prebuilt, android is 26GB of sources
<roptat>with shallow clones, too
<roptat>about 800 repositories
<brettgilio>The talks are great!
<brettgilio>Kudos to all
<brettgilio>I have enjoyed watching them
<brettgilio>Just a reminder, for you Emacsers here, EmacsConf 2020 is next weekend! You can join us in #emacsconf and I will be giving a talk too! https://emacsconf.org/2020/schedule/
<zzappie>woo guix day tomorrow
<brettgilio>And thanks to roptat for hosting the talks :)
<brettgilio>For guix day
<brettgilio>And bandali for emacsconf
<bandali>:-)
<roptat>zzappie, have you watched the talks yet? https://xana.lepiller.eu/guix-days-2020/
<roptat>you need to watch them before the conference if you want to participate
<roptat>we'll have extended Q&A only
<brettgilio>Hey does Zimoun hang out on here?
<brettgilio>Well regardless roptat, the "bug" with ocaml-cairo2 that I had to disable tests for is fixed in the cairo2 tree, but isnt yet tagged. https://github.com/Chris00/ocaml-cairo/issues/19
<brettgilio>It was a regression introduced when we moved to ocaml 4.11.c
<brettgilio>4.11.x*
<brettgilio>So we could cherry pick that commit to fix it as a patch, or bump the commit. Either way would fix the test cases
<zzappie>roptat: yes watching them right now :)
<roptat>brettgilio, yes, could you extract that fix and make a patch from it?
<brettgilio>roptat yeah. But it wont be today.
<roptat>it's fine
<brettgilio>Im off for now. Later all!
<mdevos>Does someone have an idea why my frama-c-gui doesn't find ocamlgraph?
<mdevos>package definition: https://paste.debian.net/1173720/
<mdevos>error message: [kernel] User Error: [findlib] package 'ocamlgraph' not found (required by `frama-c.kernel')
<mdevos>huh, I could swear manually adding ocaml-graph to the environment (guix enviroment --ad-hoc) used to work
<mdevos>odd, if I add the build-time dependencies of ocaml-graph frama-c-gui runs fine (guix environment ocaml-graph --ad-hoc -l ./ocaml.scm -- frama-c-gui)
<zzappie>ha mdevos you are not the first trying to package frama-c :) I did too. There is already patch 38635
*mdevos makes mental note to search for pre-existing patches in the future
<dftxbs3e>nckx, hey! also just sent this in: https://issues.guix.gnu.org/44778
<roptat>not that it works either, but hey :)
<zzappie>mdevos: I think I've encountered same issue. I remember there were handwritten lines to find some of dependencies not sure If its your problem too. Didn't find my notes on it.
<zzappie>I mean in configure.ac
<roptat>maybe using wrap-program could help?
*zzappie think I dropped the stash accidentally
<db48x>mroh: thanks. that's one of the first things I tried, but with no success
<giaptx>Hi roptat, example I write a simple Unbound service file as http://paste.debian.net/hidden/820cf2a0
<giaptx>Could you help me how can I load it?
<roptat>so this is a guile module. A guile module has a name, here (guix services dns), and it's related to the filename: here you should name it guix/services/dns.scm
<roptat>then, when reconfiguring, you should add the directory that contains guix/services/dns.scm in your load-path, by adding -L /path/to/parent/of/guix
<roptat>adding a (use-module (guix services dns.scm)) should work
<roptat>in my own config for instance, I have a directory called modules that contain these modules
<roptat>so I add -L modules when reconfiguring
<roptat>for instance, I have this file: https://git.lepiller.eu/system-configuration/tree/-/modules/services/gitile.scm
<roptat>its module name is (services gitile)
<giaptx>You mean using `guix system reconfigure` with `-L`
<roptat>yes, I do guix system reconfigure -L modules my-config.scm
<giaptx>Oh, Thanks
<roptat>obviously that's because I have a directory named "modules", you should use -L <name-of-your-directory> instead (could be "." for instance)
<giaptx>Yep
<giaptx>I will try it tomorrow. I have to go to bed now =)). I'm in GMT+7
<jorge[m]>Saludos comunidad,tengo un error al finalizar mi descarga alguna idea ? Greetings community, I have an error at the end of my download any ideas?
*jorge[m] uploaded an image: Screenshot_2020-11-21-11-52-26 (1).jpg (442KiB) < https://matrix.org/_matrix/media/r0/download/matrix.org/ovmiYIAeZBWLFNjRuQqRivre/Screenshot_2020-11-21-11-52-26 (1).jpg >
*zzappie just watched Mathieu's talk, very cool.
<efraim>jorge[m]: You can ignore that error
<mdevos>jorge: any other errors?
<nckx>Hallo gweeks.
<zzappie>o/
<nckx>dftxbs3e: I think we should not add known-irreproducible bootstrap binaries to master.
<nckx>dftxbs3e: So <https://issues.guix.gnu.org/44778> can go onto wip-ppc64le?
<nckx>‘Building the following 5300 packages would ensure 12902 dependent packages are rebuilt’ ☺
<jorge[m]><mdevos "jorge: any other errors?"> Si al final no reconoce el wi fi y hasta alli llego
<dftxbs3e>nckx, the reason why they are not reproducible seems to be really really obscure, see guix-devel messages
<dftxbs3e>nckx, libffi, I guess but that patch should only affect powerpc64le-linux-gnu, it's about to be available from an upstream release whenever they decide to make one
<mdevos>jorge[m]: (I do not speak Spanish) Do you mean the wi fi is not recognised?
<dftxbs3e>nckx, let's merge all of this into wip-ppc64le but the concern is that constantly rebasing code onto master becomes really troublesome
<mdevos>jorge[m]: I presume you are in the process of installing Guix System
<jorge[m]><mdevos "jorge: (I do not speak Spanish) "> si
<mdevos>jorge[m]: Or has Guix System been installed, and do you have trouble accessing the Internet?
<mdevos>jorge[m]: if you don't particularily care about how you access the Internet, and your computer has an ethernet port, you could use that instead
<jorge[m]><mdevos "jorge: Or has Guix System been i"> no,se queda reconociendo pero no avanza.
<mdevos>jorge[m]: ok, you are in the installer. I can't say I'm very familiar with the installer, so I am guessing mostly
<jorge[m]><mdevos "jorge: ok, you are in the instal"> si en el instalador
<mdevos>jorge[m]: I had Wi-Fi trouble too when installing Guix, so I used ethernet instead. I don't know if that is suitable for you
<mdevos>jorge[m]: and I figured out the Wi-Fi problems once Guix was installed
<jorge[m]><mdevos "jorge: I had Wi-Fi trouble too w"> como lo ago ?
<mdevos>jorge[m]: do you mean how to use ethernet?
<mdevos>jorge[m]: or how to fix Wi-Fi problems?
<jorge[m]><mdevos "jorge: or how to fix Wi-Fi probl"> como uso el ethernet ?
<mdevos>jorge[m]: an ethernet cable and port look like this: https://en.wikipedia.org/wiki/Ethernet#/media/File:Ethernet_Connection.jpg
<mdevos>jorge[m]: I believe all you have to do is plug in the cable
<nckx>dftxbs3e: #44778 as written would have to pass through core-updates because it rebuilds 12902 packages (guix refresh -l libffi). It might (and often is) possible to rewrite patches so they have no effect on other architectures, in which case wip-ppc64le could go straight to master *if* it works perfectly. That includes reproducible bootstrap binaries.
<nckx>dftxbs3e: Is there public discussion about their irreproducibility?
<mdevos>jorge[m]: but it has been quite some time ago, I may have forgotten some steps
<nckx>mdevos: Did you have a GNUnet presentation or did I dream that?
<mdevos>nckx: I don't have a GNUnet presentation
<mdevos>nckx: but I am working on some GNUnet patches
<nckx>Oh, sorry.
<nckx>Must've been the crack.
<nckx>mdevos: That's still super cool news.
<dustyweb>hi!
<nckx>o7
<dustyweb>for people stringing together multiple .scm files in the same directory, do you just hack your $GUILE_LOAD_PATH at launch-time?
<mdevos>jorge[m]: is ethernet working fine, or are there more problems?
<dustyweb>GUILE_LOAD_PATH="$GUILE_LOAD_PATH:`pwd`" guix foo -f myfile.scm
<dustyweb>like that?
<zzappie>dustyweb: isn't -L just for that purpose?
<jorge[m]><mdevos "jorge: is ethernet working fine,"> no lo se, toca leer
<dustyweb>zzappie: ...!
<dustyweb>somehow I didn't know about that!
<dustyweb>it's... amazing how long I can go without knowing about things in guix sometimes ;)
<zzappie>dustyweb: Yeah thas why I put question mark. -L is in 80% of my guix commands :)
<dustyweb>:)
<sss2>hi all, i have problem with ssh ciphers in guix https://bpa.st/VPVQ
<sss2>no, i do not want switch to aes
<dftxbs3e>nckx, yes, looking it up
<civodul>sss2: good question, it looks like we're lacking a way to choose ciphers on the client side
<civodul>could you report it to bug-guix?
<efraim>there's another patch for libffi and powerpc on the 1.2.0 branch
<mdevos>sneek: make my homework and transfer knowledge into my brain
<mdevos>alas, I have to log off
<efraim>oh, it's on master now too
<dftxbs3e>nckx, https://debbugs.gnu.org/cgi/bugreport.cgi?bug=41669
<dftxbs3e>apparently that's for powerpc64-linux-gnu binaries but I assume it's the same for both endians
<nckx>sss2: Guix respects .ssh/config. Add ‘Ciphers chacha20-poly1305@openssh.com’ there.
<sss2>nckx, but how to set it properly on non-guix host ?
<sss2>or guix have force aes by default ?
<sss2>*forced ?
<nckx>The same? ~/.ssh/config isn't Guix-specific.
<nckx>dftxbs3e: Take a look at commit 02f5ee01c96589fc13f1e21b85b0b48100aec4e8.
<sss2>i mean, host ssh client works, and guix not, so i guess this is borken defaults ?
<sss2>nckx, yes, looks like broken defaults, does work with forced cipher in config
<nckx>If you want the defaults changed, please file a bug, but that wasn't clear from your paste.
<nckx>I don't think Guix has anything to do with this, but libssh.
<sss2>probably, i do not know design in details sorry
<nckx>sss2: Yeah, Guix doesn't specify any defaults.
<nckx>Go ahead and report your wishes and we can always forward them if needed.
<sss2>libssh, i thought it was openssh wrapped
<sss2>thx
<nckx>Nope.
<sss2>got it
<sss2>it explain problem
<sss2>thx for info
<sss2>now i am trying to setup offloading (second attempt)
<nckx>Good luck.
<sss2>can't make it load profile (
*nckx glad Guix resists the OpenSSH monoculture if this is the tiny price to pay.
<nckx>sss2: Which profile?
<sss2>with environment
<sss2> https://bpa.st/VDMQ
<sys2>has anyone seen/fixed this[0] error before? [0]: https://lists.gnu.org/archive/html/guix-devel/2015-11/msg00158.html. The linked solution has no effect for me
<nckx>Good thing my client colours nicks.
<sss2> https://bpa.st/45NQ
<sss2>not sure waht wrong
<nckx>sss2: I'm afraid I've never set up offloading involving non-Guix Systems before. Which host isn't Guix System?
<sss2>exherbo
<sss2>and nixos
<nckx>Whoo.
<sss2>probably some system-based profiles corrupot environments
<sss2>or it just does not read at all
<nckx>My 2 previous distro's, you'd think I'd have tonnes of ideas, but, erm, no.
<sss2>)))
<nckx>sss2: Does your ~/.bashrc have anything roughly like this? https://paste.debian.net/plain/1173734 It should load ~/.profile even in non-interactive SSH sessions.
*nckx hasta go AFK now.
<sss2>have no bashrc at all on this account
<sss2>it is dedicated for offloading
<sss2>i have this problem for both bash and zsh
<sss2>but i should try it
<dftxbs3e>nckx, yep.. should modify the condition to also include powerpc64
<sss2>nckx, nah, kust symlinked guix to /usr/bin/
<sss2> https://guix.gnu.org/manual/en/html_node/Daemon-Offload-Setup.html - can i find somewhere description of all options ?
<sss2>for example guix offload: warning: The 'system' field is deprecated, please use 'systems' instead.
<raghavgururajan>Hello Guix!
<raghavgururajan>Is there a field in package-definition to include a hint message for user?
<raghavgururajan>Like, when a user installs the package, they will see the hint at the end.
<sys2>is anyone else failing to build vhphki5sg9xkdhh2pbc8gi6vhpfzryf0-gnutls-3.6.12 right now? I'm thinking this is because of old packages I've modified and built... but I'm not sure how to remove/update those to the newest versions
<rekado>are any drummers around?
<rekado>drummers with convenient access to a drum set that can be recorded somewhat quickly?
<rekado>(or alternatively: those who are familiar with a drum machine :))
<efraim>what does guile offload test?
<efraim>I added a dummy guix in /usr/local/bin/guix on my G4
<efraim>s/guile offload/guix offload/
<sys2>(just rebuilt to get the error): https://paste.debian.net/1173737/
<zimoun>hi!
<nckx>sss2: https://guix.gnu.org/manual/devel/en/html_node/Daemon-Offload-Setup.html
<nckx>Hi zimoun.
<nckx>Let's chat.
<zimoun>nckx, yes for sure :-)
<zimoun>roptat: I have just watched your talks, impressive!
<nckx>sss2: Note the /devel/. Without it, you're reading the manual for 1.1.eekthatsold, which is old.
<roptat>zimoun, thanks :)
<roptat>can I join the chat? :D
<zimoun>roptat, nckx: I do not know how to multi-query
<roptat>I don't think that's possible, we need our own chan for that, right?
<nckx>Great minds.
<nckx>roptat: Are you not reading zimoun's privmsgs.
<roptat>only when I can read from his shoulders, but I'm too far away for that ;)
<nckx>zimoun: Legend.
<nckx>See you there.
*raghavgururajan wonders whats happening
<raghavgururajan>Oh the talk
<roptat>reminder: watch the talks if you haven't yet! https://xana.lepiller.eu/guix-days-2020/
<zzappie>BTW what's about tomorrow's BoFs. I haven't used BBB before. I'll be able to join with just public link?
<zzappie>No clients or anything
<ryanprior>BBB requires a web browser like Firefox or Chromium and a decent amount of bandwidth.
<ryanprior>There's no nonfree JavaScript and it's designed to facilitate easy public participation in educational and organizational settings.
<roptat>it works well on icecat from guix at least
<zimoun>but yeah it needs a bit of bandwith
<zzappie>great!
<sss2>nckx, thx, again
<zzappie>see ya tomorrou!
<nckx>o/ zzappie.
<nckx>sss2: Did you find everything you needed there?
<sss2>nckx, i guess, at least corrected deprecated settings
<sss2>now i need to configure system to always offload everything possible
<sss2>also i am still unable to load profile for non-interactive shell
<sss2>workarounded it with symkinks for now
<rekado>I won’t be able to join tomorrow; haven’t even managed to watch the talks yet :-/
<rekado>y’all have fun!
<zimoun>rekado: oh, sad news.
<genevino>saaaaaaaad
<sss2>nckx, # guix archive --authorize < master-public-key.txt - where is "master-public-key.txt"
<sss2>as i understand, it's key generated by guix archive --generate-key
<sss2> https://bpa.st/OREQ offload test failure
<civodul>zimoun, roptat: oh i just realized, we don't have the BBB URL yet, do we? :-)
<civodul>oh got your messages in the meantime
<roptat>right, but I just pushed a website update
<roptat>mh... if we're lucky we have 1 hour to fix that ^^'
<roptat>I mean, it's not too bad if we use fosshost domain, is it?
<nckx>sss2: I guess you found out by now that the key is the remote /etc/guix/signing-key.pub. That... is an extremely unhelpful error with which I cannot help you.
<sss2>i can't find how to obtain more information
<nckx>sss2: Does ‘sudo -i ssh [-p N] <remote offload user>@192.168.0.2’ work?
<nckx>I use it as a quick hack to add the public (SSH) key to known_hosts.
*nckx needs to AFK once more.
<civodul>roptat: i think it's ok to use a fosshost.org URL
<civodul>if we wanted to have fun, we could add an entry in dns.scm
<civodul>but maybe we'd rather relax :-)
<roptat>I think it's too late, we'd have to ask fooshost to add an entry in their server too, to connect this url to our instance
<civodul>yeah, that's ok
<user_oreloznog>good night guix :-)
<zimoun>civodul: just updated I guess. And explanations are coming. We are a bit late. As usual. ;-)
<raghavgururajan>Any python folks available?
<raghavgururajan>Looking for ideas for http://debbugs.gnu.org/cgi/bugreport.cgi?bug=44782
<cbaines>raghavgururajan, I'm not a python, but searching the internet suggests you may have enum34 on your PYTHONPATH https://stackoverflow.com/questions/43124775/why-python-3-6-1-throws-attributeerror-module-enum-has-no-attribute-intflag
<cbaines>Is that the case?
<cbaines>I don't think enum34 is an input to gajim itself, but it could be in your profile maybe
<cbaines>In other news, I have a more readable and stable URL to list packages that are "broken" on staging, but not on master: https://data.guix-patches.cbaines.net/compare-by-datetime/package-derivations?base_branch=master&target_branch=staging&build_change=broken&all_results=on
<raghavgururajan>cbaines: Thanks, will check the link
<ngz>Oh my! Seahorse adventures is failing! :)
<zimoun>roptat: is it possible to change the banner? And add the link in?
<ngz>I don't know how to get to the build log, though.
<cbaines>ngz, the links from the Guix Data Service to Cuirass need improving, but this is the page you want https://ci.guix.gnu.org/build/3535271/details
<roptat>zimoun, ah sure
<zimoun>do you do directly or do I send patch?
<cbaines>ngz, paradoxically, the log is for a completed build. I think this can happen with Cuirass, where you get a log for a different build
<ngz>That's what I was wondering.
<roptat>zimoun, I can do that
<zimoun>thanks
<cbaines>Ok, seahorse-adventures is pretty dangerous, running it changed my display resolutions and orientations, and I've only just managed to fix things!
<ngz>Yes, we need to be extra careful with this package, we might even consider delaying the release of the next Guix.
<roptat>pushing, as soon as I can resolve git.sv.gnu.org again...
<roptat>herd invalidate nscd doesn't work btw
<roptat>(by that I mean, I still can resolve after that, but it might be doing something)
<roptat>ok, done
<roptat>zimoun, hm.. "please do" what?
<raghavgururajan>cbaines: I don't have enum anywhere.
<nckx>Hmm, running seahorse-adventures replaced my guix-daemon with a copy of seahorse-adventures.
<nckx>Good night, sweet #guix o/
<cbaines>raghavgururajan, what do you get if you run: python3 -c "import enum; print(enum.IntFlag)"
<raghavgururajan>cbaines: Oh wait, I tried running Gajim in a --pure env. Seems to work.
<raghavgururajan>nckx: o/
<raingloom>is there no %inputs to go with %outputs? ,:| (i need it for #:configure-flags)
<mroh>gn8, nckx, sweet seahorse dreams ;)
<wleslie>raingloom: %build-inputs
<raghavgururajan>cbaines: For the command you mentioned, I get:
<raghavgururajan>Traceback (most recent call last):
<raghavgururajan> File "<string>", line 1, in <module>
<raghavgururajan>AttributeError: module 'enum' has no attribute 'IntFlag'
<raingloom>wleslie: thanks!
<cbaines>raghavgururajan, right, are you sure enum34 isn't on your PYTHONPATH?
<wleslie>"import enum; print(enum.__file__)"
<cbaines>raghavgururajan, if it's not that, what version is python3, and what else is on your PYTHONPATH?
<rekado>any guitarist or keyboardist interested in contributing to what might become a Guix song?
<rekado>join me on ##guix-song
<raghavgururajan>cbaines: I spoke too soon. In --pure also not working.
<raghavgururajan>cbaines: My PYTHONPATH is https://paste.debian.net/1173758/
<raghavgururajan>It has enum
<raghavgururajan>enum34
<raghavgururajan>But I wonder why it didn't work on --pure env with gajim and gajim-omemo.
<raghavgururajan>May be one of the inputs is propagating enum34?
<cbaines>Maybe check the PYTHONPATH/profile directory in the pure environment?
<cbaines>That will at least confirm if it doesn't work in a pure environment for the same reason
<roptat>zimoun, sent!
<raghavgururajan>cbaines: How do I check env-vars value inside --pure env?
<raghavgururajan>I usually do `env` outside --pure.
<cbaines>maybe echo $PYTHONPATH
<zimoun>roptat: thanks
<raghavgururajan>cbaines: I got a directory.
<cbaines>Ok, so I'd look in that directory to find out which packages it has files from
<raghavgururajan>It has two folders, both gajim-foo
<raghavgururajan>Ah
<raghavgururajan>All the files seems to gajim related. Like gajim's .py files.
<raghavgururajan>Let me try with gajim-omemo
<raghavgururajan>rg@secondary ~$ guix environment --pure --ad-hoc gajim gajim-omemo
<raghavgururajan>rg@secondary ~ [env]$ echo $PYTHONPATH
<raghavgururajan>/gnu/store/0vvyj0i1q6xlw4553bn26a190xzzccm9-profile/lib/python3.8/site-packages
<raghavgururajan>Gonna check files again
<raghavgururajan>Ah this has many folders
<cbaines>If you're looking a site-packages directory, enum is the directory in there from enum34 (you can check this by checking the symlink)
<raghavgururajan>cbaines: https://paste.debian.net/1173760/
<raghavgururajan>I searched "enum" both for file name and content in any file.
<raghavgururajan>No results.
<cbaines>I guess it could be breaking differently in the pure environment then...
<cbaines>Unfortunately I need to get some sleep now, need to try and be awake tomorrow!
<raghavgururajan>You are right
<raghavgururajan> https://paste.debian.net/1173761/
<raghavgururajan>Cool!
<raghavgururajan>Night! o/