IRC channel logs

2020-10-12.log

back to list of logs

<ryanprior>jlicht: esbuild package should land upstream soon it sounds like
<ryanprior>gocloud.dev is a big big package, it's going to hold up hugo for a while. it'll be a nice thing to have done though.
<sys2>are docker/singularity basically the two options to run images from hub.docker.com? are there any settings I can change (e.g. swap dockerd for something or remove setuid) to protect against container breakouts to root?
<jlicht>ryanprior: nice!
<ryanprior>sys2: you can use podman to run docker containers without root
<ryanprior>not packaged in guix yet though :(
*sys2 looks up podman
<sys2>ryanprior: thanks! will try this :)
<ryanprior>Looking at the podman deps, I can see that packaging hugo is going to get us a long way towards podman too.
<ryanprior>And it depends on the k8s client, which I use for work, so that's a nice get as well.
<sys2>ooo kubectl would be great to have
<jlicht>then we just just find a way to generate k8s yaml files from guile, and Bob's your uncle :-)
<apteryx>this seems to fail reliably on latest master: FAIL: tests/channels.scm
<apteryx>cbaines: you're right, the last guix package does pass its test suite; it's the master branch that seems to be broken
<PotentialUser-81>Wish this had librewolf!
<terramorpha>Hi, does anybody know how to depend on an alternate output of a package
<terramorpha>I am trying to package a gtk theme, but the build process uses the glib-compile-resources program, which is in the glib:bin output
<terramorpha>If I just include ("glib" ,glib) in the package native-inputs, The build process can't access the program
<nckx>terramorpha: ("glib" ,glib "bin")
<terramorpha>Oh, thank you
<seepel>How would I modify files under /etc/pam.d? I'd like to add fprint support for various things as described here: https://wiki.archlinux.org/index.php/Fprint
<Esther>Hello everyone, am happy to be here. Please how do i get started
<seepel>Esther: Hi! You probably want to start here: https://guix.gnu.org/en/download/
<seepel>Guix System is a full Gnu/Linux distribution, and Guix Binary is a package manager that you can install in an existing Gnu/Linux installation.
<vits-test>nckx: re: "Sounds legit. Who was that (if you can say)?" Hello; sorry, i not understood.
<goku12>Hi guix! I am exploring guix from an Arch system. I wanted to access guix from emacs, but have failed so far. Emacs is from Arch repo and emacs-guix from MELPA. I get the error message 'No Geiser REPL for this buffer (try M-x run-geiser)' when I try M-x guix. Further attempts give me message: 'No prompt found'. Tried solutions from emacs-guix and others to no avail. Can anyone help me with where I
<goku12>could have made a mistake?
<ryanprior>Does building with `--rounds` actually work? It completes so fast that I can't believe it's actually doing anything.
<ryanprior>goku12: emacs-guix is only designed to work on Guix System, unfortunately.
<ryanprior>I also use Guix on a foreign distro & emacs-guix has never worked for me.
<goku12>ryanprior: Thanks for the info. README on emacs-guix repo does mention some problems that can happen when using foreign distros, and suggests some solutions. It didn't work for me and I thought it may be a configuration issue specific to me
<goku12>There is one another issue with plain guix. My store is 2.3 GB after a guix pull, without anything in user profile. A guix gc removes nearly 700 MB of it and another guix pull brings it back. Is this expected?
<raingloom>hello Guix geeks, my chicken-build-system code kind of works now! :D
<raingloom>patch incoming
<apteryx>raingloom: congrats!
<jsoo>Well. Can someone recommend which gcc to modify for cross compiler packages?
<apteryx>raghavgururajan: re http://issues.guix.gnu.org/40707#3, there's a comment from lfam that seems to have gone unnoticed
<jsoo>raingloom: your repo is helping
<raingloom>jsoo: thanks. honestly i barely had any idea what i was doing. did the recent GCC fixes make it work?
<apteryx>ryanprior: it only works when a build result was never cached (the first time you build something)
<apteryx>--rounds=n --check should force a rebuild but the daemon was ignoring --check with --rounds until commit 0fa0e8df60b0b005a8d9499562464c5a66218a5b. The 'guix' package hasn't been updated since so nobody has this change effective so far.
<ryanprior>Seems like a bug. If it's intentional, what's the design rationale?
<apteryx>dunno, seemed like a bug to me as well (it's an annoying and useless behavior)
<apteryx>it came from nix (daemon)
<ryanprior>I thought the docs said that rounds implied check
<apteryx>yes, that came with that same commit 0fa0e8df60b0b005a8d9499562464c5a66218a5b
<apteryx>ah, no, sorry
<apteryx>that commit added that --check works with --rounds, not that the later implies the former
<raghavgururajan>apteryx: Oh thanks.
<ryanprior>I built guix from the latest master just now and built my package with --check and 2 rounds, then 20 rounds. 7 seconds either way.
<apteryx>ryanprior: as I said it's not yet effective until you update your daemon to guix at commit 0fa0e8df60b0b005a8d9499562464c5a66218a5b or later
<apteryx>and I haven't been able to bump the guix package yet because some tests are failing (working on that)
<ryanprior>I verified manually that I have that commit which says "honor rounds when also using check"
<apteryx>if you'd like to test it you could run the daemon from your git checkout
<raghavgururajan>The patch already merged though. But that invoke thing has to be looked into
<ryanprior>Oh I understand then, it's a feature of the daemon and since the guix package hasn't been updated it's still got the old behavior
<ryanprior>Okay how do you run the daemon from git?
<apteryx>after stopping your regular daemon with 'sudo herd stop guix-daemon', you run it in the built git tree with something like: sudo -E ./pre-inst-env guix-daemon --build-users-group guixbuild --max-silent-time 0 --timeout 0 --log-compression bzip2 --substitute-urls='https://ci.guix.gnu.org'
<ryanprior>thanks :)
<apteryx>let me know if it works :-)
<apteryx>sneek: later tell civodul commit 1d4ab335b22a93e01c2eb1eb3e93fc6534157040 broke tests/channels.scm :-) it now tries to url-fetch something and fails to resolve guile-final
<sneek>Okay.
<apteryx>sneek: later tell civodul the specific test that broke is "channel-instances->manifest"
<sneek>Will do.
<jsoo>raingloom: I think it seems to work ok out of the box. This is all to have ghc on arm for me though. That's a whole other thing
<jsoo>Maybe cross-gcc and friends will be enough. I may not need the whole toolchain
<raingloom>maybe. i only need a whole toolchain because the NDS is weird. AFAIK i only really need the linker scripts, LLVM could do everything else.
<raingloom>idk, i never really tried it successfully so all of what i said may be wrong.
<apteryx>'make check' takes an awful lot of time :-/
<apteryx>ryanprior: I managed to update the guix package, so if you 'guix pull' and guix system reconfigure (and herd restart guix-daemon), you should be able to use --rounds and --check
<efraim>morning Guix!
<apteryx>morning!
*apteryx heads off to bed :-)
<efraim>ah, the Time Zone Dance™
<efraim>having built both linux-libre and linux-libre-arm64-generic, linux-libre takes about twice as long to build on my pine64
<efraim>not having recieved substitutes for either of them, and seeing that linux-libre-arm64-generic is fine, it might be worthwhile to make my own linux-libre-arm64-generic based kernel with zram enabled
<joshuaBPMan>efraim: morning. Though, it's really really early for me. :)
<g_bor[m]>sneek: seen zimoun
<sneek>zimoun?, pretty sure was seen in #guix 2 days ago, saying: *do not like.
<civodul>Hello Guix!
<sneek>Welcome back civodul, you have 2 messages!
<sneek>civodul, apteryx says: commit 1d4ab335b22a93e01c2eb1eb3e93fc6534157040 broke tests/channels.scm :-) it now tries to url-fetch something and fails to resolve guile-final
<sneek>civodul, apteryx says: the specific test that broke is "channel-instances->manifest"
<civodul>hmm
<cbaines>civodul, I've just checked, and I haven't had any weird encoding crashes overnight :D
<civodul>cbaines: yay, well done!
<cbaines>The change is also merged in, which is good as well https://notabug.org/cwebber/guile-squee/pulls/4
<civodul>neat, thanks dustyweb :-)
<cbaines>indeed :D
<guix-vits>efraim: Hello. Is Ur keyboard working in u-boot prompt on Rock64?
<sneek>guix-vits, you have 2 messages!
<sneek>guix-vits, str1ngs says: I'd rather keep %search-provider-format and %search-providers in (nomad web)
<sneek>guix-vits, str1ngs says: . I've pushed significant change to how %web-mode-map works to a describe-mode branch. This is in preparation for describe-mode. The changed should not be noticeable but if you notice any issues with web key binds let me know. for details see http://git.savannah.nongnu.org/cgit/nomad.git/commit/?h=describe-mode&id=df90e95eee3a868eef2d0909a26dbddcfd63e695
<efraim>guix-vits: i have a pine64plus, no rock64 yet
<efraim>also I haven't tried using the u-boot prompt on the pin64
<guix-vits>sneek: botsnack
<sneek>:)
<guix-vits>efraim: i cannot use keyboard on rockpro in u-boot, with my setup, so curious.
*guix-vits great, mine box boots after `reconfigure`. No need use serial with my curved hands this time.
<civodul>i can't access "https://nvd.nist.gov/feeds/json/cve/1.1/nvdcve-1.1-2020.json.gz" over IPv6, it just hangs
<civodul>is it just me?
<civodul>(it's fine over IPv4)
<civodul>tested on other networks and it's inaccessible as well from there
<PurpleSym>Same here, not working via v6.
<civodul>ok i've emailed them
<janneke>hello Guix!
<jlicht>o/
<ani_>why does it take a lot of time to install something from guix? I installed emacs and its taking a while to install it, unlike other package managers.
<ani_>or is it because I am supposed to run "guix pull" before installing something. Like as we do "apt update" and "apt install"?
<allana>Hi Guix. I am reading through guix-devel and trying to ascertain the status of Ocaml support in guix. It seems a bit incomplete, does anyone have a summary of the story of Ocaml in guix? It seems that the default version is 4.09 but many packages have 4.07 in the name. Does this mean that if I install ocaml4.07-merlin and ocaml that I will get ocaml 4.09 with merlin that is paired with Ocaml 4.07?
<allana>ani_: From what I understand you may pretty much always want to do a pull first. Are you building emacs from source? That would take a little while.
<rekado>ani_: what exactly takes a lot of time? And what is ‘a lot’?
<rekado>as allana says if you’re building everything from source it’s going to take hours.
<ani_>rekado, allana: I run the command guix install emacs according to getting started section from manual. Now it has been 5 minutes its still installing emacs, am I doing somethign wrong?
<zimoun`>allana: ping roptat for OCaml history. What do you mean by installing ocaml4.07-merlin and ocaml? You should do something as “guix install ocaml4.07-merlin ocaml@4.07” I guess.
<guix-vits>ani_: is substitutes enabled?
<numerobis>Hi #guix! To those using #guix on a personal server, do you use anything (and if you do, what) to protect your system? I used to use fail2ban on nix, but I think it isn't available on guix yet. Any recommendations?
<kab-5678>how do you edit a package definition of a package that is failing to build?
<guix-vits>ani_: also note `guix` working on profiles. Every time one installs a new package, the new profile generation being built. So overally `guix` is slower.
<guix-vits>kab-5678: like https://paste.debian.net/1166814
<ani_>guix-vits: I am new to guix and just going through the manual, got to know about substitutes today only. Will look into that.
<guix-vits>ani_: the install-script for foreign-distros asks if U want to use them. It is enabled by default on Guix System.
<ani_>guix-vits: aha, so you mean the question "Permit downloading pre-built package binaries from the project's build farms? (yes/no)" is the one to enable substitutes while installing, isn't it? I typed yes, that means substitute is enabled I guess.
<vits-test>Yes, it should.
<vits-test>ani_: try guix weather THE_PACKAGE ?
<vits-test>Sometimes there is no substitutes available.
<numerobis>kab-5678: I think you can obtain the definition of the package (guix edit THE_PACKAGE), copy it in say ~/my_module/test.scm and change the package name, then `export GUIX_PACKAGE_PATH=~/my_module`, and then `guix build MODIFIED_PACKAGE_NAME`.
<civodul>cbaines: i think we need a whole series of blog posts about the Data Service now :-)
<ani_>vits-test: guix weather: error: THE_PACKAGE: unknown package
<vits-test>numerobis: +1
<vits-test>ani_: THE_PACKAGE is placeholder. What package took much time to install?
<ani_>okay
<terpri>ani_, 'guix weather emacs' in your case
<ani_>gotcha
*vits-test cannot read, lol
<ani_>vits-test: guix weather emacs
<ani_>computing 1 package derivations for x86_64-linux...
<ani_>looking for 1 store items on https://ci.guix.gnu.org...
<ani_>updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
<ani_> https://ci.guix.gnu.org
<ani_> 100.0% substitutes available (1 out of 1)
<ani_> at least 83.4 MiB of nars (compressed)
<ani_> 128.1 MiB on disk (uncompressed)
<ani_> 4.390 seconds per request (4.4 seconds in total)
<ani_> 0.2 requests per second
<ani_> 'https://ci.guix.gnu.org/api/queue?nr=1000' returned 504 ("Gateway Time-out")
<ani_>vits-test: the output I got.
<terpri>(there's also 'guix build --dry-run emacs' which will tell you what would be built vs. downloaded on your particular system, which might matter if you were building a package and had a lot of the inputs installed already)
<terpri>i get similar output, not sure what the last line indicates
<civodul>the last line indicates that it failed to get info from the continuous integration service
<civodul>it's harmless, just a sign that Cuirass at ci.guix.gnu.org might be overloaded
<zimoun`>civodul, cbaines: I agree! The Data Services is really cool with really practical features and still under known/used.
<civodul>yup!
<ani_>civodul: I see.
<terpri>numerobis, i don't do anything special with ssh except enable x11 forwarding and disable password login. i might change the sshd port number if the system were exposed to the open internet
<numerobis>terpri: thanks! I have the password login disabled too but nothing else at the moment. I might change the sshd port, that sounds like a good idea.
<taylan>heya Guixers. we're planning to create a kubernetes cluster at work. I'm thinking I could bring Nix or Guix into the picture. it seems like the most straightforward way to do so would be to use one of them to create the docker images to be deployed on the cluster, as a better alternative to using Dockerfiles. are there other good ways to
<taylan>integrate Nix or Guix into such a setup, to reap their benefits?
<terpri>numerobis, you can also +1 fail2ban on https://libreplanet.org/wiki/Group:Guix/Wishlist if you'd like :) (i don't see any obviously similar software in {admin,networking}.scm)
*terpri adds puppet and the new JuliaMono font to the list as well
***daviid is now known as Guest14267
<rekado>numerobis: there’s a simple iptables SSH banning service that we use for the build farm.
<rekado>numerobis: https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/modules/sysadmin/services.scm#n283
<efraim>guix system: warning: Your Guix installation is 34752 days old.
<numerobis>terpri: thanks for the tip, I wasn't aware that there was a wishlist :)
<numerobis>rekado: this looks interesting thanks. So, if I understand correctly, this service is defined only for the build farms, not in guix itself? And I'd have pretty much copy paste the lines in my config?
<g_bor[m]>sneek: seen zimoun
<sneek>I think I remember zimoun` in #guix 39 minutes and 16 seconds ago, saying: civodul, cbaines: I agree! The Data Services is really cool with really practical features and still under known/used..
<rekado>numerobis: yes, you can just copy this.
<rekado>efraim: early adopter, eh?
<rekado>numerobis: I wouldn’t put too much faith in the wishlist. It’s not something that many of us regularly look at or work on.
<rekado>…because there’s always something else that needs doing.
<rekado>it’s not like we’re desperately in need of ideas for things to package or fix :)
<efraim>rekado: apparently. it comes out to about 95 years, so no idea where that number came from
<terpri>hey taylan, nice to see you here. using guix system to build docker images sounds like a reasonable approach (might run into minor obstacles if k8s expects to build docker images automatically or something...but i haven't used k8s so i'm just guessing)
<efraim>also it looks like the pine64 does need linux-libre-arm64-generic, not linux-libre
*terpri wants to figure out how to use guix with puppet someday, for hcoop.net
<rekado>terpri: in which way?
<g_bor[m]>zimoun`: I have seen your message, can we talk now?
<rekado>at work we have puppet as well, but it’s so … “dynamic” and stateful that I don’t see how Guix would fit into any of it.
<terpri>rekado, for making a "virtual" hcoop system so that volunteers can easily experiment with sysadmin tasks without having root on the actual servers. tbh i don't know exactly how puppet is being used as the relevant repos aren't public yet
<efraim>Well I hit something magical, system generation 3 is in 2115
<terpri>it might not end up being relevant if there's a big mismatch with the guix model though
<zimoun`>g_bor[m]: feel free to query me :-)
<efraim>I might take a look at debian's fake-hwclock and re-create it in guix. Currently I've been running `sudo herd restart ntpd` on board bootup
<jlicht>taylan: have a look at the recently updated skopeo if you want to easily upload your guix-built docker images to a registry
<cbaines>civodul, zimoun` what reminded you about the lack of blog posts about the Guix Data Service? :)
<cbaines>I'm up for writing one/some, although if the emails I sent out are any indication, making the posts concise will be a challenge
<ani_>rekado, zimoun`, roptat: as a newcomer and intern my initial goals are to be familiar with guix, reading application setup, getting started and then setting up environment for contribution, what else would you advice me to do?, apart from these things
<nly>why are there several lines saying the same thing?
<nly>substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
<nly>substitute: updating substitutes ...
<nly>
<nly>i see 6
<numerobis>rekado: yes, I understand. Many thanks to you and the other contributors for this great project! :)
<zimoun`>cbaines: I can send you what I am using, really often. And what I answered to help-guix question, for example about python-umap package or other. Well, concrete use cases somehow. WDYT?
<zimoun`>ani_: as discussed privately, could you drop an email in guix-devel to introduce yourself. Then I will indicate you some details.
<ani_>Sure.
<ani_>zimoun`: sure.
<rekado>nly: because it happens more than once
<rekado>that’s not a satisfying answer, I’m aware of that.
<rekado>but it’s the reason.
<rekado>it’s surprisingly tricky to make it happen less often
<rekado>because knowledge of what needs to be fetched depends on whether previous things could be fetched.
<rekado>ani_: once you have an environment for contributing to Guix I suggest jumping right in and packaging an R package from CRAN.
<rekado>R is a statistics language, and CRAN is its package repository
<nly>ok
<nly>thanks
<rekado>every package on CRAN is free software (AFAIK).
<rekado>you can use the recursive importer for CRAN to produce package definitions that are *almost* ready to be used.
<rekado>to get started run: ./pre-inst-env guix import cran -r THE-PACKAGE
<rekado>you can pick THE-PACKAGE from here: https://cran.r-project.org/web/packages/available_packages_by_name.html
<rekado>we have hundreds of R packages in Guix already, so pick one that doesn’t exist yet
<rekado>see ./gnu/packages/cran.scm for existing package definitions
<rekado>ani_: the importer generates code that you can append to that file
<rekado>you’ll only need to make minor modifications (e.g. prefixing the value in the license field with “license:”)
<rekado>then try to build your new package with ./pre-inst-env guix build THE-PACKAGE
<ani_>rekado: I will do that as soon as I setup everything. Thank you for helping out.
<rekado>that’s enough to get started and run into problems; when that happens ask here for help
<ani_>rekado: yes, sure.
<civodul>"but Linux is not a restaurant"
*civodul just read lfam's reply to guix-devel :-)
<zimoun`>ani_: I second all the wise advices by rekado and especially ask if you need help.
<ani_>zimoun`: Sure.
<civodul>g_bor[m]: hello! should we start advertising Outreachy prominently?
<zimoun`>civodul: you mean a blog post about Outreachy? FYI, 3 people seems interested \o/
<kab-5678>how do you change guix from: /usr/local/bin/guix to /home/$USER/.config/guix/current/bin/guix
<g_bor[m]>civodul: we can do that.
<g_bor[m]>I will write up a blogpost later.
<g_bor[m]>Actually the new Outreachy workflow gives some headache, it is a bit harder to convince people to apply when they can't see the list of projects beforehand....
<g_bor[m]>By the time we have the projects, people must have the first application completed...
<g_bor[m]>Anyone has any idea how to do this better?
<zimoun`>g_bor[m]: we could advertise on the projetcs we plan to propose, before the Outreachy dance.
<zimoun`>I mean, at the same time we complete the Outreachy plateform for submitting project, we could write a blog post for our proposal.
<roptat>hi guix!
<civodul>g_bor[m]: yeah i'm a bit lost about all this, it's weird
<roptat>I just reconfigured one of my servers, and changed the configuration for the guix daemon, so I tried to run "herd restart guix-daemon"
<roptat>I get: herd: exception rattrapée pendant l’exécution de « start » sur le service « guix-daemon » : Unbound variable: fork+exec-command/container
<roptat>I updated other machines to the same guix commit, and reconfigured, but then "herd restart guix-daemon" worked perfectly
<lemes>hi, I am trying to make my 1st contribution by writing a package for the arduino IDE, but I need help now cause the build part is failing and I don't know why
<roptat>lemes, can you share the recipe you wrote, and the error(s) you get?
<roptat>I'll see if a reboot fixes it, maybe the reconfigure installed a newer shepherd and I simply need it to load the guix-daemon service?
<roptat>if not, I'll just roll back :)
<lemes>roptat, I can! where should I share it? I mean, the log and the recipe? Copy and paste it here?
<Kimapr[m]>Hello, i added setuid-programs field to my operating-system definition but forgot to append %setuid-programs to it. Now i can't sudo to roll ba- wait, i can just boot up older generation
<roptat>it worked :)
<roptat>lemes, not here, on paste.debian.net for instance
<roptat>then share the link here
<lemes>this is the recipe: http://paste.debian.net/1166828/
<roptat>gpl1 is surprising as a license, otherwise it looks not too bad... except it's java and java is never easy
<lemes>and this is the final part of the log that shows the error http://paste.debian.net/1166829/
<lemes>roptat I thought so too
<roptat>so, untar-unzip-download-web tries to download something, but fails, then the rest fails
<lemes>exactly
<roptat>the reason it fails is that guix disallows using the network during the build of packages
<lemes>I see, is there a way around?
<roptat>that's for reproducibility reasons: if we allow fetching arbitrary content from the internet, we can't be sure it'll always be the same
<lemes>I just realised it's gpl2 btw, my bad
<emacsen>lemes, You want to check that. The license for Arduino stuff has changed I believe?
<roptat>here the workaround is pretty easy: guix has the ability to download files, so you can use it to download the file it needs, and copy that to the source directory during the build
<emacsen>at one point I heard it wasn't Free anymore. but I could be wrong
<roptat>this is done with an origin record, as an input
<PotentialUser-32> https://pastebin.com/i9ZYYzEA strange bug
<lemes>emacsen, on the github page it's gpl2: https://github.com/arduino/Arduino/blob/master/license.txt
<emacsen>lemes, looks good!
<roptat>so, you can specify an input like this: (inputs `(("avr-source" ,(origin (method url-fetch) (uri "https://downloads.arduino.cc/cores/avr-1.8.3.tar.bz2") (sha256 ...)))))
<roptat>then in a phase, you can use that as (assoc-ref inputs "avr-source")
<roptat>something like (copy-file (assoc-ref inputs "avr-source") "avr-1.8.3.tar.bz2") should work
<roptat>since we specify the expected hash of the file that's downloaded, it's fine, because we can guarantee reproducibility: it's always the same file
<lemes>roptat, nice, I'll look into that, thank you
<zimoun`>lemes: for an example: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/julia.scm?id=1e96e6ac8bc0285cc2adfac4ac29b538b84d5dfc#n426
<roptat>PotentialUser-32, I got a similar thing recently, but they are all just warnings, you can ignore them
<roptat>it just means it won't use the pre-compiled modules, and compile them on the fly instead, so it's going to be slow, but it'll work eventually
<PotentialUser-32>okay, thanks
<roptat>not sure why you get that for a guix pull though
<lemes>zimoun cool, i'll take a look too
<PotentialUser-32> https://pastebin.com/QGQWK2WS hmmm, i got excetion in runtime
<roptat>PotentialUser-32, then I don't know, you'll need someone who knows guile better than be
<PotentialUser-32>may be I should open issue?
<apteryx>note: nfs service is still working fine; the gotcha if that if you have a directory under /etc/exports that no longer exists, nfsd will apperently fail.
<apteryx>apparently*
<roptat>PotentialUser-32, yeah, can send a message to bug-guix?
<PotentialUser-32>no(
<roptat>oh, why not?
<PotentialUser-32>I cannot run thunderbird
<PotentialUser-32>but i can send via gmail
<roptat>sure, please do :)
<PotentialUser-32>ok
<roptat>if it's your first message to guix, it'll end up in moderation until a human can validate it. it usually takes a few hours, so don't worry if you don't see it right away
*roptat is building icecat :/
<PotentialUser-32>ohhhh, becouse I start using vpn, all my websites in google start using some kinds of arabic dialect(((
<roptat>usually there's a way to change the language
<roptat>have you ever run guix pull on that machine?
<roptat>(as that user)
<PotentialUser-32>yes
<PotentialUser-32>letter sended
<PotentialUser-32>now I`am try to switch to older generation and repeat bug
<PotentialUser-48>ehhhh, this does not help
<civodul>roptat: i need to congratulate you on the translation of "offload" in French
<civodul>everytime i see it it makes me happy :-)
<civodul>the right word, and you avoided the obvious pitfall
<roptat>mh? what pitfall?
<roptat>using the English word?
<roptat>I need something similar for a cryptographic hash btw
<roptat>I know I saw a good translation somewhere, but I can't remember what it was... it's frustrating
<civodul>roptat: some translate it as "déport", which is bad
<civodul>anyways, great choice you made :-)
<roptat>oh I see, thanks :)
<nckx>What is a chbouib anyway.
<nckx>French foo?
<zimoun`>nckx: I do not know but it is in the Guile manual https://www.gnu.org/software/guile/manual/html_node/Slot-Options.html So maybe one Ludo’s way. ;-) Maybe something as French belgian “brôl” :-)
<PotentialUser-29>Hello, I'm messing around with Guix Environment containers and the --user argument. I don't see in the manual of a way to set the uid to 0. Default sets it to 1000 but I am unable to sudo in the container. Anyone here have any experience with this?
<PotentialUser-29>or how to have guix-daemon modify the sudo store entry to modify permissions.
<PotentialUser-29>My particular error is: "sudo: /gnu/store/z9qvzjs5mxwkwzdd3k0mmr349g75mfxc-profile/bin/sudo must be owned by uid 0 and have the setuid bit set"
<civodul>PotentialUser-29: indeed, UID 1000 is hardcoded
<civodul>we could change that
<civodul>but what are you trying to do? are you running "guix environment -C" as root?
<civodul>nckx: a chbouib is a thing that can frob
<civodul>sorta like a foo i guess?
<zimoun`>is it French?
<nckx>zimoun`: I saw it first in civodul's old GPG key, then found it in a few Guile-related documents but assume it was civodul's doing too. Didn't know that ‘brol’ was typically Belgian though; thanks!
<civodul>call it what you want :-)
<zimoun`>I only see that in your production :-)
<civodul>yeah well
<civodul>what's brôl?
<PotentialUser-29>civodul: "guix environment --ad-hoc --container --no-cwd --network --user=dreamer" I am trying to get this to work with a "fake" user and not run as any of my local users, including root
<civodul>PotentialUser-29: i'm not sure what you mean by "fake user", but what this does here is create a separate user namespace (+ PID namespace, etc.)
<zimoun`>ah “brol” is kind of happy mess, in French from France: “joyeux bordel”.
<civodul>i see :-)
<civodul>PotentialUser-29: so it's obviously running as you, but "as if" it were not
*civodul wonders how clear of an explanation that is
<PotentialUser-29>civodul: Fake is a bad term to use here, temporary user
<civodul>well it probably does what you want
<PotentialUser-29>Yes, it creates the user and has it's own space. Could I submit a request on the tracker to have an option of giving the user a uid as an argument?
<nckx>zimoun`: It's used in Flemish dialect al well, but with much less of a ‘happy’ connotation. Please clean up your brol. This non-free wireless chip is brol.
<nckx>Basically, ‘shit’, from negative to neutral as in AmE.
<civodul>PotentialUser-29: yes you could, but keep in mind that the UID inside the container has no meaning
<civodul>it could be 42 and the result would the same
<PotentialUser-29>civodul: Oh, I see. Do you have an idea of how I should proceed then with fixing sudo rights?
<civodul>PotentialUser-29: so you want things to run as root?
<PotentialUser-29>Yes
<civodul>the container thing is to "isolate" processes, so reduce their privileges rather than elevate them
<civodul>perhaps that's not what you need after all?
<PotentialUser-29>Ah I see
<PotentialUser-29>civodul: Thank you for your guidance. I will remove --container and go from there.
<PotentialUser-29>Thank you
<civodul>if you want you could discuss your use case in more detail on help-guix
<civodul>yw!
<zimoun`>nckx: I am not Wallon fluent neither ;-)
<roptat>weird, you seem to be the only one to use chbouib on the internet ^^
<civodul>you can get started too :-)
<civodul>i heard it from a friend of mine long ago
<PotentialUser-29>You guys have been busy. (220 new commits). I did a pull yesterday.
<civodul>d'you know https://frob.com/ by Roland McGrath of libc/Hurd fame?
<zimoun`>civodul: browsing some chbouib-ness, does your “Cooperative Backup Approach” make sense to share/distribute the /gnu/store ?
<nckx>PotentialUser-29: The credit for today goes to Arun Isaac, who pushed most almost 200 Rust package updates.
<civodul>zimoun`: the general idea, roughly yes
<zimoun`>and the code is Guile?
<civodul>(the idea, not the code :-))
<PotentialUser-29>nckx: Woohoo
<roptat>oh speaking of big patch series, zimoun` do you want to review my ocaml series, or should I just push it?
<zimoun`>roptat: I can try… well, if no answer from my side on Fri., push it.
<zimoun`>civodul: well, I will try to book some time to read your PhD then… :-)
<roptat>thank you, I simply wanted to make sure in case you were working on it; not to pull the rug under you :)
<roptat>alright, I need to build a few things on my arm board now, it's going to be fun
<civodul>progress report in Guile-Git seems to be working fine: https://web.fdn.fr/~lcourtes/pastebin/guile-git-transfer-progress.html
<civodul>if we want to use it, we'll have to release it by ourselves i guess as OrangeShark seems to be away
<civodul>mbakke: ↑
<roptat>guix gc seems to count bytes in a weird way, after "guix gc -F50G" I have only 17G free (and gc said "invalidated more than 5-something bytes, so it didn't stop because there was no garbage left)
<civodul>roptat: the mismatch is due to deduplication
<civodul>it cannot really know in advance how much will actually be freed
<civodul>though maybe we could improve the estimate
<roptat>I see
***niko is now known as nikotine
<roptat>note that your website doesn't show your name properly: Courtès (at the bottom)
<civodul>yeah, something with Emacs or scpaste
<civodul>or the web server there
<civodul>a tribute to latin-1
<mbakke>civodul: neat guile-git work :)
<roptat>weird how that paragraph is also after the closing html tag
<civodul>free-style html
<mbakke>sneek: later tell mothacehe are you comfortable cutting a new guile-git release?
<sneek>Okay.
<civodul>mbakke: awesome, i was going to ask you the same :-)
<mbakke>I'm merely a "developer" on the gitlab project, whereas Mathieu has "maintainer" status ;-)
<civodul>heh, well done!
<jonsger>civodul: your webserver also uses TLS 1.0 plus some weak algorithms which generates a warning in firefox
<civodul>jonsger: uh, not great (it's not actually "mine" but that of a non-profit)
<lemes>so concerning the arduino IDE package, I was able to make guix download the avr part and place it in the right place, but turns out the IDE needs to download a total of 27 other files from the internet. I believe I should individually specify them in the inputs section? that'll take longer than expected haha. if there's an easier approach, pls let
<lemes>me know, otherwise I'll do it that way
<roptat>I'm afraid you'll have to specify all of them
<roptat>note that many java packages also bundle pre-compiled libraries and binaries, and we need to remove them and build them from source before we build the package itself
<roptat>this can make it very tricky to build java packages
<roptat>you'll have to make sure it doesn't download a .jar file, or similar (also check the content of downloaded archives)
<roptat>well, looking at the content of the sources, you'll have to get rid of many pre-compiled dependencies in app/lib for instance
<roptat>and arduino-core/lib
<lemes>I see, didn't know about that
<mbakke>lemes: there are som arduino patches here https://issues.guix.gnu.org/32923 if you haven't seen them
<roptat>if you're trying to make your first package, java stuff is probably not the easiest (especially if it's to record a contribution for outreachy)
<roptat>although if it's for outreachy, contributing one missing dependency of arduino would be good enough I guess :)
<lemes>mbakke: hadn't seen them, thx
<lemes>roptat it is for outreachy, thank you for the tip
<civodul>--with-c-toolchain is in the house!
<mbakke>\o/
<zimoun`>civodul: tight schedule to try it :-) BTW, cool!
<mbakke>--with-debug-info is already my new favourite feature, even though it is not committed yet :P
<civodul>zimoun`: oh i thought you were willing to try it once it's committed, apologies, then!
<jonsger>mbakke: it lets you build a package with debug infos?
<civodul>mbakke: heh cool :-)
<mbakke>jonsger: indeed, it will graft a package with debug info in place where you need it :-)
<jonsger>that sounds awesome at least :)
<mbakke>speaking of toolchains, anyone tried creating a clang+libcxx toolchain? I might need it for ungoogled-chromium, as newer versions are nearly impossible to build with libstdc++ (unless you are a C++ expert I suppose).
<civodul>mbakke: haven't tried, would be "interesting"
<Kimapr>Is there any text editor in GRUB 2? Even the most basic one will do.
<zimoun`>civodul: that’s fine. I am bit busy this week and I have already tried the v1. :-)
<bluekeys_>Hi guix. Does anyone have a config.scm using exwm that I can take a look at please?
<roptat>civodul, I'd like to finish the copyright changes in our po files. I'll contact the latest contributor to our po files to ask them to change the copyright statement on the TP, so we can download the files and make sure we won't accidentally re-introduce the wrong copyright statement
<roptat>I can also push a change to them, but we'll need to be careful next time we download from the TP
<civodul>roptat: yes, that'd be nice!
<civodul>so we're still missing one of the two i pinged this morning, right?
<nly>bluekeys_: yes
<nly>and no
<nckx>Kimapr[m]: GRUB cannot write to any file system, so there's nothing to edit.
<nly>bluekeys_: (use-modules (gnu packages emacs-xyz)) (operating-system (packages (cons emacs-exwm %base-packages)) ...)
<nly>should do it
<roptat>for the manual, yes
<roptat>we still need to fix the copyright notice for the guix and packages domains
<roptat>(they're attributed to the FSF or you, but should be "the authors of Guix")
<bluekeys_>@nly. You're teasing me. How so, yes and no?
<bluekeys_>Right, gonna logout / login or reboot. Thanks nly, thanks guix.
<Kimapr[m]>i figured out how to boot, and i think i know where the bug lies
<Kimapr[m]>The last thing i did with system configuration is to delete older generations, which updated menuentries and possibly wrote bad grub config
<Kimapr[m]>Can someone try deleting system generations on a guix system on btrfs with '/' and '/gnu/store' being separate subvolumes in top-level of btrfs filesystem?
<Kimapr[m]>top-level (root of fs)
<Kimapr[m]>|- root (mounted at '/')
<Kimapr[m]>|- store (mounted at '/gnu/store')
<zimoun`>roptat: AFAIK, only one translator is missing. If no news, let remove their contribution and go ahead
*vagrantc doesn't see any guix folks at the reproducible builds meeting :P
<bluekeys_>Hi guix. exwm is working of a fashion (I have no idea how to use it). I needed to add (exwm-enable) to the beginning of the config as well as the lines nly explained earlier. The fonts look much better for some reason.
<bonz060>:bluekeys_ do you mean the fonts of the gtk window, or the fonts of text in your emacs buffer? FYI EXWM is my daily driver ;)
<bonz060>Most probably it may be an issue with your dpi settings. See: https://bbs.archlinux.org/viewtopic.php?id=116754. Personally I have sth like: https://paste.debian.net/1166867/ in my ".Xresources"
<bonz060>bluekeys_: HTH!
<Zambonifofex>Hello, Guix! I decided to give up trying to run (with QEMU) the Hurd image I generated for Guix, and decided to try to run the one provided in the “download” page on the website. It gave me the exact same error as the one I had generated, though! I was about to give that up entirely, until I decided to try a simpler command: `qemu-system-i386 guix-hurd.qcow2` and that actually seems to have worked by default!
<Zambonifofex>Now, the problem I ran into is that it has shown me some kind of “login prompt”, but I don’t know the username to use. I tried `login guest`, but it gives me an error: `login: guest: unknown user`.
<Zambonifofex>Actually, to be more precise, what I tried was `ql guest`, after having read the `help` command, as it suggested me.
<Zambonifofex> https://usercontent.irccloud-cdn.com/file/hOlCIZgQ/image.png
<kab-5645>Am trying to change my guix path from /usr/local/bin/guix to /home/$USER/.config/guix/current/bin/guix all effort leads to : error:bash: /home/$USER/.config/guix/current/etc/profile-no search file or directory.
<rekado>kab-5645: can you show us what you’ve tried?
<kab-5645>I tried to add this to my .profile:-source "$HOME/.guix-profile/etc/profile" and source "$HOME/.config/guix/current/etc/profile",didn't work
<civodul>Zambonifofex: try "login root"
<Zambonifofex>civodul: That seems to have worked! 😮 Thanks! 🎉 🎉
<Zambonifofex>I’m considering maybe trying to get it to run on actual hardware. Is there some information about what kind of hardware is supported?
<Zambonifofex>Although, maybe that question better fits #hurd, I suppose!
<joshuaBP`>Weird. I'm trying to define my first shepherd service that I can put in my config.scm...I'm getting an error that "service-type" is an unbound variable, but I have #:use-module (gnu services) ...I'm not certain what I'm doing wrong. Just venting. Thanks for listening. :)
<joshuaBP`> http://paste.debian.net/1166879/
<joshuaBP`>Then my config.scm has a (use-modules (gnucode-form)) ... (service gnucode-form-service-type)
<joshuaBP`>the error looks like: gnucode-form.scm:24:2: error: service-type: unbound variable
<joshuaBP`>hint: Did you forget `(use-modules (gnu services))'?
<joshuaBP`>but I'm including (gnu services)! So weird.
<rekado>the error message is likely hiding the real problem
<rekado>(gnu service shepherd) does not exist
<roptat>(missing an "s" in services)
<rekado>would be good to know why the hint is so far off
<janneke>joshuaBP`: did you try to compile the file?
<janneke>have a good look at the first line ;)
<rekado>oh, yeah, that’s another problem…
<rekado>I totally missed that
<janneke>it means you really aren't including anything; the hint isn't so bad...
<joshuaBP`>I know you guys found the problem, but I don't understand what you told me to do...give me a minute to re-read your comments to digest what you've told me.
***jonsger1 is now known as jonsger
<joshuaBP`>ahhh! define-public! not define-module! gotcha!
<joshuaBP`>janneke: you may just be a genius!
<rekado>the other problem is the wrong module name (gnu service[s] shepherd)
*janneke just plays the rubber duck
<Zambonifofex>On the download page, the “Guix on Hurd” image’s description starts with “virtual machine image …” Is there really anything to it that makes it specific for virtual machines? Could I not use it to boot on actual hardware?
<roptat>apart from the fact that you need 20 years old hardware, I don't think so :)
<Zambonifofex>Oh? 🤔 I see. 😅
<roptat>well, maybe the hurd improved since last time I tried
<Zambonifofex>I see. Fair enough!
<roptat>I mean it will probably boot on recent hardware, but not recognize a lot of stuff (ethernet, usb, audio, ...)
<bonz060>kab-5645: were you able to resolve your problem?`
<kab-5645>Am still on it.will give you an update.
<Zambonifofex>roptat: Yeah, I read here that it is not currently able to support audio or USB: https://www.gnu.org/software/hurd/microkernel/mach/gnumach/hardware_compatibility_list.html
<roptat>well, there was something, I remember a demo from maybe 2 years ago where the hurd was able to play sound
<roptat>I think it was a hack in mplayer, so only it could play sound
<rekado>it’s because mplayer has support for Sun audio
<rekado>see https://core.ac.uk/display/41816390
<rekado>with more work on the rump kernel
<rekado>… general USB support is possible
<Zambonifofex>What I was thinking about doing is (1) using `qemu-img` to convert the image to raw format, (2) storing it as a regular file on a flash drive, (3) booting from a live drive (with GNU/Linux) on the computer I want to install Guix with Hurd, and (4) using `dd` to install Hurd on the hard drive of the computer.
<Zambonifofex>Is this a good approach to trying to install it, or are there any kind of fundamental flaws I’m missing?
<rekado>nobody has tried it yet.
<janneke>it could work
<rekado>generally, the Hurd fares better inside Qemu; disk access, for example, is faster in Qemu.
<janneke>what i tried is to just install guix gnu/linux on the system, and leave a smaller 1st partition for the hurd
<Zambonifofex>I see! I was just wondering if I didn’t understand how these things are meant to work together (I’m kind of a newbie), but I’m glad at I at least seem to have gotten the basics correct.
<janneke>then with some trickeyr you can run guix system --target=i586-pc-gnu init/reconfigure
<janneke>*trickery
<janneke>it seems that rumpdisk is coming along nicely, but i guess we especially need networking support
<janneke>debian has some user-space drivers patches/branches that we aren't using
<bluekeys_>bonz060, it could be dpi. Thanks for the link. I think it is fixed now, but was broken before. For example, icefox on some sites wasn't rendering some text, but everything is rendering ok now in an Async window.
<kab-5645>do you have to do to any configuration after installing guix via shell script?
<bonz060>bluekeys_: Glad to be of help :)
<bonz060>kab-5645: What do you mean? IIRC you don't have to do anything after running the shell script. If you have to, the shell script would hint at it at the very end after completion.
<kab-5645>thanks,I think you have answered my question.
<bonz060>kab-5645: Cool \m/\m/
<Zambonifofex> https://usercontent.irccloud-cdn.com/file/nwoJDzMd/20201012_184027.jpg
<Zambonifofex>Welp, I tried, at least!
<nojr>Does anyone know how to fix this issue when running M-x guix in Emacs on a foreign distro?
<nojr>guix-geiser-eval: Error in evaluating guile expression: ice-9/boot-9.scm:1669:16: In procedure raise-exception:
<nojr>error: package/output-sexps: unbound variable
<Zambonifofex>I’unno, maybe I sound take my Guix on Hurd adventures to #hurd. Maybe people there around find it more interesting, and maybe even be able to help.