IRC channel logs

2020-08-13.log

back to list of logs

<Gooberpatrol66>What are some examples of LV2 plugins that have been packaged for guix?
<rekado_>Gooberpatrol66: we’ve got lots
<rekado_>try guix search lv2
<vagrantc>in gnu/packages/linux.scm ... it looks like make-linux-libre is defined at least twice ... is that a typo, or is something going on that i don't understand?
<rekado_>finally fixed conda
<rekado_>it is so horrible
<rekado_>maybe I broke it
<rekado_>but at least “conda search python” seems to work fine
<rekado_>after massive patching the build passed, but I found that most commands failed
<rekado_>they would just print a message telling me to run “conda init”
<rekado_>“conda init” directly prints a password prompt without any further information
<rekado_>turns out it re-runs itself as root
<rekado_>via sudo
<rekado_>and then it attempts to install a whole bunch of files into its own prefix directory
<rekado_>the horror!
<rekado_>luckily I managed to run “conda init” as part of the installation
<rekado_>still wants “sudo”, so I cheated it by providing a ’#!/bin/sh\nexec $@’ wrapper on the PATH
<rekado_>the conda sources are littered with assumptions about how it is installed
<rekado_>sys.executable, sys.prefix, etc are everywhere
<rekado_>it is also rather confused about symlinks
<rekado_>this is all horrible
<rekado_>I don’t ever want to touch this again
<rekado_>~~ fin ~~
<ryanprior>rekado_oof. Can I save that and quote you on or off the record? I'm actually working on a talk about Conda vs Guix for Python package management
<rekado_>yes, you may quote me
<rekado_>I should add that conda is very popular and has helped many people install software without having to beg sysadmins
<ryanprior>Oh without a doubt. Conda has a super important place in data science.
<rekado_>so the fact that it exists and is useful for many people is a win for freedom from sysadmin abuse of powers
<rekado_>I reported the sudo thing to their github issue tracker about a year ago.
<rekado_>pinged once. no comments.
<rekado_>no surprise because there are more than 1000 open issues
<vagrantc>oh ... one is ... (define* (make-linux-libre version hash-string supported-systems and one is ... (define* (make-linux-libre version hash-string supported-systems
<rekado_>my point is just: it’s not for me, neither the code, nor the development decisions, nor the tool itself.
<vagrantc>er...
<vagrantc>(define* (make-linux-libre* version source supported-systems
<vagrantc>(define* (make-linux-libre version hash-string supported-systems
<vagrantc>the extra asterisk must be significant :)
<rekado_>the extra asterisk is often read as “prime”.
<rekado_>indicating a variant
<vagrantc>is it just a convention, or otherwise significant?
<vagrantc>or rather, does it have special meaning in guile (or guix)
<ryanprior>Where I've seen it in Guile made me read it as "special"
<ryanprior>Like you have the basic version of thing, then you have a bunch of bells and whistles or extra behaviors with thing*
<vagrantc>but from guile's perspective, it's just another variable?
<bavier[m]1>yes
***ChanServ sets mode: -b *lisbeths*!*@*
<raghavgururajan>Hello Guix!
<raghavgururajan>nckx: What's with the "‎Mode #guix [-b *lisbeths*!*@*] by ChanServ"?
<lisbeths>he he he well you see I was off my meds a couple weeks ago
<lisbeths>and I said some nasty stuff, some political stuff
<lisbeths>and I have decided to take my meds and put that political stuff aside to get work done
<raghavgururajan>lisbeths, Ah I see.
<lisbeths>my main issue is that my laptop does not support a libre kernel. I have painstakingly removed every piece of proprietary software from my system however the kernel is not one I can get rid of. I do have a wifi-dongle for using the internet during the installer process, however I need to sideload a kernel so I can begin work on this system.
<raghavgururajan>lisbeths, Glad that you are doing well now, health wise.
<lisbeths>I have had trouble getting used to the new politically correct landscape in programming, but I must humble myself to progress and set aside my ideology for getting things done. The time savings for linux devs for guix is too high for me to overlook as a programmer, and the prospect of a lisp machine on the application layer.
<raghavgururajan>I see.
<lisbeths>My poor little 6 year old laptop with 2 gb of ram that *does* support linux kernel has spent 12 solid hours compiling guix on swapspace.
<raghavgururajan>You could use substitutes?
<lisbeths>substitutes for what?
<raghavgururajan>For stuffs that you are building.
<bavier[m]1>my little 10 year old atom-based netbook often spends many hours building packages
<nckx>TBH I don't remember political stuff (and that wouldn't get you banned), just low-effort herdthink insults. They tend to get banned because they're just... boring.
<bavier[m]1>but I've been getting a better manifest setup going w/ some help from the guix-cookbook so I can stagger updates a bit better
<lisbeths>I can go into the file location that the kernel is in, and swap them out. this is not an issue. it is just I don't know if there is a proper lisp way of changing kernels
<lisbeths>I mean to say that I want to swap out my kernel gracefully
<lisbeths>I am not looking for "support" in the sense that that is part of the guix system. I am looking for "support" in the sense that I am doing it the way that kernel management was intended to be done within guix
<nckx>lisbeths: Absolutely possible. The Guix way isn't to into linux-libre.scm and edit it, but to create your own linux-lisbeths (whatever) variable. You can use (inherit linux-libre) to re-use part of Guix's package or write your own kernel package from scratch, then use (kernel linux-lisbeths) in your operating-system.
<lisbeths>ah I see, so you are saying I need to package my nonfree kernel in an unofficial package
<bavier[m]1>"custom" package, which is an awesome option with guix
<nckx>Could we keep this discussion generic please? Guix System supports totally user-defined custom packages, including kernels, yes.
<lisbeths>I see. And there are no officially supported pre-built kernels available in a sort of "nonfree" repository, like in debian?
*raghavgururajan used Guix as mainstream OS, when it was in beta. He is brave after all.
*raghavgururajan misses the line "Thanks for being so brave" on guix.gnu.org
<lfam>lisbeths: I don't believe so, although they likely wouldn't have been discussed here if they did exist.
<sneek>Welcome back lfam, you have 3 messages!
<sneek>lfam, vagrantc says: yes, the pinebook pro patch just pulled in the device-tree, if i remember correctly, which is now in upstream as of 5.7.x
<sneek>lfam, vagrantc says: full support for pinebook pro requires more patches ... working on it in wip-pinebook-pro branch
<sneek>lfam, nckx says: CONFIG_HIBERNATION_SNAPSHOT_DEV is somewhat interesting as far as kernel options go: it's not a feature per se. Until very recently, userspace could happily corru^Wwrite to active swap devices. That hole was finally closed in 5.8. This option partially re-opens it for one specific use case (hence the note about ‘attack surface’). Anyway, not (yet) relevant for us.
<brettgilio> https://mstdn.social/@brettgilio/104679583404233985 I wrote an alternative to Drew DeVault's openring in emacs lisp for org mode integration. Check it out
<bavier[m]1>lisbeths: this would not be the place to get help with that specific of a thing
<lisbeths>is there any place in irc that would be acceptable to get help making guix work on my computer?
*nckx really needs to 😴. Good night everyone. lisbeths, good luck.
<lfam>We actually have a blog post about using custom kernels with Guix: https://guix.gnu.org/blog/2019/creating-and-using-a-custom-linux-kernel-on-guix-system/
<lfam>There are lots of reasons to use custom kernels. The linux-libre kernels we offer are designed to "just work" on pretty much any computer although, as you noticed, there are some things that might not work because they aren't supported with free software
<lisbeths>yes. What it comes down to is that I am very poor and wanted a computer that could both meet my needs and be affordable. I think perhaps many of the folks who shun those that use nonfree kernels might be what you would call "privelaged class"
<lisbeths>I do not have the privelage of purchasing nonfree hardware any time soon.
<lisbeths>s/nonfree/free
<lisbeths>but anyway someone had referenced me in dms to a repository called "nonguix" and I think that the inability to speak of this or the fact that this is taboo is very backwards and doens't help anyone.
<bavier[m]1>I understand needing to work with what you can get.
<lisbeths>I am very against the censorship of software.
<lisbeths>That is why I had spoken some very hateful words and gotten myself banned the last time I was here.
<lisbeths>I am still filled with a certain amount of hate over the censorship of software that I have seeen here.
<bavier[m]1>it's not censorship. but taboo, yes.
<lisbeths>then i shall take my leave, as a good samartian has helped me in dms
<bavier[m]1>good luck
<lisbeths>I will return if I have a support question, but I do not wish to collaborate with you if your taboo prevents me from installing guix on my machine.
<lfam>Hm
<bavier[m]1>we will certainly help you get up and working with other aspects of guix.
<bavier[m]1>oops, left already
<lfam>It's good that they will be able to use Guix but too bad that we couldn't talk about it more
<lfam>It's not really a positive outcome for Guix
<bavier[m]1>hmm
<bavier[m]1>I mean, is it not clear that this channel is not the place to get support for nonfree software?
<bavier[m]1>frustrating, I guess, but there aren't many other one-stop-shops either
<lfam>It's not good if we are inspiring people to storm out. Although, I think there is a degree of understanding we tend to eventually develop; understanding of why seemingly arbitrary rules are enforced
<lfam>But it's not something that everybody learns
<lfam>It's definitely clear that this is not the place for that
<bavier[m]1>I'm not in as many channels as maybe some others are, but our tact here seems to be exemplary
<lfam>Yes
<bavier[m]1>other channels would have more direct and choice words
<blackbeard[m]1>I think that lfam is right, the rules may seem arbitrary but they are not
<blackbeard[m]1>and there is no such "censorship" of software
<blackbeard[m]1>just because you don't want to do something for somebody doesn't mean it is censorship
<blackbeard[m]1>it is like going to an anti-gun organization and asking someone to teach you how to fire a gun
<blackbeard[m]1>and then getting pissed at them for not doing that?
<blackbeard[m]1>seriously?
<lfam>It is kinda like that
<bavier[m]1>right
<rekado>hey there! I’m lost in my attempts to get McCLIM to start.
<rekado>could anyone here guide me in using sbcl and starting the clim-listener?
<rekado>I’m not sure how this is supposed to work.
<rekado>web sites all recommend the use of quicklisp, but that’s not for pre-built packages
<rekado>there’s also asdf, but I don’t understand how any of this works
<rekado>I did this: guix install sbcl sbcl-mcclim sbcl-slime-swank
<rekado>and then started the sbcl REPL
<rekado>then (require :asdf) and (require :mcclim)
<rilez>you may have more luck in a common lisp channel in case we are unable to help here
<rilez>does (require :mcclim) work?
<rekado>yes, it prints lots of warnings but seems to complete
<rilez>cool! Have you been able to run any of the McClim demos?
<rekado>no! I don’t know how.
<rekado>I tried (asdf:load-system 'clim-examples), but this errors out
<rekado>is there a load path I need to set?
<rilez>hmm i would definitely recommend using quicklisp
<rilez>even though it will pull sources, it will set up all the paths for you
<rekado>doesn’t Guix do that as well?
<rilez>If you can find where 'clim-examples lives in your filesystem, you can add it to your asdf path somehow, but I'm rusty
<rilez>I don't know if Guix will set your adsf path
***terpri__ is now known as terpri
<rekado>I see that sbcl has a search path specification for … XDG_DATA_DIRS?
<rekado>the asd files for the examples and Drei are in sub-directories, so perhaps I just need to add those
<rilez>probably!
<rilez>I'm skimming through the asdf manual now. This is really getting in to common ilsp territory, so I don't know if we should change channels, but here's the quickstart guide for ASDF https://www.common-lisp.net/project/asdf/asdf.html#Quick-start-summary
<rekado>thanks
<rekado>I wonder if we need to something in Guix to make this a little smoother.
<rilez>np! If you're looking to get into common lisp development, you should check out quicklisp for sure
<raghavgururajan>Does anyone have intel on opencv build failure?
***drakonis- is now known as drakonis
<raghavgururajan>Found it!
<raghavgururajan>mbakke: The commit 4bd428a7ce382f623784a3ff8186aadc3cebca91 causes opencv build failure.
<raghavgururajan>error: lvalue required as unary ‘&’ operand
<raghavgururajan>Looks like opencv is incompatible with jpeg-turbo.
<terpri>hm, can't view files in calibre, just says "Could not find QtWebEngineProcess"
<terpri>it has "/gnu/store/wpl0ynxjf2grab5gi3imvz2ldqybvrw9-python2-pyqtwebengine-5.14.0/lib/python2.7/site-packages" and "/gnu/store/myjn44xd9fkpgyf5kspp2fx68gcdlzzv-python2-pyqt-5.14.2/lib/python2.7/site-packages" in the calibre launch script's PYTHONPATH...
<terpri>"python2-pyqtwebengine"..."Prior to v5.12 these bindings were part of PyQt itself." perhaps a missed input during an upgrade?
<mroh>terpri: no, I dont think its a missed input, because mbakke worked quite some time making a qtwebengine pkg for py2. maybe seomthing missing in the wrapper?
<mroh>emacs to the rescue: emacs-calibredb works well ;)
<str1ngs>terpri: does installing qtwebengine into your profile help? qtwebengine should provide a search path for QtWebEngineProcess
<brendyyn>terpri: i might have a look at updating it
<brendyyn>certain parts of it wont work i think. its transitioning to python3 slowly
<terpri>ah yes, qtwebengine in profile fixes it, thanks
<str1ngs>terpri: that's not idea, but it's a quick fix atleast.
<str1ngs>s/idea/ideal
<str1ngs>I would probably change python2-pyqtwebengine to use environment variable QTWEBENGINEPROCESS_PATH set to the input of qtwebengine lib/qt5/libexec/QtWebEngineProcess path. not sure how to do that properly in python myself.
<str1ngs>or add this to calibre wrapper if it has one.
<brendyyn>looks like there are other programs that also wrap it so seems resonable to change the calibre package.
<str1ngs>that's the intention I had when I made the webengine package. that QTWEBENGINEPROCESS_PATH would be wrapped from the input. I'ts a little more problematic for language bindings though.
<str1ngs>s/webengine/qtwebengine
<brendyyn>first time using guix in a long time. updated ant rebuild my local guix and i get all these warnings. how can i get rid of them? https://paste.opensuse.org/view/raw/95092466
<str1ngs>brendyyn: your local guix build probably used guile 2 . check the guile version
<str1ngs>you can also ensure the guile version with ./configure GUILE=/path/to/guile-3
<brendyyn>hmm ill try a make clean and do it again. after updating i shouldnt have a guile 2 anymore
<str1ngs>clean will help. just ensure it's using gulie 3
<str1ngs>err guile 3
<str1ngs>terpri: a good example how to wrap QTWEBENGINEPROCESS_PATH is qutebrowser. I used that as a reference implementation for qtwebengine.
<pkill9>how easy would it be to add functionality to guix data service to list files in a derivation's output?
<jonsger>nckx so you are already updating thunderbird?
***jonsger1 is now known as jonsger
<nckx>Good morning Guix.
<nckx>jonsger: Me? No. Why?
<raghavgururajan>nckx: Is there a way to use a remote computer to build stuff for local computer, via ssh? Like `guix build foo` will actually connect to the remote computer for the guix-build-process.
<raghavgururajan>nckx: Technically, the `guix build` command will connect to guix-build-daemon on the remote computer, via ssh. Any way for that?
<PurpleSym>raghavgururajan: You could use offloading or just SSH into the other machine, `guix build` and then `guix copy`.
<nckx>raghavgururajan: Yep, you're literally describing offloading 🙂
<raghavgururajan>PurpleSym: Ah, I have to look into offloading.
<raghavgururajan>nckx: I see.
<nckx>However, the two machines need to completely trust each other, since clients can push the dependencies they already have to the offloading server, i.e. arbitrary binaries.
<nckx>So you can't offload to bayfront, but you can offload to a powerful machine you own.
<raghavgururajan>nckx: AH, so the remote machine should also be configured to receive off-load requests from a particular list of machines?
<raghavgururajan>> So you can't offload to bayfront, ...
<raghavgururajan>Damn! I was looking forward to it haha
<jonsger>hm does opencv fail also for others=?
<nckx>raghavgururajan: From a particular list of trusted keys, to be exact, but yes. You need to exchange keys between the machines before you can offload, see the manual.
<nckx>raghavgururajan: bayfront: I suspected as much. :-) It's tempting but I don't think there's a secure way to allow that with the current system.
<nckx>jonsger: Above, raghavgururajan said it was due to openjpeg-turbo.
<nckx>jonsger: Why the Thunderbird question?
<jonsger>nckx: because no one updated to 68.11.0 yet :P
<nckx>But why me? (‘so you are already updating thunderbird?’)
<nckx>I don't use it.
<raghavgururajan>> ‎nckx‎: raghavgururajan: bayfront: I suspected as much. :-) It's tempting but I don't think there's a secure way to allow that with the current system.
<raghavgururajan>I understand.
<raghavgururajan>jonsger: Yes, it fails with an error related to jpeg2000.cpp.
<raghavgururajan>So it must be with jpeg-turbo or jasper.
<jonsger>nckx: ah so it was only a friendly hint :P
<nckx>😃
<nckx>Worth a try.
*raghavgururajan is already working on a fix for OpenCV, in wip-desktop.
<nckx>Oh, I ‘recently’ updated jasper.
<raghavgururajan>nckx: Ah that must be it.
<nckx>IIRC older jasper versions have vulnerabilities so this still needs to be fixed.
<nckx>Or JPEG2000 support disabled ‘for now’ :-/
<raghavgururajan>mbakke: Never mind about the libjpeg-turbo commit
<raghavgururajan>Because mbakke's commit was long ago and opencv was building fine after that.
<raghavgururajan>nckx: No worries, I am also updating OpenCV.
<raghavgururajan>So the new version of OpenCV might be compatible with new version of Jasper.
*raghavgururajan might need to update VTK first, before updating OpenCV.
<nckx> https://github.com/jasper-software/jasper/issues/208
<nckx>raghavgururajan: Thanks!
<nckx> https://github.com/opencv/opencv/issues/17984
<raghavgururajan>Cool!
<nckx>I'll apply that fix to master if it applies, but an update is of course still welcome.
<nckx>jonsger: Where does one find the correct %icedove-build-id?
<jonsger>nckx: I usually just take the date of the release :)
<jonsger>it needs to be constant
<nckx> https://issues.guix.gnu.org/42849 -- interesting...
<efraim>I have to remind myself to open links using netsurf and not 'links -g'
<efraim>it displays much better
<nckx>Well, yeah. links is a text console browser that can render images, netsurf was always a GUI.
<rekado>evaluations fail because we have “ncurses” somewhere where a list is expected: https://ci.guix.gnu.org/eval/15727/log/raw
<rekado>any idea what might be wrong here?
<pkill9>a lightweight browser that doesn't use webkit, nice
<efraim>it was less of an images thing and more of a line break thing
<efraim>this time at least
<nckx>All lightweight browsers don't use WebKit by definition.
<pkill9>i think in the age of chromium/firefox, webkit is considered lightweight
<pkill9>but i agree with you
<nckx>efraim: I was going to valiantly defend links -g because it can be used without X/Wayland (even though the Guix version can't), but it seems like netsurf should have framebuffer support too. Neat.
<efraim>from the package cache it could be anywhere, or just a race condition
<nckx>Hard to imagine now that links -g on a VT was my primary & only browser for years.
<rekado>I hope the evaluation error is not due to my changes in pandoc.
<rekado>ah, found it!
<pkill9>is there netsurf but with vim keybindings?
<nckx>jonsger: I haven't forgot about IceDove, it just takes forever to build.
*str1ngs curses ncurses.
<str1ngs>pkill9: vim bindings? what the....
<pkill9>str1ngs: like qutebrowser, dwb, luakit, etc
<str1ngs>what is this madness. why not Emacs keybindings!
<pkill9>lol
<str1ngs>you know that's the whole reason I started writing Nomad.
<pkill9>you should make a guile web renderer
<pkill9>:P
<str1ngs>web rendering is not easy. though I can use different renders. I think that's a task for someone else :)
<str1ngs>sneek: later tell nly. take-a-selfie saves to the current working directory aka M-: (getcwd) . It was a quick hack I'd like to switch to using GdkPixbuf so that there is no need scrot or any dependencies.
<sneek>Will do.
<bavier[m]1>pkill9: netsurf supports keyboard shortcuts, and I think those could be patched pretty easily in the source ;)
<bdju>does the current version of megatools packaged not actually work? it's telling me my mega link is invalid
<bdju>they won't let me download my files with firefox. I just wanted to back them up locally so I can not worry about them anymore
<bdju>might be that mega changed how the URLs work since the version that's packaged
<guix-vits>bdju: try installing nix (check the Manual, IDK what i'm speaking about), and install the megatools. Maybe their version works.
<bdju>checking the package search on their site, they're on 1.10.3 which is barely newer than our 1.10.3. On an arch machine I seem to have 1.11.0, but it might be a -git package from the AUR
<bdju>second number meant to be 1.10.2
*guix-vits "... *on top of Guix, as addition. In the meantime."
<guix-vits>Ah
<guix-vits>bdju: Ok, less fashion: `configure && make ..`?
<guix-vits>You can specify a --prefix to some ~tmp-user/stuff.
<bdju>I guess it could be worth a shot, but I was under the impression you couldn't build stuff normally on guix
<guix-vits>to not mess with the system on make install.
<bdju>hm I've never tried that before
<guix-vits>bdju: IDK. Maybe updating this package can be easier. Did You log-off/log-in cycle after installing this package?
<str1ngs>guix-vits: suspend seems to work.
<guix-vits>str1ngs: Thanks.
<bdju>guix-vits: I've had it installed for months, I just don't use it much
<bdju>sounds like actually 1.10.3 would fix it, they added support for the new URLs. so a minor upgrade would fix it
<bdju> https://megous.com/git/megatools/commit/?h=1.10.x
<efraim>bdju: I just bumped the version of megatools to 1.10.3
<NieDzejkob>bdju: this comment seems to imply the support is only in 1.11-git? https://github.com/megous/megatools/issues/411#issuecomment-628113039
<NieDzejkob>you can also try the megacmd package, I guess
<NieDzejkob>that one is official
<bdju>NieDzejkob: that issue doesn't sound the same to me
<bdju>efraim: thank you! I'll try it in a sec
<tricon>In provisioning my machine via Guix's System Configuration, I have some supporting files I wish to ref (e.g. a `wpa_supplicant.conf' prebuilt for my Wi-Fi). Is the best practice to wrap this in a custom package with a simple builder so that it can be included and referred to in `operation-system'?
<fnstudio>hi, i'm running guix on a foreign distro, i'd like to backup any relevant guix-related files or folders, while of course not backing up anything that's unnecessary (eg binaries)
<fnstudio>is it just `.guix-profile/manifest` that i need to back up (plus everything under `.guix-profile/etc/` if anything was customised there)?
<PurpleSym>fnstudio: All you need is the output of `guix describe -f channels` and a list of packages you installed (`guix package -I`) to recreate the exact environment you’re using right now.
<PurpleSym>Using a manifest would make things easier, but .guix-profile/manifest is not what you want.
<fnstudio>PurpleSym: fantastic, thanks for that - i'll update my backup mechanism to reflect that
<PurpleSym>Restore would be something like `guix pull -C channels.scm` followed by `guix package -m manifest.scm` (if using a manifest).
<fnstudio>PurpleSym: right you say if using a manifest but i also understand that the output of `guix package -I` is not a manifest is it
<str1ngs>fnstudio: as PurpleSym suggested. For this it's better to install packages with guix install -m ~/config/profile.scm . then to backup ~/.guix-profile/manifest.
<fnstudio>ah...
<str1ngs>this way there is really no need to back up anything other then your manifest file.
<fnstudio>str1ngs PurpleSym: i think i see
<PurpleSym>Afaik there’s no programmatic way to generate a manifest from installed packages right now.
<PurpleSym>.guix-profile/manifest explicitly mentions you cannot use it with `-m`
<str1ngs>I don't think there is a need with manifest files. this way it's declarative anyways.
<str1ngs>Also want to build your profile but not install them. guix build -m ~/config/profile . Want to package your profile completely guix pack -m ~/config/profile.scm . you get the idea :)
<fnstudio>str1ngs: thanks i've been kept in a call but i'll explore that in a min - ktx
<str1ngs>fnstudio: no worries
<hendursaga>What's the policy on optional dependencies/features? Include them all unless the resulting size is too large and consider splitting it off as another output?
<apteryx>hendursaga: we err on the side of enabling as many functionality as possible, although considerations are given to the closure size, and how many dependants it has.
<apteryx>so pretty much what you wrote :-)
<hendursaga>My, how intuitive everything is here :)
<str1ngs>Hello, is there a reason that guix build --with-commit="nomad=e58805d33034474402fbc6ea6102357abd8e3b4c" nomad. builds way more then expected? If I manually update the nomad declaration with that commit hash it only builds nomad as expected.
<lfam>str1ngs: I recommend comparing the derivations of the differing builds
<guix-vits>gb
<str1ngs>lfam: how best would I do that?
<lfam>Are you asking how to look at the derivations?
<lfam>You pass the option "--derivations" to the `guix build` command, and it gives you the file name of the derivation
<lfam>They are text files, just Guile scripts
<lfam>Well, they aren't Guile
<lfam>They can include Guile IIUC
<str1ngs>okay I'll compare the two. though I'm not sure how they would be different from --with-commit=<hash> vs using the same hash in a package declaration
<str1ngs>for example if webkit is already built why would it build it again --with-commit
<pkill9>str1ngs: there's an issue with how guix finds all the packages to replace the input of
<pkill9>it's the same as --with-graft
<pkill9>there is something on it in the mailing list
<pkill9>i think it's something to do with it using the build system's closures, or something idk
<lfam>Looking at the derivation will show you what the difference is, str1ngs
<str1ngs>hmm not replacing any inputs though just changing the hash commit for a build. why would it rebuild the input just seems odd. I guess possibly the derivations change because of the --with-commit?
<apteryx>hmm, I'm struggling with a really weird networking problem. Wired ethernet doesn't seem to work anymore on my Guix System, although the link is established. DHCP requests fail to go through, and when I set two machines over the same network (via static addresses), they can't ping one another.
<str1ngs>guix build --with-commit="nomad=e58805d33034474402fbc6ea6102357abd8e3b4c" nomad --derivations -n shows /gnu/store/7vpfh79cjwxffspf80zndr19rc5q28s6-webkitgtk-2.28.4.drv. so I assume this has changed while using --with-commit?
<str1ngs>I can't get the derivations for guix build nomad --derivations it just list nomads drv
<lfam>"--derivations -n" is not what I suggested
<lfam>That's a dry run of creating the derivation
<str1ngs>well without dry running it tries to build webkit which as I said is not expected.
<lfam>Anyways, as pkill9 suggested, there may be a bug in how this stuff works
<lfam>I see, I didn't realize the unexpected thing was that it was building webkit
<lfam>You can see what the difference is by comparing the right derivations. But figuring out why they are different might require looking in the Guix code (or searching the bug reports)
<lfam>But, comparing the derivations can help
<str1ngs>well webkitgtk is already built, and it does not build if I manually change the hash.
<akko>hi guys, I am pretty new to guix, installed it yesterday and been trying to get used to it, so lemme ask something: let's say I want vim for both root and user, the way we do this is just run guix package -i vim in both root and user?
<lfam>You can still see the derivation of something that is already built, str1ngs
<lfam>akko: Is this on Guix System? Or Guix on another distro?
<akko>guix system lfam
<str1ngs>as I also said passing --derivations to guix build nomad does not list any derivations for nomad so not sure how to compare the two
<lfam>akko: On Guix System you can add vim to the (packages) field of config.scm
<akko>manually add it?
<lfam>str1ngs: For me, doing `guix build nomad -d` returns "/gnu/store/ax0lcsv0i12qacwm5nfy8ygnq8z55ln6-nomad-0.2.0-alpha.drv"
<lfam>akko: Yes, and then reconfiguring the system
<lfam>akko: This section of the manual should help: https://guix.gnu.org/manual/en/html_node/Using-the-Configuration-System.html#Globally_002dVisible-Packages
<pkill9>lfam: maybe compare the derivations of the webkit
<lfam>Please let us know if you need more assistance
<pkill9>i mean str1ngs
<akko>lfam: thank you, I'll read it :)
<str1ngs>screw it I have a ryzen 3900x I'll just build the rebuild world :)
<apteryx>akko: Welcome! Also please note that 'people' is better form that 'guys' in this channel.
<akko>apteryx: oh ok, sorry
<apteryx>no need to be sorry :-)
<akko>:3
<lfam>Hm, it's unfortunate that paste.debian.net is offline
<akko>lfam: may I recommend you some other services? there is 0x0.st and bsd.ac
<lfam>akko: Can they be used with a web browser?
<akko>lfam: I'm afraid not ;( you have to curl to them
<Formbi>hello
<Formbi>0x0 can be used with Emacs
<akko>there is uguu.se aswell, it is licensed under the mit license
<Formbi>and there's termbin
<lfam>Hm, hopefully it comes back online. It's not urgent to replace it in our channel suggestion
<Formbi>I am trying to build Firefox 79 and I get this: « 0:08.25 error: checksum for `winapi-i686-pc-windows-gnu v0.4.0` changed between lock files»
<Formbi>do you know how to fix this?
<lfam>Formbi: Is that a package in Guix?
<Formbi>nope
<Formbi>I'm trying to package it
<lfam>Somebody here might have advice, but it's more likely you'll find help in a Mozilla or Firefox channel
<akko>let me know if you can make it, I'm currently without a browser on my guix box
<Formbi> https://gitlab.com/Formbi/my-guix/-/blob/master/my-packages/firefox.scm
<lfam>Do you know where that error is coming from Formbi?
<Formbi>I don't know much about the cargo thingy
<lfam>Yeah, it's a huge pain to package
<lfam>Rust stuff, that is
<lfam>You might also get help on a Rust or Cargo channel
<lfam>There are Rust packagers here, so they might have advice
<str1ngs>lfam: https://paste.gnome.org/ works
<lfam>Thanks str1ngs. That could be a good replacement if we need one
<lfam>It appears to work over Tor which is a soft-requirement
<str1ngs>lfam: it's what daviid and I use in #guile when debpaste has issues.
<lfam>Cool
<str1ngs>which is often :)
<Formbi>here's the whole log: https://0x0.st/iYBi.txt
<str1ngs>lfam: that's primarily why we use it as a backup. it's tor friendly
<Formbi>lfam: https://forge.monarch-pass.net/warrah/warrah-nonfsdg/src/branch/master/warrah-nonfsdg/packages here's a Firefox 74
<Formbi>although it didn't build for me
<akko>lfam: after I add something to config.scm what do I run?
<lfam>The browser packages really have to be integrated into GNU Guix in order to work reliably, since they are soooo sensitive to changes in their gigantic dependency graphs
<Formbi>this commit was working though: https://forge.monarch-pass.net/warrah/warrah-nonfsdg/commit/b06dcf421c14ef793e5d2dc55fc3778c5b968106
<Formbi>lfam: yeah
<lfam>akko: Then you should run, as root, `guix system reconfigure /etc/config.scm`. I believe you'll need to reboot for it to take effect
<akko>so I'll have to do that for every new package I add?
<Formbi>if only there was a fully free Firefox without the Icecat nonsense
<Formbi>akko: btw why won't you try ungoogled-chromium?
<lfam>Some people would say that Firefox is that browser
<Formbi>it's better than nothing
<akko>Formbi: is it on the repos?
<Formbi>but it has DRM and so on
<Formbi>akko: yes
<akko>:o I'll definitely get it then
<lfam>Formbi: Sure, but that's a different problem than free licensing
<lfam>The main issue for distributing Firefox, historically, has been the "Firefox" trademark
<apteryx>Formbi: which Icecat nonsense are you referring to? It's served me well over the last past years.
<Formbi>there is some configuration which prevents some sites from working properly
<apteryx>some sites trying to track you and run javascript ladden adds, yes ;-).
<bandali>^
<bandali>if anything, icecat turns off some nonsense upstream firefox features
<bandali>to better protect you, your freedom, and your privacy
<bdju>hm got a different error with the new megatools now. API call 'g' failed: Server returned error ENOENT
<apteryx>Icecat also comes with stricter security/privacy settings out-of-the-box. I was surprised to find out my government was using weak TLS suites on some of their pages.
<apteryx>out of the box*
<akko>how often should one run guix pull?
<Formbi>as often as you wish
<akko>Formbi: I see. also, when I run guix package -u it always only gives me a warning saying I should consider running guix pull and guix package -u
<akko>i just ran guix pull, does that mean I have no upgrades?
<lfam>akko: After the first time you run `guix pull`, you should open a new terminal window or start a new shell
<akko>and after that I don't need to anymore?
<lfam>Right
<akko>cool
<lfam>I don't know why it's not working for you. My suggestion is just a "good guess"
<akko>it just worked :)
<akko>I expect to break this install, every time I test a new distro I break it at least 3 times before getting used to it XD
<lfam>It's definitely not intended to break :)
<akko>guix won't break, I will break guix lol
<akko>it is very different from anything im used to, will take me a while to get used to it
<telior>hi! I'm running a (mostly) fresh guix install on a thinkpad, ran into some problems while trying to install ungoogled-chromium. First of all, it took about a day and a half to build, and after reaching 100% it stopped because of a builder error. The logs show this: https://pastebin.com/YRgFpNgV
<vagrantc>you have a very plausible story!
<telior>huh?
<vagrantc>as in ... ungoogled-chromium takes a very long time to build, and often fails just when you think it's almost done
<vagrantc>at least, that's been my experience
<vagrantc>sorry for being unhelpful ...
<lfam>"clang-10: error: unable to execute command: Killed"
<lfam>That often means that you ran out of memory
<lfam>Do you know how much RAM you have?
<lfam>telior ^
<telior>vagrantc oh, I thought you were being sarcastic lol. It does, it took a long as well in arch, I somehow thought it would bedifferent in guix, damn chromium
<telior>lfam I have 8gb D:
<vagrantc>any swap?
<lfam>It would fail at the end due to insufficient memory because that's when it requires the most memory
<telior>plus some swap, don't remember how much tho (maybe 4gb?), it was setup by the graphical installer
<Formbi>telior: I'd say don't bother
<Formbi>wait until it's available as a substitute
<lfam>I don't know how much is required, but it's probably "a lot"
<lfam>I'm checking with `guix time-machine` if it's available for the last time our build farm says it was built
<lfam> http://ci.guix.gnu.org/search?query=ungoogled-chromium
<telior>thing is I need to use Jitsi and icecat seems to be too old for it :c
<lfam>Assuming you are using x86_64, the most recent build appears to have been on July 26 (not great!)
<lfam>Clicking on that build ID, we see that build was part of evaluation 15316, based on Guix git commit ebd1ba713cbefc9ad5dac609255e1344a328e360
<lfam>I ran `guix time-machine --commit=ebd1ba713cbefc9ad5dac609255e1344a328e360 -- build --no-grafts ungoogled-chromium --dry-run`
<lfam>It said that it would download a substitute for ungoogled-chromium, which means you would not have to build it
<lfam>When installing it, you *would* need to perform some grafts, but that should not take too long
<telior>:0 I'll try that now, tyvm :D
<lfam>So, you should be able to simplify it to `guix time-machine --commit=ebd1ba713cbefc9ad5dac609255e1344a328e360 -- install ungoogled-chromium `
<telior>just run that command as is, or do I need to do any previous setup to use time machine?
<lfam>I'll try it now
<lfam>Nope! The command sets itself up
<lfam>Yup, worked for me! I didn't have to compile anything from source
<telior>it's on the `Computing Guix derivation for 'x86_64-linux'... ` step, let's see..
<lfam>That's expected
<lfam>It's as if you were doing `guix pull --commit=ebd1ba713cbefc9ad5dac609255e1344a328e360`, but just for this operation
<apteryx>telior: Firefox is not even recommended by Jitsi upstream until they have more fixes for it (jitsi side) landing
<telior>it worked!! :D
<telior>I was afraid I'd have to wait another day and a half lol
<telior>tyvm :D :D
<lfam>You're welcome telior!
<Formbi>if it did in fact start the 1.5 day thing, you could just C-c it or something