IRC channel logs

2019-12-22.log

back to list of logs

<civodul>g_bor[m]: Cuirass used to leak fds, but i don't think that was related to the web server (plus it uses its own variant of the web server module)
<kirisime>Does the guix system configuration system support custom hwdb files?
<guixy>The manual doesn't have the case-insensitive string "hwdb". I'm guessing if guix does support custom hwdb files it would be configured with the udev-service.
<guixy>see http://guix.gnu.org/manual/en/html_node/Base-Services.html#index-file_002d_003eudev_002drule
<guixy>Upgrading clojure breaks at least one of the tests.
<brettgilio>Just sent an email to the mailing list about some proposals for the formal methods working group. Give it a read, anybody who is interested. :) bandali and I came up with some pretty nifty ideas, especially relating to possibly making a subdomain https://fm.guix.gnu.org/
<brettgilio>The email might be needing approval nckx since I sent it from my gnu.org email address which I don't think has sent an email to the guix-devel mailing list before
<brettgilio>Nvm it got pushed through
***oxford is now known as cantstanya
<peanutbutterandc>So, I am using `pkg-config` and `guile` from guix. (gcc, etc. are from my foreign distro's package manager. Yes, I like to live on the edge. :D), and I'm trying to compile a program with <libguile.h> but it requires gmp.h, which I installed (via guix) but it fails me again. Any ideas, please? n00b here
<peanutbutterandc>gcc -Wall turtle.c `pkg-config --cflags --libs gmp guile-2.2` -o turtle
<peanutbutterandc>Code: https://termbin.com/9keh
<peanutbutterandc>while I'm at it, can someone also tell me how I could, if possible, link to my guix-profile's stdlibrary ( instead of -lm, perhaps some `pkg-config` magic) while compiling?
<str1ngs>peanutbutterandc: use gcc-toolchain
<peanutbutterandc>str1ngs, Sorry I am a n00b so I will need a bit more verbose instructions. gcc-toolchain as in guix-installed one? I was hoping to do it with the distro-supplied toolchain and link with guix-supplied libraries just to play around/have fun with it. Is it possible, please?
<str1ngs>peanutbutterandc: libm is part of glibc so it'd not advised to try and link the distro's libc. gcc-toolchain has it's spec file setup to link to the store etc. it's more sane in this case
<peanutbutterandc>str1ngs, I see. How about gmp? gmp isn't part of glibc, and I installed it with guix but I can't manage to compile the tutorial with <libguile.h> (which seems to require <gmp.h>
<str1ngs>peanutbutterandc: you can try with this guix environement --ad-hoc guile gmp gcc-toolchain pkg-config
<str1ngs>peanutbutterandc: gmp probably uses libm
<peanutbutterandc>str1ngs, I see. That seems like a great idea. I will try that too.
<peanutbutterandc>I've been using -lm (so essentially linking to distro supplied glibc) so far and it's been working
<str1ngs>peanutbutterandc: actually the tutorial uses libm #include <math.h>
<peanutbutterandc>str1ngs, Yes, it does. and [ gcc -Wall turtle.c `pkg-config --cflags --libs guile-2.2` -lm -o turtle ] works
<peanutbutterandc>-lm links to distro-supplied math libraray. pkg-config is guix-installed and so is guile-2.2
<peanutbutterandc>The command only throws 'gmp.h: no such file or directory' error
<str1ngs>you need pkg-config cflags for gmp as well
<str1ngs>I don't see where gmp is being used here though
<str1ngs>though possible glibc is
<str1ngs>but that doesnt sound right
<str1ngs>does my guix environement example work?
<peanutbutterandc>str1ngs, In libguile.h. When I put gmp in the pkg-config command, it complains about not finding libguile. Perhaps it is the positional arguments that I'm messing up?
<peanutbutterandc>It's getting the required packages
<str1ngs>not sure I alwasy use Makefile's for and set CFLAGS and LDFLAGS
<str1ngs>for these*
<peanutbutterandc>I am really new to C and it's eco-system. Just going through my beginner books (3-4 done) so I don't really know. I'm just poking/messing about at this point
<peanutbutterandc>Also, how would I do pkg-config for gmp. It doesn't seem that the name is gmp. `pkg-config --cflags --libs gmp` fails
<str1ngs>I don't think gmp has a gmp.pc per say
<str1ngs>you would need to set -I and -L manually
<str1ngs>which is probably not needed if you just use gcc-toolchain :P
<str1ngs>peanutbutterandc: see find $(guix build gmp) . no pc files
<str1ngs>general found in PREFIX/lib/pkgconfig
<peanutbutterandc>I see. So I probably should -I $GUIX_PROFILE/include and -L $GUIX_PROFILE/lib ?
<peanutbutterandc>This is fun!
<str1ngs>potentially that will work. but it probably safer to use a guix environment and use GUIX_ENVIRONMENT
<str1ngs>did I mention just use gcc-toolchains as well :) :P
<peanutbutterandc>str1ngs, I will remember those as well. I need to read up a bit more on guix environment. Thank you for the pointers. :)
<str1ngs>peanutbutterandc: no problem. and use a Makefile :P
<peanutbutterandc>str1ngs, I will try to read up on it, too. :D
<peanutbutterandc>for some reason -L $GUIX_PROFILE/lib -I $GUIX_PROFILE/include seems to OVERWRITE rather than extend the other locations and it seems to be unable to find glibc
<peanutbutterandc> https://termbin.com/mhmog
<peanutbutterandc>currently working with guix environment
<str1ngs>peanutbutterandc: yep, thats why you need to use gcc-toolchain so you don't mix glibc versions
<str1ngs>which is basically what those errors you are getting
<str1ngs>guix libguile is linked against a newer version of glibc
<peanutbutterandc>I see. That makes a lot of sense. I am currently trying with guix environment. Let's see how this goes.
<navik>guix documentation clearly needs *vi* user friendly prune of emacs references
<navik>%s/emacs/zile/g would suffice as a compromise
<bandali>motion denied
<navik>just a great way to start a day
<bandali>lol
<lispmacs>is there some special dependency type if an application expects to be able to call another application, but it is not required for building or linking?
<lispmacs>or is that something that should be a build dependency? I guess the configure script should be looking for its path...
<bandali>on a more serious note, what's wrong with emacs references if a good chunk of the developers and larger community around guix use emacs?
<bandali>replacing emacs with zile would help neither emacs or vi users, really
<lispmacs>what about the leafpad fanatics? are we just going to marginalize them?
<elais[m]>Yes
<navik>bandali: you wouldn't have *vi* community start wondering if they would need a fork
<bandali>navik, do people really consider forking an *entire distro* for using a certain editor in their running examples etc?
<navik>if we're going serious on note, of course not
<navik>but perhaps the documentation
<navik>or at least a filter which generates an alternative, hosted on a mirror
<bandali>i mean i personally use emacs, so am not aware of guix-related tool support in other editors
<navik>aha, so the distribution tools are kind of integrated with emacs?
<bandali>if e.g. there are vim plugins similar to emacs-guix (guix.el), by all means, feel free to submit a patch against the manual to add them
<bandali>more like the other way around: there are convenient guix-related tools written for emacs
<bandali>but yeah if you have specific suggestions for adding useful (neo)vi(m)-related info to the guix manual, feel free to write to guix-devel@
<bandali>or try bringing it up when more maintainers/commiters are around :)
<navik>I just did, which would be simple to implement for any vi-using guix-devel's
<navik>;)
<navik>Anyway, now is a good motivation to learn some Lisp/scheme - I'm grateful for this.
<bandali>hm, i don't think any developers and commiters around now, and by guix-devel@ i meant the guix-devel@gnu.org mailing list
<navik>perhaps I will eventually understand the charm of certain editors.
<bandali>amen ;)
<navik>org-mode had me on the hook for a while, but lost it's radiance after a while.
<navik>off topic. But thanks for the input bandali !
<bandali>cheers navik. Org is pretty great tbh, but yeah there's much more keeping me in emacs every day
<bandali>another killer thing for me is Gnus for email
<bandali>(i'm kind of notorious for talking about that here :p)
<str1ngs>don't forget magit :)
<navik>I have to say; actually neovim lacks a guile plugin host
<navik>but there's some work on one for common lisp
<navik>so don't be alarmed, there will be options :)
<bandali>str1ngs, yea :) even emacs's built-in vc-mode or cvs integration are super convenient, but yeah magit takes git integration to a whole other level
<brown121408>If I want to send a patch to add a package, do I need to also add a "Copyright © 2019 name email" line at the top of the file where I added the package?
<brown121408>Also, do I include only the package module file I wrote into or should I also add the po/ directory? Cause stuff changed inside there but I don't know how to handle it...
<leoprikler>unless you yourself touched the po/ directory it is fine
<leoprikler>the copyright line will be added for you if you don't do it
<raghav-gururajan>Hello Guix!
*raghav-gururajan feels refreshing when opens guix channel
<efraim>hello!
<brown121408>leoprikler: thanks. Sorry, I just want to be sure, so the po/ dir goes in or not if I didn't manually change anything inside?
<brown121408>Figured it out. I read other people's patches that just add packages and saw they don't include the po/ folder
<ng0>bandali: Gnus becomes terrible once you have terrible large inboxes (> 100.000 messages)
<ng0>but below it's good
<navik>this with e-mail - there ought to come something more viable
<navik>wohoo, guix compiled
<ng0>navik: idk, i just don't use an editor for reading and searching my emails. everyone does what works best for them.
<rekado>I’m trying to add a package for arm-none-eabi for version “7-2018-q2-update” as offered on https://developer.arm.com
<rekado>when building GCC (without glibc) the configure script tries and fails to find a file from the glibc.
<rekado>(it’s “gnu/stubs-32.h”, but I don’t think that matters)
<rekado>should it not avoid using glibc things? After all we’re building without a libc (at first) and later combine this with newlib.
*rekado tries building with gcc-5 as the host compiler to avoid problems with header locations
<slyfox>You probably need to pass --with-newlib to gcc to avoid glibc's headers
<gnutec>Can I only compile a C/C++ program with a gcc-toolchain installed, or I can use guix? How I run the program?
<snape>gnutec: you can (1) install gcc, (2) use 'guix environment' to be in a temporary environment in which gcc will be available and (3) make a Guix package
<snape>then when you install the package, things that are in /gnu/store/...-your-package/bin will be synlinked in ~/.guix-profile/bin, which is in $PATH, so that's how you'll run the program
<gnutec>snape: Ok! "guix install gcc-toolchain" is a command to install all this tool for program. https://en.wikipedia.org/wiki/GNU_toolchain
<gnutec>snape: I'm saying cause I did no about gcc-toolchain and guix install app from a source code. So I have this question.
<snape>indeed :)
<gnutec>I really think that we don't need C++. We can do anything with C. Just see Emacs.
<gnutec>But I'm not a hacker so
<leoprikler>For all its flaws, C++ does have some advantages over C that make it worth using.
<mehlon>so guix keeps complaining about glibc locales, "failed to install locales" on guix system
<bdju>seems like locale issues are very common, I wonder if the defaults could be improved or something
<mehlon>it seems guix can't install two things at once
<mehlon>that's strange, since nix can
<leoprikler>you can either rewrite your first command or use `guix build` for the second
<leoprikler>(and then `guix install` after the first has finished)
<mehlon>oh speaking of, what is the difference between guix package -i and guix install?
<leoprikler>none, the latter is an alias for the former
<mehlon>oh I see
<gnutec>bdju: look this https://unixpablo.blogspot.com/2019/10/guix-system-install-e-btrfs-segunda.html
<gnutec>leoprikler: But the question is if this advantages of C++ is necessary.
<mehlon>ah, I just updated icecat
<mehlon>but it still doesnt render numbers...
<leoprikler>I'd rather think of utility than necessity.
<leoprikler>Do you really need functional package management? Perhaps not, but is it useful? Oh yes.
<mehlon>honestly I nearly gave up on using gnu and linux until I discovered functional package management
<mehlon>it's just a real pain in the ass to install anything on debian-likes, and then having to configure them, and manage all the dotfiles etc
<gnutec>leoprikler: Yes! Is not about what a like. Guix was made with C++ and I think is the best. What I wanna know is the possible of create the same app with C programing language.
<navik>lol, got spanish `info guix`
<mehlon>oh hey navik, any progress with booting your librem?
<navik>mehlon: the progress is as follows; I've installed guix on the arch-system, so now I'm trying to recreate the release .iso first :)
<navik>but I ended up with only non-english translations of the info-pages.
<mehlon>oh haha
<navik>luckily, there's documentation onlie
<str1ngs>gnutec: are you talking about the C++ code in guix-daemon?
<navik>mehlon: I like the idea of using ansible for system management and git for the dotfiles. But, the promises the docs of guix are making kind of trumps all that.
<navik>there's simply no other options for me atm
<mehlon>I used to put my dotfiles in a git repository but nowadays I just use whatever the defaults are on any given system
<snape>navik: Guix System is way more powerful than Ansible
<snape>(first of all Ansible isn't reproducible at all)
<snape>(I used to manage my system configurations with Ansible before I discovered Guix)
<mehlon>oh I've only just heard of ansible
<navik>(then you started typing in parentheses?) :D
<snape>(yes haha)
<mehlon>it's the scheme virus
<navik>it has the potency of being idiotipotent (or whatever it's spelled), but rarely becomes due to how things actually works or how oneself manages to put things together.
<mehlon>idempotent :)
<navik>mehlon: there we go!
<navik>:D
<snape>what is 'it'? Ansible, or Guix?
<navik>ah ansible
<navik>I don't know much of this guix phenomenon, so that's why I joined this channel.
<mehlon>have you tried installing guix on top of whatever system you already have on your librem?
<mehlon>using the "binary installation procedure"
<navik>mehlon: nah, perhaps that would have been the best practical start
<snape>Well, with Ansible (+ a debian-like system), you'd throw 'apt install' commands to install, say, foo and bar. When later on you want to uninstall foo you can't
<navik>I guess I should try that.
<snape>with Guix you have a file representing your whole system, so when you want to uninstall some stuff, you'd just remove it from the file and re-apply the file
<bdju>gnutec: not sure if that ping was really meant for me, but I can't read that language
<mehlon>ah, we all need to learn spanish :)
<navik>snape: that's the selling point attracting me!
<mehlon>actually nevermind that was portuguese not spanish
<gnutec>str1ngs: The guix core is write in C++. But most is write in Guile. /etc/config.scm is a Guile code.
<gnutec>bdju: Just follow the commands. I did have problems with "locales" after install guix system. Run the 4 follow commands, without any reboot into the end.
<gnutec>bdju: Sometimes, guix has problems with upgrades (guix system reconfigure) but you just need wait until they developers fix it.
<grillon>hi there!
<grillon>hi bandali
<mehlon>icecat now correctly renders numbers after installing the gnome desktop environment
<grillon>just to let you know guixSD is working on asus chromebook c423NA boot was hanging because of the SD card. it was too slow.
<grillon>on USB3 key it's just fine
<mehlon>I spoke too soon... only the URL bar renders numbers now
<grillon>question: is it normal when I do guix reconfigure it's using root profile?
<grillon>in the after install section I have read it's suppose to use user profile...
<grillon>ok I see I have to do a sudo -E guix system reconfigure and not a direct sudo
<gnutec>grillon: Is there you bdju?
<leoprikler>sudo without -E uses your guix while thinking it's root's
<grillon>no it's not gnutec
<grillon>yes that's what I want leoprikler
<grillon>leoprikler: is that wrong?
<leoprikler>not really, it's just confusing guix itself if you haven't pulled as root at least once
<grillon>so I need to pull root once?
<leoprikler>either that or sudo -E, whichever you prefer
<gnutec>grillon: I always use sudo -E. In guix I have to. "sudo -E gparted"
<leoprikler>(I think the consensus here is stronger towards sudo -E, but pick your poison.)
<leoprikler>Does gparted not support pkexec?
<grillon>ok I see
<gnutec>leoprikler: I don't know what it is (pkexec).
<leoprikler>the polkit equivalent to sudo
<gnutec>leoprikler: "pkexec gparted" return "Authentication is needed to run `/home/pablo/.guix-profile/bin/gparted' as the super user"
<leoprikler>apparently not, then
<bdju>gnutec: someone else was having the locales issue and I just commented on it
<bandali>hey grillon, cool, thanks for letting me know!
<grillon>bandali: :)
<grillon>brb
<str1ngs>gnutec: I'm aware of that. I was seeking clarification as to what you meant by C++. either most of that code comes from nix. and it's really not all that pretty
<str1ngs>either way*
<str1ngs>gnutec: but to answer your question yes, you could rewrite it in C. but that might not make sense since it's possible code is still tracked from nix
<gnutec>str1ngs: https://en.wikipedia.org/wiki/GNU_Guix
<grillon>is it possible to declare uuid for bootloader target instead of a device special file?
<str1ngs>grillon: you can use uuid instead of file-system-label
<str1ngs>grillon: see http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system/examples/desktop.tmpl#n40 for example
<grillon>thank you str1ngs
<grillon>I mean for bootloader part. I have (bootloader(bootloader grub-bootloader)(target "/dev/sda")) and I would like to replace /dev/sda by uuid
<grillon>in your example you have /boot/efi
<str1ngs>grillon: are you using EFI?
<grillon>no I'm not
<grillon>it's a seabios
<str1ngs>vm then?
<grillon>no physical machine
<grillon>a chromebook
<str1ngs>I was going to mention this. in the example case of EFI the uuid is implied based on the mount point
<str1ngs>but for bios grub I'm not sure if you can use uuid sorry. maybe someone else has experience with this grillon
<str1ngs>grillon: you could try this though /dev/disk/by-uuid/3C84-EAB4
<grillon>no problem:) I know grub can, but I don't know how to express it
<str1ngs>actually those are partitions. block devices don't have UUID's per say
<str1ngs>grillon: see if your device has a UUID with sudo lsblk -f
<grillon>I have seen grub use search-fs uuid instead of hdx or sda
<str1ngs>but in this case I doubt it will have a UUID
<grillon>file-systems part use uuid to mount /
<grillon>grub use the uuid to search fs
<grillon>but when I want to update grub via guix system reconfigure it use /dev/sda
<grillon>I think /dev/disk/by-uuid should work
<grillon>let's try
<str1ngs>grillon: you can maybe use /dev/disk/by-id/<ID>
<str1ngs>but that is technically not UUID and probably not much better then /dev/sda
<str1ngs>grillon: /dev/disk/by-uuid wont work. that only works for partitions. it was a bad suggestion on my part. no pun :P
<gnutec>grillon: Ubuntu has some problems with EFI, Trisquel has too. But Guix System has no problem with EFI installation, we just need to know how to create a new partition table using the gnu parted of guix instalation. I use the gparted of Trisquel, then I install guix system.
<grillon>str1ngs: I see /dev/sda is the whole disk indeed
<grillon>it's not a big deal, I have just seen that when I have a usb key that could change, so I have to be careful when I do a reconfigure
<grillon>gnutec: it's not really EFI, it's seabios. I don't know details...Is it a seabios launch by EFI or a real seabios. I have to verify. there are a chromebook page first telling me I'm in developper mode. Then I choose to boot on device with ctrl + L and it start seabios
<str1ngs>grillon: it's not ideal if the block device changes I agree. EFI is better in this regards if you have the option
<grillon>then seabios detect devices and I select my USB key with grub and grub boot guixSD :)
<alextee[m]>when you import an exported archive, does it also install its dependencies?
<alextee[m]>also, what's this? guix archive: error: getting status of `/etc/guix/signing-key.sec': No such file or directory
<alextee[m]>oh --generate-key
<alextee[m]>so i have a 4MB .nar file without the --recursive option, if i were to install this on another machine i would need to manually install the dependencies right?
<str1ngs>alextee[m]: if you use -r when export it should do dependencies aswell
<alextee[m]>str1ngs: that results in a > 1.5 GB file
<alextee[m]>i'm looking to something equivalent of a binary .deb or .rpm
<str1ngs>that sounds about right
<alextee[m]>looking for *
<alextee[m]>ok cool thanks :-)
<str1ngs>I tend to do guix archive --export -r package | ssh remote guix archive --import
<str1ngs>but you need to need to import your public key onto the remote host
<str1ngs>authorize is a better term. alextee[m] ^
<alextee[m]>oh
<alextee[m]>im trying to basically create a binary installer to sell
<alextee[m]>so i would export without the -r (to avoid humongous file size), and when installing i would first need to authorize my public key and then install the dependencies and then guix archive --import right?
<alextee[m]>^ in my installer shell script
<str1ngs>sounds about right, though build the package after import should install the dependencies as needed
<str1ngs>not sure if you can import without the depends
<str1ngs>I find -r is just more useful
<alextee[m]>i see, i'll try it
<alextee[m]>maybe there should be some kind of package definition for installing .nar archives this way? similarly to how .deb and .rpm binary packages mention their dependencies
<alextee[m]>or maybe it's not very guixy
<str1ngs>alextee[m]: you probably want guix pack
<alextee[m]>that's still huge
<alextee[m]>> 1.5gb
<alextee[m]>i can't distribute that
<str1ngs>well you can't avoid the dependencies
<alextee[m]>yeah so just install them in the script with guix install
<ng0>alextee[m]: have you looked at how rhodecode handles it?
<ng0>it's still big though
<ng0>using nix, not guix
<alextee[m]>it's 250mb
<alextee[m]>i'm looking for something that would only include my own files without dependencies that can be installed with guix
<alextee[m]>(target platform is guix only so no need to add another glib/gtk, chances are the user already has them installed)
<grillon>good night, see you folks
<navik>hm, it smells misconception here on my part; I issue the command available in the docs for creating a USB boot ISO, but get the message "guix system: error: failed to load 'test.scm': No such file or directory
<navik>even though test.scm is in the working directory
<navik>`guix system disk-image --file-system-type=iso9660 test.scm`
<mehlon>try absolute path?
<navik>same thing
<mehlon>-v flag?
<bandali>mehlon, re fonts in icecat, try installing some font packages via guix, that should help properly render characters
<mehlon>it may be any of these: the file has wrong permissions, is not readable, has a syntax error, or there's not enough space on the hard drive, or guix is misconfigured
<navik>ah, might be not enough space, permissions, or misconfiguration. I'll start checking.
<navik>I saw it was running on my user with guile; but is it expected to invoke the guix system daemon for such operations? I.e. remastering the installation iso
<mehlon>"file not found" can also be a cryptic reference to an executable that's missing libraries
<navik>ok, so `-v` didn't work in any way I tried. Did you mean `--version` or is there some way to increase verbosity?
<mehlon>--verbosity=100
<mehlon>not sure what the upper limit is
<mehlon>but it helps to get plenty of verbosity
<mehlon>by the way, gnunet just got updated to 0.12.0, can someone update the guix package?
<navik>mehlon: would love to get it more verbose, but it gives no further output than "No such file or directory", for any verbosity level I've tried so far (1,2,3,10,100,1000,10000,100000)
<navik>how much space am I expected to need for remastering the system installation ISO?
<mehlon>try without the --file-system-type flag? try a dummy scheme file?
<mehlon>maybe just an empty file or sth
<navik>any links to example dummy scheme file?
<navik>ok
<mehlon>just make an empty file, that should help pinpoint the origin of the error
<mehlon>so you are currently running guix on pureOS, right?
<navik>mehlon: it is actually reading the `.scm`, since with a filepath that does not exists, it exits immediately, and the fans are not going up (CPU usage)
<navik>when running on the .scm from gnu/system/install.scm, it does get fans crazy for a while
<navik>and running or something broken, gives an error message on the syntax.
<mehlon>I see, so there's a chance you have a broken library dependency
<navik>mehlon: I would bet it is, I just used the stock AUR build pkgfile (archlinux), so I will probably have to use a different approach.
<navik>at least, I'll try freeing up even more space and see what happens before moving on to another build.
<mehlon>what does `ldd guix` show?
<mehlon>actually, I'm not 100% sure if that would even work...
<navik>no, `which guix` gives /usr/bin/guix, which turns out to be a guile script
<navik>It might be that the build I have is some specialty thing that actually not intended to work the standard way. I'll use the tarball method and see what I get next time.
<navik>I was just happy enough that there was a community package, I haven't checked if it's gimped in any way. :)
<navik>mehlon: thanks for the input anyways
<valignatev>Hello! Seems like recursive import from crates.io is broken: https://imgur.com/zyTEfd7
<valignatev>Reported: https://issues.guix.gnu.org/issue/38709
<mehlon>is there an equivalent of cachix for rolling a custom cache that I can share with others on guix?
<leoprikler>`guix publish`?
<nckx>mehlon: I'm not familiar with Cachix, but it sounds like Nix's answer to ‘guix publish’, which many people use to run their own substitute server. However, we don't offer hosting peeps' random substitutes as a service (HPRSaaS) like Cachix seems to do.
<nckx>No plans to do so either.
<leoprikler>s/HPRSaaS/HRPSaaS/
<leoprikler>or wait, no
<leoprikler>ahh
<nckx>Hacker Public Radio Something as a Service.
<snape>navik: about your 'guix system' error, what does 'guix describe' return?
<mehlon>Hosting Random People's Services as a Software Substitute...s
<nckx>Actually, it would be literally hosting software substitutes as a service.
<leoprikler>let's abbreviate it to HRSaaS
<mehlon>nckx: mind blown
<nckx>ikr
<mehlon>maybe I can ask cachix nicely if they could host cachix.... and call it gachix
<nckx>Guache.
<mehlon>host guix packages on* cachix
<nckx>mehlon: That would be nice 🙂
<snape>Gâchis (https://www.wordreference.com/fren/g%c3%a2chis)
<nckx>(And sorry but French puns are really mandatory & vital to the project.)
<mehlon>Guache Unifies Amazing Caching and Hosting for Everyone
<nckx>snape: You know that's going to be called ‘that… hashish… thing’ by non-francophones everywhere.
<leoprikler>would not be wrong tho
<snape>:D
<snape>navik: also, the Arch way of installing Guix isn't really the recommended way
<snape>it's even said in the Arch wiki... which actually proves the high quality of this wiki
<mehlon>gotta love the arch wiki.. I use it while on any distro
<mehlon> https://github.com/cachix/cachix/issues/85 guix support has some interest
*nckx slacktivistically adds their 👍
<mehlon>oh ... I thought slack as in the chat thing
<mehlon>and there I was wondering what slack had to do with it
<nckx>So Cachix has a business model & everything. That's great and I really hope it works out for Domen but it seems like a high premium for guix publish + DNS record + {cheap VPS,home server}.
<nckx>I'm probably missing some killer feature.
<mehlon>hmm.. it doesnt look like the cachix server is itself open source?
<snape>:/
<nckx>lispmacs: Did you ever get to print anything?
<snape>mehlon: cachix client isn't a free software either
<mehlon>ah....
*snape is glad he didn't 👍 cachix ;)
<mehlon>this is so sad alexa play despacito.... oh wait
<mehlon>there were plans to host on IPFS for both nix and guix as well
<mehlon>some peer to peer solution would be very nice for saving cpu time
<snape>Well cachix doesn't seem to be a software business (the software is probably 99% implemented in Guix publish). Rather it's a storage business
<nckx>snape: I didn't 👍 them, I 👍d Guix support 😛 I didn't realise the client was non-free, though. That's just weird.
<mehlon>the client doesnt specify any license. the backend does have a EULA
<snape>nckx: :) I was just teasing you - it's strange indeed
<snape>mehlon: yeah, no license == non-free
<mehlon>well after some initial problems I'd say guix is pretty usable now
<mehlon>although icecat still has problems gnome's web browser works just fine
<nckx>mehlon: Is that wat previously was known as Epiphany?
<mehlon>I think it's still called epiphany, but GNOME likes to use noob-friendly names
<mehlon>Nautilus is "Files", Epiphany is "Web"
<nckx>Right. It just used to be rather broken, glad it's not.
<nckx>And simple-scan has become Document Scanner, which is pushing the limits of trivial changes for change's sake.
<mehlon>so all issues/pull requests on gnu happens via emails?
<nckx>mehlon: We don't do pull requests but yes.
<nckx>Patches & bugs are both handled through mail.
<mehlon>interesting
<nckx>Linux-style.
<mehlon>I'm used to the github lifestyle
<stikonas>mehlon: it's not really that different... You still clone repo, make a commit, only instead of going to web browser and clicking a button, you run git send-email. And then you can reply to your email thread, instead of reply in a webbrowser (although, you can also reply via email on github)
<mehlon>ah. I still only have my gmail
<mehlon>should probably get a disroot account or something
<nckx>mehlon: You can set up git send-email to use Gmail. Or used to, anyway.
<mehlon>(and before anyone tries to tell me: I am *not* going to run my own email server!)
<mehlon>how long does gnu keep irc logs?
<nckx>mehlon: There is no policy, just failing drives. (™)
<nckx>mehlon: We host our own logs on the same server that handles CI, it's not a GNU thing.
<mehlon>I see
<nckx>mehlon: Running your own mail server doesn't make git easier, chillax 🙂 It's user-unfriendly either way, as we know & love.
<mehlon>I was in an irc chat and someone was talking about how running your own mail server is totally easy and cheap and you should just do it
<mehlon>but like... no....
<nckx>mehlon: …you should though.
<nckx>😛
<mehlon>is that emoji
<nckx>That is emoji for : - p
<mehlon>:-p :) :3 :o
<mehlon>ah, of course hexchat does not do that
*nckx uses HexChat.
<nckx>You should run your own e-mail server if: you're the kind of person who thinks ‘ooh, running my own e-mail server sounds fun!’. In all other cases: you should not run your own e-mail server.
<mehlon>well it sounds just a little fun, just a teensy bit
<bandali>it's not *as* bad as people make it sound like it is :)
<bandali>but not exactly easy either
<jetomit>spoiler alert: it's mostly just boring :)
<nckx>It's mainly dealing with other people's broken stuff because turns out you're not that important and — spoiler — so are standards, apparently.
<nckx>You can be correct or you can have your mails arrive.
<mehlon>I once tried using the social engineering toolkit from kali linux with a free email server thingy
<mehlon>amazingly they shut me down within 30 seconds of sending a fake email to myself
<mehlon>that's hardly enough time to phish myself
<nckx>My e-mail server is on a blacklist because I also run a (completely unrelated, *non-exit*) Tor node on a related machine.
<nckx>That's a very stupid blacklist used by very stupid people, but it's still something *I* need to deal with ☹
<mehlon>I'm interested in that secushare.org thing
<nckx>Yay, it uses GNUnet.
<mehlon>yeah that's why I've been tinkering with gnunet on nix and guix as well
<mehlon>there was an android app that lets you run Nix in android userspace. I wonder if guix could work like that as well
<nckx>mehlon: Nix-on-Droid?
<mehlon>yes
*nckx reads https://nix-on-droid.unboiled.info/nixcon-2019-nix-on-droid.slides.pdf
<jonsger>nckx: http://guix.gnu.org/blog/2018/guix-on-android/ sounds less complicated
<mehlon>eh I suppose I'll... open a github issue
<mehlon>jonsger: that requires root and is hard to reverse
<jonsger>mehlon: the guix one?
<mehlon>yea
<nckx>So why is Android, presumably an operating system, a thing designed to run software, so legendarily bad at actually running software?
*nckx , afrter reading their 100th ‘attempting to run any software on Android: an autopsy’ article.
<mehlon>I dunno, java?
<nckx>But installing guix is literally ‘sudo tar xf && done’.
<nckx>I assume that Android, being vaguely based on Linux(?), has both.
<nckx>No?
<mehlon>It's not entirely clear
*nckx first used Android a month ago and failed so is clueless af.
<nckx>But seems like it's very much in need of liberation & user empowerment.
<mehlon>SELinux is part of it: and you can't just install stuff because the system is made to clean itself after every boot
<nckx>Huh.
<mehlon>for instance if you put something in /sbin it will be gone after the next boot
<nckx>mehlon: I didn't realise that, thank you.
<nckx>How do you store a thing?
<mehlon>in the guix on android article it explains the partitioning of the disk
<mehlon>boot partition, recovery, data (apps!), system (OS), vendor pre-installed stuff, etc
<mehlon>data is where you put your apps, and these apps do not pollute /bin or /sbin or /usr/bin or any of that stuff
<nckx>I read that, but it's a bit sparse on details (as well it should be — that's not its focus). I understand the notion of a volatile+read-only (union?) /, just not why you can't ‘ln -s /storage/gnu /gnu’ at startup, so to speak.
<nckx>* /data
<nckx>Eh, I'll read up.
<mehlon>it's an initramfs
<nckx>Yes. These are writable.
<mehlon>that is true, you can re-flash the boot partition for this
<mehlon>i'm sure there's some way to run things on bootup but I dont know which
<nckx>The article doesn't go into that, so it ends rather abruptly (for an outsider) with ‘enjoy your precarious stateful Guix!’.
<nckx>I'm sure there's a good reason, like it being horribly device-specific to actually make it stick across reboots.
<mehlon> https://github.com/t184256/nix-on-droid-bootstrap/issues/30
<mehlon>it could probably be done but I'll hold off on it for now since I don't have a particular need for it
<pkill9>i would like that for guix
<pkill9>does it run X applications?
<nckx>That's one fast response.
<mehlon>does Nix on droid run X applications?
<mehlon>if you want X apps on android you'll need to use a VNC server
<pkill9>nix on droid yea
<mehlon>you can install xterm and open X to vnc and use a separate VNC app on android
<mehlon> https://wiki.termux.com/wiki/Graphical_Environment
<mehlon>there's also the possibility of running it on UserLAnd https://userland.tech/
<mehlon>(but not yet, they don't support custom distros)
<mehlon>also note the great "Use Linux Anywhere" slogan. really makes you think
<nckx>wat
<mehlon>its a joke
<mehlon>it's one of those "uses the word linux even though it has nothing to do with the linux kernel" instances that the gnu.org talks about
<mehlon>sorry it was stupid anyway
<nckx>mehlon: I got ya. I was reacting to that.
<mehlon>ah right
<mehlon>:P
<d10n-work>I haven't looked at fixing this problem yet but in case anyone thinks the problem is interesting I'll describe it here:
<d10n-work>I have guix installed on CentOS 7, and my terminal of choice is Terminator, installed from Guix. I want to use the AWS SAM tool, which their docs suggest to install from Linuxbrew. When I try to run sam commands, I get "Fatal Python error: initsite: Failed to import the site module".
<d10n-work>It turns out that the guix terminator wrappers export python environment variables including PYTHONPATH. This is inherited by zsh and then sam. When unsetting PYTHONPATH in zsh, sam works as expected.
<mehlon>alright gotta go
<mehlon>au revoir
<d10n-work>I see my problem is so boring that it has already started to destroy this community (joke)
<nckx>d10n-work: TBH I don't know half the words in your description (who is Sam and what's he brewing) but: is the problem that Guix's terminator (re)sets PYTHONPATH when it should just append to it? Or would that not solve your problem?
<d10n-work>nckx: I think the best solution might be if the terminator wrapper were to instead be a Python program that just internally sets sys.path instead of exporting an environment variable that gets leaked to all child processes
<nckx>d10n-work: That would definitely be ideal.