IRC channel logs

2019-11-22.log

back to list of logs

<sirgazil>It seems that DrRacket 7.3 has a memory leak. When I click the Run button, even with simple, less than 50 lines of code programs, RAM usage grows ~100 MiB. Eventually, I have to restart DrRacket because the computer runs out of RAM.
<Blackbeard[m]>sirgazil: you can use emacs
<Blackbeard[m]>Racket-mode is nice
<sirgazil>Blackbeard[m]: Yeah, I know, I use Emacs :)
<Blackbeard[m]>sirgazil: ahh :)
***jje is now known as Guest13469
***Guest13469 is now known as jje`
***jje` is now known as jje
<ScaredySquirrel>hi guys
<ScaredySquirrel>hi guys
<ScaredySquirrel>what is wrong with my config.scm?
<ScaredySquirrel> http://dpaste.com/2YDW47D
<atw>I'm having some issues with certbot-service-type. Here's my operating-system https://paste.debian.net/1117366/, letsencrypt.log https://paste.debian.net/1117367/, and the Let's Debug output https://letsdebug.net/atw.name/79946?debug=y (ignore the error about IPv6, I think the 404 under "show verbose information" is more important). What I'm doing is running /gnu/store/...-certbot-command as root. I don't have hard evidence but I think
<atw>that the file under /var/www to respond to the challenge isn't getting created
<atw>ScaredySquirrel: is there an error that you get when you pass that config.scm to "guix system ..."?
***jonsger1 is now known as jonsger
<ScaredySquirrel>atw: absolutely
<ScaredySquirrel>line 67, column 1: missing closing parenthesis
<atw>ScaredySquirrel: by my count, there should be two more closeing parentheses at the end of the file
<ScaredySquirrel>ok done that now let me see it doesn't work
<ScaredySquirrel>it complains about gnu/services.scm:739:27: In procedure struct_vtable: Wrong type argument in position 1 (expecting struct): ...
<ScaredySquirrel>sorry my internet is down every fun time
<atw>hmm is there a backtrace?
<ScaredySquirrel>that was part of it
<ScaredySquirrel> http://dpaste.com/39JP35X
<ScaredySquirrel>there's the backtrace
<ScaredySquirrel>and how would you just say at the command line I wanna install this software for all users?
<atw>unfortunately I can't say I understand that, but I do have a guess: is it valid to use set-xorg-configuration where you're using it?
<atw>it might be, it might not be, I'm honestly not sure
<ScaredySquirrel>um no it's not
<ScaredySquirrel>where do I put openssh-configuration and set-xorg-configuration?
<ScaredySquirrel>are you still there mister atw?
<ScaredySquirrel>atw: are you there?
<ScaredySquirrel> http://dpaste.com/39JP35X
<ScaredySquirrel>oh, wait
<ScaredySquirrel>we need to figure out what independent sections to put openssh-configuration and xorg-configuration
***raghavgururajan is now known as RaghavGururajan
***RaghavGururajan is now known as raghavgururajan
<ScaredySquirrel>a little help please?
<atw>hi ScaredySquirrel, I'll be back in a second
<PotentialUser-89>I've been a Parabola user for years and I recently decided to try Guix. Everything was working fine, until I upgraded the system... now GDM keeps crashing on startup but the logs look ok.
<PotentialUser-89>I tried installing lightdm but it fails to compile.
<jackhill>PotentialUser-89: you might try manually removing /var/log/gdm
<jackhill>there have been reports of probably with stale state there, but it has been difficult to reproduce, and it's not clear what the solution is (and why it seems to affect Guix more than other distros)
<PotentialUser-89>Unfortunately it didn't work.
<ScaredySquirrel>hi
<PotentialUser-89>If I remember correctly, I had a similar problem with Gnome 3.30 on Parabola last year.
<ScaredySquirrel>oh hi
<atw>hello, I'm back too. I don't understand what you mean by independent sections, but I think openssh-service-type looks fine. Could you temporarily get rid of (set-xorg-configuration ...), just to see if that lets us get through the "guix system ..." command without any errors?
<ScaredySquirrel>ok sure
<ScaredySquirrel>I did that and it still fails
<ScaredySquirrel>same error same
<jackhill>PotentialUser-89: hmmm, well I'm one of the people that didn't get the gdm bug, so I'm not quite sure what to suggest.
<jackhill>there is also sddm and slim to try. Also, potentially ask at help-gux@gnu.org. I know some of the people who've worked on gdm are in Europe, so may be asleep now.
<PotentialUser-89>ok thank you. I might try sddm.
<atw>sorry ScaredySquirrel, I'm struggling here. I do have another idea, though. I think it should be like (append (list ...) %base-services) which is slightly different from what I told you before
<atw>let me know if that makes sense
<atw>actually, wait, I'll just paste what I have...
<atw> https://paste.debian.net/1117383/
<ScaredySquirrel>oh
<ScaredySquirrel>oh lol here we go!
<atw>:O
<ScaredySquirrel>your paste is the one that works
<ScaredySquirrel>ok so where's gnome?
<atw>the config.scm has xfce in it and not gnome, so I wouldn't expect to see gnome
<ScaredySquirrel>well I just added it in there
<atw>aha. btw the first config.scm you posted, was it straight from the graphical installer?
<ScaredySquirrel>well sure
<ScaredySquirrel>then I modified it myself with some instruction on the gnu guix main website
<ScaredySquirrel>I need a few more things to be modified
<ScaredySquirrel>my laptop auto suspends after I am barely in gdm
<ScaredySquirrel>let's start over
<atw>huh that's weird
<ScaredySquirrel>it auto suspends when I switch back to gdm
<atw>have you seen https://guix.gnu.org/manual/en/html_node/Using-the-Configuration-System.html#Using-the-Configuration-System? It's got some example configurations that you can steal from
<ScaredySquirrel>ok well how do i configure sudo with just scheme?
<ScaredySquirrel>I wanna tell it %wheel ALL: NOPASSWD: ALL
<atw> https://guix.gnu.org/manual/en/html_node/operating_002dsystem-Reference.html#operating_002dsystem-Reference talks about operating-system's sudoers-file, which I think can do that
<ScaredySquirrel>I don't know how to use local-file or plain-file
<atw>I think add (use-modules (guix gexp)) at the top and add (sudoers-file (plain-file "sudoers" "%wheel ALL: NOPASSWD: ALL")) in the (operating-system ...)
<xvilka>Hi! How to report a bug for upgrading the ocaml package? current one is 4.07.1, while the mainstream has 4.09.0 with many important changes and improvements, also other distributions caught up: https://repology.org/project/ocaml/versions
<PurpleSym>Hello guix!
***conceivably1 is now known as conceivably
<Blackbeard[m]>PurpleSym: :D
<Blackbeard[m]>٩(◕‿◕。)۶
<PurpleSym>Blackbeard[m]: Hm?
<Blackbeard[m]>PurpleSym: I was saying hi back
<roptat>hi guix!
<PurpleSym>Oh, hey there, Blackbeard[m] :)
<Franciman>Hi
<Franciman>Do you know how I can view videos using mp4 codec on icecat?
<Blackbeard[m]>Franciman: I always use mpv :)
<Franciman>thanks
<Franciman>I wanted to watch a video on twitch
<Franciman>do you have any tip?
<Franciman>I know about youtube-dl for youtube vids
<roptat>doesn't youtube-dl work for twitch?
<roptat>I'm also having troubles with mp4 videos on the web... All I can do is use an old icecat 60 when youtube-dl doesn't work :/
<Franciman>roptat, it's quite unexpected that youtube-dl works for twitch!
<Franciman>but it does
<Franciman>cool!
<roptat>yay, youtube-dl is not only for youtube, it works on many websites
<roptat>but it'd be better to find why mp4 doesn't work on icecat and fix it
<zimoun`>rockandska: hi! nice!
<Franciman>roptat, thanks for fixing the bug
<Franciman>the hexchat bug
<roptat>yw :)
<civodul>Hello Guix!
<civodul>nckx: looks like your OverDrives are down, could you take a look?
<civodul>libseccomp fails to build on aarch64: 15-basic-resolver.c:58:46: error: ‘__NR_open’ undeclared
<civodul>i'm trying to import https://ctan.org/pkg/translator but apparently it's not in the texlive repo: https://tug.org/svn/texlive/trunk/Master/texmf-dist/source/
<civodul>does anyone know where i should take it from?
***jonsger1 is now known as jonsger
<nckx>civodul: They're both up, but idle.
<BryanHonof>Hello, is this the channel to ask questions about guix? :)
<nckx>BryanHonof: It is!
<BryanHonof>Okay sorry for just going straight into it. I am trying out guix but I constantly get this weird warning and I am not sure if it is harmful. The warnings always looks something like this: "/(path)/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.utf8).
<BryanHonof>I already googled a little bit and tried installing both glibc-utf8-locales and en_US.utf8 but the warnings still pop up
<BryanHonof>I am running an Arch x86_64 box and installed guix via the installer script.
<nckx>BryanHonof: First off, don't worry, it's ugly but harmless. I'm not of much help with Guix on other distributions, though.
<nckx>BryanHonof: What does ‘echo $GUIX_LOCPATH’ say?
<BryanHonof>@nckx /home/bryan/.guix-profile/lib/locale’
<BryanHonof>Without the tailing ', copy pasted wrong sorry.
<nckx>That looks OK. I suspect its the Guix daemon printing this message.
<nckx>Looking at the .service file, I think you should run ‘sudo -i guix pull’ to update root's current-guix profile, which provides guix-daemon.
<nckx>Then ’systemctl restart guix-daemon’ and pray.
<BryanHonof>OK, I will try doing that. Will report back in a few.
<nckx>BryanHonof: I have to leave, but good luck. You can always e-mail <help-guix at gnu.org> if nobody here can help you. Good luck!
<roptat>ah iirc there's a bug in the service file for 1.0.1
<nckx>That's a bit much luck, you probably won't need that much.
<roptat>I think there's a misplaced ' on the Environment line of the service file
<roptat>it should be 'GUIX_LOCPATH=/var/.../locale' LC_ALL=en_US.utf8
<roptat>not GUIX_LOCPATH='/var/.../locale' LC_ALL=en_US.utf8
<BryanHonof>nckx I think it fixed it
<BryanHonof>Updating the guix install on root and restarting the service
<BryanHonof>I do no longer see the mesages thanks ^.^
<roptat>oh, cool then :)
<kmicu>ヽ(*^▽^)/ new emacs-guix release! Thank you Alex!
<paprika>hi all
<paprika>how do i set a specific kernel parameter when booting
<paprika>iomem=relaxed
<paprika>I need to do this in order to internally flash libreboot
<paprika>I can't simply edit /etc/default/grub
<paprika>like I'm used to
***avocado is now known as Guest63897
***Guest63897 is now known as paprika
<paprika>anyone?
<roptat>paprika, on the guix system?
<paprika>yes
<roptat>have you seen kernel-arguments in https://guix.gnu.org/manual/en/html_node/operating_002dsystem-Reference.html#operating_002dsystem-Reference
<paprika>thanks for that roptat
<paprika>I coud edit grub at boot
<paprika>which is actually all I need
<ng0>can we filter "Guix violates the GFSDG" emails? this discussion is getting tired, popping up at least once a year by someone who has enough time to come with yet another theory why this violates the guidelines and we should be removed
<ng0>or at least mention somewhere in the documentation why it does not violate the guidelines
<bandali>i don't think that's a good idea
<ng0>i was exagerating.
<ng0>but by now we have enough material to write a section on why it doesn't violate the guidelines
<bandali>sure. that will give others something concrete to point to and argue for/against
<ng0>it always seems like low level trolling
<bandali>fwiw, some of the raised concerns are valid, and afaik people are waiting to hear from rms and/or the fsf licensing staff about some of the raised concerns
<bandali>i assure you it's not trolling; those people genuinely care
<ng0>especially when a bunch of mailinglists are CC'd + rms
<ng0>mkay
<ng0>interesting, as it doesn't differ from the concerns raised in the years before
<bandali>i haven't seen those ones and idk what they are, i should probably dig up the archives
<ng0>tbh it's been very long since I've read the guidelines. either they are very vague or guix is really such a special case that enough people get confused regularly
<bandali>yeah, part of the concern is that there is some vagueness
<bandali>and guix is different in some aspects from your typical more mainstream gnu/linux distros
<bandali>one such concern is whether it's okay to do the liberating of upstream sources on the user's machine as guix does, or if that must be done on guix's infra and the end user normally only fetch the cleaned/liberated sources
<bavier1>part of the vagueness come from the nature of being "guidelines"; enumerating specific cases does no good
***bavier1 is now known as bavier
<ng0>I've written an excuse to my reply. personally i have a more specific dislike of guidelines vs technical driven decisions with regards to build-systems. i hope i won't have to go into detail about this too soon or ever. but this is outside of Guix.
<zig>guile 2.9.5 was release a moment ago, does any one plan to update `guile-next` package definition?
<zig>I can give it a try...
<dutchie>i can't build master at the moment: https://paste.sr.ht/%7Ejshholland/7cd296fe8edf368078d91a0a3758c6fe10cd9532
<bavier>dutchie: try `make clean-go` first
<bavier>that's what the 'record-abit-mismatch-error' is about
<bavier>s/abit/abi
<dutchie>that seems to done the trick
<dutchie>yep, built successfully, thanks bavier
<bavier>dutchie: np, good luck
<pkill9>In Guix System, is it possible to set capslock to ctrl in the virtual TTYs?
<rockandska>Hi guix
<civodul>hello!
<sneek>Welcome back civodul, you have 1 message.
<sneek>civodul, nckx says: They're both up (‘up 106 days’, I should probably update the kernel :-), but idle. Could this be a problem on berlin's end?
<civodul>pkill9: there's an example at https://guix.gnu.org/manual/devel/en/html_node/Keyboard-Layout.html that does exactly that :-)
<nckx>civodul: Still idle.
<rockandska>civodul: Hi ludovic, fine ?
<nckx>civodul: Can you SSH into them from your place and/or berlin?
<rockandska>Just in case, does anyone had the time to take a look at why `guix pull` change the symlink `/root/.config/guix/current` and is maybe the reason why `guix gc` is not able to clean old guix revision ?
<civodul>nckx: it must have been on berlin!
<civodul>i've restarted the tunnels now and it seems to be all right
<civodul>thanks for checking!
<nckx>civodul: Any time 🙂
<nckx>Dmitri is already building Mate.
<civodul>good :-)
<ScaredySquirrel>hi guys
<ScaredySquirrel>why doesn't xinit work at all? As my Xorg server starts it says that during parse_vt_settings while accessing /dev/tty0 it can't with Permission denied
<ScaredySquirrel>and I'm building ungoogled-chromium-wayland and the system won't stop thrashing the swap
<atw>I'm having some issues with certbot-service-type. Here's my operating-system https://paste.debian.net/1117366/, letsencrypt.log https://paste.debian.net/1117367/, and the Let's Debug output https://letsdebug.net/atw.name/79946?debug=y (ignore the error about IPv6, I think the 404 under "show verbose information" is more important). What I'm doing is running /gnu/store/...-certbot-command as root. I don't have hard evidence but I think
<atw>that the file under /var/www to respond to the challenge isn't getting created
<nckx>ScaredySquirrel: Because Guix doesn't support running X as a regular user.
<ScaredySquirrel>my laptop only has 4GB of RAM
<nckx>ScaredySquirrel: And because you have too little RAM to build U-C.
<ScaredySquirrel>err...how much ram can I put in this thing? mom doesn't want me opening my laptop
<ScaredySquirrel>when you open a laptop how can you work inside of them without breaking the machine?
<nckx>You'll have to open it if you want to add RAM, and the maximum amount depends on your motherboard model.
<ScaredySquirrel>uh it's a Acer Aspire E 11 model E3-111
<nckx>ScaredySquirrel: Replacing RAM is pretty easy provided it's a decent laptop (not the kind where the RAM is soldered on) and you take some basic precautions like being careful and maybe grounding yourself if you're paranoid.
<ScaredySquirrel>ok
<malaclyps[m]>Look up your laptop model and see what maximum memory it takes and what kind of RAM
<ScaredySquirrel>I need to order 2 things of ram
<nckx>And the right type of things.
<ScaredySquirrel>yes
<nckx>ScaredySquirrel: If I read https://www.myfixguide.com/manual/acer-aspire-e3-111-disassembly/ correctly, the RAM is on the top (?) of the motherboard, so it's a bit more involved than on most laptops but doable.
<nckx>ScaredySquirrel: Random people on Web say: ‘The max limit is 8gb’, the type is ‘SO-DIMM DDR3L 1600’, there's only 1 slot so you need to buy a single 8-GiB module and replace your 4-GiB one.
<nckx>ScaredySquirrel: Bookmark that link above if you've never done all this before, take your time, be delicate, and don't do it while your mother's watching, and you'll be fine 🙂 It's a routine thing. I must have done it 30 times in as many years.
<nckx>I've built Chromium on an 8-GiB machine before. It was headless, so no idea how long it took and how bad it was swapping, but the thing pooped out a Chromium at the end.
<ScaredySquirrel>err is there any way to use a list of symbols in Scheme?
<ScaredySquirrel>I'm trying to use more than one symbol in (use-package-modules)
<raghavgururajan>Hello Guix!
<raghavgururajan>I am so curious. Why sneek was named sneek?
<zig>sneek: what is later?
<sneek>Someone once said later is the friend of never
<raghavgururajan>xD
<zig>raghavgururajan: the owner is not around, so I can not ask the question. Come on #guile and ask the question again
<raghavgururajan>zig sure thanks!
<zig>raghavgururajan: #emacs has a similar bot, they use it all the time. #python-fr (!) bot can lookup the documentation
*raghavgururajan is thinking about new name "guixer" for sneek
<zig>or xote
<zig>even xote is something else, I am cooking ;)
<raghavgururajan>I see.
<zig>raghavgururajan: I have the project to create an alternative guix cli for ... half a decade :)
<ScaredySquirrel>ok how do I use multiple package modules in (use-package-modules)?
<raghavgururajan>zig You mean like guix cli instead?
<raghavgururajan>*gui cli
<zig>no
<zig>a command line, that use another layout for grouping subcommands
<atw>ScaredySquirrel: I think (use-package-modules one two etc)
<ScaredySquirrel>atw: I did all of that
<raghavgururajan>zig I see. Sounds fascinating.
<ScaredySquirrel>for some reason on another system its config.scm won't load
<ScaredySquirrel>it's very similar to a working one
<zig>raghavgururajan: for me, 'guix package -s keyword' is difficult to remember, I prefer guix package search keyword, similarly guix package install keyword.
<zig>but again, this is not coming until at least the next year
<zig>I focus on a search engine.
<zig>I have been benchmarking on bug-guix mailling list and response time are somewhat good.
<ScaredySquirrel>I have no sshd running so I cant diff the files
<ScaredySquirrel>I'd have to use a flash drive
<zig>raghavgururajan: and you? are still gnome guru?
<ScaredySquirrel>one moment
<nckx>ScaredySquirrel: (use-package-modules a b c) works just fine.
<nckx>Source: my system configuration.
<zig>raghavgururajan: what is the last package you pushed?
<ScaredySquirrel>well err it's something else
<ScaredySquirrel>gonna diff the files
<raghavgururajan>zig That seems like a good idea.
<zig>raghavgururajan: what ?
<raghavgururajan>About the guix cli stuff you mentioned
<zig>yeah, I think too, but I am so far the only one to think so.
<raghavgururajan>zig LoL. No gnome guru and all. I have 3 packages ready. gnome-contacts, gnome-characters and gnome-font-viewer. I still wrapping my head around git to send a patch.
<zig>raghavgururajan: do the good thing first, unlearning bad pratice is a pain.
<raghavgururajan>zig But there is already options like "--install" and "--search" right?
<raghavgururajan>zig pardon?
<zig>raghavgururajan: yes, xote, is cosmetic change, 'guix package search' is the command --search is flag or option. It is not strictly the same taxonomy.
<zig>s/taxonomy/wording/
<raghavgururajan>zig Ah I get it now.
<raghavgururajan>zig Sometimes, things like this are not just cosmetic. They can be logical in the sense of semantics.
<zig>raghavgururajan: the thing is my point of view is far from mainstead, take git for example you only get : git foobar --xyz qux
<zig>instead of git subject verb --flag
<zig>anyway, I don't want to spam the channel about this trivial, dream of mine.
<zig>raghavgururajan: see you around.
<raghavgururajan>zig I have to learn git more to understand what you mentioned.
<raghavgururajan>zig Cool!
<wictory>o hai! so I have a recently installed system and when I run "guix pull" it fails with "guix pull: error: lstat: file or directory not found: "ftp://sourceware.org/pub/libffi/libffi-3.2.1.tar.gz". Does anybody have any idea on how to proceed?
<wictory>I tried "guix edit libffi" to change the url to "http://.." but the file is write-protected.
<wictory>(I'm a new user, so I don't know how to do stuff because I can't get the system to work so that I can start figuring things out..)
<zig>wictory: did you check that the ftp server is reacheable?
<atw>wictory: the "file or directory not found" is surprising to me because I can click that link and get a download prompt. "guix edit libffi" opening a write-protected file is expected; guix package definitions are by default stored immutably under /gnu/store
<lfam>I'm guessing that wictory can't access FTP. But it would help to get the lines before and after the "error: lstat..." line pasted at <https://paste.debian.net>
<atw>ahh good thought lfam
<lfam>wictory: What if you run this command and then try again: `guix download https://sourceware.org/pub/libffi/libffi-3.2.1.tar.gz`
<wictory>lfam: the line before is basically " guix https://git.savannah.gnu.org/git/guix.git ee4db14" and before that "Building from this channel:"
<wictory>lfam will try
<lfam>wictory: If my suggestion doesn't work, please copy and paste the messages so we can see all the details
<lfam>Copy and paste them onto the <https://paste.debian.net> web site
<wictory>lfam I would, but there are very few command that I can use on the system to upload anything to the internet. (I guess I could use scheme but I don't know how) The "guix download https://..." says "guix download: error: https://...: failed to parse URI"
<lfam>Okay I understand
<lfam>I'm surprised by the new error, that command should "just work"
<lfam>How about `guix download http://example.com`?
<lfam>And, please double-check you typed the URL correctly
<wictory>the "guix download http://example.com" appears to "work". It downloads something and outputs a hash (1nf895...), but if I try "guix download http://example.com/", it seems it does something, but the last line of output is "guix download: error: invalid character `/' in name `example.com/'"
<wictory>I know it's annoying you don't get all the output :P
<lfam>wictory: And for a simple test with HTTPS, how about doing it with https://google.com?
<lfam>Huh, that crashes for me :/
<lfam>Try it with https://gnu.org
<wictory>on both urls I get the similar output, first "From https://gnu.org...", next line: "failed to download \"/tmp/...\" from \"https://gnu.org\"", "guix download: error: https://gnu.org: download failed"
<lfam>Huh
<lfam>Does anyone have any ideas?
<wictory>both google.com and gnu.org return 301
<wictory>so .. "guix download https://github.com" succeeds, but "guix download https://github.com/" fails
<lfam>Huh, well they both work for me
<lfam>You just installed the system? What does your config.scm look like?
<lfam>And how did you install it? With the installer image?
<wictory>I downloaded this: https://ftp.gnu.org/gnu/guix/guix-system-install-1.0.1.x86_64-linux.iso.xz
<wictory>I installed it twice, and it was the same problem both times. I don't know what would be relvant from the config.scm.
<lfam>Can you share it regardless?
<wictory>I have (packages(append(list nss-certs gvfs)))
<lfam>And the services?
<wictory>and (services (append (list (service gnome-desktop-service-type) (set-xorg-configuration (xorg-configuration keyboard-layout)))) %desktop-services))
<wictory>(name-service-switch %mdns-host-lookup-nss)
<wictory>it's actually (packages(append(list nss-certs gvfs)) %base-packages)
<wictory>no, .. (packages(append(list nss-certs gvfs) %base-packages))
<lfam>Okay I'm stumped, but there are a few things to observe that are weird
<wictory>so is there a way I can use my install-medium to reconfigure the system?
<lfam>You should need to download the libffi source code for `guix pull`. Instead, you should get substitutes for that stuff
<lfam>And, it may be that you are blocked from using FTP on your network, which will cause some trouble if you can't get substitutes
<wictory>for example would "guix reconfigure /mnt/etc/config.scm /mnt" work? (when I have mounted root as /mnt as in the install guide)
<lfam>But, it's hard to be sure about these observations without more complete error messages
<wictory>lfam I can download libffi-3.2.1.tar.gz on the system using "ftp", but I don't know how to give it to guix to use
<lfam>I made a typo. "You shouldn't need to download the libffi source code..." You shouldn't need to build it either. It should be available pre-built on our servers
<lfam>wictory: Use `guix download` on the file
<lfam>That puts it in /gnu/store
<lfam>Assuming the file has the same hash as the one expected by Guix, it will help you skip that step where the download fails
<wictory>the "guix download" command succeeded, but it didn't change the output of "guix pull". but it's strange that "guix pull" says "error: lstat: ..", it's like guix is handling the URL as a UNIX path
<civodul>wictory: what does "guix describe" report?
***Forza_ is now known as Forza
<wictory>"guix describe: error: failed to determine origin"
<wictory>"hint: Perhaps this `guix' command was not obatined with `guix pull'? Its version string is 1.0.1"
<civodul>wictory: and it's this guix that fails to run "guix pull"?
<civodul>BTW, hi lfam! :-)
<lfam>Howdy civodul :)
<wictory>civodul yes.
<wictory>btw I'm reinstalling now .. maybe it works this time around :P
<wictory>also I'm getting a hang of the install process the hard way
<ScaredySquirrel>err err I put (service openssh-service-type) and (use-service-modules ssh) in my config.scm but it won't activate
<ScaredySquirrel>um hello? are any of you in there?
<str1ngs>ScaredySquirrel: what error did you get?
<atw>side note that on IRC many users read the channel only intermittently
<ScaredySquirrel>there is an sshd running however it isn't listening
<ScaredySquirrel>oh wait it is
<ScaredySquirrel>just not on localhos
<ScaredySquirrel>localhost
<str1ngs>it should listen on localhost, what are you using to configure your network? network manager?
<ScaredySquirrel>um...just dhclient
<ScaredySquirrel>I want my laptop on wifi though
<ScaredySquirrel>how would you add support for wireless?
<wictory>so I reinstalled (twice since I thought I did't need dhcp-client-service-type the first time) and now I have sshd running, and the full "guix pull" output is here: https://paste.debian.net/hidden/f54cd839/
<wictory>here I first download the missing file using ftp and then "guix download" it. https://paste.debian.net/hidden/a01eb472/
<wictory>here's one strange thing. https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/libffi.scm#n51 says that "0dya49bnhianl0r65m65xndz6ls2jn1xngyn72gd28ls3n7bnvnh" should be a base32 string, which it can't be according to https://en.wikipedia.org/wiki/Base32 since it contains 0's, 1's and 8's
<bavier>wictory: guix's base32 strings use nix's base32 format, which uses slightly different characters.
<civodul>wictory: it's not the RFC base32, it's Nix base32, see: https://guix.gnu.org/manual/devel/en/html_node/Invoking-guix-hash.html#Invoking-guix-hash
<civodul>heh :-)
<bavier>jinx
<bavier>civodul: though, I can understand some confusion. (@ (guix packages) base32) reads guix hash's "nix-base32" format, but cannot read the "base32" format.
<wictory>is the source code the only documentation for the nix-base32 encoding? because I can't find any description online.
<nckx>wictory: It's mentioned in one of the Nix papers.
<nckx>IIRC it's to avoid (most) naughty words appearing in random hashes. Whether there's much more to document than what the code visibly does I do not know.
<wictory>I found "where 8dpf3wcgkv1ixghzjhljj9xbcd9k6z9ris a base-32 representation of a 160-bit hash." in https://nixos.org/~eelco/pubs/nixos-jfp-submitted.pdf and I can't find any other mentions.
<nckx>wictory: Page 97 of <https://nixos.org/~eelco/pubs/phd-thesis.pdf>.
<nckx>‘This is to reduce the possibility that hash representations contain character sequences that are potentially offensive to some users’
<nckx>wictory: It also lists the equivalent symbols.
<kmicu>wictory: the code is the best place to check. There’s a comment in hash.cc about omitting EUI… if I recall correctly.
<wictory>ok thanks for the lead, I will need to familiarize myself if I'm going to start using guix
<kmicu>Using as in ‘contributing patches’? (Cuz knowing such hash details shouldn’t be necessary for daily use.)
<nckx>You can use ‘guix hash’. No need to calculate them by hand.