IRC channel logs

2019-09-02.log

back to list of logs

<Philiponian>is it possible to enable hibernate to disk via guix system configuration?
<nckx>Philiponian: What needs to be enabled?
<nckx>I've disabled it on my kernels, but I don't think there's anything you need to do to suspend Linux. Just write ‘disk’ to /sys/power/state.
<nckx>(You will, of course, need swap.)
<nckx>(Hullo, #guix.)
<nckx>Philiponian: I don't know if resume=/dev/sd<your swap device> is required. If it is you can add it to your operating-system's kernel-arguments list.
<Philiponian>nckx: http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services/desktop.scm#n597
<Philiponian>that comment gave me pause
<nckx>Philiponian: Oh. Yeah.
<nckx>I was reconfiguring with a stock Guix kernel to try it out but I think you might have hit a blocker there. Shame.
<Philiponian>what do you mean by stock Guix kernel?
<nckx>The default linux-libre kernel with default configuration.
<Philiponian>how does my configuration differ in that regard?
<nckx>Philiponian: I doubt it does? Are you using a custom kernel with your own configuration & patches? I'm guessing not 🙂
<nckx>OK, having read some more, let's definitely never write ‘disk’ to /sys/power/state since it will probably eat data without explicit initramfs support.
<Philiponian>i have not customized the kernel
<Philiponian>i have allocated sufficient swap space, adding resume kernel parameter is straightforward, and then the other step required for hibernation is configuring initramfs
<Philiponian>that is according to arch linux wiki: i need a resume hook in initramfs hooks
<nckx>I only mentioned a ‘custom kernel’ because *I* use one everywhere, with hibernation compiled out, so I needed to build a ‘regular’ one to test this further.
<Philiponian>nckx: appreciate your help!
<nckx>Philiponian: Turns out I was correct in the most uselessy literal way: the steps above hibernate the system [05:22:47] *** Joins: MinceR_ (~mincer@unaffiliated/mincer)
<cooper[m]>When I run guix system init, I get an error at grub-install saying /boot is a directory. Any idea what's wrong?
<tidux>cooper[m]: try fixing your config.scm to list the device node rather than the mountpoint
<tidux> /dev/sda1 etc.
<tidux>or actually iirc for grub-install it's the full drive
<tidux>so /dev/sda or whatever your boot disk is
<cooper[m]>tidux Yeah that was it, I had to use /dev/sda. Thank you
<cooper[m]>I am using an encrypted root partition. In my config.scm, I have a mapped device with a target "guix-root". What should I put as the file-system device? "/dev/mapper/guix-root"?
<tidux>no, still your actual disk
<tidux>GRUB needs to boot before you decrypt
<tidux>GRUB -> kernel -> decrypt disks -> rest of OS
<nckx>(You'll have to enter your passphrase twice at every boot because of this. Guix doesn't manage this for you [yet].)
<leungbk>If I don't want to wrap this in (leave ...), what is the idiomatic way of writing the failure case here?
<leungbk>(match-lambda
<leungbk> ((and ('package ('name name) . rest) pkg)
<leungbk> `(define-public ,(string->symbol name)
<leungbk> ,pkg))
<leungbk> (dep-name
<leungbk> (format #f (G_ "failed to download meta-data for package '~a'") dep-name)
<leungbk> ;; (string-append "failed to download meta-data for package '"
<leungbk> ;; dep-name
<leungbk> ;; "'")
<leungbk> )
<leungbk> ;; (bla bla)
<leungbk> )
<leungbk>The way I'm doing it now leaves double quotes around the string in the terminal output.
<rekado_>leungbk: is there a reason why you can’t use “leave”?
<rekado_>leungbk: if you can’t use it then let the procedure throw an error and catch it where it is called (and where you could presumably use “leave”)
<leungbk>@rekado: I don't want to use anything leave/error-related stuff because this is intended to be a case in a recursive importer where a particular dependency can't be found but I nonetheless want to make the importer keep trying to recursively import the remaining ones.
*tidux files some more bugs
<tidux>it really seems like people haven't done serious developer-style workflows on guixsd yet
<tidux>at least not as a pure host system
<leungbk>Right now the behavior is to simply print #f for that particular dependency, which is less helpful.
***sturm is now known as Guest57407
<tidux>yeah gpg is completely broken and worthless on guixsd without being able to see pinentry
<tidux>guess that blocks what I wanted to do
<cooper[m]>Thanks guy, I managed to boot properly with the encrypted partition now. I was wondering if it is recommended to have a system config (like the one made during the installation) and a user config somewhere in $HOME that I can put in version control
<tidux>hmm, looks like you have to manually point gpg-agent at your pinentry program
<tidux>this should be done by default given the weird paths involved
***MinceR_ is now known as MinceR
<tidux>aah there we go
<tidux>got aerc working
<efraim>tidux: do you have a package for aerc? I tried to package 0.1.0 but ran into issues
<tidux>just a manual build from git master for now
<tidux>but go builds are pretty easy
<tidux>the hardest part was getting gpg+pinentry+pass working together so I didn't have to use plaintext passwords
<tidux>I might throw together a package later as a simple-ish intro to packaging
<tidux>can't be worse than trying to make a .deb
<leungbk>@efraim: I think I figured out how to make the crate recursive importer work the way you wanted. One problem I'm having is that my output has double quotes around it if I use:
<leungbk>(dep-name
<leungbk> ;; (format #f (G_ "failed to download meta-data for package '~a'") dep-name)
<leungbk> (string-append "failed to download meta-data for package '"
<leungbk> dep-name
<leungbk> "'"))
<leungbk>What's the idiomatic way to print out this sort of thing without using an error/leave-type thing that halts execution?
<g_bor>hello guix!
<roptat>hi guix!
<leungbk>sneek: ask efraim if he would mind looking at my question from 9:24 cest
<leungbk>@sneek test
<leungbk>@sneek: test2
<roptat>sneek, botsnack
<sneek>:)
<leungbk>sneek, is a comma all you need
<leungbk>sneek, test123
<roptat>sneek is very picky with what messages it answers to
<roptat>sneek, later tell leungbk hi
<sneek>Okay.
<leungbk>roptat: I see, thanks.
<sneek>leungbk, you have 1 message.
<sneek>leungbk, roptat says: hi
<roptat>see?
<tune>"ask" should be made to work too. (I know he still needed "later" in there)
<tune>I want it to work, I mean
<leungbk>sneek, later tell efraim I think I figured out how to make the crate recursive importer work the way you wanted, but I'm currently using (string-append), which forces the failure cases to display with extra double quotes, so that instead of "failed to get metadata for x" actually shows the quotation marks. Is there an idiomatic way of removing the double quotes that doesn't require leave/error-type stuff (since that would cut off the
<leungbk>recursion)?
<sneek>Okay.
<efraim>leungbk: I'm not sure. i think the 'failed to get metadata' is fixed by https://issues.guix.gnu.org/issue/37254
<sneek>Welcome back efraim, you have 1 message.
<sneek>efraim, leungbk says: I think I figured out how to make the crate recursive importer work the way you wanted, but I'm currently using (string-append), which forces the failure cases to display with extra double quotes, so that instead of "failed to get metadata for x" actually shows the quotation marks. Is there an idiomatic way of removing the double quotes that doesn't require leave/error-type stuff (since that would cut off the
<efraim>sneek: botsnack
<sneek>:)
<leungbk>efraim: I'll look at it in a few hours (it's past midnight here).
<civodul>Hello Guix!
<efraim>sneek: later tell leungbk looking forward to it! ludo's crate import fixes worked for me
<sneek>Got it.
<efraim>sneek: botsnack
<sneek>:)
*civodul started "guix workflow --web-interface" so that https://www.guixwl.org/ is back to life
<civodul>"/gnu/store/knv2sc44awjj23k29rrgh5c9rf9fbq1p-qtbase-5.11.3/lib/libQt5Core.so.5: ELF 64-bit LSB shared object, x86-64, version 1 (GNU/Linux), dynamically linked (uses shared libs), for GNU/Linux 3.16.0, stripped"
<civodul>notice "3.16.0", and old CentOS is at 3.10
<rekado_>civodul: oh, thanks! I forgot about the GWL web interface… :-/
<rekado_>gotta write a service and add it to the berlin config.
<rekado_>RHEL 7 is at 3.10, but the kernel is heavily patched.
<rekado_>I think we configured / patched qt5 so that it doesn’t use certain syscalls that aren’t available in the RHEL kernel that claims to be 3.10.
<rekado_>(version numbers are … frustrating. People think they mean something, but they are so arbitrary.)
<rekado_>sneek: later tell leungbk The CRAN importer retries imports from different repositories. If a package isn’t found on Bioconductor it will retry to import from CRAN. Same for imports from Git which are retried on Bioconductor (and then CRAN).
<sneek>Got it.
<gnu_srs1>Hi, when editing bootstrap.scm guix complains that bootstrap.go is too old. How to rebuild that binary file?
<rekado_>gnu_srs1: run “make”.
<gnu_srs1>rekado_: Thanks :)
<gnu_srs1>When issuing ./pre-inst-env guix build hello the only processes running is /usr/bin/guile-2.2 .../guix-1.0.1/scripts/guix build hello and guix-demon.
<gnu_srs1>No visible output and no files created (cannot find any), and /tmp is empty. What am I missing?
<rekado_>the daemon should spawn a Guile build process.
<rekado_>this is a client/server setup: the “guix” script talks to “guix-daemon” over a socket and tells it to do things.
<rekado_>the daemon prepares a chroot in which an unprivileged build user builds packages.
<gnu_srs1>tks. Where is that chroot supposed to be created?
<gnu_srs1>I started the guix-daemon with: su -c './pre-inst-env ./guix-daemon --debug --build-users-group=srs'
<rekado_>“build-users-group” should be a dedicated group of unprivileged build users
<rekado_>please follow the manual’s instructions on how to create them and how to start the daemon.
<gnu_srs1>I found two small numeric files created at /usr/var/guix/temproots/, they could not be chroots.
<rekado_>on the Hurd you will probably need “--disable-chroot”, IIRC.
<rekado_>no, that’s something else.
<roptat>oh, so you have the same issue as I have :)
<roptat>no output whatsoever on the guix or guix-daemon side
<rekado_>run without chroots
<gnu_srs1>It would be a little easier if info guix would speak English, not Spanish.
<roptat>guix iteslf speaks spanish? or just the manual?
<roptat>I guess we should really rename or guix.es, guix.fr, ... to guix-es, guix-fr etc
<gnu_srs1>info guix speaks Spanish, the guix.info files are in English.
<rekado_>is this just on the Hurd system or on the Linux system as well?
<gnu_srs1>as other info files are, like info coreutils
<roptat>it's already an issue with the website, and the reason is that some info readers take the name to be what's before the first dot, not what's before .info
<roptat>so maybe the info reader from debian takes guix.es.info to be the manual for guix, instead of for guix.es
<gnu_srs1>info guix speaks Spanish on Hurd, English on Linux
<roptat>and guix.es happens to be the first it finds
<roptat>I'll try to make a patch for that
<civodul>rekado_: re GWL (and Cuirass), i think we should streamline the config so that really everything is in the repo
<civodul>that should make it easier when several of us fiddle with berlin :-)
<civodul>i can take a stab at it if you want
<civodul>like adding a GWL snapshot and a service
<civodul>rekado_: re qt, should we adjust our package so that it really requires 3.10 (instead of 3.16)?
<civodul>would it be useful for the MDC?
<civodul>ouch, welcome back Matrix friends!
<rekado_>civodul: I bet it would be useful for all those who are stuck on CentOS / RHEL.
<rekado_>RHEL 7 is still current and will be supported for a long time to come
<rekado_>making sure that Qt actually works with 3.10 would be great
<rekado_>not sure if that’s feasible
<rekado_>re Cuirass / GWL: I totally agree. The same needs to be done for Mumi still.
<efraim>we should check what it is on staging, qt-5.12 landed there
<gnu_srs1>rekado_: I started the daemon adding --disable-chroot, still nothing in /tmp??
<efraim>/gnu/store/6zq9snpizinjgh17p22jid621fd3357i-qtbase-5.12.4/lib/libQt5Core.so.5.12.4: ELF 64-bit LSB pie executable x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /gnu/store/h90vnqw0nwd0hhm1l5dgxsdrigddfmq4-glibc-2.28/lib/ld-linux-x86-64.so.2, for GNU/Linux 3.16.0, stripped
<efraim>from staging
<rekado_>gnu_srs1: trace the daemon and its children?
<gnu_srs1>That would be using rpctrace on Hurd, which is know to be buggy and easily crashing (even the box). But I'll try.
<civodul>efraim: if we can find out what flags to pass at configure time, we could fix qt on staging
<rekado_>I remember no problems running guix-daemon on the Hurd back in May.
<gnu_srs1>I'ts running, but no visible output in /tmp. Starting 'guix build hello' creates the file: /usr/var/guix/temproots/1568 (and the socket by guix-daemon)
<rekado_>a temproot is to prevent the garbage collector from removing dependencies that are required for this current build..
<rekado_>my notes say that I ran the daemon *without* build-users-group; just “guix-daemon --disable-chroot” as root to bypass another problem.
<rekado_>I had to patch the daemon to allow downloads as root, thuogh
<rekado_>(there’s an assertion somewhere)
<rekado_>see my message to guix-devel: <87d0ktewzg.fsf@elephly.net>
<rekado_>also check your RAM consumption. Could be that Guile just eats all the memory.
<rekado_>I saw that behaviour in my past tests
<gnu_srs1>Sorry, that link is treated as a mail address on my box.
<rekado_>I think I ended up patching Guix to use Guile 2.0 on the Hurd; don’t remember.
<rekado_>it’s not a link. It’s a message ID that you can search in the guix-devel list archives.
*rekado_ has to go afk for a little while
<gnu_srs1>OK. regarding memory I still have 1.4G free.
<roptat>gnu_srs1, that's https://lists.gnu.org/archive/html/guix-devel/2019-05/msg00140.html
<gnu_srs1>roptat: Thanks. BTW: guix system is not available on my Hurd box.
<roptat>guix system would be a next step
<roptat>we need to have guix working first
<civodul>why does "getent hosts guix.gnu.org" gives me a v6 address when in fact we only have an A record and no AAAA?
<roptat>civodul, what address do you get? I only get a link-local address
<civodul>i get fe80::8218:...
<civodul>i don't see where that comes from, roptat
<roptat>that's a link-local address, but I get the same one... not sure where it comes from either
<roptat>well, from the answer section of a DNS querry:
<civodul>computers are tricky
<roptat>dig AAAA guix.gnu.org
<roptat>guix.gnu.org. 3328 IN AAAA fe80::8218:44ff:fee8:f7e0
<civodul>was ist das?
<civodul>weird
<civodul>IPv6 is hard
<roptat>mh... it's advertised from the gnu.org dns servers
<roptat>oh, even from bayfront
<roptat>see: https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/modules/sysadmin/dns.scm
<civodul>hmm did we make a mistake?
<roptat>berlin-ip6 is set to that link-local address
<raingloom>is there something like Nix's wrapQtAppsHook in Guix? is such a thing needed? i'm trying to package a QT app and it compiles and runs but breaks in weird ways. it's packaged in Nix and their package looks very similar to what I'm doing, except for that wrapper thing is missing from mine.
<roptat>and then, it's put in two AAAA records
<roptat>yep, that address is not supposed to be routed
<raingloom>(the Nix package: https://github.com/jonringer/nixpkgs/blob/master/pkgs/applications/audio/fmit/default.nix )
<civodul>but then, why does that AAAA record not show up in "dig guix.gnu.org"?
<roptat>because dig only shows A by default
<civodul>you sure?
<g_bor>hello guix!
<civodul>roptat: dig shows AAAA in the "ADDITIONAL SECTION" for instance
<g_bor>Anything regarding outreachy proposals came up?
<roptat>yes, but that one is unsolicited, it's only defined by the dns server
<roptat>the actual question is in the qestion section
<roptat>and by default it only asks for A records
<civodul>now, "telnet -6 guix.gnu.org http" fails for me
<civodul>"Invalid argument"
<roptat>of course: berlin is not connected with ipv6, and the address we have in the AAAA record is not routable
<civodul>likewise for "ssh -6 guix.gnu.org"
<civodul>so what's the story?
<civodul>is that a bogus address, after all?
<roptat>yes, it's only used locally
<roptat>that's why it's called a *link*-local address (fe80::something are link-local)
<civodul>glad you're more competent than i am :-)
<civodul>so, we should simply remove that line from dns.scm, right?
<roptat>right, except if berlin is actually connected with ipv6
<civodul>in that case we'd need to change the address
<roptat>in which case, the ipv6 address probably starts with 20*
<civodul>"ip a" only shows fe80:* addresses
<roptat>those are link-local, they're not routable, we should not have them in DNS
<civodul>so delete the line?
<roptat>g_bor, not that I know of
<roptat>I think it's wiser, yes
<g_bor>roptat,civodul: rekado told that berlin will have to wait for ipv6.
<civodul>roptat: are you able to delete + reconfigure, or should i do it?
<civodul>g_bor: ah ok
<roptat>civodul, can you do it? I don't have access right now
<civodul>alright!
<roptat>civodul, that was the right thing to do (I mean, adding the ip as (you?) did), but we'll have to wait for berlin to actually have ipv6 :)
<roptat>what does "snarf" mean?
<civodul>roptat: i've reconfigured bayfront and restart knot, so hopefully we're all good now
<civodul>"snarf" is sort of like "borrow" or "steal" in an abstract sense i'd say
<roptat>yes, we'll have to wait a bit for caches to expire though
<civodul>"wn snarf -over" has a more elaborate definition
<roptat>bayfront advertises the right thing (i.e. nothing)
<roptat>same for gnu servers
<roptat>so we're good now :)
<roptat>I don't understand it in the context of compiling guile
<civodul>yay!
<civodul>roptat: "guile-snarf" is a tool to extract documentation from C files
<rekado_>the IPv6 address for berlin would be 2001:638:81B::181:40
<civodul>roptat: there was a tradition to only use terms (slang terms maybe?) and references that only native speakers would understand
<rekado_>but IPv6 isn’t routed by the MDC network infrastructure.
<civodul>ok, so wait and see!
<rekado_>raingloom: can you show us the package definition and the errors you get?
<rekado_>gnu_srs1: do you mean that *none* of the “guix system” commands work on your Hurd box?
<rekado_>(we should focus on the simpler “guix build” for now, because that’s already failing)
*civodul pushed the 'archival' lint checker: https://issues.guix.gnu.org/issue/37224
<roptat>nice :)
<raingloom>rekado_: https://gitlab.com/raingloom/guix-source/blob/raingloom/fmit/gnu/packages/fmit.scm
<raingloom>rekado_ it starts and detects voice but doesn't draw any waveforms and none the of the icons are there
<raingloom>so far i've figured out that it's accessing ~/.guix-profile/share/icons/default instead of hicolor, but i'm not familiar enough with QT to know why
<raingloom>i'm not yet sure why it doesn't draw the waveform, it didn't print a lot of debug info
<rekado_>you may have to wrap the executable(s) in QT_PLUGIN_PATH. See gcompris-qt for an example.
<rekado_>civodul: our “guix-install.sh” script does not lead to a functioning installation of Guix.
<rekado_>I just tried it and the daemon is started with GUIX_LOCPATH set to a non-existing location.
<rekado_>as a result setting LC_ALL fails and the substituter seems to just freeze.
<rekado_>the freezing could also be a networking problem here, but the point stands: GUIX_LOCPATH points to the root user’s default profile, which does not exist. We only install the current-guix profile.
<civodul>rekado_: that's on purpose: the idea is that people can run "guix install glibc-utf8-locales" as root
<civodul>but that if you're using one of the happy few locales, it just works
<civodul>without installing anything
<rekado_>shouldn’t the installer script take care of this?
<rekado_>also: I *am* using en_US.utf8 but since the daemon runs in an environment that doesn’t have glibc-utf8-locales i will get the error (an ugly LC_ALL error, not a nice warning with a hint) every time I run a Guix command.
<rekado_>this is what I see when running “guix build hello”:
<rekado_>substitute: /gnu/store/q19l04vd2za80mk1845pz7r8cz29qk43-bash-minimal-4.4.23/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.utf8)
<civodul>yeah, that
<civodul>i want to get rid of the libexec/ trampolines partly because of that
<civodul>but yeah that's terrible
<civodul>i can't believe we've been struggling with that for so long and for so little
<civodul>i think you actually *have* to install glibc-utf8-locales to get rid of the message from Bash
<rekado_>we could make the installer script install glibc-utf8-locales by default.
<rekado_>it already does all the other annoying stuff.
<rekado_>might as well do that.
<civodul>yes, though this could take a while if the user disabled substitutes
<civodul>maybe it should ask
<rekado_>sounds fine
<quiliro>Saluton Gikso!
<roptat>saluton quiliro
<civodul>saluton!
<civodul>roptat: found a typo in fr.po: « lancez `hash guix' pour vous assurez »
<civodul>(should be "assurer")
<roptat>Indeed
<roptat>There are many more though :p
<quiliro>roptat: saluton ... Ĉu vi estas giksa programisto?
<raingloom>rekado_, it works now! thanks! gonna send the patch in a bit
<apteryx>hello! has anyone else had this problem with ntpd? Sep 1 18:40:14 localhost shepherd[1]: Respawning ntpd.
<sneek>Welcome back apteryx, you have 1 message.
<sneek>apteryx, civodul says: what do you mean by "input validation"?
<apteryx>civodul:I meant that upon construction, a record could self-verify that field values given to it match an expected predicate
<civodul>hi apteryx!
<quiliro>apteryx: i have had that error...not sure if i had it last time i turned on the computer
<apteryx>hello :-)
<civodul>apteryx: there's already some level of validation, for example, you get an error if something in 'inputs' isn't right
<civodul>did you have something specific in mind?
<apteryx>civodul: yes; I was extending the current ntp service so to be able to specify options on a server, as well as the server type: https://paste.debian.net/1098408/
<gnu_srs1>rekado_: FYI guix: system: command not found
<gnu_srs1>Reading the mail thread from May...
<rekado_>probably a problem with GUILE_LOAD_PATH, specifically a lack of guile-json, guile-sqlite, or guile-ssh.
<roptat>quiliro: jes
<apteryx>I made use of an enum, but there is no easy way to validate that the 'type' field of the <ntp-server> record is valid as per the 'ntp-server-types' enum
<apteryx>(I mean, at the type the struct is expanded)
<apteryx>s/struct/record/
<civodul>apteryx: ah indeed
<civodul>i think we should extend define-record-type* so we can specify "contracts" for each field
<civodul>or at least a predicate
<civodul>but something fancier would be nice
<civodul>hello alezost!
<apteryx>civodul: yes, that'd help! We wouldn't be able to do anything I guess for the thunked or delayed field, but it'd be useful for most cases
<civodul>yeah
<alezost>civodul: hello!
<apteryx>quiliro: I had ntpd respawn every 3 minutes about and my date wouldn't be set, until I ran it manually with a different config file (still trying to figure out what exactly made it happy)
<apteryx>quiliro: I think it works when I remove all the restrict directives from the ntp.conf file... Not sure why. We use basically the same ones as Debian
<quiliro>apteryx: i had the respawning problem with xorg some months ago...updating or changing system configuration fixed it....not sure
<apteryx>quiliro: OK. Glad you sorted it out.
<quiliro>roptat: Bonvolu montri mi vian "commits", mi petas. Mi volas esti giksa programisto.
<quiliro>pardonu...
<quiliro>roptat: Mi korektos mian frazon....donu min momento
<chrislck>where does define-record-type* come from?
<gnu_srs1>rekado_: guile 2.2.6 is available but I installed 2.2.4, any big differences?
<gnu_srs1>FYI: Augmenting GUILE_LOAD_PATH with /usr/share/guile/site/2.2/ make guix system --help work.
<roptat>quiliro, ĉu vi bezonas helpon por kontribui?
<apteryx>quiliro: yeah, I figured it out
<gnu_srs1>Adding -S to the hello build I get: substitute: guix substitute: warning: ACL for archive imports seems to be uninitialized, substitutes may be unavailable
<gnu_srs1>substitute: guix substitute: error: TLS error in procedure 'handshake': Failed to acquire random data.
<gnu_srs1>guix build: error: substituter `substitute' died unexpectedly
<apteryx>my hwclock was set to 9 hours earlier current time, and without the -g flag ntpd refuses to make such an initial big change
<roptat>gnu_srs1, oh that's an issue with you gnutls
<roptat>I think mine also has the same issue
<apteryx>the -g is recommended good practice as per the manual, so I'm going to fix this; otherwise you'd have to fiddle with your BIOS everytime you take the plane
<roptat>(at least I saw it when doing a git clone, and unseting LD_LIBRARY_PATH fixed it)
<quiliro>roptat: Mi volis diri: "Bonvolu montri al mi viajn ŝanĝerojn, mi
<quiliro> petas. Mi volas esti giksa programisto." estas bone?
<quiliro> [10:17]
<quiliro><MartinShadok[m]> Al mi ŝajnas bone ☺ [10:18]
<quiliro> > dankon MartinShadok[m] :-)
<quiliro>
<quiliro>sorry for the bad paste
<quiliro>just wanted to put one fraze
<quiliro>frase
<quiliro>Bonvolu montri al mi viajn ŝanĝerojn, mi petas. Mi volas esti giksa programisto.
<roptat>vi povas vidi ŝanĝerojn per "git log"
<quiliro>roptat: jes mi volas contribui...sed mi serĉas kiel nun. Mi pensis ke estas bone aldoni freecad-on al Gikso.
<quiliro>roptat: Mi ne scias se ĝi estas pli komplkema por min. Mi ne vidis la kodon.
<quiliro>Mi vidos git log.
<gnu_srs1>roptat: Which version of guile-gnutls did you build? I cheated and built Debian guile 3.6.9-4 with an older version of p11-kit.
<rekado_>gnu_srs1: since we don’t have substitutes anyway you could avoid this for now by running the daemon with “--no-substitutes”
<roptat>gnu_srs1, I think it's an issue with gnutls, not guile-gnutls
<roptat>I built the latest gnutls
<roptat>quiliro, mi povas helpi vin se vi havas demandojn
<roptat>fakte, ĉiu ĉi-tie povas helpi vin :)
<gnu_srs1>Progress: building /gnu/store/qihk8cf98xqc7q577wb2nc5axy2ryp8m-hello-2.10.tar.gz.drv...; guix perform-download: error: refusing to run with elevated privileges (UID 0)
<roptat>mi kredas ke la plej facila maniero por kontribui estas ĝisdatigi pakojn
<roptat>aŭ aldoni novajn pakojn, sed ĝi povas esti malfacila
<roptat>gnu_srs1, in Ricardo's message, it was mentioned that you need to patch the daemon to accept downloading as UID 0 (there is an assertion somewhere)
<civodul>rekado_: BTW, i tried out "guix pull --branch=core-updates -p guix-next" on CentOS with 3.10 and the binaries it gives appear to work fine (fortunately!)
<rekado_>phew!
<rekado_>thanks for testing!
<gnu_srs1>OK, rebuilding then :(
<rekado_>just the daemon.
<rekado_>that’s quick.
<apteryx>civodul: if I change the ntp-configuration record to take servers as a list of records rather than strings, I guess I must do the extra work to be backward compatible? (e.g. issue some deprecation warning and do the required tranformation?)
<apteryx>(when presented with a list of strings rather than records)
<quiliro>roptat: mi konas kiel ĝisdatigi pakagon...sed mi ne faris tion...mi faros tion :-)
<roptat>bone :)
<gnu_srs1>roptat: Where to change the code for UID 0?
<rekado_>in nix/libstore/build.cc
<rekado_>comment “assert(uid == 0)”
*apteryx zzzz
<roptat>vi povas uzi guix refresh, ekzemple "guix refresh -t opam" por vidi pakoj el opam kiun vi povas ĝisdatigi :)
<jgibbons[m]>hello guix!
<jgibbons[m]>What package provides tzselect?
<civodul>hello jgibbons[m]!
<civodul>i think it's from glibc
<jgibbons[m]>civodul: Looks like that's correct. Thank you!
<civodul>yw!
<gnu_srs1>roptat: Still getting the assertion :(
<roptat>have you rebuilt and re-run the daemon?
<roptat>you can use ./pre-inst-env for guix-daemon too
<gnu_srs1>I had to make more changes in build.cc and guix/scripts/perform-download.scm
<roptat>could you share?
<gnu_srs1>./pre-inst-env guix build -S hello worked: Yay :)
<gnu_srs1>Trying now without -S ...
<gnu_srs1>Seems to be stuck, waiting some more time.
<tune>oh cool, rakudo is packaged
<tune>was waiting on that to learn it
<rekado_>gnu_srs1: if it’s stuck this could indicate that Guile doesn’t work correctly.
<quiliro>how can i get a list of guix authors with the number of commits for each Kiel mi povis vidi la Giksajn verkistajn nombrojn kun la numero de ŝanĝeroj de kiu?
<quiliro>en la linio komanda....
<quiliro>on the command line....
<quiliro>mi provis: git log post git clone kaj cd guix
<quiliro>do..'guix clone ...; cd guix; git log'
<roptat>quiliro: git log | grep ^Author: | sort | uniq -c
<roptat>Although some names will appear more than once with different email address
<gnu_srs1>Seem,s like file:// fails: Starting download from ... /part2/Guix/bootstrap-tarballs/20190901/i586-gnu/binutils-static-stripped-2.31.1-i586-pc-gnu.tar.xz
<gnu_srs1>skipping URI with unsupported scheme: #<<uri> scheme: file userinfo: #f host: #f port: #f path: ...
<gnu_srs1>Any ideas?
<vagrantc>gnu_srs1: file:/// ?
<quiliro>roptat: dankon...mi ne vidis roptat-on en la listo
<roptat>ne, mi estas Julien Lepiller
<quiliro>mi pensis ke mi ne serĉis bone
<quiliro>ho!
<efraim>tune: I've had reports that zef doesn't work as expected
<tune>I don't know what zef is yet. is it like pip?
<quiliro>kiel mi povas serĉi post iom dato?
<gnu_srs1>vagrantc: The entry is: file:////part2/Guix/bootstrap-tarballs/20190901/i586-gnu/binutils-static-stripped-2.31.1-i586-pc-gnu.tar.xz
<gnu_srs1>Works in my browser.
<roptat>quiliro, mi ne komprenas
<roptat>gnu_srs1, how did you solve the issue with "Failed to acquire random data."?
<quiliro>roptat: git log ŝangeroj en la jaro 2019
<gnu_srs1>Not looked into that yet.
<quiliro>mi serĉas tion
<roptat>gnu_srs1, how did you download hello's sources then? I get this error when I try to run guix build -S hello
<roptat>quiliro, eble "git log | grep '^Date: .*2019' -B1 | grep ^Author: | sort | uniq -c"
<gnu_srs1>It was found here: ftp://ftp.funet.fi/pub/mirrors/ftp.gnu.org/gnu/hello/hello-2.10.tar.gz
<roptat>oh
<roptat>oh I see, I was using substitutes, so there was a connection to the ci system through https
<roptat>with --no-substitutes, it goes directly for the sources
<roptat>it did download them nicely :)
<efraim>Yeah, zef is the perl6 version of pip if I understand correctly
<vagrantc>rekado_: any chance you could update your gpg key on savannah? the keyservers are all broken and you're my path into the guix web of trust :)
<quiliro>roptat: kien via nick-o venis?
<quiliro>roptat: dankon por la komando
<roptat>mia nick-o venis el persono de libro kiu aperis en tri paĝoj en la tuta libro
<roptat>sed mi ne memoras la titolo de la libro
<quiliro>Roptat wins, then when the Potoku fleet arrives, they come up the mountain and destroy us before the Wetheads can get here.
<quiliro> https://findwords.info/ends/head/7
<roptat>mi pensas ke tiu libro estis: https://www.barnesandnoble.com/w/call-of-earth-orson-scott-card/1100354521
<roptat>sed mi legis tion en la francan kaj antaŭlonge
<quiliro>roptat: kiu estis vin ĉi tie https://www.haiku-os.org/conference/2019_fosdem_2019/
<gnu_srs1>roptat: Now I've finally fixed the web links, I had webfs running. Download fails though: In procedure connect*: Connection timed out
<roptat>quiliro, jes
<gnu_srs1>Works in my browser: I use a local address 192.168...
<roptat>quiliro, https://en.wikipedia.org/wiki/The_Memory_of_Earth
<quiliro>roptat: 1992
<quiliro>roptat: Ĉu vi havas jakon flavan aŭ brunan? en https://www.haiku-os.org/conference/2019_fosdem_2019/
<quiliro>roptat: Ĉu https://www.haiku-os.org/files/blog/korli/SAM_7072_small.JPG estas vi?
<roptat>ne
<roptat>mi ne estas en la foto
<roptat>mi nur vizitis, ne partoprenis
<roptat>mi havas foton ĉe mia retejo: https://lepiller.eu/
<quiliro>Vi estas francio!
<quiliro>roptat: Ĉu aŭ usonano kiu parolas francon?
<roptat>mi estas francio :)
<quiliro>:-)
<quiliro>roptat: Vi havas Github-on. Kial vi ne muntis Gitlab-an servon?
<tidux>How do I add a value for /etc/environment to config.scm?
<quiliro>mi pensas ke vi povus
<tidux>or /etc/profile.d for that matter
<roptat>mi uzas github nur por kontribui al aliajn projektojn
<roptat>miaj projektoj estas ĉe framagit
<quiliro>ho ve! mi vidas nun.
*vagrantc is playing the "attempt to install guix aarch64 binary distribution in a chroot to initialize a guix system" game
<tidux>fun
<tidux>but seriously where is "guix system" sourcing the content of /etc/environment from?
<tidux>and how can I add to it in config.scm?
<vagrantc>well, setting up guix from just the binary tarball is hard.
<vagrantc>was trying to avoid doing a foreign distro install... but ... hrm.
***Guest81054 is now known as benny
<gnu_srs1>Using a local web service or file fails:
<gnu_srs1>file:/// skipping URI with unsupported scheme: #<<uri> scheme: file userinfo: #f host: #f port: #f path:
<gnu_srs1> http://192.168.1.3: In procedure connect*: Connection timed out, works fine with my web browser
<gnu_srs1> http://127.0.0.1: Throw to key `match-error' with args `("match" "no matching pattern" (() (#<input-output: socket 18>) (#<input-output: socket 18>)))'.
<gnu_srs1>Continuing later on...
<tidux>Has nobody ever wanted to manually add an environment variable to guix via config.scm before? Is operating-system-environment-variables not exported from system.scm?
<roptat>tidux, if you can't find an answer here, try to send an email to help-guix@gnu.org
<quiliro>roptat: Mi ne povis vidi vian framagit-on. Mia TTT-legilo blokadas malliberan programon.
<roptat>quiliro, framagit estas gitlab
<roptat>ĝi estas libera programo
<quiliro>roptat: mi pensis tion...sed librejs blokadas ĝin
<quiliro>roptat: kial?
<roptat>mi ne scias
*vagrantc hopes guix can boot successfully from a degraded raid1 array
<Minall>Hello guix!
<Minall>I'm unable to mount exfat devices... What should I do?
<civodul>Minall: you may need to "guix install fuse-exfat"
<civodul>and then "sudo mount.exfat ..."
<Minall>civodul: Thanks for the responde, I do have it installed, but I'm unable to mount it...
<Minall>I have the following message: ERROR: unsupported FAT count: 2
<PotentialUser-67>hi all. using guix package manager on Linux mint 19.2 and having trouble finding packages that I see available at https://guix.gnu.org/packages/
<PotentialUser-67>is this because the packages I want, ungoogled-chromium for one, are not compatible with other Linux OS rather for GUIX OS?
<Formbi>this site is somewhat buggy
<quiliro>Formbi: which site?
<Formbi> https://guix.gnu.org/packages/
<janneke>PotentialUser-67: have you run guix pull yet?
<PotentialUser-67>packages webpage loads fine for me, I just referenced it to see what was available in Guix land, and do see ungoogled-chromium listed there as mentioned in dev github page
<conceivably>Hi :) How do people who unfortunately depend on nvidia drivers (or other proprietary packages) for work deal with this on Guix? I'm having a hard time finding information about this. As best as I can tell, the proper way would be to use channels, but it seems a bit inefficient for every user to maintain their own package.
<PotentialUser-67>guix pull, I don't think I have. is just command "guix pull"
<janneke>yes, it's vaguely like apt-get update
<PotentialUser-67>pulling now, thanks for that apt-get tip. will report back if package is found now :)
<rekado_>vagrantc: I extended my key today, but haven’t yet uploaded it.
<rekado_>will do so in a few hours
<PotentialUser-67>@janneke, +1877 new packages in this revision, seems I haven't done pull since first install gpm, thanks!
<janneke>PotentialUser-67: good, yw
<civodul>conceivably: channels are meant to be published and shared, but perhaps Nouveau would work for you?
<conceivably>Hm...Maybe. There does seem to be a performance penalty. Reading up on it some more now. Thanks!
<tidux>conceivably: there are channels out there for a lot of things
<tidux>I don't think the nvidia binary driver is one
<gnu_srs1>Progress: I managed to make the web server to give an external address: The -e ... stuff ended with: guix/build/syscalls.scm:1094:18: In procedure set-thread-name:
<gnu_srs1>In procedure prctl: Function not implemented
<gnu_srs1>Seem like it is not available on Hurd: How to disable calling it in guix/build/syscalls.scm?
<xavierm02[m]>In the --help of guix import crate, shouldn't it be crates.io instead of crate.io? And is this importer supposed to work?
<gnu_srs1>How to change (unless (zero? ret) to return with zero exit code?
<gnu_srs1>Next error: Error creating a pipe: Function not implemented: Not true!
<gnu_srs1>Endless...
<gnu_srs1>This was the xz executable complaining: building /gnu/store/aa36vj3zmj49p39hzqf8cbpy2liib393-guile-bootstrap-2.0.drv
<gnu_srs1>/home/srs/DEBs/guix/guix-1.0.1/gnu/packages/bootstrap/i586-gnu/xz --help
<gnu_srs1>/home/srs/DEBs/guix/guix-1.0.1/gnu/packages/bootstrap/i586-gnu/xz: Error creating a pipe: Function not implemented
<gnu_srs1>Something went wrong cross-building the bootstrap files...
<Minall>Saluton
<rekado_>gnu_srs1: I remember that syscall thing
<rekado_>I thought I had patched that already
<rekado_>I replaced the definition in guix/build/syscalls.scm with (define (set-thread-name name) #t)