IRC channel logs

2019-04-12.log

back to list of logs

<brettgilio>Hey all, I am trying to make a package recipe for emacs-doom-themes, but when I install it the /test and /themes subdirectories are getting lost. I am using the emacs-build-system for it, which I imagine is why the dirs are getting lost. So, I am not sure how to proceed best here. https://github.com/hlissner/emacs-doom-themes https://github.com/brettgilio/guix-system/blob/master/non-gnu/packages/emacs-extend.scm
<brettgilio>Any thoughts?
<apteryx>sneek: later tell brettgilio look at the #:include argument of the emacs-build-system. It is a list of regex which determine which files/directories get included. Example: emacs-elpy.
<sneek>Got it.
<apteryx>could someone look at the docker.scm and tell me if they also think there's an issue with the substitute* directives?
<apteryx>for example, I don't see why we want to return the mangled xxec.Command into exec.Command, nor why we would for LooxPath -> LookPath, as the mangling was done purposefully in other match rules.
<apteryx>seems like some debugging that was left in
<apteryx>(this is in the docker package)
<ebrasca>Some help how to enable TOR in GuixSD ?
<nand1>ebrasca: https://lists.gnu.org/archive/html/help-guix/2018-07/msg00082.html
<nand1>(service tor-service-type (tor-configuration (socks-socket-type 'unix)))
<nand1>you can add something like that to services in config.scm
<nand1>and make sure to add "tor" to supplementary-groups
<nand1>for your user
<nand1>that is how you would set up the "socks socket at /var/run/tor/socks-sock"
<ebrasca>nand1: Why unix instead of tcp?
<nand1>I do not know the merits of either option
<nand1>I was more concerned with getting it running
<ebrasca>nand1: How do you connect icecat to unix socket?
<nand1>they describe it in that mailing list thread
<nand1>"Manual proxy configuration"
<ebrasca>I have add tor inside supplementary-groups and apply it.
<ebrasca>But I am not in tor group.
<nand1>oh
<nand1>have you restarted your computer
<nand1>I am not sure when it takes effect
<ebrasca>I don't like to restart , going to search bash comand for it.
<nand1>ah ok
<nand1>I hope it creates the socket file
<nand1>make sure that you can write to that directory
<nand1>where the socket is
<apteryx>about docker, nevermind. It's sequential regexes that are laid out in imperative style
<apteryx>the substitutes* rules that revert some of the patching are needed (part of the logic)
<tune>I see nheko isn't packaged yet. I threw it on the guix wishlist. It's not in the FSD yet either, but I have yet to contribute to that.
***MinceR_ is now known as MinceR
<resttime>I'm curious, is there a reason why the package definitions are part of the guix git repo?
<resttime>I sorta figured they were separate until I found them there
<resttime>(Like distros I'm familiar with have the packages keep them separate and you can point the package manager sources at URLS)
<brendyyn>resttime: yes, this is a good question
<brendyyn>I might not be able to do the best job of explaining iit
<brendyyn>Basically because the project is a whole, not just two separate things, a package manager and packages. It is subject to continuous change and improvement. for example if changes were made to a build system, then all packages of that type may need to be updated
<brendyyn>However, guix has support for channels which allow other package repositories. I hope the guix community will grow as people create their own repositories for things that aren't ideal to have in the main guix distribution
***rekado_ is now known as rekado
<rekado>resttime: package definitions are code, not just data.
<rekado>since they are code we put them where all the other code is that they depend on.
<rekado>this enables us to more quickly change all of the package definitions when underlying components change.
<roptat>hi guix!
<jonsger>hi
***slyfox_ is now known as slyfox
<resttime>brendyyn, rekado, Interesting, makes more sense now
<RRedcroft>Hi guys, ive got a problem installing guixsd
<RRedcroft>Installed fine, but upon first boot i get 'Error: in procedure open-file: No such file or directory "/gnu/store..../sdhci_pci.ko"
<RRedcroft>i did add sdhci_pci to initrd modules
<kmicu>Hi RRedcroft could you share relevant snippets from your config?
<RRedcroft>sure
<RRedcroft>one sec
<roptat>RRedcroft, you probably needed sdhci-pci :/
<roptat>(notice "-" instead of "_")
<roptat>that happened to me quite a few times
<RRedcroft>the installed said to add mmc_block and sdhc_pci
<RRedcroft>how can i change to just sdhci-pci from the installer without doing an init again?
<roptat>I don't think you can: you'll have to modify the config file and init again
<RRedcroft>ok, thanks
<roptat>or maybe you can chroot and reconfigure, but I'm not sure how that will work
<buffet_>i wish i got an error when installing it...
***buffet_ is now known as buffet
<roptat>I agree
<buffet>i also prefered it when i at least had bournish instead of nothing
<jonsger>can someone please run "./configure --enable-installer" on a current checkout of guix master?
<ArneBab>Does anyone have a hint for my maven problems? It does not recognize mirror settings in ~/.m2/settings.xml — does someone else see that?
<vixus>does the default linux-libre guix package not build external modules?
<roptat>what do you mean?
<roptat>it does build most modules, but they are not available in the initrd by default, so if you need a module to access your hard drive where the module is, you're in trouble ;)
<roptat>that's why there is an option in the operating-system declaration to add more modules to the initrd
<vixus>roptat: when I try and build a system configuration using a custom kernel that inherits from linux-libre, it complains about a bunch of the %base-initrd-modules not being available
<roptat>oh
<vixus>when I look at the output of the kernel package I've built, it doesn't have any (useful) modules in lib/modules/
<roptat>I use the linux-libre kernel, so I can't help you :/
<vixus>no worries, I'm trying a plain-old `make` with my kernel config to see what it spits out
<vixus>the `make` build is definitely taking longer than the `guix build` so I suspect it's building more stuff
<roptat>it looks like the linux-libre package does a simple make too
<jonsger> is it not possible to send a mail to a closed bug?
<RRedcroft>how do i include an scm that dedines a new package?
<jonsger>oke, just went through now
<vixus>roptat: yeah running make in the linux kernel source dir built all the modules I expected as .ko files
<vixus>so now to find out why the linux-libre build definition doesn't do this
<vixus>can I "exec" into a package's build environment?
<vixus>oh yes `guix environment <package>`
<vixus>hmm, can I run `guix build` and get it to build the working directory but not actually build anything?
<vixus>and then `cd` into it before `guix environment ...`
<jonsger>civodul: did you saw my message on http://issues.guix.info/issue/35138 ?
<civodul>hello!
<civodul>jonsger: i hadn't seen it
<civodul>weird!
<roptat>now that there is a new version of bap, I'm trying to update it, and maybe we'll be able to get read of ocaml-4.02
<jonsger>civodul: have to leave now. If you find something out, just drop a mail to the bug :P
<vixus>will guix build --dry-run create a build directory?
<roptat>no it won't
<roptat>it's only for listing what it will do
<roptat>would*
<vixus>so it looks like there's no way to set up the build directory for a package
<vixus>it would be handy to be able to stop at a certain phase
<roptat>you can run guix build -K and interrupt a build
<roptat>then it will keep the buld directory in /tmp/guix-*
<wednesday>nckx: Last night I wrote a program to get all the licenses(unique) from all the pypi projects, you get about 3000 random licenses in before people just copy paste the whole gpl and stuff into the license string ha
<vixus_>roptat: good plan
<vixus_>aha
<vixus_>the .config in here has everything turned off!
<civodul>mirror.hydra.gnu.org seems to be unreachable right now
<vixus_>hmm, I think I need to better understand how local-file works
<vixus_>if I use local-file in a package definition, does it get pulled in from where `guix build` is called?
<vixus_>or is it something in the package source
<bavier`>are there not logs for failed builds on berlin.guixsd.org?
<joshuaBPMan>Hello, I'm having some issue where my trackpad only moves up and down. Restarting several times does fix the issue. Does anyone have any pointers (that's a good pun), about haw I can start to fix this issue?
<vixus_>What's the correct way to include a patch in a package (that's not in the original source)?
<brendyyn>vixus_: patches can be put into the guix git repo under gnu/packages/patches/
<vixus_>brendyyn: this is for a custom package (in its own channel) though
<brendyyn>oh
<brendyyn>then i dont know the correct way
<rekado>vixus_: just the repository root will be fine.
<vixus_>so if I have a channel under github.com/vixus0/guix-pkg and a package defined in guix-pkg/vixus/custom.scm, should I have the local-file in guix-pkg/my.patch or guix-pkg/vixus/my.patch?
<civodul>vixus_: i think it should be guix-pkg/my.patch
<vixus_>ok, I'll try that
***amiloradovsky1 is now known as amiloradovsky
<ruffni>hello
<ruffni>my machine crashes while trying to install guix sd. after downloading, just after the step `building /gnu/store/BLA-eog-3.26`. any hints how i can resolve the issue and get guix-sd installed on my machine?
<vixus_>is "eog" eye of gnome?
<vixus_>civodul: looks like it has to be guix-pkg/vixus/my.patch
<ruffni>vixus_: i don't know. the BLA part before is a long ascii string...
***vixus_ is now known as vixus
<vixus>ruffni: yeah that's the package hash. you might want to have a read through a lot of the manual before installing guixsd (I'm finding it confusing enough after having read a bunch of the manual)
<kmicu>ruffni: what did you change in stock config?
<ruffni>i commented out the mapped-devices part (since i'm not using luks) and changed the bootloader to grub-bootloader
<ruffni>and user config, of course
<ruffni>i had a similar issue, when trying to install debian with encrypted SSD on the same machine (just powers off instantly at some point). without LUKS it worked just fine..
<kmicu>What hardware is that?
<ruffni>machine is a thinkpad L412
<kmicu>Does it crash always in the same place (i.e. /gnu/store/hash-eog-3.26) or is that more random?
<ruffni>tried twice, crashes at the same place. should i try again?
<vixus>ruffni: try the bare-bones config to start with?
<ruffni>just before it crashes it lowers kernel.per_event_max_sample_rate (twice) to 50750
<kmicu>ruffni: how much RAM is on that laptop? 2GB?
<ruffni>4GB
*kmicu installed Guix 0.16 on ~3GB laptop w/o issues (with LUKS).
<ruffni>vixus: so.. not commenting out mapped-devices? i thought i strictly followed the installation manual
<kmicu>Using bare-bones config https://www.gnu.org/software/guix/manual/en/guix.html#Using-the-Configuration-System should not pull any Xorg stuff, including Eye Of Gnome.
<vixus>ruffni: if it's installing eog I'm guessing you're using a system config that pulls in a desktop env (Gnome, in this case)
<kmicu>Did you base your config on that or desktop.scm?
<kmicu>(Faulty RAM or a disk could crash your system during high load; bare-bones config requires less stuff so maybe that could pass w/o issues.)
<vixus>can someone please tell me why I can't override "kconfig" in the linux-libre package?
<ruffni>ah right.. i just stupidly followed the instructions (without checking for other contents in /etc/configurations)... trying bare-bones.scm now
<vixus>I've followed all the examples I've found on the mailing list and elsewhere: https://github.com/vixus0/guix-pkg/blob/master/vixus/linux-blobby.scm
*vixus facepalms
<kmicu>This is not the place for blobby questions ;)
<vixus>s/kcconfig/kconfig/g tho
<ruffni>thank you! it worked!
<CornBurglar>Does anyone know where I can find a package for plan9port or 9base
<kmicu>ruffni: glad it worked.
<kmicu>CornBurglar: those packages have not been contributed yet.
<CornBurglar>How does one contribute a package if they write one?
<ruffni>me too! now i installed a desktop (i3-wm) which seemingly succeded (am able to log into graphical desktop). though it raised an exception (maybe due to me running `guix system reconfigure` as root?)....... but no i3-sensible-terminal seems to be installed. any tricks how i can log in directly to console (so i'm able to install some terminal)?
<kmicu>We can send a patch via email https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html#Submitting-Patches
<ruffni>nvm, got it
<kmicu>With Guix System you can boot into a previously working setup in GRUB menu; fix the issue and reconfigure (as root, coz only root can change system stuff).
<kmicu>(There should be also a TTY on ctrl-shift-f{2,3,4,5,6} if I recall correctly.)
<ruffni>ok, did that (thanks!). i (again) get the following error msg:
<ruffni>guix system: error: exception caught while executing 'start' on service 'user-homes': Throw to key 'match-error' with args ...
<kmicu>It would help to see the config. I guess bare-bones lacks some things from desktop.scm to provide a working setup for i3.
<ruffni>i adapted the lightweight window configs from "Using the Configuration System" manual page; but left out ratpoison
<kmicu>Then it must be something else. /me waiting for an i3 user to help.
<vixus>ruffni: I get that user-homes failure too but it doesn't seem to affect using the system
<vixus>I'm not really sure what that service does
<ruffni>no worries, i'll figure it out (or ask again if real trouble occurs)
<Tirifto>Hello all!
<Tirifto>I just installed Icecat with Guix (on Parabola), and it seems keen on using Gentium for its font. Could that be a bug, or is it more likely just lack of setup on my part?
<abcdw>Doing `guix environment --container gcc@8.3.0`, but gcc --version reports 5.5.0. What am I doing wrong?
<bavier`>abcdw: you may want to include the '--ad-hoc' flag
<bavier`>see the manual for the semantics
<abcdw>bavier, thanks, I forgot that env include only inputs by default.
<tortoise>qq
<tortoise>ex/exit
<ArneBab>I have font problems in java: Caused by: java.lang.NullPointerException
<ArneBab> at java.desktop/sun.awt.FontConfiguration.getVersion(Unknown Source)
<ArneBab> at java.desktop/sun.awt.FontConfiguration.readFontConfigFile(Unknown Source)
<ArneBab> at java.desktop/sun.awt.FontConfiguration.init(Unknown Source)
<ArneBab> at java.desktop/sun.awt.X11FontManager.createFontConfiguration(Unknown Source)
<ArneBab>can I fix that easily?
<civodul>who knows!
*civodul hadn't seen a Java backtrace in a while :-)
<civodul>ArneBab: perhaps you can strace it and see why it fails to read/write its fontconfig file?