IRC channel logs

2019-03-07.log

back to list of logs

<fosterite>Hello, I am trying to install guix 0.16 on a machine behind a croporate firewall. I figured out how to tell guix-daemon to use http but I am getting a failure in guix system init
<fosterite>specifically, git fetch https savannah
<ng0>there's http_proxy, but not https_proxy iirc. that was an issue in the past, maybe someone has more recent experiences in guix behind firewalls.
<ng0>(past meaning I last tested this at least 2 years ago)
<fosterite>I came across the "https proxies not supported" message, I'm just using http://hydra for substitutes
<ng0>I think most of the substitutes servers redirect to https
<fosterite>Possibly, but it worked
<ng0>hm?
<fosterite>giving the daemon a --substitue-urls=http://... worked to avoid the https issues
<ng0>ah. ok
<fosterite>Is there a way I can monkey-patch my guix to not use https (I think ssh like git@web.site would work)?
***vagrantc_ is now known as vagrantc
<ng0>look into modifying the daemon config. I can't give you examples right now, have to go
<ng0>%defaults-substitutes-urls or what it was
<fosterite>thanks. I've already done that, guix-daemon works and I have all the substitutes I need.
<fosterite>It's (git-fetch "https://git.savannah.gnu.org/r/guix.git") that's failing
<fosterite>I think updating line 125 of gnu/packages/package-management.scm would do it
<ebrasca>Linux 5.0 ...
<vagrantc_>exciting stuff.
<fosterite>I manually converted it to http, but now it can't find git.savannah.gnu.org. `host` and `dig` are not present
<fosterite>how do I debug my DNS?
<fosterite>clearly it is mostly working because guix-daemon can use it
<ebrasca>GuisSD is updating very fast.
<ebrasca>How?
<fjascovich>Hi everyone, I have a simple question. I'm really a beginner with guix. I have installed it using binary on top of Arch. My question is, how can I install (and run) Xorg using guix on a "foreign" distro? Is this possible?
***catonano_ is now known as catonano
<mikadoZero>fjascovich: Take a look at this section of the Guix manual 4.2 Invoking ‘guix package’
<mikadoZero>fjascovich: 4 Package Management of the manual would also be good to look at.
<fjascovich>mikadoZero: I have installed packages, such as Xorg, slim, lightdm (and the greeter) but my question really is how can I start dm from packages installed with guix
<fjascovich>right now I can use installed packages without problems. But regarding dm, using a regular os package manager (pacman for this example) starting the manager requires start a systemd service as root.
<mikadoZero>fjascovich: I am working from a tty and do not use a display manager. You could just start what you want with .xintrc and startx https://wiki.archlinux.org/index.php/Xinit C-M F1 through F6 to get to a login prompt and use startx from there. C-M F7 to get back to your graphical environment.
<fjascovich>mikadoZero: under what guix package could I install startx?
<fjascovich>mikadoZero: I found it, it was under `xinit`. Now I can invoke X using startx
<fjascovich>thanks
<ebrasca>Hi
<ebrasca>I need help with "gpg: signing failed: No pinentry"
<ebrasca>I have (pinentry) 1.1.0
<ebrasca>I am in GuixSD
<fosterite>is it normal for `guix system init` to take hours
<bavier>fosterite: it can, depending on the os configuration
<fosterite>I'm just using the default desktop with gnome deleted, thought it would be pretty quick
<fosterite>and of course I didn't enable verbose output
***vagrantc_ is now known as vagrantc
<roptat>hi guix!
<g_bor>hello roptat!
<g_bor>I have a fix for neovim and will send a patch to guix-patches.
<g_bor>it was a bit more intricate than I thought, and there is still something up
<g_bor>with the neovim build.
<roptat>ok
<g_bor>roptat: I would like to share with you some information on that.
<roptat>sure
<g_bor>We were dealing with two independent segfaults.
<roptat>oh
<g_bor>Somehow the curses version leaked in, and it seems that unibilium is not found reliably in the build system.
<roptat>what's unibilium? I thought we didn't use it?
<g_bor>So the first bug I found was in the curses version, where a returned -1 error was passed in as a pointer. That is fixed by the patch I sent.
<roptat>I just received it, yes
<g_bor>roptat: I also thought that, but it turns out we would like to use it, but not always succeed. It's a terminfo library.
<roptat>ah
<g_bor>The other thing was, that unibilium<2 is broken by ncurses 6.1
<g_bor>Debian noticed that.
<roptat>so we need to update terminfo, right?
<g_bor>So now it seems that neovim is fixed on both curses and unibilium, so there is no segfault.
<g_bor>I've just updated unibilium, so it's ok now.
<roptat>ah cool
<roptat>so what's missing?
<roptat>btw https://github.com/nvim/neovim/issues/9687 is a 404
<g_bor>oops...
<g_bor>I guess it should be neovim/neovim...
<g_bor>yes, it's a typo. It's https://github.com/neovim/neovim/issues/9687
<roptat>so, we only need that patch to make neovim work again, no?
<g_bor>roptat: yes, it seems so.
<g_bor>also, it is not deterministic, so I would like you to test it.
<roptat>oh?
<g_bor>I might get a correct neovim only by chance...
<roptat>ok, I'll try
<g_bor>it would be interesting to find out why neovim is not reproducible in the first place...
<g_bor>ok, I had a look with diffoscope, it seems that part o the reproducibilityproblem might be inherited from vim. It seems that there are some string ordering issues
<roptat>g_bor, your patch worked on my computer :)
<g_bor>ok, the I will push it.
<g_bor>I already created two different versions, both working here.
<g_bor>roptat: one more thing, does the commit message look right to you?
<g_bor>I guess it's ok.
<roptat>"Partially fix" doesn't look right
<roptat>also I think the explanation is usually between the title and the list of changes
<g_bor>ok, I belive it can be fix, and we can close that issue.
<g_bor>Ok, I will move it there.
<roptat>also, I would have said "Add 'patch-tic phase."
<g_bor>ok
<g_bor>I am still in discussion with upstream, but it seems that the fix will be included in the next maintenance release, which is due in two weeks.
<rekado>g_bor: could you please also post to https://issues.guix.info/issue/34616 ? It would be good to track the state of this bug there and not only in IRC.
<g_bor>rekado: of course.
<g_bor>I've just push the patch. I also added a comment to remove the fix when not needed any more, with a link to the issue.
<g_bor>rekado: do you think that any more information is needed?
<g_bor>rekado: I belive I will file a separate bug for neovim not reproducible.
<rekado>sounds good. Thanks!
<nly>Can someone guide me about what might be the cause, or meaning of this message? "struct_vtable: Wrong type argument in position 1 (expecting struct): #f"
<nly>Message: http://nly.info.tm:9001/error/struct_vtable.txt
<nly>File in quesion:http://nly.info.tm:9001/guix/termux.scm
<catonano>nly: it seems you called package->termux-package with something that is not a record
<catonano>nly: precisely at line no. 91, column no 53
<nly>thanks
<civodul>Hello Guix!
<janneke>o/
<nly>in package bzip2 uri looks like '(string-append "https://web.archive.org/..." "http://www.bzip.org/")?
<catonano>nly: you're welcome
<civodul>rekado: i'm presenting Guix-HPC (what's done and what's next) to the bosses later today...
***jonsger1 is now known as jonsger
<rekado>civodul: oh, good luck! You got this!
<civodul>rekado: yup, we'll see how it goes
<rekado>I’m unhappy with the lack of progress wrt to GNOME upgrades.
<rekado>I just rebased the wip-gnome-upgrades branch on top of staging, will build gnome-shell (because there were a bunch of merge conflicts), and will then push it to staging.
<rekado>otherwise I fear we’ll forever be stuck with whatever old version of GNOME we have now.
<g_bor>hello guix!
<roptat>g_bor, I don't know if you're still interested in i18n of free software (in general, and for guix), and I don't remember if I've sent you this: https://89.234.186.109/l10n/ (sorry, the certificate is broken)
<roptat>it's something I did last year
<roptat>I'm still thinking about creating a place where we could welcome contributors, give them more info on how to translate their favorite software and collect stats on languages (just like I did in that link, for android apps)
<roptat>I'm also trying to continue development on stringlate, as it was stopped by its author
<roptat>I think it's a great app, and I have a lot of ideas on how to improve it further
<g_bor>roptat: wow, this is nice.
<g_bor>I like it.
<g_bor>rekado: what should be done with gnome-updates?
<g_bor>roptat: the patch made to neovim upstream
<roptat>yes, I saw that :D
<efraim>rekado: I like that idea
<roptat>you're awesome, for an emacs user :p
<efraim>I looked at stringlate but was more interested in desktop software
<roptat>then you'll be interested in my offlate :)
<roptat>although it's less useful: https://framagit.org/tyreunom/offlate
<roptat>and the code is actually less nice
<roptat>but I don't have all the time I'd like to work on all these projects :/
<g_bor>:)
<g_bor>nice :)
<roptat>I use it for guix translations
<g_bor>google offers to translate this page for me :)
<roptat>but I'm not very happy with it
<roptat>one issue is that it uses qt :/
<g_bor>roptat: I am not opposed to qt.
<roptat>it's making using diacritics very hard for me
<efraim>I've actually signed up as a Hebrew translator with GNU 3 times now I think, still uncertain about actually translating things
<efraim>Every year I think its a good idea and resubmit
<g_bor>rekado: nice catch.
<g_bor>thanks for fixing up that phase.
<roptat>efraim, do we have an Hebrew translation for guix yet?
***atw` is now known as atw
<efraim>roptat: not yet
<efraim>Not sure if my technical Hebrew is up to the task
<efraim>But I guess I won't know if I don't try
<joshuaBPMan>Hello, it is possible to symlink packages from /gnu/store to /usr/bin? Or is this not really desirable?
<roptat>joshuaBPMan, it's not really desirable
<roptat>if packages from the store reference /usr, it's a bug
<roptat>and anyway, packages outside of guix shouldn't hard-code references to dependencies
<roptat>so it would hide actual issues
<roptat>but you can always do something like ln -sv /run/current-system/profile/bin /usr/bin
<roptat>(assuming you're on the guix system)
<joshuaBPMan>roptat: That would work.
<joshuaBPMan>Actually I have a question now. How do shell scripts run on guix?
<roptat>now you have bin in other profiles, if you want them too, it's going to be more complicated
<roptat>the guix system only has /bin/sh as a symlink to the default shell
<roptat>so the shebang should be #!/bin/sh
<joshuaBPMan>ok.
<roptat>you could also add /usr/bin/env, which is what nixos does
<notnotdan[m]>i guess having /usr/bin/env is quite practical at the end of the day
<roptat>actually from the guix system, you can use http://guix.info/manual/en/Base-Services.html#Base-Services
<notnotdan[m]>even though it's strange that scripts hardcode paths to interpreters like that
<roptat>see special-files-service-type and extra-special-file
<roptat>/bin/bash is quite common
<roptat>ah so /bin/sh is not a symlink to the default shell, but to bash's sh
***renich_ is now known as renich
<rvgn>Does guix lacks sandboxing in contrast to flatpak?
<bavier`>rvgn: guix sandboxes every package build
<isengaara-tomoko>flatpack claims to have sandboxing at run time
<isengaara-tomoko>but guix also has containers
<nckx>Guix doesn't suffer from this limitation.
<rvgn>Ah! I see.
<rvgn>So to use sandboxing in run time with guix, containers are only go. Correct?
<vagrantc>hrm. on a foreign distro, i tried using "guix environment guix" to build guix from git ... but the resulting build seemed to include things from the host environment ... do i need to use "guix environment --pure --container" to make sure only guix dependencies are used?
<rvgn>TBH, after using guix for a while and when I came across "Package Management of the Future" under flatpak site, I couldn't control my laughter. XD :D
<bavier`>vagrantc: yes
<vagrantc>also, i consistantly get 3 test failures with gexp when i run make check, foreign distro of guixsd
<bavier`>rvgn: you can run applications inside a `guix environment --container`, though some applications need a little tweaking for them to work
<vagrantc>foreign distro or guixsd
<ebrasca>I need help with "gpg: signing failed: No pinentry"
<ebrasca>I am in GuixSD and I have (pinentry) 1.1.0
<roptat>ebrasca: you need to set pinentry-program in one of the files in ~/.gnupg. I can't remember which one precisely beacause I'm on my phone
<rvgn>bavier` I see. Glad to see that guix containerization exists.
<roptat>It should point to ~/.guix-profile/bin/pinentry-something
<ebrasca>roptat: I have "pinentry-program /home/ebrasca/.guix-profile/bin/pinentry-tty"
<ebrasca>roptat: In gpg-agent.conf
<nckx>ebrasca: And are you using the agent?
<nckx>(i.e. do you have ‘use-agent’ in gpg.conf?)
<vagrantc>anyone know what variables to set to get w3m to use the nss-certs directories/files from my profile on guixsd
<vagrantc>?
<nckx>There's almost certainly a way to use pinentry-tty without the agent but I don't know it.
<ebrasca>nckx: I don't have ‘use-agent’ in gpg.conf.
<rekado>bavier: I’d be happy if you could take a look at the openmpi change I suggested. I don’t think it breaks anything. No rush, though.
<vagrantc>SSL_CERT_FILE and SSL_CERT_DIR were just pointing to the system directories, which had little to nothing in them. but then pointing to the cert directory/file in my profile didn't work either
<nckx>ebrasca: Then either add it (to use the agent) or, well, see if gpg.conf supports a pinentry stanza on its own, I guess.
<ebrasca>nckx: Can you give me one example of use-agent?
<nckx>ebrasca: I'm not sure what you mean.
<nckx>tail -n1 ~/.gnupg/gpg.conf
<nckx>use-agent
<nckx>^ That's it.
<ebrasca>nckx: My ~/.gnupg/gpg.conf is empty ...
<nckx>Again, this is just my config, not the only working config.
<nckx>ebrasca: echo use-agent > ~/.gnupg/gpg.conf ;-)
*nckx → AFK.
<jackhill>Shold I, as a regular user on Guix System have GUIX_PROFILE set? I'm troubleshooting a problem where GIT_EXEC_PATH=/home/jackhill/.config/guix/current/libexec/git-core
<jackhill>libexec doesn't exist in that profile. Presumable it should be ~/.guix-profile/libexec/...
<jackhill>I'm sourcing .guix-profile/etc/profile in my .bash_profile
<rekado>what is GUIX_PROFILE set to?
<rekado>it looks like you set it to “guix pull”’s profile, which is not correct.
<rekado>$HOME/.config/guix/current is where Guix itself is stored.
<rekado>no personal packages end up there.
<jackhill>rekado: /home/jackhil/.config/guix/current
<rekado>that’s not correct.
<rekado>why does it have this value?
<jackhill>I'm not sure. Let me log out and back in to double check
<jackhill>yes, when I log in on a linux-libre virtual terminal, it gets set to that. I don't see where in my dotfiles that is happening. If I open a screen in that virtual-terminal it is not set (but since that's not a login shell the profile does not get sourced again).
<jackhill>I can try setting it to ~/.guix-profile
<jackhill>rekado: explicitly setting it worked. yay! I wonder what ghosts were causing the previous behavior...
*rekado has trouble typing after trying a new recipe and burning four fingers…
<jackhill>:( did it at least taste good?
<rekado>pizza was great, but I kept touching the pan that had just come out of the hot oven.
<rekado>good recipe, though –> https://www.seriouseats.com/recipes/2013/01/foolproof-pan-pizza-recipe.html
<Welkin>program using speech-to-text
<Welkin>close-paren close-paren close-paren close-paren close-paren close-paren
<jackhill>cool, and I appreciate the help
*nckx 😃
<rekado>Welkin: I was going to set this up, actually. But with a special “command language” to navigate.
<rekado>(no need for “close-paren” as I’d slurp and barf with paredit)
<Welkin>there is a really cool video I saw about some person who used speech-to-text for programming when he got RSI
<rekado>yes! That’s why I wanted to try this.
<Welkin>he would write code using noises like "click pop up slap" or something haha
<rekado>it used a Windows-only propriatary speech recognition software, though.
<rekado>IIRC it also involved a virtual machine
<Welkin>if you use high level languages it's less of an issue of course. Less typing going on
<Welkin>rekado: Dragon I think it's called
<rekado>this exists: http://voxhub.io/silvius
*rekado packages it for Guix
<bavier`>rekado: I've wondered how projects like that would work for packaging in guix.
<bavier`>do we package the pretrained models?
<rekado>bavier`: I guess so, but I’m not sure.
<rekado>I don’t think it’s feasible to retain the models.
<rekado>I see it as a case similar to game data.
<rekado>we don’t aim to regenerate all game resources but treat them as given artefacts.
<CornBurglar>Hey, I'm trying to develop a WM and my OS is GuixSD, I'm struggling to test it. I've tried to add the wm to my .xsession file but it seems that the existence of any .xsession file causes login to not work for any of my normal login options. Anyone have any idea why this would happen or how I could otherwise add my wm to the options offered by SLiM
<CornBurglar>without packaging the software?
<bavier`>rekado: right. I had in mind an article from RMS that I read a while ago related to this topic, but I can't find it
<bavier`>with respect to the idea that with AI models, changing the software now means augmenting the data and retraining.
<rekado>CornBurglar: is the .xsession file executable? It should be.
*rekado has used a .xsession file for a long time without problems
<CornBurglar>I may not have made it so, let me try
*rekado updates all CRAN packages
<tortoise>The problem was that .xsession wasn't executable. Thanks for help