IRC channel logs

2018-09-02.log

back to list of logs

*ecbrown bumped up the default gcc version, and instantly regretted it
<emacsomancer>when guix lint reports "tabulation on line 19, column 0" what does it want me to do exactly?
<samplet>emacsomancer: Use spaces instead of tabs, I think.
<atw>emacsomancer: how's the package coming?
<emacsomancer>samplet: ok, it's a little opaque under the circumstances, but trial-and-error may be revealing
<emacsomancer>atw: okay - I picked what I thought would be an easy first one, but it wasn't so easy
<atw>good luck!
<emacsomancer>atw: thanks!
<ecbrown>anyone know if mips arch is 64 bit only?
<ecbrown>well, anyway, compiled a code that requires OpenBLAS with INTERFACE64=1
<ecbrown>setting that, i can get it to compile link run
<ecbrown>but i don't know what would happen on other architectures, including 32-bit, arm, mips, etc
<ecbrown>i also wonder how the precompiled openblas deals with the MAX_PARALLEL_THREAD-type parameters, which are usually set to be that of the compiling machine
<ecbrown>might not be relevant to machine its running on
<amz3>hello #guix
<janneke>hi amz3
<efraim>ecbrown: yep, our mips is 64-bit, little endian
***jonsger1 is now known as jonsger
<mbakke>efraim: Have you had the chance to try core-updates on AArch64 yet?
<ecbrown>efraim: thanks
<efraim>mbakke: I built to hello yesterday
*ecbrown is on the hunt for latex2html
<mbakke>efraim: Great. I'm thinking of starting it "proper" on Hydra once it's done with NSS.
<ecbrown>mbakke: sorry to bug you, but i don't see "maintainers" listed, just most recent contributest to gcc.scm
<ecbrown>i'm wondering if the "other" compilers such as gfortran and gcc-objc++ an be updated just by copying gfortran 7 and making them gfortran 8
<mbakke>ecbrown: Sorry, I must have missed some context. What are you looking for in there? :-)
<mbakke>ecbrown: The package definitions are inherited yes.
<mbakke>But they have their own (source ...).
<ecbrown>i'm just curious why gcc 8 is provided, but only gcc 7 for the additional compilers
<mbakke>ecbrown: It would be great to get gfortran 8 and friends in, I forgot all about those when adding GCC8 :-)
<ecbrown>i was able to copy gfortran7 to make an gfortran-8
<ecbrown>yeah, that's what i figured
<mbakke>ecbrown: Excellent. Please send the patch when you are done!
<ecbrown>just wanted to confirm that e.g. "gfortran from version 8 is split out from gcc" or other such declarations are not in play
<ecbrown>i can do that, on my list.
<ecbrown>basically trying to get OpenMOLCAS and Dalton quantum chemistry programs into Guix, what with their new love of GPL
<mbakke>ecbrown: Not to my knowledge. But then I didn't read the release notes in a while: https://gcc.gnu.org/gcc-8/changes.html
<mbakke>ecbrown: Woah, sounds great!
<ecbrown>the next issue that i am working on is OpenBLAS
<ecbrown>in particular OpenMOLCAS requires 64-bit interface to OpenBLAS, INTERFACE64=1
<ecbrown>i am supposing that it sets -m32 or -m64 to fortran compiler
<ecbrown>or real is assumed to be real*8 or something
<ecbrown>but i have no idea what inserting INTERFACE64=1 behind e.g. DYNAMIC_ARCH=1 will do to any other packages that use OpenBLAS, which i suspect is high
<ecbrown>(my local changes where I add this and tell dalton to use int64's worked, and openmolcas compiles with this addition on amd64)
<mbakke>ecbrown: If it breaks things, it might be better to add an "openblas/interface64" package variant which adds the flag.
<ecbrown>thats what i was thinking.
*ecbrown launches ./pre-inst-env guix build gfortran@8 gcc-objc@8 gcc-objc++@8
<ecbrown>while that's running, i need to study cmake builds. i see some examples in the kde packages. (i'm wondering if it automatically makes a "build" directory, i.e. does out of source builds)
<ng0>studid question: is the language of gtk applications like firefox and libreoffice controlled by the locale set, or do they need additional language files?
<ng0>I'm mostly working with everything in en_US, but I forgot how to change it for friends. some friends only know Libreoffice in German for example
<ecbrown>is there essentially a "boilerplate" for someone who discovers guix, goes about installing from install.sh script, and then starts installing packages, needs to modify .bashrc/.bash_profile correctly, deal with locale bitching, but also being warned to guix pull
<ecbrown>i.e. there is some very important and good information relegated to footnotes in the manual!
<ecbrown>and also still curious about correct order of guix's recommended PATH
<ecbrown>for example, i just pile all my bashrc shit in .bashrc and call that with .bash_profile. (I thought everyone did this) but the section on guix environment suggests that maybe PATH should be in .bash_profile and env variables in .bashrc
<ecbrown>like CA_CURL_BUNDLE and whatnot
<ecbrown>and in fact i notice a difference, like --pure environments really are pure, which heretofore i had never got right
*ecbrown supplies obligatory "contributions to the documentation welcome" retort
<mbakke>ecbrown: Lol :-) I agree improvements are needed, the binary tarball instructions confuse everyone.
<mbakke>ng0: Setting LANG should work, no?
<mbakke>ecbrown: I think all CMake builds are out-of-source.
<ecbrown>mbakke: thanks for confirming, that's what i'm hoping
***jonsger1 is now known as jonsger
<ng0>mbakke: ok?
<ng0>idk
<ng0>it's not intended to work like LANG=de_DE.utf8 libreoffice
<ng0>same for firefox
<ecbrown>ugh building gcc-objc++ on four cores
<ecbrown>i fondly recall the days when i had a 40-core beast
<ecbrown>it cut through gcc like butter
<ecbrown>i know it will work, i just have to wait :-(
<civodul>channels are in the house!
<pkill9>nice :)
<ecbrown>lol
<ecbrown>mbakke: i've submitted patches to 32612@debbugs.gnu.org
<ecbrown>(gfortran, gcc-objc, and gcc-objc++ updated to 8.2)
<apteryx>hello, do we have a package which provides jpegtrans? It's used by Emacs' dired-image to rotate images.
<apteryx>s/dired-image/image-dired/
<vagrantc>whoah. guix channels!
<ecbrown>am i reading this right, if you want to follow a putative Guix 'stable' one could specify channels.scm to follow that git branch
<ecbrown>...and any old person with a git repo can make their own channel
<ecbrown>"a den of scum and villany"
<vagrantc>something along those lines ... though of course, you could always do this simply by pulling from some other git branch
<ecbrown>Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
<ecbrown>guix pull: error: Git error: cannot locate remote-tracking branch 'master'
<ecbrown>
<ecbrown>i just put in guix savannah repo and (branch "master")
<dadinn>hi all
<dadinn>i am trying to extract the tar for binary install and i am getting lot's of errors saying cannot mkdir: Permission denied
<ecbrown>dadinn: maybe you need to be root?
<ecbrown>dadinn: or sudo?
<vagrantc>or extract the tarball in a directory you have write permission to
<dadinn>I am running inside a vm with a Debian host... i use sudo
<dadinn>i see some files getting extracted, in var/gnu and some in gnu/store (40-50 or so files)
<ecbrown>what happens if you do it as root?
<dadinn>in the store there are some directories for packages put everything is empty
***rekado_ is now known as rekado
<rekado>ecbrown: this is not a pretty blog post, but it shows how to get started with the picture language: https://elephly.net/posts/2018-09-01-guile-picture-language.html
<rekado>civodul: yay for channels! Thanks!
<vagrantc>dadinn: are you following these instructions: https://www.gnu.org/software/guix/manual/en/html_node/Binary-Installation.html#Binary-Installation
<dadinn>vagrantc: yes
<dadinn>i actually get some errors with the signature verification
<vagrantc>you shouldn't extract the tarball with a bad signature
<vagrantc>could be a corrupt download, or worse, a compromised download
<dadinn>i have been doing this before and the signature is usually bad...
<rekado>dadinn: are you perhaps misreading the error message? The signature should be good, but you might not trust the key.
<ecbrown>rekado: awesome!!!!!!!
<ecbrown>one small change is to cd into pict before wgetting
<dadinn>rekado: you might be right, I am trying to add the key with gpg --recv-keys and it fails
<ecbrown>what does the error to that say
<ecbrown>do you have to sudo apt install dirmngr
<dadinn>it says: failed to start dirmngr
<ecbrown>right, you need to add it ----------^
*ecbrown suspects dadinn is off to the races
<dadinn>thx, it works now
<ecbrown>:-)
<vagrantc>dadinn: you installed without recommended packages?
<ecbrown>it's easy to make a debian without dirmngr
<vagrantc>kind of makes sense, if you're going to use guix for all your actual packages
<ecbrown>like, superminimal
<vagrantc>ecbrown: it's easy, it just means you installed gnupg without installing it's recommends.
<ecbrown>right, just saying selecting only ssh server will put one here.
<vagrantc>which is a non-default configuration... which is getting off-topic here :)
<dadinn>ecbrown: debootstrap, and suggested packages turned off from the beginning
<ecbrown>rekado: is (cellophane ...) the "transparency"
<ecbrown>?
<ecbrown>i think it is!!!
<wigust>Do somebody have a script to search for a package in all inputs? I cannot upgrade for a long time because somewhere qtwebkit is used in a graph of my manifest.
*ecbrown notes that i can't put savannah guix in channels.scm, but a bitbucket clone does
<ecbrown>work
<ecbrown>oh wait, sorry, same error
<pkill9>wigust: try this, i just made it up on the spot, i'm not very experienced though so it might not work:
<pkill9>for i in $(guix package -I | awk '{print $1}') ; do guix graph $i | grep -q qtwebkit && echo $i ; done
<pkill9>basically it echos eveyr package that it find 'qtwebkit' in the output of `guix graph <packagename>`
<pkill9>and checks that for every package installed to the user profile
<ecbrown>i think i see that (branch "master") doesn
<ecbrown>t work on my system, but (commit SHA) does work
<wigust>pkill9: It works. Thank you. (I found python-pyqt which ‘gns3’ wants as I remember)
<ecbrown>i'm pleased that i can actually stop the guix merry go round with this wonderful channels
<pkill9>is there an api reference for the build servers? i remember there being one but i've completely forgotten where it might be
<ng0>what would errors look like which are caused due to the /gnu/store size?
<ng0>asking for science.. and because my store is reaching a size where I should consider cleaning up generations of profiles and systems
<pkill9>ng0: my experience is that when compiling or download, guix will just error out with 'no space left'
<pkill9>downloading*
<ng0>i did not ask for full disks
<ng0>this is a harddisk where there's still space, but the store is 600+ GB
<pkill9>oh
<ng0>yes :)
<rekado>ng0: it’s easier to do this the other way around: do you get error messages? We can’t easily guess.
<ng0>I'm still trying to figure out if I introduced an error on my own in the package
<ng0>I'll get back to you tomorrow. until then I should have it figured out
*pkill9 is giddy from reading the guix channels info page
<pkill9>this will bring many possibilities
<efraim>OOM while building eigen on aarch64
<civodul>Eigen/C++ is terrible
<civodul>efraim: do you know where i could buy a replacement for the OverDrive PSU?
<civodul>it's a CFI-s150x, but i can't seem to find such things for sale on the intertubes
<efraim>civodul: https://tooot.im/@efraim/100657971706648755 here's how I have mine working
<efraim>24pin DC ATX PSU 12V DC Input 250W Peak Output Switch DC-DC ATX Pico PSU MINI ITX PC Power Supply For Computer
<efraim> http://s.aliexpress.com/MBVFZbq
<efraim>maybe something like that, but not sure how to hook it up to a 220V->12V converter
<efraim>hmm that link didn't work at all for me
<efraim> https://m.aliexpress.com/item/32826517978.html?shortkey=MBVFZbqI&addresstype=600
<ng0>okay. it's definitely a bad input I've added.
<jonsger>efraim: https://tooot.im/@efraim/100044979985539819 there was something on Phoronix that they planning a Talos board at ATX form factor...
<civodul>efraim: hmm, that's 12V DC input?
<efraim>not sure about the actual size but this looks like it would also work, and should arrive in fewer than 3-6 weeks https://www.amazon.com/dp/B01M6V8O8T/ref=psdc_1161760_t1_B004575F72
<efraim>yeah, the aliexpress one was 12V DC
<civodul>ok 220V AC would be more convenient :-)
<efraim>the amazon one has all the connectors of the original with an extra FDD connector
<efraim>i don't have a tape measure to check if it'd actually fit inside the box
<efraim>measuring it against my hand it looks like the overdrive one is 7"x2"x2"
<civodul>also it's 150W
<efraim>yeah,
<efraim>all the rails provide at least as much power as the 150W so it shouldn't be underpowered
*efraim heads off to bed
<civodul>maybe this: https://www.amazon.com/Electronics-ENP-2220A-200-Watt-approved-Approved/dp/B004575F72/ref=sr_1_4?s=electronics&ie=UTF8&qid=1535920041&sr=1-4&keywords=atx+psu+200W
<j3kyl_>hey guys is guile sort of ubiquitous? as it seems some gnu tools require it as dependency...
<j3kyl_>I am kinda bored of python I want to do more LISP for system software scripting...
<rekado>j3kyl_: s/guys/folks/ :)
<rekado>j3kyl_: yes, Guile is a general purpose language.
<rain1>give it a go j3kyl_!
<j3kyl_>rekado: sorry, I mean, if I am safe thinking that most famous server distros has guile package available
<j3kyl_>rain1: having been kiding with elisp and lisp got me ...hehe
<rain1>:)
<rain1>they do but some have an older version of guile
<rain1>which can be a problem, but you can easily build the latest version from source
<j3kyl_>rain1: indeed. compiling must be easy. still, I hope that most distro has it packed. I will do a litte research!
<rekado>some distros still have Guile 1.8 packaged, which is very old and very different.
<rekado>You can get the latest version of Guile with Guix, though ;)
<j3kyl_>rekado: guix rocks
<j3kyl_>Guile 2.0 on centos, rhel and debian ...is 2.0 that different of 2.2?
<rekado>it’s slower and has a few known bugs. But it builds faster and compilation requires less memory.
<j3kyl_>hum...
<j3kyl_>THIS: https://www.gnu.org/software/guix/blog/2018/tarballs-the-ultimate-container-image-format/
*rekado updated issues.guix.info, “submitter:who” should work better now.
*rekado —> zzZ
<ecbrown>tar has become the new jar!
<j3kyl_>hehe...
<ecbrown>or should i say uberjar
<j3kyl_>:D
<j3kyl_>oooh, guix makes one realize how much time we wasted dealing with annoying dependencies... I hope it makes for mainstream servers
<Gnubian>hi to all
<j3kyl_>hi
<j3kyl_>my humble vision about distro: its cool to have distro with different approaches but as for packagment its not cool at all having to learn about rpm,deb... I think guix, nix, flathub and that from ubuntu are clever solutions
***daviid is now known as Guest75565
<apteryx>updating just the description of a core package won't trigger a world rebuild, right?
***Guest75565 is now known as daviid
<apteryx>(answer: right)