IRC channel logs

2018-07-21.log

back to list of logs

<atw>getting closer on building Agda! I do think I'm making a lot of beginning-packager mistakes
<vagrantc>so, i've got a guix install on debian from 0.13 or 0.14 ... how should i upgrade to 0.15 for a foreign install?
<vagrantc>oh, nevermind ... i apparently don't actually have anything installed anymore
<vagrantc>ok, so i've got a guixsd 0.14.0 from december ... trying to update to guixsd 0.15.0 ... guix pull seems to be crashing ...
<vagrantc>i recall on another machine needing to first pull some specific commit and then pulling up to a current version ...
<vagrantc>also trying to pull to v0.15.0 since supposedly the substitutes ensure that tagged versions don't get garbage-collected?
<vagrantcish>ERROR: In procedure scm-error:
<vagrantcish>ERROR: invalid build result (#<derivation /gnu/store/sfzsj5bb5l0gdya6lckkbhnc49m3xbx2-compute-guix-derivation.drv => /gnu/store/sdhn61xfyhzp2yd2993m9rm3mkgj1wgs-compute-guix-derivation 41fec30> "")
<A87221>Trying to build a Perl module that is looking for "limits.h". How to install kernel-headers in guixsd? (The "/gnu/store" directory seems to have odd permissions, breaks some things.)
<A87221>How to install kernel-headers in guixsd?
<vagrantc>ACTION works around upgrading from guixsd 0.14.0 to 0.15.0 by reinstalling
<mbakke>So I've added a "bin" output to MariaDB to reduce size. How do I use that in the system service?
<cbaines>mbakke, first I'd check what happens if you run the system test
<cbaines>I'm guessing it uses the "out" output by default
<snape>cbaines: hey! the gitolite service review is on my todo list :-) I'll try to do it this week-end
<cbaines>snape, that would be great
<cbaines>I was just looking at it again now, but I can't get the system test to run :(
<snape>ouch
<cbaines>when I run make check-system, I get gnu/tests/install.scm:212:2: Unbound variable: system-disk-image
<snape>cbaines: you can try to clean the .go files, maybe
<snape>at least the ones that are in gnu/tests
<cbaines>I think the issue was actually something to do with guile-sqlite3, I've now installed that in my users profile, and it seems to work now
<snape>cool!
<mbakke>civodul: I'm slowly building my way to the system test (I'm on a highly divergent staging branch :P)
<mbakke>Unfortunately qtbase failed to detect this mysql (but built nevertheless!), but I suspect it just needs mariadb:bin as a native-input.
<snape>(civodul isn't here)
<A87221>How to install kernel-headers in guixsd?
<ng0>they are provided through linux-libre-headers
<TSholokhova>Hello! I have a problem with guile. Can you please help me? I'm calling the function (with-critical-section db-channel (db)...) in (let* ...) several times. I am trying to fix this. So, I tried to put (with-critical-section db-channel (db) around (let* ...) and I recieved an error: ``` In web/server.scm: 279:25 0 (_) Throw to key `vm-error' with args `(vm-run "Too few values returned to continuation" ())'. ```
<qwertasd>I'm trying to define a package for https://github.com/Airblader/i3. I'm little lost with dependencies and building it. Can someone help me with it?
<ng0>you can simply use inherit from the i3 package we have. well. simply could not be simply if that's your first package :)
<ng0>maybe searching in the repository for "inherit" in gnu/packages/ directory is already enough to get you started?
<ng0>I have no time right now to help you, maybe someone else
<A87221>ng0 -- thanks, merci
<brendyn>qwertasd: pastebin your code and show any errors you get and we can help
<qwertasd>brendyn: well my code isn't even ready to be tested. I got stuck with the build-system. Here are the instructions for compiling i3-gaps. https://github.com/Airblader/i3/wiki/Compiling-&-Installing
<brendyn>qwertasd: isn't it built the same way i3 is?
<EuAndreh[m]>The documentation points to `pre-inst-env`, but it doesn't exist in the root of the repo. It does exist under build-aux, but it's not complete nor executable
<brendyn>EuAndreh[m]: it will exist after running ./bootstrap
<brendyn>run `guix environment guix` first, then bootstrap
<qwertasd>brendyn: yes I guess
<EuAndreh[m]>brendyn: Thanks
<brendyn>qwertasd: so what you can do is simply inherit i3's definition
<brendyn>qwertasd: it's easier than you think
<brendyn>(define-public i3-gaps (package (inherit i3) (name "i3-gaps"))
<qwertasd>brendyn: oh, I will try
<atw>ng0: I read in https://debbugs.gnu.org/cgi/bugreport.cgi?bug=31250 that you started on a leiningen packaging effort?
<atw>I'm interested in helping but I lost the plot on the state of maven packaging
<ng0>atw: I did? Well I have lots of construction sites.
<ng0>at the moment of the languages I've picked up is Erlang, Elixir and Phoenix Framework, whic his why I'm looking into how beam modules can be packaged for example
<ng0>I'd rather leave Leiningen to those more involved with the languageā€¦ but eventually I would get back to it
<ng0>We (infotropique) almost have a fixed Nim package, but one part is still missing
<ng0>I hope patches can be sent back soon :)
<qwertasd>brendyn: here is my definition now http://paste.debian.net/hidden/5bcbfa84/. I'm getting "no code for module (guix packages i3-wm)" even though I have i3-wm installed.
<ng0>*send
<ng0>atw: I think someone else had a more advanced leinigen package then the one I might have somewhere
<atw>thanks ng0! any idea who might be more involved? I had some ideas about bootstrapping leiningen using maven
<brendyn>qwertasd: i3 is in (gnu packages wm)
<brendyn>not i3-wm
<ng0>I don't find many threads in my archive abozut this. in february 2017: 5 people talked about "Packaging leiningen". 6 threads appear total, searching for leiningen
<brendyn>qwertasd: this also has nothing to do with what packages you have installed
<ng0>thread:000000000002dd99 2017-02-08 [6/6] alex.ter.weele, Danny Milosavljevic, Ben Woodcroft, Catonano, Ricardo Wurmus; Packaging leiningen (feedback desired) (guix guix::patch)
<A87221>Anyone else interested in creating a package for Geany?
<ng0>atw: oh. that is you, right?
<atw>yep :) the thread was more about how the clojure package worked at the time (I think it has changed since). My leiningen-bootstrap idea needs maven IIRC
<ng0>do you have more in depth experience with nixpkgs? some parts I'm still learning - like I had no time (yet) to look into why they mark 99% of beam packages as unbuildable (by Hydra I guess)
<ng0>I now have hex, I want to get to rebar3 next and the other package manager that is there, and then look into how a build system could be generalized
<atw>ng0: no idea, unfortunately
<ng0>eventually I'll understand, right now there's just too much going on for me
<qwertasd>are there any good resources for guix and guile other than the documentation. There probably aren't any books you could read from cover to cover.
<brendyn>qwertasd: there are some talks you can find, and blog posps
<brendyn>posts
<brendyn>But not enough. I'd perhaps like to make some myself
<A87221>error, gcc conftest.c ... Am trying to build geany. Suggestions?
<brendyn>qwertasd: I'm going to bed now so I won't be able to help you any more until tomorrow. You should note that the best resource you can find is the guix source code. There are over 7800 packages defined, all of which serve as examples to learn from.
<ng0>qwertasd: there's a couple of books
<ng0>just a moment
<qwertasd>brendyn: Well I'll go search for examples and play around with guix and guile myself.
<ng0>"teach yourself scheme in fixnum days", "a pamphlet again r", the old MIT recordings of LISP teachings in general (helps to some degree), https://mitpress.mit.edu/sites/default/files/sicp/index.html and https://www.scheme.com/tspl4/ though I would not recommend SICP as a first intro for now.
<brendyn>right, there are many resources for Scheme, I meant to say there isn't so much for guile specifically at the moment.
<qwertasd>I'm actually reading SICP right now.
<buenouanq>I love the SICP lectures
<buenouanq> https://archive.org/details/MIT_Structure_of_Computer_Programs_1986/
<davidl>qwertasd: Im not really experienced in guile/scheme, but one thing that helped me who is also a noob is to setup emacs with geiser so you can have C-c C-d d for 'geiser-doc-symbol-at-point
<nixd>Does anyone know how to switch from SLiM to a different display manager in GuixSD? Haven't really found a way to do so yet
<davidl>nixd: yep
<davidl>I have been using sddm for a while.
<davidl>with wayland.
<davidl>however, I just recently switched back to slim, because sddm stopped working.
<davidl>nixd: so 1 way is to use %base-services instead of %desktop-services in the config, and add the %desktop-services services manually but replace slim-service with your own, for example: (sddm-service (sddm-configuration (display-server "wayland"))) - or whatever config you want.
<nixd>davidl I'll see how it goes, thanks
<roptat>what architectures does berlin provide substitutes for?
<pkill9>i'm pretty sure it does for i686-linux
<A87221>Trying to compile geany from source, I have the error: C compiler cannot create executables.