IRC channel logs

2018-06-25.log

back to list of logs

<snape>Copenhagen_Bram: I told you to look at librecad just so you can see an example of a package modifying a 'configure' phase :-) That's three lines, you probably don't need to understand the rest of it. Although I'm not sure, I don't know much about qmake.
<Copenhagen_Bram>ah. Thanks snape. Sadly, the qt-4 package looks kinda big so imma wait until tonight to debug the package some more.
<Copenhagen_Bram>How do I browse tor on guix? I can't seem to find a tor browser. When I search for 'tor' it gives almost all the packages available.
<OriansJ>mbakke: the problem is that most computers in the world do not support Libreboot nor coreboot and we should expect that guixsd users want to be able encrypt their root partition, even if they can't encrypt their /boot partition. Shouldn't we a standard way to enable that such that we don't force a bunch of redevelopment of the same functionality for our users.
<nckx>Copenhagen_Bram: Because it's a regex, so try ^tor. That said, Tor Browser isn't packaged for Guix yet. Like most browsers it's a slow and tedious process (I don't *think* there are any non-technical reasons but I'm no expert).
<nckx>I assume you can just use Icecat + Tor proper (which is in Guix) but I haven't tried it.
<vagrantcish>OriansJ: you don't need libreboot or coreboot, grub2 can decrypt partitions
<vagrantcish>OriansJ: but i do see a split /boot as useful for various other reasons
<vagrantcish>ACTION keeps forgetting to file a bug report about that
<vagrantc>in particular, it comes up fairly often with arm systems that have limited options for what they can boot off of (microSD, USB) but maybe have SATA or something
<OriansJ>Plus ARM systems don't have grub usually but rather depthcharge if I remember correctly
<vagrantc>i'm more familiar with u-boot, but sure
<vagrantc>though modern u-boot in some cases has an EFI implementation/emulation mode, and then you can use grub-efi
<OriansJ>its what libreboot provides https://libreboot.org/docs/depthcharge/
<vagrantc>might have jumped into the conversation without knowing all the details :)
<vagrantc>but yeah, depthcharge ... found it hard to debug
<vagrantcish>so, i'm trying to set up to use "./pre-inst-env guix ..." and i've done the "guix environment guix" "./configure --localstatedir=/gnu/store" and now it seems stalled on "make check"
<reepca>... wait, with the change to guix pull, do we now have to manually type ~/.config/guix/current/bin/guix whenever we want to run guix or else add it manually to PATH?
<vagrantcish>one of my machines automatically added it to PATH ... others didn't ... not sure why
<vagrantcish>how reasonably long should i wait for "make check" to complete? it ran a few tests, and guile is consuming a whole CPU core the whole time ...
<cornburglar>ayo
<Copenhagen_Bram>reepca: what I do is source ~/.config/guix/current/etc/profile in my bashrc or zshrc
<chewzerita>Any talk to update icecat? Anyone patching iceweasel/firefox?
<chewzerita>Emacs info Guix shows up in french now, I don't know where to report official bug
<apteryx`>how can I build locally when using offload machines?
<apteryx`>(looking for a command line flag or something)
<pkill9_>apteryx`: see the --check, --no-substitutes and --fallback options
<apteryx`>pkill9_: ok, thanks
<apteryx`>it seems `guix offload' doesn't make very good usage of the network when files are 'big'. It's taking forever at exporting a 88 MiB file.
<apteryx`>s/forever/a couple minutes/
<apteryx`>vagrantcish: I thought the usual --localstatedir should be /var
<apteryx`>(actually I'm sure; that's where guix keeps its database)
<apteryx`>and you probably don't want to keep this kind of state under /gnu/store/
<vagrantc>apteryx`: that's good to know.
<vagrantc>ACTION wishes the instructions gave a more specific default example rather than explaining what to do in prose.
<apteryx`>vagrantc: I think the instructions refer you to another section... it's a bit indirect
<vagrantc>or at least, in addition to it
<vagrantc> https://www.gnu.org/software/guix/manual/html_node/Building-from-Git.html#Building-from-Git
<vagrantc>which references https://www.gnu.org/software/guix/manual/html_node/The-Store.html#The-Store
<eric23>I am trying to boot the install cd and it gets stuck on waiting for partition '...' to appear and gives me a scheme prompt. I have no partitions on the disk as I deleted all of them so I am not sure what it is talking about.
<eric23>I have version 0.14
<Copenhagen_Bram>how do I search for packages containing the words font and unicode? i don't know regex
<apteryx`>sneek: later tell pkill9_ no luck with --check, --no-substituse or --fallback to not have something built on an offload machine...
<sneek>Will do.
<brendyn>Copenhagen_Bram: guix package -A 'font|unicode'
<brendyn>-A to search package names, -s to search descriptions also
<Copenhagen_Bram>brendyn: how do I search the name of the .scm file?
<brendyn>You want to find the scm file that contains a particular package?
<brendyn>hmm coreutils failed to build for me
<Copenhagen_Bram>brendyn: yeah
<Copenhagen_Bram>i have no clue how to read this error: http://termbin.com/ad50
<reepca>When downloading some stuff to install I'm getting "in procedure getaddrinfo: System Error". Is this likely to be a hardware issue (I'm using a mini-pcie card from thinkpenguin that is known to work with free software)? Also, not sure if this is related, but I copied my entire home directory from another install - any relevant config files in there that might be incompatible?
<efraim>Glibc mismatch?
<brendyn>Copenhagen_Bram: show your package definitioon
<brendyn>reepca: most notable are .bash_profile and .bashrc
<Copenhagen_Bram>brendyn: http://termbin.com/12ie
<brendyn>is qmake not available?
<g_bor>hello guix!
<g_bor>I've seen civodul mentioning that there was something wrong with hydra.
<g_bor>Do we know what happened?
<Copenhagen_Bram>brendyn: wouldn't qmake come with qt-4?
<brendyn>Copenhagen_Bram: qtbase i think
<efraim>qt4 should have a qt4 qmake
<efraim>brendyn Copenhagen_Bram ^
<efraim>Copenhagen_Bram: you want something more along the lines of (invoke "qmake")
<efraim>similar to tipp10 in gnu/packages/education.scm
<civodul>Hello Guix!
<jonsger>hi civodul
<brendyn>'Hello
<Copenhagen_Bram>efraim: yeh I guess.
<Copenhagen_Bram>Erm, so how do I change the output of a package when it's coming from a file?
<brendyn>I don't understand what you mean?
<Copenhagen_Bram>brendyn: I've successfully built the latest version of cataclysm-dda with guix build -f ~/cataclysm-dda.scm, now how do I build cataclysm-dda:tiles?
<brendyn>You made a tiles output?
<Copenhagen_Bram>No someone else did... Do you know how to change the output for installing a package from a file?
<snape>Copenhagen_Bram: hi :-) You shouldn't source .../etc/profile in your bashrc
<Copenhagen_Bram>what does that have to do with how to install the latest version of cataclysm-dda:tiles?
<snape>because I'm reading the chat history in chronologic order :p
<snape>*chronological
<Copenhagen_Bram>so, is this inability to change the output of a build from a file, a bug?
<civodul>Copenhagen_Bram: "guix build -f foo" builds all the outputs of the package defined in 'foo'
<Copenhagen_Bram>Alright, that's cool. So how do I install a particular output to my profile?
<civodul>when building from a file that's not a real module, it's not convenient
<civodul>you can always do: "guix package -i /gnu/store/..."
<civodul>but the best thing to do it to turn your file into a real module and add it to $GUIX_PACKAGE_PATH
<civodul>see https://www.gnu.org/software/guix/manual/html_node/Package-Modules.html
<Copenhagen_Bram>hmm.
<Copenhagen_Bram>civodul: What kind of version number should I use? Right now it's the entire commit hash, should I make it a date?
<snape>Copenhagen_Bram: it depends on the package. If it has a proper release, you should use the associated version number
<Copenhagen_Bram>ah. No proper release yet, I guess I'll just leave it as the commit.
<snape>Copenhagen_Bram: then you can use (git-version ...)
<reepca>huh, manual never mentioned that -i works with non-package arguments
<snape>to generate the version number, based on the commit
<snape>if you grep 'git-version' in the Guix repository, you'll find tons of examples
<snape>oh but I guess you are *updating* a package (cataclysm dda) aren't you?
<Copenhagen_Bram>civodul: so how do I turn the file into a module?
<civodul>Copenhagen_Bram: you need to add a 'define-module' clause at the top, as described above
<rekado_>Copenhagen_Bram: please take a look at any of the other modules in gnu/packages for examples.
<snape>and you need to wrap the package with (define-public ...)
<rekado_>(or use #:export in the module declaration)
<snape>(in that case that would be define instead of define public, but that still needed)
<Copenhagen_Bram>ahh
<Copenhagen_Bram>erm, when I wrap it in define-public, it won't build anymore: guix build: error: #<unspecified>: not something we can build
<snape>yes, because then you don't pass it to build -f anymore
<Copenhagen_Bram>hmm, just install?
<snape>instead you just do 'guix build package'
<Copenhagen_Bram>oh, do I have to add it to $GUIX_PACKAGE_PATH first?
<snape>'guix build package' will use your $GUIX_PACKAGE_PATH to find your packages
<snape>whereas guix build -f package will just load the file passed as argument
<snape>yes you have to
<snape>it also has to be in a Guile module
<nee`>Can I remove /usr /bin and /sbin after installing GuixSD over an ubuntu server? Or does GuixSD put something there?
<Copenhagen_Bram>how do I put it in a guile module?
<snape>Copenhagen_Bram: https://www.gnu.org/software/guile/docs/master/guile.html/Using-the-Guile-Module-System.html#Using-the-Guile-Module-System
<snape>it's just the (define-module ...) at the beginning of your file
<snape>if it's (define-module (foo bar) ...), it means that at the root of your GUIX_PACKAGE_PATH, there is a directory 'foo', which contains a file bar.scm.
<Copenhagen_Bram>oh
<snape>nee`: special-files-service-type services may create them to add a few symlinks in them (/bin/sh for example)
<Copenhagen_Bram>$GUIX_PACKAGE_PATH is empty, would a simple 'export GUIX_PACKAGE_PATH="~/cataclysm-dda.scm"?
<snape>Copenhagen_Bram: no, GUIX_PACKAGE_PATH should point to a directory
<Copenhagen_Bram>oh.
<snape>and it *that* directory, should be your modules
<Copenhagen_Bram>alright made a new directory, exported it
<Copenhagen_Bram>but i get a warning:
<Copenhagen_Bram>guix package: warning: failed to load '(cataclysm-dda)':
<Copenhagen_Bram>no code for module (cataclysm-dda)
<snape>wait. Shouldn't you use the one that is already packaged in Guix?
<Copenhagen_Bram>huh??
<snape> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/games.scm#n179
<Copenhagen_Bram>no, i made my own custom cataclysm-dda package that installs a recent commit
<snape>but instead, you could modify the existing one
<snape>it makes more sense
<snape>if you want to contribute the modification
<snape>because we probably don't need to different packages, one with an old version and the other with a recent one
<snape>s/to/two/
<snape>GUIX_PACKAGE_PATH is useful for custom packages that you don't plan to upstream
<snape>but if you want to do a proper contribution (which I thought you wanted?), it's got to be from within the Guix repository
<snape>to that the final patch can be applied smoothly
<brendyn> https://www.mobileread.com/forums/showthread.php?t=293242
<brendyn>" No, I will simply maintain python 2 myself, far less work and I already do it for the windows python. "
<efraim>if I have patches affecting the java bootstrap that should go in staging?
<snape>brendyn: that guy seems quite angry
<brendyn>I'm working on maintaining the calibre package. it's a bit of a nightmare
<brendyn>he says people should just use his binary release instead of packaging it
<snape>and I guess he patches his included python
<snape>which probably makes it even more difficult
<brendyn>I did not even realise it bundled python
<snape>:)
<snape>they talk about it in the thread
<brendyn>in the binary version, or even in the source?
<brendyn>i thought my guix package was using guix's python
<snape>last message
<brendyn>Is there a way I can reply to a mailing list message without having to subscribe?
<snape>depends on the mailing list
<snape>you don't have to subscribe to Guix's mailing list, for sure
<brendyn>I unsubscribed because I couldn't handle getting thousands of emails in my inbox drowning out personal emails
<brendyn>but now I don't know how to use the mailing list
<snape>so you would just download the mbox archive, open it with your mail client and reply, but it's unconvenient
<snape>what I do is use another email address to subscribe and receive the messages
<snape>and I reply with my own
<snape>which is unsubscribed
<brendyn>I see
<brendyn>I really hate email
<snape>I really love email
<snape>:p
<civodul>efraim: probably, though you may want to check with rekado_ and g_bor
<jlicht>hey guix
<civodul>heya jlicht!
<rekado_>efraim: patches that affect all architectures or just armhf/aarch64?
<snape>ACTION just discovered that 'heya' actually means 'hey you'
<jlicht>o/
<jlicht>ACTION is currenly building rust 1.26 using the patch on the ML
<Copenhagen_Bram>snape: alright, after I edit the original games.scm, how do I contribute that?
<Copenhagen_Bram>Can I go into the guix git clone and do that?
<snape>Copenhagen_Bram: if it works, you can send the patch to the ml with, for example, 'git-send-email\\
<snape>you need to do a proper commit (that matches Guix commiting style)
<efraim>rekado_: I could rework it like that, but one is an actual patch file for jamvm-1.5.1
<snape>and then, you can do 'git send-email -1 --to=guix-patches@gnu.org'
<efraim>aarch64 is going to be harder, icedtea@1 doesn't have support for it
<snape>for this you need a .netrc file
<Copenhagen_Bram>ahh
<Copenhagen_Bram>ooh that reminds me i need to get claws-mail working
<rekado_>I’m having a problem with “guix pull” :(
<Copenhagen_Bram>rekado_: what's your problem, my friend?
<rekado_>the first time seems fine, but the second time I get invalid build result (#<derivation /gnu/store/iqfm7bbs039l50j7cjrd6lzma7cgjdcx-compute-guix-derivation.drv => /gnu/store/q5rkwcfza9h3mxrx72s0ihfkcbpa9cj8-compute-guix-derivation 4f1d320> "")
<rekado_>an earlier message is probably relevant: “guix: offload: command not found”
<rekado_>that’s odd, because I use “--no-build-hook”
<g_bor>rekado_:I have two questions. I've seen a bug in our bugtracker. You wanted to daa git-subtree. What is the status of that?
<rekado_>the same happens in an environment with “guile” and “guile-ssh”.
<rekado_>g_bor: that bug can be closed.
<civodul>rekado_: the problem is that the code that compute-guix-derivation doesn't inherit store options yet
<rekado_>it should be built as part of the git package.
<civodul>vagrantc reported this problem
<civodul>it's on my to-do list
<g_bor>rekado_: And I've not heard a word from our two GSoC interns for a while.
<rekado_>g_bor: me neither.
<civodul>rekado_: in your case --no-build-hook is not honored there
<civodul>me neither, g_bor :-)
<rekado_>I pass “--no-build-hook” to “guix pull”, though.
<rekado_>not just to the daemon.
<civodul>yes, that's the bug
<rekado_>oh, okay
<civodul>hello Rukako!
<rekado_>so… I’d actually much rather fix the problem that made it necessary to add “--no-build-hook” in the first place.
<civodul>good idea :-)
<rekado_>I suppose the problem here is that guix-daemon runs in an environment where guile-ssh is unavailable.
<rekado_>I wrapped the daemon in a script that sources a profile containing guile, guile-git, guile-ssh, guile-sqlite3, guile-json, gnutls, and more.
<rekado_>…and now things seem to be fine. (building git)
<rekado_>(I added guile-sqlite3 just now and updated the profile again)
<g_bor>rekado_: Ok, I will close that bug. Do we need to do anything else to have git subtree?
<rekado_>g_bor: yes, we need to add a build phase to the git package.
<rekado_>speaking of the git package: maybe we should not change this on the master branch any more. It takes a rather long time to build because of the very large test suite.
<g_bor>Ok, I guess last time I did push one patch there on master. I've consulted this here, roptat said it was ok. Should we do it on staging?
<rekado_>according to our rules it’s fine to push this to master.
<rekado_>I just wonder if we should make an exception to git (and a bunch of other packages that have horrendous build times)
<g_bor>rekado_: you might be right about that, where should thi be documented?
<snape>ACTION wants a command 'guix where-to-push <package>'
<snape>*would like :-)
<efraim>is there a reduced test suite for git?
<civodul>rekado_: i think it would be an improvement already if (guix git-download) didn't use git
<civodul>like if it used guile-git or a built-in derivation builder
<efraim>I thought guile-git depended on git and didn't do shallow clones
<snape>it depends on libgit2 instead
<jlicht>libgit2 does not support shallow clones afaik
<jlicht>but not on principle; nobody has made a PR for it
<jlicht>although one might be able to work around this with some clever hacks in guile-git
<g_bor>I'm a bit stuck. I'm trying to build java-commons-collections, using icedtea-8. It fails. I know why, so we should make it compiled as java7 source.
<g_bor>So far, so good. So I set target and source, like it was on java-aqute-libg, but it does not work. Still fails with the same error.
<g_bor>This is the last package that needs #:jdk ,icedtea-7 on my wip-change-default-java8 branch. Once this is solved we can go on to changing to java8.
<rekado_>can we patch the sources to make it build with icedtea-8?
<g_bor>rekado_: Actually there are several patches floating around, but they are not fully backwards compatible. In the next version public methods were renamed to solve these problems.
<g_bor>We have only two direct dependencies, and the package is obsolate, so I guess it is ok to patch, and check the two dependents build... WDYT?
<rekado_>I agree.
<rekado_>it’s better than keeping icedtea-7 around in active use.
<rekado_>icedtea-7 should really only play a part in the bootstrap.
<g_bor>Ok, I will check this.
<rekado_>thank you!
<mbakke>I wonder if we still need to build icedtea with gcc-4 after the recent bootstrapping changes.
<Rukako>10:54:15 < civodul> hello Rukako!
<sneek>Rukako, you have 1 message.
<sneek>Rukako, jlicht says: where you able to get anywhere with shepherd + signalfd already :)?
<Rukako>hi!
<civodul>hey, Rukako :-)
<ng0>we can have GNUsocial at some point. Mastodon is off the table until the nodejs situation is resolved, if ever. Now I wonder since I've been running pleroma, how doable that would be as a package+service. we probably lack some elixir packages and a small build system to take on the work Mix does.. but that's it.
<Rukako>jlicht: yes, I have been toying with it with select in my tests
<ng0>seems the closest we can get to a webservice in functional programming language and capable to run on small resources
<ng0>there's a short text I'm reading right now: https://github.com/wimvanderbauwhede/limited-systems/wiki/Hacking-the-Pleroma:-Elixir,-Phoenix-and-a-bit-of-ActivityPub
<civodul>Rukako: so how is it going? were you able to replace the SIGCHLD handler with purely signalfd+select?
<Rukako>civodul: yes, I will be posting an update soon
<civodul>awesome!
<civodul>Rukako: note that "negative" updates, or why-is-it-broken updates are welcome too :-)
<Rukako>specifically, I have a fiber where I have a select on signalfd and the opened sockets
<axd[m]>so, there's a GuixSD room or matrix.org, but no one is ever there and only reposts of articles from the main website ever go there. Why isn't that room just bridged to this one?
<civodul>Rukako: oh so you're already on the second step; i was just asking of the first step where you use select/signalfd directly, without Fibers
<civodul>i guess that's good news
<jlicht>Rukako: nice to hear! How did you work around the non-determinism which guile thread 'receives' the signal?
<civodul>in terms of code, we'll probably want a first commit that switch from SIGCHLD handler to signalfd, all without Fibers
<axd[m]>unrelated question: is there a 0.15 release coming sometime soon?
<sneek>Okay.
<ng0>sneek: forget it
<sneek>Consider it forgotten.
<ng0>axd[m]: yes, around 30th
<civodul>axd[m]: given that you have "[m]" in your nickname, i take it that you're on Matrix, right? :-)
<civodul>ACTION knows nothing about Matrix
<axd[m]>ng0: very nice, good to hear.
<axd[m]>civodul: yeah I am, been checking it out. I'm primarily enjoying the caching features since I didn't run a very advanced irc setup so had to check the log to see if I missed something. Matrix/riot.im caches the history so I can see it whenever I'm back.
<ng0>I think someone has to claim ownership of the room
<ng0>should be one of us
<axd[m]>Ccivodul: found this yesterday which might help you get into it if you wanted: jgkamat/matrix-client-el: A matrix client for Emacs!
<jlicht>axd[m]: how is the emacs situation with matrix?
<jlicht>oh lol
<jlicht>nvm >.<
<mbakke>Matrix is a neat alternative to keeping a bot around, though I find the bridge misses some messages every now and then.
<ng0>if only the psyced psyc-to-irc bridge to freenode still worked reliable..
<snape>at least https://gnunet.org/bot/log/guix works reliably :-)
<ng0>welllll
<ng0>it works. but that's all it does.
<snape>and that's all I ask. It's a bit late sometimes though :-)
<ng0>pro tip: stayaway from Drupal IRC bots ;)
<ng0>I think it will be more reliable next year when we switch away from that.. thing..
<mbakke>Speaking of bots, I'm planning to set up an Irker bot for commit messages: http://www.catb.org/~esr/irker/hacking.html
<tune>catb... I had only heard of catv before
<snape>tune: Cathedral and the Bazaar
<ng0>don't look at esr's blog though. it matches many many offtopic and policy violations here.
<snape>but one must be aware that there are people believing in Open Source software ;)
<tune>good to know
<pkill9_>does anyone know a link to that scheme program that generates a package definition and uses zenity to take package info (e.g. package inputs, home page, etc)?
<sneek>pkill9_, you have 1 message.
<sneek>pkill9_, apteryx` says: no luck with --check, --no-substituse or --fallback to not have something built on an offload machine...
<pkill9_>apteryx`: oh, i think i misunderstood what you were asking, my bad
<ng0>pkill9_: for the next time: it is --no-build-hook
<pkill9_>ok
<bavier>pkill9_: rekado created some nice emacs-yasnippet templates
<bavier>which helps with filling in info for packages like that
<pkill9_>i don't use emacs much, but can i see a link to that?
<ng0>it's in the guix source
<pkill9_>oh ok
<bavier>pkill9_: or https://lists.gnu.org/archive/html/guix-devel/2017-12/msg00196.html
<pkill9_>i want to make a command line program with more templates, and in guile instead of python
<pkill9_>for example, one that simply inherits a package and puts in a different source, one that inherits and replaces an input
<pkill9_>also for git sources
<pkill9_>hmm i need to learn more scheme before i can do this
<civodul>IRC bot for Debbugs: https://github.com/sebastinas/debian-devel-changes-bot
<civodul>pretty cool!
<apteryx`>pkill9_: no worries
<apteryx`>ng0: thanks for the '--no-build-hook' tip
<janneke>ok, gcc-4.1.0 is now bootstrapped -- i'm going for a quick mes 0.16 release, esp because mes 0.15 binaries segfault on linux 4.17
<vagrantc>ACTION cheers!
<janneke>vagrantc: thanks!
<janneke>vagrantc: i saw a wnpp for mes :-D
<jlicht>janneke: no way \\o/
<jlicht>you've gotten that far already?
<janneke>yes we still use binary seeds, but not for the gnu toolchain, or tcc
<ng0>:O
<nckx>
<sdb>hi guix
<sdb>I wonder if any of "pull" or "system reconfigure" update the guix in the system profile?
<sdb>My system profile in sdb1@antelope ~$ ls -l /run/current-system/profile/bin/guix
<sdb>lrwxrwxrwx 2 root root 75 1 jan 1970 /run/current-system/profile/bin/guix -> /gnu/store/avg3vnk6p752z8iwld6yzv1wg7ki48vp-guix-0.14.0-13.7af5c2a/bin/guix
<sdb>even though I have pulled and reconfigured multiple times:
<sdb>as root
<sdb>root@antelope /home/sdb1# guix pull -l
<sdb> guix b4eae99
<sdb> repository URL: https://git.savannah.gnu.org/git/guix.git
<sdb> commit: b4eae997fe5b928f179c34d281e9f2c3eccd3670
<sdb> guix 8edebd3
<sdb> repository URL: https://git.savannah.gnu.org/git/guix.git
<sdb> commit: 8edebd3207335aff15081458e895104ac9f45d3d
<sdb>You could ask: why care about the guix version in the system profile at all? It is not used as soon as you run guix pull or populated the .config/guix some other way and adjusted the this to preceede in the PATH.
<sdb>I care because if I create a new user via config.scm they by default get access to an outdated guix when a newer is available. This is in my view a bug.
<sdb> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=31907
<sahithi-ihtihas>Hello Guix
<sahithi-ihtihas>Beginner doubt :) ..... when i try to build changes that I made ......I need to compile it first using make but how can ./pre-inst-env give results without make i.e. without compiling
<janneke>sahithi-ihtihas: you do not "always" have to run make, some most simple package changes guile will auto compile the .scm file for you if you forgot to run make
<janneke>
<vagrantc>how long should i expect https://www.gnu.org/software/guix/manual/html_node/Building-from-Git.html#Building-from-Git to take?
<janneke>vagrantc: about 15min?
<vagrantc>ah, so 12+ hours for the "make check" phase suggests something is very wrong? :)
<vagrantc>12+ hours and counting
<vagrantc>i had it working earlier with pre-inst-env, and then i had the bright idea to update it...
<janneke>you may want to check if it's somehow auto-compiling Guile, i had that once
<janneke>look at what's going on in ~/.cache/guile/
<efraim>Is it testing some bootstrap thing perhaps?
<vagrantc>guile is very busy doing something, no idea what
<janneke>have you checked the timestamps in ~/.cache/guile ?
<vagrantcish>a few hours old
<janneke>hmm
<vagrantcish>only thing in there is r21yw2lkm4fr1n7x1nxgpqrjw0xkln9r-guile-sqlite3-0.0-4.10c13a7
<janneke>okay, sorry for the noise then ;-)
<snape>vagrantc: it depends on machine. From a few minutes to a few hours.
<vagrantcish>this is a fairly fast i5 with 8GB of ram...
<snape>so it's probably a few minutes ;-)
<vagrantcish>well, hours are composed of minutes ...
<snape>true
<vagrantcish>so, i'm getting the impression something is definitely wrong, then.
<Copenhagen_Bram>When will Guix have USE flags?
<vagrantcish>that would kill your hit rate with substitutes
<kkebreau>Has anyone's pre-inst-env script suddenly stopped working?
<kkebreau>As in, `./pre-inst-env guix` uses the normal guix environment instead of the one in the repo?
<nckx>Copenhagen_Bram: Are ‘USE flags’ like build options?
<nckx>Seems to be some Gentoo thing.
<vagrantc>kkebreau: i had something like that in my first attempts at setting up pre-inst-env where i just ran configure but not the rest of the steps
<kkebreau>vagrantc: Hmmm, I'll run make just in case.
<Copenhagen_Bram>nckx: yeah, I noticed that we have outputs, but I wonder if there could be something more versatile. For instance, if there was a package that could include KDE or QT compatibility, instead of having 4 outputs: one for KD, on for QT, one for both, and one for none; it could just have two flags you could set, for KDE and QT.
<Copenhagen_Bram>And yes I got the idea from gentoo.
<Copenhagen_Bram>I think I keep losing dns. I can't load websites and I can't ping them, until I run `nmcli c up router.name`. And then if icecat is online it stops loading websites, it says 'server not found' even though there is internet. So I have to put icecat in offline mode while I run nmcli, otherwise I have to restart icecat.
<nckx>IIRC general maintainer consensus is against enable-foo? switches, preferring explicit modification of package definitions: you instead modify the package to add "--with-foo" to #:configure-flags.
<ng0>Copenhagen_Bram: you can't map Gentoo lingua like use-flags 1:1 to the model GuixSD uses at its core.
<ng0>to some extent it works, but not all of it
<Copenhagen_Bram>okay. I have a problem with cataclysm DDA: I can't get it to detect a soundpack
<ng0>if you read into the NixOS thesis and have some knowledge in Gentoo internals and Guix, you'll see why
<Copenhagen_Bram>I've tried putting it in ~/.cataclysm-dda/data/sound and ~/.cataclysm-dda/sound and it still won't detect it
<Copenhagen_Bram>Is there an environment variable I need to set or something?
<nckx>ng0: Nix(OS) does support this, though. I'm not at all convinced that it's a good idea but it does.
<ng0>the closest to USE-flags is creating local package definitions which inherit and then change values of the original packages or extend them.. currently GUILE_LOAD_PATH or GUIX_PACKAGE_PATH are useful there. There's a limit to that as well in terms of how well it scales, but for small use cases it works
<nckx>Nix packages are functions that can be called with an optional attribute set argument, so you can do things like ‘fooFox { withHTMLsupport = false, qt = qt-3.1 }’.
<bavier>a local git branch works too
<ng0>bavier: yeah. not the same though
<nckx>The fooFox definition needs to support this, so you end up with ifs all over the place, hence why I prefer the explicit Guix model.
<ng0>I approach this entire topic different.. so that's my view, where I ran into the outer limits of Guix after a couple of years exploring ;)
<ng0>not everyone wants to have the master repo around for a quick package change. but there's many ways to solve problems with guile
<kkebreau>Copenhagen_Bram: I'm not sure, I'll be investigating this soon.
<Copenhagen_Bram>oh thanks kkebreau
<reepca-laptop>ACTION lives at last!
<Copenhagen_Bram>hey reepca-laptop
<reepca-laptop>the reinstall doesn't seem to have changed audacity's inability to interact with my audio devices, unfortunately - keep getting a bunch of "unable to open audio device" errors
<kkebreau>Copenhagen_Bram: Our version of Cataclysm: DDA is fairly old, too. I have to find out which upstream code versions are "stable enough".
<kkebreau>reepca-laptop: Hi! :)
<reepca-laptop>Copenhagen_Bram, keebreau: o/
<nckx>Welcome back, reepca-laptop.
<Copenhagen_Bram>kkebreau: hmmm. I recently changed the cdda package to the latest commit, but I haven't published it yet. If we can find a more 'stable' version, maybe I'll make one for that too
<kkebreau>Copenhagen_Bram: Cool. I guess whoever emails it to the guix-patches list first wins a patch review.
<kkebreau>reepca-laptop: Do your errors say something about "Cannot open shared library" for a "libasound_module_ctl_pulse.so" file?
<kkebreau>vagrantc: Yep, I needed to run make.
<kkebreau>ACTION facepalms
<vagrantc>the whole process of setting up a working pre-inst-env setup is a bit confusing to me
<kkebreau>vagrantc: I guess it's in the name. You do everything up to but not including installing Guix, then it will work.
<kkebreau>I forgot that I ran `make clean` a few days ago.
<reepca-laptop>kkebreau: they say something like that for a "module_pcm_pulse.so" when I run it from xterm, but I don't see anything about "libasound_module_ctl.so"
<kkebreau>reepca-laptop: Darn, I thought we had the same issue!
<civodul>cbaines: thanks for the heads-up for 'guix pack', i have the squashfs fix now
<kkebreau>So apparently our Perl File::Rename package has been broken for a while. Hopefully I can fix that with an upcoming update.
<reepca-laptop>kkebreau: here's what my startup of audacity looks like (there's a bunch of "03:02:18 PM: Debug: ScreenToClient cannot work when toplevel window is not shown" messages after it, but I don't think it's related) https://paste.debian.net/1030709/
<kkebreau>reepca-laptop: Hmm, so it's similar but not exactly the same. Do you use alsamixer at all? If so, does it print the same error?
<kkebreau>reepca-laptop: Oh wait, it is the same.
<reepca-laptop>ah, seems I didn't look far enough. I should really figure out how to paste from xterm...
<reepca-laptop>alsamixer complains about libasound_module_ctl_pulse.so, while audacity complains about libasound_module_pcm_pulse.so
<mbakke>Hmm, I too am getting a "Could not prepare Boot variable: No such file or directory" from grub-efi as another user had not too long ago. And sure enough the EFI entry is no longer present.
<mbakke>It seems to me GRUB should fail in that case rather than continue with "Installation finished. No error reported.", but that's a bug for a different project.
<civodul>mbakke: indeed
<civodul>i think "EFI variables" are handled by the efibootvar package
<civodul>or somethign like that
<civodul>is /boot/efi mounted?
<mbakke>/boot/efi is mounted, and I also tried to explicitly mount efivarfs.
<mbakke>Woah, reverting 6e5a6e641a12319af35b51d44537cec1c158e099 did the trick.
<mbakke>I'll do that on master before I break more systems :/
<janneke>ouch
<bavier>clamav got a new 0.100.0 release a few months back ... I should revive my patch to add it ...
<civodul>mbakke: sounds like a good idea ;-)
<civodul>IWBN to strace grub-install with the broken efivar to see which file leads to "No such file or directory"
<Copenhagen_Bram>So, can someone help me find out what's wrong with my qtads.scm? http://termbin.com/7xqt
<mbakke>civodul: The last thing it tries before reporting the failure to update "Boot variables" is:
<mbakke>3460 openat(AT_FDCWD, "/sys/devices/pci0000:00/firmware_node/uid", O_RDONLY) = -1 ENOENT (No such file or directory)
<mbakke>ACTION dives into efivar changes
<civodul>mbakke: this file exists for me
<civodul>that's on 4.17.1
<civodul>are you on an older kernel?
<civodul>Copenhagen_Bram: you're at least missing a 'define' there, see https://www.gnu.org/software/guix/manual/html_node/Defining-Packages.html
<mbakke>civodul: I'm on 4.16 and don't have it.
<mbakke>It could also be a problem with my kernel configuration.
<civodul>dunno
<civodul>the intertubes might know
<civodul>today was interesting
<civodul>during the day i stare at pointers in gdb and wonder about terrible low-level things
<civodul>and now i do Scheme-level things
<civodul>feels like a breeze
<civodul>:-)
<mbakke>TBH debugging Guile errors are not always straightforward either ;-)
<mbakke>The EFI error is probably platform-specific, there's an issue about it: https://github.com/rhboot/efivar/issues/111 (I'm on a Thinkpad too)
<mbakke>This (unreleased) commit is also interesting, moving the firmware_node parsing stuff to a separate module: https://github.com/rhboot/efivar/commit/e2f68c8f9f4fab48f1ef3a4585932f757593fa92
<janneke>civodul: tell me ;-)
<mbakke>janneke: Heheh :-) By the way, I'm completely baffled by the rapid progress you are making.
<civodul>janneke: heh, you must know that feeling, for sure :-)
<mbakke>Seems like we're well underway to a completely transparent bootstrap graph!
<janneke>mbakke: thanks...i get great help and tbh, it seems like i've been hunting down a strrch bug for a week
<tune>I get that same boot variable error since a week or so ago
<janneke>mbakke: i'm a bit worried about non-x86 architectures
<pkill9>I'm having a strange problem, when i try to build newer kxmlgui, it unpacks the source that guix currently uses. This is the package definition i'm using, if you run `guix build -f <file>` on it, it will build kxmlgui from it: https://paste.debian.net/plain/1030716
<tune>it wiped out the guix entry from my efi so I couldn't boot for a bit, then someone here helped me add it back manually so I could boot again. I still get the error, but it doesn't stop me from booting anymore
<pkill9>i think it's mixing up the base64 thing
<janneke>civodul: jumping through different programming domains, scheme feels like such a breeze -- even with all things that could be nicer
<civodul>yeah
<pkill9>if i change a number in it, guix does download the correct source, but then gives error that it's the wrong hash
<janneke>civodul: i intend to put forward some effort into reviving gash
<pkill9>if i change the hash to the correct one, it unpacks the source for the version Guix uses
<civodul>janneke: re non-x86, did you (collectively) consider targeting an "abstract" ISA?
<civodul>janneke: oh Gash, yay!
<janneke>make it good enough to bootstrap make, then see if more coreutils could be added
<Copenhagen_Bram>Why do I keep losing dns???
<Copenhagen_Bram>ACTION puts icecat on offline mode and runs nmcli c up router
<vagrantc>janneke: could the non-x86 architectures be cross-bootstrapped from another architecture?
<janneke>i was wondering, i'd like to take a stab at SED using Guix substitute* function, cp/rm using Guix file functions, can/should i just steal them?
<janneke>civodul: we didn't yet -- that is to say, i championed the "lets only worry about x86 now to prove it can be done"
<janneke>the lower level tools are pretty arch agnostic
<janneke>vagrantc: i've been wondering...i don't know
<janneke>i don't think x86_64 can be cross-built from x86?
<Copenhagen_Bram>civodul: thank you for letting me know i forgot a define-public, but adding it didn't fix anything. I still get a compile error
<Copenhagen_Bram>civodul: here is the compile error: http://termbin.com/6nsr
<ng0>janneke: sounds good, with gash
<mbakke>"goreutils"? :-)
<janneke>hehe
<janneke>*lol* actually
<janneke>we'll be adding a pretty hard dependency on bootstrap-guile, but hey -- there's no getting past that anyway
<janneke>it inspires me to explore that route anyway, more than bootstrapping all these unix tools in C, updating mes lib c...etc
<ng0>I've been thinking about this.. how much cna reasonable be written in Guile the further you move down the graph to the root? I have a pkg-config written in perl, but pkg-config is very far up
<janneke>well, we have a C compiler and may have a shell shortly
<ng0>and if not Guile, some other Lisp would do. but there must be a limit, right?
<janneke>a limit?
<janneke>ACTION denounces limits ;-)
<reepca-laptop>huh, C-h i m "guix" RET gets me the french guix manual.
<ng0>I'm not sure. in efficiency or safety?
<civodul>reepca-laptop: this is imperialism
<janneke>in my dreams, wingo handled efficiency with native guile3 assembly/lightning/nash
<reepca-laptop>how would one go about asking info nicely for the english version?
<ng0>on the one hand I think it will work out to have these tools in lisp, on the other hand they were written in C for more than historic reasons.. although looking at some BSD or GNU core utils, they hardly change.
<janneke>s'il vous plait+
<mbakke>civodul: LOL.
<civodul>heheh
<civodul>reepca-laptop: actually both versions are in the 'dir' file
<ng0>l'info guix
<janneke>hehe
<civodul>but we should arrange to create a separate 'dir.fr' file or something
<civodul>there's a discussion somewhere on bug-guix
<ng0>guix-fr.info is not enough?
<civodul>ACTION -> zZz
<civodul>bonne nuit ! :-)
<janneke>sweet dreams, civodul
<mbakke>Copenhagen_Bram: I believe the error comes from the fact that (system ...) returns a number, whereas the build system expects a boolean. Try using (invoke ...) instead of (system ...).
<ng0>janneke: ah, another reason: what about portability? how many platforms and architectures does Guile support, vs the C ones.
<ng0>but the main ones are covered by Guile I think
<reepca-laptop>Copenhagen_Bram: also, modify-phases' docstring says that <new-phase> needs to be an expression evaluating to a procedure, so I think you need to wrap that in a lambda.
<Copenhagen_Bram>oh
<reepca-laptop>(it's trying to call the result of calling qmake, which is a status code)
<janneke>yeah ng0, Guile supports more platforms than Guix does -- and Guix is all i care about _for now_
<ng0>jzst trying to come up with reasons against / for it while thinking in another language right now
<janneke>ng0: i aprreciate and welcome that
<janneke>ACTION -> zZzzz
<ng0>the idea to have as much lisp and scheme as possible sounds really good though
<janneke>that's where i enjoy to put the focus of my efforts anyway
<ng0>for example OpenBSD's pkg-config which I've been using with some packages only lacks support for some macros the C one has, but otherwise is fully functional. that's in perl, rather small amount of lines of code. doing the same in a scheme should work out.