IRC channel logs

2018-04-14.log

back to list of logs

<darkpsi>how does one make a custom kernel on guix?
<Cthulhux>make menuconfig ; make install?
<darkpsi>in the context of guix i know how to compile a kernel from source
<darkpsi>i want to write a config or a few rule changes and apply that to my build without violating guix
<darkpsi>i am using a guixsd i should say
<darkpsi>hey guys if anyone can help me there seems to be a bug with nvme the new linux kernel (4.16.1) has the nvme drivers compiled in to the kernel and when i guix reconfigure it ither demands that i put load nvme on the initramfs or if i have done that it will say it can not find nvme.ko as it does not exist. so what would be the best way to sort this problem i could ither edit the kernel config or disable the
<darkpsi>nvme check if any one can help that would be great
<zybell_>There should be a file /sys/class/nvm... or similar that exist in *earlier* kernels only if nvme.ko is loaded. It would exist in 4.16.1 anyway. Extend the test to look for that file, and if lsmod says no module in and file exist goto no module needed.
<lfam>darkpsi: This subject was discussed here: https://lists.gnu.org/archive/html/guix-devel/2018-01/msg00492.html
<sneek>Welcome back lfam, you have 1 message.
<sneek>lfam, efraim says: on my GuixSD system with btrfs i ran `sudo chattr -R +C /tmp' and syncthing built successfully
<lfam>Hopefully there is some useful info there, darkpsi
<lfam>efraim: Can you remind me what that message about btrfs and /tmp is referring to?
<snape>o/
<eldad>hi there, I'm trying to install guixsd on wireless and I can't get my wifi recognised because the driver is not freeware, what are my options? (beside hard wire)
<roptat>eldad: you can buy a supported wifi adapter
<roptat>I know that's not the answer you wanted, but it's the only one I can give you :/
<eldad>not really, that's a shame
<eldad>So i guess try to hard wire and later i can install the wifi drivers?
<roptat>guix is a gnu project, so we can't ship non-free drivers
<roptat>but I guess you can build your own kernel with the drivers
<eldad>yeah, I understand that, it's making the install very hard and I really want to have guix :)
<roptat>for now you'll need a supported wifi adapter or a wire
<snape>eldad: it's not that difficult. GuixSD makes it very easy to be modified.
<snape>eldad: see https://lists.gnu.org/archive/html/help-guix/2018-03/msg00057.html
<Sleep_Walker>I'm a bit fighting with trivial-build-system as I am trying to do simple unpack of tarball
<Sleep_Walker>problem is that tar doesn't see gzip in path
<Sleep_Walker>I can add it to PATH manually but is this expected behavior?
<snape>Sleep_Walker: maybe you need to add gzip as native-input?
<Sleep_Walker>it is present there already but not in PATH
<snape>oh, yes, you need to add gzip to path
<snape>see font-adobe-source-han-sans
<userr>Hi.
<userr>After update, I can’t use Guix.
<userr>$ guix package
<userr>guix package: error: could not find bootstrap binary 'guile-2.0.9.tar.xz' for system 'x86_64-linux'
<userr>Update was "guix pull" and "guix system reconfigure" as root.
<userr>Note: my Guile version is "guile (GNU Guile) 2.2.3".
<iyzsong>userr: does 'guix' of the root user work?
<userr>iyzsong: Yes.
<iyzsong>userr: you may try symlink ~/.config/guix/latest to the same path as root's.
<userr>iyzsong: cp /root/.config/guix/latest ~/.config/guix/latest ?
<iyzsong>userr: it's a symlink, so you can use: ln -sfv `readlink -f /root/.config/guix/latest` ~/.config/guix/latest
<userr>iyzsong: ln: failed to create symbolic link '/home/<stripped>/.config/guix/latest/<stripped>': Read-only file system
<iyzsong>userr: try remove it first, 'rm ~/.config/guix/latest; ln ...'
<userr>iyzsong: It worked.
<userr>Bye.
<pkill9>is gvim in any of the guix packages?
<OriansJ>pkill9: I'm pretty sure it is in vim-full
<thomassgn>what is the difference between guix environment --root=./.dev --ad-hoc gcc and guix package -p dev -i gcc? I'm trying to get an environment where I can choose to enter and work without internet connection, separate from my system state
<thomassgn>another entry to the same question would be, what is the difference between a profile and a gc-root?
<pkill9>do you mean the difference between a profile and a guix environment?
<pkill9>a gc-root is basically just a symlink that tells the Guix garbage collector not to delete anything inside it/anything that is linked from inside it
<thomassgn>Yes I think so
<thomassgn>I mean , the root from guix environment looks, to me, identical to the guix package profile
<atw>thomassgn: your "guix environment" invocation includes a --root, so I think that either command will yield a profile. Either will accomplish your goal of a GC-safe set of packages available while offline. I think that "guix environment --root=..." will save you the trouble of naming the environment (contrast "guix package -p <name>"). Personally, I'm aiming for a setup where I can run "cd <project> && guix environment --root=profile
<atw>--load=guix.scm" in every project
<pkill9>isn't the `-p` flag for `guix package` functionally exactly the same as the `-r` flag for `guix environment`?
<zero21>is it possible to install nix? I know there is a package but when i try to install it build fails
<pkill9>oh interesting, didn't know there is a nix package
<pkill9>zero21: i just use the installation script from the nix homepage
<zero21>pkill9 you mean https://nixos.org/nix/download.html that?
<pkill9>yep
<zero21>I need nix only for guix import nix command, will it work if installed like that?
<pkill9>i don't know, i odn't think it will tbh because i don't think the installation method from the homepage installs the nix daemon, which i believe is a requirement for `guix import nix`
<zero21>nix package build fails for everyone or just me?
<pkill9>im running guix build nix now zero21, ill let you know what happens
<zero21>thank you
<pkill9>it failed for me too
<pkill9>cc1plus: warning: unrecognized command line option ‘-Wno-unneeded-internal-declaration’
<zero21>yes
<zero21>that
<pkill9>also i think it's kinda out of date, 2.0 just got released and it's building 1.11.9
<pkill9>then agian i supsoe not that old
<atw>pkill9: I think the difference is that -r makes a symlink in the current directory that points to a profile, while -p only makes a profile with the given name
<pkill9>atw: i think i've used -p and then it made a symlink in current directory
<pkill9>mightbe wrong tho
<thomassgn>pkill9: yes, -p makes a symlink with the name in current dir.
<pkill9>thomassgn: does that mean you can pass just the name to `guix package -p` and it will use that symlink? or do you need to give `-p` the path to the symlink?
<thomassgn>(had some problems with wifi) I'll treat the --root as a profile and see if it bites me :P
<pkill9>also, you can pass other options like `--contianer` to `guix environment`, so maybe those options get saved in the root created with `-r` which just using `guix package -p` wouldn't
<pkill9>container*
<thomassgn>ah, that could be. But, the ... huh, no.... I'll be playing with that later I think
<pkill9>what's a good laptop that people are running GuixSD on that don't have any hardware issues?
<vagrantc>fsvo "any"
<pkill9>fsvo?
<buenouanq>pkill9: runs great on my 2008 macbook
<buenouanq>look at h-node though maybe
<vagrantc>pkill9: for some value of
<vagrantc>pkill9: e.g. with spectre/meltdown ... i don't know that there are any laptops without hardware issues
<vagrantc>and capable of running GuixSD
<vagrantc>or other issues
<pkill9>yeh
<beneroth>can/are guix packages cryptographically signed?
<zybell_>they are
<zybell_>fsvo signed
<zybell_>;-)
<vagrantc>heh
<vagrantc>you basically have to manually verify each commit
<beneroth>ok, so not really easy to trust the downloaded software.?
<efraim>sneek: later tell lfam btrfs and /tmp is refering to some packages like syncthing failing tests on btrfs, but not having issues when CoW is off
<sneek>Got it.
<efraim>sneek: botsnack
<sneek>:)
<beneroth>thx zybell_m vagrantc
<mbakke>beneroth: Binary substitutes are also signed.
<mbakke>But currently no automatic verification is done of git commits when you `guix pull`.
<efraim>buenouanq: on your macbook do you have the vertical-only touchpad movement on some reboots and do you have working wifi?
<beneroth>mbakke, ok, so same as standard git. thx.
<vagrantc>since the git essentially can basically tell you to download anything from anywhere ... there's not a lot of verification going on
<beneroth>I'd like to have both integrity assurance (no tampering, e.g. via MitM) and solid proof from where/whom a package comes
<mbakke>Guix will complain loudly of the certificate on `https://git.savannah.gnu.org` is not signed by Let's Encrypt though, raising the MITM bar a little.
<mbakke>But to check the integrity of individual commits, you'll have to `git log --show-signature` (or equivalent) manually for every pull.
<beneroth>what about MitM during the upload to git.savannah.gnu.org? :)
<mbakke>On push? We use SSH for that.
<beneroth>ok
<mbakke>We don't "upload" packages, they are built and signed by the CI system, but you can run your own substitute server/build locally.
<mbakke>And most packages are reproducible.
<beneroth>I guess my use case is a bit away from the usual one with guix. I'd look to have an universal package manager able to run with independent decentralized repositories, e.g. to publish/deploy my own software packages. I'm trying to find out if Guix would be the tool for this.
<beneroth>so the point is less about the securing of one central repo but how to ensure/check if a certain piece of software (possibly source code to build locally) really is from the author/distributor I trust or not
***Piece_Maker is now known as Acou_Bass
<mbakke>beneroth: I think Guix supports that case well.
<mbakke>Currently juggling multiple repositories is somewhat primitive, but there is a "channels" facility planned.
<zybell_>beneroth:That use case is what git was written for
<zybell_>read about heavy tags
<zybell_>ACTION googles for a link
<mbakke>Guix is inherently "trustless", everything is (and can be independently) built from a small set of "bootstrap binaries", but we're trying to get rid of those too. And you can easily fork the code and create your own distribution, with your own bootstrap binaries.
<mbakke>Many users don't use our binary substitutes at all.
<mbakke>Substitutes are also cryptographically signed and it's easy to run your own substitute server (see `guix publish`).
<beneroth>interesting. though I'm not pondering about the substitutes alone - I think it would be a good idea to be able to verify that a certain source code file is signed by its author (tampering would invalidate the signature).
<zybell_>sorry its named annotated tag here: https://git-scm.com/docs/git-tag
<zybell_>The problem is only to get the *author* to sign the files.
<mbakke>beneroth: for now you can do that manually, the server enforces that all commits are signed. You don't have to use `guix pull`.
<mbakke>See https://www.gnu.org/software/guix/manual/guix.html#Building-from-Git for how to run directly from a git checkout.
<beneroth>ok thx
<userr>Hi.
<userr>About tome4 package.
<userr>From Wikipedia:
<userr>The game may also be purchased through the digital distribution outlets Steam[2][3] or GOG.[4] The game's TE4 game engine source code is under a GNU GPLv3 license,[5] the game's assets are licensed for use "with the Tales of Maj'Eyal game only."[6]
<userr>Non‐free assets.
<userr>Are them fixed in Guix?
<niebie>hey guix - quick question to see if anybody else has this issue
<niebie>i run emacs as a daemon, and love the built in info/man modes
<niebie>but with guix, if i start a guix environment for development of a sdl application, the sdl man pages wouldn't be installed for the daemon
<niebie>i was wondering if anybody else had this issue, and if they just decide to run emacs as a non-daemon in the guix environment
<zybell_>if you buy an e-book as pdf you can read it on a free reader. Nobody can "fix" your e-book to free.
<userr>FREEDOM ISSUE FOUND
<zybell_>niebie:if emacs the daemon looks into your profile and you install the pages in question into your profile, I think it would work.
<niebie>zybell_: have the emacs daemon look into the guix environment profile as well as my own?
<niebie>i don't install development tools into my default user profile ~/.guix-profile
<userr>CRITICAL: in tome4/share/licenses/COPYING-MEDIA there is "All the medias located in all the "/data/gfx" folders are granted to use with the Tales of Maj'Eyal game only."
<zybell_>Then use a development profile
<userr>Will /gnu/store/*tome4* directory(‐ies) be removed if I will do "guix package --roll-back", then remove the generation?
<niebie>zybell_: it isn't clear what you mean by that. it sounds like you are saying 'give up and install dev tools in the ~/.guix-profile'
<zybell_>you can make as many profiles as you want, you only have to tell guix about it.
<zybell_>If you tell emacs about it too (emacs is that *progammable* editor you know) it will find it.
<userr>How can I remove tome4 from my Guix?
<zybell_>s/progammable/programmable/
<userr>How can I remove /gnu/store/*tome4 directory?
<userr>s/*tome4/*tome4*/
<zybell_>rollback and gc
<userr>Is it safe enough?
<userr> https://www.mail-archive.com/bug-guix@gnu.org/msg07990.html
<userr>Anyway, I have done it.
<userr>I have done "guix package --roll-back", then "guix package -r tome4" without deleting next generation.
<userr>Where is the generation now?
<userr>Removed or hidden?
<pkill9>userr: see in /var/guix/profiles/per-user/<user>/
<userr>I see it in guix package --list-generation but without "tome4" package.
<userr>I see empty string instead of package name(s). Is it safe to remove this generation?
<pkill9>use --delete-generations=<generation number> i think
<pkill9>--delete-generations takes a regex
<pkill9>but if you don't give a regex, it deletes all generations but the current one
<pkill9>which is safe if you don't intend to roll back to any of them
<userr>Is it safe to roll back generation with no packages?
<pkill9>i dunno what you mean
<pkill9>i think hubzilla would be cool to have in the guix repos, since diaspora is in them
<pkill9>oh it\\s not
<userr>Are generations n − 1 and n same? I see empty string instead of package list for generation n.
<pkill9>paste the output into a pastebin
<JorgeMorais>Hi. I use Debian buster on my workstation and Ubuntu 16.04.4 (preinstalled) on my personal laptop (I intend to later migrate it to Debian, which better respects libre software ethics). In the workstation, I have installed afew (version 1.3) and notmuch via the Debian repositories. In the laptop I have installed notmuch 0.26.1 though Guix. Now I want to install afew on the laptop, but it is missing on Ubuntu repositories, and in G
<JorgeMorais>it is version 1.2. Guix's recipe for afew seems not to apply any patch; and while I don't know Scheme or Guix's API, the recipe is quite short and apparently simple. Therefore it seems safe to "blindly" transform it into a 1.3 recipe, right? How exactly would I do that?
<userr>Generation n − 1 date
<userr>+ package
<userr>Generation n
<userr>[empty string]
<userr>I have done "guix gc".
<userr>There are some files left:
<userr>/gnu/store/<stripped>-tome4-1.5.5.drv
<pkill9>you need to delete previous generations before guix gc will remove them
<ngz>You can also directly remove some part of the store with guix gc /gnu/store/...-tome4-1.5.5.drv
<pkill9>oh yeah that too
<efraim>Don't edit the store by hand, bad things will happen
<pkill9>and it won't delete that part of the store if it's part of a garbage collector root i think
<pkill9>so it's safe to do i believe
<userr>Why are *tome4* files here?
<ngz>efraim: Using guix gc to remove some part of the store is not editing the store by hand.
<pkill9>but yeah don't use `rm` ever on the store
<efraim>ngz: true, I misread your comment
<pkill9>userr: could be something leftover
<pkill9>guix generates lots of stuff
<userr>Do I need to use "..." or file names?
<pkill9>userr: what's your goal?
<efraim>JorgeMorais: you'll need to clone the guix repo if you want to submit a patch to update the version, most updates are fairly straightforward
<pkill9>i'm not sure what you're trying to do
<userr>pkill9: Remove anything left of tome4.
<userr>pkill9: s/of/from
<pkill9>userr: do you need your previous profile generations?
<pkill9>if not, just run `guix package --delete-generations && guix gc`
<userr>pkill9: I have removed generation with tome4.
<pkill9>do you have any registered GC root?
<pkill9>roots*
<pkill9>is apache packaged in Guix?
<userr>I don’t know.
<userr>I don’t have apache package.
<efraim>apache is in as httpd iirc
<pkill9>cool
<userr>I have done guix package -i tome4
<userr>Then read the license.
<userr>Now I need to remove it.
<userr>Completely.
<pkill9>ah
<pkill9>you can always do `cd $(guix build tome4)` instead
<pkill9>it would return a store path with it but wouldn't register it in your profile
<userr>How Can I remove these 4 files?
<pkill9>if you wanted to browse it's files
<pkill9>`guix package -r tome4`
<niebie>JorgeMorais: you can define a custom package in a .scm file located in GUIX_PACKAGE_PATH
<pkill9>then remove that profile generation and then `guix gc`
<niebie>JorgeMorais: http://paste.debian.net/plain/1020332
<niebie>JorgeMorais: i'm running 'guix build afew-1.3.0' and it seems to be working fine
<ngz>userr: Have you read <https://www.gnu.org/distros/free-system-distribution-guidelines.html>, in particular "Non-functional Data" part?
<userr>ngz: Yes.
<ngz>Great.
<userr>Then I need other distribution.
<JorgeMorais>niebie: thank you, I will test it here.
<JorgeMorais>efraim: thank you too.
<pkill9>userr: what do you need another distribution for?
<userr>pkill9: I don’t want to have a distribution with non‐free non‐functional data in any package.
<userr>pkill9: Functional data must also be free in all packages.
<pkill9>oh ok
<pkill9>why's that?
<userr>Because I want to run free * only.
<niebie>JorgeMorais: guix build did finish successfully, and the build artifact ran fine. do you know how to setup custom packages?
<niebie>
<JorgeMorais>niebie: no, I don't know. And I would like to set it up in such a way that when the official 1.3.0 recipe arrives, I get it by simply running `guix pull && guix package -u'.
<userr>Any distribution without non‐free non‐functional data?
<ngz>Maybe gnewsense ?
<PotentialUser-48>Could someone provide some insight for me? Having a bit of trouble with my audio.
<thomassgn>PotentialUser-48: what is your problem? do you see any errors? need a bit more information to troubleshoot it