IRC channel logs

2018-02-04.log

back to list of logs

<DoublePlusGood23>I got a hardcoded -Werror in a makefile, how do I use sed in a lambda to remove it?
<pkill9>how do i change the phases used int he gnu-build-system?
<pkill9>i'm looking here https://www.gnu.org/software/guix/manual/guix.html#Build-Systems
<pkill9>i dunno how to just specify phases cos i'm a guile n00b
<pkill9>i relaly need to learn it
<pkill9>it says 'ERROR: modify-phases: unbound variable'
<pkill9>nvm, had to import 'guix build utils'
<yann-kaelig>So if I understand all the linking betwenn eahc store is done by the OS. For example I'm trying to start fluxbox. I installed xorg-server, xinitrc, xauth, libinput, xf86-video-vesa. I edited my user .xinitrc, but when I execute startx I get this output > unable to run server /gnu/store/$hash-xinitrc-1.3.4/bin/X: no such file or directory. And that true because X a symlink to Xorf is inside another /gnu/store/$hash-xorg-server-1.9.16/
<yann-kaelig>bin/
<yann-kaelig>I'm using a foreign OS
<DoublePlusGood23>I get a nasty "wrong type to apply: "" " with my code, https://notabug.org/doubleplusgood23/guix/commit/14c8a7465db7e4a53bcaead43533c299aa5ad238
<DoublePlusGood23>Not quite sure what syntax is messed up, it's obviously in the 'patch-werror section
<yann-kaelig>is the job to GuixSD to make each gnu/store be able to communicate each other ? How can I tell xinit store to find the X inside the xorg-server store ? Can I with a foreign distrib ?
<DoublePlusGood23>Does anyone have an opinion on what type to apply? I assumed an empty string was fine
<DoublePlusGood23>yann-kaelig: You'll need it in your PATH most likely
<DoublePlusGood23>I wouldn't recommend running an entire X setup from guix on a seperate distro.
<buenouanq>yeah, if you're going that far, why not just try GuixSD?
<yann-kaelig>DoublePlusGood23: in my path I have /home/myuser/.guix-profile/bin:/home/myuser/.guix-profile/sbin it's not enough ?
<yann-kaelig>buenouanq: I can test GuixSD inside a VM too , but I supposer it's goign to be hard to get some proprietary part as I ask for nvidia
<yann-kaelig>and I'm certainly goign to install GuixSD to learn more
<pkill9>it's probably gonna be confusing to debug, i'm sure it's possible though
<pkill9>possible to use Guix's X on a foreign distro i mean
<pkill9>but may be more hassle than it's worth
<pkill9>can you use your distro's installation of xorg with the window manager installed through Guix?
<pkill9>e.g. `startx ~/.guix-profile/bin/awesome`
<yann-kaelig>interesting I can test this idea
<DoublePlusGood23>yann-kaelig: hmm that should be enough. X might need more
<yann-kaelig>I'm not an expert with xinit, but I coudl be able to start the server just with a xinit command line
<yann-kaelig>xinit ~/.guix-profile/bin/awesome give me something more interesting
<yann-kaelig>he's looking inside the share/X11/xorg.conf.d directory but failed on parse_vt_settings : Cannot open /dev/tty0 ( permission denied )
<pkill9>yann-kaelig: doe sit work if you open fluxbox with your distro's xorg-server?
<pkill9>does it*
<yann-kaelig>pkill9: I don't know , I started with a minimal installation to be sure to not get any issue. I will try to install guix on another VM with xorg-server / DE and all the stuff installed
<yann-kaelig>there is a little change if I had myself to the tty group , but I don't know if it's the right thing to do
<pkill9>im confused, do you not have X installed via your distro's package manager?
<pkill9>g2g
<yann-kaelig>something new I have created the file Xwrapper.config inside .guix-profile/etc/X11 the xf86openconsole cannot open virtual console 3 gone but now I have : modeset(0) drmSetMaster: Permission denied
<yann-kaelig>I installed xorg-server and xinit with the original OS package manager but it doesn't matter startx or xinit always looking inside .guix-profile
<yann-kaelig>using*
<yann-kaelig>anyway it's just a first test, I will try again in a new VM from the beginning as soon as I will be able to rfix the issue
<yann-kaelig>that mean start Xorg with a WM
<OriansJ>yann-kaelig: if you are trying a minimal system, might I suggest you git clone the guix package and look in gnu/system.scm for define %base-packages, that should help you really reduce what is installed on guix. (Similar can be done with %desktop-services in gnu/services/desktop.scm
<yann-kaelig>OriansJ: thx a lot , I will test this, tomorrow. I'm off, tired time to eat and got osleep :)
<yann-kaelig>thx a lot for your help
<OriansJ>yann-kaelig: grep -iR is your friend for finding where things are defined and we are always glad to help :D
<yann-kaelig>thank you, and personally I do not give up so easily :)
<Apteryx>can I reference to other fields inside a package definition?
<OriansJ>Apteryx: guix runs on guile, so anything you can do in guile is what you can do in guix
<apteryx1>I'm trying to do something like: `(map some-function inputs)inside à package définition but it fails saying inputs is a proc or something.
<apteryx1>I'd expect inputs would refer to the inputs field of the package, which should be a list.
<az`>hi there all
<az`>great guixers, why there is docker-compose, but no docker in repo?
<az`>ok, next actual question: What you use to sync folders over local network? Syncthing or something?
<efraim>I use a bit of syncthing and I rsync or sshfs with my RPI server
<efraim>Docker compose doesn't use go, docker has lots of go to build so no one's gotten around to it
<jeko>Hello Guixters
<ng0>yann-kaelig, let me be the "look on the bright-side" messenger: once you grok Guix, it will be relatively struggle-free, little steps involving to do whatever modules you need outside of the official distribution. But you'll still get no official support, that's the experimenting side of it. Not endorsing it, I'm just saying it's possible.
<ng0>speaking of which, what makes software coming from BSDs or with developers working on BSDs but targeting everyone else, print "BSD General Commands Manual" in the man pages? the man page itself has nothing like this.. at least spectrwm is like this
<ng0>ah.. .include <bsd.prog.mk>
<ng0>but actually bsd.man.mk would be it.. so I'm puzzled
<ng0>need to look more into this
<yann-kaelig>elo
<yann-kaelig>this guix edit command is a revolution in the gnulinux world, it's awesome
<atw>:)
<yann-kaelig>no idea if it's the right way to do, but I want to rebuild xorg-server with my own build option, so I guix edit xorg-server, made my change and now want to save it, but I don't know what to do wit hthis hard-link question, should I detahc before ?
<yann-kaelig>detch
<yann-kaelig>detach
<cbaines>yann-kaelig, I'm not following, what is the hard-link related question, is that something your editor is asking you?
<yann-kaelig>yes > Warning : File has hard-link. Detach before saving ?
<cbaines>Hmm, it sounds like you might be trying to edit a Guix package in the store, which won't work
<yann-kaelig>ha tha mean Ican't made a change like that. Indeed xorg-server is installed
<cbaines>I'd recommend cloning the Guix git repository, and then creating a symlink at ~/.config/guix/latest that points at the checkout of the repository
<cbaines>Once you do that, guix edit will open up the files in the git repository, rather than the guix package you are using from the store
<cbaines>(you'll also need to ./bootstrap && ./configure && make in the Guix repository checkout)
<yann-kaelig>I tried to find a documentation about a documentation that would put into practice this kind of intervention, I mean to understand the basics and start by modifying existing packages with the procedure to follow
<cbaines>The bit about attempting to edit in the store is mentioned in the last paragraph here https://www.gnu.org/software/guix/manual/html_node/Invoking-guix-edit.html
<cbaines>There is some documentation about building Guix in the git repository here https://www.gnu.org/software/guix/manual/html_node/Building-from-Git.html#Building-from-Git
<cbaines>But that doesn't mention how to use Guix from that repository checkout, to do that, you need to make ~/.config/guix/latest a symlink to your Guix checkout
<yann-kaelig>I don't want to hack guix itself, but I want 1) create a local environment for the work 2) Download or clone the source file containing the definition to be sure I never touch the original, 3) Edit my file and give it a new revision number 4) build 5) Install . But I didnt' found any simple doc like that
<cbaines>There are a few ways of doing that, what package or packages in are you interested in tweaking?
<yann-kaelig>xorg-server
<cbaines>Ok, and how do you want to use your tweaked xorg-server?
<yann-kaelig>I want to install it and use it instead of the original
<cbaines>Ok, and you're using GuixSD, or another distro?
<yann-kaelig>another distro
<pkill9>i would just add a $GUIX_PACKAGE_PATH and then copy the xorg-server definition and modify it there
<pkill9>then use the same name for xorg-server and it will prioritise the definition found in your custom GUIX_PACKAGE_PATH
<cbaines>Yes, using a module on your Guix package path sounds like the thing to do
<pkill9>though i think that will rebuild anything that depends on xorg-server
<pkill9>as in, jus tmodifying th ebuild process
<pkill9>but idk maybe it will just patch everythign to point to the new build of xorg
<cbaines>a slightly simpler thing would be to create a file containing the updated definition, and then install it using guix package --install-from-file ...
<cbaines>pkill9, copying the definition in any way won't replace the references to the old definition in other packages
<cbaines>so you won't end up using the tweaked definition unless you explicitly change other packages to do so
<pkill9>oh ok
<cbaines>yann-kaelig, depending on what tweaks you want to make, you're probably better off using something like (package (inherit xorg-server) (name "xorg-server-tweaked") ...)
<cbaines>where ... are your other tweaks
<pkill9>cbaines: so if you want to add a graft to a package, you need to edit the local package definitions?
<pkill9>and you need to rebuild guix too?
<cbaines>pkill9, I don't know much about grafts, but I think it relates to the replacement field of the package record...?
<cbaines>so yes, you'd need to edit the definition
<pkill9>yeah that will make it graft the replacement onto the original
<cbaines>there are some commands that can do this as well
<pkill9>oh there are? nice
<cbaines>guix package supports --with-input and --with-graft to edit the package definitions on the fly
<cbaines>(so things you do with those options will just be done for that invocation of guix package)
<pkill9>i think you can use evnironment variables to set those flags permantently aswel
<pkill9>might be wrong tho
<Apteryx>is it ok to import (guix search-paths) into the builder side?
<Apteryx>I'm trying to create some semi-automatic wrap-program args function, and I need functions that know how to deal with search-paths-specifications
<Apteryx>I guess not.
<Apteryx>Although: ./guix/build/profiles.scm:22: #:use-module (guix search-paths)
<Apteryx>so, builder side code is importing host-side code.
<orelozno1>Hello :) In Virtualbox's installation of GuixSD, here's how far I got with my partition table, using cfdisk and parted
<orelozno1># parted /dev/sda set 1 bios_grub on
<orelozno1> https://www.hubert-lombard.website/GuixSD/cfdisk-parted-bios_grub.png
<orelozno1>With no "bootable" label proposed...
<orelozno1># mkfs.ext4 L root /dev/sda1
<orelozno1># mkfs.ext4 -L home /dev/sda2
<orelozno1>For instance, it's just for test... Before going further I don't know if it's correct.
<orelozno1># mkfs.ext4 L root /dev/sda1
<orelozno1>ARGhhh... # mkfs.ext4 -L root /dev/sda1
<orelozno1>;)
<troydm>how do I delete old generation system?
<pkill9>not sure what yo unmean by old generation system, but you can remove old generatiosn by removing their symlinks in /var/guix/profiles/per-user/<user> (don't remove 'guix-profile' since that's the latest one)
<pkill9>s/latest/current
<troydm>pkill9: what I mean is that when I do guix system list-generations I have to generations 1 and 2, I'm currently on 2 and I want entirely delete 1
<troydm>*two*
<troydm>because it's using disk space and I won't be using it anyway so why not just delete it
<pkill9>the manual says `guix package` has a '--delete-generations' option which if you give with no arguments will delete all generations but the current one
<pkill9>so maybe `guix system --delete-generations` will work
<pkill9>troydm ^
<pkill9>oh it mentions 'list-generations' in the manual but not 'delete-generations' so probably won't work
<orelozno1>:leave
<efraim>for deleting system generations you have to delete the symlink by hand
<pkill9>where are they stored efraim
<efraim>/var/guix/profiles/
<Rnytom[m]>does anyone know if it's possible to install a package from an older commit without doing guix pull ?
<Rnytom[m]>For example I would like to install the lastest working version of syncthing (0.14.43 doesn't build) without changing available versions of other packages
<pkill9>oh thoguth so
<troydm>efraim: just deleting symlink won't delete it's tree of packages that might not even be used anymore right?
<efraim>thats right, you'll have to run 'guix gc' to remove them from your harddrive
<troydm>efraim: so essentially you guys can add a command to guix system called delete-generation that would just delete symlink and then run guix gc?
<efraim>we could add a command to remove older generations, we'd still leave the 'guix gc' step as a separate step though
<troydm>efraim: yeah that would be good
<troydm>guix gc: freed 1,261,432,832 bytes
<troydm>not bad not bad
<troydm>ahhh
<troydm>grub is not refreshed
<troydm>now how do I do that?
<troydm>I still see old generation entries in grub boot menu
<efraim>grub gets refreshed when you reconfigure
<efraim>although that does seem like it's worth reporting as a bug that after removing generations and rebooting that they're still available at the grub menu
<pkill9>mmm I wanna try guixsd as operating system once I'm used to writing my own packages
<Apteryx>how can I reconfigure my system using my guix checkout?
<Apteryx>ok, there was some interaction with (include "some-file.scm") and the pre-inst-env script that made "guix system reconfigure config.scm" spit the error: "guix system: error: failed to load 'config.scm': No such file or directory." Weird. I gave it the absolute path now, and it works.
<yann-kaelig>I can see some plasma and kde-framework package but what the package name to get at least a minimal kde(5) DE
<atw>I believe kde is not packaged -- see https://www.gnu.org/software/guix/manual/html_node/Limitations.html#Limitations
<yann-kaelig>KDE is great DE now don't waste your time with jokes like enlightenment or useless Xfce4 or even old with no futur like lxde. 2018 is the year of wayland/compositors and will be installed in all cottage. The future is now, now it the turn for new project like sway
<yann-kaelig> http://swaywm.org/
<buenouanq>xfce is perfectly great
<Apteryx>sneek: later tell ng0 I've sent a new patch for mcron2 which wraps the Guile and GnuTLS modules. It should work better when used in the system profile (where Guile and GnuTLS might not be propagated).
<sneek>Will do.
<pkill9>xfce is fine for me
<pkill9>why is KDE not packaged with Guix?
<amz3>because it's a lot of packages?
<amz3>I mean to say: because nobody did it.
<pkill9>oh ok
<pkill9>just wondered
<amz3>I don't think there is another reason, there is no license issue with kde
<buenouanq>After years of ignoring it I finally decided to give Gnome a chance and I actually quite like it.
<amz3>^^
<buenouanq>any other deadhead guixers between seattle and san diego wanna get together next month?
<buenouanq>who am I kidding, there aren't any other deadheads who use guix ( ._.)
<buenouanq>yet
<buenouanq>I see what I can do.
<DoublePlusGood23>buenouanq: i haven't got into the greatful dead, where's a good place to start
<DoublePlusGood23>Anyone interested in packaging Telegram please checkout my guix-devel email :-)
<DoublePlusGood23> http://lists.gnu.org/archive/html/guix-devel/2018-02/msg00050.html
<buenouanq>oh man, idk - that's a good question and it's going to be different for everyone
<buenouanq>maybe we should do this in a pm though
<ng0>maxim: thanks!
<sneek>Welcome back ng0, you have 1 message.
<sneek>ng0, Apteryx says: I've sent a new patch for mcron2 which wraps the Guile and GnuTLS modules. It should work better when used in the system profile (where Guile and GnuTLS might not be propagated).
<ng0>going to try it now