IRC channel logs

2017-12-27.log

back to list of logs

<taohansen>hey, my laptop is constantly accessing my disk (running GuixSD). this may be a more general Linux question but what's a way to peek into what process is doing all this accessing?
<taohansen>i have an SSD and if it's constantly writing, i'm a little concerned for its lifespan
<str1ngs>taohansen: iotop might help
<taohansen>strings: thanks, installing that now. just checked regular `top` and it looks like my machine is using literally half of its 32 gigs of memory which seems somewhat insane to me
<str1ngs>taohansen: linux will use as much RAM for caching as possible.
<str1ngs>so you need to read top or htop correctly
<str1ngs>I use htop makes it easier to read
<taohansen>looks like it was transmission-daemon, thanks so much
<str1ngs>np
<str1ngs>I've been planing on writing a package for deluge. I don't like transmission that much myself
<taohansen>Emacs has a package for Transmission's daemon, which i enjoy. if i can abstract its operation to Emacs, i'm a happier person hah
<foxmean>Hello, I've a problem. I've just install GuixSD and I wich to install emacs. But it doesn't work In Technoethical x200 with normal user install under GNOME Wayland. Can I really remove Emacs and Reinstall (redownload form package repository). I've use "sudo rm -rf /gnu/store/'hash'-emacs-25.3 but it doesn't work and show that I cannot remove due to there are read-only file. Now I'm using emacs-minimal instead. However, Emacs GUI make me
<foxmean>feel more happy.
<str1ngs>you don't want to manually remove files from the store
<str1ngs>if you want to install emacs gui. you can simply run guix package -i emacs
<str1ngs>if you configured your system with emacs-no-x and you want to remove it use guix system reconfigure
<foxmean>I've installed Emacs GUI, But it doesn't work. I've try to open it but nothing pop-up. Even "emacs -nw" was didn't work. I think maybe package was corrupt at some point. So I've consider /really/ reinstall it. Because "guix package -r emacs" didn't /really/ remove it. I've reintall Emacs and the problem didn't go away.
<str1ngs>foxmean: what does which -a emacs show?
<vagrantc>foxmean: maybe your $PATH is out of date? (kind of what str1ngs might have been hinting at)
<foxmean>Please wait a minute, I've to remove emacs-minimal and install emacs agian then I'll comeback. Thank you.
<foxmean>test
<foxmean>My "which -a emacs" is "/home/foxmean/.guix-profile/bin/emacs"
<foxmean>This is the output of running emacs in my terminal => "/gnu/store/d39xg06h35k91syyp7k3lhiprwxii2ii-emacs-25.3/bin/emacs-25.3[0x8176e5d]
<foxmean>...
<foxmean>Abort"
<foxmean>There are many lines in there but it look like the last one.
<str1ngs>foxmean: you mentioned you manually deleted files from the store?
<foxmean>Yup strlngs
<str1ngs>that might be the problem.
<foxmean>Yes, I think so.
<str1ngs>just so you know, the store is managed by guix. and when you remove and install. it only creates links into the store
<str1ngs>if you are familiar with gnu stow it's the same idea
<foxmean>So, can I really remove it?
<foxmean>Or, I've to re install GuixSD agian? I can do it, but it was time consumer (my internet speed was so slow).
<str1ngs>you can try guix gc -d /gnu/store/d39xg06h35k91syyp7k3lhiprwxii2ii-emacs-25.3
<str1ngs>but you make need to remove first with guix package -r emacs
<str1ngs>after which you can reinstall. and hopefully the will fix the store
<str1ngs>they might be an easier way to repair, not sure how myself
<foxmean>Thank you. I'll come back soon. I've done "guix package -r emacs" but after your command it show "guix gc: error: build failed: cannot delete path `/gnu/store/d39xg06h35k91syyp7k3lhiprwxii2ii-emacs-25.3' since it is still alive". I think may be reboot and do it again will work.
<foxmean>It didn't work and show same error. But now I have to go to work. Maybe I will reinstall GuixSD again because of messing that I cause.
***Piece_Maker is now known as Acou_Bass
<Stream>is it possible to write in config.scm to install packages for users, or it should be done only using guix command?
<str1ngs>Stream: you can create a manifest file and use -m
<str1ngs>ie guix package -m manifest.scm
<str1ngs>unless you want it system wide?
<Stream>no
<Stream>thanks
<str1ngs>no you don't want it system wide?
<Stream>no i dont want it system wide, i want it only for one user
<str1ngs>ah I use manifest for that. you can use -l but -m is easier to use
<str1ngs>(specifications->manifest '("emacs", "git"))
<str1ngs>basic manifest.scm file
<str1ngs>alternatively you can use environment. but I suspect you are looking for manifest
<Stream>another question: i got 4 partitions boot root swap home, i need to make file-system fields for each one in config.scm right?
<str1ngs>yes
<str1ngs>also efi if you plan to use GPT and EFI
<str1ngs>if not, don't worry about it
<efraim>i also added one for /var/guix/temproots because I could :) http://git.flashner.co.il/cgit/cgit.cgi/guix-config.git/tree/macbook41_config.scm#n28
<foxmean>Hello, I'm here again. I've had a problem about opening Emacs. I've try to reinstall entire GuixSD again and login as normal user to install Emacs again. But it didn't work.
<foxmean>This is my error output => https://pastebin.com/M4AZMm6v
<foxmean>And this is my config.scm => https://pastebin.com/ZyKtAh6A
<foxmean>My machine is Technoethical x200 with 250GB SSD sumsung 850 EVO
<str1ngs>foxmean: how did you reinstall with guix system reconfigure?
<foxmean>I can install and using other packages like Gimp, irssi, or even emacs-minimal. But not Emacs itself. I still don't know why? Are there any problem in reposiroty (or build farm) now?
<foxmean>strlngs: I've reinstall it from scratch.
<foxmean>I've format hardrive and install it again.
<foxmean>Or actually SSD not HDD.
<str1ngs>hmm strange
<str1ngs>what is the output of guix --version?
<foxmean>foxmean@tex200 ~$ guix --version
<foxmean>guix (GNU Guix) 0.14.0
<foxmean>Copyright (C) 2017 the Guix authors
<foxmean>License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
<foxmean>This is free software: you are free to change and redistribute it.
<foxmean>There is NO WARRANTY, to the extent permitted by law.
<str1ngs>ok one sec
<str1ngs>foxmean: guix build emacs what hash do you get?
<foxmean>/gnu/store/d39xg06h35k91syyp7k3lhiprwxii2ii-emacs-25.3
<str1ngs>foxmean: as root run guix build --repair emacs
<foxmean>Can I use 'sudo'?
<str1ngs>yes but use . sudo -i guix build --repair emacs
<str1ngs>-i enforces a login its short for --login
<str1ngs>what is the name of your x200? I'm curious. because I use a x220
<foxmean>The output was: /gnu/store/d39xg06h35k91syyp7k3lhiprwxii2ii-emacs-25.3
<str1ngs>ok, and when you run emacs now?
<foxmean>And when I run Emacs. The error was the same.
<str1ngs>ok one sec
<str1ngs>foxmean: what filesystem is your / root
<str1ngs>also what happens if you use emacs-minimal?
<foxmean>str1ngs: I don't understand your first question. But the second one was fine. I can run emacs-minimal smoothly.
<foxmean>Note: I've run "guix package -r emacs -i emacs-minimal" before use emacs-minimal. And run it with "emacs" command in GNOME-Terminal.
<str1ngs>your x200 is a core-duo?
<foxmean>Yes: Intel Core 2 Duo SL9300 1.60Ghz, BGA479 (soldered)
<foxmean>As described in technoetical website.
<str1ngs>guix pull might resolve this. but it will take sometime to build
<str1ngs>guix pull will update your package definitions
<foxmean>Ok I'll try that one. Thank you str1ngs.
<str1ngs>my x220 which an i7 and running -c 1 . takes almost an hour to build
<foxmean>I've another question: Can I run guix pull and still use GuixSD to do other things or better not do that?
<str1ngs>you can, depends on your laptops heat
<foxmean>OK, Thank you str1ngs :D
<str1ngs>my heats alot if I leave default -c . means cores
<str1ngs>try just guix pull . and see if it heats alot
<str1ngs>if it does then use guix pull -c 1
<str1ngs>which will use one core
<foxmean>Thanks a lot.
<str1ngs>lscpu should tell you CPUS.
<str1ngs>including virtual cores ala HT
<str1ngs>either way you'll need to do a guix pull. so better get it out of the way now
<foxmean>Ok.
<str1ngs>I use a highend desktop to pull with . and then I use it as a publish substitute . but that's complex to setup
<str1ngs>foxmean: after this guix pull. dont reinstall every. just use guix system reconfigure config.scm
<str1ngs>if you need to change something to system config
<str1ngs>I'm hoping this pull will resolve your store issue
<foxmean>My experience with both command was not so good. It was take A LOT of time for my machine and my internet connection speed. I've take a whole night or actually about not more than 5 hours. But I think it is normal because of a lot of compiling step to do, right?
<str1ngs>foxmean: this first pull can take along time yes unfortunately. after that you should get everything from nicely from substitutes
<str1ngs>foxmean: do you have access to a high powered linux machine
<str1ngs>?
<foxmean>Absolutely not. I'm not working in computer field.
<str1ngs>for now I would do atleast one guix pull.
<str1ngs>also substitutes work?
<foxmean>Another machine that I have is also Laptop which is HP_G32. But that maching isn't proper for runnig GuixSD because of lacking Free wifi firmware.
<foxmean>Anyway, I've test GuixSD on that machine and it was so slowly too.
<foxmean>str1ngs: Oh, I've answser your second question. Not the first one yet.
<str1ngs>my x220 does not have free wifi firmware. so I just built stock kernel.
<foxmean>"foxmean: do you have access to a high powered linux machine
<foxmean>"
<str1ngs>I'll probably burn in hell now
<foxmean>hahaha
<str1ngs>alternatively you can buy a free usb wifi
<str1ngs>free is a freedom drivers
<foxmean>For now, I must wait guix pull and run guix system reconfigure /etc/config.scm after that, right?
<foxmean>I've consider buying that one, for sure, but not now.
<newb12>can i change config.scm after installation?(i forgot to add line about swap)
<str1ngs>newb12: yes, you can use guix system reconfigure config.scm
<str1ngs>foxmean: you don't need to reconfigure right away. you can just do guix package -i emacs . to test emacs. reconfigure would be good later though
<str1ngs>also guix package -u to upgrade user packages
<foxmean>OK
<str1ngs>it may build some package, if not substitutes exist. it's rare but does happen
<foxmean>I see.
<foxmean>Hence, After guix pull. I need to run "guix package -i emacs" and "guix package -u" then see what happen to my Emacs. If it were work, I won't need to run guix reconfigure, right?
<foxmean>sorry "guix system reconfigure config.sc
<foxmean>m
<str1ngs>if you have emacs installed already. then guix package -u will upgrade it
<foxmean>OK.
<str1ngs>-i emacs if you just want to test emacs
<str1ngs>encase -u wants to upgrade alot
<foxmean>I've finished "guix pull". And I've run guix package -i emacs and its hash was change. But when I run it. There are error report look like the same as previous shown. And after that I've run "guix package -u emacs". Then it doesn't work again.
<foxmean>Now, I'm runnig "guix package -u"
<foxmean>And it is compiling.
<str1ngs>what is it compiling?
<str1ngs>I'm still worried about the emacs errors
<foxmean>Lock like gimp, now.
<foxmean>*Look
<str1ngs>can you pastebin output of when you run emacs
<foxmean>yup
<foxmean> https://pastebin.com/fyZZ9Yek
<str1ngs>what is output of guix --versoiin
<foxmean>And this was output when I run "guix build emacs" => /gnu/store/lgdrdz7v2574kypp2jzx9sk1p8dbzd1b-emacs-25.3
<str1ngs>err --version
<foxmean>guix (GNU Guix) e8e860a5596659e0ce2ed8911dfa78663e216bf9
<foxmean>Copyright (C) 2017 the Guix authors
<foxmean>License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
<foxmean>This is free software: you are free to change and redistribute it.
<foxmean>There is NO WARRANTY, to the extent permitted by law.
<str1ngs>what happens when you run emacs -Q
<str1ngs>foxmean: ^
<foxmean>Wait a minute my internet was so slow. :D
<foxmean> https://pastebin.com/GGvDSf7e
<foxmean>This was an output.
<str1ngs>seems related to https://lists.gnu.org/archive/html/help-guix/2017-11/msg00054.html
<str1ngs>foxmean: ^ something related to gtk
<foxmean>str1ngs: I'm confusing. But I've an idea: I might write a package definition of emacs by hand without using gtk, right?
<foxmean>Or another option is to use GDB?
<newb12>i am a little confused, after installation i logged in as a user and then made sudo guix pull, but when i try reconfigure it sais guix pull was never run, so i need to do reconfigure as root or pull as user, does it matter if i try to reconfigure as root or user or i can do for both?
<wigust>foxmean: Could you try "emacs -nw"?
<wigust>newb12: You can use reconfigure only as root, so you need to pull as root
<newb12>can i do user sudo or i need to literally log in as root and run it?
<wigust>newb12: sudo is fine
<newb12>thanks
<newb12>are there any negative consequences after i ran guix pull as user?
<foxmean>wigust: same problem as just 'emacs'
<wigust>newb12: It's discussed in the documentation https://www.gnu.org/software/guix/manual/html_node/Invoking-guix-pull.html
<foxmean> https://pastebin.com/Ax6mTR2z
<foxmean>The error output look like the same.
<wigust>foxmean: check out fonts as https://github.com/hlissner/doom-emacs/issues/244 suggests
<foxmean>wigust: This is diff of output 'emacs' and 'emacs -nw'
<foxmean> https://pastebin.com/Hzp3btig
<foxmean>wigust: So, I need to write my init.el like that present in your link, isn't it?
<foxmean>(set! :font "Ubuntu Mono" :size 15)
<foxmean>(set! :big-font "Ubuntu Mono" :size 18)
<foxmean>(set! :variable-font "DajaVu Sans" :size 15)
<foxmean>(set! :unicode-font "DejaVu Sans Mono" :size 15)
<foxmean>?
<foxmean>wigust: It didn't work;this is the output of 'emacs' after I've include that to my init.el => https://pastebin.com/gvcTgtmM
<str1ngs>a related ML thread https://lists.gnu.org/archive/html/help-guix/2017-11/msg00054.html
<wigust>foxmean: What about "guix environment -C --ad-hoc emacs" then "TERM=xterm emacs -nw"?
<foxmean>wigust: didn't work and output look like the same as previously.
<foxmean>str1ngs: I've read that and so confusing. By my guess, I need to write my own package definition, isn't it?
<foxmean>Maybe use emacs-minimal instead is better for now. :p
<foxmean>After a while I will write it when I've more experience in guix package manager.
<str1ngs>I don't think that is the fix
<wigust>foxmean: Try to build without grafts
<wigust>foxmean: 'guix build --no-grafts emacs'
<foxmean>This is new hash after build --no-grafts
<foxmean>/gnu/store/64shsn6hc1xxab8vqn230b6gnrq04lxb-emacs-25.3
<foxmean> https://pastebin.com/txmVrDss
<foxmean>This is the output
<foxmean>And I've try to dif between before and after build-nograft's output: No difference found.
<foxmean>(I've redirected error message to file and diff between them).
<foxmean>The output was nothing.
<foxmean>str1ngs: I've not try guix reconfigure yet. Is try run "guix system reconfig" still possible solution now?
<wigust>foxmean: I succeeded to run on e8e860a5596659e0ce2ed8911dfa78663e216bf9
<wigust>foxmean: https://paste.debian.net/plain/1002535
<wigust>foxmean: no, system reconfigure doesn't do anything in this case
<wigust>foxmean: you should be able to run it in even in container only with emacs in it as you tried it with guix environment
<foxmean>Ok wigust I'm testing your script now "guix environment --pure guix --ad-hoc help2man strace git gdb". Thank you. But it's take time. So, I'll tell you again after it finished.
<wigust>foxmean: I wonder why my hash is differ from your /gnu/store/64shsn6hc1xxab8vqn230b6gnrq04lxb-emacs-25.3 vs my /gnu/store/cyflzmifi6cm720a46g80l3r02l2f6az-emacs-25.3
<foxmean>wigust: I've no idea about that.
<wigust>foxmean: Did you build Emacs locally?
<wigust>ACTION just got a substitute one
<foxmean>wigust: Nope. I use "guix package -i emacs".
<foxmean>Now, I've to go out for eating. If you still here when I'm back, I'll tell you the result.
<foxmean>Thank you so much.
<foxmean>wigust: It didn't work.
<foxmean>So, Thank you every one; I'm so tried now. I will use emacs-minimal instead.
<foxmean>And hopefully in the future there will be fixed.
<Guest36956>Hello,
<Guest36956>I'm having some issues with nginx. I have a (use-service-modules web) in my config.
<Guest36956>Do I need to specify nginx somewhere else?
<Guest36956>herd start nginx isn't working...
<gnewb`>Hello Guix
<Guest36956>hello
<gnewb`>I was wondering whether the syntax for declaring mapped devices has changed.
<mlin>Hello all. I just installed GuixSD and I've been playing with it for a while, but I have run into an issue when building a program. Is there any package in the repo like `base-devel` or `build-essential` as I know them in other distros?
<jonsger[m]>mlin: gcc-toolchain
<joshuaBPMan>afternoon guix Squad
<stefanc_diff>what is the way of getting the equivalent of the CA certificate bundle in guix ? The equivalent of "/etc/ssl/certs/ca-certificates.crt"
<pkill9>stefanc_diff: https://www.gnu.org/software/guix/manual/guix.html#X_002e509-Certificates
<stefanc_diff>pkill9, found that page in the interim time
<stefanc_diff>thanks
<stefanc_diff>problem is that I was trying to use https in a guix environment --container
<stefanc_diff>which fails unless openssl is added to the container
<stefanc_diff>s/container/environment
<boegel>would it be wrong to label GNU Guix as "alpha", since there's no v1.0 version yet? is anything like that stated officially somewhere?
<boegel>(context: I'm working on a presentation that compares Guix with other installation tools)
<ConfusedLizzard>Hello, due to my recently awakened interest in scheme I wanted to start to play around with GuixSD. But I had some problems installing GuixSD on two of my computers. On my laptop, neither the internal nor a external usb wifi card are recognized. I read the logs and apparently there is a problem with "free firmware not found". Since this distro uses linux-libre this was expected. Since a laptop without wifi is useless, i tried my
<ConfusedLizzard>computer. Booting in UEFI mode is not possible there, since my computer freezes at "fb: switching to radeondrmfb from EFI VGA". The GPU there is a r290x. All the other components seems to work, as i tried installing in legacy boot mode but ran into a wall when it tried to install grub in efi mode. This seems not possible in legacy mode. Has anyone experienced something similar? What hardware stats should I post?
<ConfusedLizzard>@boegel This installation splash actually warns you that guixSD is alpha. No idea if this applies to the packagemanager itself.
<ConfusedLizzard>@boegel corrention: It says "... Furthermore, it is 'beta' software so it may contain bugs."
<ConfusedLizzard>how could i manually create a efi grub for guixSD? The guixSD installer gave up on me, as it does not want to boot in UEFI mode.
<ConfusedLizzard>Is there a way of booting the guixSD installl medium with the ssh daemon already running? This way i could install without graphics, which seems to be the problem
***gnu is now known as Guest22529
<Guest22529>Does the newest guix iso have a gui installer? I was having issues trying to install the distribution last time I tried.
<ConfusedLizzard>Since some time has passed and new people have joined / left the channel i will repost my problem
<ConfusedLizzard>Hello, due to my recently awakened interest in scheme I wanted to start to play around with GuixSD. But I had some problems installing GuixSD on two of my computers. On my laptop, neither the internal nor a external usb wifi card are recognized. I read the logs and apparently there is a problem with "free firmware not found". Since this distro uses linux-libre this was expected. Since a laptop without wifi is useless, i tried my
<ConfusedLizzard>computer. Booting in UEFI mode is not possible there, since my computer freezes at "fb: switching to radeondrmfb from EFI VGA". The GPU there is a r290x. All the other components seems to work, as i tried installing in legacy boot mode but ran into a wall when it tried to install grub in efi mode. This seems not possible in legacy mode. Has anyone experienced something similar? What hardware stats should I post?
<adfeno>I wonder if you can pass "nomodeset" to the GuixSD GRUB entry while under UEFI mode.
<ConfusedLizzard>@adfeno uhh, yeah. Thank you for answering. I forgot to write what solutions i tried already. Yes i tried editing the grub menu entry with 'e'. I added on the same line that countains "linux .... --root= ..." the nomodset statement. Sadly, during boot it still sayys "fb: switchung to radeondrmfb from EFI VGA"
<ConfusedLizzard>My desktop pc uses a xeon cpu which does not include a iGPU. My connection to the display is via DVI directly to the r290x GPU.
<ConfusedLizzard>lol fuck me. I do not deserve computers.
<amz3>ls
<amz3>sorry
<ConfusedLizzard>i typed nomodset because I was thinking about "mod" as in "module". But it is nomodEset
<ConfusedLizzard>people connecting with a webclient usually need help.
<amz3>I am trying to fix guile-wiredtiger to be a state of the art package, make distcheck works but guix.scm included in the project fails with a weird error related to wiredtiger itself, it seems like the previous cnx is not closed properly
<amz3>or something like that
<amz3>also I need to package microkanren separatly
<amz3>... is there a build system for pure scheme packages?
<amz3>going through the autotools chain is a pain for simple packages
<ConfusedLizzard>Since this is a IRC for a fully free Distro, which browser do you all use? Avaible on GuixSD ofcourse. I currently use qutebrowser and firefox. But since qute is very out of date on guixsd i would not want to use it there.
<ConfusedLizzard>There is also a very early alpha browser written in common lisp written and similar to emacs. Seems like the perfect fit for this distro. But there is a problem, as it firstly has no linux port yet. And i think the license is a problem. Is this license a free licesene? https://github.com/nEXT-Browser/nEXT/blob/master/LICENSE
<buenouanq>Icecat
<buenouanq>GNU"s packaging of FF
<wigust>ConfusedLizzard: Also Epiphany
<ConfusedLizzard>buenouanq wigust thank you for the recommendations.
<wigust>ConfusedLizzard: Also there is a conkeror browser, which is Icecat + Emacs like interface and keybindings.
<ConfusedLizzard>wigust Yes, i used it for a short time. I thought it was a nice concept of using js for all configs. But as of firefox 57 conkeror is dead.
<buenouanq>Epiphany is just [confusingly] called `Web' if you've installed Gnome.
<wigust>ConfusedLizzard: Conkeror is really powerfull. You could export all the stuff after all.
<wigust>ConfusedLizzard: And it's still maintained.
<nee`>Does anyone want to make an ad for guix for the 34c3? They get shown on the screens between talks for about 10 seconds each. See the submit page for examples: https://34c3.infobeamer.com/
<ConfusedLizzard>wigust As far as I heard is that the new addons system (webextensions) prevents conkeror from beeing based on newer versions. For some time this would be ok, but a webbrowser not seeing updates for longer periods of time does not seems like a good idea
<nee`>I have a github account that can be used for submits. The ad has to be 16:9. Here is the full requirements text: https://p.sicp.me/dEvKT
<ConfusedLizzard>what key features do we want to point out?
<wigust>ConfusedLizzard: I guess they will switch to waterfox or what ever with webextensions.
<wigust>There is just no other browser like that (dunno about nEXT with focus on mac and strange license)
<ConfusedLizzard>weird. I selected lightweight desktop as base config. I only added stumpwm. Why does this install xorg AND wayland?
<ConfusedLizzard>wigust maybe an email could convince the next author to switch to a tried and proven license. I think convicing him to go the GPL route would be hard but some less extremeist licenses like BSD or MIT could be.
<ConfusedLizzard>I have another problem during install. It said ...grub-efi-2.02/sbin/grub-instal: error: failed to get canonical path of /boot/efi