IRC channel logs

2017-11-26.log

back to list of logs

<nee`>Also here are some warnings that I got when compiling the fresh repo with make: https://p.sicp.me/mpFHi
<OriansJ>anyone on arm want to do a tiny test for me?
<efraim>OriansJ: if aarch64 is good enough, i'm happy to test, otherwise the best I have is an RPi 1, armv6j(?)
<brendyn>When I unplug my usb sound card and plug it back in, the alsa state resets so i have to manually restore it again. Does anyone know how to make the state persistent on GuixSD?
<ng0>is LD_LIBRARY_PATH a case for wrapping or for search path?
<ng0>basically I'm trying to fix https://c.n0.is/pastes/plain/pitivi-fail
<ng0>I'll go with wrapping first
<roptat>gradle looks like it's impossible to bootstrap properly... the last version that did not require gradle was from 2008, before the first released version...
<roptat>now they're proud that "Naturally, Gradle builds itself with Gradle"
<ng0>roptat: maybe another thing to follow within bootstrappable?
<roptat>all of java should be followed from withing bootstrappable :p
<roptat>but yeah, it would be great to see some interest on bootstrapping that
<roptat>after all, it's the build system used by most android applications
<ng0>there's a wiki, see if gradle fits somewhere, if not, create a page
<roptat>where is that wiki?
<roptat>oh, I found it
<rekado>ng0: LD_LIBRARY_PATH is not a search path. The better way here would be to patch the sources to look up the library by full path.
<rekado>roptat: good job building that version of gradle!
<rekado>roptat: did you have to use gradle for that or did it bootstrap gradle as I was hoping?
<roptat>rekado: I didn't build gradle, only groovy
<efraim>I have a feeling if I ever finish with bootstrapping Java on aarch64 it'll fix the assembly errors for armhf
<roptat>I can't build gradle as it requires itself
<rekado>roptat: ah, yes, I meant groovy
<roptat>then yes, groovy built "fine"
<rekado>excellent
<roptat>I had to fix the build.xml so it could find its dependencies
<rekado>yeah, that’s common.
<rekado>I was thinking that we could cheat with gradle and build it “manually” with groovy
<rekado>gradle doesn’t do much that ant wouldn’t also do.
<roptat>and I didn't run the tests because they require hsqldb that I don't have yet (I think it has lots of deps as I encountered it before and decided to not build it)
<roptat>yes, but it looks difficult, there's a lot of subprojects...
<ng0>rekado: thanks. yes, but I think there are other problems. I hope I can avoid using some git checkout
<ng0>Can be avoided though. Reading their flatpak definitions (their official distribution ways) will help.
<roptat>rekado: anyway, I'll try to build gradle
<brendyn>How can I disable the pc speaker beep in my operating system definition?
<efraim>I think there's a kernel parameter you can pass
<efraim>If you want to disable it for your user you could try adding 'set system-beep visible' or none in your .inputrc
<efraim>To disable the beep, and your speaker, adding 'modprobe.blacklist=pcspkr' to your kernel-arguments might work
<DusXMT>ACTION thought the pcspkr driver was actually an alsa output driver that can be used as a fallback when no sound card is installed
<DusXMT>The console beep can actually, and often is, be emulated by the sound card; take a look at alsamixer
<brendyn>it turns off when i run rmmod pcspkr
<brendyn>if i dont do that and i press backspace in a terminal it beeps annoyinglys
<DusXMT>ACTION personally always thought the beep was useful, but oh well; turns out I was wrong on the driver then, but I do recall there being a driver that used the PC speaker as a fallback audio device with pulse-wave modulation
<brendyn>But it doesn't obey alsa. I'm wearing headphones plugged into an external usb audio interface, but the beep still comes out of the laptop speaker
<brendyn>What do you use the beep for? I never guessed someone would like it.
<DusXMT>To me, a console without a bell feels incomplete :)
<DusXMT>That's the long story short
<brendyn>hahaha
<brendyn>It's intruiging how often I think "This is an abomination, why would any one want it", mention it, and then someone says "Actually I think it's indispensible "
<DusXMT>brendyn: try: guix package -s nxbelld
<DusXMT>:3
<brendyn>I use terminology which has a red flash instead a bell. It's pretty neat.
<DusXMT>brendyn: `13:06 < brendyn> It's intruiging how often I think "This is an abomination, why would any one want it", mention it, and then someone says "Actually I think it's indispensible "'
<DusXMT>Me too, this is why I think freedom of choice is incredibly important too
<DusXMT>(something that's often overlooked in the world of GNU, imho)
<brendyn>Indeed, however, my ambition is to create the best desktop distro out of guix that can be used by anyone, so I'm always interested in figuring out what the ideal default settings and programs are.
<lamefun>GUIX_PROFILE=$HOME/.guix-profile source $GUIX_PROFILE/etc/profile - does not work
<lamefun>I don't get the path set despite the script clearly setting it
<rekado>lamefun: try adding a semicolon before source.
<brendyn>when i switch with 'su' i get an empty PATH, but it works with 'su -l'
<lamefun>IMO Guix needs an install script like Haskell's stack... I.e. "curl -sSL https://get.haskellstack.org/ | sh"
<amz3`>...
<lamefun>Is this style of install scripts bad?
<DusXMT>lamefun: incredibly unsecure
<DusXMT>Not to mention, easy to break
<lamefun>Also incredibly PEOPLEtrue.
<lamefun>Maybe 'install.sh' in guix binary tar.gz then?
<lamefun>The daemon doesn't start... """guix package: error: failed to connect to `/var/guix/daemon-socket/socket': Connection refused"""
<rekado>what do you mean with “doesn’t start”?
<rekado>have you started it and it failed?
<lamefun>Found the reason: SELinux...
<rekado>lamefun: I’d be very happy if you could send us a log of what SELinux complains about.
<roptat>rekado: not cool, latest gradle depends on more recent groovy than 2.0, I'll have to build an older version of gradle, to rebuild groovy, to rebuild gradle :/
<roptat>specifically, all tests require groovy.transform.stc.FirstParam
<lamefun>rekado: https://paste.ofcode.org/32aicRkUXfjAs3qaCcdjTgP
<lamefun>Why not just tell people to disable SELinux? IMO it's just a source of trouble with terrible usability, and no one outside enterprise cares that much about security anyway.
<lamefun>It works! :)
<clacke[m]>fabsh (I think) once said that SELinux is for people who miss the days when Linux was a lot of fiddling and tinkering to get working and he is not entirely wrong :-D
<lamefun>If it had some semblance of usability, maybe it'd be good...
<OriansJ>efraim: yes that will work, please git clone https://github.com/oriansj/mescc-tools && make && ./bin/get_machine ; I just need to know that it is reporting correctly on arm
<efraim>armv6l, so it looks good
<efraim>same value reported from /proc/cpuinfo
<OriansJ>excellent, thank you efraim
<OriansJ>soon the arm built will have its own tests for mescc-tools
<efraim>cool
<lamefun>Can I speak my mind for once? I think FSF has been taken over by Microsoft.
<lamefun>I think GNU Guix would be so much better investment for it than DRM doomsday preachment (which simply will not work, because the most DRM-restricted works are usually best in class).
<ryanwatkins>How does one enable non-free firmware loading? I think now I have gone from linux-libre 4.11.* -> 4.14.*, my wireless driver is now not working?
***astronav_ is now known as astronavt_
<civodul>hello ryanwatkins!
<civodul> https://www.gnu.org/software/guix/manual/html_node/operating_002dsystem-Reference.html#index-firmware has info about firmware
<civodul>that said, this is not the place where we'll discuss non-free firmware, as you can imagine :-)
<ryanwatkins>civodul: It just seems that somehow the ethernet driver is now non-free in 4.14.2 linux-libre for my laptop and now that's stopping my wireless working :(
<ryanwatkins>civodul: I haven't been able to guix system reconfigure for a good while because of it
<civodul>driver or firmware?
<civodul>usually Ethernet on laptops has free drivers and firmware
<ryanwatkins>civodul: I have no idea haha
<ryanwatkins>civodul
<civodul>i think you'll need to gather more info from "lspci" etc.
<civodul>it's hard to tell
<ryanwatkins>civodul: Basically when I boot up I get some uaccess failed systemd error I think it is. It says uaccess unknown ...
<ryanwatkins>civodul: so I have a Qualcomm Atheros QCA9565 with capablities: Access denied
<ryanwatkins>civodul: does that help?
<efraim>however, we also don't currently have linux-libre-firmware packaged
<ryanwatkins>civodul: Direct firmware load for /*(DEBLOBBED)*/ failed with error -2
<ryanwatkins>civodul: maybe it's nothing to do with firmware but my system just keeps authenticating, deauthenticating
<ryanwatkins>civodul: and then prints udevd[232]: RUN{builtin}: 'uaccess' unknown /gnu/store/*/73-seat-late-rules:15
<brendyn>My Slim DE now stretches across two monitors as if it's one screen. it didnt do it a few months ago
<ryanwatkins>Perhaps there is a way for me to downgrade kernal?
<rekado>roptat: ignore the tests? Or does the code also require a more recent groovy?
<roptat>rekado: not sure... and the tests also require more packages... so I'll ignore them for now I think
<civodul>ryanwatkins: the "DEBLOBBED" thing shows it attempted to load non-free firmware
<civodul>so that could be the reason, but then again, if it worked before, i don't see why it would no longer work
<civodul>efraim: "linux-libre-firmware"?
<efraim> https://jxself.org/firmware/
<efraim>when the firmware got taken out of the upstream linux repo there were actually a few libre pieces in it
<rekado>lamefun: the FSF is supporting the GNU project, and that includes GNU Guix.
<civodul>efraim: oh, i didn't know that, we should package it!
<lamefun>rekado: prove to me that it's not been blatantly turning blind eye to self-destruction of GNU/Linux via package management, and I'll change my mind :)
<ryanwatkins>civodul: yh I just selected linux-libre 4.11.4 as opposed to 4.14.3 in the GRUB menu and it now works but I assume it is now also a previous system config symlink?
<ryanwatkins>civodul: rendering my guix system reconfigure redundant on 4.11.4 right?
<civodul>ryanwatkins: could it be that you changed other things in addition to the kernel between these two system generations?
<ryanwatkins>civodul: several packages were updated it seemed. Usually everytime I do a guix system reconfigure I have to install a bunch of packages irregardless of a previous guix package -u
<lamefun>The fact that https://www.fsf.org/campaigns/priority-projects does not even hint at GNU Guix proves to me that FSF is not what it seems to be.
<civodul>ryanwatkins: then it could also be a bug in the linux-libre deblob script (a fixed bug, or a new bug)
<civodul>i would suggest emailing details about the driver and firmware to help-guix Cc: linux-libre
<civodul>lamefun: this is not the FSF channel here :-)
<civodul>also, the FSF does not directly fund developement; rather it funds supporting infrastructure
<adfeno>civodul: +1 not being FSF channel.
<civodul>like Savannah, gnu.org, sysadmins, etc.
<civodul>but anyway, #guix can't really help you here :-)
***astronavt_ is now known as astronavt
<ryanwatkins>civodul: is there a way to do a guix system reconfigure while keeping Linux-Libre@4.11.4?
<ryanwatkins>civodul: just so I can keep reapplying system config changes without breakages :D
<ryanwatkins>is that linux-libre@gnu.org?
<civodul>i don't remember the address
<ryanwatkins>civodul: okay
<civodul>ryanwatkins: to keep the old kernel, you'd have to reintroduce it as a package locally (in your config file)
<ryanwatkins>civodul: so If I do (use-package-modules linux-libre) with a (use-modules ... (ryan guix packages linux-libre)) I'm good?
<civodul>or in your config file, you just do:
<civodul>(define old-kernel (package (inherit linux-libre) (version "4.11.4") (source ...)))
<civodul>and then (operating-system (kernel old-kernel) ...)
<ryanwatkins>civodul: how do I get documentation up for certain guix specific symbols?
<ryanwatkins>civodul: do I load a guix user module into geiser somehow?
<amz3`>grep
<civodul>yeah, that and the manual too ('info guix')
<OriansJ>efraim: could you please do a git pull and verify that the latest version of the mescc-tools tests pass on arm?
<efraim>It says its already up to date
<OriansJ>try now
<efraim>OK there are the tests
<efraim>test/test1/proof1 no such file or directlory
<OriansJ>one sec and I'll get that fixed
<OriansJ>and updated
<efraim>Make test[0..7]-binary passed
<efraim>OK, now they all passed
<OriansJ>sweet :D, we now have support for ARM on mescc-tools and proof that ARM builds x86 binaries identically to x86 systems :D
<efraim>Now if only we had armv7 machines :)
<OriansJ>indeed
<lamefun>Is there some easy install script I can point people to?
<OriansJ>for mescc-tools?
<lamefun>For Guix itself.
<OriansJ>here: https://paste.debian.net/997678/
<lamefun>this would fail on Fedora because SELinux prevents guix-daemon from starting :/
<lamefun>I also found this: https://github.com/Hellseher/wds/blob/master/wds-guix-install.sh
<lamefun>Why isn't there an official script in Guix tar.gz?
<OriansJ>lamefun: because everyone is busy and have not yet taken the time to be responsible for that problem yet
<OriansJ>we always welcome contributions and alternate perspectives but at the end of the day, we are humans with complex lives and problems that exist beyound that of shipping software. Our personal lives and priorities are what we address first and thus our contributions are done in the spirit of free software.
<brendyn>lamefun: It's still a young project. Don't be suprised when you find things lacking you feel should already exist
<adfeno>lamefun: For example, I take my case, as long as I can't address the lack of a job, or get hired specifically to contribute to free/libre software, then most of the project will remain second priority because I have to weekly take care of distributing my curriculum vitae, and take care of college obligations and house keeping.
<catonano>lamefun: anyway, I understand that the new Guix installer is quite neat and it will be released with the next Guix version (is it 0.14 ?)
<catonano>lamefun: you could try that to install GuixSD
<catonano>lamefun: it's true that the installation process is not apiece of cake right now bt that's because thhe project is young and people do what they can
<catonano>lamefun: it's steadly improving though !
<roptat>rekado: I'm afraid gradle-core-api needs groovy.lang.DelegatesTo, which is not available in groovy 2.0
<roptat>even gradle 3.0 uses groovy.lang.DelegatesTo in its core module
<roptat>2.3 may be ok if we don't care about testing, and it's the one used to build groovy 2.4.12 (the latest stable groovy is 2.4.13)
<lamefun>catonano: installer for Guix (on top of another distro) or GuixSD?
<jcob>I remember reading somewhere that guix sd does not support xfs. Is that true?
<cehteh>xfs should be supported, zfs isnt
<jcob>*d'oh*
<jcob>I'm thinking of using guix to make my emacs reproductible. Is that thinking in the right direction or would guix not be helpful there
<kmicu>Hi jcob, if you will not use package.el then yes, your emacs environment should be reproducible.
<efraim>anyone using vim on guix with packaged addons? what's the helptags command i have to run?
<nee`>I tagged this bug https://debbugs.gnu.org/cgi/bugreport.cgi?bug=28602#11 with 'patch' now, so it shows up at the top in debbugs. It would be nice to get some feedback for the patch.
<catonano>lamefun: installer for GuixSD
<janneke>crap -- tests/psyntax.test-guile: [FAIL]
<janneke>that's with bootstrap-guile: 2.0.9
<janneke>can i get bootstrap-guile in a environment?
<janneke>package not found for: guix environment --ad-hoc guile@2.0.9
<janneke>ah: guix environment --ad-hoc guile-bootstrap
<efraim>guix environment --ad-hoc '(@@ (gnu packages bootstrap) %bootstrap-guile)' didn't work for me
<janneke>great: ERROR: Unbound variable: with-ellipsis
<janneke>ACTION is happy
<janneke>ellipsis is 2.2 then
<rekado>jcob: I’m using Guix for Emacs as well.
<efraim>i've never heard of GNU Gama, but I have it packaged now
<ryanwatk`>My issue with networking and deauthenticating by local choice reason 3 is to do with the wpa-supplicant service. Does it take a default config?
<ryanwatk`>If I disable all networking herd services I can do wpa_supplicant with my own settings with np irregardless of kernel
<ryanwatk`>Any idea why?
<ryanwatk`>I don't get it man, fml
<ryanwatk`>Conversely I need the networking service to use the ssh-daemon so anytime I do herd stop wpa-supplicant to do my own wpa-supplicant without herd, it stops a bunch of others...
<ryanwatk`>wlp2s0: deauthenticating from * by local choince (Reason: 3=DEAUTH_LEAVING)
<ryanwatk`>yay!
<ryanwatk`>Any idea where this wpa_supplicant default config is. The networking service just decides arbitrarily to not connect. I assume it's because at install I used a different network.
<ryanwatk`>It says that networking is provide dmore
<ryanwatk`>Where can I find the package for the clear command
<ryanwatk`>coreutils?
<ryanwatk`>I can't remember
<ryanwatk`>ncurses?
<rekado>have you tried Ctrl-L?
<ryanwatk`>rekado: I did not know that was a thing
<ryanwatk`>rekado: <3
<lfam>It's in ncurses. But Ctrl-L is easier :)
<ryanwatk`>lfam: yh I just installed ncurses, thanks :D
<ryanwatk`>man, is there no way just to tell disable wpa_supplicant from the networking services list somehow?
<ryanwatk`>it's driving me nuts
<lfam>ryanwatk`: Can you clarify what you mean by "to tell disable wpa_supplicant from the networking services list"?
<ryanwatk`>lfam: somehow if I do `herd stop networking` and then do `wpa_supplicant -B -i ... -C<(...); dhclient *` it works
<ryanwatk`>lfam: otherwise with the networking service enabled I just get constant authenticate/deauthenticate nonsense
<vagrantc>i've found "reset" to sometimes be necessary when ctrl-l didn't clean up everything ... not sure where that's from
<ryanwatk`>lfam: I think it's because when I first installed guix I used a different wifi network perhaps?
<ryanwatk`>lfam: ever since I switched location it just stopped working
<ryanwatk`>lfam: I assume wpa_supplicant has some default config somewhere but I have no idea where that might be in the /gnu/store/...
<efraim>I added 'Control-l: clear-screen' to my .inputrc
<lfam>ryanwatk`: You can find out what configuration file is being used by looking at the command line used to run wpa_supplicant. For example, `ps aux | grep wpa`
<lfam>It will show the path of the configuration file
<ryanwatk`>lfam: from what I can see it doesn't seem to have any config
<ryanwatk`>lfam: I just have /gnu/store/.../wpa_supplicant -u -B -P/some-process.pid
<lfam>How do you interact with it? Wicd? Network-manager? Something else?
<ryanwatk`>lfam: Neither. I thought by default the networking service provided wicd but when I try to use wicd-curses or wicd-gtk for instance it says the wicd daemon isn't started
<ryanwatk`>lfam: if I do `sudo wicd` it still remains
<ryanwatk`>Which also drives me nuts
<ryanwatk`>haha
<roptat>I think your issue is that their are two wpa-supplicant running at the same time
<lfam>Are you using %base-services or %desktop-services?
<ryanwatk`>%desktop-services
<ryanwatk`>lfam: should I be using %base-services?
<lfam>Only if you don't want a desktop
<roptat>rekado: I tried building gradle 2.3 but at some point it failed because of groovy being too old again :/
<ryanwatk`>lfam: oh, I need X11
<lfam>%desktop-services includes network-manager
<ryanwatk`>lfam: Yh I saw that popup in htop
<ryanwatk`>lfam: so I should use network manager to configure the wlan?
<lfam>Yes, I think that's the way. I've never used network-manager so I can't help much with it :)
<ryanwatk`>lfam: but I don't have netctl or network-manager at cli
<ryanwatk`>lfam: is it a gui?
<ryanwatk`>lfam: I've never used it either. I prefer wicd
<roptat>rekado: so I may try with gradle 1.x, but at that point I wonder if it would be simpler to just use our ant-build-system to build latest groovy
<efraim>i normally use nmtui
<ryanwatk`>efraim: You are a saviour
<ryanwatk`>
<efraim>:)
<ryanwatk`>efraim: is nmtui some sort of wifi-menu gnus thing? haha :D
<rekado>roptat: my plan was to copy the bootstrap from the build.xml of 2.0.0beta3 and use that with a later version of groovy.
<rekado>found out why there are no icons in librecad
<rekado>need to wrap the executable in QT_PLUGIN_PATH to include qtsvg’s plugin directory
<roptat>rekado: oh, that makes sense
<rekado>a rebuild takes too long, though…
<efraim>sometimes I wait for substitutes
<rekado>well, I need to build it at least once to be sure that what I push is really okay
<efraim>i wonder if our ntp service can be extended for openntpd or if it would be better to write a new service for it
<lfam>efraim: I'd guess their configuration files are totally different, since ntpd is the fullest-featured reference implementation, whereas openntpd is very simple
<efraim>i thought I could override the start command but it looks like i'd want to replace the config file also
<efraim>at that point there's not much left
<lfam>I guess we will also get a chrony service eventually
<efraim>it still makes sense to leave the option for a non-default ntp in the ntp service, people might want other options
<lfam>Yes, but that field is usually so that you can use a package variant, not a totally different package
<lfam>The chrony startup is sort of complicated, so I think that one will never be part of the ntp-service
<lfam>ACTION pushes fix for remote code execution in Exim 
<civodul>i learned about 9.9.9.9 ("Quad9"), which runs DNS-over-TLS
<civodul>and one way to use it would be to have an Unbound service
<civodul>would be nice
<civodul>"and a poney too" :-)
<lfam>Based on this discussion, it seems like we might need to build OpenSSH with LibreSSL once OpenSSL 1.0.2 is retired
<lfam> https://lists.mindrot.org/pipermail/openssh-unix-dev/2017-October/036376.html
<lfam>(It works fine with LibreSSL, btw)
<adfeno>I wonder if GnuTLS can be used instead...
<adfeno>;)
<lfam>No, they said it's not an option considered by the OpenSSH team
<adfeno>Hm...
<adfeno>I see.
<lfam>The problem is with the new OpenSSL API in 1.1. They don't anticipate being compatible with it in the right timeframe for support in distros with super long stability guarantees like Debian
<adfeno>lfam: "they" == "OpenSSH"?
<lfam>Yes
<adfeno>Interesting...
<lfam>Well, now I can't find that message. But, OpenSSH is developed natively with LibreSSL, and OpenBSD seems to actively remove dependencies on copyleft / GNU software, so I don't really think it's worth pursuing
<adfeno>Oh.... Indeed thanks for reminding....
<adfeno>.... I also read something along these lines in regards to OpenBSD's denial of GPL's importance. ;)
<efraim>FreeBSD was also complaining about GCC 4.4(?) being really old, but still being GPL2
<lamefun>"libGL error: No matching fbConfigs or visuals found"
<lamefun>can I tell Guix packages to use system OpenGL?
<civodul>lamefun: in general mixing libraries from both Guix and the host distro is a bad idea
<civodul>(mixing in the same process, i mean)
<lamefun>So Guix is useless for me then (at least for installing GUI applications)?
<lamefun>Is there a way to force it?
<lamefun>(to mix libraries)
<civodul>i don't know if it's useless for you :-), but GUI applications installed from Guix should work in general
<civodul>if there's a specific package that doesn't work, i'd recommend emailing help-guix
<civodul>so we can pinpoint what the issue is
<lamefun>It's probably this: https://lists.gnu.org/archive/html/bug-guix/2017-09/msg00094.html
<lamefun>proprietary drivers :(
<civodul>ok
<rekado>although it is a bad idea in general to mix system libraries with libraries from Guix, you can —in some cases— have success with LD_PRELOAD to override a library at runtime.
<rekado>but this is not supported / supportable.
<civodul>yeah don't come report segfaults if you do that :-)
<rekado>using LD_PRELOAD is a good recipe for segfaults indeed.
<lamefun>ERROR: ld.so: object '/usr/lib/libGL.so.1' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
<lamefun>doesn't even start...
<lamefun>nvm
<lamefun>LD_PRELOAD="/usr/lib64/libGL.so.1 /usr/lib64/libGLX.so.0 /usr/lib64/libX11.so.6 /usr/lib64/libXext.so.6 /usr/lib64/libGLdispatch.so.0 /usr/lib64/libxcb.so.1 /usr/lib64/libXau.so.6"
<lamefun>well...
<lamefun>is there no other solution?
<OriansJ>adfeno: it isn't that openbsd denies GPL's importance, rather they prefer mass use of their software more than standing for user freedom. To them proprietary forks are a good thing. Which is certainly a personal choice they are free to make.
<OriansJ>Every developer is free to decide what values they wish to stand for and what boundries they wish to enforce on their work.
<OriansJ>For some, isc and bsd licenses fit their values better than GPL licenses and that is fine, since their software is still free software.
<adfeno>OriansJ: +1
***jna is now known as qih
<qih>Hi y'all. Will Guix run the current React/Native frameworks?
<lfam>qih: Hi! We don't have React packaged in Guix so, no, not currently. Maybe someone has packaged it for Guix externally, but I haven't heard of it
<qih>Ah 8-( ... well in that case, I'll install Guix but in a Dual Boot setup
<lfam>Well, I guess I should clarify. We don't have React packaged for development purposes, but of course you can visit sites that use React :)
<qih>Yeah sorry, I was not concise, I want React for Development 8-)
<qih>ACTION looks through Packages
<qih>What is the browser IceCat like? I have used IceWeasal a few years ago and disliked it for its video handling and image non-smooting
<qih>smoothing*
<lfam>qih: It's based on the extended support release of FireFox. It removes non-free software and recommendations to use non-free software
<lfam>Things like image / font smoothing are typically handled by the distro or user, so it may render things differently than on other distros. If so, suggestions for improvements are welcome!
<buenouanq>IceCat currently is just FireFox 52 rebranded with questionable things removed and settings moreso geared towards freedom and privacy and ships with some adons that do the same.
<buenouanq>I've had no problems with it.