IRC channel logs

2017-11-11.log

back to list of logs

<kristofer>hello guix!
<marusich>Hey there
<kristofer>I am trying to create a package with guile-lib and guile as inputs. when I build the package it cannot find htmlprag and when I create an environment it appears guile-lib is not included in it. I'm not sure what I am doing wrong
<kristofer> https://dpaste.de/SPxM
<kristofer>I can guix environment --ad-hoc guile guile-lib and htmlprag is included in that environment. but guix environment -l guix.scm in my git checkout doesn't include it
<kristofer>ha! wrong version of guile.
<Apteryx>Hello Guix!
<Apteryx>sneek: later tell civodul: finally connected at home again. Did you merge the patch I was looking at like 2 weeks ago yet (about guix pull), or is it still needing my attention?
<sneek>Got it.
<Digit>ACTION again been having grief with a few other distros he thinks he could have managed better with guix, if he used guix, and had the knowledge n skill to use it well.
<happy_gnu[m]>hello
<happy_gnu[m]>anyone here that can help me with a recipe?
<marusich>what's up?
<happy_gnu[m]>marusich: hi! I am having trouble, I am trying to package https://dthompson.us/projects/chickadee.html
<happy_gnu[m]>chickadee
<happy_gnu[m]>when i run ./pre-inst-env guix build guile-chickadee
<happy_gnu[m]>I have an error that module (sdl2) can't be found
<happy_gnu[m]>let me send you message exactly
<happy_gnu[m]>checking if (sdl2) is available... noconfigure: error: required guile module not found: (sdl2)
<brendyn>Well davexunit created that program
<davexunit>hey
<davexunit>yeah you need guile-sdl2 to build chickadee
<happy_gnu[m]>I know but I want to package it
<happy_gnu[m]>:)
<happy_gnu[m]>I just don't know how to solve this
<happy_gnu[m]>checking if (sdl2) is available... no
<happy_gnu[m]>davexunit: can I send you my recipe
<davexunit>afaik guile-sdl2 isn't packaged
<happy_gnu[m]>I probably got it wrong
<davexunit>so you need to package that first
<happy_gnu[m]>it is
<davexunit>okay
<davexunit>so did you include it as an input?
<brendyn>happy_gnu[m]: In the chikadee repo there is already a guix.scm file
<davexunit>yeah
<happy_gnu[m]> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/sdl.scm?id=v0.13.0-4600-g7c087150e#n480
<happy_gnu[m]>ohh I didnot see that
<davexunit>happy_gnu[m]: did you include guile-sdl2 as a propagated input of chickadee?
<davexunit>note that the guix.scm file is not a full package
<davexunit>or rather it's not a package suitable for building from a release tarball
<davexunit>happy_gnu[m]: are you building from a release tarball or a git checkout?
<happy_gnu[m]>yes I did
<happy_gnu[m]>from the tarball
<happy_gnu[m]>my recipe is practically the same :/ let me see if I can get it right
<happy_gnu[m]>davexunit: you mean the guix git or the chickadee git
<happy_gnu[m]>the guix git but the recipe has the chickadee tarball
<davexunit>yeah that
<davexunit>I'm not sure what to suggest
<davexunit>I recommend building from a git checkout for now, honestly. I haven't made a release in 9 months and there's been a bunch of stuff added/fixed in that time.
<davexunit>need to make a release at some point
<happy_gnu[m]>davexunit: ohhh ok
<happy_gnu[m]>I think I am gonna just do ./configure make and make install then
<davexunit>okay
<davexunit>you're nearly all the way there already
<happy_gnu[m]>If I have guix-sdl2 and guix-opengl right
<happy_gnu[m]>Ohh
<happy_gnu[m]>But doesn't guix need tar balls?
<davexunit>it's preferred
<marusich>happy_gnu[m], check out the "git-fetch" method mentioned in the manual at: (guix) origin Reference
<marusich>To see examples of it used in action, do: grep -r git-fetch gnu/packages
<marusich>where gnu/packages is the directory containing the package definitions in Guix.
<davexunit>the guix.scm file in the chickadee repo has an example for the guile-sdl2 development package
<marusich>If you're using emacs, you can also do M-x rgrep, which is a handy tool.
<davexunit>happy_gnu[m]: honestly I think it may be best to not upstream a chickadee package right now. I can probably take care of that when I make a new release.
<happy_gnu[m]>ok
<davexunit>let me give you some code that I've been using to work with chickadee on other projects
<happy_gnu[m]>yes thats great :)
<happy_gnu[m]>i want to make a game
<happy_gnu[m]>so I should just do ./configure make && make install? or not?
<marusich>Sounds fun. I didn't know about Chickadee until you mentioned it. Looks neat!
<happy_gnu[m]>jajaja I am confused
<happy_gnu[m]>sorry is hahahaha not jajajaj (In spanish we say jajaja)
<davexunit>hmmmm paste.lisp.org is down
<davexunit>who has a good paste site to recommend that can do scheme syntax highlighting?
<happy_gnu[m]>how do you do guix hash if you git clone a repo
<marusich> https://paste.debian.net lists "Scheme" as a language.
<davexunit>thanks
<davexunit>happy_gnu[m]: there's a flag you can pass to ignore the .git directory and get an accurate hash of the repo
<davexunit>(honestly I never use it and just have guix tell me the hash :x)
<happy_gnu[m]>but how do you get the hash?
<happy_gnu[m]>I did git clone git://dthompson.us/chickadee.git
<happy_gnu[m]>but when I do git hash it tells me I can't do it because it is a directory
<happy_gnu[m]>sorry guix hash*
<davexunit>happy_gnu[m]: there's a special flag you need to use
<marusich>Well, if you provide a hash and the build fails due to a hash mismatch, you can just take the one that got spat out in the eror output and use it.
<marusich>Or, you can figure out the right options to invoke on guix hash.
<davexunit>anyway, here is a guix.scm suitable for use with 'guix environment -l guix.scm': https://paste.debian.net/hidden/2eae5bf7/
<happy_gnu[m]>marusich: thanks
<davexunit>it has the latest commits of guile-sdl2 and chickadee
<davexunit>I have been using this exact code to do some game prototyping
<happy_gnu[m]>davexunit: thanks!!!!
<happy_gnu[m]>this is good!
<happy_gnu[m]>this wont require me to install chichadee everytime right?
<davexunit>when I get around to making real releases I will get everything into guix
<davexunit>happy_gnu[m]: not sure what you mean
<davexunit>are you used to using 'guix environment'?
<happy_gnu[m]>davexunit: not used :/
<davexunit>there's the potential that upgrading guix will cause stuff to be rebuilt when you run 'guix environment' again, but other than that you won't rebuild stuff
<happy_gnu[m]>this was the first package I was doing a recipe
<davexunit>okay
<davexunit>well perhaps I can recommend a different approach
<happy_gnu[m]>I learn how to do it
<davexunit>if you want to install these things with 'guix package', you can do 2 steps:
<happy_gnu[m]>so maybe I can do new stuff
<happy_gnu[m]>basically I was doing it because I wanted to make a game with chickadee :)
<happy_gnu[m]>nah that's alright, it even includes a game prototype :D
<davexunit>don't your get hopes up too high with chickadee, there's some good stuff there but there's lots to do still
<davexunit>2d sprite rendering is what it's best at
<happy_gnu[m]>I want to make more packages but the configure flags are too confusing for me
<happy_gnu[m]>I was thinking on installing funtoo to learn once and for all to compile
<happy_gnu[m]>well, I am reading "how to design programs"
<happy_gnu[m]>so the stuff I am gonna be doing for now is pretty basic
<davexunit>okay
<happy_gnu[m]>but maybe I can learn to contribute to chickadee too
<happy_gnu[m]>although I don't know anything about sdl2
<davexunit>you don't necessarily have to know anything about it
<davexunit>sdl2 provides the means to create a window and handle mouse/keyboard/joystick input
<davexunit>and that's it
<davexunit>opengl is used for the rendering engine
<davexunit>and most everything else is pure guile code
<happy_gnu[m]>guix environment -l guix.scm is done:
<happy_gnu[m]>so how can I help you davexunit ? if you need any help of course :/
<davexunit>next I recommend taking the examples/sprite.scm file from the chickadee repo, adding it to your project directory, and running it with 'guile sprite.scm'
<davexunit>it will fail because it can't find an image file, so your exercise will then be to load an image of your own. :)
<davexunit>once you've got that working, you can move on
<happy_gnu[m]>ok
<davexunit>happy_gnu[m]: as far as help I think the best thing would be to just use chickadee and see how you like it. figure out if something you want is missing.
<happy_gnu[m]>oh it works!!!!
<davexunit>:)
<happy_gnu[m]>I see the chickadee logo
<davexunit>great
<happy_gnu[m]>davexunit: thank you so much!!
<davexunit>you're welcome :)
<happy_gnu[m]>I will try to make my game this weekend
<happy_gnu[m]>when I have the code I will send it to you
<happy_gnu[m]>I already have images and sounds
<davexunit>oh good :)
<happy_gnu[m]>is gonna be very simple game for now
<davexunit>that sounds good
<davexunit>good luck
<happy_gnu[m]>is the documentation for sly useful for chickadee?
<davexunit>no
<davexunit>chickadee has its own manual
<davexunit>it's incomplete, but I recommend checking it out to see if anything if of use to you
<davexunit>and also look at other example programs in the examples/ directory in the chickadee repo
<happy_gnu[m]>ok
<happy_gnu[m]>:)
***Piece_Maker is now known as Acou_Bass
<rekado>davexunit: I recommend using both servers. berlin.guixsd.org is using cuirass naively, so it doesn’t build substitutes as quickly as it could.
<mb[m]1>rekado: can you add the berlin signing key to the Guix repo?
<ng0>Are there any recordings of the talks presented at GHM 2012?
<ng0>all I find is https://www.gnu.org/ghm/2012/ddorf/
<ng0>which holds no recordings or links to them
<rekado_>mb[m]1: the key is part of the guix-maintenance repo for now. For the next release we may add the key for berlin to the default set.
<rekado_>before that I need to attach the new glusterfs storage to the new head node, though. Haven’t been able to make time for that yet.
<civodul>ACTION fearlessly runs 'guix pull' on the Olimex A20
<vagrantc>ACTION wonders what time unit would be appropriate to measure that in
<benny>is there a way to see why something is considered for an upgrade when I run guix package -u? I've reported the (what I believe to be bug) about python-wrapper but I sometimes see a list of packages that all keep their version number
<benny> https://paste.debian.net/995178/
<benny>--verbose doesn't show any additional information
<rekado_>benny: the version string is not sufficient to describe a package variant.
<rekado_>Guix incorporates the hash of the whole dependency graph in the name of a package.
<benny>I understand that part, other package manager therefor often opt for the package revision number, I would just like to know why something changes
<rekado_>so you may see that Guix “upgrades” a package, while it stays at the same version.
<rekado_>all that happened was that that new package has updated references to other items in the dependency graph.
<rekado_>revision numbers would not be sufficient.
<benny>I would like that to be surfaced when I do --verbose, because right now it doesn't seem to do anything
<rekado_>in Guix any change to a dependency (or a dependency of a dependency) results in a new package variant.
<benny>and when I increase --verbosity I get nothing but a lot read/write locks
<efraim>rekado_: java-swt's sources disapeared upstream
<efraim> http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/eclipse/downloads/drops4/
<civodul>conclusion: 1 GiB of RAM on the A20 isn't enough for guix pull
<sneek>civodul, you have 1 message.
<sneek>civodul, Apteryx says: finally connected at home again. Did you merge the patch I was looking at like 2 weeks ago yet (about guix pull), or is it still needing my attention?
<civodul>Apteryx: i haven't merged it; i've found a couple of issues, so i'll send an update soonish
<civodul>you can hold on for now
<civodul>but thanks for the offer!
<Digit>ACTION shud give his guix virtual machines more ram
<efraim>civodul: how much swap do you have?
<lfam>I found that adding ~1.2 GiB of swap to 1 GiB RAM was enough on a VPS
<lfam>But, it takes several hours to compile python.go
<civodul>efraim: zero
<civodul>really a shame
<lfam>At 99% iowait
<lfam>Maybe it would be improved if the swap was flash-based, but I think this is a spinning disk
<lfam>So icu4c fails to build for me on core-updates
<civodul>uh
<lfam> https://paste.debian.net/995189/
<lfam>"number_decimalquantity.cpp:333:9: error: ‘_Generic’ is not a member of ‘std’"
<ng0>lfam: oh? maybe I should rent one more 512MB piece then
<efraim>i'll try it on aarch64 after i see if gtk+@2 succeeds
<lfam>ng0: Maybe! I didn't try less than ~1.2 GiB for my swap. It just worked and I didn't adjust it since then
<ng0>on baremetal I needed at least 3GB RAM
<amz3>Héllo, I just re-installed guix binary on top of ubuntu
<amz3>I did 'guix pull' and 'guix package -u' as a user and then went into installing guile@2.2 and gnutls
<amz3>when I try to load gnutls module it gives me an error:
<amz3>scheme@(guile-user)> (use-modules (gnutls))
<amz3>While compiling expression:
<amz3>ERROR: In procedure dynamic-link: file: "/gnu/store/16xvw2i4ma8n81zvf5wxwc7r2n2f6y1j-gnutls-3.5.13/lib/guile/2.2/guile-gnutls-v-2", message: "file not found"
<efraim>gtk+@2 failed the abicheck.sh test on aarch64 on core-updates
<amz3>indeed there is no such file as 'guile-gnutls-v-2' but there is 'guile-gnutls-v-2.so'
<amz3>sorry.. i think it works...
<amz3>nvm
<rekado_>amz3: what was the reason for this error?
<amz3>I don't know, maybe because the environment variables were not correct
<amz3>that said, regarding TLS, I still get an error when trying to http-get something https. But that is not related to guix
<rekado_>yeah, same here
<amz3>it's strange because it's use to work
<amz3>used*
<amz3>I'm not sure what changed
<efraim>lfam: icu4c@60.1 didn't give me any problems on aarch64
<taohansen>what is this about? `shepherd: Evaluating user expression (register-services (primitive-load "/gnu/sto?")).
<taohansen>shepherd: Service user-homes could not be started.`
***egnun1 is now known as egnun
<efraim>if anyone's curious, mesa with svga on aarch64 on core-updates still doesn't compile
<civodul>taohansen: the "user-homes could not be started" is expected, but the message is confusing
<civodul>essentially user-homes is a "trigger" kind of service, which just executes one operation and "stops"
<taohansen>civodul: ah yeah, it'd be nice if that was cleaned up.
<taohansen>i think the assumption is something's wrong here
<civodul>yeah
<taohansen>i have a few usability issues. they're papercuts for me and i'd like to confirm they are in fact bugs before submitted on the bug tracker.
<taohansen>1. to use any fuse-based filesystems i have to manually `modprobe fuse` after startup.
<taohansen>2. pulseaudio does not always start on-demand requiring me to launch it myself which i've set in my .xsession. personally i'd like if it was just firmly integrated into GuixSD rather than the provisional and responsive loading it appears to do presently.
<taohansen>i know it's Poettering software but man i'd really like to see that hatefest end.
<roptat>taohansen: for 1, there's a list of modules in the operating system declaration
<taohansen>3. basically GuixSD assumes a system that is not HiDPI. this in my opinion should be responsive by default. as it is, SLiM is tiny and unreadable, TTYs are tiny and unreadable, and .Xresources entries fix everything but the tiny cursor, which appears to be hardcoded. whatever the case, i and others cannot fix this issue.
<taohansen>we are entering very rapidly the HiDPI future. let's get it by the balls?
<taohansen>roptat: thank you, i'll check this out.
<roptat>for 2 and 3 I have no idea
<ng0>often features are missing because of the usual reasons: no one noticed it. no one bothered to report. it's complex to work on (I've stuck myself into that field of work…). someone needs to do it.
<taohansen>by ".Xresources entries fix everything" i mean everything inside a window manager, not TTYs and SLiM
<roptat>taohansen: you can add modules in the initrd field of the operating-system, there's an example in the manual
<ng0>like for HiDPI, I'm still stuck with old laptops and a small 1080p television/monitor combination for finacial reasons
<taohansen>ng0: yeah, i totally understand. i'm just making these things clear before i go ahead and put them on the bug tracker
<ng0>more specific examples would maybe help in the documentation, if something already (partial) addresses these issues
<mb[m]1>Tao Hansen: Have you tried SDDM instead of SLiM for HiDPI support?
<mb[m]1>I've seen a configuration option for it, but not sure if it's tweakable atm.
<taohansen>mb: haven't no, i'd be interested if it doesn't pull in half of KDE with it?
<mb[m]1>"just" Qt :P
<taohansen>haha, okay.
<taohansen>do we have GDM?
<mb[m]1>Regarding pulseaudio, I suspect it's something we have to fix on a per-app basis. IceCat manages to launch it automatically, but some other programs can't find it unless it's already running.
<mb[m]1>There is a GDM service, but don't think it's functional yet.
<ng0>well, parts of Qt. you could run: guix size `guix build sddm` (guessing here) to get the graph
<ng0>a cool feature I want to see is webbrowser extension+addons integration (and get a trustable 'addon' store). I've tried to work on it briefly, but wasn't succesful so far
<mb[m]1>ng0: Yes, browser extensions would be great. I have tried to package some for IceCat without success too.
<ng0>we need some combination of what Nix does + what Gentoo does + fixes on our own
<mb[m]1>Does Nix have browser extensions?
<ng0>yes
<ng0>Gentoo has the eclasses + ebuilds and patches applied sorting this out
<mb[m]1>ng0: Can you recall some extensions packaged in Nix? I tried grepping for a few I use without success.
<rekado_>we also have lightdm, but no service for it
<rekado_>maybe we can make this work before the next release?
<ng0>mb[m]1: I have them bookmarked, but can't open the browser right now. I'll look into my nixpkgs
<ng0> pkgs/applications/networking/browsers/mozilla-plugins/
<ng0>and in nixos the hooks
<ng0>or what the integration is called
<ng0>I used NixOS for like 1 day so far
<ng0>well longer, but it's a good source
<ng0>s/but//
<mb[m]1>Those plugins seem to be different from regular extensions.
<ng0>archlinux and AUR has some extensions as well as far as I remember
<mb[m]1>Debian too.
<ng0>we need to achieve the following: Firefox based browser must accept a path/union in the store for the plugins. adjust one or two values in the extensions to make them accept the differing path. I'll take a look if I have pushed my work somewhere
<mb[m]1>Mark sent some information here: https://lists.gnu.org/archive/html/guix-devel/2017-01/msg01037.html
<ng0>I know
<ng0>I mean, I've read the thread
<ng0>I tried some stuff here: https://c.n0.is/ng0_guix/packages/tree/ng0/packages/personalized.scm#n91
<ng0>could be that I also have an adjusted icecat somewhere