IRC channel logs

2017-11-09.log

back to list of logs

<bms_>Hello.
<mekeor>hi, bms_ :)
<bms_>How are you?
<mekeor>confused. and you?
<happy_gnu[m]>ok I did "guix enviroment guix"
<bms_>I'm fine. Why confused?
<vagrantc>does the initrd that guixsd generates respect rootdelay or rootwait or something similar?
<vagrantc>it appears to be attempting to access the luks device before it detects the disk
<happy_gnu[m]>lfam link says to run ./boostrap
<happy_gnu[m]>where do I get that file
<lfam>happy_gnu[m]: It's in the Guix Git repo. Did you clone it yet?
<happy_gnu[m]>oh :/ I thought guix enviroment guix would do that
<happy_gnu[m]>let me try
<OriansJ>hey bms_ long time no see :D
<bms_>Hello. I'm really sorry about my failed project for Bootstrapping. I'm just not quite good enough to do what I set out to do. I've set my eyes lower now. I'm happy to see you though. :D
<OriansJ>bms_: failure is a good thing. It teaches us. The fact that you tried is something to celebrate.
<bms_>Thank you. I've been in the not-so-active Bootstrappable IRC channel a couple times and also onto the website. It looks like you're all doing well.
<lfam>happy_gnu[m]: The latest version of the manual reminds users to do that: https://git.savannah.gnu.org/cgit/guix.git/tree/doc/contributing.texi#n33
<OriansJ>well, my new M2-Planet still needs more people pointing out flaws and points of improvement. Not to mention I need to figure out how to shove types into it
<mekeor>vagrantc: i think my setup uses grub stage 1.5 which is between MBR and the first partition
<mekeor>vagrantc: there is enough space to implement decryption
<bms_>OriansJ: Can I have a link?
<OriansJ>bms_: always my friend https://github.com/oriansj/M2-Planet
<OriansJ>Its first major test was to be able to compile this: https://web.archive.org/web/20160402225843/http://homepage.ntlworld.com/edmund.grimley-evans/cc500/
<OriansJ>now we are adding features to try to make it self hosting with the goal of compiling mes.c
<bms_>Cool.
<bms_>Man, I really wish Robert Fripp would put King Crimson albums on Spotify.
<bms_>I swear, that man scours the internet looking for full album uploads of his music.
<vagrantc>ACTION finally decides to get less ambitious and just set up a bare-bones system
<bms_>I went with the bare bones. I'm generally SSH'ing anyway.
<OriansJ>bms_: youtube-dl comes in super handy though for things like this http://www.youtube.com/playlist?list=PL94gOvpr5yt2TJW06ei5GPGsKBC3aiV_K
<bms_>Thanks for that playlist. That's an album I have yet to hear so I'll do that now.
<OriansJ>bms_: guix package -i youtube-dl && youtube-dl -cif webm ...
<bms_>Most of the KC uploads on any part of the internet are only to be found on DGM's own channel, it seems.
<bms_>Yeah.
<bms_>I should work on the server-side of Msg. I implemented a client last night, but I can't test it without some semblance of a server.
<OriansJ>p2p not an option?
<clacke[m]>So I just did a guix archive --import
<clacke[m]>How do I use the packages I just imported?
<clacke[m]>without setting up PATH etc myself
<clacke[m]>I was hoping guix environment --ad-hoc would take an explicit derivation, but seems not.
<clacke[m]>That's what I would do with nix-shell.
<bms_>P2P almost seems better, but it kind of confuses me. I have trouble understanding the theory behind actually implementing peer-to-peer systems.
<bms_>Like, I understand what it means, but I've had trouble wrapping my head around distributed hash tables. Think it's worth looking back into?
<OriansJ>bms_: well distributed hash tables are only one way to implement p2p communication. Another option is what is called centralized lookup; which is what skype originally used. Basically the clients only talk to a centralized server to initialize the sessions between the 2 nodes
<OriansJ>which if you cleanly seperate the session initialization from the actual session protocall itself, you can always transistion it later
<bms_>Yes, I saw that on Wikipedia, but the current design of Msg is based on the lack of a central server, instead using small community-servers run by the users themselves. I really like this design, even though I'd like to get p2p working more. I see p2p as more of an extension of this design than as a new design completely, so I think my problem with the centralized lookup server border on the ethical.
<OriansJ>bms_: centralized lookup doesn't have to mean globally centralized. Federation is always a possible approach
<bms_>Oh. Hmm. I hadn't thought of that. I rather like it actually. It keeps the small server idea, while also being closer to p2p. Thank you.
<OriansJ>bms_: always here to help :D
<bms_>:)
<bms_>Hello.
<bms_>Msg design issue poll: Originally, my idea was to have it work through interactive terminal sessions, almost like a shell. Now, I've begun having doubts about that design. I know a lot of people work in an environment where they can have multiple "windows" open, one of which could be for Msg, but some people don't have that or, more likely, prefer not to use it. So I've had an interesting thought that could greatly complicate writing
<bms_>this program: how do I accomodate for the disparity in windowed environment usage. Do I run the client as a daemon that hands the messages to the user. The server wouldn't have to change much (yes, I've "regressed" back to my original non-p2p design; I kind of like it more). If I do that, how do I not break a running session of, for instance nano or Emacs? Do I make the client an Emacs mode and only have the server be its own program,
<bms_>cutting off a large batch of my target audience?
<OriansJ>bms_: erc might provide some model ideas to play with
<bms_>Yes, I'm using it right now... I just don't know if that's the route I should take or not.
<OriansJ>bms_: why dictate to the user how they can interact? simply provide mechanisms which multiple different types of front ends could use
<bms_>That's a good idea, actually. I've been too caught up in designing the user interface (something at which I'm horrendously bad) that I didn't think about what I should be doing: designing an accessible and powerful backend. Thanks again!
<OriansJ>bms_: out of curiousity, wouldn't it be easier to gain adoption if you targeted a gap in the current market?
<bms_>It would. I'm pretty darn awful at finding those gaps and also knowing what people like -- I generally don't like a lot of stuff that others do, and vice versa. Did you have a gap in mind?
<OriansJ>bms_: let me ask you a more useful question. What small thing would make your day better?
<bms_>Because the more and more I dive into this, the more and more I realize that the current standards (IRC and the like) are just good enough to block everyday usage of my (possibly) better alternative.
<OriansJ>bms_: that very perspective is why matrix (riot.im) was created.
<bms_>That's the question everyone asks themselves when coming up with ideas... I've historically had trouble answering it myself. I mean, I could use a lot of things. Expensive things, but they'd most likely not make my day-to-day life any "better".
<bms_>Oh, great. Another piece of competing software.
<bms_>I think that if I want this to work, I might have to rethink things a little.
<OriansJ>bms_: things don't make people happy. Experiences with people are what usually makes people happy.
<OriansJ>so perhaps what you are looking for is an excuse to create, share and feel like you belong.
<bms_>I understand that, but you can't bottle social interaction and put it online for everyone to download. If you could, I would have found *that* by now.
<bms_>Yes, most likely that's it.
<OriansJ>good, bms_ you share that with all of us here.
<bms_>Well, that's all well and good, but what does it mean for something to dedicate my time to.
<bms_>Don't get me wrong, I really like you all, but I don't completely understand what you're getting at.
<OriansJ>bms_: it means you'll see things that need doing here that you feel you can do. Those are the things to go after
<OriansJ>some people do bug reports, some patches, some infrastructure and some development. But we all are first solving a problem we feel needs to be addressed
<bms_>That's an interesting perspective, OriansJ. Hopefully I see those things before I get too bored and crack. I seem to always need something to do. I can't even watch television without doing something else, at least semi-actively. I can't be passive. When I don't have a project of some sort, it just kind of bugs me just enough to annoy me into finding something to do. Maybe I should just finally dive head-first into music. Not like
<bms_>there's a future in wanting to be Keith Emerson.
<bms_>Thanks for talking to me, by the way. I'm probably coming off as a bit apathetic and pessimistic, and I am in fact the latter, but I do really appreciate this.
<OriansJ>bms_: I am always available if you want to talk.
<bms_>I appreciate that. Immensely.
<OriansJ>I'm on signal or riot.im should you wish for voice conversation.
<bms_>Oh, cool. Voice conversations are an interesting idea. I used to Skype with my friends often, but we don't seem to anymore. Generally, I just resort to singing when they get awkward. I can sing all of Jesus Christ Superstar and pretty much any classic prog rock song you can throw at me. :P But yes, I might like that sometime.
<bms_>I'm really an odd bird... I realized that while writing that.
<happy_gnu[m]>OriansJ bms_ what a wonderful conversion you are having \\o/
<happy_gnu[m]>Can I be your friend too :) ?
<OriansJ>happy_gnu[m]: yes
<bms_>Sure. I'm in need of friends pretty much all the time. I only have one good one in real life.
<happy_gnu[m]>You both can join #lgn (libre game night) we are a few friendly people who like to play free games :)
<happy_gnu[m]>I am there all the time
<happy_gnu[m]>I don't have a single friend in real life
<happy_gnu[m]>I dedicate my time to learn programming
<happy_gnu[m]>As OriansJ said, maybe I just want ta do something for others to feel like I belong
<bms_>I'm sorry about your friendship situation.
<happy_gnu[m]>I used to have friends
<happy_gnu[m]>But shit happens
<OriansJ>happy_gnu[m]: I feel we should fix that
<happy_gnu[m]>People betrays you
<happy_gnu[m]>Let me turn on pc
<happy_gnu[m]>You can meet the bot I've been working an
<happy_gnu[m]>On*
<OriansJ>happy_gnu[m]: people are human
<happy_gnu[m]>I am on riot on mobile right now
<bms_>Well, I used to have two friends. I'm down to one because the other one is a liar, drug dealer, and possibly worse.
<bms_>It was a big thing around the end of last school year. It's kind of sad. My whole high school has this obvious drug culture that the administration doesn't do a thing about. The sex stuff is worse. It gets annoying hearing about everyone's "brave exploits" in carnal affection during school hours. I hate it. It hurts how bad everyone is.
<happy_gnu[m]>well I used to had 2 friends
<happy_gnu[m]>one of them treat me like shit a few times
<happy_gnu[m]>the other robbed me
<happy_gnu[m]>It was sad, both were my friends for years
<OriansJ>happy_gnu[m]: to be a friend, one must act like a friend
<bms_>I'm sorry. People really do change, it seems. Not always for the better.
<happy_gnu[m]>yeah but I try to focus on learning :)
<happy_gnu[m]>that helps me a lot
<bms_>That's good. :)
<happy_gnu[m]>my bot is on #lgn is was built with guile, guix and 8sync, thanks to dustyweb :)
<OriansJ>happy_gnu[m]: I learn the most from my friends
<bms_>Well, I'd be best be off to bed now that the ELP concert is over. Goodnight!
<OriansJ>bms_: sweet dreams
<bms_>Thanks!
<happy_gnu[m]>:) good night bms_
<happy_gnu[m]>\\o/
<OriansJ>happy_gnu[m]: https://github.com/oriansj/M2-Planet
***Digitteknohippie is now known as Digit
<vagrantc>so, running guix as the user installs stuff for that specific user ... is there a way to run updates for the whole system/globally?
<buenouanq>vagrantc: I do not believe so - That would sort of negate all the benefits of individual user control.
<vagrantc>so, a new user on the system is stuck with whatever ancient versions when the system was installed?
<benny>a new user also has for example /run/current-system/profile/bin in PATH
<benny>which is from the system definition
<vagrantc>so, how do you upgrade the "system definition" parts?
<benny>guix system reconfigure the-config-file.scm
<vagrantc>got it
<vagrantc>these seem like the sort of questions that might likely be in a FAQ
<vagrantc>ACTION reads through the guix manual
<benny>I reconfigured my system like 20x because I couldn't get the EFI bootloader to install, so that's the one part I'm relatively familiar with for a newbie of like 1 week
<benny>FWIW I still couldn't and right now the images on the site are outdated and use a different bootloader config format so I just went with bios and a separate /boot again
<vagrantc>ACTION started running "sudo -E guix system reconfigure /etc/config.scm" and watches the kernel get built
<buenouanq>got guix?\\tm
<benny>it's been like 15 years I've built a kernel until I started using guixsd hehe
<vagrantc>ACTION went many years without building kernels and then started working on support for arm systems a few years ago
<vagrantc>ACTION wonders how much disk space a typical guix kernel build takes
<vagrantc>kind of built a pretty minimal system
<janneke>if you're wondering installed size, my /gnu/store/j21dj5wxymqapzfvasm11whl7nwka6vv-linux-libre-4.9.52/ is 221M
<janneke>you want to know build-time resource needs, right?
<vagrantc>well, i've only got ~1.6GB of disk space while part-way through a kernel build
<vagrantc>free disk space
<vagrantc>so yeah :)
<vagrantc>presumably will find out in a few minutes if that was enough
<ng0>sneek: later tell civodul: Does the regex for the new licenses related commit also match LICENSE? Didn't read the whole thing yet
<sneek>Okay.
<rekado_>ng0: it does
<ng0>thanks
<rekado_>vagrantc: currently, GuixSD is pretty wasteful, space-wise
<vagrantc>"guix gc" cleaned up quite a bit
<civodul>Hello Guix!
<sneek>civodul, you have 1 message.
<sneek>civodul, ng0 says: Does the regex for the new licenses related commit also match LICENSE? Didn't read the whole thing yet
<civodul>i think so
<efraim> https://blog.cloudflare.com/arm-takes-wing/ Qualcomm centriq looks interesting
<vagrantc>well, it's been a fun day learning a bit of guixsd ... :)
<vagrantc>ACTION waves
<rekado_>ACTION waves back
<wingo>is anyone seeing an issue with recent icecat where that damn "show hidden text" button is always there, even when the extension is disabled?
<brendyn>I see it. which plugin is it a part of?
<brendyn>actually, i see "click to reveal hidden elements" and "remove buttons"
<efraim>i have that too
<brendyn>anyone know how i can get .xinitrc to be executed on login with slim?
<civodul>wingo: i've seen that in icecat but not conkeror
<wingo>does conkeror also have a bunch of pre-enabled extensions?
<wingo>yeah i can't stand this, you can't disable this damn thing
<wingo>ACTION old man apparently
<rekado_>wingo: I saw that in icecat and immediately disabled it. Had to restart the browser to have it take effect.
<wingo>maybe i have a process hanging around
<rekado_>brendyn: don’t know about this file, but .xsession will be executed if it is there and executable.
<wingo>i think that's what it was
<brendyn>I tried setting an xsession but it just broke X completely. i think having one might override some default xsession file/
<brendyn>hmm, no i have installed arc-theme but it doesn't appear in lxappearance
<htgoebel>Is there a way to quickly uninstall a package (from current-system) without running reconfigure? And then reinstall it if necessary?
<wingo>ACTION does not know
<Guest83299>htgoebel: haven't actually done this before, but this might do the trick: `sudo guix package --profile=/run/current-system/profile --remove [package]`
<Guest83299>or maybe it's part of the read-only filesystem.. not sure
<Guest83299>nah, just tried myself, that's no good
<htgoebel>Guest83299: Would be worth a try. Sadly the installed guix is not the one which created the system (vm-image) and thus guix tries to install a log of other stuff :-(
<civodul>cbaines: i wonder if the switch from unionfs to overlayfs by htgoebel improves performance for you?
<davexunit>morning folks. someone from the fsf sent me an email yesterday wondering if I wanted to submit a proposal for a talk at libreplanet 2018. I may submit a proposal for a general guix project update.
<rekado>davexunit: neat!
<janneke>how do i convert an input, e.g. like: ("gcc-lib" #<package gcc@5.4.0 gnu/packages/gcc.scm:374 22f89c0> "lib") to a directory?
<janneke>this works... but (string-append (with-store store (package-output store (cadr input))) "-" (caddr input))
<janneke>ah..but is incorrect..hmm
<rekado>janneke: in a gexp this happens automatically
<janneke>automatically? hmm
<rekado>well, with ungexp
<rekado>are you in a context where gexps could be used?
<rekado>or maybe I’m just confusing you.
<janneke>i think so; i'm writing a test and outside i do (map cadr (package-direct-inputs package)) and inside the test/gexp i use that list ... but i already stripped the output bit here
<rekado>in build phases you can just do (assoc-ref inputs "foo") and use that as a directory
<janneke>yes...
<rekado>do you need to strip the output part?
<janneke>no, i want the output part considered, added
<janneke>i just found that i strip it with cadr, now i'm looking how i could not do that stripping
<janneke>i tried using the list (<package> "output") in the gexp but can't get it to work yet
<rekado>in some packages we use match to get all directories of all inputs
<rekado>but if you’re in a gexp anyway, couldn’t you just ungexp the packages?
<janneke>hmm, this question possibly already helps, let me see :-)
<janneke>ACTION goes to repl
<rekado>#~(begin #$emacs)
<rekado>as the gexp is compiled #$emacs is replaced with the store path for the emacs package.
<janneke>yeah thanks...that works for my gcc-lib output: (#<package gcc@5.4.0 gnu/packages/gcc.scm:374 22f89c0> "lib") automatically, indeed. tnx!!
<efraim>i checked r-rhdf5, not sure why lambda* isn't enough to keep it from racing
<DusXMT>I wonder, how does one specify that the configure script of a package ins't in the souce tree's root directory?
<rekado>DusXMT: you can add a phase before the configure phase to change the directory
<DusXMT>rekado: Thanks :)
<vagrantc>so, i seem to have issues with guixsd when i type halt or reboot ... it just seems to hang...
<vagrantc>how do i properly shut down or reboot a guixsd system?
<quigonjinn>vagrantc: using loginctl
<efraim>Not Brut
<efraim>Not just 'sudo shutdown'?
<benny>how would I fix this: happens as root or user: https://paste.debian.net/994900/
<benny>vagrantc: I had that as well and then after a guix pull + reconfigure later it worked properly
<DusXMT>I wonder, is there a way to add folders within the profile to the include path of a package to be built? Long story short, package assumes that headers that are in a subdirectory on GNU/Linux are available directly
<bavier>DusXMT: sometimes we fix that by adding CPPFLAGS
<DusXMT>Mmmm... cmake seems to not to care about that env. var... perhaps it can be made to care about it...
<bavier>oh, cmake...
<bavier>DusXMT: -DCMAKE_C_COMPILER_FLAGS=...
<DusXMT>Thanks :)
<lfam>How can I use `guix build --expression` with the modules I have in GUIX_PACKAGE_PATH?
<lfam>I tried something like guix build -e '(@@ (leo packages mixxx) mixxx)', but the variable is unbound in that context
<vagrantc>so, packages installed as part of "guix system reconfigure foo.scm" are installed globally?
<vagrantc>ACTION is still struggling a bit conceptually with global vs. user-installed packages
<benny>what helped me understand is just looking at $PATH
<benny>current-system vs. .guix-profile
<lfam>vagrantc: The packages listed in the packages field of foo.scm, as well as the packages required for the services field of foo.scm, are available globally.
<vagrantc>i mean, i understand that packages *can* be installed by individual users vs. system-wide ... but i'm more trying to wrap my head around the idea of when to install where
<janneke>vagrantc: we try to keep global packages to a minimum, required for the system to boot
<janneke>users are encouraged to shadow most of those with versions they like
<lfam>As benny says, the profiles that correspond to this are in /run/current-system. There is also /run/booted-system, which could be different if you've reconfigured since boot
<vagrantc>the whole idea that different users *typically* have entirely different package sets is a bit hard for me to wrap my head around :)
<lfam>We can help you stretch your head around it ;)
<janneke>vagrantc: that's what i always had in ~/pkg/{bin,lib,var} ... you too i guess?
<benny>best way to fix this: guix pull doesn't work as root or 2nd test user: https://paste.debian.net/994900/
<vagrantc>janneke: i've mostly never had any user-specific packages
<janneke>only now it's with system support ;-)
<benny>sorry that was supposed to be a question
<lfam>benny: The paste is "not found"
<janneke>vagrantc: ah...as a [lilypond] developer i very often needed newer packages than available in system
<benny>oops: https://paste.debian.net/994913/
<vagrantc>ACTION generally used chroots for development
<janneke>and then newer auto*, libtool, etc
<janneke>vagrantc: and how did you get dependencies installed in your chroots?
<vagrantc>these days, i mostly use single-user systems, so it's kind of moot in many cases
<vagrantc>janneke: well, i mostly built debian packages using package-building tools (e.g. sbuild) which handle dependency resolution... and then use chroots or VMs to test built packages
<vagrantc>with guixsd, i'd almost see doing some of that with throwaway users or something
<janneke>vagrantc: that's a nice solution
<lfam>benny: Hm, I'm not sure what's up :/ What kind of installation is this? GuixSD or another distro? Is the guix-daemon definitely running?
<benny>lfam: it's a modified (reconfigured a few times) guix 0.13 vm
<benny>guixsd
<janneke>vagrantc: you can use throwaway environments (with or without container) or named profiles
<janneke>less need for throwaway users
<vagrantc>janneke: not surprising that such a thing exists ... seems well adapted to transient environments of some form or another
<lfam>benny: Is this `guix pull` on behalf of root or an unprivileged user? I'm wondering if there is some API incompatibility between the running guix-daemon (controlled by root at the system level) and whoever is running `guix pull`
<vagrantc>so, individual users have individual versions of "guix" installed?
<janneke>yes
<benny>lfam: ahhhh good point, I've read in some readme (not official I think) to use guix system build config.scm as user and then sudo -E guix system reconfigure config.scm
<janneke>that is, possibly/probably, not necessarily
<vagrantc>ACTION listens to the gears turning
<benny>so this incompatibility could be from there
<benny>I have 3 accounts: the one I mainly use that can still guix pull, the test user (empty $HOME) that can't and root that also can't use pull
<lfam>benny: Hm... I have to recommend against using `sudo -E` unless you are trying to pass the unprivileged user's environment to root on purpose
<lfam>benny: `sudo --login` is usually what one wants when temporarily escalating privileges, in my experience
<vagrantc>it surely is a different way of things that takes some getting used to, but it's perhaps the most interesting distro i've seen in a long time
<benny>that was on purpose because I wanted to include my own packages that I have under ~/pkgs/bla/bla
<lfam>I see
<lfam>But you don't need those packages for `guix pull`, right? And `guix pull` is the problem here?
<janneke>vagrantc: very happy to see you here
<benny>yeah guix pull was just done to update, I wanted to reconfigure based on the newest guix pull because I want to reproduce an error in a new user account for a bug report
<benny>(my config.scm before this only include a single account)
<benny>the bug is unrelated, fwiw
<benny>but if I have different guix then I don't understand this because
<benny>which guix for both root and my user account that still works are one and the same
<benny>including md5sum
<janneke>ACTION created hacks for rpm and later deb to create relocatable, user-installable packages
<janneke>never dared to be so bold as guix ;-)
<benny>this is too weird
<benny>as user: /gnu/store/qzw8q4mbk5dymmkffi6k13jphzm1mhmd-guix-0.13.0-8.357ab93/bin/guix --version
<benny>guix (GNU Guix) 0af94ad52f65a5a62febd203e431f17642f07577
<benny>as root: /gnu/store/qzw8q4mbk5dymmkffi6k13jphzm1mhmd-guix-0.13.0-8.357ab93/bin/guix --version
<benny>guix (GNU Guix) 20171101.03
<benny>and the root one fails to guix pull as in the paste above
<benny>ahh! there is ~/.config/guix/latest
<benny>which doesn't help if you set it on root to the one working from $USER
<benny>the version is now the same but pull still fails
<DusXMT>Hmmm... I'm having problems with guix package and guix environment not wanting to work if I have .config/guix/latest linked to a git tree: https://dpaste.de/2pf1 --- The error persists even if I restore the tree to a default state
<DusXMT>(guix build works though)
<vagrantc>anyone have any experience with caching proxies for guix packages? some package builds seem to re-download a lot of the same build dependencies
<vagrantc>or maybe i'm running "guix gc" too much
<efraim>vagrantc: you can also run 'guix gc -F 25G' to free up space until you have 25 GB free on the partition with /gnu/store
<DusXMT>'s'been a while since I've last submitted a package for guix, hope I didn't mess it up :) https://debbugs.gnu.org/cgi/bugreport.cgi?bug=29234
<vagrantc>efraim: my first install is only on a 4GB partition ... clearly i'll need to allocate more space to use it for real :)
<vagrantc>ACTION ♥ debbugs
<lfam>efraim: I see you've done CMake updates in the past. Did you find the test suite to be flaky? Some tests seem to be failing nondeterministically
<efraim>I remember something about libarchive being a PITA
<efraim>But its been a while
<efraim>well i am jealous of the armhf kernel
<bavier>jealous?
<lfam>I bet efraim wants an aarch64 kernel ;)
<bavier>oh oh, sure :)
<efraim>i have a 4.12 that i was working with, but I never actually booted anything with it
<bavier>ACTION feeling a bit slow today
<efraim>is Mathieu on irc?
<efraim>%intel-compatible-systems is now undefined
<lfam>efraim: Should we just change the remaining %intel-compatible-systems to %linux-compatible-systems?
<lfam>Or revert?
<efraim>they would need to have an arm kernel config
<efraim>I just added %intel-compat back for the moment
<lfam>Okay
<vagrantc>is there a way to search for whick packages contain a specific file?
<lfam>vagrantc: No, we don't have a registry of files created by packages
<vagrantc>curious if "lesspipe" is available. in debian it's shipped with "less"
<lfam>Our less package doesn't include it
<lfam>Seems like a 3rd party software based on my web search
<efraim>apt-file search lesspipe shows debian builds it from less
<benny>anyone an idea regarding the guix pull issue I have? https://paste.debian.net/994913/
<civodul>benny: that seems to be a new bug in guile-git :-/
<civodul>could you email bug-guix@gnu.org
<civodul>?
<civodul>please provide the guile-git version
<benny>civodul: I don't have the issue with another user account using the same guix version
<civodul>maybe because that other user account already has a clone under ~/.cache/guix/pull/
<civodul>as a workaround, you could create the initial clone manually with git
<benny>civodul: you are right, I moved the clone from cache and then it also stopped working for the user it previously worked for
<civodul>yeah, i see where the bug is
<benny>should I send a bug mail?
<civodul>yes please
<benny>just this moment I had an error with my mail, I think it went through
<benny>got the acknowledgement