IRC channel logs

2017-08-19.log

back to list of logs

<cbaines>wingo, I've just created a bug for the info-dir issue, as I've had that problem a few times https://debbugs.gnu.org/cgi/bugreport.cgi?bug=28144
<Gamayun>Just wondering, as I am travelling with my GuixSD laptop at the moment, is there a way to set the time-zone temporarily or per profile? Or is there no other place but the OS definition?
***ShalokShalom_ is now known as ShalokShalom
<ng0>Gamayun: do you just need the time for yourself as a clock?
<ng0>in the case for just a clock you could write script, like https://gitweb.krosos.org/scripts.git/tree/dash/world_time.sh
<cbaines>Is there a way to have guix system reconfigure take effect on services, without rebooting?
<rekado>cbaines: you need to stop the service, then reconfigure
<rekado>this works for most services
<cbaines>great, I'll try that
<ng0>yesterday I found this.. it's a cute toy project showing that the general idea and importance of aiming for exact and comparable builds hasn't reached everyones attention yet. https://notabug.org/akkartik/basic-build
<ng0>maybe this changes now that Debian has made the mandatory reproducible build policy, debian being very big in use and all..
<ng0>Wouldn't it be better if we would move all the XXXs, FIXMEs and TODOs to bug tracker issues?
<ng0>this is not completely accurate, but we have 647 XXXs, 397 FIXMEs, and 336 TODOs in the code.
<cbaines>Why do you think it might be better?
<ng0>the tracker can be searched, in the text files it is just "noise" in the code, you will only see it once you search for it. With the tracker you know directly which package has open tasks without searching explicitly for the kind of open task and directory
<ng0>sometimes the notes are okay, as they are right in place, but you get no central place for information
<ng0>no, they are always okay the problem is just that you don't know what exists.
<ng0>the blackboard for jobs is missing
<ng0>does someone of you keep their Shepherd user-services, for shepherd running on non-GuixSD systems, online somewhere? I need a practical set of examples to see how exactly they differ.
<ng0>I have a rather stupid question about the guix system disk-image command. I have read most of the code around it. We do not auto-compile the gnu/system/install.scm module, we just use it as an argument. So far I just assumed this only works when you are in the root of the git checkout out the guix source. I think I still don't understand the full PATH perspective. Will it work when I move elsewhere? Do I have
<ng0>to have the git checkoutout or is the location of the file in some environment variable and we could move whereever and it'd still be functional? Any further modules I should read to unerstand it?
<pmikkelsen>hi guix
<ng0>For a guix package definition I have which is using git: is there an easy way to have (dirname (current-filename)) point to ../../.. ? Whe I use (define %source-dir (dirname "../../../README")) I get an illegal filename message when I try to build, while in the repl I get returned "../../.."
<ng0>I have to instruct the source that 1. the source is at ../../.. so that not just the cwd is copied to the build machine, and 2. that the build happens at ../../..
<cbaines>ng0, try using the canonicalize-path function, in place of dirname
<ng0>I could chdir and then getcwd.. maybe that helps
<ng0>hm
<ng0>okay
<ng0>which srfi provides that?
<ng0>(should bookmark the search for that)
<ng0>ice-9?
<cbaines>I don't know, I think I remember not even being able to find documentation on it
<cbaines>it just works if you launch Guile though, so I think it's always available
<ng0>ok
<ng0>now I have different errors
<ng0>it worked though
<cbaines>great :)
<ng0>this copying is taking much longer now.. I think I got it
<ng0>not a file but just "../../.."
<cbaines>do you know about the git-predicate function?
<ng0>yep.. as I should've guessed, -path is for paths
<ng0>I moved a file around, that's why I asked
<ng0>I'm not sure if nix has something similar, but the person maintaining the nix files will adjust it
<rekado>it’s unfortunate, that the cuirass service cannot be reloaded without a reboot
<rekado>I stopped the service, changed the cuirass package, reconfigured, started the service … and it’s not using the latest version.
<rekado>only after reboot
<rekado>and “guix pack” is very slow.
<rekado>I’m currently trying to build a docker image for a pipeline we’ve developed at the institute and waiting for “guix pack” is boring :)
<janneke>rekado_: we've a hybrid release with ubuntu+guix pack and i'm very happy we were able to switch to ubuntu+guix package -i
<janneke>*we've done
<janneke>guix pack was an amazing help to take the first step towards that
<rekado_>I’m adding the “none” compressor now. This speeds up docker image generation by several minutes.
<efraim>looks like freeimage is the culprit for armhf and aarch64 build failures of dependants, it bundles tons of stuff
<dadinn>hi all
<dadinn>quick question: why is it that sh is not available in the normal root-profile? I am usind GuixSD 0.13.0
<dadinn>using
<dadinn>it is a bit annoying, as i am trying to run some scripts I wrote with "#! /bin/sh" for portability purposes, and it doesn't work unless I manually symlink stuff
<buenouanq>dadinn: are you suing to root? you have to su - or su --login
<rekado_>dadinn: that’s by design, but you can change this if you want to.
<rekado_>dadinn: search the manual for “special-files-service-type”
<rekado_>dadinn: that’s how you can create a system-wide /bin/sh link.
<dadinn>rekado_: but sh is something quite basic expectation on a unix system, is it not included to keep the base image small?
<dadinn>rekado_: I have just booted in to the raw usb image, by default I am root@gnu
<rekado_>dadinn: it’s nothing to do with size.
<rekado_>dadinn: this is also about reproducibility
<rekado_>but it’s trivial to change this by using a special-files-service
<rekado_>it’s just not the default.
<rekado_>dadinn: yes, you are root when booting the usb image. Is this a problem?
<dadinn>rekado_: no root is not a problem, you were just asking if i am suing to be root
<rekado_>no, I did not. buenouanq did.
<buenouanq>sorry, I misunderstood